Polaris

Polaris Database Repository (Version 7.0)

This help file provides information about databases used in Polaris. It provides detailed information for the tables in all of the databases used in the Polaris application. All foreign key columns in a table are presented as hyperlinks to their referenced table. The SeeAlso section for each table displays links to all referencing tables. (9502)

© 1997-2021 Innovative Interfaces, Inc. All rights reserved.


ACQExchangeDataDefinition

Polaris Database

ACQExchangeDataDefinition Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
DataMemberID | int | Reserved. For Internal Use Only
DataTypeID | int | Reserved. For Internal Use Only
ACQExchangeDataTableID | int | Reserved. For Internal Use Only
BaseColumnName | nvarchar(4000) | Reserved. For Internal Use Only
TypeOrdinal | int | Reserved. For Internal Use Only
ParsedDataOrdinal | int | Reserved. For Internal Use Only
IsAggregate | int | Reserved. For Internal Use Only

See Also

ACQExchangeXMLDefinition,

© 1997-2020 Innovative Interfaces, Incorporated. All rights reserved.


ACQExchangeDataTableDefinition

ACQExchangeDataTableDefinition Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ACQExchangeDataTableID | int | Reserved. For internal use only.
TableName | nvarchar(4000) | Reserved. For internal use only.
TableAlias | nvarchar(80) | Reserved. For internal use only.

See Also

ACQExchangeDataDefinition,


ACQExchangeDataTypes

ACQExchangeDataTypes Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
DataTypeID | int | Reserved. For internal use only.
Description | nvarchar(80) | Reserved. For internal use only.

See Also

ACQExchangeDataDefinition,


ACQExchangeFileInformation

ACQExchangeFileInformation Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ACQExchangeFileID | int | Reserved. For internal use only.
AcqExchangeFileName | nvarchar(4000) | Reserved. For internal use only.
XMLDocumentTypeID | int | Reserved. For internal use only.
DispositionID | int | Reserved. For internal use only.
ProcessDate | datetime | Reserved. For internal use only.

See Also

ACQExchangePLRETCKSLog, ACQExchangePLRETPOSLog,


ACQExchangeMultipleLineEntities

ACQExchangeMultipleLineEntities Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
XMLDocumentTypeID | int | Reserved. For internal use only.
NameChar | nvarchar(4000) | Reserved. For internal use only.
KeyColumn | nvarchar(4000) | Reserved. For internal use only.


ACQExchangeOutgoingDataLog

ACQExchangeOutgoingDataLog Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
DataLogID | int | Reserved. For internal use only.
XMLDocumentTypeID | int | Reserved. For internal use only.
DispositionID | int | Reserved. For internal use only.
ProcessDate | datetime | Reserved. For internal use only.
PurchaseOrderID | int | Reserved. For internal use only.
InvoiceID | int | Reserved. For internal use only.
FundID | int | Reserved. For internal use only.
SupplierID | int | Reserved. For internal use only.
ACQExchangeFileID | int | Reserved. For internal use only.


ACQExchangePLRETCKSLog

ACQExchangePLRETCKSLog Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ACQExchangeFileID | int | Reserved. For internal use only.
NodeID | int | Reserved. For internal use only.
DCD | nvarchar(4000) | Reserved. For internal use only.
DDPT | nvarchar(4000) | Reserved. For internal use only.
DID | nvarchar(4000) | Reserved. For internal use only.
CHKNUM | nvarchar(4000) | Reserved. For internal use only.
CHKAMT | nvarchar(4000) | Reserved. For internal use only.
CHKDT | nvarchar(4000) | Reserved. For internal use only.
ICD | nvarchar(4000) | Reserved. For internal use only.
IDPT | nvarchar(4000) | Reserved. For internal use only.
IID | nvarchar(4000) | Reserved. For internal use only.
INVDT | nvarchar(4000) | Reserved. For internal use only.
INV | nvarchar(4000) | Reserved. For internal use only.
VCOD | nvarchar(4000) | Reserved. For internal use only.
RCD | nvarchar(4000) | Reserved. For internal use only.
RDPT | nvarchar(4000) | Reserved. For internal use only.
RID | nvarchar(4000) | Reserved. For internal use only.
InvoiceID | int | Reserved. For internal use only.
InvNumber | nvarchar(30) | Reserved. For internal use only.
InvNumberSuf | nvarchar(8) | Reserved. For internal use only.
ProcessDate | datetime | Reserved. For internal use only.


ACQExchangePLRETPOSLog

ACQExchangePLRETPOSLog Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ACQExchangeFileID | int | Reserved. For internal use only.
NodeID | int | Reserved. For internal use only.
DCD | nvarchar(4000) | Reserved. For internal use only.
DDPT | nvarchar(4000) | Reserved. For internal use only.
DID | nvarchar(4000) | Reserved. For internal use only.
RUNDT | nvarchar(4000) | Reserved. For internal use only.
DOCTOT | nvarchar(4000) | Reserved. For internal use only.
RCD | nvarchar(4000) | Reserved. For internal use only.
RDPT | nvarchar(4000) | Reserved. For internal use only.
RID | nvarchar(4000) | Reserved. For internal use only.
ProcessDate | datetime | Reserved. For internal use only.
PurchaseOrderID | int | Reserved. For internal use only.
PONumber | nvarchar(30) | Reserved. For internal use only.
PONumberSuf | nvarchar(8) | Reserved. For internal use only.


ACQExchangeSettings

ACQExchangeSettings Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
PLRETPOSPickupLocation | nvarchar(4000) | Reserved. For internal use only.
PLRETCKSPickupLocation | nvarchar(4000) | Reserved. For internal use only.
DropOffLocation | nvarchar(4000) | Reserved. For internal use only.
OutgoingFilePrefix | nvarchar(4000) | Reserved. For internal use only.


ACQExchangeXMLDefinition

ACQExchangeXMLDefinition Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
XmlDefinitionID | int | Reserved. For internal use only.
XMLDocumentTypeID | int | Reserved. For internal use only.
XMLTypeID | int | Reserved. For internal use only.
ParentNodeID | int | Reserved. For internal use only.
NameChar | nvarchar(4000) | Reserved. For internal use only.
IsForced | bit | Reserved. For internal use only.
ForcedData | nvarchar(4000) | Reserved. For internal use only.
DataMemberID | int | Reserved. For internal use only.
IsUsed | bit | Reserved. For internal use only.


ACQExchangeXMLDocumentTypes

ACQExchangeXMLDocumentTypes Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
XMLDocumentTypeID | int | Reserved. For internal use only.
Description | nvarchar(80) | Reserved. For internal use only.

See Also

ACQExchangeFileInformation, ACQExchangeMultipleLineEntities, ACQExchangeOutgoingDataLog, ACQExchangeXMLDefinition,


ACQExchangeXMLTypes

ACQExchangeXMLTypes Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
XMLTypeID | int | Reserved. For internal use only.
Description | nvarchar(80) | Reserved. For internal use only.

See Also

ACQExchangeXMLDefinition,


ACQEXCHXMLData

ACQEXCHXMLData Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
DocOrdID | int | Reserved. For internal use only.
XmlOrd | int | Reserved. For internal use only.
DataChr | nvarchar(-1) | Reserved. For internal use only.
Typ | int | Reserved. For internal use only.
PurchaseOrderID | int | Reserved. For internal use only.
POLineItemID | int | Reserved. For internal use only.


AcqPurgeRecordDetails

AcqPurgeRecordDetails Table

Stores the data used when running Purge Acquisitions Records job is run.

Columns

Column name | Data type | Description
OrgID | int | INT. FK, Organizations.OrganizationID. The Organization that linked to the purge record details
UserID | int | INT. FK. PolarisUsers.PolarisUserID PolarisUserID that created or last modified the purge record for the given OrgID.
LastRunDate | datetime | DATETIME. Last time the job was run for the organization.
ScheduledDate | datetime | DATETIME. The date the purge for the given OrgID is set to run.
ScheduleEnabled | bit | BIT. When 1 the purge job will use this record when it is run.
PurgeBeforeDate | datetime | DATETIME. The date prior to which records will be purged
PurgeEnabled | bit | BIT. When 1 the purge is enabled for the given OrgID
FollowSystem | bit | BIT. When 1 the organization's purge settings are controlled at the system level. When 0 the organization's purge settings are independent.


AcqSupplierURLs

AcqSupplierURLs Table

This table holds urls to supplier databases which are accessible from the tech client toolbar.

Columns

Column name | Data type | Description
AcqSupplierURLsID | int | Unique Identifier, primary key
SupplierName | nvarchar(50) | The name of the supplier.
SupplierURL | nvarchar(255) | The url of the supplier (web site).


Addresses

Addresses Table

This table contains all addresses that can be stored in Polaris, including patron addresses and supplier addresses.

Columns

Column name | Data type | Description
AddressID | int | Primary key unique identifier (IDENTITY)
PostalCodeID | int | FK to PostalCodes
StreetOne | nvarchar(64) | Street Address Line 1
StreetTwo | nvarchar(64) | Street Address Line 2
ZipPlusFour | nvarchar(4) | Zip plus four data to be appended to the postal code from the related PostalCodes table entry
MunicipalityName | nvarchar(64) | Municipality Name this address resides in. (Populated via address verification function)
StreetThree | nvarchar(64) | Street 3

See Also

ChangeAddress, Donors, MailingLabelRecordSets, PatronAddresses, Suppliers,


AddressLabels

AddressLabels Table

Contains one row for each address label

Columns

Column name | Data type | Description
AddressLabelID | int | Unique identifier
Description | nvarchar(255) | Text description of the address label
Display | bit | Boolean indicating if the label is always visible
DisplayOrder | int | Display order for Address Labels

See Also

PatronAddresses,


AddressTypes

AddressTypes Table

This table is a coded value table which holds all the different types (how they are used) of addresses.

Columns

Column name | Data type | Description
AddressTypeID | int | Primary key
Description | nvarchar(80) | Address type

See Also

PatronAddresses,


AdminAttributeClasses

AdminAttributeClasses Table

This table contains string descriptions of the various types of SysAdmin attributes. The strings are used to build window title bar captions for attribute property page dialog windows.

Columns

Column name | Data type | Description
AttrClassID | int | Class unique ID - Identity column
AttrClassDesc | nvarchar(20) | String description of an attribute. ('Profile', 'Privilege', ..., etc.)

See Also

AdminAttributes,


AdminAttributes

AdminAttributes Table

This table contains information that defines what the values represent within the OrganizationsPPPP, ServersPPPP, WorkstationsPPPP, UsersPPPP, CollectionsPPPP, and PatronsPPPP tables by associating the AttrID.

Columns

Column name | Data type | Description
AttrID | int | Primary key of the table
AttrTypeID | int | Data type of the value. Foreign Key reference to the AdminAttributeTypes table.
AttrDesc | nvarchar(80) | Describes what the value is used for within Polaris
ControlFlags | int | Bit encoded control flag that defines which domains the value is valid in: bit 0 - System, bit 1 - Library, bit 2 - Branch, bit 3 - Collection, bit 4 - Workstation, bit 5 - User, bit 6 - Patron, bit 7 - Database, bit 8 - Server
Mnemonic | nvarchar(30) | Mnemonic assigned to the attribute. The Polaris application defines enumerated constants in the name of the mnemonic. The mnemonic contains the value of the AttrID primary key. A manual effort is required to add mnemonic declarations to the Polaris code to enable the use of a new attribute.
MaxLength | int | Used in conjunction with AttrType of 1 or 3 to define max string length of max value
DefaultValue | nvarchar(255) | Contains the Polaris default value for the associated admin attribute. If no value is found in the associated PPPP table, the default value is returned to the requester. This attribute can contain NULLs. A NULL default value is used where it does not make sense to have a default value, such as for attributes that contain a database ID.
DatabaseInfo | nvarchar(255) | Holds schema information for AttrTypeID=5
AttrClassID | int | Attribute class ID, points to the AdminAttributeClasses table

See Also

AdminGroup, AdminLanguageStrings, CollectionsPPPP, OrganizationsPPPP, PatronsPPPP, SA_COMMUNITY_SearchDashboardDisplay, SA_PAC_SearchDashboardDisplay, ServersPPPP, UsersPPPP, VendorAccountsPPPP, WorkstationsPPPP,


AdminAttributeTypes

AdminAttributeTypes Table

This table defines the data type of the value associated with AdminAttributes.

Columns

Column name | Data type | Description
AttrTypeID | int | Primary key
AttrTypeDesc | nvarchar(20) | Describes the data type of the value associated with AdminAttributes

See Also

AdminAttributes,


AdminCategories

AdminCategories Table

This table is a lookup table for the System Administration explorer. It holds the domain and section descriptions for the PPPPs.

Columns

Column name | Data type | Description
AdminCategoryID | int | Primary key
AdminCatName | nvarchar(40) | Name of category
DomainID | int | Domain in which the category is active

See Also

AdminGroup,


AdminForeignFields

AdminForeignFields Table

Describes how to display in SA UI columns that contains only IDs while actual descriptions are in the special tables.

Columns

Column name | Data type | Description
ForeignFieldID | int | Primary key referenced in the AdminTableFields table.
TableName | nvarchar(50) | Name of the description table.
ColumnKey | nvarchar(50) | Name of the column that contains IDs referenced in the displayed table.
ColumnResult | nvarchar(50) | Name of the column that contains description to be displayed.
FieldType | nvarchar(10) | Type of column.
FieldSize | int | Value size for column types like char of varchar.
FieldProp | nvarchar(10) | Whether the value is required or nullable.

See Also

AdminTableFields,


AdminGroup

AdminGroup Table

This table holds the data that defines which AdminAttributes display in each AdminCategory.

Columns

Column name | Data type | Description
AttrID | int | Reference to AdminAttributes
AdminCategoryID | int | Reference to AdminCategories
DisplayOrder | smallint | Currently unused


AdminLanguages

AdminLanguages Table

This table holds all of the languages that the customer subscribes to with respect to multi-language capabilities in the PowerPAC. This table will contain at least one row to represent the 'English' language.

Columns

Column name | Data type | Description
AdminLanguageID | int | Unique identifier. Maps to the language code id in the syslanguages table on the master database. (1033 is the code for 'English')
Description | nvarchar(255) | Language label in its own language (eg. 'English', 'Español', ..., etc)
FileName | nvarchar(255) | Associated translation file name.
EnabledPowerPAC | bit | States whether this language will be enabled for the PowerPAC
EnabledCPAC | bit | States whether this language will be enabled for the CPAC
EnabledExpressCheck | bit | States whether this language will be enabled for the Polaris ExpressCheck system
EnabledPhoneAttendant | bit | States whether this language will be enabled for Inbound Telephony
EnabledOutboundTelephony | bit | States whether this language will be enabled for Outbound Telephony
EnglishDescription | nvarchar(80) | Language label in English (eg. 'English', 'Spanish', ..., etc)
BitValue | int | Bit value defined for each languages is used to encode language selections by different products.
IsoCode | nvarchar(10) | Code for the Representation of Names of Languages

See Also

AdminLanguageStrings, MultiLingualStrings, PromotionLanguageIndex, SA_CustomMultiLingualStrings, SA_DefaultMultiLingualStrings, SA_PatronMessageLanguageStrings, SA_Telephony_Outbound_SAPI_Settings,


AdminLanguageStrings

AdminLanguageStrings Table

This table holds the 'Language String' values of all mutli-lingual sysadmin attributes. For each language and organization a separate string value can be expressed.

Columns

Column name | Data type | Description
AdminAttrID | int | Foreign key link to AdminAttributes (part of primary key) Represents the sysadmin attribute of a 'Language String' attribute.
OrganizationID | int | Foreign key to Organizations (part of primary key) The organizational context.
AdminLanguageID | int | Foreign key to AdminLanguages (part of primary key) This is the language context.
Value | nvarchar(500) | An nvarchar column that can store Unicode strings. This represents the actual language value of the attribute described by the AdminAttrID for the given language (AdminLanguageID) for the given organizational context (OrganizationID).


AdminLog

AdminLog Table

This table logs system administration transactions.

Columns

Column name | Data type | Description
AttrID | int | References AdminAttributes
DomainTypeID | int | Type of domain. References Domains.
DomainID | int | Domain in which transaction is done
ModifierID | int | References PolarisUsers table
Date | datetime | Date of transaction
Value | nvarchar(255) | New value
WorkstationID | int | Foreign Key reference to Workstations table.


AdminTableFields

AdminTableFields Table

Describes fields of the tabels that can be displayed modified via SA UI.

Columns

Column name | Data type | Description
TableID | int | Reference to the AdminTables table.
ColumnNumber | int | Column number in display order.
PrimaryKeyFlag | bit | Whether the column is a primary key.
IdentityFlag | bit | Whether it's an identity column.
DuplicableFlag | bit | Whether column can contain duplicate values.
ForeignFieldID | int | Reference to the AdminForeingFields table for columns that display values defined in special tables.
ColumnHeading | nvarchar(50) | Display name for the column.
TableName | nvarchar(50) | Name of the table. Kind of redundant column since it simply duplicates the same column in the AdminTables table. However, if the displayed table is actually a combination of thables that can be achieved by specifying of custom SELECT command, this column will be used to describe the origin of the displayed data.
ColumnName | nvarchar(50) | Database column name
FieldType | nvarchar(10) | Type of column.
FieldSize | int | Size of value for column types like char or varchar.
FieldProp | nvarchar(10) | Whether user is required to specify a value.
DuplicableFlag2 | bit | Defines a secondary set of columns that will also define a duplicate table row


AdminTables

AdminTables Table

Describes all tables that can be displayed/modified via SA UI.

Columns

Column name | Data type | Description
TableID | int | Primary key.
TableName | nvarchar(50) | Well, that's just it - table name.
SequencedFlag | bit | Whether records are sequenced in a particular order.
InsertableFlag | bit | Whethter new records can be added to the table
ModifiableFlag | bit | Whether existing records can be modified
DeletableFlag | bit | Whether records can be deleted from the table
QueryCommand | nvarchar(255) | SELECT comand to query the table if it's not a standard SELECT * connamd.

See Also

AdminTableFields, SA_DatabaseTableTriggerAftermath,


ApiConsumerServicePullSynchronizationLog

ApiConsumerServicePullSynchronizationLog Table

This table is used to log activity by the API consumer service as it relates to pull synchronization

Columns

Column name | Data type | Description
ApiConsumerServiceSynchronizationLogID | int | A unique identifier
VendorAccountID | int | The vendor account being synchronized
VendorObjectIdentifier | nvarchar(4000) | The object identifier of the title in the vendors repository
ResourceEntityID | int | The Resource entity being tested
BibliographicRecordID | int | the Polaris bibliographic record ID
TotalVendorItems | int | The number of total items reported by the vendors API
AvailableVendorItems | int | The total number of available items being reported by the vendors API
VendorHolds | int | The number of holds as reported by the vendors API
TotalPolarisItems | int | The total number of items associated with the resource entity with a record status of “1” (Final)
AvailablePolarisItems | int | the number of checked in items in Polaris
SynchronizationLogDate | datetime | the date and time that the “snapshot” was taken


Author4XX

Author4XX Table

This table provides a link between the Author Bib headings for See References.

Columns

Column name | Data type | Description
ID4xx | int | MainAuthorHeadingID value for the subject represented in a 4XX authority tag
ID1xx | int | MainAuthorHeadingID for the author associated with 1XX authority tag entry (the See heading)
AuthorityTagID | int | Link to Authority tag table
DisplayCode | char | Cross Reference Display Code referencing the field, CrossReferenceDisplayConstants.CrossReferenceCode


Author5XX

Author5XX Table

This table provides a link between the Author Bib headings for See Also References.

Columns

Column name | Data type | Description
ID5xx | int | MainAuthorHeadingID for the author associated with 5XX authority tag entry (the See Also heading)
ID1xx | int | MainAuthorHeadingID for the author associated with 1XX authority tag entry
AuthorityTagID | int | Link to Authority tag table
DisplayCode | char | Cross Reference Display Code referencing the field, CrossReferenceDisplayConstants.CrossReferenceCode


AuthorityBrowseSubfields

AuthorityBrowseSubfields Table

This table contains the list of all authority tags and subfields to be built into the authority record browse index.

Columns

Column name | Data type | Description
AuthorityBrowseSubfieldID | int | Primary key
AuthorityIndexKey | char | Index key which the tag/subfield is to be built into (such as HE, TR)
AuthorityIndexParamsTag | smallint | Foreign key reference
Subfield | char | Actual subfield to use


AuthorityConcordance

AuthorityConcordance Table

Contains one row for each distinct collocation composed of 1 to 8 keywords within an authority record

Columns

Column name | Data type | Description
CollocationID | int | Unique identifier for the row.
LexicalContextTuple | varbinary | Compressed tuple of keyword/delimiter pairs.


AuthorityConcordanceRadix

AuthorityConcordanceRadix Table

Contains one row for each distinct code point at a given prefix-position within the concordance.

Columns

Column name | Data type | Description
NexusID | int | Unique identifier for the row.
ParentNexusID | int | Unique identifier for the parent row.
EdgeTransition | nchar | Distinct code point at a given prefix-position within the concordance.
SemanticHintTuple | varbinary | Compressed tuple of collocation hints.


AuthorityControl

AuthorityControl Table

This table maps which bibliographic tags are subject to authority control, as well as which authority tags are used for each bib tag in the table.

Columns

Column name | Data type | Description
BibliographicTagNumber | smallint | Bibliographic tag number
AuthorityTagNumber | smallint | Authority record's tag number to be used
AuthorityControlTypeID | int | Foreign key to coded values table
AuthorizeOption | bit | User can turn this on or off for each bib tag

See Also

AuthorityControlIndicatorOne, AuthorityControlIndicatorTwo, AuthorityControlSubfields,


AuthorityControlHeadings

AuthorityControlHeadings Table

Table which holds every authority record heading for the purposes of authority control matching.

Columns

Column name | Data type | Description
AuthorityRecordID | int | Authority record ID
AuthorityTagID | int | Authority tag ID
Heading | nvarchar(255) | The normalized heading
HeadingSubs | nvarchar(255) | The normalized heading with integrated subfields and delimiters.
BrowseHeading | nvarchar(255) | The heading in a display format
BrowseHeadingSubs | nvarchar(255) | The heading in display format with subfields and delimiters included
TagNumber | smallint | heading tag number
IndicatorOne | char | First indicator value
IndicatorTwo | char | Second indicator value
SubfieldString | nvarchar(40) | Subfield delimiters concatinated
MARCKindOfRecord | char | tag 008/09 value
MARCCatalogingRules | char | tag 008/10 value
MARCSubjectHeadings | char | tag 008/11 value
MARCUseMainEntry | char | tag 008/14 value
MARCUseSubjectEntry | char | tag 008/15 value
MARCUseSeriesEntry | char | tag 008/16 value


AuthorityControlIndicatorOne

AuthorityControlIndicatorOne Table

Used in authority control processing for bib headings

Columns

Column name | Data type | Description
BibliographicTagNumber | smallint | Bib Tag number to subject to authority control
IndOneCharValue | char | When tag has first indicator of this value, subject it to authority control.


AuthorityControlIndicatorTwo

AuthorityControlIndicatorTwo Table

Used in authority control processing for bib headings

Columns

Column name | Data type | Description
BibliographicTagNumber | smallint | Bib Tag number to subject to authority control
IndTwoCharValue | char | When tag has second indicator of this value, subject it to authority control.


AuthorityControlSubfields

AuthorityControlSubfields Table

Used in authority control processing for bib headings

Columns

Column name | Data type | Description
BibliographicTagNumber | smallint | Bib Tag number to subject to authority control
SubfieldCharValue | char | When this subfield exists in the tag, subject the subfield to authority control.


AuthorityControlTypes

AuthorityControlTypes Table

This table is a coded value table for the different types of authority control (name, subject, series).

Columns

Column name | Data type | Description
AuthorityControlTypeID | int | Will be an enumerated type which stands for one of three values
AcName | nchar | Actual name (name, subject, series) text stored here

See Also

AuthorityControl, CommunityAuthorityControl,


AuthorityCreateLinkedBibRecordsRequestsHistoryTags

AuthorityCreateLinkedBibRecordsRequestsHistoryTags Table

Logging history for when bib/see also links are created for an authority record.

Columns

Column name | Data type | Description
LinkedRequestID | int | Link to the request history ID
BibliographicRecordID | int | Bib record ID
BibliographicTagID | int | Bib tag ID
Heading | nvarchar(1000) | The bib heading text
DescriptionOfWork | nvarchar(255) | what happened to this link? Was it created, or some error occured? That is logged here.


AuthorityCreateLinkedBibRecordsRequestsTags

AuthorityCreateLinkedBibRecordsRequestsTags Table

List of bib tags that the user has asked to link to the authority record.

Columns

Column name | Data type | Description
LinkedRequestID | int | Link to request main table
BibliographicRecordID | int | Bib record ID
BibliographicTagID | int | Bib tag ID


AuthorityCreateLinkedRecordsRequests

AuthorityCreateLinkedRecordsRequests Table

List of requests that users have submitted for the background job to run, to create new bib/see also links to the given authority record.

Columns

Column name | Data type | Description
LinkedRequestID | int | primary key
AuthorityRecordID | int | authority record which is getting new links.
RequestDate | datetime | date the request was made
UserID | int | user who submitted the request
WorkstationID | int | workstation that submitted request
BibHeadingCountToProcess | int | Number of bib headings it thinks it needs to update initially
SeeAlsoHeadingCountToProcess | int | Number of bib headings it thinks it needs to update initially
ProcessStage | bit | Says whether the job is still pending, in progress, or complete.
BuildRecordList | bit | Flag saying if we need to detect linked records when the job runs or can we use a pre-populated list (for importing vs. online).

See Also

AuthorityCreateLinkedBibRecordsRequestsTags, AuthorityCreateLinkedSeeAlsoRecordsRequestsTags,


AuthorityCreateLinkedRecordsRequestsHistory

AuthorityCreateLinkedRecordsRequestsHistory Table

Logging history for when bib/see also links are created for an authority record.

Columns

Column name | Data type | Description
LinkedRequestID | int | primary key from original requests table.
AuthorityRecordID | int | authority record ID for whom links were created.
RequestDate | datetime | date request was made.
UserID | int | user who submitted request
WorkstationID | int | workstation who submitted request
BibHeadingUpdatedCount | int | number of bib headings linked
SeeAlsoHeadingUpdatedCount | int | count of see also links created
BibHeadingDetectedCount | int | Number of bib headings it thinks it needs to update initially
SeeAlsoHeadingDetectedCount | int | Number of see also headings it thinks it needs to update initially
ProcessStage | bit | Says whether the job is still pending, in progress, or complete.

See Also

AuthorityCreateLinkedBibRecordsRequestsHistoryTags, AuthorityCreateLinkedSeeAlsoRecordsRequestsHistoryTags,


AuthorityCreateLinkedSeeAlsoRecordsRequestsHistoryTags

AuthorityCreateLinkedSeeAlsoRecordsRequestsHistoryTags Table

Logging history for when bib/see also links are created for an authority record.

Columns

Column name | Data type | Description
LinkedRequestID | int | Link to the request in the history table.
AuthorityRecordID | int | See also record ID.
AuthorityTagID | int | See also tag ID.
Heading | nvarchar(1000) | The textual heading.
DescriptionOfWork | nvarchar(255) | what happened to this link? Was it created, or some error occured? That is logged here.


AuthorityCreateLinkedSeeAlsoRecordsRequestsTags

AuthorityCreateLinkedSeeAlsoRecordsRequestsTags Table

The list of see also tags that the user has asked to link to the given authority record.

Columns

Column name | Data type | Description
LinkedRequestID | int | Link to the main request.
AuthorityRecordID | int | See also record ID
AuthorityTagID | int | See also tag ID.


AuthorityDeDup1XXIndex

AuthorityDeDup1XXIndex Table

Index which holds all of the 1xx tags for duplicate detection purposes.

Columns

Column name | Data type | Description
AuthorityRecordID | int | Authority record ID
AuthorityTagID | int | Authority Tag ID
TagNumber | int | 1xx tag number (100, 110, etc.)
Heading | nvarchar(255) | The normalized heading data


AuthorityDuplicateDetectionPrecedence

AuthorityDuplicateDetectionPrecedence Table

This table lists the precedence of the duplicate detection rules used in duplicate processing.

Columns

Column name | Data type | Description
AuthorityDupDetectRuleID | int | Foreign key - number associated with the rule itself.
ImportProfileID | int | System defaults to 1, but since profiles can have specific rule groupings, that is captured here.
DupDetectPrecedence | smallint | The precedence of this rule group
DisplayName | nvarchar(50) | The name used for displaying the rule in cataloging UI


AuthorityDuplicateDetectionRules

AuthorityDuplicateDetectionRules Table

This table lists the rules used for duplicate detection.

Columns

Column name | Data type | Description
AuthorityDupDetectRuleID | int | Primary key - number associated with the rule itself.
DuplicateDetectionRule | nvarchar(255) | Description of the rule
RuleDesc | nvarchar(100) | Authority Duplicate Detection Rule Description

See Also

AuthorityDuplicateDetectionPrecedence, ImportJobsAuthorityDuplicateDetectionRules,


AuthorityHeadingIndices

AuthorityHeadingIndices Table

This table is the index for authority control searching (used by bibs to find valid headings)

Columns

Column name | Data type | Description
AuthorityRecordID | int | Record id of authority heading
AuthorityTagID | int | Tag ID of authority heading
Heading | nvarchar(255) | Searchable version of heading (normalized)
TagNumber | smallint | Tag number which is crucial for bib-authority heading matching
BrowseHeading | nvarchar(255) | Listing of heading is list view display
MARCKindOfRecord | char | Corresponds to 008/09, which for purposes of this table is usually 'a'


AuthorityIndexDefinition

AuthorityIndexDefinition Table

This table contains coded values for the authority indexes used by Polaris.

Columns

Column name | Data type | Description
AuthorityIndexKey | char | Z39.50 character code
AuthorityIndexName | nvarchar(40) | The actual description of the code
IndexOrder | smallint | Specifies the order in which indexes are built (used for a newly loaded database)
Type | char | Coded value to specify using numerics, alphabetics, or both type of characters

See Also

AuthorityIndexParams,


AuthorityIndexParams

AuthorityIndexParams Table

This table contains a listing of tags that comprise the indexes built from authority records.

Columns

Column name | Data type | Description
AuthorityIndexKey | char | Z39.50 index coding
AuthorityIndexParamsTag | smallint | Tag number included in index
Precedence | smallint | Specifies which tags (by number) are built into the index first
HonorNonFiling | smallint | Relates to indicators and whether words like A, An, and The are included in indexes

See Also

AuthorityBrowseSubfields,


AuthorityInvalidMARCLCCNIndex

AuthorityInvalidMARCLCCNIndex Table

This index contains all of the 010 $z values found in authority records.

Columns

Column name | Data type | Description
AuthorityInvalidMARCLCCNIndexID | int | Primary key
AuthorityRecordID | int | authority record
AuthorityTagID | int | authority tag
InvalidMARCLCCN | nvarchar(40) | Invalid LCCN data


AuthorityKeywordIndex

AuthorityKeywordIndex Table

Contains one row for each keyword indexed in an authority record.

Columns

Column name | Data type | Description
KeywordID | int | Is the authority keyword identifier.
RecordID | int | Identifies the authority record from which a keyword has been indexed.
TypeFlags | smallint | Identifies one or more keyword types; based on the (MARC) data element from which the keyword was indexed.
TokenizedData | varbinary | Contains compressed binary data which includes the Significance, TypeFlags, ContractionCount, DelimiterClass, ChunkID and WordPosition for each occurrence of a keyword within a given record.


AuthorityKeywordRules

AuthorityKeywordRules Table

Contains one row for each authority keyword indexing rule. Each authority keyword indexing rule identifies a MARC data element to be indexed and is identified by a unique tag/subfield pair.

Columns

Column name | Data type | Description
TagNumber | smallint | Identifies the tag of a MARC data field to be indexed. This column combined with the Subfield column is unique for each row.
Subfield | char | Identifies the subfield of a MARC data element to be indexed. This column combined with the TagNumber column is unqiue for each row.
TypeFlags | smallint | Associates this rule with one or more authority keyword types. A keyword type is enabled if bit position POWER(2, TypeID - 1) is set to one, where TypeID must reference a row in the AuthorityKeywordTypes table.
MinimumSignificance | real | Contains the minimum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
MaximumSignificance | real | Contains the maximum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
AverageTermCount | real | Contains the average term count for a given data element associated with a specific TagNumber and Subfield.
AverageTermCountStandardDeviation | real | Contains the standard deviation of the AverageTermCount for a given data element associated with a specific TagNumber and Subfield.


AuthorityKeywords

AuthorityKeywords Table

Contains one row for each distinct keyword found in an authority record.

Columns

Column name | Data type | Description
KeywordID | int | Unique identifier for the row.
Term | nvarchar(128) | Normalized term suitable for keyword and phrase searching. This column is unique for each row.
Weight | real | The IDF (inverse document frequency) weight associated with the term. The weight equals log((N + 1) / n), where N = total number of records and n = number of records containing one or more occurrences of the keyword.

See Also

AuthorityKeywordIndex,


AuthorityKeywordScaleFactors

AuthorityKeywordScaleFactors Table

Contains one row for each authority keyword scale factor. Each scale factor is associated with a predefined keyword scale and contains a default signficance to be associated with a MARC data element.

Columns

Column name | Data type | Description
ScaleID | tinyint | Identifies a predefined authority keyword scale. This column combined with the TagNumber and Subfield column is unqiue for each row.
TagNumber | smallint | Identifies the tag of a MARC data field. This column combined with the ScaleID and Subfield column is unique for each row.
Subfield | char | Identifies the subfield of a MARC data element. This column combined with the ScaleID and TagNumber column is unqiue for each row.
MinimumSignificance | real | Contains the minimum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
MaximumSignificance | real | Contains the maximum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.


AuthorityKeywordScales

AuthorityKeywordScales Table

Contains one row for each authority keyword scale. Each keyword scale is associated with a set of predefined keyword scale factors.

Columns

Column name | Data type | Description
ScaleID | tinyint | Unique identifer for the row.
Name | nvarchar(100) | Unique name for the row.

See Also

AuthorityKeywordScaleFactors,


AuthorityKeywordTypes

AuthorityKeywordTypes Table

Contains one row for each authority keyword type. Each keyword type corresponds to a search access point and is associated with a subset of MARC data elments.

Columns

Column name | Data type | Description
TypeID | tinyint | Unique identifier for the row.
Name | nvarchar(100) | Unique name for the row.
Mnemonic | nvarchar(32) | Search qualifier name.
MinimumDegradation | float | Contains the minimum degradation applied to the relevance of a collocation composed of multiple keywords.
MaximumDegradation | float | Contains the maximum degradation applied to the relevance of a collocation composed of multiple keywords.


AuthorityOverlayRetentionIndOne

AuthorityOverlayRetentionIndOne Table

Table used to determine for a particular tag number, which indicator one values do we retain for overlay processing.

Columns

Column name | Data type | Description
RetentionID | int | foreign key
RetainIndicator | char | The indicator we retain.


AuthorityOverlayRetentionIndTwo

AuthorityOverlayRetentionIndTwo Table

Table used to determine for a particular tag number, which indicator two values do we retain for overlay processing.

Columns

Column name | Data type | Description
RetentionID | int | foreign key
RetainIndicator | char | The indicator we retain.


AuthorityOverlayRetentionTags

AuthorityOverlayRetentionTags Table

For overlay and retention of duplicates, the list of tags (organization specific) will appear in this table.

Columns

Column name | Data type | Description
RetentionID | int | primary key
RetainTagNumber | int | The marc tag number of the tag we retain
OrganizationID | int | The organization which uses these (general) retention tags
ImportProfileID | int | If an import profile has it's own unique list, the link to the profile is here.

See Also

AuthorityOverlayRetentionIndOne, AuthorityOverlayRetentionIndTwo,


AuthorityRecordModifyOptions

AuthorityRecordModifyOptions Table

This table is a coded table which is used during importing bib records (when unlinked headings are found).

Columns

Column name | Data type | Description
ACModifyOptionID | smallint | Primary key
Description | nvarchar(80) | Actual option (as text)

See Also

AuthorityUpdateLinkedRecordsRequests,


AuthorityRecords

AuthorityRecords Table

Main authority record table. There is a single entry in this table for each MARC authority record in the system. Additional contents of the record are contained in the AuthorityTags and AuthoritySubfields tables.

Columns

Column name | Data type | Description
AuthorityRecordID | int | Primary key
RecordStatusID | int | Link to record statuses table (final, provisional, etc.)
CreatorID | int | Polaris user who created the record
ModifierID | int | Polaris user who last modified the record
FirstUseDate | datetime | Date when record is first linked to a bib record
ImportedDate | datetime | Date when record was entered into the system (by importing or original cataloging)
MARCStatus | char | LDR/05
MARCType | char | LDR/06
MARCUndefined7 | char | MARC LDR/07
MARCUndefined8 | char | MARC LDR/08
MARCEncodingLevel | char | LDR/17
MARCUndefined18 | char | MARC LDR/18
MARCUndefined19 | char | MARC LDR/19
MARCKindOfRecord | char | 008/09
MARCCatalogingRules | char | 008/10
MARCSubjectHeadings | char | 008/11
MARCUseMainEntry | char | 008/14
MARCUseSubjectEntry | char | 008/15
MARCUseSeriesEntry | char | 008/16
Heading | nvarchar(255) | Normalized, searchable version of the heading
BrowseHeading | nvarchar(255) | Display version of the heading for this record
MARCCatalogingSource | char | 008/39
MARCSubjectSubdivision | char | 008/17
MARCCreationDate | nchar | 008/00-05
MARCModificationDate | nchar | MARC Tag 005 (non repeatable)
MARCLCCN | nvarchar(40) | MARC 010 tag (non repeatable in record)
MARCGeographicSubdivision | char | 008/06
MARCRomanization | char | 008/07
MARCTypeOfSeries | char | MARC 008/12
MARCNumberedSeries | char | 008/13
MARCGovernmentAgency | char | 008/28
MARCReferenceEvaluation | char | 008/29
MARCRecordUpdate | char | 008/31
MARCUndifferentiatedName | char | MARC 008/32
MARCLevelOfEstablishment | char | 008/33
MARCModifiedRecord | char | 008/38
MARCCharCodingScheme | char | LDR/09 - tells use whether the record is Unicode format or not.
RecordStatusDate | datetime | date when the record's status was last changed. either from Provisional, Final or Deleted.
ModifiedByAuthorityJob | bit | Was the last modification to this record by a linked authority background job?
CreationDate | datetime | Non-marc creation date field
ModificationDate | datetime | Non-MARC modification date field
ImportedFileName | nvarchar(255) | File name record was imported from (if applicable)
BrowseHeadingNonFilingCount | tinyint | Is the number of non-filing characters in the BrowseHeading column that should be ignored for collating purposes.
ImportedControlNumber | nvarchar(50) | The 001 tag from the record when it was imported
ImportedRecordSource | nvarchar(50) | The 003 tag from the record when it was imported
LinkedBibCount | int | Count of linked bibliographic records.
LinkedSeeAlsoCount | int | Count of linked see also authority records.

See Also

AuthorityControlHeadings, AuthorityDeDup1XXIndex, AuthorityHeadingIndices, AuthorityInvalidMARCLCCNIndex, AuthorityRecordSets, AuthorityTag035Index, AuthorityTags, AuthorityTracingsIndices, BibAuthorIndices, BibSeriesIndices, BibSubfieldsAuthorized, BibSubjectIndices, UnauthorizedSeeAlsoHeadings,


AuthorityRecordSets

AuthorityRecordSets Table

This table contains links which tell what authority records are in which record sets.

Columns

Column name | Data type | Description
AuthorityRecordID | int | Link to authority records table
RecordSetID | int | Link to record sets table


AuthoritySaves

AuthoritySaves Table

This table is used to communicate "smart" authority save information between the Polaris application and the authority indexing stored procedures. The table is populated directly from code after an authority record has been modified, and it records which tags have been changed. The changed tags are then un-indexed and re-indexed. After re-indexing, the inserted rows are removed via a call to the PurgeAuthoritySaves stored procedure.

Columns

Column name | Data type | Description
AuthorityRecordID | int | ID of the authority record that was modified
AuthorityTagID | int | ID of a tag that was added, modified, or deleted
AuthorityTagNumber | smallint | Tag number of the tag that was added, modified, or deleted. For a deleted tag, the tag number is 0.
AuthoritySaveCode | smallint | This code indicates how the tag was modified. The values are: 0 - Diagnostic code -- not currently used 1 - A tag that has been added 2 - A tag that has been deleted 3 - A tag that has had its tag data (tag number or indicators) modified 4 - A tag that has had its subfield data modified 5 - A tag that has had both its tag data and subfield data modified
IndexTime | datetime | Time at which the entry was made into the table


AuthoritySubfields

AuthoritySubfields Table

This table contains all of the MARC subfield data for all authority records.

Columns

Column name | Data type | Description
AuthoritySubfieldID | int | Primary key
AuthorityTagID | int | Foreign Key link to AuthorityTags table
SubfieldSequence | smallint | The order of this subfield in relation to the entire tag.
Subfield | char | The subfield character as defined by MARC format
Data | nvarchar(4000) | The Authority record subfield data in Unicode format.
NumberOfNonFilingCharacters | tinyint | Is the number of non-filing characters that should be ignored for collating purposes.


AuthorityTag035Index

AuthorityTag035Index Table

This table is an index used for searching MARC Tag 035.

Columns

Column name | Data type | Description
AuthorityTag035IndexID | int | Unique identifier for the row.
AuthorityRecordID | int | Record ID where tag exists
AuthorityTagID | int | Tag ID
SystemControlNumber | nvarchar(40) | The actual control number data (does not include source, even though both pieces make up the text of this subfield)


AuthorityTags

AuthorityTags Table

Holds all of the Marc Tag numbers

Columns

Column name | Data type | Description
AuthorityTagID | int | Primary key
AuthorityRecordID | int | Link to authority record table
Sequence | smallint | Order of tag in relation to record it belongs in
TagNumber | smallint | MARC Tag number
IndicatorOne | char | First Indicator associated with tag
IndicatorTwo | char | Second indicator associated with tag
AssociatedAuthorityRecordID | int | If the tag is a 5xx, this is a link to the record where it is a 1xx (which may or may not exist)

See Also

Author4XX, Author5XX, AuthorityControlHeadings, AuthorityDeDup1XXIndex, AuthorityHeadingIndices, AuthorityInvalidMARCLCCNIndex, AuthoritySubfields, AuthorityTag035Index, AuthorityTracingsIndices, Series4XX, Series5XX, Subject4XX, Subject5XX, UnauthorizedSeeAlsoHeadings,


AuthorityTemplates

AuthorityTemplates Table

Templates used by users to create Authority records are stored here.

Columns

Column name | Data type | Description
AuthorityTemplateID | int | Primary key
Name | nvarchar(50) | The name of the template
OrganizationOwnerID | int | The organization who claims ownership of the template
CreatorID | int | The polaris user who created the template
ModifierID | int | The polaris user who last modified the template
CreationDate | datetime | When template was created
ModificationDate | datetime | The date when the record is updated - maps to tag 005
MARCStatus | char | LDR/05
MARCType | char | LDR/06
MARCEncodingLevel | char | LDR/17
MARCCharCodingScheme | char | LDR/09 - tells use whether the record is Unicode format or not.

See Also

AuthorityTemplateTags,


AuthorityTemplateSubfields

AuthorityTemplateSubfields Table

Authority template MARC subfields are stored here

Columns

Column name | Data type | Description
ACTemplateSubfieldID | int | Primary key
AuthorityTemplateTagID | int | Foreign Key Link to AuthorityTemplateTags table.
SubfieldSequence | smallint | Where this subfield lies in relation to rest of subfields in a tag
Subfield | char | The actual subfield character code
Data | nvarchar(4000) | The Authority template record subfield data in Unicode format.


AuthorityTemplateTags

AuthorityTemplateTags Table

MARC tags which are included in an Authority Template

Columns

Column name | Data type | Description
AuthorityTemplateTagID | int | Primary key
AuthorityTemplateID | int | Link to main template table
Sequence | smallint | Where this tag is in relation to other tags in record
TagNumber | smallint | The MARC tag number
IndicatorOne | char | First indicator associated with MARC tag
IndicatorTwo | char | Second indicator associated with MARC tag

See Also

AuthorityTemplateSubfields,


AuthorityTracingsIndices

AuthorityTracingsIndices Table

This table is an index of all tracings (4xx,5xx) in all authority records

Columns

Column name | Data type | Description
AuthorityRecordID | int | Record that tracing belongs to
AuthorityTagID | int | Tag ID in AuthorityTags table
Tracing | nvarchar(255) | The searched tracing - normalized
TagNumber | smallint | The tag number of the tracing
BrowseTracing | nvarchar(255) | The text string which is the tracing - shown on listview
BrowseHeading | nvarchar(255) | Heading (1xx) of record where tracing exists - shown on listview


AuthorityUpdateLinkedBibRecordsRequestsHistoryTags

AuthorityUpdateLinkedBibRecordsRequestsHistoryTags Table

Insanely long table name used to keep a history of bib tags and how they were changed when a linked 1xx was modified.

Columns

Column name | Data type | Description
LinkedRequestID | int | Request this was associated with.
BibliographicRecordID | int | Bib record ID of the tag
BibliographicTagID | int | Tag ID of the tag
Heading | nvarchar(1000) | The textual heading
DescriptionOfWork | nvarchar(255) | Is a description of one of four things: unlink, modify, delete, or some error in the processing.


AuthorityUpdateLinkedRecordsRequests

AuthorityUpdateLinkedRecordsRequests Table

This is what the authority background job uses when it needs to update linked records when a 1xx changes, or it's usage changes.

Columns

Column name | Data type | Description
LinkedRequestID | int | The primary key.
AuthorityRecordID | int | Authority record which was modified.
LinkedBibOptionID | smallint | The option selected for bib links
LinkedAuthorityOptionID | smallint | The option selected for authority links.
RequestDate | datetime | Date request was added to the queue
UserID | int | User who made the request.
WorkstationID | int | Workstation request launched from.
BibHeadingCountToProcess | int | Number of bib headings it thinks it needs to update initially
SeeAlsoHeadingCountToProcess | int | Number of see also headings it thinks it needs to update initially
ProcessStage | bit | Says whether the job is still pending, in progress, or complete.


AuthorityUpdateLinkedRecordsRequestsHistory

AuthorityUpdateLinkedRecordsRequestsHistory Table

Keeps a history of authority record changes and how linked records were affected.

Columns

Column name | Data type | Description
LinkedRequestID | int | The request ID (primary key).
AuthorityRecordID | int | Authority record change was submitted for.
RequestDate | datetime | Date of request.
UserID | int | User who submitted request.
WorkstationID | int | Workstation who submitted request.
BibHeadingUpdatedCount | int | Number of bib headings affected.
SeeAlsoHeadingUpdatedCount | int | Number of changed see also links.
BibHeadingDetectedCount | int | Number of bib headings it thinks it needs to update initially
SeeAlsoHeadingDetectedCount | int | Number of see also headings it thinks it needs to update initially
LinkedBibOptionID | smallint | The option to apply to all linked bibliographic records (unlink, delete, flip, modify)
LinkedAuthorityOptionID | smallint | The option to apply to all linked authority records (unlink, delete, flip, modify)
ProcessStage | bit | Says whether the job is still pending, in progress, or complete.

See Also

AuthorityUpdateLinkedBibRecordsRequestsHistoryTags, AuthorityUpdateLinkedSeeAlsoRecordsRequestsHistoryTags,


AuthorityUpdateLinkedSeeAlsoRecordsRequestsHistoryTags

AuthorityUpdateLinkedSeeAlsoRecordsRequestsHistoryTags Table

Insanely long table name used to keep a history of 5xx tags and how they were changed when a linked 1xx was modified.

Columns

Column name | Data type | Description
LinkedRequestID | int | Request this was associated with.
AuthorityRecordID | int | Record ID of the linked tag
AuthorityTagID | int | Tag ID of the linked tag
Heading | nvarchar(1000) | The heading affected
DescriptionOfWork | nvarchar(255) | Is a description of one of four things: unlink, modify, delete, or some error in the processing.


AuthPrefCatSource

AuthPrefCatSource Table

Controls whether an imported authority record is accepted as superior to an existing authority record

Columns

Column name | Data type | Description
SourceID | int | Unique ID
OrganizationID | int | Organisation to which that rule applies
Code | nvarchar(15) | Code representing a cataloging sources in field 040$a of the authority record
Preference | int | Preference ranking (highest preference = 1)


Authtemp

Authtemp Table

Temporary table for authorities conversions. Maps the old Authority id found in the 001 to the polaris auth numbers.

Columns

Column name | Data type | Description
bid | int | Polaris authority ID number
cn | nvarchar(25) | Old system control number (usually found in the 001)
leader | nvarchar(20) | The leader of the authority record (optional)


BackorderInstr

BackorderInstr Table

Back order instructions tell a vendor what the library wishes to do should an ordered item become backordered.

Columns

Column name | Data type | Description
BackorderInstrID | int | Integer value for corresponding text message.
BackorderInstr | nvarchar(100) | Text of the backorder instructions.
BISACCode | nvarchar(3) | BISAC code upon which the text and integer values are based.

See Also

POLines, PurchaseOrders,


BestsellerLists

BestsellerLists Table

Table used to import BestSeller List definitions from Book Sense.

Columns

Column name | Data type | Description
ListID | int | Primary Key. Bestseller identifier, number is significant: 1 - Trade Paperback Fiction 2 - Trade Paperback Nonfiction 3 - Hardcover Fiction 4 - Hardcover Nonfiction 5 - Mass Market 6 - Childrens 7 - The Book Sense Teen Lit Bestseller List
ListName | nvarchar(255) | Bestseller List Name.


BestsellerListsDetails

BestsellerListsDetails Table

Table used to import BestSeller List details from Book Sense. Contains the actual book lists.

Columns

Column name | Data type | Description
ListID | int | Foreign Key reference to BestsellerLists table.
Rank | int | Bestseller's rank on the associated list.
ISBN | nvarchar(255) | Bestseller's ISBN.
Title | nvarchar(255) | Bestseller's Title.
Publisher | nvarchar(255) | Bestseller's Publisher.
Price | nvarchar(255) | Bestseller Price.
Author | nvarchar(255) | Bestseller's Author.
NormalISBN | nvarchar(50) | Bestseller's ISBN which is normalized for searching/sorting purposes.


BibAuthorIndices

BibAuthorIndices Table

Bib Author Index associative entity. This table is an associative entity (with additional information) between the Author search index table (AU_Index) and the Bib table. It maps an author heading in AU_Index to all Bib records that contain that author, Additional information for each Bib map is included in this table.

Columns

Column name | Data type | Description
MainAuthorHeadingID | int | Link to main author table (where author text is held)
BibliographicTagID | int | Link to Bib Tag table
BibliographicRecordID | int | Link to Bib Record table
DisplayInPAC | bit | Indicates whether or not the bibliographic record referenced in the BibliographicRecordID column should display in PAC. This column is synchronized with the BibliographicRecords.DisplayInPAC column.
AuthorityRecordID | int | Identifies the authorizing record.


BibCallNumberIndices

BibCallNumberIndices Table

This table associates call number entries with bibliographic records and item records.

Columns

Column name | Data type | Description
BibCallNumberIndexID | int | Unique identifier for the row.
MainCallNumberEntryID | int | Identfies the call number entry to which a bibliographic record or item record is associated with.
BibliographicRecordID | int | Identifier of the bibliographic record to which the call number entry refers. If the ItemRecordID column is NULL then the call number entry contains a bibliographic-level call number, otherwise this column is synchronized with the CircItemRecords.AssociatedBibRecordID column.
BibliographicDisplayInPAC | bit | Indicates whether or not the bibliographic record referenced in the BibliographicRecordID column should display in PAC. This column is synchronized with the BibliographicRecords.DisplayInPAC column.
ItemRecordID | int | Identifier of the item record to which the call number entry refers. If the ItemRecordID column is not NULL then the call number entry contains an item-level call number, otherwise the call number entry contains a bibliographic-level call number.
ItemDisplayInPAC | bit | Indicates whether or not the item record referenced in the ItemRecordID column should display in PAC. If the ItemRecordID column is NULL then this column will also be NULL, otherwise this column is synchronized with the CircItemRecords.DisplayInPAC column.
NormalVolumeNumber | nvarchar(255) | Contains a normalized volume number suitable for sorting purposes. When the ItemRecordID column is NULL then this column will also be NULL, otherwise this column is synchronized with the ItemRecordDetails.VolumeNumber column.
Flags | tinyint | A tiny integer value representing a bitwise combination of the following flags: BIBCALLNUMBERINDICES_FLAG_SORTTERM = 0x1, BIBCALLNUMBERINDICES_FLAG_SYSTEMLEVEL = 0x2.


BibDashboardStatistics

BibDashboardStatistics Table

This table is used in the maintenance of PowerPAC dashboards. It contains counts by BibliographicRecordID for the number of times a Bib has circulated. The searched column is reserved for future use for a search dashboard.

Columns

Column name | Data type | Description
BibliographicRecordID | int | FK Link to BibliographicRecords table
PeriodicCircCount | int | The number of times the associated Bib has been circulated within the reporting period. This column is maintained by the trigger CircItemRecords_UPD. (By "reporting period" it means since the last time the Most Circulated dashboard was populated.)
PeriodicSearchCount | int | Planned for future used.


BibDuplicateDetectionPrecedence

BibDuplicateDetectionPrecedence Table

This table lists the precedence of the duplicate detection rules used in duplicate processing.

Columns

Column name | Data type | Description
BibDupDetectRuleID | int | Foreign key - number associated with the rule itself.
ImportProfileID | int | System defaults to 1, but since profiles can have specific rule groupings, that is captured here.
DupDetectPrecedence | smallint | The precedence of this rule group
DisplayName | nvarchar(50) | The display name of the rule used in cataloging UI


BibDuplicateDetectionRules

BibDuplicateDetectionRules Table

This table lists the rules used for duplicate detection.

Columns

Column name | Data type | Description
BibDupDetectRuleID | int | Primary key - number associated with the rule itself.
DuplicateDetectionRule | nvarchar(255) | Description of the rule itself
RuleDesc | nvarchar(100) | Rule description

See Also

BibDuplicateDetectionPrecedence, ImportJobsBibDuplicateDetectionRules,


BibGhostTagsNotDeleted

BibGhostTagsNotDeleted Table

Internal table used for troubleshooting purposes ONLY

Columns

Column name | Data type | Description
BibliographicRecordID | int | Bib record ID
BibliographicTagID | int | Bib Tag ID
TagNumber | int | MARC tag number
TableReference | nvarchar(255) | Name of DB table


BibIndexDefinition

BibIndexDefinition Table

Contains a list of indexes built off Bib records. This table is no longer used in Polaris proper, but still referenced in some conversion services routines.

Columns

Column name | Data type | Description
IndexKey | char | The Z39.50 mnemonic
IndexName | nvarchar(40) | Is the description of the index
IndexOrder | smallint | What order the indexes are built in (initially when a db is loaded)
Type | char | *** OBSOLETE *** Is it alphabetic, numeric, or both types of string data?

See Also

BibIndexParams,


BibIndexParams

BibIndexParams Table

Defines the tags used in Bibliographic browse indexing and keyword indexing. (see the table BrowseSubfields for details on subfield information)

Columns

Column name | Data type | Description
IndexKey | char | The Z39.50 mnemonic - character code.
BibIndexParamsTag | smallint | The actual tag number in the index.
Type | char | ** OBSOLETE -- NO LONGER USED ** What type data is found in index (alpha, numeric, or both)
AddedEntry | bit | Used for special processing for authors
HonorNonFiling | smallint | Specifies if this tag has non-filing indicators that need to be taken into account for normalization (for stripping leading articles). 1 - use indicator one 2 - use indicator two 0/null - No non-filing indicators
BIB_1 | nvarchar(100) | Mnemonic which was not used in this format
Precedence | smallint | The precedence of this tag in the associated index. (i.e. precedence of 1 indicates the tag of highest precedence)

See Also

BrowseSubfields,


BibliographicConcordance

BibliographicConcordance Table

Contains one row for each distinct collocation composed of 1 to 8 keywords within a bibliographic record

Columns

Column name | Data type | Description
CollocationID | int | Unique identifier for the row.
LexicalContextTuple | varbinary | Compressed tuple of keyword/delimiter pairs.


BibliographicConcordanceRadix

BibliographicConcordanceRadix Table

Contains one row for each distinct code point at a given prefix-position within the concordance.

Columns

Column name | Data type | Description
NexusID | int | Unique identifier for the row.
ParentNexusID | int | Unique identifier for the parent row.
EdgeTransition | nchar | Distinct code point at a given prefix-position within the concordance.
SemanticHintTuple | varbinary | Compressed tuple of collocation hints.


BibliographicFacetIndex

BibliographicFacetIndex Table

Contains one row for each bibliographic record associated with one or more search facets.

Columns

Column name | Data type | Description
RecordID | int | Unique identifier of the bibliographic record.
FacetKeyChain | varbinary | Compressed binary chain of facet keys associated with the bibliographic record.


BibliographicFacets

BibliographicFacets Table

Contains one row for each distinct bibliographic search facet.

Columns

Column name | Data type | Description
FacetTypeID | tinyint | Unique identifier of the facet type.
FacetKey | varbinary | Unique hierarchical key of the facet.
DisplayTerm | nvarchar(255) | Text representation of the facet.
ParentFacetKey | varbinary | Unique identifier the parent facet. This column may be NULL.
NormalTerm | nvarchar(255) | Normalized text representation of the facet used for filtering purposes.
ReferenceID | int | Identifies the underlying identifier associated with the facet key. This column is optional and specific to the facet type.


BibliographicFacetTypes

BibliographicFacetTypes Table

Contains one row for each bibliographic facet type.

Columns

Column name | Data type | Description
FacetTypeID | tinyint | Unique identifier of the facet type.
Name | nvarchar(255) | Name of the facet type.
FacetKindID | tinyint | Identifies the facet kind.


BibliographicHoldableMaterialTypes

BibliographicHoldableMaterialTypes Table

Contains one row for each distinct material type that is holdable for a bibliographic record

Columns

Column name | Data type | Description
BibliographicRecordID | int | Unique identifier for the bibliographic record
MaterialTypeID | int | Unique identifier for the material type


BibliographicInvalidMARCLCCNIndex

BibliographicInvalidMARCLCCNIndex Table

This index contains all of the 010 $z values found in bib records.

Columns

Column name | Data type | Description
BibliographicInvalidMARCLCCNIndexID | int | Primary key
BibliographicRecordID | int | bib record
BibliographicTagID | int | bib tag
InvalidMARCLCCN | nvarchar(40) | Invalid LCCN data


BibliographicISBNIndex

BibliographicISBNIndex Table

This table is an index by ISBN (normalized value) into the Bibliographic MARC tables.

Columns

Column name | Data type | Description
BibliographicISBNIndexID | int | Unique identifier for the row.
BibliographicRecordID | int | BibliographicRecords table reference.
BibliographicTagID | int | BibliographicTags table reference for the tag associated with this ISBN value.
ISBNString | nvarchar(50) | Normalized ISBN field.
IsValidISBN | bit | Flags ISBN as "valid". If the ISBN is sourced from a Tag 020 subfield z (020$z) the ISBN is flagged as not valid in this field.
ISBNDisplayData | nvarchar(50) | The non-normalized version of the ISBN


BibliographicKeywordIndex

BibliographicKeywordIndex Table

Contains one row for each keyword indexed in a bibliographic record.

Columns

Column name | Data type | Description
KeywordID | int | Is the bibliographic keyword identifier.
RecordID | int | Identifies the bibliographic record from which a keyword has been indexed.
TypeFlags | smallint | Identifies one or more keyword types; based on the (MARC) data element from which the keyword was indexed.
TokenizedData | varbinary | Contains compressed binary data which includes the Significance, TypeFlags, ContractionCount, DelimiterClass, ChunkID and WordPosition for each occurrence of a keyword within a given record.


BibliographicKeywordRelations

BibliographicKeywordRelations Table

Contains one row for each keyword/related-keyword pair.

Columns

Column name | Data type | Description
KeywordID | int | Identifies the base keyword.
RelatedKeywordID | int | Identifies the related keyword.
Likelihood | float | A floating point number between 0 and 1 that represents the likelihood the KeywordID is related to the RelatedKeywordID.
HasCommonStem | bit | Indicates whether the keyword/related-keyword pair has a common stem.


BibliographicKeywordRules

BibliographicKeywordRules Table

Contains one row for each bibliograhic keyword indexing rule. Each bibliographic keyword indexing rule identifies a MARC data element to be indexed and is identified by a unique tag/subfield pair.

Columns

Column name | Data type | Description
TagNumber | smallint | Identifies the tag of a MARC data field to be indexed. This column combined with the Subfield column is unique for each row.
Subfield | char | Identifies the subfield of a MARC data element to be indexed. This column combined with the TagNumber column is unqiue for each row.
TypeFlags | int | Associates this rule with one or more bibliographic keyword types. A keyword type is enabled if bit position POWER(2, TypeID - 1) is set to one, where TypeID must reference a row in the BibliograhpicKeywordTypes table.
MinimumSignificance | real | Contains the minimum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
MaximumSignificance | real | Contains the maximum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
AverageTermCount | real | Contains the average term count for a given data element associated with a specific TagNumber and Subfield.
AverageTermCountStandardDeviation | real | Contains the standard deviation of the AverageTermCount for a given data element associated with a specific TagNumber and Subfield.


BibliographicKeywords

BibliographicKeywords Table

Contains one row for each distinct keyword found in a bibliographic record.

Columns

Column name | Data type | Description
KeywordID | int | Unique identifier for the row.
Term | nvarchar(128) | Normalized term suitable for keyword and phrase searching. This column is unique for each row.
Weight | real | The IDF (inverse document frequency) weight associated with the term. The weight equals log((N + 1) / n), where N = total number of records and n = number of records containing one or more occurrences of the keyword.

See Also

BibliographicKeywordIndex, BibliographicKeywordRelations,


BibliographicKeywordScaleFactors

BibliographicKeywordScaleFactors Table

Contains one row for each bibliographic keyword scale factor. Each scale factor is associated with a predefined keyword scale and contains a default signficance to be associated with a MARC data element.

Columns

Column name | Data type | Description
ScaleID | tinyint | Identifies a predefined bibliographic keyword scale. This column combined with the TagNumber and Subfield column is unqiue for each row.
TagNumber | smallint | Identifies the tag of a MARC data field. This column combined with the ScaleID and Subfield column is unique for each row.
Subfield | char | Identifies the subfield of a MARC data element. This column combined with the ScaleID and TagNumber column is unqiue for each row.
MinimumSignificance | real | Contains the minimum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
MaximumSignificance | real | Contains the maximum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.


BibliographicKeywordScales

BibliographicKeywordScales Table

Contains one row for each bibliographic keyword scale. Each keyword scale is associated with a set of predefined keyword scale factors.

Columns

Column name | Data type | Description
ScaleID | tinyint | Unique identifer for the row.
Name | nvarchar(100) | Unique name for the row.

See Also

BibliographicKeywordScaleFactors,


BibliographicKeywordTypes

BibliographicKeywordTypes Table

Contains one row for each bibliographic keyword type. Each keyword type corresponds to a search access point and is associated with a subset of MARC data elments.

Columns

Column name | Data type | Description
TypeID | tinyint | Unique identifier for the row.
Name | nvarchar(100) | Unique name for the row.
Mnemonic | nvarchar(32) | Search qualifier name.
MinimumDegradation | float | Contains the minimum degradation applied to the relevance of a collocation composed of multiple keywords.
MaximumDegradation | float | Contains the maximum degradation applied to the relevance of a collocation composed of multiple keywords.


BibliographicPACFilter

BibliographicPACFilter Table

Contains one row for each bibliographic record that should not display in PAC.

Columns

Column name | Data type | Description
BibliographicRecordID | int | Identifies a bibliograhic record that should not display in PAC.


BibliographicRecordResourceGroups

BibliographicRecordResourceGroups Table

Associative Entity table that links Bibliographic Records to Resource Groups.

Columns

Column name | Data type | Description
BibliographicRecordID | int | Foreign Key reference to BibliographicRecords table
ResourceGroupID | int | Foreign Key reference to SA_ResourceGroups table


BibliographicRecords

BibliographicRecords Table

Main bibliographic record table. There is a single entry in this table for each MARC bibliographic record in the system. Additional contents of the record are contained in the BibliographicTags and BibliographicSubfields tables.

Columns

Column name | Data type | Description
BibliographicRecordID | int | This is the unique identifier for the record. (primary key, identity)
RecordStatusID | int | Status of the record (final, provisional) - link back to a status table
RecordOwnerID | int | Polaris organization who owns the record
CreatorID | int | This is the ID of the Polaris user who created the record.
ModifierID | int | This is the ID of the Polaris user who last modified the record.
BrowseAuthor | nvarchar(255) | This is the display field for the author of highest precedence. It is used, for example, in the "hit list" returned from a search.
BrowseTitle | nvarchar(255) | This is the display field for the title of highest precedence. It is used, for example, in the "hit list" returned from a search.
BrowseCallNo | nvarchar(255) | This is the display field for the call number of highest precedence. It is used, for example, in the "hit list" returned from a search.
DisplayInPAC | tinyint | This flag indicates whether or not the record will be displayed in the PAC.
ImportedDate | datetime | For an imported record, this is the date on which the record was imported.
MARCBibStatus | char | This is part of the leader of the record. It represents position 5.
MARCBibType | char | This is part of the leader of the record. It represents position 6.
MARCBibLevel | char | This is part of the leader of the record. It represents position 7.
MARCTypeControl | char | This is part of the leader of the record. It represents position 8.
MARCBibEncodingLevel | char | This is part of the leader of the record. It represents position 17.
MARCDescCatalogingForm | char | This is part of the leader of the record. It represents position 18.
MARCLinkedRecordReq | char | This is part of the leader of the record. It represents position 19.
MARCPubDateOne | nchar | This data is pulled from tag 008/07-10 during the indexing process.
MARCPubDateTwo | nchar | This data is pulled from tag 008/11-14 during the indexing process.
MARCTargetAudience | char | This data is pulled from tag 008/22 for books, music, visual materials, and computer files during the indexing process.
MARCLanguage | nchar | This data is pulled from tag 008/35-37 during the indexing process.
MARCPubPlace | nchar | This data element is obsolete and can be removed.
PublicationYear | smallint | This corresponds to MARC 008/06-10
MARCCreationDate | nchar | This data is pulled from tag 008/00-06 during the indexing process.
MARCModificationDate | nchar | This data is pulled from tag 005 during the indexing process.
MARCLCCN | nvarchar(40) | This data is pulled from tag 010$a during the indexing process.
MARCMedium | nvarchar(100) | This data is pulled from tag 245$h during the indexing process.
MARCPublicationStatus | char | This data is pulled from tag 008/06 during the indexing process.
ILLFlag | bit | This flag indicates whether or not this bib record is used for ILL.
MARCCharCodingScheme | char | LDR/09 - tells use whether the record is Unicode format or not.
SortAuthor | nvarchar(255) | Normalized primary author of this Bib record used in sorting.
LiteraryForm | char | Literary Form (extracted from tag 008, offset 33)
RecordStatusDate | datetime | date when the record's status was last changed. either from Provisional, Final or Deleted.
ModifiedByAuthorityJob | bit | Was this record last modified by a linked authority record background job?
PrimaryMARCTOMID | tinyint | Primary MARC type of Material associated with bib record (can ultimately have many, but only one primary).
FirstAvailableDate | datetime | The first available date for the bib is the first day the first item linked to the bib becomes available for circulation. This is used by NewTitles job and RSS feeds among others.
CreationDate | datetime | Non-MARC creation date
ModificationDate | datetime | Non-MARC modification date
LifetimeCircCount | int | Composite count of lifetime circ for all associated item records
LifetimeInHouseUseCount | int | Composite count of in house circ for all associated item records
SortTitle | nvarchar(255) | Normalized primary title of this Bib record used in sorting.
Popularity | int | The current popularity of the record based on recent and lifetime activity. For details, refer to the comments in the PAC_UpdatePopularity stored procedure.
ImportedFileName | nvarchar(255) | File name record was imported from (if applicable)
BrowseTitleNonFilingCount | tinyint | Is the number of non-filing characters in the BrowseTitle column that should be ignored for collating purposes.
ImportedControlNumber | nvarchar(50) | The 001 tag from the record when it was imported
ImportedRecordSource | nvarchar(50) | The 003 tag from the record when it was imported
HasElectronicURL | bit | If the bib record has an electronic URL (an 856 $u), this bit is set.
DoNotOverlay | bit | Yes/No flag that allows or prohibits this record from being overlaid
HostBibliographicRecordID | int | Set to a non-null value if this record is a constituent of another record. Note: a record cannot be a constituent of itself.
HasConstituents | bit | Flag indicating whether this record is associated with constituents. If this record's BibliographicRecords.BibliographicRecordID equals the BibliographicRecords.HostBibliographicRecordID in one or more other records then this record has constituents.
BoundWithCreatorID | int | This is the ID of the Polaris user who created the Bound-With link.
BoundWithCreationDate | datetime | Creation date of the Bound-With link

See Also

BibAuthorIndices, BibCallNumberIndices, BibDashboardStatistics, BibliographicHoldableMaterialTypes, BibliographicInvalidMARCLCCNIndex, BibliographicISBNIndex, BibliographicRecordResourceGroups, BibliographicRecords, BibliographicTag022Index, BibliographicTag024Index, BibliographicTag027Index, BibliographicTag028Index, BibliographicTag030Index, BibliographicTag035Index, BibliographicTag037Index, BibliographicTag050Index, BibliographicTag055Index, BibliographicTag060Index, BibliographicTag070Index, BibliographicTag080Index, BibliographicTag082Index, BibliographicTag086Index, BibliographicTags, BibliographicTOMIndex, BibliographicUPCIndex, BibRecordSets, BibSeriesIndices, BibSubjectIndices, BibTitleIndices, CircItemRecords, DeDup1XXIndex, DeDup245Index, DeDup246Index, DeDup247Index, DeDup260Index, ILLRequests, InvLines, ItemTemplates, MfhdIssues, MRMS_ResourceLinks, MRMS_ResourceRecords, PACAvailability, PACAvailabilityFacetIndex, POLines, PromotionBibliographicLinks, ResourceEntities, SDIResults, SelListLines, SHRCopies, SHRSharedPublicNotes, Subscriptions, SysHoldRequests, TitleRatings, UnauthorizedBibHeadings,


BibliographicSubfields

BibliographicSubfields Table

The Bibliographic MARC subfield table. Every subfield in the Bib MARC record will contain an entry in this table. This table contains a foreign key to the BibliographicTags entity to identify the MARC tag that contains this subfield.

Columns

Column name | Data type | Description
BibliographicSubfieldID | int | Primary Key unique identifier (IDENTITY)
BibliographicTagID | int | Link to the BibliographicTags table
SubfieldSequence | smallint | Where this particular subfield exists in relation to other subfields in a tag.
Subfield | char | The character subfield code
Data | nvarchar(4000) | The subfield data (Unicode)
NumberOfNonFilingCharacters | tinyint | Is the number of non-filing characters that should be ignored for collating purposes.

See Also

BibSubfieldsAuthorized,


BibliographicTag022Index

BibliographicTag022Index Table

Index used for searching MARC Bib tag 022 values.

Columns

Column name | Data type | Description
BibliographicTag022IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table
BibliographicTagID | int | Link to Bib Tag table
ISSNString | nvarchar(50) | The data string which is searched upon (the index).


BibliographicTag024Index

BibliographicTag024Index Table

Index used for searching MARC Bib tag 024 values that are not specific to ISBN or UPC (which have their own index)

Columns

Column name | Data type | Description
BibliographicTag024IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Bibliographic record ID
BibliographicTagID | int | Bibliographic Tag ID
OSINumber | nvarchar(50) | The other standard identifier number.


BibliographicTag027Index

BibliographicTag027Index Table

Index used for searching MARC Bib tag 027 values.

Columns

Column name | Data type | Description
BibliographicTag027IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table
BibliographicTagID | int | Link to Bib Tag table
STRNString | nvarchar(50) | The data string which is searched upon (the index).


BibliographicTag028Index

BibliographicTag028Index Table

Index used for searching MARC Bib tag 028 values.

Columns

Column name | Data type | Description
BibliographicTag028IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table
BibliographicTagID | int | Link to Bib Tag table
PublisherNumber | nvarchar(50) | The data string which is searched upon (the index).


BibliographicTag030Index

BibliographicTag030Index Table

Index used for searching MARC Bib tag 030 values.

Columns

Column name | Data type | Description
BibliographicTag030IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table
BibliographicTagID | int | Link to Bib Tag table
CODENString | nvarchar(50) | The data string which is searched upon (the index).


BibliographicTag035Index

BibliographicTag035Index Table

Index used for searching MARC Bib tag 035 values.

Columns

Column name | Data type | Description
BibliographicTag035IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table.
BibliographicTagID | int | Link to Bib Tag table
SystemControlNumber | nvarchar(40) | The data string which is searched upon (the index) which does not include the source (usually 3 char prefix).


BibliographicTag037Index

BibliographicTag037Index Table

Index used for searching MARC Bib tag 037 values.

Columns

Column name | Data type | Description
BibliographicTag037IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Bibliographic Record ID
BibliographicTagID | int | Bibliographic Tag ID
SOANumber | nvarchar(50) | Source of acquisition number


BibliographicTag050Index

BibliographicTag050Index Table

Index used for searching MARC Bib tag 050 values.

Columns

Column name | Data type | Description
BibliographicTag050IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table
BibliographicTagID | int | Link to Bib Tag table
NormalCallNumber | nvarchar(255) | Normalized call number suitable for sorting purposes.
CanonicalCallNumber | nvarchar(255) | Canonicalized call number suitable for searching puporses.
BrowseCallNumber | nvarchar(255) | Unnormalized call number suitable for display purposes.
DisplayInPAC | bit | This flag indicates whether or not the record will be displayed in the PAC. (Copied from the BibliographicRecords table)


BibliographicTag055Index

BibliographicTag055Index Table

Index used for searching MARC Bib tag 055 values.

Columns

Column name | Data type | Description
BibliographicTag055IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table
BibliographicTagID | int | Link to Bib Tag table
NormalCallNumber | nvarchar(255) | Normalized call number suitable for sorting purposes.
CanonicalCallNumber | nvarchar(255) | Canonicalized call number suitable for searching puporses.


BibliographicTag060Index

BibliographicTag060Index Table

Index used for searching MARC Bib tag 060 values.

Columns

Column name | Data type | Description
BibliographicTag060IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table
BibliographicTagID | int | Link to Bib Tag table
NLMClassNumber | nvarchar(50) | The data string which is searched upon (the index).


BibliographicTag070Index

BibliographicTag070Index Table

Index used for searching MARC Bib tag 070 values.

Columns

Column name | Data type | Description
BibliographicTag070IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table
BibliographicTagID | int | Link to Bib Tag table
NALClassNumber | nvarchar(50) | The data string which is searched upon (the index).


BibliographicTag080Index

BibliographicTag080Index Table

Index used for searching MARC Bib tag 080 values.

Columns

Column name | Data type | Description
BibliographicTag080IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table
BibliographicTagID | int | Link to Bib Tag table
NormalCallNumber | nvarchar(255) | Normalized call number suitable for sorting purposes.
CanonicalCallNumber | nvarchar(255) | Canonicalized call number suitable for searching puporses.


BibliographicTag082Index

BibliographicTag082Index Table

Index used for searching MARC Bib tag 082 values.

Columns

Column name | Data type | Description
BibliographicTag082IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table
BibliographicTagID | int | Link to Bib Tag table
NormalCallNumber | nvarchar(255) | Normalized call number suitable for sorting purposes.
CanonicalCallNumber | nvarchar(255) | Canonicalized call number suitable for searching puporses.
BrowseCallNumber | nvarchar(255) | Unnormalized call number suitable for display purposes.
DisplayInPAC | bit | This flag indicates whether or not the record will be displayed in the PAC. (Copied from the BibliographicRecords table)


BibliographicTag086Index

BibliographicTag086Index Table

Index used for searching MARC Bib tag 086 values.

Columns

Column name | Data type | Description
BibliographicTag086IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Record table
BibliographicTagID | int | Link to Bib Tag table
GovDocClassNum | nvarchar(50) | The data string which is searched upon (the index).
IndicatorOne | char | The sourcing tag's first indicator value.


BibliographicTags

BibliographicTags Table

The Bibliographic MARC tag table. This table contains an entry for each tag in the MARC record. The indicators for the tag is stored in this table along with a sequence number whish is the ordinal position in the MARC record for this specific tag. All subfields for this tag are stored in the BibSubfield entity.

Columns

Column name | Data type | Description
BibliographicTagID | int | BibTag Primary Key unique identifier (IDENTITY)
BibliographicRecordID | int | Link to Bib Record table
Sequence | smallint | Where is this tag in relation to other tags in a bib record?
TagNumber | smallint | The tag number
IndicatorOne | char | First indicator value for tag
IndicatorTwo | char | Second indicator value for tag
EffectiveTagNumber | smallint | Is the effective tag number to be used for indexing purposes. If the TagNumber column equals 880 and the first subfield is a properly formatted $6, then this column contains the linked tag number from the first subfield $6, otherwise this column equals the TagNumber column.

See Also

BibAuthorIndices, BibliographicInvalidMARCLCCNIndex, BibliographicISBNIndex, BibliographicSubfields, BibliographicTag022Index, BibliographicTag024Index, BibliographicTag027Index, BibliographicTag028Index, BibliographicTag030Index, BibliographicTag035Index, BibliographicTag037Index, BibliographicTag050Index, BibliographicTag055Index, BibliographicTag060Index, BibliographicTag070Index, BibliographicTag080Index, BibliographicTag082Index, BibliographicTag086Index, BibliographicUPCIndex, BibSeriesIndices, BibSubfieldsAuthorized, BibSubjectIndices, BibTitleIndices, DeDup1XXIndex, DeDup245Index, DeDup246Index, DeDup247Index, DeDup260Index, UnauthorizedBibHeadings,


BibliographicTemplates

BibliographicTemplates Table

MARC Data-like structures used as templates for Bib records

Columns

Column name | Data type | Description
BibliographicTemplateID | int | Primary key
Name | nvarchar(50) | Template name
OrganizationOwnerID | int | Organization ID of template owner (if not owned by user)
RecordOwnerID | int | Who actually owns the record (OrganizationID)
CreatorID | int | Polaris UserID of creator
ModifierID | int | Polaris user ID of user who last modified record
CreationDate | datetime | Date template was created
ModificationDate | datetime | The date when the record is updated - maps to tag 005
DisplayInPAC | bit | Whether or not the record can display in PAC (will be indexed regardless)
MARCBibStatus | char | LDR/05
MARCBibType | char | LDR/06
MARCBibLevel | char | LDR/07
MARCTypeControl | char | LDR/08
MARCBibEncodingLevel | char | LDR/17
MARCDescCatalogingForm | char | LDR/18
MARCLinkedRecordReq | char | LDR/19
MARCCharCodingScheme | char | LDR/09 - tells use whether the record is Unicode format or not.
DoNotOverlay | bit | Yes/No flag that allows or prohibits this record from being overlaid

See Also

BibTemplateTags,


BibliographicTOMIndex

BibliographicTOMIndex Table

This table is a satellite Bibliographic index table that supports the MARC Type Of Material search filter.

Columns

Column name | Data type | Description
BibliographicRecordID | int | Foreign Key link to the BibliographicRecords table.
MARCTypeOfMaterialID | tinyint | Foreign Key link to the MARCTypeOfMaterial table that defines this index.
SearchCode | nchar | 3-character search code from the associated entry in MARCTypeOfMaterial table. This code is redundantly stored here to improve search performance.


BibliographicUPCIndex

BibliographicUPCIndex Table

Index used for searching MARC record UPC values.

Columns

Column name | Data type | Description
BibliographicUPCIndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Bibliographic Record ID
BibliographicTagID | int | Bib Tag ID
UPCNumber | nvarchar(13) | The UPC data


BibOverlayRetentionIndOne

BibOverlayRetentionIndOne Table

Table used to determine for a particular tag number, which indicator one values do we retain for overlay processing.

Columns

Column name | Data type | Description
RetentionID | int | foreign key
RetainIndicator | char | the indicator we retain


BibOverlayRetentionIndTwo

BibOverlayRetentionIndTwo Table

Table used to determine for a particular tag number, which indicator two values do we retain for overlay processing.

Columns

Column name | Data type | Description
RetentionID | int | foreign key
RetainIndicator | char | The indicator we retain


BibOverlayRetentionTags

BibOverlayRetentionTags Table

For overlay and retention of duplicates, the list of tags (organization specific) will appear in this table.

Columns

Column name | Data type | Description
RetentionID | int | primary key
RetainTagNumber | int | The marc tag number of the tag we retain
OrganizationID | int | The organization which uses these (general) retention tags
ImportProfileID | int | If an import profile has it's own unique list, the link to the profile is here.
Retain | bit | flag to retain or delete this tag

See Also

BibOverlayRetentionIndOne, BibOverlayRetentionIndTwo,


BibRecordSets

BibRecordSets Table

Table contains lists of which bib records are in which record sets.

Columns

Column name | Data type | Description
BibliographicRecordID | int | Link to Bib
RecordSetID | int | Link to record set


BibSaves

BibSaves Table

This table is used to communicate "smart" bibliographic save information between the Polaris application and the bibliographic indexing stored procedures. The table is populated directly from code after a bibliographic record has been modified and it records which tags have been changed. Only those tags are then un-indexed and re-indexed. After re-indexing, the rows that were inserted are removed via a call to the PurgeBibSaves stored procedure.

Columns

Column name | Data type | Description
BibRecordID | int | Link to Bib Records table
BibTagID | int | Link to Bib Tags table
BibTagNumber | smallint | Tag number of Bib tag in question
BibSaveCode | smallint | BibSaveCode defines the transaction type of the row in the table with respect to the tag (AE_SmartSaveCode enumeration in code): 0 - Diagnostic code used by the indexing/unindexing stored procedures (currently not used) 1 - A tag that has just been added 2 - A tag that has just been deleted 3 - A tag that has only had its tag data (# or indicators) modified 4 - A tag that has only had its subfield data modified 5 - A tag that has had both its tag data and subfield data modified Codes 1, 3, 4, and 5 are of interest to the Indexing stored procedures (addition or modification of a tag) while code 2 pertains to the Unindexing stored procedures (deleted tag)
IndexTime | datetime | The time at which the entry was made into the table.


BibSeriesIndices

BibSeriesIndices Table

Table which maps normalized series titles to the bib records which contain them.

Columns

Column name | Data type | Description
MainSeriesEntryID | int | Link to normalized series
BibliographicTagID | int | Link to Bib Tag
BibliographicRecordID | int | Link to Bib Record
DisplayInPAC | bit | Indicates whether or not the bibliographic record referenced in the BibliographicRecordID column should display in PAC. This column is synchronized with the BibliographicRecords.DisplayInPAC column.
AuthorityRecordID | int | Identifies the authorizing record.


BibSubfieldsAuthorized

BibSubfieldsAuthorized Table

This table is an extension of the BibliographicSubfields table and contains replicated data for the purposes of improved SQL performance.

Columns

Column name | Data type | Description
BibliographicSubfieldID | int | Bib Subfield ID
BibliographicTagID | int | Bib Tag ID
AuthorizingRecordID | int | Linked authority record ID


BibSubjectIndices

BibSubjectIndices Table

Bib Subject Index associative entity. This table is an associative entity (with additional information) between the Subject search index table (SU_Index) and the Bib table. It maps a subject heading in SU_Index to all Bib records that contain that subject, Additional information for each Bib map is included in this table.

Columns

Column name | Data type | Description
MainSubjectHeadingID | int | Link to subjects table
BibliographicTagID | int | Link to Bib Tags table
BibliographicRecordID | int | Link to Bib Record table
DisplayInPAC | bit | Indicates whether or not the bibliographic record referenced in the BibliographicRecordID column should display in PAC. This column is synchronized with the BibliographicRecords.DisplayInPAC column.
AuthorityRecordID | int | Identifies the authorizing record.


bibtemp

bibtemp Table

A table for conversion services to map the Polaris Bibliographic record id to the old system control number.

Columns

Column name | Data type | Description
bid | int | The Polaris bibliographic record ID
cn | nvarchar(25) | The old system control number.
leader | nvarchar(20) | The leader of the bib record (optional)


BibTemplateSubfields

BibTemplateSubfields Table

Table contains MARC subfields used in Bib Templates

Columns

Column name | Data type | Description
BibTemplateSubfieldID | int | Primary key
BibTemplateTagID | int | Link to BibTemplateTags table for templates
SubfieldSequence | smallint | Where subfield is in relation to other subfields in a tag
Subfield | char | The character code for the subfield
Data | nvarchar(4000) | The Bibliographic template record subfield data (Unicode)


BibTemplateTags

BibTemplateTags Table

MARC Tags defined in Bibliographic templates

Columns

Column name | Data type | Description
BibTemplateTagID | int | Primary key
BibliographicTemplateID | int | Link to BibliographicTemplates table
Sequence | smallint | Where tag exists in relation to other tags in template
TagNumber | smallint | MARC Tag number
IndicatorOne | char | First indicator char
IndicatorTwo | char | Second indicator char

See Also

BibTemplateSubfields,


BibTitleIndices

BibTitleIndices Table

This table associates title entries with bibliographic records.

Columns

Column name | Data type | Description
MainTitleEntryID | int | Identfies the title entry to which a bibliographic record is associated with.
BibliographicTagID | int | Bibliographic tag identifier to which the title entry refers. This column is also a unique identifier for the row.
BibliographicRecordID | int | Identifier of the bibliographic record to which the title entry refers.
DisplayInPAC | bit | Indicates whether or not the bibliographic record referenced in the BibliographicRecordID column should display in PAC. This column is synchronized with the BibliographicRecords.DisplayInPAC column.
ID4XX | int | A special identifier used to group records by title entry and type of material. The lower 26 bits (0-25) contains the same value as the MainTitleEntryID column and the upper 6 bits (26-31) contains a valid MARCTypeOfMaterialID from the MARCTypeOfMaterials table. This upper 6 bits of this column is synchronized with the BibliographicRecords.PrimaryMARCTOMID column.


BindingFormatRequested

BindingFormatRequested Table

Contains pre-defined binding format types that a library can request from a vendor when order items.

Columns

Column name | Data type | Description
BindingFormatID | int | Integer value for corresponding text data.
BindingFormatRequested | nvarchar(25) | Text data for a specific binding format.
BISACCode | nvarchar(3) | BISAC standard code for the the corresponding text entry.

See Also

POLines,


BindingSubstitutionInstr

BindingSubstitutionInstr Table

Vendor instructions as to what, if any, binding should be substituted for an ordered item should the requested binding format be unavailable.

Columns

Column name | Data type | Description
BindingSubInstrID | int | Integer value for corresponding text data.
BindingSubstitution | nvarchar(75) | Text data stating the binding type to be sustituted.
BISACCode | nvarchar(3) | BISAC standard for the corresponding binding type.

See Also

POLines, PurchaseOrders,


BNCBranchData

BNCBranchData Table

Stores branch details to be sent to BookNet Canada

Columns

Column name | Data type | Description
Library Code | nvarchar(20) | Abbreviation of the associated branches library
Library Name | nvarchar(55) | Name of the associated branches library
Branch Code | nvarchar(20) | Branch abbreviation
Branch Name | nvarchar(55) | Branch name
Postal Code | nvarchar(17) | Postal code of branch address
Address | nvarchar(300) | Branch address
User Count | int | Number of users
DateEnd | datetime | End date from when data was retrieved


BNCLendingData

BNCLendingData Table

This table contains data to be used by a custom report consumed by BookNet Canada. The data in this table is repopulated every time SQL Job - BNC LibrarySDAm, runs. The reports are named as BRANCHDATA_[SYS_ABBREVIATION] and LENDINGDATA_[SYS_ABBREVIATION]

Columns

Column name | Data type | Description
BranchCode | nvarchar(15) | Abbreviation code from Polaris.Organizations.Abbreviation.
CatalogueKey | int | BibliographicRecordID related to the transactions.
EAN_ISBN13 | nvarchar(-1) | List (semicolon delimited, concatenated string) of all valid ISBN related to the Bibliographic record. The value are from BibliographicISBNIndex.ISBNString, and in descending order of BibliographicTags.Sequence.
Loans | int | Total number of check-out transactions at the transacting branch in the period.
Renewals | int | Total number of renewal transactions at the transacting branch in the period.
Holds | int | Current total number of Active (3) , Pending (4), or Located (18) holds found at the pickup branch.
Copies | int | Current total number of items (copies) assigned to the branch from which the data is being reported. Items with any of these circulation status will be included/counted: In(1), Out (2), Out-ILL (3), Held (4), Transferred (5), In-Transit (6), Routed (18), Shelving (19)
CopiesOut | int | Current total number of items (copies) assigned to the branch from which the data is being reported, and whose circulation status is Out or Out-ILL.
DateStart | datetime | the beginning datetime of the period that the data is collected.
DateEnd | datetime | the cutoff datetime of the period that the data is collected.
CopiesOnOrder | int | Current total number of items (copies) assigned to the branch from which the data is being reported that are on order. All items with a circulation status of On-Order (13) or In-Process (15) are included.


BrowseSubfields

BrowseSubfields Table

This table contains subfields that are used in building the browse indexes for the associated Tag/Index.

Columns

Column name | Data type | Description
BrowseSubfieldID | int | BrowseSubfields Primary Key unique identifier (IDENTITY)
IndexKey | char | FK: See BibIndexParams table
BibIndexParamsTag | smallint | FK: See BibIndexParams table
Subfield | char | The Bibliographic record subfield this row applies to.


BulkHolds

BulkHolds Table

For internal use only. Contains an entry for a bulk hold request used during the process of triaging and placing bulk holds.

Columns

Column name | Data type | Description
BH_TokenID | int | Unique identifier primary key.
PatronID | int | ID of the patron placing the bulkd hold request.
PickupOrgID | int | ID of the pickup branch for the bulk hold request.
RequestingOrgID | int | The organization set in the PAC from which the bulk hold request is being placed.
LanguageID | int | The language selected in the PAC when the bulk hold request was placed.
CreationDate | datetime | The date/time the bulk hold request was made.

See Also

BulkHoldsBibs,


BulkHoldsBibs

BulkHoldsBibs Table

For internal use only. Contains one entry for each title requested in a bulk hold request used during the process of triaging and placing the requests.

Columns

Column name | Data type | Description
BH_TokenID | int | Foreign key reference to the parent table BulkHolds.
BibID | int | The bibliographic record unique ID for the title being requested.
Holdable | bit | Flag indicating whether the title is holdable.
ActiveRequests | int | The numbmer of outstanding active requests for the title.
ErrMnemonic | nvarchar(4000) | If the request cannot be placed for any reason, this is the message mnemonic from webAdmin for the reason the request cannot be placed.
Chargable | bit | Flag indicating that the patron may be charged for placing this request.
HoldableCode | int | Internal code indicating why a title is not holdable (if non-zero).
ErrorMssg | nvarchar(4000) | The language translated exception message if the request cannot be placed.


BulkItemChange

BulkItemChange Table

This utility table is used to express a Bulk Item Change operation request from an Item Record Set Workform in the Polaris tech client. When the user successfully completes the Bulk Item Change property sheet dialog, a single row is inserted into this table for the specific Item Record Set that the bulk change will be applied to. The stored procedure Cat_PerformBulkItemChange is then invoked which reads this row and uses the column values as input parameters, telling it what Item Record fields to change and what values to change them to. Once Cat_PerformBulkItemChange completes the bulk change, the row is removed from this table. Only one Bulk Item Change operation can occur for a particular item record set at any one time. The object lock that Polaris places on the record set while the workform is activated enforces this (the choice to perform a Bulk Item Change will be disabled on all other instances of this record set's workform window).

Columns

Column name | Data type | Description
RecordSetID | int | This column is the Item Record Set object link that represents which record set holds the item records that the Bulk Item Change will be applied to.
OwningBranchID | int | This column will hold the value of the Owning Branch which all items in the record set should be changed to (The branch which owns the item - see OwningBranchID column description in the ItemRecordDetails table). If the user didn't specify a change to the owning branch, this column will be NULL to indicate no change.
AssignedBranchID | int | This column will hold the value of the Assigned Branch which all items in the record set should be changed to (The branch the item is assigned to - see AssignedBranchID column description in the CircItemRecords table). If the user didn't specify a change to the assigned branch, this column will be NULL to indicate no change.
TemporaryShelfLocationChange | int | This column indicates whether or not a change to the Temporary Shelf Location was specified by the user. If the value is 1, a change was specified and the value to change to is found in the TemporaryShelfLocation column. If the value is 0, no change was specified.
TemporaryShelfLocation | nvarchar(255) | This column will hold the value of the Temporary Shelf Location which all items in the record set should be changed to (In case the item is not returned immediately - placed in a separate spot somewhere- see TemporaryShelfLocation column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Temporary Shelf Location in all the items. This column will only be consulted when the TemporaryShelfLocationChange column is 1, indicating a change was specified.
CirculationStatusID | int | This column will hold the value of the Circulation Status which all items in the record set should be changed to (The circulation status of the item (IN, Transit, OUT, etc.)- see ItemStatusID column description in the CircItemRecords table). If the user didn't specify a change to the circulation status, this column will be NULL to indicate no change.
MaterialTypeID | int | This column will hold the value of the Material Type which all items in the record set should be changed to (Link to Material types table - see MaterialTypeID column description in the CircItemRecords table). If the user didn't specify a change to the material type, this column will be NULL to indicate no change.
LoanPeriodCodeID | int | This column will hold the value of the Loan Period Code which all items in the record set should be changed to (Link to Loan Period Codes (specifies how long an item can be loaned out) - see LoanPeriodCodeID column description in the CircItemRecords table). If the user didn't specify a change to the loan period code, this column will be NULL to indicate no change.
FineCodeID | int | This column will hold the value of the Fine Code which all items in the record set should be changed to (Used when an item needs to have a fine put on it (link to FineCodes table) - see FineCodeID column description in the CircItemRecords table). If the user didn't specify a change to the fine code, this column will be NULL to indicate no change.
RenewalLimit | int | This column will hold the value of the Renewal Limit which all items in the record set should be changed to (The number of times any particular patron is allowed to renew an item - see RenewalLimit column description in the ItemRecordDetails table). If the user didn't specify a change to the renewal limit, this column will be NULL to indicate no change.
Holdable | int | This column will indicate what the Holdable status (Yes or No) should be changed to for all items in the record set (Can the item be held for patrons? - see Holdable column description in the ItemRecordDetails table). If the user didn't specify a change to the holdable status, this column will be NULL to indicate no change.
LoanableOutsideSystem | int | This column will indicate what the "Loanable Outside Sytem" status (Yes or No) should be changed to for all items in the record set (Can this item be loaned to other libraries in the system? - see LoanableOutsideSystem column description in the ItemRecordDetails table). If the user didn't specify a change to the "loanable outside system" status, this column will be NULL to indicate no change.
ShelvingSchemeID | int | This column will hold the value of the Shelving Scheme which all items in the record set should be changed to (Link to shelving scheme table (coded values) - see ShelvingSchemeID column description in the ItemRecordDetails table). If the user didn't specify a change to the shelving scheme, this column will be NULL to indicate no change.
CallNumberPrefixChange | int | This column indicates whether or not a change to the Call Number Prefix was specified by the user. If the value is 1, a change was specified and the value to change to is found in the CallNumberPrefix column. If the value is 0, no change was specified.
CallNumberPrefix | nvarchar(60) | This column will hold the value of the Call Number Prefix which all items in the record set should be changed to (see CallNumberPrefix column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Call Number Prefix in all the items. This column will only be consulted when the CallNumberPrefixChange column is 1, indicating a change was specified.
ClassificationNumberChange | int | This column indicates whether or not a change to the Classification Number was specified by the user. If the value is 1, a change was specified and the value to change to is found in the ClassificationNumber column. If the value is 0, no change was specified.
ClassificationNumber | nvarchar(60) | This column will hold the value of the Classification Number which all items in the record set should be changed to (see ClassificationNumber column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Classification Number in all the items. This column will only be consulted when the ClassificationNumberChange column is 1, indicating a change was specified.
CutterNumberChange | int | This column indicates whether or not a change to the Cutter Number was specified by the user. If the value is 1, a change was specified and the value to change to is found in the CutterNumber column. If the value is 0, no change was specified.
CutterNumber | nvarchar(60) | This column will hold the value of the Cutter Number which all items in the record set should be changed to (see CutterNumber column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Cutter Number in all the items. This column will only be consulted when the CutterNumberChange column is 1, indicating a change was specified.
CallNumberSuffixChange | int | This column indicates whether or not a change to the Call Number Suffix was specified by the user. If the value is 1, a change was specified and the value to change to is found in the CallNumberSuffix column. If the value is 0, no change was specified.
CallNumberSuffix | nvarchar(60) | This column will hold the value of the Call Number Suffix which all items in the record set should be changed to (see CallNumberSuffix column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Call Number Suffix in all the items. This column will only be consulted when the CallNumberSuffixChange column is 1, indicating a change was specified.
VolumeNumberChange | int | This column indicates whether or not a change to the Volume Number was specified by the user. If the value is 1, a change was specified and the value to change to is found in the VolumeNumber column. If the value is 0, no change was specified.
VolumeNumber | nvarchar(60) | This column will hold the value of the Volume Number which all items in the record set should be changed to (see VolumeNumber column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Volume Number in all the items. This column will only be consulted when the VolumeNumberChange column is 1, indicating a change was specified.
CopyNumberChange | int | This column indicates whether or not a change to the Copy Number was specified by the user. If the value is 1, a change was specified and the value to change to is found in the CopyNumber column. If the value is 0, no change was specified.
CopyNumber | nvarchar(60) | This column will hold the value of the Copy Number which all items in the record set should be changed to (see CopyNumber column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Copy Number in all the items. This column will only be consulted when the CopyNumberChange column is 1, indicating a change was specified.
PublicNote | nvarchar(255) | This column will hold the value that will be applied to the existing Public Note value for all items in the record set (Note not displayed to public - necessary actions needed to be taken on an item - see PublicNote column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Public Note in all the items. This column will only be consulted when the PublicNoteMode column is not NULL, indicating a change was specified.
PublicNoteMode | int | This column indicates whether or not a change to the Public Note was specified by the user and, if so, in what way the change will be applied. The existing Public Note will be replaced (value = 0), prepended to (value = 1), or appended to (value = 2) using the value in the PublicNote column. A NULL value means no change was specified.
NonPublicNote | nvarchar(255) | This column will hold the value that will be applied to the existing Non Public Note value for all items in the record set (Is a text field for the user to enter descriptive information - see NonPublicNote column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Non Public Note in all the items. This column will only be consulted when the NonPublicNoteMode column is not NULL, indicating a change was specified.
NonPublicNoteMode | int | This column indicates whether or not a change to the Non Public Note was specified by the user and, if so, in what way the change will be applied. The existing Non Public Note will be replaced (value = 0), prepended to (value = 1), or appended to (value = 2) using the value in the NonPublicNote column. A NULL value means no change was specified.
PhysicalCondition | nvarchar(255) | This column will hold the value that will be applied to the existing Physical Condition value for all items in the record set (see PhysicalCondition column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Physical Condition in all the items. This column will only be consulted when the PhysicalConditionMode column is not NULL, indicating a change was specified.
PhysicalConditionMode | int | This column indicates whether or not a change to the Physical Condition was specified by the user and, if so, in what way the change will be applied. The existing Physical Condition will be replaced (value = 0), prepended to (value = 1), or appended to (value = 2) using the value in the PhysicalCondition column. A NULL value means no change was specified.
FreeTextBlock | nvarchar(255) | This column will hold the value that will be applied to the existing Free Text Block value for all items in the record set (Why is the item blocked for loaning? - see FreeTextBlock column description in the CircItemRecords table). A value of NULL is taken to mean that the change is to clear the Free Text Block in all the items. This column will only be consulted when the FreeTextBlockMode column is not NULL, indicating a change was specified.
FreeTextBlockMode | int | This column indicates whether or not a change to the Free Text Block was specified by the user and, if so, in what way the change will be applied. The existing Free Text Block will be replaced (value = 0), prepended to (value = 1), or appended to (value = 2) using the value in the FreeTextBlock column. A NULL value means no change was specified.
AssociatedBibRecordID | int | This column will hold the value of the Associated Bib Record link which all items in the record set should be changed to (Bib record link - see AssociatedBibRecordID column description in the CircItemRecords table). If the user didn't specify a change to the associated bibliographic record link, this column will be NULL to indicate no change.
DisplayInPAC | int | This column will indicate what the "Display In PAC" status (Yes or No) should be changed to for all items in the record set (Whether or not the record can display in PAC - see DisplayInPAC column description in the ItemRecordDetails table). If the user didn't specify a change to the "display in PAC" status, this column will be NULL to indicate no change.
ParentItemRecordID | int | This column will hold the value of the Parent Item Record link which all items in the record set should be changed to (Some items have a parent - see ParentItemRecordID column description in the CircItemRecords table). If the user didn't specify a change to the parent item record link, this column will be NULL to indicate no change.
NameOfPieceChange | int | This column indicates whether or not a change to the Name Of Piece was specified by the user. If the value is 1, a change was specified and the value to change to is found in the NameOfPiece column. If the value is 0, no change was specified.
NameOfPiece | nvarchar(255) | This column will hold the value of the Name Of Piece which all items in the record set should be changed to (see NameOfPiece column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Name Of Piece in all the items. This column will only be consulted when the NameOfPieceChange column is 1, indicating a change was specified.
FundingSourceChange | int | This column indicates whether or not a change to the Funding Source was specified by the user. If the value is 1, a change was specified and the value to change to is found in the FundingSource column. If the value is 0, no change was specified.
FundingSource | nvarchar(50) | This column will hold the value of the Funding Source which all items in the record set should be changed to (see FundingSource column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Funding Source in all the items. This column will only be consulted when the FundingSourceChange column is 1, indicating a change was specified.
PriceChange | int | This column indicates whether or not a change to the Price was specified by the user. If the value is 1, a change was specified and the value to change to is found in the Price column. If the value is 0, no change was specified.
Price | money | This column will hold the value of the Price which all items in the record set should be changed to (The price of an item associated with the bib record- see Price column description in the ItemRecordDetails table). A value of NULL is taken to mean that the change is to clear the Price in all the items. This column will only be consulted when the PriceChange column is 1, indicating a change was specified.
HoldableByPickup | int | holdable only for pickup
HoldableByLibrary | int | holdable at the library level
HoldableByBranch | int | holdable at the branch level
NonCirculating | int | Non circulating flag data element
HoldableByPrimaryLender | int | holdable only for a preferred (primary) lender
ItemDoesNotFloat | int | Do not float flag
HomeBranchID | int | Item home branch
AssignedCollectionName | nvarchar(80) | The text string representing the collection to be changed to
ShelfLocationName | nvarchar(80) | The text string representing the shelf location to be changed to
StatisticalCodeName | nvarchar(80) | The text string representing the statistical code to be changed to
ItemBlockName | nvarchar(80) | The text string representing the item block to be changed to
DoNotMailToPatron | int | Flag to not mail an item to a patron for BBM holds processing
BulkItemChangeID | int | Primary key
PullCallNumberFromBibChange | int | Flag to tell bulk change to pull the call number from the bib record instead of the UI
HoldPickupBranchID | int | holdable for pickup only at this branch
AssignedCollectionAbbreviation | nvarchar(15) | The text string representing the collection to be changed to - the abbreviation of said collection


BulkItemChangeItemRecordBarcodes

BulkItemChangeItemRecordBarcodes Table

Barcodes that have been specified for item bulk change. These barcodes are added to items which don't already have barcodes.

Columns

Column name | Data type | Description
BulkItemChangeID | int | Primary key
Barcode | nvarchar(20) | Barcode
Precedence | int | Which item gets which barcode?


BulkItemChangeItemRecords

BulkItemChangeItemRecords Table

Item records that are specified when ad hoc bulk change is attempted from a list of item records.

Columns

Column name | Data type | Description
BulkItemChangeID | int | Primary key
ItemRecordID | int | Item Record ID
Precedence | int | Order of the item in the list


CallNumberHierarchies

CallNumberHierarchies Table

This table specifies the hierarchy which will be observed for determining where the call number will be taken out of a bibliographic record and used for an item record. These can vary according to the library, branch, and precedence which the library chooses to place on tags.

Columns

Column name | Data type | Description
OrganizationID | int | Organization for which particular scheme is used.
CallNumPrecedence | smallint | Ordinal value indicating the order of importance of this Tag/Subfield relative to others in the table with the same Name.
ShelvingSchemeID | int | Shelving scheme table link
BibTagNumber | int | MARC Bib Tag Number
ClassificationSubfields | nvarchar(10) | Subfields which are part of the classification number
CutterSubfields | nvarchar(10) | Subfields which are part of the cutter number
PrefixSubfields | nvarchar(10) | Subfields which are part of the call number prefix
SuffixSubfields | nvarchar(10) | Subfields which are part of the call number suffix
VolumeSubfields | nvarchar(10) | Subfields which are part of the volume number
CopySubfields | nvarchar(10) | Subfields which are part of the copy number


CampaignConcordance

CampaignConcordance Table

Contains one row for each distinct collocation composed keywords within a Campaign record

Columns

Column name | Data type | Description
CollocationID | int | A unique identifier for the row
LexicalContextTuple | varbinary | Compressed tuple of keyword/delimiter pairs.


CampaignConcordanceRadix

CampaignConcordanceRadix Table

Contains one row for each distinct code point at a given prefix-position within the concordance.

Columns

Column name | Data type | Description
NexusID | int | Unique identifier for the row.
ParentNexusID | int | Unique identifier for the parent row.
EdgeTransition | nchar | Distinct code point at a given prefix-position within the concordance.
SemanticHintTuple | varbinary | Compressed tuple of collocation hints.


CampaignKeywordIndex

CampaignKeywordIndex Table

Contains one row for each keyword indexed in a Campaign record.

Columns

Column name | Data type | Description
KeywordID | int | Is the Campaign keyword identifier.
RecordID | int | Identifies the Campaign record from which a keyword has been indexed.
TypeFlags | smallint | Identifies one or more keyword types; based on the data element from which the keyword was indexed.
TokenizedData | varbinary | Contains compressed binary data which includes the Significance, TypeFlags, ContractionCount, DelimiterClass, ChunkID and WordPosition for each occurrence of a keyword within a given record.


CampaignKeywordRules

CampaignKeywordRules Table

Contains one row for each Campaign keyword indexing rule. Each Campaign keyword indexing rule identifies a data element to be indexed and is identified by a unique tag/subfield pair

Columns

Column name | Data type | Description
TagNumber | smallint | Identifies the tag of a data field to be indexed. This column combined with the Subfield column is unique for each row.
Subfield | char | Identifies the subfield of a data element to be indexed. This column combined with the TagNumber column is unqiue for each row.
TypeFlags | smallint | Associates this rule with one or more Campaign keyword types. A keyword type is enabled if bit position POWER(2, TypeID - 1) is set to one, where TypeID must reference a row in the CampaignKeywordTypes table.
MinimumSignificance | real | Contains the minimum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
MaximumSignificance | real | Contains the maximum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
AverageTermCount | real | Contains the average term count for a given data element associated with a specific TagNumber and Subfield.
AverageTermCountStandardDeviation | real | Contains the standard deviation of the AverageTermCount for a given data element associated with a specific TagNumber and Subfield.


CampaignKeywords

CampaignKeywords Table

Contains one row for each distinct keyword found in a Campaign record.

Columns

Column name | Data type | Description
KeywordID | int | Unique identifier for the row.
Term | nvarchar(128) | Normalized term suitable for keyword and phrase searching. This column is unique for each row.
Weight | real | The IDF (inverse document frequency) weight associated with the term. The weight equals log((N + 1) / n), where N = total number of records and n = number of records containing one or more occurrences of the keyword.

See Also

CampaignKeywordIndex,


CampaignKeywordTypes

CampaignKeywordTypes Table

Contains one row for each Campaign keyword type. Each keyword type corresponds to a search access point and is associated with a subset of data elements.

Columns

Column name | Data type | Description
TypeID | tinyint | Unique identifier for the row.
Name | nvarchar(100) | Unique name for the row.
Mnemonic | nvarchar(32) | Search qualifier name.
MinimumDegradation | float | Contains the minimum degradation applied to the relevance of a collocation composed of multiple keywords.
MaximumDegradation | float | Contains the maximum degradation applied to the relevance of a collocation composed of multiple keywords.


CampaignLinkageTypes

CampaignLinkageTypes Table

A table that defines the type of record associated with the campaign.

Columns

Column name | Data type | Description
CampaignLinkageTypeID | tinyint | A unique identifier
Name | nvarchar(255) | The name of the linkage type

See Also

PromotionCampaigns,


CashDrawer_ClientTxnInfo

CashDrawer_ClientTxnInfo Table

When a payment is submitted using integrated POS technology, the Polaris transaction info is stored here.

Columns

Column name | Data type | Description
ChargeTxnID | int | The Polaris charge txn ID
PolarisUserID | int | The Polaris user's ID
WorkstationID | int | The Polaris workstation ID
LogonBranchID | int | The Polaris user's logon branch


CashDrawer_ClientTxnInfoHistory

CashDrawer_ClientTxnInfoHistory Table

History table for logging CLASS POS transaction data

Columns

Column name | Data type | Description
ChargeTxnID | int | The charge to be paid
PolarisUserID | int | Polaris User
WorkstationID | int | Workstation
LogonBranchID | int | Logon Branch
InsertionDate | datetime | Date inserted


CashDrawer_DisablePOSLaunch

CashDrawer_DisablePOSLaunch Table

A table that is used as an override for POS integration. If a workstation appears in this table, even if CLASS POS is installed on the client, the POS software will not be used in the integration.

Columns

Column name | Data type | Description
WorkstationID | int | Polaris workstation ID


CashDrawer_Payments

CashDrawer_Payments Table

This table is used to record patron account transactions submitted by Class software.

Columns

Column name | Data type | Description
ClassTxnPK | nvarchar(20) | Class primary key
PatronID | int | Polaris Patron ID
TxnAmount | money | amount of transaction
PaymentMethod | int | method of payment
TransactionType | int | type of transaction - pay or void
TransactionDate | datetime | date of transaction
ComputerName | nvarchar(32) | computer name
UserName | nvarchar(50) | name of user
ChargeTxnID | int | The Polaris charge transaction submitted to POS


CashDrawer_PaymentsHistory

CashDrawer_PaymentsHistory Table

This table is used to record patron account transaction history submitted by Class software.

Columns

Column name | Data type | Description
ClassTxnPK | nvarchar(20) | Class primary key
PatronID | int | Polaris Patron ID
TxnAmount | money | amount of transaction
PaymentMethod | int | method of payment
TransactionType | int | type of transaction - pay or void
TransactionDate | datetime | date of transaction
PolarisTxnID | int | polaris patron transaction ID
PolarisTxnDate | datetime | polaris patron transaction date
ComputerName | nvarchar(32) | computer name
UserName | nvarchar(50) | name of user
ChargeTxnID | int | The Polaris charge transaction submitted to POS


CatalogingServicesInstr

CatalogingServicesInstr Table

Cataloging services instructions are instructions to the supplier about what cataloging services are requested. Values entered in this table must exist in PolAcqServer/Acquisitons.h as part of the enumerated type AE_CatServInstr.

Columns

Column name | Data type | Description
CatServInstrID | int | Integer value used to link Cataloging Services Instructions to a Purchase Order or Purchase Order Line Item.
CatServInstr | nvarchar(70) | Please see the Polaris.Acquisitions/Serials functional sepcifications Section 13 for list a of pre-defined cataloging services instructions.
BISACCode | nvarchar(3) | The BISAC standard code for the pre-defined values used in Polaris.

See Also

POLines, PurchaseOrders,


CatPurgeCriterias

CatPurgeCriterias Table

table that holds the contents of Cataloging Purge Criteria records. It consists of links to record sets as well as specific record types to be purged. Records to be purged can be set for a specifc date (when the job will be run) and in the case of specific record types a range of deleted status dates.

Columns

Column name | Data type | Description
RecordID | int | Primary key for the Purge Criteria record.
Name | nvarchar(255) | Searchable, name of the Purge Criteria record.
OrgID | int | Organization ID that owns the record types to be deleted. DOES NOT APPLY TO RECORD SET OR AUTHORITY RECORD PURGES.
AuthFlag | bit | determines if Authority records are to be purged when the criteria is executed.
BibFlag | bit | determines if Bibliographic records are to be purged when the criteria is executed.
ItemFlag | bit | determines if Item records are to be purged when the criteria is executed.
RecordSetID | int | Foreign key to RecordSets table, when a Recordset is scheduled to be purged.
BeginDate | datetime | start of record status dates to be deleted as part of the purge processing.
EndDate | datetime | end of record status dates to be deleted as part of the purge processing.
ScheduledDate | datetime | Date at which the Purge Criteria is to be executed. The actual job can be run on or after that scheduled date, but a given criteria will only be run once. The criteria must then be re-scheduled.
LastRunDate | datetime | date and time that the Purge Criteria was last run.
CreatorID | int | Polaris User ID of the logged in account that created teh Purge Criteria record.
CreationDate | datetime | date that the Purge Criteria record was created.
ModifierID | int | Polaris User ID of the logged in account that last modified the Purge Criteria record.
ModificationDate | datetime | date and time that the Purge Criteria record was last modified.
OwningOrgID | int | Organizaton ID that owns the Purge Criteria record.
RecordSetType | tinyint | integer field storing the cataloging record type ID for the record to be purged. 1 = Authority 2 = Bibliographic 3 = Item


Cat_BulkBibChange_00XChanges

Cat_BulkBibChange_00XChanges Table

Bulk Bib Change: This table records all bibliographic records affected by a control field bulk change

Columns

Column name | Data type | Description
JobID | int | Bulk Bib Change job identifier (reference to Cat_BulkBibChange_Queue.JobID, but no foreign key constraint)
BibID | int | Bibliographic Record ID (no foreign key constraint, though) of the affected bib
Phase | int | Numeric value representing which phase of the Bulk Bib Change process caused the change (internal usage)


Cat_BulkBibChange_BibProvisionalSaves

Cat_BulkBibChange_BibProvisionalSaves Table

This table is utilized during a Bulk Bib Change job to keep track of provisional bibliographic records involved in the process.

Columns

Column name | Data type | Description
JobID | int | Bulk bib change job identifier
BibRecordID | int | Bibliographic record identifier of a provisional bib involved in the bulk change job.
BibTagID | int | Foreign key reference to BibliographicTags table


Cat_BulkBibChange_BrokenLinks

Cat_BulkBibChange_BrokenLinks Table

Bulk Bib Change: This table collects all authority record ids for those bibliographic subfields affected by a bulk change which resulted in the authority link being 'broken'

Columns

Column name | Data type | Description
JobID | int | Bulk Bib Change job identifier (reference to Cat_BulkBibChange_Queue.JobID, but no foreign key constraint)
AuthorizingRecordID | int | The BibliographicSubfields.AuthorizingRecordID value that represented the authority link before the bulk change process caused a change that 'broke' the link (not a foreign key constraint)


Cat_BulkBibChange_DFChanges

Cat_BulkBibChange_DFChanges Table

Bulk Bib Change: This table records all data field changes specified for a bulk bib change job (on the 'Data Fields' tab of the UI dialog)

Columns

Column name | Data type | Description
JobID | int | Bulk Bib Change job identifier (reference to Cat_BulkBibChange_Queue.JobID, but no foreign key constraint)
ExecutionOrder | int | The relative order in which to execute this particular data field change for a given bulk change job
OperationID | int | Data field operation identifier (foreign key reference to the Cat_BulkBibChange_DFOperations.OperationID column)
TagNumber | int | The tag number that is targeted by this particular data field change (used for all data field changes except the non-filing indicator operation)
AltTagNumber | int | The tag number value to change an existing tag 'to' for a tag number change data field operation. This effectively deletes that tag whose number gets changed and inserts a whole new tag to replace it.
IndicatorOne | char | The original single-character value of a tag's first indicator to be used as part of the criteria for a data field change
IndicatorTwo | char | The original single-character value of a tag's second indicator to be used as part of the criteria for a data field change
StatCount | int | This column is filled in by the bulk bib change job to record the number of bibliographic records affected by this particular data field change (for the report)
Description | nvarchar(255) | Description of the data field change specified (for the report)
AltIndicatorOne | char | The single-character value to change a tag's first indicator value 'to' for an indicator change data field operation.
AltIndicatorTwo | char | The single-character value to change a tag's second indicator value 'to' for an indicator change data field operation.
DeleteOnlyTag | bit | This column is a flag that signifies whether or not a single instance of a tag should still be deleted for the tag deletion data field operations.
CycleCompleted | int | This indicates what 'chunk' of records is currently being operated on. Increments after each data field change is applied.


Cat_BulkBibChange_DFOperations

Cat_BulkBibChange_DFOperations Table

Bulk Bib Change: This static table contains the string descriptions of all the data field change operations available to be specified on the UI dialog

Columns

Column name | Data type | Description
OperationID | int | Unique identifier value for a data field operation
Description | nvarchar(80) | String description of a data field operations to be displayed in the combo-box control of operations on the 'Data Fields' tab of the dialog UI
DisplayOrderID | int | Display order
Mnemonic | nvarchar(100) | WebAdmin mnemonic string that allows for multilingual configuration of a category name

See Also

Cat_BulkBibChange_DFChanges,


Cat_BulkBibChange_DFSubfields

Cat_BulkBibChange_DFSubfields Table

Bulk Bib Change: This table is used in conjunction with Cat_BulkBibChange_DFChanges and will specify the subfield information associated with a particular data field change (if needed)

Columns

Column name | Data type | Description
JobID | int | Bulk Bib Change job identifier (reference to Cat_BulkBibChange_Queue.JobID, but no foreign key constraint)
ExecutionOrder | int | The relative order that the associated data field change is to be executed (maps to the 'linked' Execution Order value in Cat_BulkBibChange_DFChanges)
SubfieldOrder | int | Relative subfield order for this particular data field change (grouped by the JobID/ExecutionOrder comination)
SubfieldCode | char | Relative subfield order for this particular data field change (grouped by the JobID/ExecutionOrder comination)
SubfieldData | nvarchar(4000) | The actual subfield data (Unicode)


Cat_BulkBibChange_Exceptions

Cat_BulkBibChange_Exceptions Table

Bulk Bib Change: This table holds all exception conditions found during the execution of a particular bulk change job (used for the report)

Columns

Column name | Data type | Description
JobID | int | Bulk Bib Change job identifier (reference to Cat_BulkBibChange_Queue.JobID, but no foreign key constraint)
BibID | int | The bibliographic record identifier of the bib involved in the exception (foreign key reference to BibliographicRecords.BibliographicRecordID)
AuthID | int | The authorizing record id involved in a broken link exception (foreign key reference to AuthorityRecords.AuthorityRecordID)
Title | nvarchar(255) | The browse title value of the bibliographic record involved in the exception
Author | nvarchar(255) | The browse author value for the bibliographic record involved in the exception
Reason | nvarchar(255) | The description of the exception
TagRep | nvarchar(1000) | A string representation of the bibliographic tag involved in the exception
Status | int | An internal code that represents the type of exception


Cat_BulkBibChange_FieldLevel00X

Cat_BulkBibChange_FieldLevel00X Table

Bulk Bib Change: This table holds all individual control field tag changes specified on the 006/007/008 tabs of the UI dialog

Columns

Column name | Data type | Description
JobID | int | Bulk Bib Change job identifier (reference to Cat_BulkBibChange_Queue.JobID, but no foreign key constraint)
TagNumber | int | The 00X tag number invovled in the change (6, 7, or 8)
MARCFixedFieldTagType | int | Tag type code for the control field tag being changed (eg. 008-BOOK (3), 007-MICROFORM (21), 006-MUSIC (8))
StartPosition | int | The 0-based position that represents the first character of the field being changed
FieldLength | int | The length of the actual tag field being changed
FromValue | nvarchar(7) | The original value of the field (for a conditional change - must match this value to qualify for the change)
ToValue | nvarchar(7) | The new value of the field (the value to change 'to')
StatCount | int | This column is filled in by the bulk bib change job to record the number of bibliographic records affected by this particular control field change (for the report)
Description | nvarchar(255) | Description of the control field change specified (for the report)
CycleCompleted | int | This indicates what 'chunk' of records is currently being operated on. Increments after each field level change is applied.


Cat_BulkBibChange_Leader

Cat_BulkBibChange_Leader Table

Bulk Bib Change: This table contains specifications for changes to the Leader (00) tag

Columns

Column name | Data type | Description
JobID | int | Bulk Bib Change job identifier (reference to Cat_BulkBibChange_Queue.JobID, but no foreign key constraint)
Pos | int | The actual leader position being changed (5, 6, 7, 8, 9, 17, 18, or 19)
FromChar | char | The original value of the particular leader position being changed (for a conditional change - the original value must match this value for the change to be applied)
ToChar | char | The value to change the leader position 'to'
StatCount | int | This column is filled in by the bulk bib change job to record the number of bibliographic records affected by this particular leader change (for the report)
Description | nvarchar(255) | Description of the leader tag change specified (for the report)
CycleCompleted | int | This indicates what 'chunk' of records is currently being operated on. Increments after each leader change is applied.


Cat_BulkBibChange_Modifications

Cat_BulkBibChange_Modifications Table

Bulk Bib Change: This table is used internally by the Bulk Change process to collect all bib and tag information for those tags that qualify for a particular data field change.

Columns

Column name | Data type | Description
JobID | int | Bulk Bib Change job identifier (reference to Cat_BulkBibChange_Queue.JobID, but no foreign key constraint)
BibID | int | Bibliographic record id involved (foreign key reference to BibliographicRecords.BibliographicRecordID)
TagID | int | Bibliographic tag ID involved
TagNumber | int | Tag number of the tag involved in the change
ExecOrder | int | Data field execution order for this job (maps to Cat_BulkBibChange_DFChanges.ExecOrder)
SaveCode | int | Save code for the BibSaves table row (BibSaves.BibSaveCode)


Cat_BulkBibChange_NonMARC

Cat_BulkBibChange_NonMARC Table

Bulk Bib Change: This table holds the specification of a Display-In-PAC change and/or a record owner change from the bulk change UI dialog

Columns

Column name | Data type | Description
JobID | int | Bulk Bib Change job identifier (reference to Cat_BulkBibChange_Queue.JobID, but no foreign key constraint)
DisplayInPAC | int | The Display-In-PAC value to change the records to (on/off)
DIPStatCount | int | This column is filled in by the bulk bib change job to record the number of bibliographic records affected by the Display-In-PAC change (for the report)
DIPDescription | nvarchar(255) | Description of the Display-In-PAC change (for the report)
OwnerFrom | int | The original value of the record owner; An organization ID value (for a conditional owner change - the bib must have this owner value for the change to be applied)
OwnerTo | int | The owner (organization ID) to change the record(s) to
OwnerStatCount | int | This column is filled in by the bulk bib change job to record the number of bibliographic records affected by the owner change (for the report)
OwnerDescription | nvarchar(255) | Description of the owner change (for the report)
CycleCompleted | int | This indicates what 'chunk' of records is currently being operated on. Increments after each non-MARC change is applied.
SaveAsFinal | int | Indicates whether or not the user specified to save 'as final' any provisional bib records found in the record set for which a Bulk Bib Change job is being performed.
SaveAsFinalCount | int | This field will hold a statistical count of the number of provisional records that were saved 'as final' during the Bulk Bib Change process. This count will be displayed in the report.
ResourceEntityVendorAccountID | int | The vendor account for which resource entities are being created
ResourceEntityCount | int | Number of resource entites created in a bulk change job
ResourceEntityDescription | nvarchar(255) | The resource entity action being taken
ResourceEntityCycleCompleted | int | This indicates what 'chunk' of records is currently being operated on. Increments after each non-MARC change is applied.
DoNotOverlay | int | Yes/No flag that allows or prohibits this record from being overlaid
DoNotOverlayStatCount | int | Number of records affected by this change
DoNotOverlayDescription | nvarchar(255) | Do not overlay change description (for reporting)


Cat_BulkBibChange_Queue

Cat_BulkBibChange_Queue Table

Bulk Bib Change: This table holds the high-level information associated with a specific Bulk Bib Change job queue submission

Columns

Column name | Data type | Description
JobID | int | An identity column that uniquely identifies a particular bulk bib job queue submission
TotalCount | int | The total number of records in the record set; This column will be filled in at the start of Phase 1 of the bulk change job process before any filtering is done
TotalEligible | int | The total number of records from the record set to apply the changes to; This column will be filled in at the end of Phase 1 of the bulk change job process after filtering out locked, deleted, illegal records from the record set
ModifierID | int | The user ID that submitted the job; Used for object lock setting (foreign key reference to PolarisUsers.PolarisUserID)
OrganizationID | int | The organization ID associated with the user that submitted the job; Used for posting transactions and MARC sorting (foreign key reference to Organizations.OrganizationID)
WorkstationID | int | Workstation ID associated with the user that submitted the job; Used for posting transactions (foreign key reference on Workstations.WorkstationID)
TimePosted | datetime | This column holds the time that the job was initially posted to the queue (the creation date of this row)
StartTime | datetime | This column is filled in by the Bulk Bib Change process when this job starts being processed
EndTime | datetime | This column is filled in by the Bulk Bib Change process when it completes the job
ReadyToRun | bit | This flag (initially 'off') indicates that the job represented is ready to be executed (there is a time gap between this row creation and the insertion of all the UI specifications; this flag will get turned 'on' once all the specs are entered)
PhaseCompleted | int | This column is filled in by the Bulk Bib Change job process as it completes each phase of the job (for restarting an interrupted job from where it left off; also for displaying the progress of a job on the job queue window)
Cycle | int | Indicates which Cycle (or 'chunk' of records) the bulk bib change job is currently in.
RSName | nvarchar(100) | Name of the record set associated with the bulk change job.
RSOwner | nvarchar(50) | Record set owner associated with the bulk change job.

See Also

Cat_BulkBibChange_00XChanges, Cat_BulkBibChange_BibProvisionalSaves, Cat_BulkBibChange_BrokenLinks, Cat_BulkBibChange_DFChanges, Cat_BulkBibChange_DFSubfields, Cat_BulkBibChange_Exceptions, Cat_BulkBibChange_FieldLevel00X, Cat_BulkBibChange_Leader, Cat_BulkBibChange_Modifications, Cat_BulkBibChange_NonMARC, Cat_BulkBibChange_RecordSetChunk, Cat_BulkBibChange_RecordSetSnapShot, Cat_BulkBibChange_TagLevel00X,


Cat_BulkBibChange_RecordSetChunk

Cat_BulkBibChange_RecordSetChunk Table

This table holds fixed-size subset of the set of records to be changed during a bulk bibliographic change job. The job will apply the changes to this set of bibs, then the table will be cleared and the next 'chunk' of records will populate it.

Columns

Column name | Data type | Description
JobID | int | Bulk bib change job identifier.
BibID | int | Bibliographic record identifier of a bib in the current 'chunk' of records.


Cat_BulkBibChange_RecordSetSnapShot

Cat_BulkBibChange_RecordSetSnapShot Table

This table holds a copy of the set of bibliographic records in the record set to apply the changes to. It is populated at the time the job is submitted and is not affected by changes to the original record set in the interim between job submission and execution.

Columns

Column name | Data type | Description
JobID | int | Bulk bib change job identifier
BibID | int | Bibliographic record identifier of a bib in the original record set.


Cat_BulkBibChange_TagLevel00X

Cat_BulkBibChange_TagLevel00X Table

Bulk Bib Change: This table holds tag-level control field tag changes (deletions, insertions, replacements) as specified on the bulk bib change UI dialog

Columns

Column name | Data type | Description
JobID | int | Bulk Bib Change job identifier (reference to Cat_BulkBibChange_Queue.JobID, but no foreign key constraint)
TagNumber | int | The tag number to be affected by the change (6, 7, or 8); 008 tags can not be inserted/deleted, only replaced
MARCFixedFieldTagType | int | Tag type code for the control field tag being deleted/inserted/modified (eg. 008-BOOK (3), 007-MICROFORM (21), 006-MUSIC (8))
Operation | int | Indicates whether an insertion, deletion or a replacement is being specified
Scope | int | Indicates whether the operation applies to the 1st instance of a tag, the last instance, or all instances
NewValue | nvarchar(255) | For insertions and replacements, the new tag in its entirety
StatCount | int | This column is filled in by the bulk bib change job to record the number of bibliographic records affected by the tag-level change (for the report)
Description | nvarchar(255) | Description of the tag-level change (for the report)
CycleCompleted | int | This indicates what 'chunk' of records is currently being operated on. Increments after each Tag Level 00X change is applied.


Cat_BulkBibChange_ValidLeaderChars

Cat_BulkBibChange_ValidLeaderChars Table

Bulk Bib Change: This is a static table that holds the string of all valid characters for each of the 8 leader position values that can be changed; This is used when a leader position change wants to change 'All Illegal Values' to a valid value

Columns

Column name | Data type | Description
LeaderPosition | int | The 0-based leader tag position (5, 6, 7, 8, 9, 17, 18, or 19)
ValidCharacters | nvarchar(100) | The string of valid character values for the leader tag position


Cat_NonFilingIndicators_Bib

Cat_NonFilingIndicators_Bib Table

This is a static table that holds all Tag Number / Indicator combinations that the non-filing indicator change Bulk Bib Change data field operation will apply to

Columns

Column name | Data type | Description
TagNumber | int | The tag number having a non-filing indicator
Indicator | int | Either 1 or 2, the indicator involved in combination with the tag number that is a non-filing indicator


ChainedJobs

ChainedJobs Table

Contains the job names to include in the Chained Jobs process and which order they should be run in.

Columns

Column name | Data type | Description
JobName | sysname | Name of SQL job.
RunOrder | int | The order in which the included jobs are run.


ChangeAddress

ChangeAddress Table

Patron address change information

Columns

Column name | Data type | Description
ChangeAddressID | int | changed address ID
PatronID | int | Link to Patron who's address change we are dealing with
AddressID | int | Address label
FreeTextLabel | nvarchar(30) | Free text field
StreetOne | nvarchar(32) | Street One portion of address
StreetTwo | nvarchar(32) | Second street field for address
City | nvarchar(32) | City address
State | nvarchar(32) | State portion of address
PostalCode | nvarchar(32) | Postal (zip) code portion of address
County | nvarchar(32) | County portion of address
Country | nvarchar(32) | Country portion of address


ChangeBasicInfo

ChangeBasicInfo Table

patron basic information

Columns

Column name | Data type | Description
ChangeBasicInfoID | int | unique id
PatronID | int | patron ID
ResponsibleID | nvarchar(14) | ID of basic information
PhoneVoice | nvarchar(20) | phone voice message
EmailAddress | nvarchar(64) | patron email address
AddressMonthly | nvarchar(30) | address for monthly statement
AddressNotices | nvarchar(30) | address for notices and bills
AddressServices | nvarchar(30) | address for services


CheckOutDisplayOptions

CheckOutDisplayOptions Table

This tables stores all the avaible fields that can be selected to display in the check-out list view.

Columns

Column name | Data type | Description
OptionID | tinyint | Identical ID of the data field.
OptionName | nvarchar(100) | Description of the data field.

See Also

SA_CheckOutDisplayOrder,


ChildPAC_Categories

ChildPAC_Categories Table

This table holds search categories used by the Children's PAC

Columns

Column name | Data type | Description
CategoryID | int | Unique identifier (primary key)
ParentCategoryID | int | A link to a parent category, defining a hierarchy of categories and sub-categories (foreign key of ChildPAC_Categories)
IconFileName | nvarchar(255) | The graphical image/icon file that will be displayed on the Children's PAC interface next to this category (The assigned Theme defines the Image Path directory to look in for this file)
ToolTipPreview | bit | Indicates whether a Tooltip is displayed when the cursor hovers over the category
DisplayNameStringID | int | The ID used to link to the MultiLingualStrings table, in order to get the proper translation for the Display Name
DisplayMessageStringID | int | The ID used to link to the MultiLingualStrings table, in order to get the proper translation for the Display Message

See Also

ChildPAC_Categories, ChildPAC_SearchTargets,


ChildPAC_CollectionLimits

ChildPAC_CollectionLimits Table

Lists the collections (per organization) used to help create the default search limits for the CPAC. Used in conjunction with SA_GetChildPACSearchLimit.

Columns

Column name | Data type | Description
OrganizationID | int | The organization that a group of collections are associated with to help create the default search limit for the CPAC.
CollectionID | int | A collection that this organization uses to help create the default search limit for the CPAC.


ChildPAC_SearchTargetData

ChildPAC_SearchTargetData Table

This table holds the actual data needed to perform the search in the Children's PAC for a given search target

Columns

Column name | Data type | Description
SearchTargetDataID | int | Unique identifier (primary key)
SearchTargetID | int | The search target for which the data in this row will apply to (foreign key of ChildPAC_SearchTargets)
Value | nvarchar(255) | Actual string data for the target (Search and URL types have only one row of data, Bib types can have more than one)


ChildPAC_SearchTargets

ChildPAC_SearchTargets Table

This table holds all Children's PAC searches that are defined under a particular category

Columns

Column name | Data type | Description
SearchTargetID | int | Unique identifier (primary key)
ParentCategoryID | int | The category that the search target is defined for (primary key of ChildPAC_Categories)
SearchTargetTypeID | int | The type of search target this is (Search, URL, or Bib) (foreign key of ChildPAC_SearchTargetTypes)
IconFileName | nvarchar(255) | String file name of the icon to be displayed for this target
DisplayNameStringID | int | The ID used to link to the MultiLingualStrings table, in order to get the proper translation for the Display Name
IconDisplayNameStringID | int | The ID used to link to the MultiLingualStrings table, in order to get the proper translation for the Icon Display Name

See Also

ChildPAC_SearchTargetData,


ChildPAC_SearchTargetTypes

ChildPAC_SearchTargetTypes Table

This table holds the various type of Children's PAC search targets

Columns

Column name | Data type | Description
SearchTargetTypeID | int | Unique identifier (primary key)
Description | nvarchar(255) | The name of the target type (not used, just for descriptive purposed in this table)

See Also

ChildPAC_SearchTargets,


CircItemRecords

CircItemRecords Table

This table contains item record information which is used heavily in circulation (transaction processing intensive data)

Columns

Column name | Data type | Description
ItemRecordID | int | Is the primary key for items - internal id number
Barcode | nvarchar(20) | For circulation, the item must have a barcode
ItemStatusID | int | The circulation status of the item (IN, Transit, OUT, etc.)
LastCircTransactionDate | datetime | The date when the item was last circulated
AssociatedBibRecordID | int | Bib record link (all items must have one)
ParentItemRecordID | int | Some items have a parent (things like items in a kit, etc.)
RecordStatusID | int | Link to record status table (final, provisional)
AssignedBranchID | int | The branch the item is assigned to
AssignedCollectionID | int | The collection the item is assigned to
MaterialTypeID | int | Link to Material types table (all items have an associated type)
LastUsePatronID | int | The ID of the Patron who last had the item is stored here (link to Patron table)
LastUseBranchID | int | The branch which last did some sort of processing with the item.
YTDCircCount | int | The circulation count for the current year
LifetimeCircCount | int | The lifetime circulation total
YTDInHouseUseCount | int | The year to date access count of an item (non-circulating)
LifetimeInHouseUseCount | int | The lifetime access count of an item (non-circulating)
FreeTextBlock | nvarchar(255) | Why is the item blocked for loaning?
ManualBlockID | int | Link to Manual blocks table (can prevent circulation of item)
FineCodeID | int | Used when an item needs to have a fine put on it (link to FineCodes table)
LoanPeriodCodeID | int | Link to Loan Period Codes (specifies how long an item can be loaned out)
StatisticalCodeID | int | Link to Statistical codes table
ShelfLocationID | int | Link to shelf locations table
ILLFlag | bit | This flag indicates whether or not this item record is used for ILL.
DisplayInPAC | bit | Whether or not the record can display in PAC. (This column is a copy of the column with the same name in ItemRecordDetails and maintained via Triggers on the ItemRecordDetails table.)
RenewalLimit | int | The number of times any particular patron is allowed to renew an item
Holdable | bit | Can the item be held for patrons?
HoldableByPickup | bit | This is a restriction option. If this is set, then it implies that this item will be used for fulfilling a hold request only if the pickup branch and item's assigned branch are the same.
HoldableByBranch | bit | This is a restriction option. If this is set, then it implies that this item will be used for fulfilling a hold request only if the patron's branch and item's assigned branch are the same.
HoldableByLibrary | bit | This is a restriction option. If this is set, then it implies that this item will be used for fulfilling a hold request only if the patron's branch and item's assigned branch belong to the same library.
LoanableOutsideSystem | bit | Can this item be loaned to libraries outside the system?
NonCirculating | bit | This field denotes whether the item can be checked out and taken out of the library.
RecordStatusDate | datetime | date when the record's status was last changed. either from Provisional, Final or Deleted.
LastCircWorkstationID | int | Last workstation who performed a circ operation on this item.
LastCircPolarisUserID | int | Last polaris user who performed a circ operation on this item.
HoldableByPrimaryLender | bit | This is a restriction option. If this is set, then it implies that this item will be used for fulfilling a hold request only if the item's assigned branch's preferred lender list contains the pickup branch in the request.
OriginalCheckOutDate | datetime | If item's status is Lost or Claimed, this is its original checked out date.
OriginalDueDate | datetime | If item's status is Lost or Claimed, this is its original due date.
ItemStatusDate | datetime | The date the item status last changed
CheckInBranchID | int | The branch that the item was last checked in at
CheckInDate | datetime | The date the item was last checked in
InTransitSentBranchID | int | The branch that the item was sent in transit from
InTransitSentDate | datetime | The date the item was sent in-transit
InTransitRecvdBranchID | int | The branch that is supposed to receive the in-transit item
InTransitRecvdDate | datetime | The date the in-transit item was received
CheckInWorkstationID | int | The workstation where the item was last checked in at.
CheckInUserID | int | The Polaris user who last checked in the item
LastCheckOutRenewDate | datetime | The date the item was last checked out or renewed
ShelvingBit | bit | A field to tell us that the item should be in 'shelving' status
FirstAvailableDate | datetime | Date the item was first available in Polaris, used in the future for NewTitles job and RSS feeds specific to a particular branch.
LoaningOrgID | int | Organization from where item is currently or was most recently checked out.
HomeBranchID | int | Item home branch
ItemDoesNotFloat | bit | Item does not float flag
EffectiveDisplayInPAC | bit | Determines whether the item record should display in PAC. This column is automatically set to 1 when the RecordStatusID column equals 1 and the DisplayInPAC column equals 1 and the AssignedBranchID/ItemStatusID column pair does not exist in the PACSuppressionRules table.
DoNotMailToPatron | bit | Flag to not mail an item to a patron for BBM holds processing
ElectronicItem | bit | A flag to determine if an item is used for electronic purposes (E-book)
LastDueDate | datetime | The itme's due date when item was last checked out or renewed
ResourceEntityID | int | Foreign Key reference to ResourceEntities table
HoldPickupBranchID | int | holdable for pickup only at this branch
EffectiveItemStatusID | int | This computed column allows Shelving and Non-circulating item statuses to be correctly recognized since they are not ‘real’ statuses. This field is used by the PAC Suppress Item Display processing.
DelayedHoldsFlag | bit | Flag to signify if there is a Delayed Hold value for this item
DelayedNumberOfDays | int | Number of days to delay filling holds for patrons not belonging to the item's assigned branch past the first available date

See Also

BibCallNumberIndices, CircItemRecords, ILLRequests, ItemCheckouts, ItemRecordBranchCircCounts, ItemRecordDetails, ItemRecordHistory, ItemRecordHistoryDaily, ItemRecordNotifications, ItemRecordSets, ItemRecordSystemBlocks, ItemShelvingDate, LineItemSegmentToItemRecord, ORSPatronSelectionLists, PatronClaims, PatronReadingHistory, PrevYearItemsCirc, PrevYearItemsCircPerBranch, PrevYearReserveItemCourseCirc, PrevYearReserveItemsCirc, ReserveItemRecords, SysHoldItemRecordRTFPrimaryCycles, SysHoldItemRecordRTFSecondaryCycles, SysHoldItemRecordsRTFAvailable, SysHoldRequests,


CircReceiptOptions

CircReceiptOptions Table

This tables stores all the available fields that can be selected on a circulation receipt.

Columns

Column name | Data type | Description
OptionID | tinyint | Identical ID of the data field.
OptionName | nvarchar(100) | Description of the data field.
IsPatron | tinyint | Indicates whether this data is patron related data.
IsCheckOutPrintOption | bit | Bit flag to indicate whether or not the option in question is enabled for Printed receipts (1) or not (0). Displayed on the Parameters-->Patron Services-->Check-out: Receipt options SA dialog (1 = checked/enabled, 0 = unchecked/not enabled)
IsCheckOutEmailOption | bit | Bit flag to indicate whether or not the option in question is enabled for E-mail receipts (1) or not (0). Displayed on the Parameters-->Patron Services-->Check-out: Receipt options SA dialog (1 = checked/enabled, 0 = unchecked/not enabled)
IsCheckOutTXTOption | bit | Bit flag to indicate whether or not the option in question is enabled for TXT receipts (1) or not (0). Displayed on the Parameters-->Patron Services-->Check-out: Receipt options SA dialog (1 = checked/enabled, 0 = unchecked/not enabled)

See Also

SA_CheckOutReceiptSettings, SA_CircReceiptOptionSelections, SA_ItemsOutReceiptSettings,


CircUsageOptions

CircUsageOptions Table

This is a data table for displaying selection options for circulation operations.

Columns

Column name | Data type | Description
UsageOptionID | int | This column is a unique identifier for this Circ Usage Option.
Description | nvarchar(80) | Data: Receiving Assigned


ClaimActions

ClaimActions Table

contains pre-defined "actions" that can be linked to a claimed item from within acquisitions. The "action" describes what the library as done regarding the particular claimed item.

Columns

Column name | Data type | Description
ClmActionID | int | interger primary key for individual claim actions
ClmAction | nvarchar(100) | pre-defined claim action strings

See Also

ClaimHistories,


ClaimHistories

ClaimHistories Table

contains the claim histories for claim records within the Polaris Acquisitions subsystem

Columns

Column name | Data type | Description
ClaimID | int | interger primary key for each claim history entry.
HistoryDate | datetime | date and time that claim history entry was created.
UserID | int | interger PolarisUserID of the person that generated the claim history entry.
ClmActionID | int | integer key for linked "claim action" in ClaimActions table.
Quantity | int | number of items from linked purchase order line item or line item segment that were claimed.
ClmCycleNum | int | claim cycle number (1 - 5) that claim history entry is describing.


ClaimReasons

ClaimReasons Table

Claim reasons are what a library uses to tell a supplier the reason for which an item is being claimed.

Columns

Column name | Data type | Description
ClaimReasonID | int | Integer value used to link a Claim Reason with a Claim. Must be unique to this table.
ClaimReason | nvarchar(50) | The reason an item is claimed. Its pre-defined options are: issue(s) not received,no issues received on this order, damaged in transit, imperfect copy,previous claim; no response.

See Also

Claims,


Claims

Claims Table

The main table used by the Claiming process in Polaris. All the acquisition and serial claims are stored here in the same table.

Columns

Column name | Data type | Description
ClaimID | int | Unique, system assigned ID number for a Claim record.
ObjectId | int | ID number of purchase order line item record (POLines), serial issue/part or Standing Order Part (mfhdIssues) linked to this claim record.
ClaimReasonID | int | ID number of claim reason found in ClaimReasons table.
ClmCycNum | smallint | a number that indicates the particular claim for a particular copy, for example, first claim, second claim, third claim, etc. Polaris allows a maximum of 5 claims.
ClmNote | nvarchar(255) | a free-text note associated with a claim. Can be for internal use only, or, can be included on the claim that goes to the supplier.
ClmRespDate | datetime | the date on which a supplier’s claim response was received.
ClmRespNote | nvarchar(255) | a free text field for users to add a note regarding a response from the supplier to a claim for an item.
ClmStatusDate | datetime | The date on the claim status was entered.
CreationDate | datetime | System generated date & time that this record was created.
CreatorID | int | Polaris User ID of the that created this claim record.
ModifierID | int | Polaris User ID of user that last modified this record.
NumCopiesClaimed | smallint | Number of copies being claimed.
SupplierID | int | ID number of supplier to which the claim was sent.
ModificationDate | datetime | The date & time at which the claim record was last modified.
CALDate | datetime | Claim Alert List Date: the date, calculated by the system, that will cause a POLI to appear on the CLaim Alert List.
Reminder | bit | bit flag that displays in the Claim Alert List (CAL) when the item appears there.
PrintNotice | bit | bit flag that if set to 1, will cause a claim notice to be printed.
ObjectTypeId | int | Object Type ID of the object that links to the claim.


ClientApplicationLogs

ClientApplicationLogs Table

This table is used by LEAP's Polaris Application Logging Service.

Columns

Column name | Data type | Description
ClientApplicationLogID | int | Internal ID.
AccessToken | nvarchar(50) | Access token used by client to connect to the service.
AccessSecret | nvarchar(50) | Access secret used by client to connect to the service.
ClientIP | nvarchar(30) | Client IP address.
Url | nvarchar(255) | Url of code. Currently used to store the route.
ProductID | int | Polaris product ID
PolarisUserID | int | Polaris user ID
WorkstationID | int | Logged in workstation ID.
OrganizationID | int | logged in organization id
LogTimeStamp | datetime | time stamp of log message
LogType | int | type of log message
LogMsg | nvarchar(-1) | log message
Line | int | line in code file reporting the message
File | nvarchar(200) | Log file name (N/A indicates log data stored in database)


ClientHistory

ClientHistory Table

Used with a "stub" application to check and verify the client on the local machine (see the documentation for the Auto Install Application Stub)

Columns

Column name | Data type | Description
HistorySequence | int | UniqueID for entry
ClientType | nvarchar(50) | AP = ActivePAC, TC = TechClient, WC = WebClient
ServerVersion | nvarchar(50) | What server version is needed for this client entry(ServerHistory) eg) 1.7.1290
ClientVersion | nvarchar(50) | Current Version of the Client eg) 1.7.68
ClientComment | nvarchar(255) | A comment about the entry in the table
LastUpdateUser | nvarchar(50) | Who added the entry
LastUpdateDate | datetime | When did they add it!


ClientUpgradeHistory

ClientUpgradeHistory Table

Log Successful client installs, both upgrade and new install

Columns

Column name | Data type | Description
UpgradeSequence | int | a running count of rows in table. Primary Key.
ClientType | nvarchar(50) | What client was updated / installed
ClientMachineName | nvarchar(50) | Machine name of the updated / installed client
ClientOrgID | int | OrganizationID of the updated / installed client
ClientWsID | int | WorkstationID of the updated / installed client
ClientUpgraded | char | If client was upgraded successful then log [Y] here else [N]
ClientUpgradeDate | datetime | If client was upgraded then log Date here.
ClientInstalled | char | If client was installed successful then log [Y] here else [N]
ClientInstalledDate | datetime | If client was installed then log Date here.


cnv_AuthFixTable

cnv_AuthFixTable Table

A table used by conversion services to track the processing status of each new authority record. This table is used by the ConvertMARC program.

Columns

Column name | Data type | Description
AuthorityRecordID | int | The Polaris Authority Record ID
Flag005 | bit | Flag used in adding a default 005 to the authority record. 0 indicates an 005 does NOT need to be added. 1 indicates an 005 needs to be added
Flag008 | bit | A flag to indicate a defualt 008 needs to be added to the authority record. 1 indicates an 008 needs to be added. 0 indicates no 008 needs to be added
FlagDel | bit | A flag to indiated that the MARC record status is 'd'... deleted. 1 indicates the record has the status of 'd'. 0 indictaes the record does NOT have the status of 'd'.
Flag001 | bit | Flag used in in moving the current 001 t0 an 035a. 0 indicates an 001 does NOT exist. 1 indicates an 001 exists.
FlagDup001 | bit | Indicates the record has more than one 001 tag. Duplicates are removed, the first 001 is preserved.
Flag008Long | bit | A flag to indicate that the 008 is either longer tha fourty characters, or shorter than fourty characters. 0 indicates thart the tag is equal to fourty characters. 1 indicates that the tag needs to be trucated or elongated.
FlagNormalize | bit | Indicates that the record has been normalized.
FlagIndex | bit | Indicates the record has been indexed.
FlagMap | bit | Indicates thae record has been mapped using the AuthTemp table.
FlagFixIndicators | bit | Indicators have been fixed (optional)


cnv_AuthOptions

cnv_AuthOptions Table

A table used by conversion services to track the options selected by the user in the ConverMarc program. Used in the case a restart of conversion processing is needed.

Columns

Column name | Data type | Description
TagLocalCtrl | int | The tag holding the old system control number.
SubLocalCtrl | char | The subfield containing the local control number (if any).
DelRecs | int | Indicates what to do with deleted records. 1 Nothing. 2 Move to a record set. 3 Remove.
Tag001CloneFlag | int | Clone the 001 to some tag other than the 035a. A 035a will always be created.
Tag001CloneTag | int | What tag is used in the cloning prcoess if the flag is set to one.
Tag001Subfield | char | The subfield used in the cloning process (if any) if the cloning flag is set to 1.


CNV_AuthProcessLog

CNV_AuthProcessLog Table

The log file used by conversion services for authority processing.

Columns

Column name | Data type | Description
ProcessID | int | The ID of the logged step.
Description | nvarchar(255) | The desciption of the logged step.
Outcome | bit | The outcome of the logged step.
ProcessDate | datetime | The date the logged step took place.


cnv_BibFixTable

cnv_BibFixTable Table

A table used by conversion services to track the status of each bib record in the processing queue.

Columns

Column name | Data type | Description
BibliographicRecordID | int | The Polaris bib record ID.
Flag005 | bit | Indiacates a default 005 needs to be added.
Flag008 | bit | Indicates a default 008 needs to be added.
FlagDel | bit | Indciates the record has a MARC status of 'd'.
Flag245 | bit | Indicates the record has no 245.
Flag001 | bit | Indicates an 001 needs to be moved to an 035a.
FlagDup001 | bit | Indicates the record has more than one 001 tag. Duplicates are removed and the first 001 is preserved.
Flag008Long | bit | Indicates the records current 008 is either longer or shorter than fourty characters.
Flag020c | bit | Indciates that 350a has been moved to an 020c in records that have an 020a, but no 020c. (optional)
FlagClone | bit | Indicates the local control number has been cloned (optional).
FlagNormalize | bit | Indciates the record has been normalized.
FlagIndex | bit | Indicates the record has been indexed.
FlagMap | bit | Indicates the record has been mapped in the bibtemp table.
FlagMtomFormat | bit | Not in use.
FlagFixIndicators | bit | Indicates the indicators have been 'fixed' (optional).


CNV_BibIndicatorOne

CNV_BibIndicatorOne Table

A table used by conversion services to 'fix' indicators.

Columns

Column name | Data type | Description
IndyTag | nvarchar(3) | The tag affected.


CNV_BibIndicatorTwo

CNV_BibIndicatorTwo Table

A table used by conversion services to fix indicators.

Columns

Column name | Data type | Description
IndyTag | nvarchar(3) | The tag affected.


cnv_BibOptions

cnv_BibOptions Table

A table used to set the bib prcoessing options for conversion services. This table is leveraged by the convert MARC program.

Columns

Column name | Data type | Description
TagLocalCtrl | int | what incoming tag contains the local control number.
SubLocalCtrl | char | The subfield containing the local control number (if any).
DelRecs | int | What to do with records with a MARC bib status of 'd'. 1 nothing. 2 put in a record set. 3 remove.
Tag001CloneFlag | int | Clone the incoming 001 to another tag.
Tag001CloneTag | int | Which tag to use to clone the 001 (if any).
Tag001Subfield | char | What subfield to use to clone the 001.
Tag245Nothing | int | What to do if a record does not have a 245a. 1 nothing, 2 put in a record set, 3 remove.
SplitFlag | int | Split items records from incoming MARC records.
SplitTag | int | What tag contains the item record entries.
BibOwner | int | The default owner for bibs
Tag020cFlag | int | Indicates to move the 350a to the 020c. This applies if the records contain an 350a, Do contain an 020a, do do NOT have an 020c.
TagReorder | int | reorder tags (not in use)
FixIndicators | int | Indicates the user wishesd to 'fix' indicators in incoming records.
DupCtrlOption | int | What to do with records that have duplicate control numbers.


CNV_BibProcessLog

CNV_BibProcessLog Table

The conversion services table that logs the status of each process.

Columns

Column name | Data type | Description
ProcessID | int | The ID of the processing step.
Description | nvarchar(255) | The desription of the processing step.
Outcome | bit | The outcome of the prcoessing step.
ProcessDate | datetime | The date of the processing step.


CNV_Dedup010Tab

CNV_Dedup010Tab Table

A table used for the conversion services bib deduplication process. This table stores deduplication canidates.

Columns

Column name | Data type | Description
BibliographicRecordID | int | The bibliographic record id of the canidate
BibliographicTagID | int | The ID of the bibliographic Tag
BibliographicSubfieldID | int | The ID if the Bibliographic subfield
Ndata | nvarchar(50) | The Control number
SubA | nvarchar(255) | the 245 $a
SubB | nvarchar(255) | The 245 $b
SubH | nvarchar(80) | The 245 $h
SubN | nvarchar(80) | The 245 &n
SubP | nvarchar(80) | The 245 $p
PubB | nvarchar(80) | The 260 $b
PubC | nvarchar(10) | The 260 $c
MarcFmt | varchar(2) | The LDR 07 & LDR 08
LocCode | nvarchar(80) | The 915 $a


CNV_Dedup020Tab

CNV_Dedup020Tab Table

A table used for the conversion services bib deduplication process. This table stores deduplication canidates.

Columns

Column name | Data type | Description
BibliographicRecordID | int | The bib record ID of the Canidate
BibliographicTagID | int | The bib tag of the canidate (245 $a)
BibliographicSubfieldID | int | The subfield of the canidate (245 $a)
Ndata | nvarchar(50) | The control number
SubA | nvarchar(255) | The 245 $a
SubB | nvarchar(255) | The 245 $b
SubH | nvarchar(80) | The 245 $h
SubN | nvarchar(80) | The 245 $n
SubP | nvarchar(80) | The 245 $p
PubB | nvarchar(80) | The 260 $b
PubC | nvarchar(10) | The 260 $c
MarcFmt | varchar(2) | The LRD: 06 / 07
LocCode | nvarchar(80) | the 915 $a


CNV_DeDuplicationLog

CNV_DeDuplicationLog Table

A file that contains a log of the results of the conversion services bib deduplication process

Columns

Column name | Data type | Description
DDProcessTag | int | The tag of the control number
BibliographicRecordID | int | The Bib ID of the surving BIB
Suba1 | nvarchar(255) | The 245 $a used for deduplication
Subb1 | nvarchar(255) | The 245 $b used for deduplication
SubN1 | nvarchar(80) | The 245 $n used for deduplication
SubP1 | nvarchar(80) | The 245 $p used for deduplication
SubH1 | nvarchar(80) | The 245 $h used for deduplication
PubB1 | nvarchar(80) | The 260 $b used for deduplication
PubC1 | nvarchar(80) | The 260 $c used for deduplication
MARCFMT1 | varchar(2) | The LDR 06/07 used for deduplication
LocCode1 | nvarchar(80) | The 915 $a of the surviving bib
ControlNumber | nvarchar(80) | The control number used for deduplication
DeDupBibliographicRecordID | int | The loosing bib id
LocCode2 | nvarchar(80) | The 915$a of the loosing bib
ItemsMoved | int | Number of tags moved from the loosing bib to the surviiving bib


CNV_DeDupTagsToPreserve

CNV_DeDupTagsToPreserve Table

The tags to be moved during the conversion services bib deduplication process. These tags will be moved from the looging bib to the winning bib before the loosing bib is removed from the system.

Columns

Column name | Data type | Description
Tagnumber | int | The tagnumber to be moved


CNV_DupAuth

CNV_DupAuth Table

A table used to detect duplicate name and subject authorities for incoming auth records.

Columns

Column name | Data type | Description
SubData | nvarchar(450) | The subfield data (not in use).
AuthoritySubfieldID | int | The ID of the authority subfield. (not in use)
AuthorityTagID | int | The ID of the authority Tag (not in use).
AuthorityRecordID | int | The authority record ID


CNV_fixedindicators

CNV_fixedindicators Table

Tag numbers to fix when the 'fix' indicators option is selected in the Convert MARC program. This table is used by conversion services.

Columns

Column name | Data type | Description
tagnum | smallint | The tag number where the indicator was 'fixed'.
tagid | int | The tag id where the indicator was 'fixed'.


CNV_lc_callnumbers

CNV_lc_callnumbers Table

Conversion table used as temporary storage to split LC call numbers

Columns

Column name | Data type | Description
ID | int | Unique ID for the row
itembarcode | nvarchar(20) | Item Barcode
CallNumber | nvarchar(255) | Reconstructed call number
callnumberprefix | nvarchar(60) | Call number prefix
classificationnumber | nvarchar(60) | Classification number
cutternumber | nvarchar(60) | Cutter
callnumbersuffix | nvarchar(60) | Call number suffix
VolumeNumber | nvarchar(60) | Volume number
CopyNumber | nvarchar(60) | Copy number


cnv_LinkingMessages

cnv_LinkingMessages Table

A log file for the conversion services linking process. This allows conversion services to track the progress and status of authority linking.

Columns

Column name | Data type | Description
LinkOrd | int | An ordinal that corresponds to the message
LinkMSG | nvarchar(4000) | The Log Message


CNV_linking_statistics

CNV_linking_statistics Table

A table to track the conversion services linking processes statistics.

Columns

Column name | Data type | Description
bibtagnumber | int | Corresponding Bib record tag
subfield | char | The linked tag subfield
Num_linked | int | Number of links
Num_notLinked | int | Number not linked
AC_Tagnumber | int | Authority Control Tag number
AC_Tags_used | int | Flag to indicated that the tag/subfield combo has been used
AC_Tags_not_used | int | Flag to indicated that the authority control tag/subfield combination is unused


CNV_Mig_CollectionData

CNV_Mig_CollectionData Table

Table used by conversion services to map collection data

Columns

Column name | Data type | Description
OrigCollectionID | nvarchar(500) | The original system collection ID
CollectionID | int | The Polaris collection ID


CNV_Mig_ItemStatusData

CNV_Mig_ItemStatusData Table

Table used by conversion services to map item status data

Columns

Column name | Data type | Description
OrigItemStatus | nvarchar(500) | The original system item status ID
ItemStatusID | int | The Polaris Item Status ID


CNV_Mig_LocationMapData

CNV_Mig_LocationMapData Table

A table used by conversion services to map organization level data

Columns

Column name | Data type | Description
OrigLocation | nvarchar(500) | The original system location ID
OrganizationID | int | The Polaris Organization ID


CNV_Mig_MaterialTypeData

CNV_Mig_MaterialTypeData Table

A table used by conversion services to map material type data

Columns

Column name | Data type | Description
OrigMaterialType | nvarchar(500) | The Originial system material type
MaterialTypeID | int | The Polaris material type ID
LoanperiodcodeID | int | The polaris loan period code ID
FineCodeID | int | The Polaris Fine code id
RenewalLimit | int | The polaris renewal limit
DefaultPrice | money | The default proce for the item if the item has no price
DisplayInPAC | bit | Display in PAC flag
NonCirculating | bit | The non circulating flag
Holdable | bit | The holdable flag
HoldableByPickup | bit | The holdable by pickup flag
HoldableByLibrary | bit | The holdable by library flag
LoanableOutsideSystem | bit | The loanable outside the system flag


CNV_Mig_PatronAccFeeReasonCodesData

CNV_Mig_PatronAccFeeReasonCodesData Table

A table used by conversion services to map patron account fee reason codes

Columns

Column name | Data type | Description
OrigFeeReasonCode | nvarchar(500) | The original system fee reason code
FeeReasonCodeID | int | The polaris fee reason code ID


CNV_Mig_PatronAccTxnCodesData

CNV_Mig_PatronAccTxnCodesData Table

A table used by conversion services to map patron account transaction (txncodes) codes

Columns

Column name | Data type | Description
OrigTxnCode | nvarchar(500) | The original system transaction code
TxnCodeID | int | The Polaris txncodeid


CNV_Mig_PatronCodeMapData

CNV_Mig_PatronCodeMapData Table

A table used by conversion services to map patron codes

Columns

Column name | Data type | Description
OrigPatronCode | nvarchar(500) | The original system patron code
PatronCodeID | int | The Polaris Patron code ID


CNV_Mig_PatStatClassMapTable

CNV_Mig_PatStatClassMapTable Table

A table used by conversion services to map patron statistical codes

Columns

Column name | Data type | Description
StatisticalClassID | int | Polaris Statistical class ID
StatisticalClassVar | nvarchar(500) | Original System statistical class


CNV_Mig_ShelfLocationData

CNV_Mig_ShelfLocationData Table

A table used by conversion services to map shelf locations

Columns

Column name | Data type | Description
OrigShelfLocation | nvarchar(500) | Originial system shelf location
ShelfLocationID | int | Polaris Shelf location ID


CNV_Mig_StatisticalCodeMapTable

CNV_Mig_StatisticalCodeMapTable Table

A table used by conversion services to map item statistical codes

Columns

Column name | Data type | Description
StatisticalCodeID | int | Polaris statistical code ID
OrigStatisticalCode | nvarchar(500) | Original system item statistical code


CNV_Mig_SysHoldStatusesData

CNV_Mig_SysHoldStatusesData Table

A table used by conversion services to map hold status

Columns

Column name | Data type | Description
OrigSysHoldStatus | nvarchar(500) | original system hold status ID
SysHoldStatusID | int | Polaris sysholdstatusid


CNV_tmp_callnum

CNV_tmp_callnum Table

A table used by conversion services in splitting dewey call numbers

Columns

Column name | Data type | Description
ID | int | Incoming item record id
itembarcode | nvarchar(20) | The item barcode
CallNumber | nvarchar(255) | Recontructed call number
callnumberprefix | nvarchar(60) | Call number prefix
classificationnumber | nvarchar(60) | Classification number
cutternumber | nvarchar(60) | The cutter
callnumbersuffix | nvarchar(60) | Call number suffix


CN_to_Bib

CN_to_Bib Table

Temp table used in conversion of Bibliographic MARC data for mapping control number to bib records.

Columns

Column name | Data type | Description
bid | int | Bib Record id
cn | nvarchar(25) | Control number field - text
leader | nvarchar(12) | Leader info for bib record - text


CollectionAgencyExcludePatronCodes

CollectionAgencyExcludePatronCodes Table

Patron Codes that should not be reported to collection agency whatever such patrons did.

Columns

Column name | Data type | Description
OrgID | int | Organization that generates report.
PatronCodeID | int | Patron code to be excluded.


CollectionAgencyFees

CollectionAgencyFees Table

This table contains detailed info for collection agency fees.

Columns

Column name | Data type | Description
OrgID | int | Organization that generates report.
MinAmount | smallmoney | Start of that range.
MaxAmount | smallmoney | End of that range.
CollectionFee | smallmoney | Fee anount for a particular range of amount collected.


CollectionAgencyIncludePatrons

CollectionAgencyIncludePatrons Table

Patrons that should be reported to collection agency no matter what.

Columns

Column name | Data type | Description
OrgID | int | Organization that generates report.
PatronID | int | Patron to be included unconditionally.


CollectionAgencyRunDates

CollectionAgencyRunDates Table

This table has information about the last date when submission and update reports were run.

Columns

Column name | Data type | Description
OrgID | int | The organization for which the report was run.
CollectionType | int | Denotes whether it was a submission or an update report.
LastRunDate | datetime | Last time the (update or submission) report was run.
PackageStatus | int | Whether the DTS package was successful in creating the collection report or not.
RunSynchReport | bit | Flag indicating a Synch Report has been selected to be run.


Collections

Collections Table

Collections definitions. See the OrganizationsCollections table to determine the branches that are associated with each Collection.

Columns

Column name | Data type | Description
CollectionID | int | Primary Key unique identifier.
Name | nvarchar(80) | The name of the collection.
Abbreviation | nvarchar(15) | Abbreviation for the Collection. Often used for display purposes in the UI
CreatorID | int | ID of user who created this object.
ModifierID | int | ID of user who last modified this object.
CreationDate | datetime | Date/time of creation.
ModificationDate | datetime | Date/time of the last modification.

See Also

ChildPAC_CollectionLimits, InnReachFilterCollections, OrganizationsCollections, OrganizationsFloatingCollections, SA_FloatingMatrixCollectionLimits,


CollectionSAParams

CollectionSAParams Table

This table is used during collection processing to store the SA collection values.

Columns

Column name | Data type | Description
OrgID | int | The organization for which the SA parameters are being stored.
CutOffDate | datetime | The cutoff date as specified in SA.
FineAge | int | The FineAge as specified in SA.
MinBalance | money | The minimum balance as specified in SA.
SubmissionFreq | int | Numeric value that designates how often to run sumbission reports for the organization (OrgID)
UpdateFreq | int | Numeric value that designates how often to run update reports for the organization (OrgID)
ReportPath | nvarchar(255) | The report path for submission and update reports as specified in SA.
ReportUDF1 | nvarchar(3) | Denotes whether UDF1 should be included in the submission or update reports.
ReportUDF2 | nvarchar(3) | Denotes whether UDF2 should be included in the submission or update reports.
ReportUDF3 | nvarchar(3) | Denotes whether UDF3 should be included in the submission or update reports.
ReportUDF4 | nvarchar(3) | Denotes whether UDF4 should be included in the submission or update reports.
ReportUDF5 | nvarchar(3) | Denotes whether UDF5 should be included in the submission or update reports.
CAType | tinyint | Denotes whether the system is using UMS or other agencies for collection reporting.
UDFToUse | nvarchar(32) | Denotes which UDF in the patron record has info about the responsible person in the case of minors. This UDF will be used to get the parent/guardian info when minors are reported to collection agencies other than UMS. The UDF chosen should contain the parent's barcode in the patron registration WF.


CollectionsPPPP

CollectionsPPPP Table

Holds AdminAttribute data values that have been set for a particular Collection. (FOR FUTURE USE)

Columns

Column name | Data type | Description
CollectionID | int | ID of the collection the data pertains to.
AttrID | int | AdminAttribute ID
Value | nvarchar(255) | The data value for this attribute


CollectionSubmission

CollectionSubmission Table

This table has information on the patrons included in the submission report.

Columns

Column name | Data type | Description
ReportingOrgID | int | ID of the organization which is submitting this report.
ReportingOrgName | nvarchar(80) | Name of the organization that is submitting this report.
PatronID | int | ID of patron.
PatronCodeID | int | ID of patron code.
PatronCode | nvarchar(80) | Description of patron's code.
PatronRegisteredBranchID | int | ID of patron's registered branch.
PatronRegisteredBranch | nvarchar(80) | Description of patron's registered branch.
PatronNameLast | nvarchar(32) | Last name of the patron.
PatronNameFirst | nvarchar(32) | First name of the patron.
PatronNameMiddle | nvarchar(32) | Middle Name of the patron.
PatronNameTitle | nvarchar(8) | Patron's Title.
PatronNameSuffix | nvarchar(4) | Suffix for patron's name.
StreetOne | nvarchar(64) | StreetOne of the address which is reported in the submission report.
StreetTwo | nvarchar(64) | StreetTwo of the address which is reported in the submission report.
City | nvarchar(32) | City of the address which is reported in the submission report.
County | nvarchar(32) | County of the address which is reported in the submission report.
State | nvarchar(32) | State of the address which is reported in the submission report.
PostalCode | nvarchar(32) | Postal Code of the address which is reported in the submission report.
ZipPlusFour | nvarchar(32) | ZipPlusFour of the address which is reported in the submission report.
VoicePhone1 | nvarchar(20) | Phone number for the patron.
BirthDate | datetime | Birthdate of the patron from the PatronRegistration table.
UDF1 | nvarchar(64) | User Defined Field1 for the patron.
UDF2 | nvarchar(64) | User Defined Field2 for the patron.
UDF3 | nvarchar(64) | User Defined Field3 for the patron.
UDF4 | nvarchar(64) | User Defined Field4 for the patron.
UDF5 | nvarchar(64) | User Defined Field5 for the patron.
TotalReplacementCost | money | Total replacement charges that the patron owes the system.
TotalOVDCharge | money | Overdue charges that the patron owes the system.
TotalOtherCharges | money | Charges other than overdue or replacement charges that the patron owes the system.
CollAgencyCharge | money | Collection agency charge added to the patron's account.
TotalAmountDue | money | Total amount that the patron owes the system.
EarliestTxnDate | datetime | Date of the earliest unresolved charge in the patron's account.
TotalReportingOrgCharges | money | Denotes the total amount that is due to the reporting organization.
LastActivityDate | datetime | Denotes the last date when the patron performed any circ related operations.
PrimaryPatronID | int | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's PatronID.
PrimaryPatronNameLast | nvarchar(32) | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's last name.
PrimaryPatronNameFirst | nvarchar(32) | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's first name.
PrimaryPatronNameMiddle | nvarchar(32) | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's middle name.
PrimaryPatronTitle | nvarchar(32) | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's title.
PrimaryPatronSuffix | nvarchar(32) | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's suffix.
VoicePhone2 | nvarchar(20) | 2nd Phone number for the patron in the patron registration WF.
VoicePhone3 | nvarchar(20) | 3rd Phone number for the patron in the patron registration WF.
TotalProcessingFee | money | Processing fee charges that the patron owes the system.


CollectionSynchronization

CollectionSynchronization Table

This table has information on the patrons included in the synchronization report.

Columns

Column name | Data type | Description
ReportingOrgID | int | ID of the organization which is submitting this report.
ReportingOrgName | nvarchar(80) | Name of the organization that is submitting this report.
ReportDate | datetime | Date when the synchronization report was generated.
PatronID | int | ID of patron.
PatronNameLast | nvarchar(32) | Last name of the patron.
PatronNameFirst | nvarchar(32) | First name of the patron.
PatronNameMiddle | nvarchar(32) | Middle Name of the patron.
ItemRelatedCharges | money | The charges that are related to items belonging to the organization submitting the report.
NonItemRelatedCharges | money | The charges that are not related to items but were created by the organization submitting the report.
TotalReportingOrgCharges | money | Denotes the total amount that is due to the reporting organization.
TotalSystemCharges | money | Denotes the total amount that is due to the entire system.


CollectionTypes

CollectionTypes Table

Gives the descriptions of the collectiontype id's used in the table CollectionAgencyRunDates table.

Columns

Column name | Data type | Description
CollectionTypeID | int | The collection type ID.
CollectionTypeName | nvarchar(50) | The description of the collection type.


CollectionUpdate

CollectionUpdate Table

This table has information on the patrons included in the update report.

Columns

Column name | Data type | Description
ReportingOrgID | int | ID of the organization which is submitting this report.
ReportingOrgName | nvarchar(80) | Name of the organization that is submitting this report.
PatronID | int | ID of patron.
PatronCodeID | int | ID of patron code.
PatronCode | nvarchar(80) | Description of patron's code.
PatronRegisteredBranchID | int | ID of patron's registered branch.
PatronRegisteredBranch | nvarchar(80) | Description of patron's registered branch.
PatronNameLast | nvarchar(32) | Last name of the patron.
PatronNameFirst | nvarchar(32) | First name of the patron.
PatronNameMiddle | nvarchar(32) | Middle Name of the patron.
PatronNameTitle | nvarchar(8) | Patron's Title.
PatronNameSuffix | nvarchar(4) | Suffix for patron's name.
UDF1 | nvarchar(64) | User Defined Field1 for the patron.
UDF2 | nvarchar(64) | User Defined Field2 for the patron.
UDF3 | nvarchar(64) | User Defined Field3 for the patron.
UDF4 | nvarchar(64) | User Defined Field4 for the patron.
UDF5 | nvarchar(64) | User Defined Field5 for the patron.
TotalPaidReplacementCharges | money | Total payments that the patron made towards charges that were replacement charges. This only includes payments made since the last report that included the patron.
TotalWaivedCharges | money | Total waives that the library made towards charges. This only includes waives made since the last report that included the patron.
TotalPaidOtherCharges | money | Total payments that the patron made towards charges that were not replacement or overdue charges. This only includes payments made since the last report that included the patron.
TotalReportingOrgCharges | money | The total amount that the patron owes the organization that has included him in its update report.
TotalAmountDue | money | Total amount that the patron owes the system.
TotalReportingOrgNewCharges | money | The total charges that were added to the patron's account since the last report that included this patron. This is the sum which the patron owes the organization that has included him in its update report.
TotalAmountPaid | money | Total payments that the patron made towards charges for the reporting organization. This only includes payments made since the last report that included the patron.
TotalWaivedReplacementCharges | money | Total waives that the library made towards replacement charges. This only includes waives made since the last report that included the patron.
TotalWaivedOtherCharges | money | Total waives that the library made towards charges which were not for replacement cost. This only includes waives made since the last report that included the patron.
PrimaryPatronID | int | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's PatronID.
PrimaryPatronNameLast | nvarchar(32) | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's last name.
PrimaryPatronNameFirst | nvarchar(32) | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's first name.
PrimaryPatronNameMiddle | nvarchar(32) | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's middle name.
PrimaryPatronTitle | nvarchar(8) | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's title.
PrimaryPatronSuffix | nvarchar(4) | When collection agencies other than UMS are used, when the PatronID column contains a minor, then this column has the parent/guardian's suffix.
VoicePhone1 | nvarchar(20) | Phone number for the patron.
VoicePhone2 | nvarchar(20) | 2nd Phone number for the patron in the patron registration WF.
VoicePhone3 | nvarchar(20) | 3rd Phone number for the patron in the patron registration WF.
StreetOne | nvarchar(64) | StreetOne of the address which is reported in the update report
StreetTwo | nvarchar(64) | Street Two of the address which is reported in the update report
City | nvarchar(32) | City of the address which is reported in the update report.
State | nvarchar(32) | State of the address which is reported in the update report.
PostalCode | nvarchar(10) | Postal Code of the address which is reported in the update report.
ZipPlusFour | nvarchar(4) | ZipPlusFour of the address which is reported in the update report.
BirthDate | datetime | Birthdate of the patron from the PatronRegistration table.


CommunityAuthorityControl

CommunityAuthorityControl Table

For future use

Columns

Column name | Data type | Description
CommunityInformationTagNumber | smallint | For future use
CommunityAuthorityTagNumber | smallint | For future use
AuthorityControlTypeID | int | For future use
AuthorizeOption | bit | For future use

See Also

CommunityAuthorityControlIndicatorOne, CommunityAuthorityControlIndicatorTwo, CommunityAuthorityControlSubfields,


CommunityAuthorityControlHeadings

CommunityAuthorityControlHeadings Table

For future use

Columns

Column name | Data type | Description
CommunityAuthorityRecordID | int | For future use
CommunityAuthorityTagID | int | For future use
Heading | nvarchar(255) | For future use
HeadingSubs | nvarchar(255) | For future use
BrowseHeading | nvarchar(255) | For future use
BrowseHeadingSubs | nvarchar(255) | For future use
TagNumber | smallint | For future use
IndicatorOne | char | For future use
IndicatorTwo | char | For future use
SubfieldString | nvarchar(40) | For future use
MARCKindOfRecord | char | For future use
MARCCatalogingRules | char | For future use
MARCSubjectHeadings | char | For future use
MARCUseMainEntry | char | For future use
MARCUseSubjectEntry | char | For future use
MARCUseSeriesEntry | char | For future use


CommunityAuthorityControlIndicatorOne

CommunityAuthorityControlIndicatorOne Table

For future use

Columns

Column name | Data type | Description
CommunityInformationTagNumber | smallint | For future use
IndOneCharValue | char | For future use


CommunityAuthorityControlIndicatorTwo

CommunityAuthorityControlIndicatorTwo Table

For future use

Columns

Column name | Data type | Description
CommunityInformationTagNumber | smallint | For future use
IndTwoCharValue | char | For future use


CommunityAuthorityControlSubfields

CommunityAuthorityControlSubfields Table

For future use

Columns

Column name | Data type | Description
CommunityInformationTagNumber | smallint | For future use
SubfieldCharValue | char | For future use


CommunityAuthorityRecords

CommunityAuthorityRecords Table

For Future Use

Columns

Column name | Data type | Description
CommunityAuthorityRecordID | int | For Future Use
RecordStatusID | int | For Future Use
CreatorID | int | For Future Use
ModifierID | int | For Future Use
FirstUseDate | datetime | For Future Use
ImportedDate | datetime | For Future Use
MARCStatus | char | For Future Use
MARCType | char | For Future Use
MARCUndefined7 | char | For Future Use
MARCUndefined8 | char | For Future Use
MARCEncodingLevel | char | For Future Use
MARCUndefined18 | char | For Future Use
MARCUndefined19 | char | For Future Use
MARCKindOfRecord | char | For Future Use
MARCCatalogingRules | char | For Future Use
MARCSubjectHeadings | char | For Future Use
MARCUseMainEntry | char | For Future Use
MARCUseSubjectEntry | char | For Future Use
MARCUseSeriesEntry | char | For Future Use
Heading | nvarchar(255) | For Future Use
BrowseHeading | nvarchar(255) | For Future Use
MARCCatalogingSource | char | For Future Use
MARCSubjectSubdivision | char | For Future Use
MARCCreationDate | nchar | For Future Use
MARCModificationDate | nchar | For Future Use
MARCLCCN | nvarchar(40) | For Future Use
MARCGeographicSubdivision | char | For Future Use
MARCRomanization | char | For Future Use
MARCTypeOfSeries | char | For Future Use
MARCNumberedSeries | char | For Future Use
MARCGovernmentAgency | char | For Future Use
MARCReferenceEvaluation | char | For Future Use
MARCRecordUpdate | char | For Future Use
MARCUndifferentiatedName | char | For Future Use
MARCLevelOfEstablishment | char | For Future Use
MARCModifiedRecord | char | For Future Use
MARCCharCodingScheme | char | For Future Use
RecordStatusDate | datetime | For Future Use
ModifiedByCommunityAuthorityJob | bit | For Future Use
CreationDate | datetime | For Future Use
ModificationDate | datetime | For Future Use
ImportedFileName | nvarchar(255) | For Future Use
BrowseHeadingNonFilingCount | tinyint | For Future Use

See Also

CommunityAuthorityControlHeadings, CommunityAuthorityTags, CommunityAuthorityTracingsIndices, CommunityInformationPrimaryNameIndices, CommunityInformationSeriesIndices, CommunityInformationSubfieldsAuthorized, CommunityInformationSubjectIndices,


CommunityAuthoritySubfields

CommunityAuthoritySubfields Table

For Future Use

Columns

Column name | Data type | Description
CommunityAuthoritySubfieldID | int | For Future Use
CommunityAuthorityTagID | int | For Future Use
SubfieldSequence | smallint | For Future Use
Subfield | char | For Future Use
Data | nvarchar(4000) | For Future Use
NumberOfNonFilingCharacters | tinyint | For Future Use


CommunityAuthorityTags

CommunityAuthorityTags Table

For Future Use

Columns

Column name | Data type | Description
CommunityAuthorityTagID | int | For Future Use
CommunityAuthorityRecordID | int | For Future Use
Sequence | smallint | For Future Use
TagNumber | smallint | For Future Use
IndicatorOne | char | For Future Use
IndicatorTwo | char | For Future Use
AssociatedCommunityAuthorityRecordID | int | For Future Use

See Also

CommunityAuthorityControlHeadings, CommunityAuthoritySubfields, CommunityAuthorityTracingsIndices, CommunityPrimaryName4XX, CommunityPrimaryName5XX, CommunitySeries4XX, CommunitySeries5XX, CommunitySubject4XX, CommunitySubject5XX,


CommunityAuthorityTracingsIndices

CommunityAuthorityTracingsIndices Table

For Future Use

Columns

Column name | Data type | Description
CommunityAuthorityRecordID | int | For Future Use
CommunityAuthorityTagID | int | For Future Use
Tracing | nvarchar(255) | For Future Use
TagNumber | smallint | For Future Use
BrowseTracing | nvarchar(255) | For Future Use
BrowseHeading | nvarchar(255) | For Future Use


CommunityEventImportXMLProfiles

CommunityEventImportXMLProfiles Table

A table that holds configuation information for importing event data from third party vendors

Columns

Column name | Data type | Description
CommunityXMLProfileID | int | Uniquie ID for the import profile (system assigned)
OrganizationID | int | The organization owner of this import profile.
ThirdPartyAPIUrl | nvarchar(4000) | The URL for the third part event vendors site for the specified polaris organization.
RecursionLevel | int | Does the import run Daily, weekly, or monthly ...
RecursionDepth | int | How often to run the import
LastRunDate | datetime | The last time an event import took place using this profile.
EventRecordTypeID | int | The type of event Record (Evanced, PlymouthRocket, etc...)
ContactPerson | nvarchar(4000) | The contact person that will be used during event creation
ContactPhone | nvarchar(4000) | The contact persons telephone number that will be used during event creation
ContactEmail | nvarchar(4000) | The contact persons e-mail address that will be used during event creation
URLLinkText | nvarchar(4000) | URL Link text that will be used during event creation
Street | nvarchar(4000) | The street that will be used during event creation
City | nvarchar(4000) | The city that will be used during event creation
State | nvarchar(4000) | The State that will be used during event creation
FAX | nvarchar(4000) | The FAX number that will be used during event creation
PostalCode | nvarchar(4000) | The postal code that will be used during event creation
Location | nvarchar(4000) | The location within the library that will be used during event creation
ProfileEnabled | bit | Indicates if the profile is enabled.
ParentCommunityInformationRecordID | int | The Parent record ID that will be used during event creation
CreatorID | int | The creator of the import profile
CreationDate | datetime | The date and time that the import profile was created
ModifierID | int | The Polaris user who last modified the profile
LastUpdateDate | datetime | The last date and time the profile was updated
LastImportResult | nvarchar(4000) | A textual description of the status of the last import job associated with the profile
NumberEventsCreated | int | The number of event candidates dicovered during the last run

See Also

CommunityEventXMLImportJobs,


CommunityEventXMLImportJobs

CommunityEventXMLImportJobs Table

A table to track ine third party event import jobs in progress.

Columns

Column name | Data type | Description
CommunityEventXMLImportJobID | int | A unique ID (system assigned)
CommunityXMLProfileID | int | The profile settings used to process the import job.
StartImportedEventID | int | The date and time the import job started.
EndImportedEventID | int | The last imported event ID in the job
NumberOfEventsImported | int | The total number of events found during the import process.
NumberOfNewEvents | int | The number of new events found during the import process.
NumberOfExistingEvents | int | The number of events found that already existed in the polaris database.
ProcessingComplete | int | Indicates if events processing is complete.
StartTime | datetime | the time that the import started.
EndTime | datetime | The time that the import finished.
RecordOwnerID | int | The polaris owning organization ID for the incoming events.
ParentCommunityInformationRecordID | int | The community profile record to which the imported events will be attached.


CommunityImportedEvancedEvents

CommunityImportedEvancedEvents Table

A Table to import raw evanced data for MARC processing

Columns

Column name | Data type | Description
ImportedEventID | int | Polaris Interal ID for this event entity
ImportedDate | datetime | Date that the event was imported - Used in Processing
EventTitle | nvarchar(4000) | The event title as defined by Evanced
StrEVTDate | nvarchar(4000) | Polaris Internal Column used in forming the start and end date of the event
Evtdate1 | datetime | Event Date as defined by Evanced
EvtLength | int | Event length (in minutes) as defined by Evanced
EvtEndDate1 | datetime | Event end date as defined by Evanced
EvtEndTime | nvarchar(4000) | Event end time as defined by Evanced
EVTTime | nvarchar(4000) | Event start time as defined by Evanced
EVTDescription | nvarchar(4000) | Event description as defined by Evanced
EVTLocation | nvarchar(4000) | Location of the event as defined by Evanced
EVTLink | nvarchar(4000) | URL of the event as defined by Evanced
EVTID | int | Event ID as defined by Evanced
RecordType | int | Record type 1 as defined by Evanced
EvtRCID | int | Internal RCID of the event as defined by Evanced
PriEventType | nvarchar(4000) | Primary Event type 1 as defined by Evanced
EventType1 | nvarchar(4000) | Event type 1 as defined by Evanced
EventType2 | nvarchar(4000) | Event type 2 as defined by Evanced
EventType3 | nvarchar(4000) | Event type 3 as defined by Evanced
AgeGroup1 | nvarchar(4000) | Age Group 1 as defined by Evanced
AgeGroup2 | nvarchar(4000) | Age Group 2 as defined by Evanced
AgeGroup3 | nvarchar(4000) | Age Group 3 as defined by Evanced
OtherInfo | nvarchar(4000) | Misc. Info defined by Evanced
Presenter | nvarchar(4000) | The presenter of the event as defined by Evanced
evtsignup | int | Boolean, does event require signup - as defined by Evanced
SignUpStarts | datetime | Date signup starts as defined by Evanced
SignUpEnds | datetime | Date event signup ends as defined by Evanced
ContactName | nvarchar(4000) | Contact name as defined by Evanced
ContactPhone | nvarchar(4000) | Contact Phone as defined by Evanced
LinkText | nvarchar(4000) | URL link text defined by Evanced
LinkAddress | nvarchar(4000) | UEL of this event on the Evanced Server
ImagePath | nvarchar(4000) | Event ImageURL as defined by Evanced
ImageText | nvarchar(4000) | Text associated with the image as defined by Evanced
ImageHeight | int | Event Image height as defined by Evanced
ImageWidth | int | Image width as defined by Evanced
LastUpdated | datetime | Last time that this event was updated defined by Evanced


CommunityImportedXMLEvents

CommunityImportedXMLEvents Table

A table to hold imported events from an event provider, when creating event records from an event providers API.

Columns

Column name | Data type | Description
ImportedEventID | int | A unique ID for the row (identity)
CommunityEventXMLImportJobID | int | A unique identifier for the XML import job
ParentCommunityInformationRecordID | int | The polaris Parent community profile record ID for the event
RecordOwnerID | int | The Polaris record owner of the event
ImportedDate | datetime | The date that the event was imported
EventTitle | nvarchar(4000) | The name of the event
EventDate | datetime | The date of the event
EventEndDate | datetime | The end date of the event
EventExpirationDate | datetime | The expiration date of the event
TextualEventDateTime | nvarchar(4000) | A textual representation of the evnt start and end date
EVTDescription | nvarchar(4000) | The description of the event
EVTLocation | nvarchar(4000) | The loacation (within the building) of the event
EVTLink | nvarchar(4000) | The URL to event sign up page at the event provider site
EVTID | int | Internal use
RecordType | int | Internal use
EvtRCID | int | Internal use
EventType1 | nvarchar(4000) | Internal use
EventType2 | nvarchar(4000) | Internal use
EventType3 | nvarchar(4000) | Internal use
AgeGroup1 | nvarchar(4000) | Internal use
AgeGroup2 | nvarchar(4000) | Internal use
AgeGroup3 | nvarchar(4000) | Internal use
OtherInfo | nvarchar(4000) | Internal use
Presenter | nvarchar(4000) | The presenter of the event
EvtSignUp | int | Internal use
ContactName | nvarchar(4000) | The contact name associated with the event.
ContactPhone | nvarchar(4000) | The contact phone number
ContactEmail | nvarchar(4000) | The contact e-mail address
LinkText | nvarchar(4000) | Internal use
LinkAddress | nvarchar(4000) | Internal use
ImagePath | nvarchar(4000) | Internal use
ImageText | nvarchar(4000) | Internal use
LastUpdated | nvarchar(4000) | The last time this event was updated
Processed | int | Indicates if the row has been processed
CommunityInformationRecordID | int | The record ID of the event that was created
Street | nvarchar(4000) | The street address
City | nvarchar(4000) | The city
State | nvarchar(4000) | The state
FAX | nvarchar(4000) | The Fax number
PostalCode | nvarchar(4000) | The Postal code
EventRecordTypeID | int | The record type ID of the event


CommunityImportJobs

CommunityImportJobs Table

Import Jobs Table, used in importing community information records. Import is used only during conversion at this time

Columns

Column name | Data type | Description
CommunityImportJobID | int | Polaris Internal Import Job ID
ImportScheduled | bit | For Future use
ScheduledTimeForImport | datetime | For Future use
ImportCompleted | bit | Boolean, Indicates if the import completed successfully
PolarisUserID | int | The Polaris User that initited the import
OrganizationID | int | The OrganizationID from which the import was initiated
WorkstationID | int | The workstation from which the import took place
ImportFileName | nvarchar(255) | The name of the file containing the community information records.
IsExpressImport | bit | For Future use
CommunityInformationRecordOwnerID | int | Record Owner for the Community Information Records
CommunityInformationDisplayInPAC | bit | For Future use
CommunityInformationRecordSaveOptionID | int | Save Option for the records
CommunityInformationAuthorityControlOptionID | int | For Future use
CommunityAuthorityRecordSaveOptionID | int | The Save Option for the new event record
CommunityAuthoritySeeAlsoFromOptionID | int | For Future use
ImportJobSubmittedDate | datetime | The date that the import job was submitted
CommunityImportProfileID | int | Polaris Internal Import Profile ID


CommunityImportProfiles

CommunityImportProfiles Table

The Table used when Importing Community records from an XML file

Columns

Column name | Data type | Description
CommunityImportProfileID | int | The unique ID of the profile
ProfileName | nvarchar(255) | The name of the profile used in the import
ProfileDescription | nvarchar(255) | A description of the profile used for import.
CreatorID | int | The creator of the profile
ImportNowOrLater | smallint | For future use
ScheduledTimeForImport | datetime | For future use.
SourceFileName | nvarchar(1000) | The name of the source file, if applicable.
ReportFileName | nvarchar(1000) | For Future use
CommunityInformationRecordSaveOptionID | int | For future use
CommunityInformationRecordOwnerID | int | The record owner ID of of records created using this profile.
CommunityInformationAuthorityControlOptionID | int | For Future Use.
CommunityAuthorityRecordSaveOptionID | int | For Future Use.
CommunityAuthoritySeeAlsoFromOptionID | int | For Future Use.
CommunityInformationFinalRSNew | bit | For Future Use.
CommunityInformationFinalRSExisting | bit | For Future Use.
CommunityInformationFinalRSName | nvarchar(50) | For Future Use.
CommunityInformationFinalRSOwnerID | int | For Future Use.
CommunityInformationFinalRSExistingID | int | For Future Use.
CommunityInformationFinalRSAppendOrReplace | bit | For Future Use.
CommunityInformationProvRSNew | bit | For Future Use.
CommunityInformationProvRSExisting | bit | For Future Use.
CommunityInformationProvRSName | nvarchar(50) | For Future Use.
CommunityInformationProvRSOwnerID | int | For Future Use.
CommunityInformationProvRSExistingID | int | For Future Use.
CommunityInformationProvRSAppendOrReplace | bit | For Future Use.
CommunityInformationDelRSNew | bit | For Future Use.
CommunityInformationDelRSExisting | bit | For Future Use.
CommunityInformationDelRSName | nvarchar(50) | For Future Use.
CommunityInformationDelRSOwnerID | int | For Future Use.
CommunityInformationDelRSExistingID | int | For Future Use.
CommunityInformationDelRSAppendOrReplace | bit | For Future Use.
CommunityAuthorityFinalRSNew | bit | For Future Use.
CommunityAuthorityFinalRSExisting | bit | For Future use
CommunityAuthorityFinalRSName | nvarchar(50) | For Future Use.
CommunityAuthorityFinalRSOwnerID | int | For Future Use.
CommunityAuthorityFinalRSExistingID | int | For Future Use.
CommunityAuthorityFinalRSAppendOrReplace | bit | For Future use
CommunityAuthorityProvRSNew | bit | For Future Use.
CommunityAuthorityProvRSExisting | bit | For Future Use.
CommunityAuthorityProvRSName | nvarchar(50) | For Future Use.
CommunityAuthorityProvRSOwnerID | int | For Future Use.
CommunityAuthorityProvRSExistingID | int | For Future Use.
CommunityAuthorityProvRSAppendOrReplace | bit | For Future Use.
CommunityAuthorityDelRSNew | bit | For Future use
CommunityAuthorityDelRSExisting | bit | For Future use
CommunityAuthorityDelRSName | nvarchar(50) | For Future use
CommunityAuthorityDelRSOwnerID | int | For Future use
CommunityAuthorityDelRSExistingID | int | For Future use
CommunityAuthorityDelRSAppendOrReplace | bit | For Future use
CreationDate | datetime | The date on which the profile was created
ModificationDate | datetime | The date on which the profile was modified
ModifierID | int | The Profile modifier
CommunityInformationDisplayInPAC | bit | For Future Use.

See Also

CommunityImportJobs,


CommunityInformationBrowseSubfields

CommunityInformationBrowseSubfields Table

This table contains subfields that are used in building the community browse indexes for the associated Tag/Index.

Columns

Column name | Data type | Description
CommunityInformationBrowseSubfieldID | int | BrowseSubfields Primary Key unique identifier (IDENTITY)
IndexKey | char | FK: See CommunityInformationIndexParams table
CommunityInformationIndexParamsTag | smallint | FK: See CommunityInformationIndexParams table
Subfield | char | The Community record subfield this row applies to.


CommunityInformationConcordance

CommunityInformationConcordance Table

Contains one row for each distinct collocation composed of 1 to 8 keywords within a community information record.

Columns

Column name | Data type | Description
CollocationID | int | Identifier of the collocation. This column is unique to each row.
LexicalContextTuple | varbinary | Compressed tuple of keyword/delimiter pairs.


CommunityInformationConcordanceRadix

CommunityInformationConcordanceRadix Table

Contains one row for each distinct code point at a given prefix-position within the concordance.

Columns

Column name | Data type | Description
NexusID | int | Identifier of the nexus. This column is unique to each row.
ParentNexusID | int | Identifier of the parent nexus.
EdgeTransition | nchar | Distinct code point at a given prefix-position within the concordance.
SemanticHintTuple | varbinary | Compressed tuple of collocation hints.


CommunityInformationDeDup1XXIndex

CommunityInformationDeDup1XXIndex Table

This index contains a listing of all community 1xx tags used by the duplicate detection algorithm

Columns

Column name | Data type | Description
CommunityInformationDeDup1XXIndexID | int | Unique identifier for the row.
CommunityInformationRecordID | int | Link to community information Records table
CommunityInformationTagID | int | Link to Community information Tags table
Tag1XXaData | nvarchar(450) | Data string searched against for duplicates


CommunityInformationDeDup245Index

CommunityInformationDeDup245Index Table

This index contains a listing of all community 245 tags used by the duplicate detection algorithm

Columns

Column name | Data type | Description
CommunityInformationDeDup245IndexID | int | Unique identifier for the row.
CommunityInformationRecordID | int | Link to Community information Records table
CommunityInformationTagID | int | Link to Community information Tags table
Tag245aData | nvarchar(450) | Data string searched against for duplicates


CommunityInformationDeDup246Index

CommunityInformationDeDup246Index Table

This index contains a listing of all community information 246 tags used by the duplicate detection algorithm

Columns

Column name | Data type | Description
CommunityInformationDeDup246IndexID | int | Unique identifier for the row.
CommunityInformationRecordID | int | Link to Community information Records table
CommunityInformationTagID | int | Link to Community Information Tags table
Tag246aData | nvarchar(450) | Data string searched against for duplicates


CommunityInformationDeDup247Index

CommunityInformationDeDup247Index Table

This index contains a listing of all Community 247 tags used by the duplicate detection algorithm

Columns

Column name | Data type | Description
CommunityInformationDeDup247IndexID | int | Unique identifier for the row.
CommunityInformationRecordID | int | Link to community information records table
CommunityInformationTagID | int | Link to community information Tags table
Tag247aData | nvarchar(450) | Data string searched against for duplicates


CommunityInformationDeDup270Index

CommunityInformationDeDup270Index Table

This index contains a listing of all bib 270 tags used by the duplicate detection algorithm

Columns

Column name | Data type | Description
CommunityInformationDeDup270IndexID | int | Unique identifier for the row.
CommunityInformationRecordID | int | Link to community information Records table
CommunityInformationTagID | int | Link to community information Tags table
Tag270aData | nvarchar(450) | Data string searched against for duplicates


CommunityInformationEventsPrograms

CommunityInformationEventsPrograms Table

A table to link events and programs to their owning community information organization records

Columns

Column name | Data type | Description
EventProgramID | int | The Unique Identitifer
ParentCommunityInformationRecordID | int | The owning community organizations communityInformationRecordID
CommunityTypeOfOrganizationID | tinyint | The type of event or program
OrganizationID | int | The event or programs owning Polaris Organization ID
RecordStatusID | int | The status of the event or program
BrowseProgramEventTitle | nvarchar(255) | The browse program or event title
BrowsePrimaryName | nvarchar(255) | The browse promary name of the owning organization record
FullEventProgramCommunityInformationRecordID | int | The CommunityInformationRecordID of the event or program record
CreationDate | datetime | The date the event or program was created
FirstAvailableDate | datetime | For future use
EventDate | datetime | The start date of the event or program
ExpirationDate | datetime | The expiration date of the event or program (when will the event or program no longer display in PAC)
DisplayInPAC | int | Indicates if the event or program will display in PAC
CreatorID | int | The Polaris User ID of the creator
EventEndDate | datetime | The end date of the event or program
TextualEventDateTime | nvarchar(255) | A textual description of the event date/time and location
ParentOrganizationPrimaryNameTagID | int | The CommunityInformationTagID associated with the 1XX tag of the parent community profile record.


CommunityInformationFacetIndex

CommunityInformationFacetIndex Table

Contains one row for each community information record associated with one or more search facets.

Columns

Column name | Data type | Description
RecordID | int | Identifier of a community information record associated with the facet.
FacetKeyChain | varbinary | Compressed key assigned to the facet.


CommunityInformationFacets

CommunityInformationFacets Table

Contains one row for each distinct community information search facet.

Columns

Column name | Data type | Description
FacetTypeID | tinyint | Unique identifier of the facet type.
FacetKey | varbinary | Unique hierarchical key of the facet.
DisplayTerm | nvarchar(255) | Text representation of the facet.
ParentFacetKey | varbinary | Unique identifier the parent facet. This column may be NULL.
NormalTerm | nvarchar(255) | Normalized text representation of the facet used for filtering purposes.
ReferenceID | int | Identifies the underlying identifier associated with the facet key. This column is optional and specific to the facet type.


CommunityInformationFacetTypes

CommunityInformationFacetTypes Table

Contains one row for each community information facet type.

Columns

Column name | Data type | Description
FacetTypeID | tinyint | Unique identifier of the facet type.
Name | nvarchar(255) | Unique name of the
FacetKindID | tinyint | Identifies the facet kind.


CommunityInformationIndexDefinition

CommunityInformationIndexDefinition Table

Contains a list of indexes built off community information records.

Columns

Column name | Data type | Description
IndexKey | char | The Z39.50 mnemonic
IndexName | nvarchar(40) | Is the description of the index
IndexOrder | smallint | What order the indexes are built in (initially when a db is loaded)
Type | char | Is it alphabetic, numeric, or both types of string data

See Also

CommunityInformationIndexParams,


CommunityInformationIndexParams

CommunityInformationIndexParams Table

Defines the tags used in community browse indexing and keyword indexing. (see the table communityInformationBrowseSubfields for details on subfield information)

Columns

Column name | Data type | Description
IndexKey | char | The Z39.50 mnemonic - character code.
CommunityInformationIndexParamsTag | smallint | The actual tag number in the index
Type | char | What type data is found in index (alpha, numeric, or both)
AddedEntry | bit | Used for special processing for primary names
HonorNonFiling | smallint | Specifies if this tag has non-filing indicators that need to be taken into account for normalization (for stripping leading articles). 1 - use indicator one 2 - use indicator two 0/null - No non-filing indicators
Precedence | smallint | The precedence of this tag in the associated index. (i.e. precedence of 1 indicates the tag of highest precedence)

See Also

CommunityInformationBrowseSubfields,


CommunityInformationKeywordIndex

CommunityInformationKeywordIndex Table

Contains one row for each keyword indexed in a community information record.

Columns

Column name | Data type | Description
KeywordID | int | Unique identifier of the keyword.
RecordID | int | Unique identifier of the community information record.
TypeFlags | smallint | Identifies one or more keyword types; based on the (MARC) data element from which the keyword was indexed.
TokenizedData | varbinary | Contains compressed binary data which includes the Significance, TypeFlags, ContractionCount, DelimiterClass, ChunkID and WordPosition for each occurrence of a keyword within a given record.


CommunityInformationKeywordRules

CommunityInformationKeywordRules Table

Contains one row for each community information keyword indexing rule. Each community information keyword indexing rule identifies a MARC data element to be indexed and is identified by a unique tag/subfield pair.

Columns

Column name | Data type | Description
TagNumber | smallint | Identifies the tag of a MARC data field to be indexed. This column combined with the Subfield column is unique for each row.
Subfield | char | Identifies the subfield of a MARC data element to be indexed. This column combined with the TagNumber column is unique for each row.
TypeFlags | int | Restricts the keyword rule to a set of keyword types.
MinimumSignificance | real | Contains the minimum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
MaximumSignificance | real | Contains the maximum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
AverageTermCount | real | Contains the average term count for a given data element associated with a specific TagNumber and Subfield.
AverageTermCountStandardDeviation | real | Contains the standard deviation of the AverageTermCount for a given data element associated with a specific TagNumber and Subfield.


CommunityInformationKeywords

CommunityInformationKeywords Table

Contains one row for each distinct keyword found in a community information record.

Columns

Column name | Data type | Description
KeywordID | int | Unique identifier of the keyword.
Term | nvarchar(128) | Normalized term used for keyword and phrase searching.
Weight | real | The IDF (inverse document frequency) weight associated with the term. The weight equals log((N + 1) / n), where N = total number of records and n = number of records containing one or more occurrences of the keyword.

See Also

CommunityInformationKeywordIndex,


CommunityInformationKeywordScaleFactors

CommunityInformationKeywordScaleFactors Table

Contains one row for each community information keyword scale factor.

Columns

Column name | Data type | Description
ScaleID | tinyint | Unique identifier of the keyword scale.
TagNumber | smallint | Identifies the tag of a MARC data field to be indexed. This column combined with the Subfield column is unique for each row.
Subfield | char | Identifies the subfield of a MARC data element to be indexed. This column combined with the TagNumber column is unique for each row.
MinimumSignificance | real | Contains the minimum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
MaximumSignificance | real | Contains the maximum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.


CommunityInformationKeywordScales

CommunityInformationKeywordScales Table

Contains one row for each promotion keyword scale. Each keyword scale is associated with a set of predefined keyword scale factors.

Columns

Column name | Data type | Description
ScaleID | tinyint | Unique identifier of the keyword scale.
Name | nvarchar(100) | Unique name of the keyword scale.

See Also

CommunityInformationKeywordScaleFactors,


CommunityInformationKeywordTypes

CommunityInformationKeywordTypes Table

Contains one row for each community information keyword type.

Columns

Column name | Data type | Description
TypeID | tinyint | Unique identifier of the keyword type.
Name | nvarchar(100) | Unique name of the keyword type.
Mnemonic | nvarchar(32) | Search qualifier name.
MinimumDegradation | float | Contains the minimum degradation applied to the relevance of a collocation composed of multiple keywords.
MaximumDegradation | float | Contains the maximum degradation applied to the relevance of a collocation composed of multiple keywords.


CommunityInformationMaterialListLinks

CommunityInformationMaterialListLinks Table

For Future use in event sign up

Columns

Column name | Data type | Description
MaterialListID | int | For Future Use
ListID | int | For Future use
ListTypeID | int | For Future Use
ListDescription | nvarchar(255) | For future use
CommunityInformationRecordID | int | For future use


CommunityInformationPACFilter

CommunityInformationPACFilter Table

Contains one row for each community information record that should not display in PAC.

Columns

Column name | Data type | Description
CommunityInformationRecordID | int | Identifies a community information record that should not display in PAC.


CommunityInformationPatronAssociations

CommunityInformationPatronAssociations Table

A table to associate a patron with a community information record. Patrons with entires in this table may edit community information records.

Columns

Column name | Data type | Description
CommunityInformationRecordID | int | The Community Information Record associated with the patron.
PatronID | int | The Patrons ID
CommunityRoleGroupID | int | The role group with which the patron is assigned


CommunityInformationPostalCodeIndex

CommunityInformationPostalCodeIndex Table

The Community Information Postal code index. This index allows for searhing of community information records by postal code

Columns

Column name | Data type | Description
CommunityInformationPostalCodeIndexID | int | Unique Identifier
CommunityInformationRecordID | int | The Community Information Record ID
CommunityInformationTagID | int | The community Information Tag ID
PostalCodeString | nvarchar(255) | The postal code
NormalPostalCodeString | nvarchar(255) | The normalized postal code string
DisplayInPAC | bit | Indicates of the entry is available in PAC


CommunityInformationPrimaryNameIndices

CommunityInformationPrimaryNameIndices Table

This table is the index for browse searching of primary names (used by community records to find valid headings)

Columns

Column name | Data type | Description
PrimaryNameHeadingID | int | Unique Identifier of the browse heading
CommunityInformationTagID | int | The community information TagID
CommunityInformationRecordID | int | The Community Information RecordID
DisplayInPAC | bit | Indicates id the entry will display in PAC
CommunityAuthorityRecordID | int | For future use


CommunityInformationRecords

CommunityInformationRecords Table

Main community ifnormation record table. There is a single entry in this table for each MARC community information record in the system. Additional contents of the record are contained in the CommunityInformationTags and CommunityInformationSubfields tables.

Columns

Column name | Data type | Description
CommunityInformationRecordID | int | The unique identifier of the community information record
RecordStatusID | int | The Polaris Record Status
RecordOwnerID | int | The Owning Polaris Organization ID
CreatorID | int | The Polaris User who created the record
ModifierID | int | The polaris user that modified the record
BrowsePrimaryName | nvarchar(255) | The name of the organization
BrowseProgramEventTitle | nvarchar(255) | The title of the event or program
DisplayInPAC | tinyint | Indicates if the record will display in PAC
ImportedDate | datetime | The date the record was imported
RecordStatus | char | This is part of the leader of the record. It represents position 5.
TypeOfRecord | char | This is part of the leader of the record. It represents position 6.
KindofData | char | For future use
LDR08 | char | This is part of the leader of the record. It represents position 8.
LDR17 | char | This is part of the leader of the record. It represents position 17.
LDR18 | char | This is part of the leader of the record. It represents position 18.
LDR19 | char | This is part of the leader of the record. It represents position 19.
MARCCharCodingScheme | char | LDR/09 - tells use whether the record is Unicode format or not.
VolunteerOpportunities | char | For future use
VolunteersProvided | char | For Future use
ChildCareArrangements | char | for future use
SpeakersBureau | char | For Future use
MutualSupportGroups | char | For Future use
HasURL | bit | Indicates if the record has a primary URL
MeetingRoomsAndFacilitiesAvailable | char | For future use in event sign up
MARCLanguage | nchar | This data is pulled from tag 008/35-37 during the indexing process
DateEnteredOnFile | nchar | The date the record was created
MARCModificationDate | nchar | This data is pulled from tag 005 during the indexing process.
SortPrimaryName | nvarchar(255) | The normalized form of the primary name
RecordStatusDate | datetime | The date the record status was updated
PrimaryCommunityInformationTOOID | tinyint | The type of record
FirstAvailableDate | datetime | For future use
CreationDate | datetime | The date the record was created
ModificationDate | datetime | When the record was modified
SortProgramEventTitle | nvarchar(255) | The Normalized form of the event or program title
Popularity | int | For future use in event sign up
ImportedFileName | nvarchar(255) | The name of the file from which the record was imported
BrowseProgramEventTitleNonFilingCount | tinyint | The non-filing count used in the event or program title tag (if any)
ExpirationDate | datetime | The date the record will expire (used by events and programs)
ActionDate | datetime | For future use
BeginingDate | datetime | For Future use
PurgeDate | datetime | The date on which the purge process took place
PrimaryAddress | nvarchar(255) | The concatenated primary address
ContentXChangeOrganizationID | int | The Polaris organization to use when displaying ContentXChange widgets

See Also

CommunityInformationDeDup1XXIndex, CommunityInformationDeDup245Index, CommunityInformationDeDup246Index, CommunityInformationDeDup247Index, CommunityInformationDeDup270Index, CommunityInformationEventsPrograms, CommunityInformationKeywordIndex, CommunityInformationPatronAssociations, CommunityInformationPostalCodeIndex, CommunityInformationPrimaryNameIndices, CommunityInformationRelatedOrganizations, CommunityInformationSeriesIndices, CommunityInformationServicesAvailableIndices, CommunityInformationSubjectIndices, CommunityInformationTag041Index, CommunityInformationTag043Index, CommunityInformationTag072Index, CommunityInformationTag073Index, CommunityInformationTags, CommunityInformationThumbnailImages, CommunityInformationTitleIndices, CommunityInformationUnauthorizedHeadings, CommunityRecordsToOrganizations, CommunityRecordStoreLinks, CommunitySocialEntities, ContentXChangePersonalPageOptions, PromotionCommunityLinks,


CommunityInformationRelatedOrganizations

CommunityInformationRelatedOrganizations Table

A table that links events and programs to multiple community organization entities. This tables indicates of the event or program is co-sponsored by several organizations.

Columns

Column name | Data type | Description
RealtedOrganizationEntityID | int | The CommunityInformationRecordID of the co-sponsoring organization.
CommunityInformationRecordID | int | The community information record id of the event or program
CommunityInformationTagID | int | The tag containing the name of the co-sponsor
RelatedOrganizationID | int | A unique identifier for this relation
RelatedOrganizationPrimaryNameTagID | int | The related organizations promary name
BrowsePrimaryName | nvarchar(255) | The promary name of the co-sponsoring organization
SortPrimaryName | nvarchar(255) | The normalized for of the related organizations promary name


CommunityInformationRoleGroups

CommunityInformationRoleGroups Table

Role Groups for patron associations with community information records

Columns

Column name | Data type | Description
CommunityRoleGroupID | int | Unique Identifier
RoleGroupDescr | nvarchar(255) | Description

See Also

CommunityInformationPatronAssociations, CommunityRoleDefintions,


CommunityInformationRoles

CommunityInformationRoles Table

Individual roles for community information patron associations

Columns

Column name | Data type | Description
CommunityRoleID | int | Unique Identifier
RoleDescr | nvarchar(255) | The description of the role
Mnemonic | nvarchar(30) | The Mnemonic of the role

See Also

CommunityRoleDefintions,


CommunityInformationSaves

CommunityInformationSaves Table

A table used in smart indexing of community information records

Columns

Column name | Data type | Description
CommunityInformationRecordID | int | The Community Information Record ID
CommunityInformationTagID | int | The tag being indexed
CommunityInformationTagNumber | smallint | The type of tag being indexed
CommunityInformationSaveCode | smallint | The save code
IndexTime | datetime | The date/time the entry was added


CommunityInformationSeriesIndices

CommunityInformationSeriesIndices Table

For Futire Use

Columns

Column name | Data type | Description
CommunitySeriesEntryID | int | For future use
CommunityInformationTagID | int | For future use
CommunityInformationRecordID | int | For future use
DisplayInPAC | bit | For future use
CommunityAuthorityRecordID | int | For future use


CommunityInformationServicesAvailableIndices

CommunityInformationServicesAvailableIndices Table

The serivces available browse index

Columns

Column name | Data type | Description
ServicesAvailableEntryID | int | The Heading ID
CommunityInformationTagID | int | The tag ID of the service
CommunityInformationRecordID | int | The Community Information Record ID
DisplayInPAC | bit | Indicates if the record displays in PAC


CommunityInformationSubfields

CommunityInformationSubfields Table

The Community MARC subfield table. Every subfield in the community MARC record will contain an entry in this table. This table contains a foreign key to the CommunityInformationTags entity to identify the MARC tag that contains this subfield.

Columns

Column name | Data type | Description
CommunityInformationSubfieldID | int | Primary Key unique identifier (IDENTITY)
CommunityInformationTagID | int | Link to the CommunityInformationTags table
SubfieldSequence | smallint | Where this particular subfield exists in relation to other subfields in a tag.
Subfield | char | The character subfield code
Data | nvarchar(4000) | The subfield data (Unicode)
NumberOfNonFilingCharacters | tinyint | Is the number of non-filing characters that should be ignored for collating purposes

See Also

CommunityInformationSubfieldsAuthorized,


CommunityInformationSubfieldsAuthorized

CommunityInformationSubfieldsAuthorized Table

For Future use

Columns

Column name | Data type | Description
CommunityInformationSubfieldID | int | For Future use
CommunityInformationTagID | int | For Future use
AuthorizingRecordID | int | For Future use


CommunityInformationSubjectIndices

CommunityInformationSubjectIndices Table

Community information Subject Index associative entity. This table is an associative entity (with additional information) between the Subject search index table (SU_Index) and the Community information. It maps a Community information subject heading in SU_Index to all Community information records that contain that subject, Additional information for each Community information map is included in this table.

Columns

Column name | Data type | Description
CommunitySubjectHeadingID | int | Link to Community information subjects table
CommunityInformationTagID | int | Link to Community information. Tags table
CommunityInformationRecordID | int | Link to Community information Record table
DisplayInPAC | bit | Indicates whether or not the Community information referenced in the CommunityInformationRecordID column should display in PAC. This column is synchronized with the CommunityInformationRecords.DisplayInPAC column
CommunityAuthorityRecordID | int | For Future use


CommunityInformationTag041Index

CommunityInformationTag041Index Table

Index used for searching MARC community tag 041 values.

Columns

Column name | Data type | Description
CommunityInformationTag041IndexID | int | Unique identifier for the row.
CommunityInformationRecordID | int | Link to CommunityInformationRecords table
CommunityInformationTagID | int | Link to community Tag table
LanguageCodeString | nvarchar(255) | The data string which is searched upon (the index).
NormalLanguageCodeString | nvarchar(255) | The normalized form data string which is searched upon (the index).
DisplayInPAC | bit | Indicates if the entry displays in PAC


CommunityInformationTag043Index

CommunityInformationTag043Index Table

Index used for searching MARC community tag 043 values.

Columns

Column name | Data type | Description
CommunityInformationTag043IndexID | int | Unique identifier for the row.
CommunityInformationRecordID | int | Community Information Record ID
CommunityInformationTagID | int | Link to community Tag table
GeographicClassificationString | nvarchar(255) | The data string which is searched upon (the index).
NormalGeographicClassificationString | nvarchar(255) | The normalized data string which is searched upon (the index).
DisplayInPAC | bit | Indicates if the entry displays in PAC


CommunityInformationTag072Index

CommunityInformationTag072Index Table

Index used for searching MARC community tag 072 values.

Columns

Column name | Data type | Description
CommunityInformationTag072IndexID | int | Unique identifier for the row.
CommunityInformationRecordID | int | Link to Community Record table
CommunityInformationTagID | int | Link to community tag table
HumanServicesString | nvarchar(255) | The data string which is searched upon (the index).
NormalHumanServicesString | nvarchar(255) | The normalized data string which is searched upon (the index).
DisplayInPAC | bit | Indicates if the entry displays in PAC


CommunityInformationTag073Index

CommunityInformationTag073Index Table

Index used for searching MARC community tag 073 values.

Columns

Column name | Data type | Description
CommunityInformationTag073IndexID | int | Unique identifier for the row.
CommunityInformationRecordID | int | Link to community Record table
CommunityInformationTagID | int | Link to community Tag table
TypeofProgramOrganizationCodeString | nvarchar(255) | The data string which is searched upon (the index).
NormalTypeofProgramOrganizationCodeString | nvarchar(255) | The normalized data string which is searched upon (the index).
DisplayInPAC | bit | Indicates if the record displays in PAC


CommunityInformationTags

CommunityInformationTags Table

The Community information MARC tag table. This table contains an entry for each tag in the MARC record. The indicators for the tag is stored in this table along with a sequence number whish is the ordinal position in the MARC record for this specific tag. All subfields for this tag are stored in the Community information Subfield entitys.

Columns

Column name | Data type | Description
CommunityInformationTagID | int | Primary Key unique identifier (IDENTITY)
CommunityInformationRecordID | int | Link to Community information Record table
Sequence | smallint | Where is this tag in relation to other tags in a community record?
TagNumber | smallint | The tag number
IndicatorOne | char | First indicator value for tag
IndicatorTwo | char | Second indicator value for tag
EffectiveTagNumber | smallint | Is the effective tag number to be used for indexing purposes. If the TagNumber column equals 880 and the first subfield is a properly formatted $6, then this column contains the linked tag number from the first subfield $6, otherwise this column equals the TagNumber column.

See Also

CommunityInformationDeDup245Index, CommunityInformationDeDup246Index, CommunityInformationDeDup247Index, CommunityInformationDeDup270Index, CommunityInformationEventsPrograms, CommunityInformationPostalCodeIndex, CommunityInformationPrimaryNameIndices, CommunityInformationRelatedOrganizations, CommunityInformationSeriesIndices, CommunityInformationServicesAvailableIndices, CommunityInformationSubfields, CommunityInformationSubfieldsAuthorized, CommunityInformationSubjectIndices, CommunityInformationTag041Index, CommunityInformationTag043Index, CommunityInformationTag072Index, CommunityInformationTag073Index, CommunityInformationTitleIndices, CommunityInformationUnauthorizedHeadings,


CommunityInformationThumbnailImages

CommunityInformationThumbnailImages Table

A table that provides a link between community information records and their thumbnail images (if any)

Columns

Column name | Data type | Description
ThumbnailID | int | Primary Key unique identifier (IDENTITY)
CommunityInformationRecordID | int | The Community Information Record
ThumbnailURL | nvarchar(4000) | The URL of the thumbnail
ThumbailDescription | nvarchar(80) | The Alt text used with the image


CommunityInformationTitleIndices

CommunityInformationTitleIndices Table

This table associates title entries with community records.

Columns

Column name | Data type | Description
ProgramEventTitleEntryID | int | Identfies the title entry to which a community record is associated with
CommunityInformationTagID | int | community tag identifier to which the title entry refers. This column is also a unique identifier for the row
CommunityInformationRecordID | int | Identifier of the community record to which the title entry refers
DisplayInPAC | bit | Indicates whether or not the community record referenced in the communityinformationRecordID column should display in PAC. This column is synchronized with the communityinformationRecords.DisplayInPAC column.


CommunityInformationTypeOfOrganization

CommunityInformationTypeOfOrganization Table

A table containing the valid types of organizations

Columns

Column name | Data type | Description
CommunityTypeOfOrganizationID | tinyint | Primary key
Precedence | int | Indiocates the precendence of the type entry
Description | nvarchar(80) | A desription of the type
SearchCode | nvarchar(25) | The PAC search code used in finding records of this type

See Also

CommunityInformationEventsPrograms, CommunityInformationRecords,


CommunityInformationUnauthorizedHeadings

CommunityInformationUnauthorizedHeadings Table

For Future use

Columns

Column name | Data type | Description
CommunityInformationRecordID | int | For Future use
CommunityInformationTagID | int | For Future use
Heading | nvarchar(255) | For Future use


CommunityMainTitleEntries

CommunityMainTitleEntries Table

Contains one row for each unique normalized community title entry.

Columns

Column name | Data type | Description
ProgramEventTitleEntryID | int | Unique identifier for the row.
NormalProgramEventTitle | nvarchar(255) | Normalized title entry suitable for searching and sorting puporses. This column is unique for each row.
BrowseProgramEventTitle | nvarchar(255) | Unnormalized title entry suitable for display purposes.
StaffCount | int | Real-time count of distinct community records associated with the NormalTitle column that can be displayed in the staff client.
PACCount | int | Real-time count of distinct community records associated with the NormalTitle column that can be displayed in the PAC.

See Also

CommunityInformationTitleIndices,


CommunityPrimaryName4XX

CommunityPrimaryName4XX Table

This table provides a link between the primary name headings for See References.

Columns

Column name | Data type | Description
ID4xx | int | Main PrimaryNameHeadingID value for the primary name represented in a 4XX community authority tag
ID1xx | int | Main PrimaryNameHeadingID for the primary name associated with 1XX community authority tag entry (the See heading)
CommunityAuthorityTagID | int | Link to Community Authority tag table
DisplayCode | char | Cross Reference Display Code referencing the field, CrossReferenceDisplayConstants.CrossReferenceCode


CommunityPrimaryName5XX

CommunityPrimaryName5XX Table

This table provides a link between the primary name community headings for See Also References.

Columns

Column name | Data type | Description
ID5xx | int | PrimaryNameHeadingID for the primary name associated with 5XX authority tag entry (the See Also heading)
ID1xx | int | PrimaryNameHeadingID for the Primary Nameassociated with 1XX authority tag entry
CommunityAuthorityTagID | int | Link to community Authority tag table
DisplayCode | char | Cross Reference Display Code referencing the field, CrossReferenceDisplayConstants.CrossReferenceCode


CommunityPrimaryNameHeadings

CommunityPrimaryNameHeadings Table

Contains one row for each unique normalized primary name heading.

Columns

Column name | Data type | Description
PrimaryNameHeadingID | int | Unique identifier for the row.
PrimaryName | nvarchar(255) | Normalized primary name heading suitable for searching and sorting puporses. This column is unique for each row.
BrowsePrimaryName | nvarchar(255) | Unnormalized primary name heading suitable for display purposes.
StaffCount | int | Real-time count of distinct community information records associated with the Author column that can be displayed in the staff client.
PACCount | int | Real-time count of distinct community information records associated with the Author column that can be displayed in the PAC.

See Also

CommunityInformationPrimaryNameIndices, CommunityPrimaryName4XX, CommunityPrimaryName5XX,


CommunityRecordsToOrganizations

CommunityRecordsToOrganizations Table

A table that links community information records directly to Polaris Organization entities.

Columns

Column name | Data type | Description
CommunityInformationRecordID | int | The community Information Record
OrganizationID | int | The Polaris Organization That this record represents


CommunityRecordStoreLinks

CommunityRecordStoreLinks Table

A table that relates various lists with a community information record.

Columns

Column name | Data type | Description
RecordStoreID | int | The ID of the associated list
CommunityInformationRecordID | int | The Community Information Record ID
RecordStoreTypeID | int | The Type of list (Patron Title List, Saved Search, or Polaris Record Set.


CommunityRoleDefintions

CommunityRoleDefintions Table

A table to build relations between community roles and role groups. - Polaris internal table

Columns

Column name | Data type | Description
CommunityRoleGroupID | int | The Role group ID
CommunityRoleID | int | The Role ID associated with the role group


CommunitySeries4XX

CommunitySeries4XX Table

For future use

Columns

Column name | Data type | Description
ID4xx | int | For future use
ID1xx | int | For future use
CommunityAuthorityTagID | int | For future use
DisplayCode | char | For future use


CommunitySeries5XX

CommunitySeries5XX Table

For future use

Columns

Column name | Data type | Description
ID5xx | int | For future use
ID1xx | int | For future use
CommunityAuthorityTagID | int | For future use
DisplayCode | char | For future use


CommunitySeriesEntries

CommunitySeriesEntries Table

For future use

Columns

Column name | Data type | Description
CommunitySeriesEntryID | int | For future use
Series | nvarchar(255) | For future use
BrowseSeries | nvarchar(255) | For future use
StaffCount | int | For future use
PACCount | int | For future use

See Also

CommunityInformationSeriesIndices, CommunitySeries4XX, CommunitySeries5XX,


CommunityServicesAvailableEntries

CommunityServicesAvailableEntries Table

Contains one row for each unique normalized service entry.

Columns

Column name | Data type | Description
ServicesAvailableEntryID | int | Primary Key
NormalService | nvarchar(255) | Normalized service entry suitable for searching and sorting puporses. This column is unique for each row.
BrowseService | nvarchar(255) | Unnormalized service entry suitable for display purposes.
StaffCount | int | Real-time count of distinct community information records associated with the Series column that can be displayed in the staff client.
PACCount | int | Real-time count of distinct community ifnormation records associated with the Series column that can be displayed in the PAC.

See Also

CommunityInformationServicesAvailableIndices,


CommunitySocialEntities

CommunitySocialEntities Table

A table containing a community information records social entity entries

Columns

Column name | Data type | Description
SocialEntityID | int | Primary Key
CommunityInformationRecordID | int | Relation to the community Information Records Table
FacebookAccountID | nvarchar(4000) | The facebook account ID, used in building the "like" button on the community information record full display in the PAC
FacebookURL | nvarchar(4000) | The organizations facebook URL
TwitterURL | nvarchar(4000) | The Organizations Twitter feed URL
BlogURL | nvarchar(4000) | The URL of the organizations BLOG
LinkedInURL | nvarchar(4000) | The organizations LinkedIn URL
MySpaceURL | nvarchar(4000) | The organizations MySpace URL


CommunitySubject4XX

CommunitySubject4XX Table

Provides a link between the Community Subject Bib headings for See References.

Columns

Column name | Data type | Description
ID4xx | int | The CommunityMainSubjectHeadingID for the Subject associated with 4XX authority tag entry.
ID1xx | int | The CommunituyMainSubjectHeadingID for the Subject associated with 1XX authority tag entry. (The See heading)
CommunityAuthorityTagID | int | Link to community authority tags table
DisplayCode | char | Cross Reference Display Code referencing the field CrossReferenceDisplayConstants.CrossReferenceCode


CommunitySubject5XX

CommunitySubject5XX Table

Provides a link between the Subject community headings for See Also References.

Columns

Column name | Data type | Description
ID5xx | int | The community MainSubjectHeadingID for the Subject associated with 5XX authority tag entry. (The See Also heading)
ID1xx | int | The Community MainSubjectHeadingID for the Subject associated with 1XX authority tag entry
CommunityAuthorityTagID | int | Link to community authority tags table
DisplayCode | char | Cross Reference Display Code referencing the field CrossReferenceDisplayConstants.CrossReferenceCode


CommunitySubjectHeadingGroups

CommunitySubjectHeadingGroups Table

for future use

Columns

Column name | Data type | Description
CommunitySubjectHeadingGroupID | int | for future use
CommunitySubjectHeadingID | int | for future use


CommunitySubjectHeadings

CommunitySubjectHeadings Table

Contains one row for each unique normalized subject heading for community information records.

Columns

Column name | Data type | Description
CommunitySubjectHeadingID | int | Unique identifier for the row.
Subject | nvarchar(255) | Normalized subject heading suitable for searching and sorting puporses. This column is unique for each row.
BrowseSubject | nvarchar(255) | Unnormalized subject heading suitable for display purposes.
StaffCount | int | Real-time count of distinct community information records associated with the Subject column that can be displayed in the PAC.
PACCount | int | Real-time count of distinct community information records associated with the Subject column that can be displayed in the staff client.

See Also

CommunityInformationSubjectIndices, CommunitySubject4XX, CommunitySubject5XX,


CompressedHoldings

CompressedHoldings Table

This table stores the location level serial holdings record data.

Columns

Column name | Data type | Description
OrganizationId | int | Organization ID where SHR belongs.
BibliographicRecordId | int | Bibliographic record ID
Holdings | nvarchar(255) | Compressed holdings statement. This result is generated by the database daily job Buildup Compressed Holdings statement.
Note | nvarchar(512) | Obsolete. Replaced by multiple rows in ShrSharedPublicNotes table.
RetDesignatorID | int | Retention Designator ID on the serial holdings record. If multiple SHR exist per location/bibliographic record, this ID field is shared by all the SHRs.
RetDesignSpec00813 | varchar(1) | Retention period indicator, latest (1) or previous (0), on serial holdings record. If multiple SHR exist per location/bibliographic record, this indicator field is shared by all the SHRs.
RetDesignSpec00814 | int | Retention period on serial holdings record. If multiple SHR exist per location/bibliographic record, this period field is shared by all the SHRs.
RetDesignSpec00815 | varchar(1) | Retention period term (y - year, m - month, w - week, i - issues, e - edition, etc.) on serial holdings record. If multiple SHR exist per location/bibliographic record, this period term field is shared by all the SHRs.
RetentionNote | nvarchar(255) | Retention note. This note is generated by the database daily job Buildup Compressed Holdings statement according to location retention indicator data.
CreationDate | datetime | Date record was created
ModificationDate | datetime | Date record was last modified
MD5Hash | varbinary | MD5 hash of the record contents
LastReceivedIssue | nvarchar(780) | Designation of the last received issue


ComputypeLabelPrinterCommands

ComputypeLabelPrinterCommands Table

This table stores Computype Label printer commands. The entries in this table are needed only if a LabelMorphor IIe printer is used in a terminal server environment. The input to this table is not exposed to users from Polaris graphic user interface. The PSE sets up entries for Polaris customers on a case-by-case basis.

Columns

Column name | Data type | Description
PrinterName | nvarchar(255) | Printer name of the Computype printer installed.
PrinterCommands | nvarchar(510) | value of printer command follows Computype instruction for printer installation. the format of the printer command is: {COMPUTYPE:[DEST]:[PRINTER]} a sample value is: {COMPUTYPE:192.168.5.2:3844Z}


Connections

Connections Table

This table is used to store connection information for entries in the servers table

Columns

Column name | Data type | Description
ConnectionID | int | primary key for the table
ConnectionTypeID | int | Describes the type of connection ( SQL, Z39.50, ILL, EDI,..)
ServerID | int | Server that this row applies to
Name | nvarchar(80) | Name of the server
ConnectionString | nvarchar(1024) | String used to connect to a server's database
ConfigurationString | nvarchar(-1) | String used to connect to a search server via the ERMSDaemon.


ConnectionTypes

ConnectionTypes Table

This table definines the types of server connections available to polaris ( i.e. SQL, Z39.50, ILL )

Columns

Column name | Data type | Description
ConnectionTypeID | int | Primary key
Description | nvarchar(80) | describes the type.

See Also

Connections,


ContactPersons

ContactPersons Table

This table contains the ordering, payment, and claiming contact person data associated with suppliers that the library deals with.

Columns

Column name | Data type | Description
ContactPersonID | int | Polaris assigned unique id for each contact person.
Name | nvarchar(50) | Name associated with the contact person.
EmailAddress | nvarchar(64) | Email address for the contact person.
PhoneNumberOne | nvarchar(20) | Primary phone number for the contact person.
PhoneNumberTwo | nvarchar(20) | Secondary phone number for the contact person.
FaxNumber | nvarchar(15) | Fax number for the contact person.

See Also

Suppliers,


ContentXChangePersonalPageOptions

ContentXChangePersonalPageOptions Table

A table used to store the personal page options selected by an community organization

Columns

Column name | Data type | Description
PersonalPageID | int | Primary Key
CommunityInformationRecordID | int | The community Information Record to use in creating the personalized page.
OrganizationID | int | The Polaris Organization owner of the community information record
PersonalPageName | nvarchar(500) | The URL name of the personal page
PersonalPageTitle | nvarchar(500) | The title displayed in the web browser when opening the page
CalendarType | int | the type of calendar widget selected (if any).
MapItOption | int | Include the "google maps" widget.
DrawerOption | int | Include the "web content drawer" widget.
AskALibrarianOption | int | Include the "ask a librarian" widget.
LibrarySearchBoxOption | int | Include the "search the library catalog" widget.
ThemeID | int | The theme to apply to the personalized page
TitleListID | int | a title list content carousel ID
SavedSearchID | int | If creating a content carrousel, the ID of the saved search


ControlRecordDefs

ControlRecordDefs Table

Control Record Definitions. They're NOT the Control Records themselves.

Columns

Column name | Data type | Description
ControlRecordDefID | int | Unique ID
SubSystemID | int | 1 - Acquisitions 2 - Patron Services 3 - Cataloging 4 - System Administration 5 - PAC 6 - Serials
Type | bit | 0 - OCR 1 - TCR
SystemFlag | bit | If 1, this kind of Control Record exists for System.
LibraryFlag | bit | If 1, this kind of Control Record exists for every Library.
BranchFlag | bit | If 1, this kind of Control Record exists for every Branch.
ControlRecordName | nvarchar(128) | Name

See Also

ControlRecords, PermissionDefs,


ControlRecords

ControlRecords Table

Control Records themselves.

Columns

Column name | Data type | Description
ControlRecordID | int | Unique ID
ControlRecordDefID | int | ID of corresponding definition.
OrganizationID | int | ID of organisation this Control Record belongs. 1 (what is System) for organizationless Control Records.
ModifierID | int | ID of last modifier.
ModificationDate | datetime | Date/time of last modification.

See Also

PermissionGroups, PermissionUsers, PermissionWorkstations,


CopyRetentionDesignators

CopyRetentionDesignators Table

This table defines the literal description of retention designators referenced by Copy record.

Columns

Column name | Data type | Description
RetDesignatorID | int | numeric definition.
Description | nvarchar(225) | literal description.

See Also

CompressedHoldings,


CopySubsStatuses

CopySubsStatuses Table

contains the literal descriptions for Copy record's subscription status. this table is referenced by Copies table SubscrStatusH column.

Columns

Column name | Data type | Description
StatusID | smallint | status ID.
Description | nvarchar(30) | literal description of the status.

See Also

SHRCopies,


Copy_INLISegs

Copy_INLISegs Table

Contains the links between a Serial copy record and a invoice line segment.

Columns

Column name | Data type | Description
CopyID | int | Serial copy record ID.
INLISegID | int | invoice line segment ID.
ModifierID | int | Polaris user ID who builds the link.
TransactionDate | datetime | transaction datetime when the link is built.


Copy_POLISegs

Copy_POLISegs Table

Contains the links between a Serial copy record and a purchase order line segment.

Columns

Column name | Data type | Description
CopyID | int | Serial copy record ID.
POLISegID | int | purchase order line segment ID.
ModifierID | int | Polaris user ID who builds the link.
TransactionDate | datetime | transaction datetime when the link is built.


Countries

Countries Table

Contains zipcode information for different countries.

Columns

Column name | Data type | Description
CountryID | int | Primary key
Country | nvarchar(32) | The country field
PostalCodeFormat | nvarchar(12) | Format of postal code
PostalCodeLength | int | The number of characters that can be present for a valid zip code.
MinZipCodeLength | int | The minimum number of characters in any zip code for the particular country.
DisplayInPAC | bit | Flag to display country in PAC
StateRequired | bit | Indicates whether or not the State field is required in this country

See Also

ILSStoreOrders, PhoneFormatsByCountry, PostalCodes,


CourseInstructorLinks

CourseInstructorLinks Table

This table is the list of course reserves and their associated instructors.

Columns

Column name | Data type | Description
CourseReserveID | int | the course reserve ID
InstructorID | int | patron ID of the instructor (the instructor is really just a patron).
Note | nvarchar(255) | generic Note field
InstructorStatusID | tinyint | Status of the instructor (primary or alternate)


CourseNumbers

CourseNumbers Table

List of course numbers, which are associated with specific courses.

Columns

Column name | Data type | Description
CourseNumberID | int | primary key
CourseID | int | The foreign key to the courses table
CourseNumber | nvarchar(20) | free text course number value
CourseAbbreviation | nvarchar(100) | The abbreviation associated with the course name/course number combination.

See Also

CourseReserves, CourseSections, CourseTemplates,


CourseReserveLinks

CourseReserveLinks Table

This table has the list of course reserves and the reserve item records which are linked them.

Columns

Column name | Data type | Description
CourseReserveID | int | course reserve ID
ItemRecordID | int | Item record ID (is an RIR)
ReserveStatus | tinyint | Status of the item on reserve, can be on reserve, not reserved, or permanent reserve
StartDate | datetime | Start Date when item is on reserve for this course
EndDate | datetime | End Date when item is on reserve for this course
YTDCircCount | int | how many times this item circulated for this course reserve
Note | nvarchar(255) | free text note


CourseReserves

CourseReserves Table

This table is the list of course reserves.

Columns

Column name | Data type | Description
CourseReserveID | int | primary key
CreatorID | int | polaris user who created the CR
ModifierID | int | polaris user
CreationDate | datetime | This column contains the creation date of the record, or the most recent date the course status changed from Inactive to Active.
ModificationDate | datetime | date when CR was last modified
CourseID | int | link to Courses table
OrganizationID | int | organization who owns the CR
TermID | int | link to course terms table
CourseStatusID | int | link to course reserve statuses table
NumberOfStudents | int | number of students in CR
Note | nvarchar(255) | free text note field
CourseNumberID | int | link to course numbers table
CourseSectionID | int | link to course sections table
SchoolDivisionID | int | link to school division table
DepartmentID | int | link to departments table
CourseNumberSection | nvarchar(45) | managed data field handled via triggers for search and display of number/section string data.
AlternateName | nvarchar(80) | alternate name of the CR, free text field
CourseNameNumber | nvarchar(300) | concatination of name and number for searching
PublicNote | nvarchar(255) | Note publicly viewable in the PAC.

See Also

CourseInstructorLinks, CourseReserveLinks, ItemCheckouts, PrevYearReserveItemCourseCirc,


CourseReserveStatuses

CourseReserveStatuses Table

list of possible statuses that a course can have (which are 'active' and 'inactive')

Columns

Column name | Data type | Description
CourseReserveStatusID | int | primary key
Description | nvarchar(50) | free text description

See Also

CourseReserves, CourseTemplates,


Courses

Courses Table

Courses that have been entered in SA and can be selected from for a course reserve record.

Columns

Column name | Data type | Description
CourseID | int | Unique identifier for this entry.
OrganizationID | int | Organization for which the course belongs.
CourseName | nvarchar(255) | The name of the course.

See Also

CourseNumbers, CourseReserves, CourseTemplates,


CourseSections

CourseSections Table

list of sections which are linked to a particular course number

Columns

Column name | Data type | Description
CourseSectionID | int | primary key
CourseNumberID | int | foreign key to course numbers table
SectionNumber | nvarchar(20) | free text field which is the section number

See Also

CourseReserves, CourseTemplates,


CourseTemplates

CourseTemplates Table

list of course reserve templates which are used to create course reserve records.

Columns

Column name | Data type | Description
CourseTemplateID | int | primary key
Name | nvarchar(50) | name of the template
OrganizationOwnerID | int | template owner (organization or user)
CreatorID | int | polaris user
ModifierID | int | polaris user
CreationDate | datetime | date the course template was created
ModificationDate | datetime | date the course template was last changed
CourseID | int | link to the courses table
OrganizationID | int | owner of the CR
TermID | int | link to the course terms table
CourseStatusID | int | link to the course reserve statuses table
NumberOfStudents | int | number of students in the course
Note | nvarchar(255) | free text note field
CourseNumberID | int | link to the course numbers table
CourseSectionID | int | link to the course sections table
SchoolDivisionID | int | link to the school divisions table
DepartmentID | int | link to the departments table
AlternateName | nvarchar(80) | alternate name of the course reserve
PublicNote | nvarchar(255) | Note publicly viewable in the PAC.


CourseTerms

CourseTerms Table

list of term periods that are associated with courses.

Columns

Column name | Data type | Description
TermID | int | primary key
OrganizationID | int | organization who defined the term
TermName | nvarchar(80) | name of the term
TermYear | int | year associated with the course term
StartDate | datetime | start date for the term
EndDate | datetime | end date for the term

See Also

CourseReserves, CourseTemplates,


CrossReferenceCodes

CrossReferenceCodes Table

List of cross reference codes (found in MARC records) used by PAC

Columns

Column name | Data type | Description
CrossReferenceCode | char | The 1 char code
Relationship | nvarchar(80) | The text meaning as defined by MARC

See Also

CrossReferenceDisplayConstants,


CrossReferenceDisplayConstants

CrossReferenceDisplayConstants Table

Lists of display constants according to organization, type, and code for PAC

Columns

Column name | Data type | Description
OrganizationID | int | Link to Organizations table
CrossReferenceCode | char | The MARC cross reference code
CrossReferenceTypeID | int | Link to Cross reference types table
Text | nvarchar(255) | text string to display
Color | nchar | color to display text in


CrossReferenceTypes

CrossReferenceTypes Table

Is a list of cross reference coded types (used by PAC)

Columns

Column name | Data type | Description
CrossReferenceTypeID | int | Primary key - coded value
Description | nvarchar(32) | Text description of type

See Also

CrossReferenceDisplayConstants,


Currencies

Currencies Table

This table allows Polaris' Acquisitions to work with currencies from multiple countries. A base currency must be defined in the System WF and defaults to USD.

Columns

Column name | Data type | Description
CurrencyID | int | Primary Key uniquely identifying each currency entry.
Currency | nvarchar(255) | VARCHAR (50). Full name of currency, ie. 'United States Dollar'
Code | nchar | 3 character Alpha code for a countries currency. ie. USD, CAD, AUD.
Enabled | bit | Bit flag that determines whether an entry is available in Acquisitions or at the system level. The default entry = 0, disabled

See Also

ExchangeRates, Suppliers,


CurrencyConversions

CurrencyConversions Table

Many libraries purchase items from foreign vendors. This table is used to handle currency conversions from the local currency to the foreign of the supplier using an exchange rate agreed to by both the the library and supplier prior ordering or paying ofr any items.

Columns

Column name | Data type | Description
LocaleID | int | Windows LocaleID used to determine the destination countries currency type and format.
ExchangeRate | numeric | Currency exchange rate agreed to between a library/branch and a foreign supplier.
CountryName | nvarchar(50) | Name of foreign country where LocaleID and exchange rate apply.


CursorTypes

CursorTypes Table

This table holds all the types of mouse cursors available for assignment to a particular Children's PAC theme.

Columns

Column name | Data type | Description
CursorTypeID | int | Unique identifier (primary key)
Description | nvarchar(255) | Description of the cursor type (used by the System Administration UI)

See Also

Themes,


Databases

Databases Table

Holds databases defined for each server within Servers.

Columns

Column name | Data type | Description
DBID | int | Primary Key
ServerID | int | References Servers table to associate which server the databases resides on.
DatabaseName | nvarchar(100) | Internal name of database
DisplayName | nvarchar(80) | Name to display for the database.

See Also

FindTool_SaveDefaultSearchDatabases, FindToolTargetSettings, SearchDatabases,


DatesClosed

DatesClosed Table

These are the days during the year that the library is closed.

Columns

Column name | Data type | Description
OrganizationID | int | Link to Organizations table
DateClosed | datetime | A Date the organization is closed. This attribute, combined with the OrganizationID comprises the primary key for the table.


DB_AlterScripts

DB_AlterScripts Table

This table is used in controlling the processing of Alter Scripts in the database upgrade.

Columns

Column name | Data type | Description
ID | int | Unique ID for the row (IDENTITY)
ScriptNum | int | The script number.
ScriptStart | datetime | The time the script was started.
ScriptEnd | datetime | Time of script completion.
Completed | bit | Indicated the script has run to successfull completion.


DB_ResetLogTrunc

DB_ResetLogTrunc Table

This table is used only as a flag table during the DBUpdate process. This table is created at the beginning of the dbupdate process in script 2800 then dropped at the end of the DBUpdate via script DBEndScript.sql

Columns

Column name | Data type | Description
dt | datetime | This is the date time value of when the table was created as a row is inserted at the beginning of the dbupdate process.


DB_ScriptLog

DB_ScriptLog Table

This table contains logging information from Alter Script processing. It is written to by use of the DB_LogIt stored procedure.

Columns

Column name | Data type | Description
dt | datetime | The time the message was logged.
mssg | nvarchar(255) | The log message.


DDM_MediaFormats

DDM_MediaFormats Table

This table contains the Danish Data Model media formats for RFID tag processing.

Columns

Column name | Data type | Description
DDM_MediaFormatID | int | Primary Key
Mnemonic | nvarchar(50) | Name of media format as defined by the Danish Data Model.
Description | nvarchar(50) | User friendly text that describes the media format.

See Also

SelfCheckMaterialTypes,


DeDup1XXIndex

DeDup1XXIndex Table

This index contains a listing of all bib 1xx tags used by the duplicate detection algorithm

Columns

Column name | Data type | Description
DeDup1XXIndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Records table
BibliographicTagID | int | Link to Bib Tags table
Tag1XXaData | nvarchar(450) | Data string searched against for duplicates


DeDup245Index

DeDup245Index Table

This index contains a listing of all bib 245 tags used by the duplicate detection algorithm

Columns

Column name | Data type | Description
DeDup245IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Records table
BibliographicTagID | int | Link to Bib Tags table
Tag245aData | nvarchar(450) | Data string searched against for duplicates


DeDup246Index

DeDup246Index Table

This index contains a listing of all bib 246 tags used by the duplicate detection algorithm

Columns

Column name | Data type | Description
DeDup246IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Records table
BibliographicTagID | int | Link to Bib Tags table
Tag246aData | nvarchar(450) | Data string searched against for duplicates


DeDup247Index

DeDup247Index Table

This index contains a listing of all bib 247 tags used by the duplicate detection algorithm

Columns

Column name | Data type | Description
DeDup247IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Records table
BibliographicTagID | int | Link to Bib Tags table
Tag247aData | nvarchar(450) | Data string searched against for duplicates


DeDup260Index

DeDup260Index Table

This index contains a listing of all bib 260 tags used by the duplicate detection algorithm

Columns

Column name | Data type | Description
DeDup260IndexID | int | Unique identifier for the row.
BibliographicRecordID | int | Link to Bib Records table
BibliographicTagID | int | Link to Bib Tags table
Tag260cData | nvarchar(450) | Data string searched against for duplicates


DeletedPatronAccount

DeletedPatronAccount Table

This table stores all patron account transactions replicated from PatronAccount table when a patron record is deleted from Patrons and PatronRegistration table. All columns in this table are mapped to columns in PatronAccount table.

Columns

Column name | Data type | Description
TxnID | int | ID of the transaction.
PatronID | int | ID of the patron associated with this transaction. It references Patrons table (PatronID).
TxnCodeID | int | ID of the transaction code that distinguishes the nature of different transactions such as Charge, Pay etc. It references PatronAccTxnCodes table (TxnCodeID).
FeeReasonCodeID | int | ID of the reason for this transaction, will be null if no reason. It references FeeReasonCodes table (FeeReasonCodeID).
TxnAmount | money | Amount of this transaction.
OutstandingAmount | money | Outstanding amount that this transaction is having.
ItemRecordID | int | ID of the item associated with this transaction, will be null if no such association.
TxnDate | datetime | Date of the transaction created.
PaymentMethodID | int | ID of the payment method associated with this transaction if any, otherwise will be null. It references PatronPaymentMethods table (PaymentMethodID).
OrganizationID | int | OrganizationID of the governing branch for fine calculations as defined in Systems Administration. Could be Item's Assigned Branch, Patron's Branch or the transacting library's branch.
WorkStationID | int | ID of the computer that the user uses to create this transation. It references Workstations table (WorkstationID).
CreatorID | int | ID of the user who loggs on to Polaris and creates this transaction. It references PolarisUsers table (PolarisUserID)
CheckOutDate | datetime | Check out date of the item associated with this transaction, will be null if no such association.
DueDate | datetime | Due date of the item circulated and associated with this transaction, will be null if no such association.
FreeTextNote | nvarchar(255) | Note of this transaction if any, otherwise will be null.
ILSStoreTransactionID | int | Links to ILSStoreTransactions table. ID of associated credit card transaction. Null if credit card was not used to pay for the fine/fee.
LoaningOrgID | int | Organization ID of item's lending branch. This is usually valid for overdue item related charges.
ItemAssignedBranchID | int | The associated item record's Assigned Branch at the time of the transaction.
PatronBranchID | int | The Patron's registration branch ID at the time of the transaction.


DeletedPatronAccountAssoc

DeletedPatronAccountAssoc Table

This table stores all patron account transaction associates replicated from PatronAccountAssoc table when a patron record is deleted from Patrons and PatronRegistration table. All columns in this table are mapped to columns in PatronAccountAssoc table.

Columns

Column name | Data type | Description
MainTxnID | int | ID of a transaction which is the base to other associated transactions. It references DeletedPatronAccount(TxnID) column.
AssocTxnID | int | ID of a transaction based on another transaction. It references DeletedPatronAccount(TxnID) column.


DeletedPatrons

DeletedPatrons Table

This table stores basic patron information after patron record is deleted from Patrons and PatronRegistration tables.

Columns

Column name | Data type | Description
PatronID | int | Deleted patron's PatronID
Barcode | nvarchar(20) | Deleted patron's barcode
PatronCodeID | int | Deleted patron's PatronCodeID
StatisticalClassID | int | Deleted patron's StatisticalClassID
DeleteDate | datetime | Datetime when patron record is deleted from Patrons and PatronRegistration tables
OrganizationID | int | Organization ID of the deleted patron's registration branch


DeliveryOptions

DeliveryOptions Table

Defines the types of deliveries for correspondences to patrons. Entries in this table describe the data fields and processing to use in making the correspondence.

Columns

Column name | Data type | Description
DeliveryOptionID | int | ID of the delivery method, primary key.
DeliveryOption | nvarchar(30) | Is the description of the delivery method.

See Also

PatronRegistration, Suppliers, SysHoldRequests,


Departments

Departments Table

this table lists the departments for an organization which are potentially associated with course reserves.

Columns

Column name | Data type | Description
DepartmentID | int | primary key
OrganizationID | int | organization where the department is located
DepartmentName | nvarchar(255) | free text field which is the name of the department.

See Also

CourseReserves, CourseTemplates,


Depreciated_SysHoldBibliographicRecords

Depreciated_SysHoldBibliographicRecords Table

Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.

Columns

Column name | Data type | Description
SysHoldRequestID | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
BibliographicRecordID | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
SysHoldReasonCodeID | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.


Depreciated_SysHoldItemRecords

Depreciated_SysHoldItemRecords Table

Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.

Columns

Column name | Data type | Description
SysHoldRequestID | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
ItemRecordID | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
ReasonID | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
RTFDaysPrimary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
RTFDaysSecondary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
RTFBeginDate | datetime | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
Denied | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
DeniedDate | datetime | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
RTFCyclesPrimary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
RTFCyclesSecondary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
TotalRTFDaysPrimary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
TotalRTFDaysSecondary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.


Depreciated_SysHoldItemRecordsHistory

Depreciated_SysHoldItemRecordsHistory Table

Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.

Columns

Column name | Data type | Description
SysHoldRequestID | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
ItemRecordID | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
ReasonID | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
RTFDaysPrimary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
RTFDaysSecondary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
RTFBeginDate | datetime | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
Denied | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
DeniedDate | datetime | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
RTFCyclesPrimary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
RTFCyclesSecondary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
HistoryDate | datetime | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
TotalRTFDaysPrimary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.
TotalRTFDaysSecondary | int | Depreciated functionality from Polaris 4.1R2 from June 2013. Do not use unless you need a data reference point when doing a Polaris installation on your server.


DigitalMediaLibrary

DigitalMediaLibrary Table

This table contains binary data (media files) which is associated with various types of Polaris records. Currently, it is used only for patron photos but has been designed to be expandable as other media types are used/stored by Polaris

Columns

Column name | Data type | Description
DMLID | int | Primary key
BLOBData | image | Binary data stream
DMLTypeID | int | Type of Media

See Also

DML_Patron,


DMLTypes

DMLTypes Table

Digital Media types available in Polaris (currently only pictures are implemented).

Columns

Column name | Data type | Description
DMLTypeID | int | Primary key
Description | nvarchar(20) | Description of media type

See Also

DigitalMediaLibrary,


DML_Patron

DML_Patron Table

Table associating a Patron with a piece of digital media.

Columns

Column name | Data type | Description
PatronID | int | Polaris patron ID
DMLID | int | Key from DigitalMediaLibrary table
CreationDate | datetime | Date photo was created
ModificationDate | datetime | Date photo was modified


Domains

Domains Table

This table defines the domains in Polaris systems administration. Each domain has a primary key equal to a single set bit. This is the bit that is set in AdminAttributes.ControlFlags for defining the valid domains for a given administration attribute.

Columns

Column name | Data type | Description
DomainID | int | ID
Domain | nchar | Domain lever: System, Library, Branch, Collection, Workstation, User, Patron, Database, or Server

See Also

AdminCategories, LabelConfigDefs, LabelContentOptionDefs, SA_SL_BranchFundFilter_DomainSettings,


DonationCategories

DonationCategories Table

This table holds the donation category descriptions used when a patron donates a monetary gift to the library via the PowerPAC.

Columns

Column name | Data type | Description
DonationCategoryID | int | Primary key for individual donation category records.
Description | nvarchar(50) | Displayable text for dropdowns.
AllowAcknowledgement | bit | Bit that controls if acknowledgement fields are displayed on the donation workform in the PowerPAC.

See Also

Donations,


Donations

Donations Table

This table holds the donation information submitted by the patron when they donate a monetary gift to the library via the PowerPAC.

Columns

Column name | Data type | Description
DonationID | int | Primary key for individual donation records.
DonationCategoryID | int | Foreign key to donation category record.
ReceivingOrgID | int | Foreign key to organization that should receive the donation.
Amount | decimal | Monetary amount of donation.
SendAcknowledgement | bit | Bit signifying an acknowledgement should be sent.
AckName | nvarchar(50) | Acknowledgement name field.
AckAddress | nvarchar(100) | Acknowledgement address field.
AckCity | nvarchar(50) | Acknowledgement city field.
AckStateProvinceID | int | Acknowledgement state field.
AckZip | nvarchar(20) | Acknowledgement zip code field.
AckEmail | nvarchar(50) | Acknowledgement email field.
PurchaseTitle | bit | Text field to store a title name the donation should be used to purchase.
SubjectArea | nvarchar(100) | Text field to store a subject area item the donation should be used to purchase.
Processed | bit | Bit signifying if the library is done "handling" this donation. Used to verify an acknowledgement was sent if required.
ProcessedDate | datetime | Date this donation was processed.
DonationDate | datetime | Date donation was submitted.
ILSStoreOrderID | int | Foreign key to ILS Store Order record.
DonatingPatronBarcode | nvarchar(20) | Barcode of patron who submitted the donation.


Donors

Donors Table

contains donor information displayed by funds that are of the type donor. Donor info can also be used / displayed in item records for items that were donated.

Columns

Column name | Data type | Description
DonorID | int | primary key for individual donor records.
FirstName | nvarchar(30) | first name of donor if not a corporation
MiddleName | nvarchar(15) | middle name of donor if not a corporation
LastName | nvarchar(50) | last name of donor if not a corporation
CorporateName | nvarchar(255) | name of the donor if a corporation.
Phone | nvarchar(30) | phone number of donor.
Fax | nvarchar(30) | fax number for donor.
Email | nvarchar(70) | email address for donor.
MemorialNote | nvarchar(255) | note for use if donor fund is created in memory of a person.
DescriptionNote | nvarchar(255) | free text note for donor record info.
RestrictionNote | nvarchar(255) | free text note field for any donor fund restrictions. (ie. not to be used for purchasing rap music)
RenewalDate | datetime | for re-newable donation funds, this is the date by which the fund should be renewed.
AddressID | int | integer key to addresses table containing the address data for the particular donor.

See Also

Funds, ItemRecordDetails, ItemTemplates,


DRMAuthenticationData

DRMAuthenticationData Table

A table to store DRM authentication information received from a vendors repository

Columns

Column name | Data type | Description
VendorID | int | The Vendor ID
PatronID | int | The Polaris Patron ID
DRMUserName | nvarchar(4000) | The DRM User name associated with the patron
DRMPassword | nvarchar(4000) | The DRM password reported (if any)


DueDateModificationReasons

DueDateModificationReasons Table

Contains one row for each due date modification reason

Columns

Column name | Data type | Description
ReasonID | int | Unique identifier
Description | nvarchar(50) | Text description of the reason


DWIAttributeTypes

DWIAttributeTypes Table

Defines the attributes associated with a DWI-LDAP Entry.

Columns

Column name | Data type | Description
AttributeTypeID | int | Primary Key unique identifier
EntryID | int | FK Link to the DWIEntries table
AttributeType | nvarchar(255) | Attribute Name (as defined in DWIRSchemaAttributes). This can be considered a FK reference to DWIRSchemaAttributes.AttributeType, but it is not enforced by rule in the Database.

See Also

DWIAttributeValues,


DWIAttributeValues

DWIAttributeValues Table

Contains the Attribute Data Values for DWI-LDAP entries.

Columns

Column name | Data type | Description
AttributeTypeID | int | FK Link to DWIAttributeTypes table
Value | nvarchar(840) | The Attribute value.


DWIEntries

DWIEntries Table

Contains an entry for each DWI-LDAP structured entry.

Columns

Column name | Data type | Description
EntryID | int | Primary Key unique identifier
CommonName | nvarchar(255) | Common Name for this DWI-LDAP Entry.

See Also

DWIAttributeTypes, DWIEntryDisplayOrder,


DWIEntryDisplayOrder

DWIEntryDisplayOrder Table

This table holds the display order attribute of an entry/parent id pair and is maintained in conjunction with entry creations/deletions (used by the E-Source and Z39.50 configuration UI dialogs in SysAdmin)

Columns

Column name | Data type | Description
EntryID | int | The DWI entry involved
ParentEntryID | int | The parent DWI entry which each child entry id is ordered 'under'
DisplayOrder | int | The relative display order of the given entry with respect to the given parent entry id


DWIRAttributeDataTypes

DWIRAttributeDataTypes Table

Defines the valid attribute Data types allowed in the DWI.

Columns

Column name | Data type | Description
AttributeDataTypeID | int | Primary Key unique identifier
DataType | nvarchar(20) | the name of the Datatype
Description | nvarchar(255) | Description of the Datatype

See Also

DWIRSchemaAttributes,


DWIREnumConstraints

DWIREnumConstraints Table

Defines Enumerated values for an attribute type.

Columns

Column name | Data type | Description
SchemaAttribID | int | FK Reference to DWIRSchemaAttributes.
EnumValue | nvarchar(100) | Enumerated constant value.
DisplayOrder | int | Order in which to display the constants in a UI List.


DWIRFKConstraints

DWIRFKConstraints Table

Defines foreign key constraints within the LDAP DWI schema. (FUTURE)

Columns

Column name | Data type | Description
PKSchemaAttribID | int | Primary Key (to-one side) of the constraint
FKSchemaAttribID | int | Foreign Key (many-to side) of the constraint


DWIRObjects

DWIRObjects Table

Defines the objects types that are supported in the DWI-LDAP Data Structures.

Columns

Column name | Data type | Description
DWIObjectID | int | Unique Identifier.
ObjectName | nvarchar(100) | Name of Object.


DWIRSchema

DWIRSchema Table

Defines the objects allowed in the DWI-LDAP Data Structures

Columns

Column name | Data type | Description
SchemaID | int | Primary Key unique identifier
Description | nvarchar(100) | Object Description

See Also

DWIRSchemaAttributes,


DWIRSchemaAttributes

DWIRSchemaAttributes Table

Defines the various Attributes allowed in the DWI

Columns

Column name | Data type | Description
SchemaAttribID | int | Primary Key unique identifier
SchemaID | int | FK Reference to Object this attribute belongs to (FK to DWIRSchema)
AttributeType | nvarchar(255) | Attribute name
AttributeDataTypeID | int | Data type of this attribute (FK to DWIRAttributeDataTypes)
Key | bit | Flag indicating this attribute is a Primary Key for the DWI object.
Required | bit | flag indicating this attribute is required in the parent object
Repeatable | bit | flag indicating this attribute can be repeated in the parent object
ParentSchemaAttribID | int | Attribute is defined by a parent entry in this table (FK to self)

See Also

DWIREnumConstraints, DWIRFKConstraints, DWIRSchemaAttributes,


EDIAckCodes_ACK01

EDIAckCodes_ACK01 Table

contains ACK01 codes for vendor EDI 855 (PO Acknowledgements). these are line item specific acknowledgements.

Columns

Column name | Data type | Description
VendorSAN | nvarchar(7) | SAN number of vendor that "owns" the given ACK code.
AckCode | nvarchar(3) | 2 digit code that maps to vendor assigned/specific description.
Description | nvarchar(255) | varchar(255). Vendor specified textual decsription for a given ACK code


EDIAckCodes_ACK29

EDIAckCodes_ACK29 Table

contains ACK29 codes for vendor EDI 855 (PO Acknowledgements).

Columns

Column name | Data type | Description
VendorSAN | nvarchar(7) | SAN number of vendor that "owns" the given ACK code.
AckCode | nvarchar(3) | 2 digit code that maps to vendor assigned/specific description.
Description | nvarchar(255) | varchar(255). Vendor specified textual decsription for a given ACK code


EDIAckCodes_BAK02

EDIAckCodes_BAK02 Table

More EDI 855 acknowledgement codes

Columns

Column name | Data type | Description
Code | varchar(2) | 2 digit code that maps to textual decsription
Description | nvarchar(255) | varchar(255) acknowledgement decsription


EDIAckCodes_PO115

EDIAckCodes_PO115 Table

more EDI 855 acknowledgement codes

Columns

Column name | Data type | Description
VendorSAN | nvarchar(7) | SAN of vendor that "owns" the particular ACK code/description
AckCode | nvarchar(3) | 2 digit code mapping to vendor assinged decsription
Description | nvarchar(255) | varcahr(255) textual description of Ack Code


EDIAckCodes_SCH11

EDIAckCodes_SCH11 Table

more 855 vendor assigned ACK codes

Columns

Column name | Data type | Description
VendorSAN | nvarchar(7) | SAN number of vendor that "owns" ACK code.
AckCode | nvarchar(3) | 2 or 3 character codes that map to vendor specific descriptions.
Description | nvarchar(255) | varchar(255) vendor specified textual acknowledgement


EDIDataElement

EDIDataElement Table

defines the data elements in a segment

Columns

Column name | Data type | Description
EDISegmentNo | int | segment number of the data element that is being defined
DataElementSequence | int | position of the data element with in the segment
Value | nvarchar(100) | value of the data element


EDIInvoiceDetail

EDIInvoiceDetail Table

it is a child table for EDIInvoiceHeader and holds the detailed lineitems for the invoice. More information about the columns in these tables can be obtained from the edi invoice specification

Columns

Column name | Data type | Description
StructureID | int | base key that defines the edidocument
ST01 | int | transaction set number
ST02 | nvarchar(50) | transaction set number
IT101 | nvarchar(50) | PO Line Item database ID (POLineItemID)
IT102 | nvarchar(50) | quantity
IT103 | nvarchar(50) | unit of measure
IT104 | nvarchar(50) | price
IT107 | nvarchar(50) | isbn
IT111 | nvarchar(50) | line item po number
CTP02 | nvarchar(50) | price qualifier
CTP03 | nvarchar(50) | retail price
CTP06 | nvarchar(50) | discount
CTP07 | nvarchar(50) | price multiplier
PID05 | nvarchar(80) | title
SAC02 | nvarchar(50) | type of charge
SAC05 | nvarchar(50) | charges
SAC15 | nvarchar(50) | contains further details for Brodart EDI Invoices that have a SAC02 code of ZZZZ. This allows for multiple ZZZZ charges to be listed on the Invoice.
IT117 | nvarchar(50) | Vendor Stock Number - 'Other Number' in the INLI


EDIInvoiceHeader

EDIInvoiceHeader Table

table that summarizes the invoice headers from the base edi tables. More information about the columns in these tables can be obtained from the edi invoice specification

Columns

Column name | Data type | Description
StructureID | int | foreign key column to edistructure that defines the edi document
ST01 | int | Transaction set number
ST02 | nvarchar(50) | transaction set number
ISA06 | nvarchar(50) | sender id
ISA08 | nvarchar(50) | receiver id
ISA09 | nvarchar(50) | date/time generated
ISA10 | nvarchar(50) | date/time generated
GS08 | nvarchar(50) | version number
N104 | nvarchar(50) | Account SAN ID code
BIG01 | nvarchar(50) | Invoice date
BIG02 | nvarchar(50) | Invoice number
BIG04 | nvarchar(50) | PO Number
CUR02 | nvarchar(50) | Currency code
DTM02 | nvarchar(50) | Date shipped
SAC02 | nvarchar(50) | type of charge
SAC05 | nvarchar(50) | charges
TDS01 | nvarchar(50) | invoice total
CTT01 | nvarchar(50) | number of line items
CTT02 | nvarchar(50) | hash total of units shipped

See Also

EDIInvoiceDetail, EDIInvoiceSAC,


EDIInvoiceSAC

EDIInvoiceSAC Table

Describes multiple SAC segments at the invoice level

Columns

Column name | Data type | Description
StructureID | int | foreign key column to edistructure that describes the edi document
ST01 | int | transaction set number
ST02 | nvarchar(50) | transaction set number
SAC02 | nvarchar(50) | type of charge
SAC05 | nvarchar(50) | charges
SAC15 | nvarchar(50) | contains further details for Brodart EDI Invoices that have a SAC02 code of ZZZZ. This allows for multiple ZZZZ charges to be listed on the Invoice.


EDIPODetail

EDIPODetail Table

Edi PO Detail tables holds the details for a PO summarized from the base tables. Please refer to the EDI PO Acknowledgement specification for more column info

Columns

Column name | Data type | Description
StructureID | int | structure id that holds the header and the detail PO Acknowledgement and is foreigned key to the edistructure table which describes the edi document
ST01 | int | transaction set number
ST02 | nvarchar(50) | transaction set number
PO101 | nvarchar(50) | Line item number
PO102 | nvarchar(50) | quantity
PO103 | nvarchar(50) | unit
PO104 | nvarchar(50) | price
PO107 | nvarchar(50) | isbn
PO109 | nvarchar(50) | Conatins Author data for the POA report when the PO108 data is 'B6'.
PO115 | nvarchar(50) | availability status codes
CTP07 | nvarchar(50) | discount
PID05 | nvarchar(80) | title
ACK01 | nvarchar(50) | line item status codes
ACK02 | nvarchar(50) | ship quantity
ACK29 | nvarchar(50) | acknowledgement codes
SCH11 | nvarchar(50) | acknowledgement codes
ACK11 | nvarchar(50) | If this field contains the data 'B6', use the data from ACK12 for the Author field in the POA report.
ACK12 | nvarchar(50) | This field conatins Author data for the POA report when the ACK11 column contains 'B6' as its data.
PO108 | nvarchar(50) | When this field contains the data 'B6' use the data in PO109 for Author in the POA Report.


EDIPOHeader

EDIPOHeader Table

purchase order table -- which summarizes the purchase order acknowledgement from the base tables. Please refer to the edi purchase order acknowledgement specification for more info

Columns

Column name | Data type | Description
StructureID | int | identity column that holds the PO Acknowledgement foreign keyed to edistructure
ST01 | int | transaction set number
ST02 | nvarchar(50) | transaction set number
ISA06 | nvarchar(50) | sender id
ISA08 | nvarchar(50) | receiver id
ISA09 | nvarchar(50) | Date produced
ISA10 | nvarchar(50) | time produced
GS08 | nvarchar(50) | version number
BAK02 | nvarchar(50) | acknowledgement codes
BAK03 | nvarchar(50) | PO Number
BAK04 | nvarchar(50) | PO Date
CUR02 | nvarchar(50) | currency
N104 | nvarchar(50) | Account SAN ID code
CTT01 | nvarchar(50) | Number od PO segments
CTT02 | nvarchar(50) | Total Units

See Also

EDIPODetail,


EDISegment

EDISegment Table

defines the segments for the edi structure

Columns

Column name | Data type | Description
EDISegmentNo | int | segmnet number -- identity column
StructureID | int | structure id for the segments
SegmentID | nvarchar(50) | type of the segment
SegmentSequence | int | position of the segment
LoopSegmentSequence | int | to group all the segments in a loop

See Also

EDIDataElement,


EDIStructure

EDIStructure Table

This defines the EDI transmission. Every edi file downnloaded will have a structure associated with it

Columns

Column name | Data type | Description
StructureID | int | unique key for the edi file
EDIFileName | nvarchar(256) | the file name of the edifile from the vendor
EDITypeCode | int | type of edi file -- 810, 855, 850
CreationDate | datetime | date when the file is loaded
Invoiced | bit | when = 1 the EDI Invoice associated with the structure ID has used to create a Polaris Invoice.

See Also

EDI_ASNHeader, EDIInvoiceHeader, EDIPOHeader, EDISegment,


EDIType

EDIType Table

Types of EDI files

Columns

Column name | Data type | Description
EDITypeCode | int | defines the edi types - 850, 855, 810
EDITypeDesc | nvarchar(100) | describes the type of edi transmission

See Also

EDIStructure,


EDI_ASNDetail

EDI_ASNDetail Table

Stored line item details for EDI ASN files

Columns

Column name | Data type | Description
DetailID | int | INT - Primary Key
HeaderID | int | INT - FK into the EDI_ASNHeader table
StructureID | int | INT - links to the EDI file in the EDIStructure table.
ST01 | int | INT - EDI Tansaction Type, in this case 856 for ASN
ST02 | nvarchar(50) | VARCHAR(50) - EDI file data that helps distinguish an ST01 transaction within an EDI file with multiple ASNs.
SN101 | nvarchar(50) | VARCHAR(50) - Database ID for linked POLI
SN102 | nvarchar(50) | VARCHAR(50) - Quantity claimed to be shipped by vendor
LIN03 | nvarchar(50) | VARCHAR(50) - ISBN/UPC for linked POLI
LIN09 | nvarchar(50) | VARCHAR(50) - PO Number for PO linked to this POLI
MAN02 | nvarchar(50) | VARCHAR(50) - MAN02 data (Tracking Barcode)from linked EDI file
SN102Modified | bit | BIT - when set indicates the SN102 data was manually updated during the ASN Receiving process.
MAN01 | varchar(2) | VARCHAR(50): code that identifies what the data in the MAN02 represents - vendor tracking data (GM)or shipper tracking data (SM)


EDI_ASNHeader

EDI_ASNHeader Table

Stored header details for EDI ASN files

Columns

Column name | Data type | Description
HeaderID | int | INT - Primary key
StructureID | int | INT - links to the EDI file in the EDIStructure table.
ST01 | int | INT - EDI Tansaction Type, in this case 856 for ASN
ST02 | nvarchar(50) | VARCHAR(50) - EDI file data that helps distinguish an ST01 transaction within an EDI file with multiple ASNs.
ISA06 | nvarchar(50) | VARCHAR(50) - Supplier SAN
ISA08 | nvarchar(50) | VARCHAR(50) - Library SAN
MAN02 | nvarchar(50) | VARCHAR(50) - SSCC Barcode (tracking barcode) for ASN container
DTM02 | nvarchar(50) | VARCHAR(50) - Shippment Date for ASN
TD502 | nvarchar(50) | VARCHAR(50) - Standard Carrier code for shipper.
TD503 | nvarchar(50) | VARCHAR(50) - Code for the company that handle the shipment
Processed | bit | BIT - when set, ASN data associated with this row has been successfully processed.
MAN01 | varchar(2) | VARCHAR(50): code that identifies what the data in the MAN02 represents - vendor tracking data (GM)or shipper tracking data (SM)

See Also

EDI_ASNDetail,


EDI_InvCreationMsgs

EDI_InvCreationMsgs Table

Stores message data during EDIAgent invoice processing. The contents of the table are written in EDI emails then purged from the table.

Columns

Column name | Data type | Description
MsgID | int | INT (NULL not allowed) Key used to group messages for a particular EDIAgent run.
InvNum | nvarchar(50) | VARCHAR(50) (allows NULL) The Invoice Number of the generated EDI Invoice.
Msg | nvarchar(-1) | VARCHAR(MAX) (allows NULL) Contains the message string written to the email


ElectronicCommunications

ElectronicCommunications Table

This table contains the electronic communications data associated with suppliers that the library deals with.

Columns

Column name | Data type | Description
ElecCommID | int | Polaris assigned unique id for each electronic communications data.
SupplierID | int | SupplierID that this data is linked to.
Address | nvarchar(50) | Electronic communications address for the supplier.
Notes | nvarchar(200) | Notes applying to the electronic communications for this supplier.
EnrichedEDI | bit | flag that tells the Polaris system if the linked supplier accepts and processes Enriched EDI 850 data.
DefaultPutDir | nvarchar(50) | varchar. contains the directory name on a vendor FTP sight where Polaris customers place EDI 850 (PO)documents.
DefaultGetDir | nvarchar(50) | varchar. contains the directory name on a vendor FTP sight where Polaris customers retrieve EDI 855 (POA) and 810 (INV) documents.
POFileExt | nvarchar(10) | varchar. vendor assigned file ext for EDI 850 (PO) documents.
FTPUserName | nvarchar(255) | varchar. contains the vendor assigned user name for a polaris customer's FTP log in for delivering EDI orders to the vendor's FTP site.
FTPPassword | nvarchar(255) | varchar. contains the vendor assigned password for a polaris customer's FTP log in for delivering EDI orders to the vendor's FTP site.
ProfileTypeID | int | flag to determine whether the vendor wants a customer SAN or Library Account number referenced in the EDI 850 (PO). segment N103.
InterchangeCtrlNumber | int | int. maintains the next interchange control number to be used when sending and EDI 850 (PO) to a vendor.
GroupCtrlNumber | int | int. maintains the next group control number to be used when sending and EDI 850 (PO) to a vendor.
TransactionSetCtrlNumber | int | int. maintains the next transaction set control number to be used when sending and EDI 850 (PO) to a vendor.
isbnflag | bit | when = 1, the linked supplier accepts 13 digit ISBN's/EAN's. Otherwise, the supplier expects 10 digit ISBN's in their EDI 850 (PO's).
ASNShipments | bit | BIT - when set indicates the linked supplier sends EDI ASN files.


ElectronicItemCheckInLog

ElectronicItemCheckInLog Table

This table is used to track electronic items that are checked in in Polaris PAC products

Columns

Column name | Data type | Description
ElectronicItemCheckInLogID | int | A unique identifier for the log entry
PatronID | int | The ID of the patron checking the item in
BibliographicRecordID | int | The Associated Bibliographic record ID of the item being checked in
ItemRecordID | int | The item record ID that is being checked in
VendorAccountID | int | The vendor account associated with the items resource entity
VendorObjectIdentifier | nvarchar(255) | The Unique ID of the title in the vendor’s repository
CheckInDate | datetime | The date and time that the item was checked in
CheckInLogDate | datetime | The date and time that the transaction was added to the log
CircTxnTypeID | int | The type of circulation transaction
TxnBranchID | int | The branch ID associated with the transaction
TxnUserID | int | The Polaris User ID associated with the transaction
TxnWorkstationID | int | The PAC workstation ID
PatronVendorContractID | nvarchar(255) | The vendor account associated with the patron
PatronBarcode | nvarchar(255) | The barcode of the patron checking the item in


ElectronicItemCheckOutLog

ElectronicItemCheckOutLog Table

This table is used to track electronic items that are checked out in Polaris PAC products

Columns

Column name | Data type | Description
ElectronicItemCheckOutLogID | int | A unique identifier for the log entry
PatronID | int | The ID of the patron checking the item out
BibliographicRecordID | int | The Associated Bibliographic record ID of the item being checked out
ItemRecordID | int | The item record ID that is being checked out
VendorAccountID | int | The vendor account associated with the items resource entity
VendorObjectIdentifier | nvarchar(255) | The Unique ID of the title in the vendor’s repository
CheckOutDate | datetime | The date and time that the item was checked out
CheckOutLogDate | datetime | The date and time that the transaction was added to the log
CircTxnTypeID | int | The type of circulation transaction
TxnBranchID | int | The branch ID associated with the transaction
TxnUserID | int | The Polaris User ID associated with the transaction
TxnWorkstationID | int | The PAC workstation ID
PatronVendorContractID | nvarchar(255) | The vendor account associated with the patron
PatronBarcode | nvarchar(255) | The barcode of the patron checking the item out


EmailFormat

EmailFormat Table

Table contains allowed format for email notificaiton

Columns

Column name | Data type | Description
EmailFormatID | int | Primary Key unique identifier.
EmailFormat | nvarchar(10) | The format

See Also

PatronRegistration, SDIHeader,


EnrichedDataSources

EnrichedDataSources Table

This table provides string selections for a PAC profile combo-box (Enrich Data: Source)

Columns

Column name | Data type | Description
DataSourceID | int | ID of the particular data source (used to identify the combo-box selection from SysAdmin)
Description | nvarchar(80) | String description of the data source, for display in the combo-box control in SysAdmin


EOTDueDateExclude

EOTDueDateExclude Table

Patron codes that are excluded from the end-of-term due date rules.

Columns

Column name | Data type | Description
DueDateID | int | Unique ID of the particular due date this exlusion belongs to. If it's NULL, this exclusion belongs to all due dates, defined for organization, indicated by OrganizationID field. Due date-specific exclusions and organization-wide exclusions can NOT be mixed together. That means all exclusions for a particular organization are either all date-specific or not date-specific. However, it's possible to have date-specific exclusions for one organization and organization-wide for another one.
OrganizationID | int | ID of organization this exclusion is defined for. This field is correct even if this is a date-specific exclusion.
PatronCodeID | int | Patron code that is excluded.


EOTDueDateSchedule

EOTDueDateSchedule Table

Scheduled end-of-term due dates

Columns

Column name | Data type | Description
DueDateID | int | Unique ID
OrganizationID | int | ID of organization this due date is defined for.
Recurring | bit | Indicator, that this date is recurring every year.
SpecificDate | bit | Indicator, that due date is defined by DueDate field. Otherwise it's defined by DueMinth, DueDay, and DueCount fields.
DueDate | datetime | Specific due date.
DueMonth | tinyint | Due date's month. 1 - January ... 12 - December
DueDay | tinyint | Kind of day. 1 - Monday ... 7 - Sunday 8 - weekday 9 - weekend day
DueCount | tinyint | Number of day, named by DueDay field: 1 - first 2 - second 3 - third 4 - fourth 5 - last Only first and last are possible for weekday and weekend day.
Terminate | bit | Indicates, that recurring of due date will be terminated some day.
TermType | bit | The meaning of TermYear field. 0 - it contains total number of occurences of due date before termination. 1 - it contains the last year when due date occure.
TermYear | int | See TermType description

See Also

EOTDueDateExclude,


EphemeralItemRecords

EphemeralItemRecords Table

This is the table that is used to store so called 'quick-circ' item records.

Columns

Column name | Data type | Description
EphemeralItemID | int | primary key
Barcode | nvarchar(20) | barcode of the quick-circ item
AssignedBranchID | int | Assigned branch of the quick-circ item
MaterialTypeID | int | material type of quick-circ item record
CreatorID | int | user who created quick-circ item
CreationDate | datetime | Creation date
ModifierID | int | polaris user who last modified item.
ModificationDate | datetime | date record was last modified
LastCircTransactionDate | datetime | last date item was circulated (check in/check out)
LastCircPolarisUserID | int | last polaris user who circulated item
LastCircWorkstationID | int | last workstation who circ'ed item
YTDCircCount | int | number of times per year item circulated
LifetimeCircCount | int | number of times item circulated
AssignedCollectionID | int | The assigned collection for the quick circ item

See Also

PrevYearEphemeralItemsCirc,


ESourceAccessLevel

ESourceAccessLevel Table

This static table holds the various access levels available for E-Source targets (Disabled, Login required, No login required)

Columns

Column name | Data type | Description
AccessLevelID | int | Unique identifier for an access level
Description | nvarchar(255) | The text string of the access level


ESourceTransferType

ESourceTransferType Table

Code table describing to type of html protocol to use when transferring to an ESource Target. Current values are POST and GET

Columns

Column name | Data type | Description
ESourceTransferTypeID | int | ID Column. Primary Key
Description | nvarchar(255) | Contains the transfer type description


EventRecordTypes

EventRecordTypes Table

A table used to associate event vendors with event import profiles. This table is maintained by Polaris.

Columns

Column name | Data type | Description
EventRecordTypeID | int | A unique identifier for the record
EventRecordTypeDescription | nvarchar(4000) | A description of the event vendor

See Also

CommunityEventImportXMLProfiles,


ExchangeRates

ExchangeRates Table

System or library defined currency exchange rate used for PO and Inv transactions. Exchange rates are linked to entries in the Currencies table.

Columns

Column name | Data type | Description
OrganizationID | int | Foreign key to the System/Library that defined the exchange rate.
CurrencyID | int | Foreign key linking an exchange rate to a currency.
Rate | numeric | Numeric(10,4). Contains the exchange rate value used when a PO is release or an Invoice is paid.
ModifiedDate | datetime | The date the exchange rate was last modififed.
ModifierID | int | Foerign Key to the PolarisUserID that last modified the entry.


ExpressCheckLibAssignedIBlocks

ExpressCheckLibAssignedIBlocks Table

This table records the organization-level library-assigned item blocks that exist for the Polaris ExpressCheck system. The presence of an Item Block / Organization row in this table indicates that the item block is in effect for that organization.

Columns

Column name | Data type | Description
OrganizationID | int | Organizations foreign key identifier: Specifies which organization that the item block is in effect for.
ItemBlockID | int | ItemBlockDescriptions foreign key identifier: Specifies the item block that is in effect for the organization.


ExpressCheckLibAssignedPBlocks

ExpressCheckLibAssignedPBlocks Table

This table records the organization-level library-assigned patron blocks that exist for the Polaris ExpressCheck system. The presence of a Patron Block / Organization row in this table indicates that the patron block is in effect for that organization.

Columns

Column name | Data type | Description
OrganizationID | int | Organizations foreign key identifier: Specifies which organization the patron block is in effect for.
PatronStopID | int | PatronStopDescriptionss foreign key identifier: Specifies the patron block that is in effect for the organization.


ExpressCheckPatCodePBlocks

ExpressCheckPatCodePBlocks Table

This table records the organization-level patron code patron blocks that exist for the Polaris ExpressCheck system. The presence of a Patron Code / Organization row in this table indicates that the patron block is in effect for that patron code for that organization.

Columns

Column name | Data type | Description
OrganizationID | int | Organizations foreign key identifier: Specifies the organization that the patron code block is in effect for.
PatronCodeID | int | PatronCodes foreign key identifier: Specifies the patron code block that is in effect for the organization.


EXP_CriteriaForAUTH

EXP_CriteriaForAUTH Table

Used by ExportExpress. The cirteria to use in retreving an authority record

Columns

Column name | Data type | Description
CriteriaProfileName | nvarchar(255) | The name of the criteria
CriteriaProfileDescription | nvarchar(500) | A description of the criteria
AuthSelectCritSQL | nvarchar(-1) | the SQL for the criteria


EXP_CriteriaForItems

EXP_CriteriaForItems Table

A table used by ExportExpress. The item level criteria used when exporting bibs with holdings.

Columns

Column name | Data type | Description
CriteriaProfileName | nvarchar(255) | The name of the criteria
CriteriaProfileDescription | nvarchar(500) | A description of the criteria
CriteriaSql | nvarchar(-1) | The SQL that comprises the criteria


EXP_CriteriaForMARC

EXP_CriteriaForMARC Table

A table used by ExportExpress. This table describes the criteria used by export express when exporting a MARC record.

Columns

Column name | Data type | Description
CriteriaProfileName | nvarchar(255) | The name of the criteria
CriteriaProfileDescription | nvarchar(500) | A description of the criteria
MarcSelectCritSQL | nvarchar(-1) | The SQL that comprises the criteria
nExcludeTag | nvarchar(-1) | The tags to exclude on export


EXP_CriteriaForPatrons

EXP_CriteriaForPatrons Table

A table used by ExportExpress. The patron level criteria used when exporting patrons.

Columns

Column name | Data type | Description
CriteriaProfileName | nvarchar(255) | The name of the criteria
CriteriaProfileDescription | nvarchar(500) | A description of the criteria
PatronSelectCritSQL | nvarchar(-1) | The SQL that comprises the criteria


EXP_HoldingsProfile

EXP_HoldingsProfile Table

Holdings profile table. Used by ExportExpress/SimplyReports to hold user defined holdings profile information

Columns

Column name | Data type | Description
ProfileID | int | The Unique ID of the profile
IncludeHoldingsInfo | bit | A flag indicating if the profile includes holdings information
ProfileExportName | nvarchar(80) | The name of export profile
HoldingsSQL | nvarchar(-1) | Stored Proc Elements (Internal Use)
EXP_Var_MAP_Item | nvarchar(255) | Stored Proc Elements (Internal Use)
EXP_Var_MAP_ItemEnd | nvarchar(100) | Stored Proc Elements (Internal Use)
EXP_Var_MAP_Bib | nvarchar(255) | Stored Proc Elements (Internal Use)
EXP_Var_MAP_BibEnd | nvarchar(100) | Stored Proc Elements (Internal Use)
EXP_MARC21_MARCDATASP | nvarchar(4000) | Stored Proc Elements (Internal Use)
ExcludeTags | nvarchar(-1) | A comma delimited list of tags to exclude from the export
EXP_MARC21_MARCDATASPEnd | nvarchar(100) | Stored Proc Elements (Internal Use)
ItemTag | nvarchar(80) | The MARC tag to export holdings to
AssignedBranchIDFlag | bit | A flag indicating if this data element is exported
AssignedCollectionIDFlag | bit | A flag indicating if this data element is exported
ShelfLocationIDFlag | bit | A flag indicating if this data element is exported
StatisticalCodeIDFlag | bit | A flag indicating if this data element is exported
ItemRecordIDFlag | bit | A flag indicating if this data element is exported
ItemStatusIDFlag | bit | A flag indicating if this data element is exported
ClassificationNumberFlag | bit | A flag indicating if this data element is exported
CutterNumberFlag | bit | A flag indicating if this data element is exported
CallNumberPrefixFlag | bit | A flag indicating if this data element is exported
CallNumberSuffixFlag | bit | A flag indicating if this data element is exported
OwningBranchIDFlag | bit | A flag indicating if this data element is exported
BarcodeFlag | bit | A flag indicating if this data element is exported
PhysicalConditionFlag | bit | A flag indicating if this data element is exported
FineCodeIDFlag | bit | A flag indicating if this data element is exported
CopyNumberFlag | bit | A flag indicating if this data element is exported
PublicNoteFlag | bit | A flag indicating if this data element is exported
RenewalLimitFlag | bit | A flag indicating if this data element is exported
NonPublicNoteFlag | bit | A flag indicating if this data element is exported
LoanPeriodCodeIDFlag | bit | A flag indicating if this data element is exported
MaterialTypeIDFlag | bit | A flag indicating if this data element is exported
VolumeNumberFlag | bit | A flag indicating if this data element is exported
PriceFlag | bit | A flag indicating if this data element is exported
ShelvingSchemeIDFlag | bit | A flag indicating if this data element is exported
FundingSourceFlag | bit | A flag indicating if this data element is exported
DisplayInPACFlag | bit | A flag indicating if this data element is exported
TemporaryShelfLocationFlag | bit | A flag indicating if this data element is exported
NonCirculatingFlag | bit | A flag indicating if this data element is exported
LoanableOutsideSystemFlag | bit | A flag indicating if this data element is exported
HoldableFlag | bit | A flag indicating if this data element is exported
ManualBlockIDFlag | bit | A flag indicating if this data element is exported
FreeTextBlockFlag | bit | A flag indicating if this data element is exported
NameOfPieceFlag | bit | A flag indicating if this data element is exported
AssignedBranchIDSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
AssignedBranchIDForm | nvarchar(30) | Indicates which form of this element is extracted: C = Code, A = Abbreviation, D = Description, N = Name
AssignedCollectionIDSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
AssignedCollectionIDForm | nvarchar(30) | Indicates which form of this element is extracted: C = Code, A = Abbreviation, D = Description, N = Name
ShelfLocationIDSubField | nvarchar(30) | Indicates Subfield this element is extracted to
ShelfLocationIDForm | nvarchar(30) | Indicates which form of this element is extracted: C = Code, A = Abbreviation, D = Description
StatisticalCodeIDSubField | nvarchar(30) | Indicates Subfield this element is extracted to
StatisticalCodeIDForm | nvarchar(30) | Indicates which form of this element is extracted: C = Code, A = Abbreviation, D = Description
ItemRecordIDSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
ItemStatusIDSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
ItemStatusIDForm | nvarchar(30) | Indicates which form of this element is extracted: C = Code, A = Abbreviation, D = Description, N = Name
ClassificationNumberSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
CutterNumberSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
CallNumberPrefixSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
CallNumberSuffixSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
OwningBranchIDSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
OwningBranchIDForm | nvarchar(30) | Indicates which form of this element is extracted: C = Code, A = Abbreviation, D = Description, N = Name
BarcodeSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
PhysicalConditionSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
FineCodeIDSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
FineCodeIDForm | nvarchar(30) | Indicates which form of this element is extracted: C = Code, A = Abbreviation, D = Description, N = Name
CopyNumberSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
LoanPeriodCodeIDSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
LoanPeriodCodeIDForm | nvarchar(30) | Indicates which form of this element is extracted: C = Code, A = Abbreviation, D = Description, N = Name
VolumeNumberSubField | nvarchar(30) | Indicates Subfield this element is extracted to
MaterialTypeIDSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
MaterialTypeIDForm | nvarchar(30) | Indicates which form of this element is extracted: C = Code, A = Abbreviation, D = Description, N = Name
NonPublicNoteSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
RenewalLimitSubField | nvarchar(30) | Indicates Subfield this element is extracted to
PublicNoteSubField | nvarchar(30) | Indicates Subfield this element is extracted to
PriceSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
FundingSourceSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
ShelvingSchemeIDSubField | nvarchar(30) | Indicates Subfield this element is extracted to
ShelvingSchemeIDForm | nvarchar(30) | Indicates which form of this element is extracted: C = Code, A = Abbreviation, D = Description
DisplayInPACSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
HoldableSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
LoanableOutsideSystemSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
NonCirculatingSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
TemporaryShelfLocationSubField | nvarchar(30) | Indicates Subfield this element is extracted to
FreeTextBlockSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
ManualBlockIDSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
ManualBlockIDForm | nvarchar(30) | Indicates which form of this element is extracted: C = Code, A = Abbreviation, D = Description, N = Name
NameOfPieceSubField | nvarchar(30) | Indicates which subfield this data element is extracted to
CharacterEncoding | tinyint | Identifies the character encoding used in the record. 0 - Use LDR/09 value, 1 - MARC-8, 2 - UTF-8.

See Also

RWRITERSavedReports,


EXP_ItemMapExport

EXP_ItemMapExport Table

A table used by ExportExpress. This table contains the user defined holdings maps.

Columns

Column name | Data type | Description
ExportMapName | nvarchar(255) | The name of the MAP
ExportMapDescription | nvarchar(500) | A desciption of the map
SqlSelect | nvarchar(-1) | The SQL that comprises the map


EXP_Tag_Display

EXP_Tag_Display Table

A table used by ExportExpress. This table is used in displaying tags for exclusion.

Columns

Column name | Data type | Description
TagNumber | int | The tagnumber
DisplayTag | nvarchar(3) | The three digit TagNumber
Description | nvarchar(70) | A verbose description of the tag


ExternalAcctSystemExchangeDispositionValues

ExternalAcctSystemExchangeDispositionValues Table

A table that enumerates the disposition vales for the PO exchange tables

Columns

Column name | Data type | Description
DispositionID | int | A unique ID for the diposition
Description | nvarchar(255) | A description of the value

See Also

ACQExchangeFileInformation, ACQExchangeOutgoingDataLog, ExternalAcctSystemExchangeInvoices, ExternalAcctSystemExchangePurchaseOrders,


ExternalAcctSystemExchangeInvoices

ExternalAcctSystemExchangeInvoices Table

A table to track exchange invoices.

Columns

Column name | Data type | Description
ExchangeInvoiceIdentityID | int | An Identity column
InvoiceID | int | The Polaris Invoice ID
CreationDate | datetime | Date the entry was added
ProcessDate | datetime | The date on which the invoice went through the exchange process.
DispositionID | int | The disposition
Processed | bit | A flag that indicates if the invoices was processed.


ExternalAcctSystemExchangePurchaseOrders

ExternalAcctSystemExchangePurchaseOrders Table

A table which tracks PO's duting the exchange process.

Columns

Column name | Data type | Description
ExchangePOIdentityID | int | An Identity column.
PurchaseOrderID | int | The Polaris PO ID
CreationDate | datetime | The creation date of the entry.
ProcessDate | datetime | The date on which the PO was processed.
DispositionID | int | The disposition
Processed | bit | The outcome of processing.


FacetKinds

FacetKinds Table

Contains one row for each facet kind.

Columns

Column name | Data type | Description
FacetKindID | tinyint | Facet kind identification number.
Name | sysname | Facet kind name.


FeeReasonCodes

FeeReasonCodes Table

This table stores the reasons defined by a library for fee charge.

Columns

Column name | Data type | Description
FeeReasonCodeID | int | Primary key
FeeDescription | nvarchar(255) | The text description of the reason

See Also

FeeReasonCodesByBranch, PatronAccount,


FeeReasonCodesByBranch

FeeReasonCodesByBranch Table

This table defines the sequence and the enabled status for those fees defined in the FeeReasonCodes table specific to each branch.

Columns

Column name | Data type | Description
OrganizationID | int | Reference to the branch organization in context (Foreign key reference to Organizations table)
FeeReasonCodeID | int | Reference to a particular fee (foreign key reference to the FeeReasonCodes table)
SequenceID | int | Numeric sequence to indicate the relative order fee reasons will appear.
Selected | bit | Bit flag to indicate whether the fee reason in question is enabled for the given branch.


FindToolColumnSettings

FindToolColumnSettings Table

Contains one row for each column in the scope of a database and user/activity context.

Columns

Column name | Data type | Description
FindToolSearchSettingsID | int | Identities the parent database and user/activity context.
OrdinalPosition | smallint | The 1-based ordinal position among the set of columns.
DisplayPosition | smallint | The 1-based display position among the set of columns.
Width | decimal | The width of the column in characters (measured in ems).
Visible | bit | Indicates whether the column is visible.
Pinned | bit | Indicates whether a column will move when a user scrolls the result list horizontally.
Folded | bit | Indicates whether a column will be folded into a secondary text line and displayed under each row's (standard) tabular data.


FindToolContexts

FindToolContexts Table

This table defines every possible way that a Find Tool can be created from the Tech Client user interface.

Columns

Column name | Data type | Description
ContextID | int | This column is a unique identifier for this Find Tool context.
Description | nvarchar(80) | This column contains a verbal description of this Find Tool Context.

See Also

FindTool_SaveDefaultSearchDatabases, FindToolSearchFors, FindToolSortBys, PersonalSearchSettings,


FindToolDataTypes

FindToolDataTypes Table

Contains one row for each find tool data type.

Columns

Column name | Data type | Description
DataTypeID | int | Identifies the data type.
DataTypeName | sysname | Name of the data type.

See Also

FindToolProfileColumns,


FindToolDefaultSearchDatabases

FindToolDefaultSearchDatabases Table

Contains one row for each user-specific default search database.

Columns

Column name | Data type | Description
UserID | int | Unique identifier of the user.
SearchActivityCode | smallint | Unique identifier for the search activity code.
SearchDatabaseID | int | Identifies a unique search database/activity pair.


FindToolImageMappings

FindToolImageMappings Table

Contains one row for each unique profile/column-ordinal pair that should be mapped to an image.

Columns

Column name | Data type | Description
ProfileID | int | Specifies the find tool profile.
OrdinalPosition | int | Specifies the ordinal position of the field.
Key | nvarchar(255) | Specifies the raw value of the field to be mapped.
ImageIndex | int | Specifies the image to be displayed in the row/cell.
TooltipText | sysname | Specifies the tooltip text associated with the image.
IsDefault | bit | Specifies whether this is the default image mapping.


FindToolImages

FindToolImages Table

Contains one row for each image to be displayed within the find tool.

Columns

Column name | Data type | Description
ImageIndex | int | Identifies an image.
Description | sysname | Describes the image.

See Also

FindToolImageMappings, FindToolProfileColumns,


FindToolProfileColumns

FindToolProfileColumns Table

Contains one row for each column associated with a find tool profile.

Columns

Column name | Data type | Description
ProfileID | int | Identifies the find tool profile.
OrdinalPosition | int | Identifies the ordinal position of the column.
EntityID | int | Identifies the (NSM) entity identifier associated with the underlying column value.
Name | nvarchar(255) | Friendly name of the column.
IdealWidth | int | Ideal width of column measured in characters.
DataTypeID | int | Identifies the data type of the column.
ImageIndex | int | Identifies an image to be displayed in the column header.
CrossReferenceProfileID | int | Identifies a find tool profile associated with a control-number based field different from the profile associated with the current row.
Mnemonic | nvarchar(128) | Identifies the search mnemonic associated with the profile column.


FindToolProfileQualifiers

FindToolProfileQualifiers Table

Contains one row for each qualifier associated with a find tool profile.

Columns

Column name | Data type | Description
ProfileID | int | Identifies the find tool profile.
Mnemonic | sysname | Identifies the search mnemonic associated with the qualifier.
Description | nvarchar(255) | Friendly description of qualifier.
Flags | int | Bitwise OR of zero or more find tool qualifier flags.
DataTypeID | int | Identifies the data type of the qualifier.
EnumeratedTypeName | nvarchar(255) | Identifies the enumerated type associated with the qualifier. If the qualifier is not based on an enumerated type, then this column is set to NULL.
Submnemonic | sysname | Identifies the secondary mnemonic associated with qualifier based on a hierarchical enumerated type. If the qualifier is not based on a hierarchical enumerated type, then this column is set to NULL.


FindToolProfiles

FindToolProfiles Table

Contains one row for each column associated with a find tool profile.

Columns

Column name | Data type | Description
ProfileID | int | Identifies a find tool profile.
Name | sysname | Identifies the name of the find tool profile. This name corresponds to the abstract (search) database name.
Description | nvarchar(255) | Friendly description of the database.
SingularName | nvarchar(255) | Singular (as opposed to plural) name of the find tool profile.

See Also

FindToolImageMappings, FindToolProfileColumns, FindToolProfileQualifiers,


FindToolQualifierFlags

FindToolQualifierFlags Table

Contains one row for each find tool qualifier flag.

Columns

Column name | Data type | Description
QualifierFlag | int | Identifies the qualifier flag (always a power of 2).
QualifierFlagName | sysname | Name of the qualifier flag.


FindToolSavedSearches

FindToolSavedSearches Table

Contains one row for each saved search with the scope of an object.

Columns

Column name | Data type | Description
SavedSearchID | int | Unique identifier of the saved search.
UserID | int | Unique identifier of a Polaris user. This column is required when the search mode is Power Search (2), and NULL otherwise.
ObjectTypeID | int | Unique identifier of the object type.
SearchMode | tinyint | Unique identifier of the search mode. This field can be one of the following: Power (2) or SQL (3).
DisplayName | nvarchar(80) | The display name of the saved search.
QueryText | nvarchar(3900) | Text of the saved query.


FindToolSearchActivityCodes

FindToolSearchActivityCodes Table

Contains one row for each search activity within the LEAP web application.

Columns

Column name | Data type | Description
SearchActivityCode | smallint | Unique identifier of the search activity.
Name | sysname | Descriptive name of the search activity.
CanChangeDefaultDatabase | bit | Specifies whether a user can specify a default database for the search activity.

See Also

FindToolDefaultSearchDatabases, FindToolSearchDatabases, FindToolSearchSettings,


FindToolSearchBys

FindToolSearchBys Table

This table describes all the access points that can be searched by on the Find Tool for a given "Search For". (See FindToolSearchFors table)

Columns

Column name | Data type | Description
FindToolSearchForID | int | This column is a link to the particular context/object row in the FindToolSearchFors table.
Z3950AttributeValueID | int | This column is a link to the Z3950 database (Attribute value info) and defines the Z3950 attribute values for this access point.
SearchFlags | int | This column is a bit mask that describes the types of searches (eg. keyword, exact match, ..., etc.) allowed as well as its visibility on the General & Scoping tabs of the Find Tool for this particular access point in this particular "SearchFor" context.


FindToolSearchDatabases

FindToolSearchDatabases Table

Contains one row for each search database associated with a search activity.

Columns

Column name | Data type | Description
SearchDatabaseID | int | Identifies a unique search database/activity pair.
SearchActivityCode | smallint | Unique identifier for the search activity code.
DatabaseName | nvarchar(50) | Abstract search database name.
IsDefault | bit | Flag indicating whether the search database is the default for the search activity/user pair.

See Also

FindToolDefaultSearchDatabases,


FindToolSearchFors

FindToolSearchFors Table

This table describes all the objects that can be searched for on a Find Tool within a certain context.

Columns

Column name | Data type | Description
SearchForID | int | This column uniquely identifies this row of context/object information.
FindToolContextID | int | This column links to the FindToolContexts table and describes the Find Tool context from which a particular object can be searched for.
FindToolSearchObjectID | int | This column is a linke to the FindToolSearchObjects table and specifies the object that can be searched for.
SearchByAttributeValueID | int | This column is a link to the Z3950 database (AttributeValueInfo table) and describes the default access point ("Search By") value that will display when this particular object is selected as the search object on the Find Tool UI for the particular context.

See Also

FindToolSearchBys,


FindToolSearchModes

FindToolSearchModes Table

Contains one row for each find tool search mode.

Columns

Column name | Data type | Description
SearchMode | tinyint | Unique identifier of the search mode.
Name | sysname | Descriptive name of the search mode.

See Also

FindToolSavedSearches, FindToolSearchSettings,


FindToolSearchObjects

FindToolSearchObjects Table

This table defines every object that can be searched for from the Tech Client Find Tool.

Columns

Column name | Data type | Description
SearchObjectID | int | Unique row identifier
ObjectTypeID | int | This column identifies the Polaris object type and is a link to the ObjectTypes table
Z3950DatabaseID | int | Link to the Z3950 database (DatabaseInfo table) that defines the Z3950 object type.
PermissionID | int | Link to the new PermissionDefs table. This value is used to determine Access permission to the object being searched from the Find Tool. Replaces the old PPPP Mnemonic and Category style.

See Also

FindToolSearchFors,


FindToolSearchSettings

FindToolSearchSettings Table

Contains one row for each search setting in the scope of a database and user/activity pair.

Columns

Column name | Data type | Description
FindToolSearchSettingsID | int | Unique identifier of the search settings.
UserID | int | Unique identifier of the user.
SearchActivityCode | smallint | Unique identifier for the search activity code.
DatabaseName | nvarchar(50) | Abstract search database name.
SearchMode | tinyint | Unique identifier of the search mode.
QualifierName | sysname | The default qualifier name.
RelationalOperator | sysname | The default relational operator.
Modifiers | sysname | Specifies optional search modifiers. Currently, the only supported modifier is "R" for right truncation.

See Also

FindToolTargetSettings,


FindToolSortBys

FindToolSortBys Table

Contains one row for each sort-by option exposed in the find tool per object type and find tool context.

Columns

Column name | Data type | Description
ObjectTypeID | int | Identifies the object type.
ContextID | int | Identifies the find tool context.
SortCookie | bigint | An 8-byte integer broken up into (4) 2-byte sort crumbs (a.k.a. sort keys). Each sort crumb contains a Bib-1 use-attribute in the lower 15 bits and the sort relation in the high bit. If the high bit (i.e. sort relation) is set to 0 then the sort key will be in ascending order, otherwise the sort key will be in descending order. The first sort crumb is stored in the lower 2 bytes of the sort cookie and the last sort crumb is stored in the upper 2 bytes of the sort cookie. If a sort crumb equals zero or an invalid Bib-1 use-attribute then the sort key will be ignored. For example, a sort cookie equal to 0x000000000000000C is equivalent to "SORT [12] ASC" and a sort key equal to 0x000000001468801F is equivalent to "SORT [31] DESC, [5224] ASC".
Description | nvarchar(128) | A brief description of the sort key(s) associated with the SortCookie (e.g. "Title, then Author").


FindToolTargetSettings

FindToolTargetSettings Table

Contains one row for each due date modification reason

Columns

Column name | Data type | Description
FindToolTargetSettingsID | int | Unique identifier
FindToolSearchSettingsID | int | Reference to FindToolSearchSettings.FindToolSearchSettingsID
DBID | int | Reference to Databases.DBID


FindTool_SaveDefaultSearchDatabases

FindTool_SaveDefaultSearchDatabases Table

Contains one row for each saved default search database for a user

Columns

Column name | Data type | Description
UserID | int | User ID from PolarisUsers table
FTContextID | int | Find Tool Context Identifier from FindToolContexts table
ObjectTypeID | int | Object Type Identifier from ObjectTypes table
DBID | int | Database Identifier from Databases table


FineCodes

FineCodes Table

This table stores fine codes and descriptions for each organization.

Columns

Column name | Data type | Description
FineCodeID | int | ID of fine code, combined primary key.
Description | nvarchar(80) | is the description of each fine code.

See Also

CircItemRecords, Fines, ItemTemplates, ReserveItemRecords,


Fines

Fines Table

This table stores the matrix of fine rates for each organization based on different patron codes and fine codes, for calculating overdue fines.

Columns

Column name | Data type | Description
FinesID | int | The sole purpose of this ID is to hold a unique identifier (Primary Key) for each entry in the table. This will be an IDENTITY property in the Replication Publishing Database.
OrganizationID | int | ID of the organization that defines its fine rates, references Polaris.FineCodes (OrganizationID) and Polaris.Organizations (OrganizationID).
PatronCodeID | int | ID of patron code, references Polaris.PatronCodes (PatronCodeID).
FineCodeID | int | ID of fine code, references Polaris.FineCodes (FineCodeID).
Amount | money | is the basic rate of overdue fine.
MaximumFine | money | is the maximum amount of overdue fine. It will replace an overdue fine that is greater than it.
GraceUnits | int | defines a period that there is no overdue fine if item returns within.


FinishedPatronAccount

FinishedPatronAccount Table

This table is a copy of the patron account table, used to store information which is removed from the primary 'PatronAccount' table when the job to delete finished patron transactions is run.

Columns

Column name | Data type | Description
TxnID | int | primary key
PatronID | int | Patron who is associated with transaction
TxnCodeID | int | type of transaction
FeeReasonCodeID | int | Fee reason ID
TxnAmount | money | monetary value associated with transaction
OutstandingAmount | money | monetary value for unpaid value (if applicable).
ItemRecordID | int | associated item record ID with transaction
TxnDate | datetime | date of transaction
PaymentMethodID | int | method of payment
OrganizationID | int | Organization writing the transaction
WorkstationID | int | workstation who made the transaction
CreatorID | int | Creator
CheckoutDate | datetime | Date item was checked out
DueDate | datetime | Item due date
FreeTextNote | nvarchar(255) | free text note
InsertionDate | datetime | date transaction inserted
ILSStoreTransactionID | int | Links to ILSStoreTransactions table. ID of associated credit card transaction. Null if credit card was not used to pay for the fine/fee.
LoaningOrgID | int | Organization ID of item's lending branch. This is usually valid for overdue item related charges.


FinishedPatronAccountAssoc

FinishedPatronAccountAssoc Table

This table is a copy of the patron account assoc table, used to store information which is removed from the primary 'PatronAccountAssoc' table when the job to delete finished patron transactions is run.

Columns

Column name | Data type | Description
MainTxnID | int | main transaction ID
AssocTxnID | int | associated transaction
InsertionDate | datetime | date transaction was entered into table


FiscalYears

FiscalYears Table

This table stores data for fiscal year periods. A fiscal year contains links to all funds associated with a specific period of time used to purchase items for a library/branch.

Columns

Column name | Data type | Description
FiscalYearID | int | System generated Primary Key for the Fiscal Year Record.
FiscalYearStatusID | int | Status ID of the fiscal year record's status. Must exist in FiscalYearStatus taable.
CreationDate | datetime | System generated date/time that the record was created.
CreatorID | int | PolarisUserID of the person that created the record.
FYStartDate | datetime | Date that current Fiscal Year began.
FYEndDate | datetime | Date that current Fiscal Year ends.
ModificationDate | datetime | System generated date/time at which the record was last modified.
OrganizationID | int | Polaris Organization ID of the library that 'owns' the current fiscal year record.
ModifierID | int | PolarisUserID of the person that last modified the record.
Name | nvarchar(50) | Usert assigned 'name' of the fiscal year record.
Notes | nvarchar(200) | Free text field for users to enter notes pertaining to the current fuscal year record.
StatusDate | datetime | Date at which the record obtained it's current status.

See Also

Funds, FundTransactionHistories, InvLineItemSegmentAmts,


FiscalYearStatus

FiscalYearStatus Table

This table contains the list of predefined statuses for fiscal year records.

Columns

Column name | Data type | Description
FiscalYearStatusID | int | Primary key: Integer value for corresponding text data.
Status | nvarchar(21) | text data of actual fiscal year status. Its : pre-defined options values: open, encumbrances closed, expenditures closed, all activity closed.

See Also

FiscalYears,


FundCategories

FundCategories Table

categories used to define a donor fund. there are 3 system defined categories, but users can add new ones/ remove unsed ones via system admin.

Columns

Column name | Data type | Description
CategoryID | int | integer key for each category.
Category | nvarchar(50) | text feild stating what the category is.

See Also

Funds,


FundEncExpOptions

FundEncExpOptions Table

This is a secondary table used by theFund record.Encumbrance/Expenditure options are used to inform Polaris when in the ordering process that funds should be encumbered and expended.

Columns

Column name | Data type | Description
FundEncExpOptionID | int | Integer value used to link a Fund record with an Encumbrance/Expenditure option. Must be unique to this table.
FundEncExpOption | nvarchar(50) | Options are: Encumber when PO was released, do not emcumber, encumber now, expend when PO was released, expend when PO was closed, expend when PO item was received, expend when invoice was closed, expend now.

See Also

Funds,


Funds

Funds Table

A FUND is linked to a FISCAL YEAR for the purposes of organizing libray Funds. Each FUND can have many CHILD (SUB) FUNDS. Each fund amy also be the CHILD fund to a SINGLE PARENT fund.

Columns

Column name | Data type | Description
FiscalYearID | int | Primary key of linked fiscal year.
FundID | int | System generated ID for the fund record. The FundID and FiscalYearID comprise the complex primary key for the record.
FundEncExpOptionID | int | Link to the FundEncExpOptions table. This setting determines what encumbrance/expenditure options are allowed for a particular fund.
FundStatusID | int | Id of the current fund status value as defined in the FundStatus table.
AlternativeName | nvarchar(50) | Fund alternmative name assigned by the owning library.
AmtExpYTD | money | Amount Expended Year-to-date for the particular fund record.
BegAllocation | money | Allocated Funds at time of creation
CarryOverAlloc | money | Carry over Allocation is the amount that was added to the Fund as a result of 'End of Fiscal Year Processing'. In other words - the amount left over in a Fund at the end of a Fiscal Year that was transferred to this Fund.
CreationDate | datetime | Date/Time that the fund record was originally created.
CreatorID | int | PolarisUserID of the person that created the record.
DepFundsUsed | money | In reference to 'Deposit Accounts', maintains the amount that has been used for the particular deposit account.
EncLimFreeBal | bit | A setting that tells the system to produce a visible and audible warning when the user attempts to encumber funds and the AMOUNT ENCUMBERED is greater than the current FREE BALANCE.
EncLimPercentAlloc | int | Encumberance limit as a percentage of total allocated for this fund
EncLimPerItem | money | The maximum amount that can be encumbered for a single line item for a particular fund.
EncLimPerOrder | money | The maximum amount that can be encumbered for a single order for a particular fund.
EncLimTotCurrEnc | money | Total currently encumbered for this fund can not exceed this amount.
ExpLimFreeBal | bit | A setting that tells the system to produce a visible and audible warning when the user attempts to expend funds and the AMOUNT to be EXPENDED will exceed the current FREE BALANCE.
ExpLimPerItem | money | Maximum amount allowed for a single line to expend in a particular fund.
ExpLimPerOrder | money | Maximum expenditure allowed for a single order/invoice for a particular fund.
ExpLimTotExp | money | A setting that tells the system to produce a visible and audible warning when the user attempts to expend funds and the AMOUNT to be EXPENDED will exceed a user defined maximum amount that can be expended for the particular fund.
ExtName | nvarchar(50) | User provided External Fund name. Can be NULL.
FreeBal | money | Free Balance Amount in a REGULAR fund.
FreeDepBal | money | Amount left in a deposit account that is available to the library for acquiring new items.
FundingSource | nvarchar(50) | User entered source for the "money" allocated to the fund.
IsParent | bit | Bit value 0=non parent fund / 1= parent fund. This setting tells the system the this fund record is the parent fund for other funds in the system. This record's FundID will appear in the ParentFundID column of the child/sub fund(s).
ModificationDate | datetime | System generated date/time at which the record was last modified.
OrganizationID | int | Polaris Organization ID of the library that 'owns' the fund record.
ManDecrAmt | money | Amount by which a fund was decreased during a manual fund adjusment.
ManIncrAmt | money | Amount by which a Fund was increased during a manual fund adjustment.
ModifierID | int | PolarisUserID of the person that last modified the record.
Name | nvarchar(50) | User entered name for the fund record.
OverExpAllow | money | Bit value. 0 means expenditure limit cannot be exceeded, 1 means that it is possible to exceed the limit if the user has sufficient privilege.
ParentFundFiscalYearID | int | The fiscal year id of the parent fund for this record if one exists. must be the same as the fiscal year id for this record.
ParentFundID | int | The id of the parent fund for this record if one exists.
PerExpYTD | int | Percent of Fund that has been Expended year-to-date. (no longer used - replaced by PercentExpYTD)
StatusDate | datetime | System assigned date/time at which the record obtained it's current statsu value.
TotAlloc | money | Total amount currently allocated for the particular fund record.
TotAmtDep | money | Deposit Account : tracks the cumulative total of all deposits made to the account during the current fiscal year.
TotCurrEnc | money | Total amount of Fund that is currently encumbered.
TotExp | money | Total amount currently expended for a particular fund record.
TransfersAllowed | bit | Indicates whether money can be transferred into or out of a fund.
PercentExpYTD | numeric | Percent of total allocated for a particular fund that has been expended year-to-date.
DonorID | int | link to donors table, for donation funds.
CategoryID | int | link to Fund catagories table
TypeID | int | link to fundtypes table.
Note | nvarchar(255) | free text note field for users to enter a note pertaining to the specific fund.
Display | bit | data type = BIT. This flag tells the system whether to display the fund in the drop lists within Acquisitions.

See Also

Funds, FundTransactionHistories, InvLineItemSegmentAmts, InvoiceAmts, POAmounts, POLineItemSegmentAmts, SA_SL_BranchFundFilter_FundSettings, SelListLineSegments, Subscriptions,


FundStatus

FundStatus Table

This is a secondary table used by the Fund record. Fund statuses are used to inform users of Polaris the current status of a fund record.

Columns

Column name | Data type | Description
FundStatusID | int | Integer value used to link a Fund Status with a Fund. Must be unique to this table.
Status | nvarchar(21) | The status of a particular fund. its pre-defined values are: open, encumbrances closed, expenditures closed, closed (permanently closed, usually at end of FY)

See Also

Funds,


FundTransactionHistories

FundTransactionHistories Table

This record keeps track of transaction that occurr with regards to the specific fund with which it is associated.

Columns

Column name | Data type | Description
FundTransactionHistID | int | System generated ID for the individual table entry. not really used for anything of value at this point.
FiscalYearID | int | primary key of the fiscal year that 'owns' the fund for which the entry belongs.
FundID | int | ID number of fund record for which a particular entry belongs.
FundTransactionTypeID | int | ID number that identified the type of trnasaciton that took place. The definations of the transaction types are found in the FundTransactionTypes table.
ExchangeRate | numeric | The exchange rate that was used to convert a particular price from one currency to another.
ForeignCurrencyID | int | Currently unused data element.
FundTransAmt | money | Currency amount of the particular transaction.
FundTransDateTime | datetime | system generated date/time of the particular transaction.
FundTransNote | nvarchar(200) | User entred note pertaining to the particular transaction.
FundTransSource | nvarchar(100) | User entered Source from which the funds in the transaction came.
OrdInvLINumber | nvarchar(11) | PO or Invoice line number that generated the transaction. Can be null.
OrdInvNumber | nvarchar(30) | PO or Invoice number that generated the transaction. can be null.
OrdInvNumberSuf | nvarchar(8) | Suffix portion of the PO or Invoice number that generated the transaction. can be null.
UserID | int | PolarisUserID of the person that generated the specific transaction.


FundTransactionTypes

FundTransactionTypes Table

Polaris defined list of fund transaction types.

Columns

Column name | Data type | Description
FundTransactionTypeID | int | Interger value used to link a transaction type to a particular transaction.
FundTransType | nvarchar(45) | Text entry of corresponding transaction type ID. Such as: beginning allocation, carryover allocation, reduction in allocation, supplementary allocation.

See Also

FundTransactionHistories,


FundTypes

FundTypes Table

list the types of funds allowed in Polaris. (as of release 3.0 they are regular, donation, deposit account)

Columns

Column name | Data type | Description
TypeID | int | integer key for each fund type
Type | nvarchar(50) | text stating the fund type

See Also

Funds,


Genders

Genders Table

Contains one row for each gender

Columns

Column name | Data type | Description
GenderID | int | Unique identifier
Description | nvarchar(255) | Text description of the gender

See Also

GendersByOrg, PatronRegistration,


GendersByOrg

GendersByOrg Table

Contains one row for each gender and organization pair

Columns

Column name | Data type | Description
OrganizationID | int | Unique identifier from the Organizations table
GenderID | int | Unique identifier from the Genders table
Display | bit | Bit indicating if the row is visible
DisplayOrder | int | Display sequence


GroupOrganizations

GroupOrganizations Table

Organizations that belong to the Group.

Columns

Column name | Data type | Description
GroupID | int | ID of the Group.
OrganizationID | int | ID of Organization.


Groups

Groups Table

Security Groups

Columns

Column name | Data type | Description
GroupID | int | Unique ID.
GroupName | nvarchar(110) | Name.
GroupDescription | nvarchar(255) | Some text description.
CreatorID | int | ID of creator.
ModifierID | int | ID of the last modifier.
CreationDate | datetime | Date/time of creation.
ModificationDate | datetime | Date/time of the last modification.

See Also

GroupOrganizations, GroupUsers, GroupWorkstations, PermissionGroups,


GroupUsers

GroupUsers Table

Users that belong to the Group.

Columns

Column name | Data type | Description
GroupID | int | ID of the Group.
PolarisUserID | int | ID of User.


GroupWorkstations

GroupWorkstations Table

Workstations, that belong to the Group.

Columns

Column name | Data type | Description
GroupID | int | ID of the Group.
WorkstationID | int | ID of Workstation.


HoldChargeExcludePatronCodes

HoldChargeExcludePatronCodes Table

This table contains Patron Codes that should be excluded from holds charges. (Future)

Columns

Column name | Data type | Description
PatronCodeID | int | Foreign Key reference to PatronCodes indicating the Patron code that is to be excluded from charges.


HoldsPickupBranchesExclude

HoldsPickupBranchesExclude Table

Is a list of values used by SA for PAC purposes, to allow the user to exclude branches from being available for holds processing in PAC at the per branch level.

Columns

Column name | Data type | Description
OrganizationID | int | The organization ID (this is the main entry point into table).
ExcludedBranchID | int | The branch ID
Exclude | bit | A bit flag meaning 'yes' or 'no'


HoldsPickupStatusesExclude

HoldsPickupStatusesExclude Table

A list of values used by SA to allow the user to exclude hold statuses from being eligible to have their pickup location changed for holds processing.

Columns

Column name | Data type | Description
ExcludedStatusID | int | Hold status
Exclude | bit | A bit flag meaning 'yes' or 'no'


HoldsPreferredLendersInclude

HoldsPreferredLendersInclude Table

Is a list of values used by SA for PAC/tech client purposes, to allow the user to include branches as being preferred lenders, and works in conjunction with items that have a preferred lenders flag set. Used primarily for the item trapping for holds process during check in/check out.

Columns

Column name | Data type | Description
OrganizationID | int | The organization ID (this column is the entry point into the table).
IncludedBranchID | int | branch ID
Include | bit | A bit flag meaning 'yes' or 'no'


HoldUserNotSuppliedReasons

HoldUserNotSuppliedReasons Table

Reasons why hold was not supplied

Columns

Column name | Data type | Description
ReasonID | int | Unique ID
ReasonDesc | nvarchar(50) | Reason description

See Also

SysHoldItemRecordsRTFAvailable,


HomeboundArchive

HomeboundArchive Table

This table is for future use.

Columns

Column name | Data type | Description
PatronID | int | This table is for future use.
HomeboundNote | nvarchar(255) | This table is for future use.


IDXErrorLog

IDXErrorLog Table

Contains error information associated with indexing related tasks.

Columns

Column name | Data type | Description
TaskLogID | int | Identifies the task associated with the error described in the current row.
ErrorNumber | int | The numeric error number of the error that caused an exception.
ErrorSeverity | int | The severity of the error that caused an exception.
ErrorState | int | The state number of the error that caused an exception.
ErrorProcedure | nvarchar(126) | The procedure name of the error that caused an exception.
ErrorLine | int | The line number at which an error occurred that caused an exception.
ErrorMessage | nvarchar(2048) | The message text of the error that caused an exception.


IDXTaskLog

IDXTaskLog Table

Contains statistical information associated with indexing related tasks.

Columns

Column name | Data type | Description
TaskLogID | int | Unique identifier for the row.
ParentTaskLogID | int | Identifies the parent of the current task.
TaskName | sysname | The name of an indexing task.
Progress | bigint | Specifies the current progresss value.
MaxProgress | bigint | Specifies the maximum progress value.
RowsAffected | bigint | Specifies the number of rows affected.
StartTime | datetime | Specifies the task start time.
EndTime | datetime | Specifies the task end time.
SessionID | int | Identifies session ID associated with the calling process.

See Also

IDXErrorLog, IDXTaskLog,


ILL$Messages

ILL$Messages Table

This table is used to store ILL messages received by and sent to the ILLDaemon service.

Columns

Column name | Data type | Description
MessageID | uniqueidentifier | The uniqueidentifier for an ILL APDU.
Chunk | int | Used to maintain the proper data sequence. If an ASN1 packet is greater than 8000 bytes, it will span multiple rows. This column will be used to piece the data back together in the right order.
Data | varbinary | Stores ASN.1 BER or XER encoded ILL messages

See Also

ILL_MessageDetails, ILLRequests, SysHoldRequests,


ILLRequests

ILLRequests Table

This table contains one row for each ILL request placed in the system. This table is similar to the SysHoldRequests table for hold requests.

Columns

Column name | Data type | Description
ILLRequestID | int | Identifies the ill request. The ILLRequestID is the primary key and has the identity property.
ILLStatusID | int | Status of the ill request. The ILLStatusID column is handled automatically and should never be set directly.
CreationDate | datetime | Date the ill request was placed. This value is handled automatically and should never be set directly.
ActivationDate | datetime | Date the ill request is activated (system does not attempt to satisfy request until after specified date has been reached). Optional. If not specified, default is the CreationDate. Similar to the ActivationDate in the SysHoldRequests table.
NeedByDate | datetime | The date by which the item is needed.
LastStatusTransitionDate | datetime | Date of last status transition. This value is handled automatically and should never be set directly.
LastStatusID | int | The status that the ill request was in earlier.
Export | smallint | Denotes whether the request has been exported to oclc or not.
Converted | smallint | Denotes whether this request was a result of converting a hold to an ill request.
PatronID | int | Patron for which the ill request was placed. Required.
PickupBranchID | int | Branch at which the item is to be picked up. Required.
RequestType | int | Denotes whether the request is loan type or copy type. 1 -- Loan, 2 -- Copy (meaning a make a copy of the article or item for loan)
SortAuthor | nvarchar(255) | Author of requested item. Similar to Author column in SysHoldRequests table.
SortTitle | nvarchar(255) | Title of requested item. Optional, can be NULL. Similar to Title column in SysHoldRequests table.
VolumeAndIssue | nvarchar(255) | Denotes the volume and issue number of the requested item. Optional, can be NULL.
Series | nvarchar(255) | If the item is part of a series, then this field denotes that value. Optional, can be NULL.
Edition | nvarchar(50) | The requested edition of the item.
Publisher | nvarchar(100) | The company that published (eg. printed, recorded, marketed, distributed) the item. Optional, can be NULL.
PublicationYear | smallint | Publication year of requested item. See also BibliographicRecords table. Optional, can be NULL.
LCCN | nvarchar(40) | LC call number of requested item. See also BibliographicRecords table. Optional, can be NULL.
ISBN | nvarchar(50) | ISBN of requested item. See also BibliographicTag020Index table. Optional, can be NULL. Similar to ISBN column in SysHoldRequests table.
ISSN | nvarchar(50) | ISSN of requested item. See also BibliographicTag022Index table. Optional, can be NULL. Similar to ISSN column in SysHoldRequests table.
OCLCNumber | int | Taken from the 035$a fo the Bibliographic record on which the ill request was placed.
BibliographicRecordID | int | After an ILL item has been received, this is the bibliographic record control number of the BibRecord when the ill status changed to received.
ItemRecordID | int | After an ILL item has been received, this is the item record control number of the BibRecord when the ill status changed to received.
StaffNotes1 | nvarchar(255) | Contains notes entered by staff.
StaffNotes2 | nvarchar(255) | Contains notes entered by staff.
OpacNotes | nvarchar(255) | Contains notes entered by patron. Similar to OpacNotes column in SysHoldRequests table.
MessageID | uniqueidentifier | When an ill request is exported to OCLC or created via PAC, this value denotes the unique identifier of the OCLC request. See also ILL$Messages table.
MediumType | smallint | ISO standard value which denotes the medium of the item.
HoldNotificationDate | datetime | Denotes the date when a notice for this request was sent.
PrimaryMARCTOMID | tinyint | MARC type of Material value
TargetGUID | nvarchar(36) | ID used to store database request came from.
ShippingAddress | nvarchar(32) | Shipping address used in ICCOC implementation.
ShippingCity | nvarchar(32) | Shipping city used in ICCOC implementation.
ShippingState | nvarchar(32) | Shipping state used in ICCOC implementation.
ShippingPostalCode | nvarchar(10) | Shipping postal code used in ICCOC implementation.
ISBNNormalized | nvarchar(50) | Normalized version of the ISBN
ISSNNormalized | nvarchar(50) | Normalized version of the ISSN
BrowseTitle | nvarchar(255) | display title
BrowseTitleNonFilingCount | tinyint | browse title non filing count
BrowseAuthor | nvarchar(255) | display author
HoldNotification2ndDate | datetime | Denotes the date when a second notice for this request was sent.
ReturnUncirculated | bit | When set, this indicates the ILL Request was returned without being circulated to the patron.
HoldTillDate | datetime | If the request cannot be supplied by this date it should not be filled. NULL indicates the request should not expire.

See Also

InnReachRequests,


ILLStatuses

ILLStatuses Table

This table contains a record for each valid ill status.

Columns

Column name | Data type | Description
ILLStatusID | int | Identifies the ill status.
Description | nvarchar(80) | Describes the ill status - this is what is displayed in UI.
InternalDescription | nvarchar(80) | Detailed description of the ill status code.

See Also

ILLRequests,


ILL_MessageDetails

ILL_MessageDetails Table

This table is used to store OCLC ILL queue information and ILL Transaction data.

Columns

Column name | Data type | Description
MessageDetailID | int | primary key
MessageTypeID | int | Foreign key to ILL_MessageTypes table. Determines what kind of ILL APDU this message detail entry describes.
MessageID | uniqueidentifier | foreign key to ILL$Messages table. Links details to the actual ILL APDU
TxnGroupQualifier | nvarchar(25) | ILL transaction group qualifier.
TxnQualifier | nvarchar(25) | ILL transaction qualifier.
SubTxnQualifier | nvarchar(25) | ILL sub transaction qualifier. When this field is populated, it typically signifies this request is OCLC specific.
CreationDate | datetime | Date row was created
ReceivedDate | datetime | Date message was received by system.
SentDate | datetime | Date ILL request was successfully sent to OCLC by ILLDaemon queue processing mechanism. If null, message was not sent or was not successfully sent.
AttemptedToSendDate | datetime | Date OCLC ILL APDU Request was attempted to be sent to OCLC ILL server.
NumberOfAttempts | tinyint | Number of attempts made by ILLDaemon queue processing mechanism to send ILL request to OCLC.
RequestingOrgID | int | Polaris Organization ID of branch requesting an item.
HostName | nvarchar(255) | ILL Server address used by ILLDaemon Queue processing mechanism to send requests
Port | int | Port of server address used by ILLDaemon Queue processing mechanism to send requests
Email | nvarchar(255) | Email address used by ILLDaemon Queue processing mechanism to send requests
LocalHold | bit | 0 = ILL, 1 = local hold
StatusMsg | nvarchar(255) | Populated by ILLDaemon queue processing mechanism when the ILL request is processed. Contains status or error text.


ILL_MessageTypes

ILL_MessageTypes Table

This table defines the ILL APDU message types.

Columns

Column name | Data type | Description
MessageTypeID | int | primary key
Description | nvarchar(50) | Message type description.

See Also

ILL_MessageDetails,


ILSStoreCreditCards

ILSStoreCreditCards Table

This table holds an organization's list of valid credit cards used for payments within the PowerPAC and staff client when using services such as PayFlowPro.

Columns

Column name | Data type | Description
OrganizationID | int | Foreign key that links the ILSStoreCreditCards table to individual organization records.
ILSStoreCreditCardTypeID | int | Foreign key that links the ILSStoreCreditCards table to individual ILSStoreCreditCardTypes records.


ILSStoreCreditCardTypes

ILSStoreCreditCardTypes Table

This table holds the credit card types used for payments within the PowerPAC and staff client when using services such as PayFlowPro.

Columns

Column name | Data type | Description
ILSStoreCreditCardTypeID | int | Primary key for individual ILSStoreCreditCardTypes records.
Name | nvarchar(60) | Displayable text for dropdowns.
Description | nvarchar(200) | Text field containing a description of the credit card type.

See Also

ILSStoreCreditCards, ILSStoreOrders,


ILSStoreOrderDetails

ILSStoreOrderDetails Table

This table holds the order details for a specific ILSStoreOrder for payments/purchases/donations made in the PowerPAC.

Columns

Column name | Data type | Description
ILSStoreOrderDetailID | int | Primary key for individual ILS Store Order Detail records.
ILSStoreOrderID | int | Foreign key to an individual ILS Store Order record.
ILSStoreProductID | int | Foreign key to an individual ILS Store Product record.
Quantity | int | Integer representing number of items purchased.
Price | decimal | Monetary amount of this purchased item.
Description | nvarchar(100) | Text field describing the item purchased.
Data | int | A numeric field used to store generic information about an order detail. For a fine payment, this field represent a foreign key to the patronaccounts table. For a donation, this field represents the receiving organization id.
AppliedCredit | decimal | This decimal field stores the amount of money that has been credited to the credit card charge. It is used to ensure the credit does not exceed the original charge.
PaymentTxnID | int | This integer field stores a foreign key to the PatronAccounts table. It represents the payment TxnID associated with this credit card charge.
PendingRefundAmount | money | Pending refund amount


ILSStoreOrderReasons

ILSStoreOrderReasons Table

This table holds the predefined reasons for a purchase.

Columns

Column name | Data type | Description
ILSStoreOrderReasonID | int | Primary key for individual ILS Store Order Reason records.
Name | nvarchar(60) | Displayable text for dropdowns.
Description | nvarchar(200) | Text field containing a description of the store order reason.

See Also

ILSStoreOrders,


ILSStoreOrders

ILSStoreOrders Table

This table holds the store order (purchase) information submitted by the patron when they pay fines or donate monetary gifts to the library via the PowerPAC.

Columns

Column name | Data type | Description
ILSStoreOrderID | int | Foreign key to individual ILS Store Order record.
PatronID | int | Foreign key to patron record responsible for placing this order.
ILSStoreOrderReasonID | int | Foreign key to individual ILS Store Order Reason record.
OrderDate | datetime | Date field used to store the date and time the purchased was made.
ILSStoreOrderStatusID | int | Foreign key to individual ILS Store Order Status record.
BillingName | nvarchar(150) | Text field used to store credit card billing name.
BillingAddress1 | nvarchar(100) | Text field used to store credit card billing address.
BillingAddress2 | nvarchar(100) | Text field used to store credit card billing address.
BillingCity | nvarchar(50) | Text field used to store credit card billing city.
BillingStateProvinceID | int | Text field used to store credit card billing state ID.
BillingZip | nvarchar(20) | Text field used to store credit card billing zip.
BillingCountryID | int | Text field used to store credit card billing country ID.
BillingEmail | nvarchar(150) | Text field used to store credit card billing email address.
ILSStoreCreditCardTypeID | int | Foreign key to individual ILS Store Credit Card Type record.
CreditCardNumber | nvarchar(20) | Text field used to store credit card number.
ExpirationDate | datetime | Date field used to store credit card expiration date.
Amount | decimal | Monetary amount of store order (purchase).
Note | nvarchar(200) | Text field used to store a note or extra detail information for a purchase.
DateModified | datetime | Date field used to store last time this order data was changed.
TransactingOrgID | int | Foreign key to organization record where the patron was logged in when they placed the order.
UserID | int | Foreign key to polaris user record responsible for placing the purchase.
WorkstationID | int | Foreign key to polaris workstation record where user was logged in when purchase was made.

See Also

Donations, ILSStoreOrderDetails, ILSStoreTransactions,


ILSStoreOrderStatuses

ILSStoreOrderStatuses Table

This table holds the ILS Store Order Status descriptions used when a purchase is made.

Columns

Column name | Data type | Description
ILSStoreOrderStatusID | int | Primary key for individual ILS Store Order Status records.
Name | nvarchar(60) | Displayable text for dropdowns.
Description | nvarchar(200) | Text field containing a description of the status.

See Also

ILSStoreOrders,


ILSStoreProducts

ILSStoreProducts Table

This table holds the products that may be "purchased" in the PowerPAC. These may contain items such as fine payments or donations.

Columns

Column name | Data type | Description
ILSStoreProductID | int | Primary key for individual ILS Store Product records.
Description | nvarchar(100) | Text field containing a description of the product. May be used in a dropdown for display or report purposes.

See Also

ILSStoreOrderDetails,


ILSStoreTransactions

ILSStoreTransactions Table

This table holds the data returned by the credit card gateway when sales/credits are made in the PowerPAC and staff client.

Columns

Column name | Data type | Description
ILSStoreTransactionID | int | Primary key.
ILSStoreOrderID | int | Foreign key to an ILS Store Order record.
Type | nvarchar(10) | Type of transaction. S = Sale. C = Credit.
Tender | nvarchar(10) | Field used to store the type of payment offered. C (Credit) is only accepted for Polaris.
Partner | nvarchar(50) | Text field used to store Gateway (Verisign) Partner login information.
Vendor | nvarchar(50) | Text field used to store Gateway (Verisign) Vendor login information.
OrgID | nvarchar(50) | Foreign key to an organization record.
ProfileID | nvarchar(50) | Text field used to store Gateway (Verisign) Profile ID for recurring payments.
AuthCode | nvarchar(50) | Text field used to store the authorization code for the credit card transaction.
Result | nvarchar(50) | Field used to store the result value returned by the payment gateway.
ResponseMsg | nvarchar(200) | Text field used to store the response message returned by the payment gateway (Verisign). Approved, declined, etc.
DataPacket | nvarchar(1000) | Text field used to store the original data packet returned by the credit card gateway.
TransactionAmount | decimal | Monetary amount of the transaction.
TransactionDate | datetime | Date and time the transaction occurred.
TransactingOrgID | int | OrganizationID representing the location of the credit card transaction. This is typically the branch the user was logged on to when they processed a payment/credit using a credit card. Used for credit card reports.
UserID | int | UserID representing the logged on user that processed the credit card transaction. Used for credit card reports.
WorkstationID | int | WorkstationID representing the location of the credit card transaction. This is typically the physical computer the user was logged on to when they processed a payment/credit using a credit card. Used for credit card reports.
SecureToken | nvarchar(50) | Secure token used by PayflowLink credit card payment authentication.
SecureTokenID | nvarchar(50) | Secure token ID used by PayflowLink credit card payment authentication.
GatewayID | int | ID of payment gateway provider. Foreign key references to SA_OLP_Gateways.GatewayID.

See Also

PatronAccount,


ImportAuthorityControlOptions

ImportAuthorityControlOptions Table

for import profiles, a list of possible authority control processing options.

Columns

Column name | Data type | Description
ImportAuthorityControlOptionID | int | primary key
Description | nvarchar(255) | free text

See Also

CommunityImportJobs, CommunityImportProfiles, ImportJobs, ImportProfiles,


ImportDuplicateAuthorityOptions

ImportDuplicateAuthorityOptions Table

for import profiles, a list of possible duplicate authority record processing options.

Columns

Column name | Data type | Description
ImportDuplicateAuthorityOptionID | int | primary key
Description | nvarchar(255) | free text

See Also

ImportJobs, ImportProfiles,


ImportDuplicateBibOptions

ImportDuplicateBibOptions Table

for import profiles, a list of possible duplicate bibliographic record processing options.

Columns

Column name | Data type | Description
ImportDuplicateBibOptionID | int | primary key
Description | nvarchar(255) | free text field

See Also

ImportJobs, ImportProfiles,


ImportDuplicateItemBarcodeOptions

ImportDuplicateItemBarcodeOptions Table

Options available on an import profile when an item is created with a duplicate barcode.

Columns

Column name | Data type | Description
ImportDuplicateItemBarcodeOptionID | int | Primary key
Description | nvarchar(255) | The description of the option

See Also

ImportJobs, ImportProfiles,


ImportEDIItemUpdateOptions

ImportEDIItemUpdateOptions Table

This table holds the options available when an import is done and an item update is desired. It is typically a process driven by EDI ordering where the items are already linked to a bib/POLI and the desire is to update item barcodes and such, as opposed to creating new items.

Columns

Column name | Data type | Description
ImportEDIItemUpdateOptionID | int | Primary key
Description | nvarchar(255) | The option description

See Also

ImportJobs, ImportProfiles,


ImportEmbeddedHoldings

ImportEmbeddedHoldings Table

Contains the mappings used for import when item records are created from bib subfield data

Columns

Column name | Data type | Description
ImportProfileID | int | The import profile this mapping is used with
ImportEmbeddedItemFieldID | int | The item mapping ID
HoldingsTagNumber | int | The bib tag number
HoldingsSubfield | char | The subfield used for the item field


ImportEmbeddedItemFields

ImportEmbeddedItemFields Table

Table used by import embedded item which has the item field definitions

Columns

Column name | Data type | Description
ImportEmbeddedItemFieldID | int | Primary key field
ItemDataField | nvarchar(100) | The description of the item field, will match an existing DB column

See Also

ImportEmbeddedHoldings, ImportJobsItemMARCMapping,


ImportEncodingCheckBibOptions

ImportEncodingCheckBibOptions Table

Options that describe during a bib import, what will happen to the incoming record if encoding levels match

Columns

Column name | Data type | Description
ImportEncodingCheckBibOptionID | int | Primary key
Description | nvarchar(255) | Description of what will happen

See Also

ImportJobs, ImportProfiles,


ImportFileMediums

ImportFileMediums Table

for import profiles, a list of possible import medium options.

Columns

Column name | Data type | Description
ImportFileMediumID | int | primary key
Description | nvarchar(255) | free text field

See Also

ImportJobs, ImportProfiles,


ImportItemCreationOptions

ImportItemCreationOptions Table

Table of codes used with item creation during bib import for where to get item info from (tags, template, or both).

Columns

Column name | Data type | Description
ImportItemCreationOptionID | int | Primary key field
Description | nvarchar(255) | Textual description of status

See Also

ImportJobs, ImportProfiles,


ImportJobs

ImportJobs Table

A logging table used when import jobs are run. These series of tables stores the parameters and results of the import jobs

Columns

Column name | Data type | Description
ImportJobID | int | primary key
ImportScheduled | bit | is import scheduled?
ScheduledTimeForImport | datetime | import scheduled at what time
ImportCompleted | bit | import complete flag
PolarisUserID | int | user running import job
OrganizationID | int | Organization where the job was run
WorkstationID | int | workstation running import job
ImportFileNameClient | nvarchar(255) | file name from the client
ImportFileClientPathName | nvarchar(500) | file path from the client
ImportFileNameServer | nvarchar(255) | file name on the server
ImportFileMediumID | int | Medium used - file only
IsExpressImport | bit | express import used?
BibRecordOwnerID | int | bib record owner
BibDisplayInPAC | bit | bib display in pac setting
ItemDisplayInPAC | bit | item display in PAC
BibRecordSaveOptionID | int | bib save option
BibAuthorityControlOptionID | int | authority control option
BibMARCValidationOptionID | int | bib validation option
BibDuplicateOptionID | int | bib duplicate option
UseSystemBibDuplicateRules | bit | use system bib duplicate rules?
RetainDataFromRetentionTable | bit | retain bib data?
UseSystemBibRetainRules | bit | use bib system retain rules?
AuthorityRecordSaveOptionID | int | Authority save option
AuthoritySeeAlsoFromOptionID | int | Authority see also processing option
AuthorityMARCValidationOptionID | int | Authority validation option
AuthorityDuplicateOptionID | int | Authority duplicate option
UseSystemAuthorityDuplicateRules | bit | use system authority duplicate rules?
AuthorityDeDupOrgID | int | Authority de dup Organization
ItemRecordSaveOptionID | int | item save option
ItemTemplateID | int | item template used
ImportDuplicateItemBarcodeOptionID | int | duplicate item barcode option
ImportNoItemBarcodeOptionID | int | no item barcode option
ImportItemCreationOptionID | int | item creation option
ImportEDIItemUpdateOptionID | int | EDI item update option
ImportJobSubmittedDate | datetime | date job submitted
ImportProfileID | int | Import profile used
ImportEncodingCheckBibOptionID | int | What to do when encoding levels match
ImportPaused | bit | The import has been paused (or not)
FileIndexID | int | The position of the file in an import where multiple files were selected and processed at one time.
ImportRunning | bit | A flag to tell the system that the current import job is running
ImportStopped | bit | The import was stopped while it was running.
VendorAccountID | int | Link to the specified vendor used for the import
ImportTerminated | bit | A bit set when Polaris determines that an import job cannot complete and needs to be terminated.
ImportJobCreatedBySystem | bit | A flag to indicate that Polaris automatically created an import job (with data from an external source)
VendorAccountEnabled | bit | A flag set when a vendor account is used in an import job and it tells us if the vendor account was enabled or not
LastRecordProcessed | datetime | The date that the 'last' record was processed during the running of an import job. This field is updated every time a record action is completed.
DeleteDataFromRetentionTable | bit | Flag to say if the job is deleting MARC tags
UseSystemBibDeleteRules | bit | use system delete rules?
DoNotOverlay | bit | Yes/No flag that allows or prohibits this record from being overlaid

See Also

ImportJobsAuthorityDuplicateDetectionRules, ImportJobsAuthorityRecordCreated, ImportJobsAuthorityRecordCreatedDuplicateErrors, ImportJobsAuthorityRecordCreatedErrors, ImportJobsAuthorityRecordCreatedMessages, ImportJobsAuthorityRecordCreatedWarnings, ImportJobsAuthorityRecordDeletedRecordSet, ImportJobsAuthorityRecordFinalRecordSet, ImportJobsAuthorityRecordFromBibCreated, ImportJobsAuthorityRecordFromBibCreatedErrors, ImportJobsAuthorityRecordFromBibCreatedMessages, ImportJobsAuthorityRecordFromBibCreatedWarnings, ImportJobsAuthorityRecordProvisionalRecordSet, ImportJobsBibDuplicateDetectionRules, ImportJobsBibOverlayRetentionTags, ImportJobsBibRecordCreated, ImportJobsBibRecordCreatedDuplicateErrors, ImportJobsBibRecordCreatedErrors, ImportJobsBibRecordCreatedMessages, ImportJobsBibRecordCreatedWarnings, ImportJobsBibRecordDeletedRecordSet, ImportJobsBibRecordFinalRecordSet, ImportJobsBibRecordProvisionalRecordSet, ImportJobsItemMARCMapping, ImportJobsItemRecordFinalRecordSet, ImportJobsItemRecordFromBibCreated, ImportJobsItemRecordFromBibCreatedErrors, ImportJobsItemRecordFromBibCreatedMessages, ImportJobsItemRecordFromBibCreatedWarnings, ImportJobsItemRecordFromBibNoRecordCreated, ImportJobsItemRecordFromBibNoRecordUpdated, ImportJobsItemRecordFromBibUpdated, ImportJobsItemRecordFromBibUpdatedErrors, ImportJobsItemRecordFromBibUpdatedMessages, ImportJobsItemRecordFromBibUpdatedWarnings, ImportJobsItemRecordProvisionalRecordSet, ImportJobsNoRecordCreated, ImportJobsRecordSetCreatedErrors, ImportJobsRecordSetCreatedWarnings, ImportJobsRecordSets, ImportJobsSeeAlsoRecordFromAuthorityCreated, ImportJobsSeeAlsoRecordFromAuthorityCreatedErrors, ImportJobsSeeAlsoRecordFromAuthorityCreatedMessages, ImportJobsSeeAlsoRecordFromAuthorityCreatedWarnings, ImportJobsStatistics,


ImportJobsAuthorityDuplicateDetectionRules

ImportJobsAuthorityDuplicateDetectionRules Table

Authority duplicate rules specified for import job

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityDupDetectRuleID | int | duplicate detection rule
DupDetectPrecedence | smallint | Precedence of rule


ImportJobsAuthorityRecordCreated

ImportJobsAuthorityRecordCreated Table

authority record created via import job

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | authority record ID
RecordStatusID | int | Polaris record status
LDRRecordStatus | char | LDR 05
BeginTime | datetime | begin time of create
EndTime | datetime | end time of create
Heading | nvarchar(255) | authority heading


ImportJobsAuthorityRecordCreatedDuplicateErrors

ImportJobsAuthorityRecordCreatedDuplicateErrors Table

authority record created via import - duplicates found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | current record
DuplicateAuthorityRecordID | int | duplicate authority record
DuplicateReason | nvarchar(500) | reason for duplicate
DuplicateHeading | nvarchar(255) | duplicate heading


ImportJobsAuthorityRecordCreatedErrors

ImportJobsAuthorityRecordCreatedErrors Table

authority record created via import - errors found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | authority record ID
ErrorType | int | error type
ErrorText | nvarchar(255) | error text


ImportJobsAuthorityRecordCreatedMessages

ImportJobsAuthorityRecordCreatedMessages Table

authority record created via import - messages found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | authority record ID
MessageType | int | message type
MessageText | nvarchar(255) | message text


ImportJobsAuthorityRecordCreatedWarnings

ImportJobsAuthorityRecordCreatedWarnings Table

authority record created via import - warnings found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | authority record ID
WarningType | int | warning type
WarningText | nvarchar(255) | warning text


ImportJobsAuthorityRecordDeletedRecordSet

ImportJobsAuthorityRecordDeletedRecordSet Table

Records to be placed in authority deleted set

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | authority record ID


ImportJobsAuthorityRecordFinalRecordSet

ImportJobsAuthorityRecordFinalRecordSet Table

Records to be placed in authority final set

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | authority record ID


ImportJobsAuthorityRecordFromBibCreated

ImportJobsAuthorityRecordFromBibCreated Table

authority record created during bib import

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | authority record ID
BibliographicRecordID | int | linked bib ID
RecordStatusID | int | polaris record status
LDRRecordStatus | char | LDR 05
BeginTime | datetime | begin create time
EndTime | datetime | creation end time
OriginalTagData | nvarchar(500) | tag from bib used to create record data


ImportJobsAuthorityRecordFromBibCreatedErrors

ImportJobsAuthorityRecordFromBibCreatedErrors Table

authority record created during bib import - errors

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | authority record ID
ErrorType | int | error type
ErrorText | nvarchar(255) | error text


ImportJobsAuthorityRecordFromBibCreatedMessages

ImportJobsAuthorityRecordFromBibCreatedMessages Table

authority record created during bib import - messages

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | authority record ID
MessageType | int | message type
MessageText | nvarchar(255) | message text


ImportJobsAuthorityRecordFromBibCreatedWarnings

ImportJobsAuthorityRecordFromBibCreatedWarnings Table

authority record created during bib import - warnings

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | authority record ID
WarningType | int | warning type
WarningText | nvarchar(255) | warning text


ImportJobsAuthorityRecordProvisionalRecordSet

ImportJobsAuthorityRecordProvisionalRecordSet Table

Records to be placed in authority provisional set

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
AuthorityRecordID | int | authority record ID


ImportJobsBibDuplicateDetectionRules

ImportJobsBibDuplicateDetectionRules Table

Bib duplicate rules specified for import job

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
BibDupDetectRuleID | int | Rule ID
DupDetectPrecedence | smallint | Precedence


ImportJobsBibOverlayRetentionIndOne

ImportJobsBibOverlayRetentionIndOne Table

Indicator one value retained during import

Columns

Column name | Data type | Description
RetainIndicator | char | indicator value
RetentionID | int | primary key


ImportJobsBibOverlayRetentionIndTwo

ImportJobsBibOverlayRetentionIndTwo Table

Indicator two value retained during import

Columns

Column name | Data type | Description
RetainIndicator | char | indicator value
RetentionID | int | primary key


ImportJobsBibOverlayRetentionTags

ImportJobsBibOverlayRetentionTags Table

MARC tags retained during import

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
RetainTagNumber | int | tag number
Retain | bit | retain or delete MARC tag
RetentionID | int | primary key

See Also

ImportJobsBibOverlayRetentionIndOne, ImportJobsBibOverlayRetentionIndTwo,


ImportJobsBibRecordCreated

ImportJobsBibRecordCreated Table

bib record created during import

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
BibliographicRecordID | int | bib record ID
RecordStatusID | int | record status
LDRRecordStatus | char | LDR 05
BeginTime | datetime | creation begin time
EndTime | datetime | creation end time
Title | nvarchar(255) | title of bib record
BibRecordAlreadyExisted | bit | The bib record was added to this table, but it already existed in the DB (was not new, but added because an incoming bib was rejected).


ImportJobsBibRecordCreatedDuplicateErrors

ImportJobsBibRecordCreatedDuplicateErrors Table

bib record created during import - duplicates found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
BibliographicRecordID | int | bib record ID
DuplicateBibliographicRecordID | int | duplicate bib
DuplicateReason | nvarchar(500) | duplicate reason
DuplicateTitle | nvarchar(255) | duplicate title


ImportJobsBibRecordCreatedErrors

ImportJobsBibRecordCreatedErrors Table

bib record created during import - errors found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
BibliographicRecordID | int | bib record ID
ErrorType | int | error type
ErrorText | nvarchar(255) | error text


ImportJobsBibRecordCreatedMessages

ImportJobsBibRecordCreatedMessages Table

bib record created during import - messages found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
BibliographicRecordID | int | bib record ID
MessageType | int | message type
MessageText | nvarchar(255) | message text


ImportJobsBibRecordCreatedWarnings

ImportJobsBibRecordCreatedWarnings Table

bib record created during import - warnings found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
BibliographicRecordID | int | bib record ID
WarningType | int | warning type
WarningText | nvarchar(255) | warning text


ImportJobsBibRecordDeletedRecordSet

ImportJobsBibRecordDeletedRecordSet Table

Records to be placed in bibliographic deleted set

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
BibliographicRecordID | int | bib record ID


ImportJobsBibRecordFinalRecordSet

ImportJobsBibRecordFinalRecordSet Table

Records to be placed in bibliographic final set

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
BibliographicRecordID | int | bib record ID


ImportJobsBibRecordProvisionalRecordSet

ImportJobsBibRecordProvisionalRecordSet Table

Records to be placed in bibliographic provisional set

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
BibliographicRecordID | int | bib record ID


ImportJobsItemMARCMapping

ImportJobsItemMARCMapping Table

Mapping used during import job for item creation

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ImportEmbeddedItemFieldID | int | item field foreign key
HoldingsTagNumber | int | MARC tag
HoldingsSubfield | char | MARC subfield


ImportJobsItemRecordFinalRecordSet

ImportJobsItemRecordFinalRecordSet Table

Records to be placed in item final set

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ItemRecordID | int | item record ID


ImportJobsItemRecordFromBibCreated

ImportJobsItemRecordFromBibCreated Table

item record created from bib during import

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ItemRecordID | int | item record ID
BibliographicRecordID | int | linked bib record ID
RecordStatusID | int | record status of item
BeginTime | datetime | creation begin time
EndTime | datetime | creation end time
OriginalTagData | nvarchar(500) | bib data item was created from


ImportJobsItemRecordFromBibCreatedErrors

ImportJobsItemRecordFromBibCreatedErrors Table

item record created from bib during import - errors found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ItemRecordID | int | item record ID
ErrorType | int | error type
ErrorText | nvarchar(255) | error text


ImportJobsItemRecordFromBibCreatedMessages

ImportJobsItemRecordFromBibCreatedMessages Table

item record created from bib during import - messages found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ItemRecordID | int | item record ID
MessageType | int | message type
MessageText | nvarchar(255) | message text


ImportJobsItemRecordFromBibCreatedWarnings

ImportJobsItemRecordFromBibCreatedWarnings Table

item record created from bib during import - warnings found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ItemRecordID | int | item record ID
WarningType | int | warning type
WarningText | nvarchar(255) | warning text


ImportJobsItemRecordFromBibNoRecordCreated

ImportJobsItemRecordFromBibNoRecordCreated Table

Table used by import report, for logging item creation from bib record failures. Including when a $9 found in the tag, etc.

Columns

Column name | Data type | Description
ImportJobID | int | Import job
BibliographicRecordID | int | Bib record
BeginTime | datetime | begin time
EndTime | datetime | end time
OriginalTagData | nvarchar(500) | the tag data from the bib record
ErrorType | int | Error type
ErrorText | nvarchar(255) | Error text


ImportJobsItemRecordFromBibNoRecordUpdated

ImportJobsItemRecordFromBibNoRecordUpdated Table

Table used by import report, for logging item update via EDI from bib record failures. Including when a $9 found in the tag, etc.

Columns

Column name | Data type | Description
ImportJobID | int | import job
BibliographicRecordID | int | bib record
BeginTime | datetime | begin time
EndTime | datetime | end time
OriginalTagData | nvarchar(500) | original data from bib record
ErrorType | int | error type
ErrorText | nvarchar(255) | error text


ImportJobsItemRecordFromBibUpdated

ImportJobsItemRecordFromBibUpdated Table

item record updated from bib during import

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ItemRecordID | int | item record ID
BibliographicRecordID | int | linked bib record ID
BeginTime | datetime | update begin time
EndTime | datetime | update end time
OriginalTagData | nvarchar(500) | bib data used to update item record


ImportJobsItemRecordFromBibUpdatedErrors

ImportJobsItemRecordFromBibUpdatedErrors Table

item record updated from bib during import - errors found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ItemRecordID | int | item record ID
ErrorType | int | error type
ErrorText | nvarchar(255) | error text


ImportJobsItemRecordFromBibUpdatedMessages

ImportJobsItemRecordFromBibUpdatedMessages Table

item record updated from bib during import - messages found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ItemRecordID | int | item record ID
MessageType | int | message type
MessageText | nvarchar(255) | message text


ImportJobsItemRecordFromBibUpdatedWarnings

ImportJobsItemRecordFromBibUpdatedWarnings Table

item record updated from bib during import - warnings found

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ItemRecordID | int | item record ID
WarningType | int | warning type
WarningText | nvarchar(255) | warning text


ImportJobsItemRecordProvisionalRecordSet

ImportJobsItemRecordProvisionalRecordSet Table

Records to be placed in item provisional set

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ItemRecordID | int | item record ID


ImportJobsNoRecordCreated

ImportJobsNoRecordCreated Table

Log table when an error during import caused MARC data to not be saved

Columns

Column name | Data type | Description
ImportJobsNoRecordCreatedID | int | primary key
ImportJobID | int | foreign key
ObjectTypeID | int | what object type failed
BeginTime | datetime | begin time
EndTime | datetime | end time

See Also

ImportJobsNoRecordCreatedErrors, ImportJobsNoRecordCreatedWarnings,


ImportJobsNoRecordCreatedErrors

ImportJobsNoRecordCreatedErrors Table

Errors found when no record was created

Columns

Column name | Data type | Description
ImportJobsNoRecordCreatedID | int | foreign key
ErrorType | int | error type
ErrorText | nvarchar(255) | error text


ImportJobsNoRecordCreatedWarnings

ImportJobsNoRecordCreatedWarnings Table

Warnings found when no record was created

Columns

Column name | Data type | Description
ImportJobsNoRecordCreatedID | int | foreign key
WarningType | int | warning type
WarningText | nvarchar(255) | warning text


ImportJobsRecordSetCreatedErrors

ImportJobsRecordSetCreatedErrors Table

Errors during record set creation in import

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ErrorText | nvarchar(255) | error text


ImportJobsRecordSetCreatedWarnings

ImportJobsRecordSetCreatedWarnings Table

Warnings during record set creation in import

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
WarningText | nvarchar(255) | warning text


ImportJobsRecordSets

ImportJobsRecordSets Table

The record sets created during import and all the record set parameters

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
BibFinalRecordSetName | nvarchar(80) | name of record set
BibFinalRecordSetOwnerID | int | owner of record set
BibFinalExistingRecordSetID | int | existing record set ID (not created by import)
BibFinalRecordSetNew | bit | is the record set new or not?
BibFinalNewRecordSetID | int | new record set ID (created by import)
BibFinalRecordSetAppendOrReplace | bit | existing record set had new records appended to or replaced by
BibProvRecordSetName | nvarchar(80) | name of record set
BibProvRecordSetOwnerID | int | owner of record set
BibProvExistingRecordSetID | int | existing record set ID (not created by import)
BibProvRecordSetNew | bit | is the record set new or not?
BibProvNewRecordSetID | int | new record set ID (created by import)
BibProvRecordSetAppendOrReplace | bit | existing record set had new records appended to or replaced by
BibDelRecordSetName | nvarchar(80) | name of record set
BibDelRecordSetOwnerID | int | owner of record set
BibDelExistingRecordSetID | int | existing record set ID (not created by import)
BibDelRecordSetNew | bit | is the record set new or not?
BibDelNewRecordSetID | int | new record set ID (created by import)
BibDelRecordSetAppendOrReplace | bit | existing record set had new records appended to or replaced by
AuthorityFinalRecordSetName | nvarchar(80) | name of record set
AuthorityFinalRecordSetOwnerID | int | owner of record set
AuthorityFinalExistingRecordSetID | int | existing record set ID (not created by import)
AuthorityFinalRecordSetNew | bit | is the record set new or not?
AuthorityFinalNewRecordSetID | int | new record set ID (created by import)
AuthorityFinalRecordSetAppendOrReplace | bit | existing record set had new records appended to or replaced by
AuthorityProvRecordSetName | nvarchar(80) | name of record set
AuthorityProvRecordSetOwnerID | int | owner of record set
AuthorityProvExistingRecordSetID | int | existing record set ID (not created by import)
AuthorityProvRecordSetNew | bit | is the record set new or not?
AuthorityProvNewRecordSetID | int | new record set ID (created by import)
AuthorityProvRecordSetAppendOrReplace | bit | existing record set had new records appended to or replaced by
AuthorityDelRecordSetName | nvarchar(80) | name of record set
AuthorityDelRecordSetOwnerID | int | owner of record set
AuthorityDelExistingRecordSetID | int | existing record set ID (not created by import)
AuthorityDelRecordSetNew | bit | is the record set new or not?
AuthorityDelNewRecordSetID | int | new record set ID (created by import)
AuthorityDelRecordSetAppendOrReplace | bit | existing record set had new records appended to or replaced by
ItemFinalRecordSetName | nvarchar(80) | name of record set
ItemFinalRecordSetOwnerID | int | owner of record set
ItemFinalExistingRecordSetID | int | existing record set ID (not created by import)
ItemFinalRecordSetNew | bit | is the record set new or not?
ItemFinalNewRecordSetID | int | new record set ID (created by import)
ItemFinalRecordSetAppendOrReplace | bit | existing record set had new records appended to or replaced by
ItemProvRecordSetName | nvarchar(80) | name of record set
ItemProvRecordSetOwnerID | int | owner of record set
ItemProvExistingRecordSetID | int | existing record set ID (not created by import)
ItemProvRecordSetNew | bit | is the record set new or not?
ItemProvNewRecordSetID | int | new record set ID (created by import)
ItemProvRecordSetAppendOrReplace | bit | existing record set had new records appended to or replaced by


ImportJobsSeeAlsoRecordFromAuthorityCreated

ImportJobsSeeAlsoRecordFromAuthorityCreated Table

See Also heading created from authority record during import

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
SeeAlsoAuthorityRecordID | int | see also authority ID
AuthorityRecordID | int | Authority record ID
RecordStatusID | int | record status
LDRRecordStatus | char | LDR 05
BeginTime | datetime | creation begin time
EndTime | datetime | creation end time
OriginalTagData | nvarchar(500) | MARC data used to create record


ImportJobsSeeAlsoRecordFromAuthorityCreatedErrors

ImportJobsSeeAlsoRecordFromAuthorityCreatedErrors Table

See Also heading created from authority record during import - errors

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
SeeAlsoAuthorityRecordID | int | see also authority ID
ErrorType | int | error type
ErrorText | nvarchar(255) | error text


ImportJobsSeeAlsoRecordFromAuthorityCreatedMessages

ImportJobsSeeAlsoRecordFromAuthorityCreatedMessages Table

See Also heading created from authority record during import - messages

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
SeeAlsoAuthorityRecordID | int | see also record ID
MessageType | int | message type
MessageText | nvarchar(255) | message text


ImportJobsSeeAlsoRecordFromAuthorityCreatedWarnings

ImportJobsSeeAlsoRecordFromAuthorityCreatedWarnings Table

See Also heading created from authority record during import - warnings

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
SeeAlsoAuthorityRecordID | int | see also record ID
WarningType | int | warning type
WarningText | nvarchar(255) | warning text


ImportJobsStatistics

ImportJobsStatistics Table

Import job stats

Columns

Column name | Data type | Description
ImportJobID | int | foreign key
ImportBeginTime | datetime | begining of import
ImportEndTime | datetime | end of import
BibRecordSavedAsFinalCount | int | number of bib records saved as final status
BibRecordSavedAsProvisionalCount | int | number of bib records saved as provisional status
BibRecordSavedAsDeletedCount | int | number of bib records saved as deleted status
BibRecordRejectedCount | int | number of bib records rejected
AuthorityRecordSavedAsFinalCount | int | number of authority records saved as final status
AuthorityRecordSavedAsProvisionalCount | int | number of authority records saved as provisional status
AuthorityRecordSavedAsDeletedCount | int | number of authority records saved as deleted status
AuthorityRecordRejectedCount | int | number of authority records rejected
ItemRecordSavedAsFinalCount | int | number of item records saved as final status
ItemRecordSavedAsProvisionalCount | int | number of item records saved as provisional status
ItemRecordUpdatedCount | int | number of item records updated (via EDI)
ItemRecordRejectedCount | int | number of item records rejected
ImportTotalRecordsReadCount | int | number of records read from import file
ImportTotalRecordsCreatedCount | int | number of records created during import
AuthorityRecordSystemGeneratedCount | int | number of authority records generated by Polaris.
AuthorityRecordAutoAuthorityGeneratedCount | int | number of authority records auto generated
BibRecordUpdatedCount | int | The count of the number of existing bib records that were updated with retained tags from rejected records.
RecordSetCreatedCount | int | Number of record sets created by an import
RecordSetUpdatedCount | int | Number of record sets updated by an import
RecordSetBibRecordFinalCount | int | number of records in the record set
RecordSetBibRecordProvCount | int | number of records in the record set
RecordSetBibRecordDelCount | int | number of records in the record set
RecordSetAuthorityRecordFinalCount | int | number of records in the record set
RecordSetAuthorityRecordProvCount | int | number of records in the record set
RecordSetAuthorityRecordDelCount | int | number of records in the record set
RecordSetItemRecordFinalCount | int | number of records in the record set
RecordSetItemRecordProvCount | int | number of records in the record set
ResourceEntitiesCreatedNewBibsCount | int | Number of resource entities created in new bib records
ResourceEntitiesCreatedExistingBibsCount | int | Number of resource entities created in existing records


ImportMARCValidationOptions

ImportMARCValidationOptions Table

for import profiles, a list of possible marc validation authority/bib record processing options.

Columns

Column name | Data type | Description
ImportMARCValidationOptionID | int | primary key
Description | nvarchar(255) | free text field

See Also

ImportJobs, ImportProfiles,


ImportNoItemBarcodeOptions

ImportNoItemBarcodeOptions Table

Options for the user on an import profile to do if no barcode is found on imported item record.

Columns

Column name | Data type | Description
ImportNoItemBarcodeOptionID | int | primary key
Description | nvarchar(255) | description

See Also

ImportJobs, ImportProfiles,


ImportProfiles

ImportProfiles Table

This is the import profiles table, which lists all of the profiles which have been created for importing.

Columns

Column name | Data type | Description
ImportProfileID | int | primary key
ProfileName | nvarchar(255) | name of profile
ProfileDescription | nvarchar(255) | description with profile
CreatorID | int | polaris user id of creator
ImportFileMediumID | int | link to import file mediums table
ImportScheduled | bit | Flag to say if import is to be done now or scheduled (not functional yet).
ScheduledTimeForImport | datetime | date time to schedule imports (not yet functional)
SourceFileName | nvarchar(1000) | file of marc records to import
BibRecordSaveOptionID | int | link to save options table
BibRecordOwnerID | int | default owner associated with bib records imported
BibMARCValidationOptionID | int | link to marc validation options table
BibDuplicateOptionID | int | link to bib duplicate options table
UseSystemBibDuplicateRules | bit | Y/N flag to say if to use system dedup rules or not
RetainBibDataFromRetentionTable | bit | Y/N to say whether or not to retain data during overlay
UseSystemRetainBibRules | bit | Y/N flag to say if to use system retention rules or not
BibAuthorityControlOptionID | int | link to bib authority control options table
ItemRecordSaveOptionID | int | link to embedded item create options table
ItemTemplateID | int | if item creation is on, a template can be selected for defaults.
AuthorityRecordSaveOptionID | int | link to authority record save options table
AuthorityMARCValidationOptionID | int | link to marc validation options table
AuthorityDuplicateOptionID | int | link to authority duplicate detection options table
UseSystemAuthorityDuplicateRules | bit | Y/N flag to say if to use system dedup rules or not
AuthorityDeDupOrgID | int | if authority merge processing is on, this is the organization who we merge against.
AuthoritySeeAlsoFromOptionID | int | link to authority see also options table
BibFinalRSNew | bit | Y/N for use new record set
BibFinalRSExisting | bit | Y/N for use existing record set
BibFinalRSName | nvarchar(50) | name of new/existing record set
BibFinalRSOwnerID | int | owner ID for new/existing record set
BibFinalRSExistingID | int | record set ID for existing record set
BibFinalRSAppendOrReplace | bit | append or replace records in an existing record set
BibProvRSNew | bit | Y/N for use new record set
BibProvRSExisting | bit | Y/N for use existing record set
BibProvRSName | nvarchar(50) | name of new/existing record set
BibProvRSOwnerID | int | owner ID for new/existing record set
BibProvRSExistingID | int | record set ID for existing record set
BibProvRSAppendOrReplace | bit | append or replace records in an existing record set
BibDelRSNew | bit | Y/N for use new record set
BibDelRSExisting | bit | Y/N for use existing record set
BibDelRSName | nvarchar(50) | name of new/existing record set
BibDelRSOwnerID | int | owner ID for new/existing record set
BibDelRSExistingID | int | record set ID for existing record set
BibDelRSAppendOrReplace | bit | append or replace records in an existing record set
AuthorityFinalRSNew | bit | Y/N for use new record set
AuthorityFinalRSExisting | bit | Y/N for use existing record set
AuthorityFinalRSName | nvarchar(50) | name of new/existing record set
AuthorityFinalRSOwnerID | int | owner ID for new/existing record set
AuthorityFinalRSExistingID | int | record set ID for existing record set
AuthorityFinalRSAppendOrReplace | bit | append or replace records in an existing record set
AuthorityProvRSNew | bit | Y/N for use new record set
AuthorityProvRSExisting | bit | Y/N for use existing record set
AuthorityProvRSName | nvarchar(50) | name of new/existing record set
AuthorityProvRSOwnerID | int | owner ID for new/existing record set
AuthorityProvRSExistingID | int | record set ID for existing record set
AuthorityProvRSAppendOrReplace | bit | append or replace records in an existing record set
AuthorityDelRSNew | bit | Y/N for use new record set
AuthorityDelRSExisting | bit | Y/N for use existing record set
AuthorityDelRSName | nvarchar(50) | name of new/existing record set
AuthorityDelRSOwnerID | int | owner ID for new/existing record set
AuthorityDelRSExistingID | int | record set ID for existing record set
AuthorityDelRSAppendOrReplace | bit | append or replace records in an existing record set
ItemFinalRSNew | bit | Y/N for use new record set
ItemFinalRSExisting | bit | Y/N for use existing record set
ItemFinalRSName | nvarchar(50) | name of new/existing record set
ItemFinalRSOwnerID | int | owner ID for new/existing record set
ItemFinalRSExistingID | int | record set ID for existing record set
ItemFinalRSAppendOrReplace | bit | append or replace records in an existing record set
ItemProvRSNew | bit | Y/N for use new record set
ItemProvRSExisting | bit | Y/N for use existing record set
ItemProvRSName | nvarchar(50) | name of new/existing record set
ItemProvRSOwnerID | int | owner ID for new/existing record set
ItemProvRSExistingID | int | record set ID for existing record set
ItemProvRSAppendOrReplace | bit | append or replace records in an existing record set
CreationDate | datetime | Date the profile was created.
ModificationDate | datetime | Date profile was modified.
ModifierID | int | Polaris user who last modified profile
ImportDuplicateItemBarcodeOptionID | int | Flag to say whether or not to save duplicate items as provisional.
ImportNoItemBarcodeOptionID | int | Code to say whether or not to save item records imported with no barcode, or to save as provisional vs. final.
BibDisplayInPAC | bit | The bib's display in pac flag
ItemDisplayInPAC | bit | The item's display in PAC flag
ImportItemCreationOptionID | int | Enum choice to say if we should create items, based on presence of template and/or embedded items or both when importing a bib record.
ImportEDIItemUpdateOptionID | int | The EDI Update option saved in the profile
ImportEncodingCheckBibOptionID | int | What to do what encoding levels match
VendorAccountID | int | Link to the vendor used in the import
DeleteDataFromRetentionTable | bit | Are we deleting MARC tags?
UseSystemBibDeleteRules | bit | Are we using the system bib deletion rules?
DoNotOverlay | bit | Yes/No flag that allows or prohibits this record from being overlaid

See Also

AuthorityDuplicateDetectionPrecedence, AuthorityOverlayRetentionTags, BibDuplicateDetectionPrecedence, BibOverlayRetentionTags, ImportEmbeddedHoldings, ImportJobs,


ImportRecordSaveOptions

ImportRecordSaveOptions Table

for import profiles, a list of possible record saving options.

Columns

Column name | Data type | Description
ImportRecordSaveOptionID | int | primary key
Description | nvarchar(255) | free text field

See Also

CommunityImportJobs, CommunityImportProfiles, ImportJobs, ImportProfiles,


ImportSeeAlsoFromReferenceOptions

ImportSeeAlsoFromReferenceOptions Table

for import profiles, a list of possible authority see also processing options.

Columns

Column name | Data type | Description
ImportSeeAlsoFromReferenceOptionID | int | primary key
Description | nvarchar(255) | The see also processing option described

See Also

CommunityImportJobs, CommunityImportProfiles, ImportJobs, ImportProfiles,


Import_AuthorityRecords

Import_AuthorityRecords Table

Import authority record table. There is a single entry in this table for each MARC authority record in the import. Additional contents of the record are contained in the AuthorityTags and AuthoritySubfields tables.

Columns

Column name | Data type | Description
AuthorityRecordID | int | The Parsed authority record ID (primary Key)
CreatorID | int | The ID of the polaris user that created the parsed record
ImportedDate | datetime | The date and time the import job began the processing task
MARCStatus | char | LDR/05
MARCType | char | LDR/06
MARCUndefined7 | char | LDR/07
MARCUndefined8 | char | MARC LDR/08
MARCEncodingLevel | char | LDR/17
MARCUndefined18 | char | MARC LDR/18
MARCUndefined19 | char | MARC LDR/19
MARCCharCodingScheme | char | LDR/09 - tells use whether the record is Unicode format or not.
CreationDate | datetime | The date and time the parsed authority record was created
ImportedFileName | nvarchar(255) | The name of the file that the record came from
ImportFileSequence | int | The sequence of the record in the file


Import_AuthoritySubfields

Import_AuthoritySubfields Table

This table contains all of the parsed MARC subfield data for all import authority records.

Columns

Column name | Data type | Description
AuthoritySubfieldID | int | Primary key
AuthorityTagID | int | Foreign Key link to Import_AuthorityTags table
SubfieldSequence | smallint | The order of this subfield in relation to the entire tag.
Subfield | char | The subfield character as defined by MARC format
Data | nvarchar(4000) | The Authority record subfield data in Unicode format.


Import_AuthorityTags

Import_AuthorityTags Table

A table where parsed authority tags reside before import processing takes place.

Columns

Column name | Data type | Description
AuthorityTagID | int | Primary key
AuthorityRecordID | int | Link to import authority record table
Sequence | smallint | Order of tag in relation to record it belongs in
TagNumber | smallint | MARC Tag number
IndicatorOne | char | First Indicator associated with tag
IndicatorTwo | char | Second indicator associated with tag
AssociatedAuthorityRecordID | int | Not used


Import_AuthRecordsScheduleLink

Import_AuthRecordsScheduleLink Table

A link between the parsed authority records and the import file

Columns

Column name | Data type | Description
ImportAuthorityRecordID | int | A link to the import authority records table
ImportFileID | int | The ID of the file in which the authority record was contained.
ImportCompleted | bit | A flag yhat indicates if the file parsing task is complete
CreationCompleted | bit | A flag that indicates if the creation of the authority record has taken place


Import_BibliographicRecords

Import_BibliographicRecords Table

A table where parsed bibliographic records reside before import processing takes place.

Columns

Column name | Data type | Description
BibliographicRecordID | int | This is the unique identifier for the record. (primary key, identity)
RecordOwnerID | int | Polaris organization who owns the record
CreatorID | int | This is the ID of the Polaris user who created the record.
DisplayInPAC | tinyint | Depricated
ImportedDate | datetime | The date on which the import took place
MARCBibStatus | char | This is part of the leader of the record. It represents position 5.
MARCBibType | char | This is part of the leader of the record. It represents position 6.
MARCBibLevel | char | This is part of the leader of the record. It represents position 7.
MARCTypeControl | char | This is part of the leader of the record. It represents position 8.
MARCBibEncodingLevel | char | This is part of the leader of the record. It represents position 17.
MARCDescCatalogingForm | char | This is part of the leader of the record. It represents position 18.
MARCLinkedRecordReq | char | This is part of the leader of the record. It represents position 19.
MARCCharCodingScheme | char | LDR/09 - tells use whether the record is Unicode format or not.
CreationDate | datetime | Non-MARC creation date
ImportedFileName | nvarchar(255) | File name record was imported from
ImportFileSequence | int | The sequence of the record in the incoming file


Import_BibliographicSubfields

Import_BibliographicSubfields Table

The import MARC subfield table. Every subfield in the Bib MARC record will contain an entry in this table. This table contains a foreign key to the BibliographicTags entity to identify the MARC tag that contains this subfield.

Columns

Column name | Data type | Description
BibliographicSubfieldID | int | Primary Key unique identifier (IDENTITY)
BibliographicTagID | int | Link to the IMPORT_BibliographicTags table
SubfieldSequence | smallint | Where this particular subfield exists in relation to other subfields in a tag.
Subfield | char | The character subfield code
Data | nvarchar(4000) | The subfield data (Unicode)
AuthorizingRecordID | int | Not used.


Import_BibliographicTags

Import_BibliographicTags Table

The Import Bibliographic MARC tag table. This table contains an entry for each tag in the imported MARC record.

Columns

Column name | Data type | Description
BibliographicTagID | int | BibTag Primary Key unique identifier (IDENTITY)
BibliographicRecordID | int | Link to Import Bib Record table
Sequence | smallint | Where is this tag in relation to other tags in a bib record?
TagNumber | smallint | The tag number
IndicatorOne | char | First indicator value for tag
IndicatorTwo | char | Second indicator value for tag


Import_BibRecordsScheduleLink

Import_BibRecordsScheduleLink Table

A link between the parsed bibliographic records and the import file

Columns

Column name | Data type | Description
ImportBibliographicRecordID | int | Link to import Bibliographic Record table
ImportFileID | int | A link to the Import Files table
ImportCompleted | int | A flag indicating if file parsing has been completed
CreationCompleted | bit | A flag indicating if the record has been created in the Polaris BibliographicRecords table


Import_ScheduledImportFiles

Import_ScheduledImportFiles Table

A table to track of imported files

Columns

Column name | Data type | Description
ScheduledImportFileID | int | Primary Key
ImportJobID | int | The import Job ID associated with the file
ImportStartTime | datetime | The start date and time of file parsing
ImportFileName | nvarchar(4000) | The name of the file
ImportFileLength | int | The size of the import file in bytes
ImportCurrentProgress | int | The current parsing progress
ImportFileEncodingName | nvarchar(4000) | The kind of encoding of the file (UCS/MARC8)
WorkstationID | int | The workstation at which the import took place
PolarisUserID | int | The polaris user who imported the file
NumberOfRecordsInFile | int | The raw number of records found in the file
NumberOfRecordsImported | int | The number of records found in the file that were parsed successfully
NumberOfErrors | int | The number of processing errors.
ImportEndTime | datetime | The end date and time of the parsing process
ImportCompleted | bit | A flag indicating if import parsing has been completed
FileIsConsumed | bit | A flag indicating if the file has been consumed
NumberOfBibs | int | The number of bibliographic records in the file
NumberOfAuths | int | The number of authority records in the file
NoValidRecords | int | Indicates that there were no valid records in the file
HasBeenCancelledByUser | int | Indicates that the import job has been cancelled by the user
ImportFileConsumedPause | bit | When the parsing is finished, we pause the file until all parsing is done for a given user's selected files.


Import_ScheduleErrors

Import_ScheduleErrors Table

A table to report importing errors

Columns

Column name | Data type | Description
ImportErrorID | int | Primary Key
ScheduledImportFileID | int | A relation to the import files table
ImportJobID | int | The Import Job ID associated with the error
RecordNumber | int | The record sequence in the file associated with the error
ErrorType | int | The error type
ErrorText | nvarchar(255) | The text of the error
ErrorReported | bit | If the error was reported
IsWarning | bit | Indicates if the row is a warning


InboundPhoneLines

InboundPhoneLines Table

This table stores the phone line specific settings for the Polaris Phone Attendant Service. When the service is started, it connects to the web server and loads inboundconfig.asp. This ASP page queries this table and build the service's config XML file.

Columns

Column name | Data type | Description
PhoneLineID | int | Identity
LineNumber | int | The phone line index (1 based) of the phone line in the Dialogic boards.
OrganizationID | int | Organization ID used for transactions.
TransactionUserID | int | User ID used for transactions.
TransactionWorkstationID | int | Workstation ID used for transactions.
ConnectionInfo | nvarchar(255) | Used to supply datasource connection information to the PhoneAttendant's data layer. When using the PhoneAttendant_PCS.dll, this entry can be blank (use default partition@server) or a specific partition@server entry.
PasswordRequired | bit | Option to determine if a password is required when the patron logs into the Phone Attendant.
MaxLoginAttempts | int | Number of attempts to allow a patron to login.
ExpirationWarningEnabled | bit | When a patron logs into the Phone Attendant, it tells the service whether or not it should warn the patron if their account is about to expire.
ExpirationWarningDays | int | When a patron logs into the PhoneAttendant, this number is used to provide advance warning of their account expiration.
PhoneMessagesURL | nvarchar(255) | URL where the Phone Attendant's messages are located. This allows different phone lines to have their own messages.
WavePath | nvarchar(255) | Location of wave files used in Phone Attendant. This allows different phone lines to have their own messages.
ListItemsOutEnabled | bit | When a patron has logged into the phone attendant, determines if the option to list items out is enabled. This does not remove the option from the menu.
ListItemsOutAuthor | bit | When a patron has logged into the phone attendant and the system is listing their items out, this option determines if the author will be heard.
ListItemsOutMaterialType | bit | When a patron has logged into the phone attendant and the system is listing their items out, this option determines if the material type will be heard.
ListItemsOutBranch | bit | When a patron has logged into the phone attendant and the system is listing their items out, this option determines if the assigned branch will be heard.
RenewSingleItem | bit | When a patron has logged into the phone attendant, determines if the option to renew a single items is enabled. This does not remove the option from the menu.
ListOverdueItemsEnabled | bit | When a patron has logged into the phone attendant, determines if the option to list overdue items is enabled. This does not remove the option from the menu.
ListOverdueItemsAuthor | bit | When a patron has logged into the phone attendant and the system is listing their overdue items, this option determines if the author will be heard.
ListOverdueItemsMaterialType | bit | When a patron has logged into the phone attendant and the system is listing their overdue items, this option determines if the material type will be heard.
ListOverdueItemsBranch | bit | When a patron has logged into the phone attendant and the system is listing their overdue items, this option determines if the assigned branch will be heard.
ListRequestsEnabled | bit | When a patron has logged into the phone attendant, determines if the option to list requests is enabled. This does not remove the option from the menu.
ListHeldItemsEnabled | bit | When a patron has logged into the phone attendant, determines if the option to list held items is enabled. This does not remove the option from the menu.
AccountStatementEnabled | bit | Offer option to hear account summary.
ServerID | int | Foreign Key link to Telephony Server associated with this phone line.
IsAlphaNumericPWD | bit | Option to determine if a password can be alphanumeric or not when the patron logs into the Phone Attendant.
EstimateFinesEnabled | bit | When a patron has logged into the phone attendant, determines if the option to list accrued fines is enabled. This does not remove the option from the menu.


InboundPhoneVoices

InboundPhoneVoices Table

This table stores the phone voice specific settings for the Polaris Phone Attendant Service. When the service is started, it connects to the web server and loads inboundconfig.asp. This ASP page queries this table and build the service's config XML file.

Columns

Column name | Data type | Description
InboundPhoneVoiceID | int | Identity
OrganizationID | int | Organization ID used for transactions.
LanguageID | int | Choice of the language for each phone voice.
DefaultLanguage | bit | Default language to be used in phone call.
SAPIVoiceIndex | smallint | speech index for the phone voice which is used while playing the phone message. The index indicates what voice to be used in phone call. Example would be 'Microsoft Mary' or 'AT&T Mike'
Rate | smallint | Rate at which the phone message is played.
Volume | smallint | Volume at which the phone message is played.
MenuOption | smallint | If more than one language is licensed, menu option is configured for each language which is used while playing the phone message to choose the language choice.
ServerID | int | Foreign Key link to Telephony Server associtated this phone voice.


InHouseIPAddresses

InHouseIPAddresses Table

This table represents a list of individual IPs, range of IPs or IP masks that will be considered In-house or local IP addresses. It is typically used for the PAC's remote patron authentication.

Columns

Column name | Data type | Description
InHouseIPAddressID | int | Identity column
StartingIP | nvarchar(15) | Starting IP address. Cannot be null. Can contain a single IP address or an IP address mask such as 10.0.50.*.
EndingIP | nvarchar(15) | Ending IP address. This can be NULL. It cannot contain an IP mask. Used with the StartingIP to specify a range of IP addresses.


InitialArticle

InitialArticle Table

This tables contains the words that are to be removed from the beginning of a user's search criteria before the search is performed. There are system administration parameters that control whether this table is used in PAC and whether it is used in the staff client. When in use, this tables applies to both browse and phrase searching in the PAC and exact match, browse, and phrase searching in the staff client.

Columns

Column name | Data type | Description
InitialArticleWord | nvarchar(32) | The word to be stripped from the beginning of a user's search criteria.


InnReachAgencies

InnReachAgencies Table

This table contains an entry for each Agency on the local server participating with INN-Reach. It was determined remote Agencies are not required for definiton here, only Agencies local to the Polaris server.

Columns

Column name | Data type | Description
AgencyID | int | The primary key unique identifier for this table.
LocalServerID | int | Foreign Key reference to InnReachLocalServers referencing the INN-Reach local server this Agency is associated with.
AgencyCode | nvarchar(5) | The up to 5 character Agency code assigned by INN-Reach.
Name | nvarchar(80) | A descriptive name for this Agency.

See Also

InnReachCentrals_Agencies, InnReachLocations,


InnReachApiDiagnostics

InnReachApiDiagnostics Table

Entries for each incoming and outgoing INN-Reach circulation-related API call. The data is used to help troubleshoot issues by being able to see the transactions for a given INN-Reach hold request over its lifespan.

Columns

Column name | Data type | Description
TransactionDate | datetime | Date/time API call was made.
Direction | nvarchar(10) | Direction of the API call (inbound or outbound).
URI | nvarchar(100) | URI of the API call made.
HttpHeaderAuthorization | nvarchar(255) | Authorization header used when issuing the API call including authorization token.
HttpHeaderXFromCode | nvarchar(10) | The INN-Reach central or local server code that issued the API call.
HttpHeaderXToCode | nvarchar(10) | The INN-Reach central or local server code that is the intended recipient of the API call.
MessageNumber | int | Numeric value representing the type of circulation message sent. NULL means a non-circulation message like patron validation.
MessageBody | nvarchar(-1) | Body of the posted API message.
ResponseHttpStatusCode | int | Numeric HTTP status code of the call.
ResponseHttpStatusDescription | nvarchar(100) | Description of the HTTP status of the call.
ResponseBody | nvarchar(-1) | The body of the response from the API call.
IsTransactionSuccess | bit | A value of ‘1’ means the API call was formatted correctly. A value of ‘0’ means there where an error in the formatting of the request.
Note | nvarchar(-1) | Any additional error message
TrackingID | int | The INN-Reach tracking identification number associated with the request.


InnReachApplicationErrors

InnReachApplicationErrors Table

This table contains log entries of errors and warnings related to INN-Reach API message processing.

Columns

Column name | Data type | Description
MessageNumber | int | The Polaris to INN-Reach API message number associated with this entry.
TransactionDate | datetime | The timestamp associated with this application error log.
CentralCode | nvarchar(5) | The INN-Reach Central Server identification code from the API Message.
TrackingID | int | The INN-Reach unique TrackingID for the request associated with the error.
ReasonCode | int | The TBD Reason Code for the error/warning.
Message | nvarchar(255) | The descriptive message detailing the error/warning.


InnReachBibs

InnReachBibs Table

This table contains details on the Bibliographic records that have been contributed to INN-Reach.

Columns

Column name | Data type | Description
CentralID | int | Foreign Key reference to the InnReachCentrals table indicating the INN-Reach Central Server this content has been contributed to.
BibID | int | The Polaris BibliographicRecordID associated with this contributed Bib.
EntryDate | datetime | The timestamp the record was contributed to this INN-Reach Central Server.
UpdateDate | datetime | The timestamp the contributed record was last updated to this INN-Reach Central Server.
MD5Hash | nvarchar(100) | A hash entry containing details from the last time this record was updated to INN-Reach. This is used in determining if a record that was newly updated needs to be updated at INN-Reach Central.


InnReachCentralITypeToTOM

InnReachCentralITypeToTOM Table

This table contains mappings of the INN-Reach Central Item Types to Polaris MARC Type-Of-Material. This is used in the creation of Virtual Bibs for INN-Reach items that will circulate at the Borrowing Library. The converted TOM will be assigned to the Virtual Bib and will display in the PAC for the title requested then circulated.

Columns

Column name | Data type | Description
CentralID | int | The ID of the INN-Reach Central server that the Central Item Types are defined for. Foreign Key reference to the INNREACH_Centrals table.
CentralIType | int | The Central iType defined at INN-Reach central.
PrimaryMARCTOMID | tinyint | MARC Type of Material to map the associated Central iType to.


InnReachCentrals

InnReachCentrals Table

This table defines the INN-Reach Central Servers that this local server participates with.

Columns

Column name | Data type | Description
CentralID | int | The primary key unique identifier for this table.
CentralCode | nvarchar(5) | The INN-Reach Central Server identification code.
Name | nvarchar(80) | The descriptive name of this Central Server.
DiscoveryLayerUrl | nvarchar(255) | The URL of the Discovery Layer web interface for this INN-Reach central site
IsSkyRiver | bit | Flag indicating the if the central location is SkyRiver.
IsPeerToPeer | bit | Flag indicating the if the central location is Peer to Peer.

See Also

InnReachBibs, InnReachCentralITypeToTOM, InnReachCentrals_Agencies, InnReachCentrals_Locations, InnReachCirculationExceptions, InnReachContributionQueue, InnReachFilterCollections, InnReachFilterItemStatuses, InnReachFilterMaterialTypes, InnReachItems, InnReachMapPatronCodeToPTypes, InnReachMapPTypeToPatronCodes, InnReachRequests,


InnReachCentrals_Agencies

InnReachCentrals_Agencies Table

This table is an associative entity table linking INN-Reach Agencies with the Central Servers in which they participate.

Columns

Column name | Data type | Description
CentralID | int | Foreign Key reference to the InnReachCentrals table.
AgencyID | int | Foreign Key reference to the InnReachAgencies table.


InnReachCentrals_Locations

InnReachCentrals_Locations Table

This table defines the locations each INN-Reach Central Server participates with

Columns

Column name | Data type | Description
CentralID | int | Unique identifier for the INN-Reach Central Server
OrganizationID | int | Unique identifier for the location


InnReachCirculationExceptions

InnReachCirculationExceptions Table

This table contains exceptions from the INN-Reach API message receiver.

Columns

Column name | Data type | Description
ExceptionID | int | The primary key unique identifier for this table.
TransactionDate | datetime | The timestamp associated with the circulation exception.
MessageType | int | The Polaris to INN-Reach API Message number to be sent.
TrackingID | int | The INN-Reach unique Tracking number for the request assocaited with the API Message.
MessageBody | nvarchar(-1) | The JSON formatted body of the API message containing content according to the P2IR API Document.
Note | nvarchar(1024) | Additional details associated with the exception.
CentralID | int | ID of INN-Reach central that circulation message is intended for. Used in requeuing the exception.


InnReachCirculationQueue

InnReachCirculationQueue Table

This table contains the queue of INN-Reach API Circulation messages to be sent from the local Polaris server to an INN-Reach Central Server and remote INN-Reach Agencies

Columns

Column name | Data type | Description
CirculationQueueID | int | Primary key unique identifier for this table.
TransactionDate | datetime | The timestamp when this message was placed in the queue.
CentralID | int | Foreign Key reference to the InnReachCentrals table for the Central Server to receive the message.
MessageType | int | The Polaris to INN-Reach API Message number to be sent.
TrackingID | int | The INN-Reach unique Tracking number for the request assocaited with the API Message.
MessageBody | nvarchar(-1) | The JSON formatted body of the API message containing content according to the P2IR API Document.


InnReachContributionExceptions

InnReachContributionExceptions Table

This table contains exceptions related to the upload processing of records via the InnReachContributionQueue.

Columns

Column name | Data type | Description
ExceptionID | int | The primary key unique identifier for this table entry.
TransactionDate | datetime | The timestamp associated with the contribution exception.
RecordType | nvarchar(50) | RecordType for this entry: 1 = Bibliographic Record, 2 = Item Record.
ActionType | nvarchar(50) | Indicates new record or update: 1 = New record, 2 = Update Eexisting record.
RecordID | int | This is the BibliographicRecordID (if RecordType = 1) or ItemRecordID (if RecordType = 2).
Note | nvarchar(1024) | Additional details associated with the exception.


InnReachContributionQueue

InnReachContributionQueue Table

This table contains the queue of INN-Reach API Data Contribution messages to be sent from the local Polaris server to an INN-Reach Central Server that houses the INN-Reach catalog of Bibs and Items.

Columns

Column name | Data type | Description
ContributionQueueID | int | The primary key unique identifier for this table.
TransactionDate | datetime | The timestamp when this message was placed in the queue.
RecordType | int | RecordType for this entry: 1 = Bibliographic Record, 2 = Item Record.
ActionType | int | Indicates new record or update: 1 = New record, 2 = Update Eexisting record.
IsUploadCheckNeeded | int | Flag indicating the record needs to be checked against the INN-Reach upload configuration rules to determine if it really needs to be uploaded.
RecordID | int | This is the BibliographicRecordID (if RecordType = 1) or ItemRecordID (if RecordType = 2).
CentralID | int | Optional INN-Reach central ID if contribution is intended for one specific central


InnReachFilterCollections

InnReachFilterCollections Table

List of collections that should be contributed to INN-Reach central(s).

Columns

Column name | Data type | Description
CentralID | int | ID mapping to the central that the collection should be uploaded to.
PolarisCollectionID | int | ID of Polaris collection to be uploaded.
InnReachItemTypeID | int | Optional INN-Reach IType value. If this value is NULL, the material type of the item is used for mapping purposes.


InnReachFilterItemStatuses

InnReachFilterItemStatuses Table

List of item statuses whose items should be contributed to INN-Reach central(s).

Columns

Column name | Data type | Description
CentralID | int | ID mapping to the central that the collection should be uploaded to.
PolarisItemStatusID | int | ID of Polaris item status to be uploaded.
InnReachItemStatusCode | nvarchar(32) | INN-Reach item status value to be mapped from the Polaris item status ID.
InnReachItemStatusDescription | nvarchar(80) | Description of the INN-Reach item status code being mapped to.


InnReachFilterMaterialTypes

InnReachFilterMaterialTypes Table

List of material types whose items should be contributed to INN-Reach central(s).

Columns

Column name | Data type | Description
CentralID | int | ID mapping to the central that the collection should be uploaded to.
PolarisMaterialTypeID | int | ID of Polaris material types to be uploaded.
InnReachItemTypeID | int | INN-Reach IType value to be mapped from the Polaris material type ID.


InnReachItems

InnReachItems Table

This table contains details on the items that have been contributed to INN-Reach.

Columns

Column name | Data type | Description
CentralID | int | Foreign Key reference to the InnReachCentrals table indicating the INN-Reach Central Server this content has been contributed to.
ItemID | int | The Polaris ItemRecordID for the item contributed.
BibID | int | The AssociatedBibRecordID for the item contributed.
EntryDate | datetime | The timestamp the record was contributed to this INN-Reach Central Server.
UpdateDate | datetime | The timestamp the contributed record was last updated to this INN-Reach Central Server.
MD5Hash | nvarchar(100) | A hash entry containing details from the last time this record was updated to INN-Reach. This is used in determining if a record that was newly updated needs to be updated at INN-Reach Central.


InnReachLocalServers

InnReachLocalServers Table

This table contains the INN-Reach Local Server information for this Polaris server that is participating in INN-Reach.

Columns

Column name | Data type | Description
LocalServerID | int | The primary key unique identifier for this table.
LocalServerCode | nvarchar(30) | The INN-Reach assigned local server code for this server.
Name | nvarchar(80) | The descriptive name for the INN-Reach Local Server.

See Also

InnReachAgencies,


InnReachLocations

InnReachLocations Table

This table contains the INN-Reach Locations for this local server. For a Polaris system Locations are the Branches on the server participating in INN-Reach. These branches are all valid pickup locations within INN-Reach.

Columns

Column name | Data type | Description
LocationID | int | The primary key uniquie identifier for this table.
AgencyID | int | Foreign key reference to the parent Agency for this Location.
LocationCode | nvarchar(32) | The INN-Reach assigned Location Code for the branch.
Name | nvarchar(80) | The descriptive name used in INN-Reach for this Location.
OrganizationID | int | The Polaris branch orgnizationID (foreign key reference to Organizations) associated with this Location.


InnReachMapPatronCodeToPTypes

InnReachMapPatronCodeToPTypes Table

Used for INN-Reach data contribution to the central INN-Reach server. This table maps the local Polaris Patron Codes to a Central Patron Type (PType).

Columns

Column name | Data type | Description
PolarisPatronCode | int | The local Polaris Patron Code to be mapped to a local PType.
InnReachLocalPType | int | The local Patron Type (PType) to map the Patron Code to for contributing up to INN-Reach Central.
CentralID | int | Unique identifier for the INN-Reach Central Server


InnReachMapPTypeToPatronCodes

InnReachMapPTypeToPatronCodes Table

This table contains mappings of the INN-Reach Central Patron Types to Polaris Patron Codes. This is used at the lending library when creating a Virtual Patron.

Columns

Column name | Data type | Description
CentralID | int | ID mapping to the central that the collection should be uploaded to.
InnReachCentralPType | int | The central Patron Type (PType) to map the Patron Code of the contributor.
PolarisPatronCode | int | The Polaris Patron Code to be mapped to.


InnReachRequests

InnReachRequests Table

This table contains an entry for all INN-Reach requests that involve the local system. An INN-Reach request can be for a Patron at this server getting material from a remote system (Borrowing Library Scenario), an item from the local system that is filling a request by a patron from a remote server (Lending Library scenario), or a local hold at this server that was placed through INN-Reach.

Columns

Column name | Data type | Description
CentralID | int | Foreign Key reference to InnReachCentrals indicating the INN-Reach Central Server associated with this INN-Reach request. Comprises the Primary Key for this table along with InnReachTrackingID.
InnReachTrackingID | int | This is the TrackingID established by the associated INN-Reach Central Server for this request and is used as a reference for all API messages associated with the request. Comprises the Primary Key for this table along with CentralID.
LastAPIMessage | int | The most recent API message received associated with this request.
LastAPIMessageTime | datetime | The date/time the LastAPIMessage was received.
PickupLocationCode | nvarchar(10) | The INN-Reach Pickup Location Code component of the Pickup Location. This code indicates the location for pickup. When it is associated with a Polaris site it maps to a Branch organization.
PickupLocationPrintName | nvarchar(100) | The INN-Reach 'Print Name' component of the Pickup Location. This is the field to display on pickup/routing slips as it usually contains both the Agency code and Library abbreviation. (i.e. 'CMPL - Main')
PickupLocationDeliveryStop | nvarchar(100) | The INN-Reach 'Delivery Stop' component of the Pickup Location. This field usually contains descriptive info on the location in the library where the hold is picked up. (i.e. 'Hold Shelf 1st Floor')
PickupOrganizationID | int | The Polaris OrganizationID associated with the Pickup Location.
PatronAgencyCode | nvarchar(5) | The INN-Reach Agency identifier associated with the Patron who placed the request.
ItemAgencyCode | nvarchar(5) | The INN-Reach Agency identifier associated with the item selected to fill the request.
LocalItemType | int | The INN-Reach ItemType as defined at the local server associated with item selected to fill the request.
CentralItemType | int | The INN-Reach ItemType as defined at the Central INN-Reach server associated with item selected to fill the request.
CentralPatronType | int | The INN-Reach PatronType as defined at the Central INN-Reach server associated with patron who placed the request.
ItemBarcode | nvarchar(99) | The barcode of the item selected to fill the request.
SysHoldRequestID | int | The Polaris unique identifier for the item level hold that was created for filling the INN-Reach request. This request exists at the Lending Library.
ILLRequestID | int | The Polaris unique identifier for the ILL request that was created for filling the INN-Reach request. This ILL request exists at the Borrowing Library and is linked to the Patron who placed the request.
PatronID | nvarchar(99) | The PatronID of the Patron who placed the request. At the Lending Library this is a PatronID from the remote system. At the Borrowing Library this is the local Polaris patron who placed the INN-Reach hold request.
PatronName | nvarchar(99) | The name of the Patron who placed the INN-Reach request. This field exists at the Lending Library to provide informational reference to the Patron at the Borrowing Library site. In Polaris a Virtual Patron is created for this patron to associated with the request referenced by SysHoldRequestID.
ItemID | nvarchar(99) | The Item Identifier for the Item selected to fill the INN-Reach hold request. This should match the ItemRecordID at the Polaris Lending Library that will fill the request.
ItemRecordID | int | The Polaris unique identifier of the Item filling the INN-Reach request. At the Lending Library this is the physical Item that is pulled to fill the request. At the Borrowing Library this is the Virtual Item that was created for circulating the physical item provided by the remote library.
V_PatronID | int | The unique idenitifier of the Virtual Patron that was created at the Lending Library for the INN-Reach request. This field exists at the Lending Library to provide informational reference to the Patron at the Borrowing Library site. This Virtual Patron is created to be associated with the SysHoldRequest that is created for filling the hold. This Virtual Patron exists through the entire INN-Reach process of holds fulfillment and circulation.
Author | nvarchar(256) | The Author associated with the Item INN-Reach has selected to fill the request. (This field is not required and may not exist for all Item Holds).
Title | nvarchar(256) | The Title associated with the Item INN-Reach has selected to fill the request. (This field is not required and may not exist for all Item Holds).
BibCallNumber | nvarchar(256) | The Bibliographic Call Number associated with the Item INN-Reach has selected to fill the request. (This field is not required and may not exist for all Item Holds).
V_ItemTemplateID | int | The unique identifier of the Item Template that was used in the creation of the Virtual Item that is created for circulating the item at the Borrowing Library.
PatronPhone | nvarchar(20) | The Patron phone number as provided in the [100 - Create Item Hold] API message.
ItemLocation | nvarchar(80) | The source location for the item as (optionally) provided in the [201 - Item Shipped] API message.
Local | bit | Flags the request as being local to this system (both Patron and Item are associated with the local Polaris system).
PatronHomeLibrary | nvarchar(200) | Name of the library at which the patron is registered.


InnReachRequestsHistory

InnReachRequestsHistory Table

Contains a historical archive of the InnReachRequests table. When the InnReachRequests entry is deleted due to transaction completion or final clean-up it is written to this historical archive table.

Columns

Column name | Data type | Description
CentralID | int | Foreign Key reference to InnReachCentrals indicating the INN-Reach Central Server associated with this INN-Reach request. Comprises the Primary Key for this table along with InnReachTrackingID.
InnReachTrackingID | int | This is the TrackingID established by the associated INN-Reach Central Server for this request and is used as a reference for all API messages associated with the request. Comprises the Primary Key for this table along with CentralID.
LastAPIMessage | int | The most recent API message received associated with this request.
LastAPIMessageTime | datetime | The date/time the LastAPIMessage was received.
PickupLocationCode | nvarchar(10) | The INN-Reach Pickup Location Code component of the Pickup Location. This code indicates the location for pickup. When it is associated with a Polaris site it maps to a Branch organization.
PickupLocationPrintName | nvarchar(100) | The INN-Reach 'Print Name' component of the Pickup Location. This is the field to display on pickup/routing slips as it usually contains both the Agency code and Library abbreviation. (i.e. 'CMPL - Main')
PickupLocationDeliveryStop | nvarchar(100) | The INN-Reach 'Delivery Stop' component of the Pickup Location. This field usually contains descriptive info on the location in the library where the hold is picked up. (i.e. 'Hold Shelf 1st Floor')
PickupOrganizationID | int | The Polaris OrganizationID associated with the Pickup Location.
PatronAgencyCode | nvarchar(5) | The INN-Reach Agency identifier associated with the Patron who placed the request.
ItemAgencyCode | nvarchar(5) | The INN-Reach Agency identifier associated with the item selected to fill the request.
LocalItemType | int | The INN-Reach ItemType as defined at the local server associated with item selected to fill the request.
CentralItemType | int | The INN-Reach ItemType as defined at the Central INN-Reach server associated with item selected to fill the request.
CentralPatronType | int | The INN-Reach PatronType as defined at the Central INN-Reach server associated with patron who placed the request.
ItemBarcode | nvarchar(99) | The barcode of the item selected to fill the request.
SysHoldRequestID | int | The Polaris unique identifier for the item level hold that was created for filling the INN-Reach request. This request exists at the Lending Library.
ILLRequestID | int | The Polaris unique identifier for the ILL request that was created for filling the INN-Reach request. This ILL request exists at the Borrowing Library and is linked to the Patron who placed the request.
PatronID | nvarchar(99) | The PatronID of the Patron who placed the request. At the Lending Library this is a PatronID from the remote system. At the Borrowing Library this is the local Polaris patron who placed the INN-Reach hold request.
PatronName | nvarchar(99) | The name of the Patron who placed the INN-Reach request. This field exists at the Lending Library to provide informational reference to the Patron at the Borrowing Library site. In Polaris a Virtual Patron is created for this patron to associated with the request referenced by SysHoldRequestID.
ItemID | nvarchar(99) | The Item Identifier for the Item selected to fill the INN-Reach hold request. This should match the ItemRecordID at the Polaris Lending Library that will fill the request.
ItemRecordID | int | The Polaris unique identifier of the Item filling the INN-Reach request. At the Lending Library this is the physical Item that is pulled to fill the request. At the Borrowing Library this is the Virtual Item that was created for circulating the physical item provided by the remote library.
V_PatronID | int | The unique idenitifier of the Virtual Patron that was created at the Lending Library for the INN-Reach request. This field exists at the Lending Library to provide informational reference to the Patron at the Borrowing Library site. This Virtual Patron is created to be associated with the SysHoldRequest that is created for filling the hold. This Virtual Patron exists through the entire INN-Reach process of holds fulfillment and circulation.
Author | nvarchar(256) | The Author associated with the Item INN-Reach has selected to fill the request. (This field is not required and may not exist for all Item Holds).
Title | nvarchar(256) | The Title associated with the Item INN-Reach has selected to fill the request. (This field is not required and may not exist for all Item Holds).
BibCallNumber | nvarchar(256) | The Bibliographic Call Number associated with the Item INN-Reach has selected to fill the request. (This field is not required and may not exist for all Item Holds).
V_ItemTemplateID | int | The unique identifier of the Item Template that was used in the creation of the Virtual Item that is created for circulating the item at the Borrowing Library.
PatronPhone | nvarchar(20) | The Patron phone number as provided in the [100 - Create Item Hold] API message.
ItemLocation | nvarchar(80) | The source location for the item as (optionally) provided in the [201 - Item Shipped] API message.
Local | bit | Flags the request as being local to this system (both Patron and Item are associated with the local Polaris system).
PatronHomeLibrary | nvarchar(200) | Name of the library at which the patron is registered.


InstructorStatuses

InstructorStatuses Table

This table is for Course Reserves, and is an enum type of what statuses are available for a linked instructor (patron).

Columns

Column name | Data type | Description
InstructorStatusID | tinyint | Primary key.
Description | nvarchar(50) | The textual description (will be either primary or alternate).

See Also

CourseInstructorLinks,


InventoryStatistics

InventoryStatistics Table

Used to store the results of inventories done using the Polaris Inventory Manager. Each row represents an item that was inventoried.

Columns

Column name | Data type | Description
InventoryStatisticsID | int | Polaris assigned unique ID number for an inventory statistics record.
ItemRecordID | int | The ItemRecordID of the item that was inventoried.
OrganizationID | int | The OrganizationID of the Branch where the item was inventoried.
InventoryDate | datetime | The date the inventory was performed on.
CurrentStatusID | int | The ItemStatusID associated with the item that was inventoried.
Misshelved | bit | Whether ot not the item was misshelved.
CollectionID | int | The collectionid of the collection that was selected when this item was inventoried.
InventoryComputer | nvarchar(80) | The name of the computer that was used to perform the inventory.
CallNumRange | nvarchar(240) | The call number range that was selected when this item was inventoried.


InvLineItemSegmentAmts

InvLineItemSegmentAmts Table

This table tracks which Fund(s) is being used for a given Line Item Segment. Each Invoice segment can have one or more funds for payment.

Columns

Column name | Data type | Description
InvLineItemSegmentID | int | ID number of the Invoice line item segment linked to this record.
FiscalYearID | int | ID of the fiscal year linked to this record.
FundID | int | ID of the fund linked to this record.
Amount | money | Amount of money assigned from a linked fund to a linked Invoice line item segment.
Percentage | int | Percentage of the segment total that is allocated to the associated fund.


InvLineItemSegments

InvLineItemSegments Table

This is the main record for the Invoice Line Item Segment object. An item on an Invoice line item segment may, or may not, be linked to a purchase order line item segment.

Columns

Column name | Data type | Description
InvLineItemSegmentID | int | Polaris assigned unique ID number for an Invoice line item segment record. Each Invoice segment must belong to a specific Invoice line id.
InvoiceID | int | Polaris assigned unique ID number for an invoice record.
InvLineItemID | int | Polaris assigned unique ID number for an Invoice line item record.
AmtCreditedBase | money | Amount credited for this segment in the base currency of the library.
BindFormatChargeBase | money | Added cost associated with that segment that has special bindings requested.
CatServChargeBase | money | Cataloging service charge for this segment in the base currency of the library.
CheckDate | datetime | The date that appears on a printed check.
CheckNumber | nvarchar(30) | Check number used to pay the line item.
CreationDate | datetime | System generated date & time that this record was created.
CreatorID | int | Polaris User ID of the person that created the record.
DestinationCollectionID | int | The ID number of the collection for which an item was purchased (for example, children's collection, reference collection, etc.)
DestinationOrgID | int | Organization ID of the destination organization for an item.
Encumbered | bit | A flag specifying whether funds have been encumbered for this segment. (0=NO (default), 1=YES)
ErrorIndicator | bit | A flag indicating a problem with the line item. (0=NO (default), 1=YES)
Expended | bit | A flag specifying whether funds have been expended for this segment. (0=NO (default), 1=YES)
GrandTotalBase | money | The grand total of the segment in the library's base currency.
InvLISegmentNumber | int | Invoice line item segment number as it appears on the Invoice.
ModificationDate | datetime | System generated date & time that this record was modified.
ModifierID | int | Polaris User ID of the person who last modified the record.
OtherChargeBase | money | Other charges associated with the segment in the base currency of the library.
PaymentStatusID | int | Integer value used to link a Payment Status with an entry in one of the payment history records.
PaymentStatusDate | datetime | The date on which the current payment status was entered.
PONumber | nvarchar(50) | Library or system assigned purchase order number.
POLineItemSegmentID | int | Polaris assigned unique ID number for a Invoice line item segment record. Each Invoice segment must belong to a specific Invoice line.
POLINumber | int | Line Item Number as it appears on the Purchase Order.
POLISegmentNumber | int | The PO line item segment number as it appears on the purchase order.
PONumberSuf | nvarchar(50) | Suffix to a purchase order number.
QuantRec | int | Number of items received by the library.
QuantSent | smallint | Number of items sent by the supplier.
SalesTax1Base | money | Main sales tax associated with this segment in the base currency of the library.
SalesTax2Base | money | Secondary sales tax associated with this segment in the base currency of the library.
ServChargeBase | money | Service charge associated with this segment in the base currency of the library.
ShipChargeBase | money | Shipping charge associated with this segment in the base currency of the library.
SpecialHandChargeBase | money | Special handling charge associated with this segment in the base currency of the library.
TotDiscPriceBase | money | The discount Price Per Unit multiplied by the Quantity Ordered (for a PO) or Quantity Sent (for an Invoice).
VchrDate | datetime | The date that appears on a printed voucher.
VchrNumber | nvarchar(30) | The number that appears on a printed voucher.
ItemTemplateCode | nvarchar(10) | VARCHAR(10) - holds a template matching code populated from the linked POLI's Bib 970 data during Copy To.

See Also

Copy_INLISegs, InvLineItemSegmentAmts, LineItemSegmentPaymentStatusHistories, LineItemSegmentToItemRecord, MfhdIssues, PaymentHistoryLinks,


InvLines

InvLines Table

This is the main record for the Invoice Line Item object. Invoice line items appear on an invoice and may, or may not, be linked to a puchase order line item.

Columns

Column name | Data type | Description
InvLineItemID | int | Polaris assigned unique ID number for an invoice line item record.
InvoiceID | int | Polaris assigned unique ID number for linked the invoice record.
POLineItemID | int | Polaris assigned unique ID number for the linked purchase order line item record.
BibliographicRecordID | int | Polaris assigned unique ID number for linked bibliographic record.
CheckNumber | nvarchar(30) | Check number used to pay for the line item.
CreationDate | datetime | System generated date & time that this record was created.
CreatorID | int | Polaris User ID of the user that created the record.
DiscPriceUnitBase | money | Discount price paid for each item in the base currency of the library.
DiscRate | numeric | Discount rate applied to the line item.
ErrorIndicator | bit | A flag indicating an problem with the line item.(0=no(default)/1=yes)
InvLINumber | int | Line item number as it appears on the invoice.
ModificationDate | datetime | System generated date & time of the last modification to this record.
ListPriceUnitBase | money | List price/unit for the item in the libraries base currency. This is the price before the discount rate, if any, is applied.
ModifierID | int | Polaris User ID of the person who last modified the record.
Notes | nvarchar(200) | User assigned note attached to the line.
POLINumber | int | Line number of linked purchase order line item as it appears on the purchase order.
PONumber | nvarchar(30) | Purchase order number upon which linked purchase order line item can be found.
PONumberSuf | nvarchar(8) | purchase order number suffix of assoicated purchase order.
ShippedDate | datetime | Date that the supplier says item(s) were shipped.
StartDate | datetime | The date on which a subscription, standing order, approval plan or other continuing plan should start.
StartNumber | nvarchar(25) | The issue number with which a subscription, standing order, approval plan or other continuing plan should start ....
SubscrPeriod | nvarchar(30) | The length of time or other unit covered by a subscription.
VchrNumber | nvarchar(30) | The number that appears on a printed voucher.
ISBN_ISSN | nvarchar(50) | International Standard Book Number/International Standard Serial Number of the item.
SubscrExpDate | datetime | The date on which a subscription is due to expire.
CheckDate | datetime | the date that appears on a printed check.
VchrDate | datetime | The date that appears on a printed voucher.
PaymentStatusID | int | Polaris assigned ID number used to link an Payment Status with an entry in the invoice line item record.
PaymentStatusDate | datetime | The date on which the current payment status was entered.
NormalIsbnIssn | nvarchar(50) | This contains the normailzed version of the ISBN/ISSN number stored with a partiular line item. It is normalized based on Polaris' Normalization routine at the time the line item is saved to the database.
MaterialTypeID | int | int. foreign key containing the material type ID of the invoice line item. the foreign key references the MaterialTypes table.
CatalogNumber | nvarchar(50) | Bibliographic Catalog Number for the item being paid for. May be different from that of the linked Bibliographic Record.
Title | nvarchar(255) | title saved for display purposes.
Author | nvarchar(255) | author field for display purposes.
MARCLCCN | nvarchar(40) | the LCCN copied from the linked bib record (if exists) or entered by the user.
NormalLCCN | nvarchar(40) | normalized version of LCCN
NormalTitle | nvarchar(255) | title stored for searching, sorting.
NormalAuthor | nvarchar(255) | normalized version of author data.
TitleNonFilingCount | tinyint | Is the number of non-filing characters in the Title column that should be ignored for collating purposes.

See Also

InvLineItemSegments, LineItemPaymentStatusHistories,


InvLinesToPay

InvLinesToPay Table

This table conatins a list of invoice lines and segments that are to be paid during the payment process.

Columns

Column name | Data type | Description
InvID | int | database ID of the invoice being paid.
LineID | int | database ID of the invoice line being paid
SegID | int | database ID of the invoice line item segment being paid
UserID | int | database ID of the polaris user that is performing the invoice payment


InvoiceAmts

InvoiceAmts Table

Because an invoice can be asscoiated with more than one Fund, this table was developed to maintain which Fund(s) were being used for a given invoice.

Columns

Column name | Data type | Description
InvoiceID | int | primary key of the invoice record linked to this entry.
FiscalYearID | int | ID of the fiscal year linked to the invoice line item.
FundID | int | ID of the fund linked to the invoice line item.
Amount | money | Amount of a particular invoice that is associated with a particular fund.
Percentage | int | percentage of the invoice level charges that are represented by the AMOUNT value in this record.
ChargeType | int | Integer type that links the dollar amount to a specific charge type in the PO header WF.


InvoiceDeliveryMethods

InvoiceDeliveryMethods Table

This is a secondary table used by Purchase Orders. Invoice delivery methods are instructions to a supplier telling them how the library wishes to have the invoice shipped with order.

Columns

Column name | Data type | Description
InvDeliveryMethID | int | Integer value used to link an Invoice Delivery Method with a Purchase Order. Must be unique to this table.
InvDelivMethod | nvarchar(75) | Instructions to the supplier about how the invoice should be delivered. Its pre-defined values are: attach invoice to outside of package, marked "invoice attached", attach invoice to outside of package, enclose invoice and mark package, "invoice enclosed", send invoice separately .
BISACCode | nvarchar(3) | The BISAC standard code for the pre-defined values used in Polaris.

See Also

PurchaseOrders,


Invoices

Invoices Table

This is the main table used by the Invoice object. Invoices are used to pay for items that are orderd via the Polaris Acquisitons subsystem, or obtained in some other manner, but still need to be paid for by the library.

Columns

Column name | Data type | Description
InvoiceID | int | Polaris assigned unique ID number for an invoice record.
SupplierID | int | Polaris assigned unique ID number for the linked supplier record.
PaymentMethodID | int | ID number that links the paymentmethods and invoices tables.
InvoiceTypeID | int | ID number that links the invoicetypes and invoices tables.
CatServChargeBase | money | Cataloging service charge for this line in the base currency of the library.
CatServChargeForeign | money | Cataloging service charge for this line in the foreign currency of the supplier/vendor.
CheckDate | datetime | the date that appears on a printed check.
CheckNumber | nvarchar(30) | The number that appears on a printed check.
CrdtMemoNumber | nvarchar(50) | The supplier-assigned number of a credit memo. Obsolete feild, no longer used, will be removed when the DB is upgraded.
CreationDate | datetime | System generated date & time that this record was created.
CreatorID | int | Polaris User ID of the that created the record.
DepAmtBase | money | For a DEPOSIT account, the amount that was deposited, either initially or in subsequent deposits, with the supplier.
DepAmtForeign | money | For a deposit account, the amount that was used on this invoice in the foreign base currency of the supplier/vendor.
DiscRate | numeric | The actual discount rate applied to the invoice.
ExchangeRate | numeric | The exchange rate that was used to convert a particular price from one currency to another.
ForeignCurrencyID | int | ID number of foreign currency used by supplier/vendor.
InvAddChrgSubtotBase | money | The accumulated total of line item charges, not including the 'Total Discount Price' of the item itself, in the base currency of the library.
InvAddChrgSubtotForeign | money | The accumulated total of line item charges, not including the 'Total Discount Price' of the item itself, in the currency of the supplier/vendor.
InvClosingAlertDate | datetime | the date on which the system should alert the user that an invoice should be closed.
InvDate | datetime | The supplier-assigned invoice date.
InvGrndTotBase | money | Invoice grand total in the library's base currency.
InvGrndTotForeign | money | Invoice grand total in the currency of the supplier/vendor.
InvMatSubtotBase | money | The accumulated total of all line item 'Total Discount Price' fields in the base currency of the library.
InvMatSubtotForeign | money | The accumulated total of all line item 'Total Discount Price' fields in the currency of the supplier/vendor.
InvNote | nvarchar(200) | a free-text note associated with a particular invoice. Available to the user to input internal notes regarding the invoice as a whole.
InvNumber | nvarchar(30) | The invoice number assigned by the supplier, could also be assigned by the library.
InvNumberSuf | nvarchar(8) | A suffix to an invoice number.
InvReceiptDate | datetime | the date on which an invoice was received at the library.
InvTxMeth | nvarchar(10) | Indicates whether the original invoice was paper, fax, or electronic. Canbe one of the following pre-defined types:paper, fax, electronic.
ModificationDate | datetime | System generated date & time of the last modification to this record.
LBAcctNumber | nvarchar(50) | The account number assigned to the library or branch by a supplier or a bindery.
OrganizationID | int | ID number of library that is processing the invoice.
ModifierID | int | Polaris User ID of user that last modified this record.
NumberOfDays | int | Number of days to wait before billing starts.
OtherChargeBase | money | Additional charges not covered by the available invoice or line item charges options in the base currency of the library.
OtherChargeForeign | money | Additional charges not covered by the available invoice or line item charges options in the foreign currency of the supplier/vendor.
PaymentAmtBase | money | Unused field, will be removed from database.
PaymentAmtForeign | money | unused field
PaymentDueDate | datetime | Enter by a user or calculated using 'number of days due' dependent upon the payment terms option.
PaymentTerms | datetime | Describes the date at which payment of the invoice is due, can be enter as 'number of days' or a specific date.
PlanName | nvarchar(50) | The name under which a particular acquisitions plan is known to the user.
SalesTax1Base | money | Main sales tax associated with this invoice in the base currency of the library.
SalesTax2Base | money | Secondary sales tax associated with this invoice in the base currency of the library.
SalesTax1Foreign | money | Main sales tax associated with this invoice in the foreign currency of the supplier/vendor.
SalesTax2Foreign | money | Secondary sales tax associated with this invoice in the foreign currency of the supplier/vendor.
ServChargeBase | money | Service charge associated with the invoice in the base currency of the library.
ServChargeForeign | money | Special handling charge associated with the invoice in the foreign currency of the supplier/vendor.
ShipChargeBase | money | Shipping charge associated with the invoice in the base currency of the library.
ShipChargeForeign | money | Shipping charge associated with the invoice in the foreign currency of the supplier/vendor.
ShippedDate | datetime | Date that the supplier says item(s) were shipped.
SpecialHandChargeBase | money | Special handling charge associated with the invoice in the base currency of the library.
SpecialHandChargeForeign | money | Special handling charge associated with the invoice in the foreign currency of the supplier/vendor.
TotClsdPayBase | money | For partially-paid invoices, shows the total amount for paid line items in the library's base currency.
TotClsdPayForeign | money | For partially-paid invoices, shows the total amount for paid line items in the foreign currency of the supplier/vendor.
TotCrdtBase | money | The total dollar amount of all credits in the library's base currency.
TotCrdtForeign | money | The total dollar amount of all credits in the foreign currency of the supplier/vendor.
TotPendPayBase | money | The total dollar amount for all line items that are neither paid nor credited, in the library's base currency.
TotPendPayForeign | money | The total dollar amount for all line items that are neither paid nor credited, in the foreign currency of the supplier/vendor.
VchrDate | datetime | The date that appears on a printed voucher.
VchrNumber | nvarchar(30) | The number that appears on a printed voucher.
SalesTaxRate1 | numeric | the standard sales tax rate associated with purchasing items from a particular supplier.
InvoiceStatusID | int | Integer value used to link an Invoice Status with an Invoice.
InvStatusDate | datetime | System supplied date & time the InvoiceStatusID was set.
HeaderCreditsBase | money | Credits applied to an inovice header in the customers Base currency.
EDIFileName | nvarchar(255) | For EDI Invoices this contains the file name retrieved from the Supplier that contained the invoice data.

See Also

ExternalAcctSystemExchangeInvoices, InvLineItemSegments, InvLines, InvoiceAmts, InvoiceStatusHistories, LinkedInvoices, OrdersToInvoices, PaymentHistories, PSE_InvoicesLog,


InvoiceSequencing

InvoiceSequencing Table

This is a secondary table used by Purchase Orders. Invoice sequencing options are instructions to a supplier telling them in what order the library wants items to be listed on an invoice.

Columns

Column name | Data type | Description
InvSequencingID | int | Integer value used to link an Invoice Sequencing option with a Purchase Order. Must be unique to this table.
InvSequencing | nvarchar(25) | instructions to the supplier about the sequencing on the invoice. Its pre-defined values are:as the order 301, ISBN order 302, author order 303, title order 304, fund order 305.
BISACCode | nvarchar(3) | The BISAC standard code for the pre-defined values used in Polaris.

See Also

PurchaseOrders,


InvoiceStatus

InvoiceStatus Table

This is a secondary table used by the Invoice Status History record.Invoice statuses are used to inform users of Polaris the current status of an invoice record.

Columns

Column name | Data type | Description
InvoiceStatusID | int | Integer value used to link an Invoice Status with an Invoice. Must be unique to this table.
InvoiceStatus | nvarchar(8) | Describes the status of the invoice as a whole in the local system. Can be one of hte following pre-defined types:open, closed, canceled (for cases where an incorrect invoice is canceled because the supplier has agreed to supply a new, correct invoice), held (for cases where there is a problem with the invoice that is still being resolved with the supplier.

See Also

Invoices, InvoiceStatusHistories, PaymentHistories,


InvoiceStatusHistories

InvoiceStatusHistories Table

This is a secondary table used by the Invoice record. The invoice status history is used, mainly for reporting purposes, to track the status of an invoice while it is in the system. The most recent entry is the one that displays in the Invoice workform.

Columns

Column name | Data type | Description
InvoiceID | int | Polaris assigned unique ID number for an invoice record.
InvoiceStatusID | int | Integer value used to link an Invoice Status with an Invoice.
InvStatusDate | datetime | System supplied date & time the InvoiceStatusID was set.


InvoiceTypes

InvoiceTypes Table

This is a secondary table used by the Invoice record. Invoice types tell the user whether the invoice is a regular one or one of the special types used by libraries.

Columns

Column name | Data type | Description
InvoiceTypeID | int | Integer value used to link an Invoice Type with an Invoice. Must be unique to this table.
InvoiceType | nvarchar(50) | Indicates the invoice type, can be one of the following pre-defined types: regular, pro forma, dummy, credit memo.

See Also

Invoices,


IRAttributeTypes

IRAttributeTypes Table

Contains one row for each information retrieval attribute type.

Columns

Column name | Data type | Description
AttributeTypeID | int | Information retrieval attribute type identification number.
Name | sysname | Information retrieval attribute type name.
SortTypeID | tinyint | Identifies the sort order associated with the attribute type.

See Also

IRAttributeValues, IRRecordIndex, IRRecordStores,


IRAttributeValues

IRAttributeValues Table

Contains one row for each information retrieval cache-entry/attribute-type pairs.

Columns

Column name | Data type | Description
CacheEntryID | int | Identifies the cache entry.
AttributeTypeID | int | Identifies the attribute type.
DisplayValue | nvarchar(-1) | Display value.
NormalValue | nvarchar(-1) | Normalized value.
NonFilingCount | int | The number of non-filing characters that should be ignored for collating purposes.


IRCacheEntries

IRCacheEntries Table

Contains one row for each information retrieval cache entry.

Columns

Column name | Data type | Description
CacheEntryID | int | Information retrieval cache entry identification number.
Hash | binary | Contains the SHA-1 hash of the (MARC) data.
Data | varbinary | Contains the raw (MARC) data.
LocalControlNumber | int | Identifies the local control number (a.k.a. bibliographic record identifier) associated with the cache entry.

See Also

IRAttributeValues, IRRecords,


IRRecordIndex

IRRecordIndex Table

Contains one row for each information retrieval record store record/attribute type pair.

Columns

Column name | Data type | Description
RecordStoreID | int | Identifies the record store.
AttributeTypeID | int | Identifies the attribute type of the record store record.
Position | int | Identifies the position of the record store record.
RecordID | int | Identifies the record store record.


IRRecords

IRRecords Table

Contains one row for each information retrieval record store record.

Columns

Column name | Data type | Description
RecordID | int | Record store record identification number.
RecordStoreID | int | identifies the record store associated with the record store record.
CacheEntryID | int | Identifies the cache entry associated with the record store record.
AddedDate | datetime | Date the record store record was added.

See Also

IRRecordIndex,


IRRecordStores

IRRecordStores Table

Contains one row for each information retrieval record store.

Columns

Column name | Data type | Description
RecordStoreID | int | Information retrieval record store identification number.
AccountID | int | Identifies the owning (patron) account identifier.
Name | nvarchar(255) | Information retrieval record store name.
PrimarySortAttributeTypeID | int | Identifies the primary sort attribute type associated with the record store.
CreationDate | datetime | Date the record store was created.

See Also

IRRecordIndex, IRRecords,


IRSortTypes

IRSortTypes Table

Contains one row for each information retrieval sort type.

Columns

Column name | Data type | Description
SortTypeID | tinyint | Information retrieval sort type identification number.
Name | sysname | Information retrieval sort type name.

See Also

IRAttributeTypes,


ItemAvailabilityDisplay

ItemAvailabilityDisplay Table

Sets the levels (local or syste) that the item locations can be set to according to the current Organization. This affects where the item availability will be displayed in the PAC.

Columns

Column name | Data type | Description
OrganizationID | int | ID of the organization that the item's location has a level set for. Links to Organizations table.
ItemAvailabilityLevelID | int | ID of the Level that this location is set for. Link to Item Availability level (organization) table.
SortOrder | int | The order in which the items appear by location in the PAC.
BranchLocationOrgID | int | ID of the organization that specifies the location where a level is set for.


ItemAvailabilityLevels

ItemAvailabilityLevels Table

Coded values which correspond to which (org) levels items are available at.

Columns

Column name | Data type | Description
ItemAvailabilityLevelID | int | Primary Key
Description | nvarchar(32) | Text description

See Also

ItemAvailabilityDisplay,


ItemBlockDescriptions

ItemBlockDescriptions Table

Contains a list of item blocks defined by organization.

Columns

Column name | Data type | Description
OrganizationID | int | The organization which uses the particular block
ItemBlockID | int | Primary key
Description | nvarchar(80) | The text description of the block
SequenceID | int | The order in which the blocks display

See Also

CircItemRecords, ExpressCheckLibAssignedIBlocks, ItemTemplates, PatRenewalLibAssignedIBlocks,


ItemBulkChangeTemplates

ItemBulkChangeTemplates Table

Contains templates for Item Record Bulk Change settings

Columns

Column name | Data type | Description
ItemBulkChangeTemplateID | int | Unique identifier for the template
Name | nvarchar(50) | Name of template
OrganizationOwnerID | int | Organization that owns the template
CreatorID | int | ID of the template creator
ModifierID | int | ID of the last user to modify the template
CreationDate | datetime | Date the template was created
ModificationDate | datetime | Date the template was last modified
OwningBranchEnabled | int | Indicates whether or not the Owning Branch value will be changed.
OwningBranchID | int | Value the Owning Branch will be changed to
AssignedBranchEnabled | int | Indicates whether or not the Assigned Branch value will be changed.
AssignedBranchID | int | Value the Assigned Branch will be changed to
AssignedCollectionEnabled | int | Indicates whether or not the Assigned Collection value will be changed.
AssignedCollectionAbbreviation | nvarchar(15) | Value the Assigned Collection Abbreviation will be changed to
AssignedCollectionName | nvarchar(80) | Value the Assigned Collection Name will be changed to
ShelfLocationName | nvarchar(80) | Value the Shelf Location will be changed to
ShelfLocationEnabled | int | Indicates whether or not the Shelf Location value will be changed.
HomeBranchEnabled | int | Indicates whether or not the Home Branch value will be changed.
HomeBranchID | int | Value the Home Branch will be changed to
TemporaryShelfLocationEnabled | int | Indicates whether or not the Temporary Shelf Location value will be changed.
TemporaryShelfLocation | nvarchar(50) | Value the Temporary Shelf Location will be changed to
ItemStatusEnabled | int | Indicates whether or not the Item Status value will be changed.
ItemStatusID | int | Value the Item Status will be changed to
MaterialTypeEnabled | int | Indicates whether or not the Material Type value will be changed.
MaterialTypeID | int | Value the Material Type will be changed to
LoanPeriodEnabled | int | Indicates whether or not the Loan Period value will be changed.
LoanPeriodCodeID | int | Value the Loan Period Code will be changed to
Holdable | int | Value that Holdable will be changed to
HoldableEnabled | int | Indicates whether or not the Holable value will be changed.
FineCodeEnabled | int | Indicates whether or not the Fine Code value will be changed.
FineCodeID | int | Value the Fine Code will be changed to
StatisticalCodeEnabled | int | Indicates whether or not the Statistical Code value will be changed.
StatisticalCodeName | nvarchar(80) | Value the Statistical Code will be changed to
RenewalLimitEnabled | int | Indicates whether or not the Renewal Limit value will be changed.
RenewalLimit | int | Value the Renewal Limit will be changed to
HoldableByPickupEnabled | int | Indicates whether or not the Holdable By Pickup value will be changed.
HoldableByPickup | int | Value that Holdable By Pickup will be changed to
HoldPickupBranchID | int | Value the Holdable By Pickup Branch will be changed to
HoldableByLibraryEnabled | int | Indicates whether or not the Holdable By Library value will be changed.
HoldableByLibrary | int | Value that Holdable By Library will be changed to
HoldableByBranchEnabled | int | Indicates whether or not the Holdable By Branch value will be changed.
HoldableByBranch | int | Value that Holdable By Branch will be changed to
HoldableByPrimaryLenderEnabled | int | Indicates whether or not the Holable By Primary Lender value will be changed.
HoldableByPrimaryLender | int | Value that Holdable By Primary Lender will be changed to
LoanableOutsideSystemEnabled | int | Indicates whether or not the Loanable Outside System value will be changed.
LoanableOutsideSystem | int | Value that Loanable Outside System will be changed to
NonCirculatingEnabled | int | Indicates whether or not the Non-Circulating value will be changed.
NonCirculating | int | Value that Non-Circulating will be changed to
DoNotMailToPatronEnabled | int | Indicates whether or not the Do Not Mail to Patron value will be changed.
DoNotMailToPatron | int | Value that Do Not Mail To Patron will be changed to
ItemDoesNotFloatEnabled | int | Indicates whether or not the Item Does Not Float value will be changed.
ItemDoesNotFloat | int | Value that Item Does Not Float will be changed to
ShelvingSchemeEnabled | int | Indicates whether or not the Shelving Scheme value will be changed.
ShelvingSchemeID | int | Value the Shelving Scheme will be changed to
CallNumberPrefixEnabled | int | Indicates whether or not the Call Number Prefix value will be changed.
CallNumberPrefix | nvarchar(60) | Value the Call Number Prefix will be changed to
ClassificationNumberEnabled | int | Indicates whether or not the Classification Number value will be changed.
ClassificationNumber | nvarchar(60) | Value the Classification Number will be changed to
CutterNumberEnabled | int | Indicates whether or not the Cutter Number value will be changed.
CutterNumber | nvarchar(60) | Value the Cutter Number will be changed to
CallNumberSuffixEnabled | int | Indicates whether or not the Call Number Suffix value will be changed.
CallNumberSuffix | nvarchar(60) | Value the Call Number Suffix will be changed to
CopyNumberEnabled | int | Indicates whether or not the Copy Number value will be changed.
CopyNumber | nvarchar(60) | Value the Copy Number will be changed to
VolumeNumberEnabled | int | Indicates whether or not the Volume Number value will be changed.
VolumeNumber | nvarchar(60) | Value the Volume Number will be changed to
UseCallNumberFromBib | int | Indicates if the call number data will be pulled from the bibliographic record
ItemBlockName | nvarchar(80) | Value the Item Block will be changed to
LibraryAssignedBlockEnabled | int | Indicates whether or not the Library Assigned Block value will be changed.
FreeTextBlockEnabled | int | Indicates whether or not the Free Text Block value will be changed.
FreeTextBlock | nvarchar(255) | Value the Free Text Block will have appended, prepended, or replaced
FreeTextBlockPlacement | int | Indicates if the FreeTextBlock value will be appended, prepended, or replaced
PublicNoteEnabled | int | Indicates whether or not the Public Note value will be changed.
PublicNote | nvarchar(255) | Value the Public Note will be changed to
PublicNotePlacement | int | Indicates if the Public Note value will be appended, prepended, or replaced
NonPublicNoteEnabled | int | Indicates whether or not the Non-Public Note value will be changed.
NonPublicNote | nvarchar(255) | Value that Non-Public Note will have appended, prepended, or replaced
NonPublicNotePlacement | int | Indicates if the Non-Public Note value will be appended, prepended, or replaced
PhysicalConditionEnabled | int | Indicates whether or not the Physical Condition value will be changed.
PhysicalCondition | nvarchar(255) | Value that Physical Condition will have appended, prepended, or replaced
PhysicalConditionPlacement | int | Indicates if the Physical Condition value will be appended, prepended, or replaced
BibControlNumberEnabled | int | Indicates whether or not the Associated Bib value will be changed.
AssociatedBibRecordID | int | Value the Associated Bib will be changed to
DisplayInPacEnabled | int | Indicates whether or not the Display in PAC value will be changed.
DisplayInPac | int | Value the Display in PAC will be changed to
ParentItemRecordEnabled | int | Indicates whether or not the Parent Item Record value will be changed.
ParentItemRecordID | int | Value the Parent Item Record will be changed to
NameOfPieceEnabled | int | Indicates whether or not the Name of Piece value will be changed.
NameOfPiece | nvarchar(255) | Value that Name of Piece will be changed to
FundingSourceEnabled | int | Indicates whether or not the Funding Source value will be changed.
FundingSource | nvarchar(50) | Value the Funding Source will be changed to
PriceEnabled | int | Indicates whether or not the Price value will be changed.
Price | money | Value the Price will be changed to
UseSystemAssignedBarcodes | int | Indicates if system assigned barcodes should be used


ItemCheckouts

ItemCheckouts Table

This table stores information on the check-out items that belong to this database. The patrons must also be from this database.

Columns

Column name | Data type | Description
ItemRecordID | int | ID of the item, primary key. It references CircItemRecords table(ItemRecordID).
PatronID | int | ID of the patron having this item checked out. It may be from other database.
OrganizationID | int | ID of the branch the item was checked out.
CreatorID | int | ID of Polaris user who does this check out.
CheckOutDate | datetime | is the date the item was checked out. From 3.0 onwards, if the item is renewed, then it will be the renewal date.
DueDate | datetime | The date when an item is due
Renewals | int | is the count of renewal times for the item.
OVDNoticeCount | int | is the number of overdue notices sent.
RecallFlag | smallint | (Not used yet)
RecallDate | datetime | (Not used yet)
LoanUnits | tinyint | This is a code indicating the units of the Loan Period: 1=daily, 2=hourly, 3=minutely.
OVDNoticeDate | datetime | The date the most recent overdue notice was sent for this checked out item.
BillingNoticeSent | tinyint | tells if a bill against the item is sent or not, 1=Sent otherwise NULL.
OriginalCheckOutDate | datetime | Date when the original checkout occured.
OriginalDueDate | datetime | Date when the item was originally due - before any renewals were made.
CourseReserveID | int | If the item is an RIR and it is checked out for a course reserve, the ID is stored here.


ItemMapData

ItemMapData Table

A table used by conversion services for the migration console application. This table maps the column headers of in incoming text file to a specific column in a polaris table

Columns

Column name | Data type | Description
Data | nvarchar(255) | Information about the column
IncomingData | nvarchar(255) | Column name in the incoming data
MapColumn | nvarchar(255) | The Column in which the incoming data will eventually reside.
DataType | nvarchar(255) | Data type in polaris
GoalTable | nvarchar(255) | The table where this data will live
Required | bit | Indicates if the column is required 0 = not required 1 = required
MapType | int | What type of data is in the incoming column: 1 = item data 2 = Patron data 3 = item checkout transaction data 4 = patron account data 5 = holds data 6 = lost item data 7 = claims data


ItemPriceHierarchies

ItemPriceHierarchies Table

This table holds the tag/subfield combinations of where in the bib record price information will be taken from when new linked items are created. There is an organization context, as well as a precedence.

Columns

Column name | Data type | Description
OrganizationID | int | The Polaris Organization ID (branches only)
PricePrecedence | int | Precedence for which tag/subfield the price will be taken from.
BibTagNumber | int | Bibliographic tag number
BibSubfield | char | Bibliographic subfield


ItemQualificationIndex

ItemQualificationIndex Table

Contains one row for each partial or complete search term matching one or more qualification types.

Columns

Column name | Data type | Description
PrefixKey | varbinary | A canonical binary prefix key associated with a partial or complete search term.
QualificationContextTuple | varbinary | Contains compressed binary data which includes the QualificationTypeID and HitCount.


ItemQualificationTypes

ItemQualificationTypes Table

Contains one row for each patron qualification type. Each qualification type corresponds to a search access point.

Columns

Column name | Data type | Description
QualificationTypeID | int | Unique identifier for the qualification type.
Name | nvarchar(100) | Unique name for the qualification type.
Mnemonic | nvarchar(32) | Search qualifier name.


ItemRecordBranchCircCounts

ItemRecordBranchCircCounts Table

This is a listing of the item record's circ stats as relates to the specific branch it belongs to. When an item belongs to a branch and it circ's, this table is updated (as well as the main item counts)

Columns

Column name | Data type | Description
ItemRecordBranchCircCountID | int | Primary key
ItemRecordID | int | The item record ID
OrganizationID | int | The assigned branch for the item
YTDCircCount | int | YTD circ count for a specific branch
LifetimeCircCount | int | Lifetime circ count for a specific branch
YTDInHouseUseCount | int | YTD in house use count for a specific branch
LifetimeInHouseUseCount | int | Lifetime in house use count for a specific branch


ItemRecordDetails

ItemRecordDetails Table

This structure is the Non-MARC item record

Columns

Column name | Data type | Description
ItemRecordID | int | Primary key
OwningBranchID | int | The branch which owns the item
CreatorID | int | Polaris user who created the item record
ModifierID | int | Polaris user who last modified item record
CallNumberPrefix | nvarchar(60) | call number prefix of the item
ClassificationNumber | nvarchar(60) | Is used with the classification scheme to determine fine codes (???)
CutterNumber | nvarchar(60) | Cutter number of the item
CallNumberSuffix | nvarchar(60) | call number suffix of the item
CopyNumber | nvarchar(60) | Is the copy number of an item
VolumeNumber | nvarchar(60) | Is the volume number of an item
TemporaryShelfLocation | nvarchar(25) | In case the item is not returned immediately - placed in a separate spot somewhere
PublicNote | nvarchar(255) | Note not displayed to public - necessary actions needed to be taken on an item
NonPublicNote | nvarchar(255) | Is a text field for the user to enter descriptive information
CreationDate | datetime | Date that the item record was created
ModificationDate | datetime | The date when the record is updated - maps to tag 005
ImportedDate | datetime | The date when the record was entered into the system (import or original cataloging)
LastInventoryDate | datetime | The date when the item was last inventoried
Price | money | The price of a item associated with the bib record
ImportedBibControlNumber | nvarchar(50) | Free text link to bib control number (035)
ImportedRecordSource | nvarchar(50) | Taken from a bib 035 if applicable
PhysicalCondition | nvarchar(255) | Free text field
NameOfPiece | nvarchar(255) | Free text name field
FundingSource | nvarchar(50) | Free text field used by acquisitions
AcquisitionDate | datetime | The Item record creation date. Populated only if item is linked to Acquisitions.
ShelvingSchemeID | int | Link to shelving scheme table (coded values)
CallNumber | nvarchar(255) | Call number of the item
DonorID | int | link to the donors table (used for POLI and INLI donor info)
ImportEDIUpdateFlag | bit | A flag that is set when an item record is updated via import (related to EDI import processing)
CallNumberVolumeCopy | nvarchar(370) | The call number + volume + copy of an item in a single string value
SpecialItemCheckInNote | nvarchar(255) | Note submitted during check-in from the Special Item Check-in dialog.

See Also

ItemTemplates, MfhdIssues,


ItemRecordHistory

ItemRecordHistory Table

This table keeps a running history of item record changes/modifications.

Columns

Column name | Data type | Description
ItemRecordHistoryID | int | Primary key
ItemRecordID | int | Item record ID
TransactionDate | datetime | Transaction date
ActionTakenID | int | Key to actions taken table
OldItemStatusID | int | The previous item status
NewItemStatusID | int | The newly assigned item status
AssignedBranchID | int | Item assigned branch
InTransitRecvdBranchID | int | The in transit branch (if applicable)
PatronID | int | Patron record ID
OrganizationID | int | Organization entering the history
PolarisUserID | int | Polaris user ID
WorkstationID | int | Workstation ID


ItemRecordHistoryActions

ItemRecordHistoryActions Table

Coded list of possible actions that can be taken on an item record that are currently logged.

Columns

Column name | Data type | Description
ActionTakenID | int | Primary key
ActionTakenDesc | nvarchar(255) | Description

See Also

ItemRecordHistory, ItemRecordHistoryDaily,


ItemRecordHistoryDaily

ItemRecordHistoryDaily Table

This table keeps a running history of item record changes/modifications for a specific day (is cleared out each day by SQL job and moved to permanent history table)

Columns

Column name | Data type | Description
ItemRecordHistoryID | int | Primary key
ItemRecordID | int | Item Record ID
TransactionDate | datetime | Transaction date
ActionTakenID | int | Action taken
OldItemStatusID | int | Old Item Status
NewItemStatusID | int | New item status
AssignedBranchID | int | Assigned Branch of item
InTransitRecvdBranchID | int | In transit branch (if applicable)
PatronID | int | Patron ID
OrganizationID | int | Organization entering the history
PolarisUserID | int | Polaris User ID
WorkstationID | int | Workstation ID


ItemRecordNotifications

ItemRecordNotifications Table

This table has information about notifications sent to patrons with respect to items.

Columns

Column name | Data type | Description
ItemRecordID | int | ItemRecordID of the item for which notification was sent.
OVDNoticeDate1 | datetime | Date when the 1st overdue notice was sent.
OVDNoticeDate2 | datetime | Date when the 2nd overdue notice was sent.
OVDNoticeDate3 | datetime | Date when the 3rd overdue notice was sent.
BillingDate | datetime | Date when the billing notice was sent.
RecallDate | datetime | Date when the recall notice was sent.
ReminderDate | datetime | Date when the reminder notice was sent.
ReplCostTxnID | int | The Replacement charge TxnID associated with a billing/lost charge.
OVDChargeTxnID | int | The OVD charge TxnID associated with a billing/lost charge.
ProcChargeTxnID | int | The patron processing charge txn ID


ItemRecordSets

ItemRecordSets Table

Contains a list of which item records belong to which record sets.

Columns

Column name | Data type | Description
ItemRecordID | int | Link to item record
RecordSetID | int | Link to corresponding record set.


ItemRecordSystemBlockDescriptions

ItemRecordSystemBlockDescriptions Table

This table is the coded values table for item record system blocks

Columns

Column name | Data type | Description
SystemBlockID | int | primary key
BlockDescription | nvarchar(100) | the textual description

See Also

ItemRecordSystemBlocks,


ItemRecordSystemBlocks

ItemRecordSystemBlocks Table

Holds the item record and its associated system blocks. An item can have 0,1, or more system blocks.

Columns

Column name | Data type | Description
ItemRecordID | int | Foreign Key reference to the Item record. It references CircItemRecords table(ItemRecordID).
SystemBlockID | int | foreign key reference to item record system blocks descriptions table


ItemShelvingDate

ItemShelvingDate Table

This table is used to determine an "In" item's shelving status.

Columns

Column name | Data type | Description
ItemRecordID | int | Foreign Key reference to CircItemRecords
ProcessDay | tinyint | The enumerated day of the week (1-Sunday, 2-Monday, etc.) this entry was last processed to determine shelving status. A given entry in this table will be processed only once on a given processing day.
ShelvingDate | smalldatetime | The date/time the Item is expected to be on the shelf. If NULL it is not expected to be shelved in the current day.
CheckInDate | smalldatetime | The Date/Time the item was checked in. This will only have a value in this table when the item is to be shelved the same day the item was checked in.
Duration | int | The number of minutes remaining before the item is expected to be on the shelf starting from TOMORROW'S opening time for the branch.


ItemStatuses

ItemStatuses Table

Contains a list of item circulation statuses

Columns

Column name | Data type | Description
ItemStatusID | int | Is the circulation code for items (in, out, transit, withdrawn, etc.)
Description | nvarchar(80) | Text description of the status
Name | nvarchar(25) | Used in circ processing
BannerText | nvarchar(15) | The description text shown under the bookjacket or format icon in the web client

See Also

CircItemRecords, HoldsPickupStatusesExclude, InnReachFilterItemStatuses, ItemRecordHistory, ItemStatusMatrix, ItemTemplates, PACSuppressionRules, SA_ORS_ExcludedItemStatuses, SA_PAC_SuppressedCircStatuses, SA_SIPCheckOutItemAllowances,


ItemStatusMatrix

ItemStatusMatrix Table

This table will hold all of the item choices and all of the possible changes which can be made

Columns

Column name | Data type | Description
ItemStatusID | int | Link to item status table - what status we currently have
ItemStatusChoiceID | int | Link to item status table - what status we can set to


ItemTemplates

ItemTemplates Table

Contains item record templates for cataloging.

Columns

Column name | Data type | Description
ItemTemplateID | int | Primary key
Name | nvarchar(50) | name of template
AssociatedBibRecordID | int | Link to bib record
ParentItemRecordID | int | item record parent (if applicable)
ItemStatusID | int | Link to item status table (circulation statuses)
OrganizationOwnerID | int | Organization who owns template (could be user also)
SystemWideOwnerID | int | branch who owns item
AssignedBranchID | int | Branch was currently has item possession.
AssignedCollectionID | int | Collection to which item belongs (if applicable)
CreatorID | int | Polaris user who created item
ModifierID | int | Polaris user who last modified template
CreationDate | datetime | Date that the item was created
ModificationDate | datetime | The date when the record is updated - maps to tag 005
DisplayInPAC | bit | Whether or not the record can display in PAC (will be indexed regardless)
CallNumberPrefix | nvarchar(60) | Call number prefix of item
ClassificationNumber | nvarchar(60) | Is used with the classification scheme to determine fine codes (???)
CutterNumber | nvarchar(60) | Cutter number of the item
CallNumberSuffix | nvarchar(60) | Call number suffix of item
CopyNumber | nvarchar(60) | Is the copy number of an item
VolumeNumber | nvarchar(60) | Is the volume number of an item
ShelfLocationID | int | link to Shelf locations table (coded values)
TemporaryShelfLocation | nvarchar(25) | In case the item is not returned immediately - placed in a separate spot somewhere
MaterialTypeID | int | link to material type table
PublicNote | nvarchar(255) | Note not displayed to public - necessary actions needed to be taken on an item
NonPublicNote | nvarchar(255) | Is a text field for the user to enter descriptive information
Price | money | The price of a item associated with the item record
LoanableOutsideSystem | bit | Can this item be loaned to other libraries in the system?
NonCirculating | bit | Can this item be loaned to other branches or collections within the library?
RenewalLimit | int | The number of times any particular patron is allowed to renew an item
Holdable | bit | Can the item be held for patrons?
LoanPeriodCodeID | int | Link to loan period codes table
FineCodeID | int | Coded value for applicable fine
StatisticalCodeID | int | Link to StatisticalCodes table
ShelvingSchemeID | int | Link to Shelving Schemes table
PhysicalCondition | nvarchar(255) | free text cataloging field
NameOfPiece | nvarchar(255) | free text field for cataloging
FreeTextBlock | nvarchar(255) | Why is the item blocked for loaning?
FundingSource | nvarchar(50) | Free text field used by acquisitions.
ManualBlockID | int | link to manual blocks table
HoldableByPickup | bit | holdable only for pickup
HoldableByLibrary | bit | holdable at the library level
HoldableByBranch | bit | holdable at the branch level
ReserveAssignedBranchID | int | for course reserves, the reserve assigned branch ID
ReserveAssignedCollectionID | int | for course reserves, the reserve assigned collection ID
ReserveShelfLocationID | int | for course reserves, the reserve shelf location ID
ReserveLoanPeriodCodeID | int | for course reserves, the reserve loan period code ID
ReserveFineCodeID | int | for course reserves, the reserve fine code ID
ReserveRenewalLimit | int | for course reserves, the reserve renewal limit
ReserveHoldable | int | for course reserves, the reserve holdable flag
CopyrightFeeRequired | bit | Y/N for fee required
CopyrightCompliance | tinyint | for course reserves, the CCG or CCL value
CopyrightFee | money | a monetary value representing the fee
CopyrightFeePaid | bit | Y/N for fee paid
LimitedToLibUse | bit | for course reserves, a Y/N which spawns a message at checkout
LibraryCopy | bit | for course reserves, if the item is owned by the library or instructor
DeleteWhenDone | bit | is the auto-delete flag
ActionWhenDone | tinyint | for course reserves, when you are done what action to take.
RequiresFullCataloging | bit | for course reserves, a Y/N flag
Purchase | bit | for course reserves, a Y/N flag
YTDCircCount | int | for course reserves, the number of times the item has circulated for a course
ReserveStatus | tinyint | for course reserves, the status of the reserve item (on reserve, not reserved, permanent reserve)
StartDate | datetime | for course reserves, the start date for when the item is on the course reserve.
EndDate | datetime | for course reserves, the end date for when the item is on the course reserve.
Note | nvarchar(255) | note associated with course reserve
IsReserveTemplate | bit | flag to say if the item is a reserve template or not.
HoldableByPrimaryLender | bit | This is a restriction option. If this is set, then it implies that this item will be used for fulfilling a hold request only if the item's assigned branch's preferred lender list contains the pickup branch in the request.
ItemDoesNotFloat | bit | Do not float flag
HomeBranchID | int | Item home branch ID
DonorID | int | Link to Donors table
DoNotMailToPatron | bit | Flag to not mail an item to a patron for BBM holds processing
HoldPickupBranchID | int | holdable for pickup only at this branch
DelayedHoldsFlag | bit | Flag to signify if there is a Delayed Hold value for this item
DelayedNumberOfDays | int | Number of days to delay filling holds for patrons not belonging to the item's assigned branch past the first available date

See Also

ImportJobs, ImportProfiles,


Job_POLineItemSegmentHistory

Job_POLineItemSegmentHistory Table

This table contains historical information for Purchase Order Line Item Segments created as part of the Polaris.Jobs service processing.

Columns

Column name | Data type | Description
POLineItemSegmentHistoryID | int | Unique identifier for the table row
POLineItemHistoryID | int | Foreign key reference to the Job_POLinesHistory table
POLineItemSegmentID | int | Unique identifier for the segment created
EDIPOLISegNum | nvarchar(10) | EDI segment number
Location | nvarchar(50) | Organization abbreviation
Fund | nvarchar(50) | Fund alternative name
Collection | nvarchar(80) | Collection abbreviation for the segment
Callnumber | nvarchar(255) | Call number for the segment
Copies | int | Number of copies
POLISegmentNumber | int | Purchase order line item segment number


Job_POLinesHistory

Job_POLinesHistory Table

This table contains historical information for Purchase Order Line Items created as part of the Polaris.Jobs service processing.

Columns

Column name | Data type | Description
POLineItemHistoryID | int | Unique identifier for the table row
PurchaseOrderHistoryID | int | Foreign key reference to the Job_PurchaseOrderHistory table
POLineItemID | int | Unique identifier for the line item created
ExternalLineItemID | nvarchar(50) | Unique identifier provided by the third party
MARCData | nvarchar(-1) | Raw marc data provided by the third party
BibliographicRecordID | int | Unique identifier for the bibliographic record created
LineNumber | int | Line number

See Also

Job_POLineItemSegmentHistory,


Job_PurchaseOrderHistory

Job_PurchaseOrderHistory Table

This table contains historical information for Purchase Orders created as part of the Polaris.Jobs service processing.

Columns

Column name | Data type | Description
PurchaseOrderHistoryID | int | Unique identifier for the table row
JobID | int | Foreign key reference to the Job_PurchaseOrders table
PurchaseOrderID | int | Unique identifier for the purchase order created
PONumber | nvarchar(30) | Purchase Order number
ExternalID | nvarchar(50) | Unique identifier provided by the third party

See Also

Job_POLinesHistory,


Job_PurchaseOrders

Job_PurchaseOrders Table

This table contains details for jobs initiated through the Polaris.Jobs service.

Columns

Column name | Data type | Description
JobID | int | Unique identifier for the table row
PAPIJobID | uniqueidentifier | Unique identifier used to pull information about the job
HangfireJobID | int | Unique identifier for the job within Hangfire
ExternalJobID | nvarchar(50) | Unique identifier provided by the third party
PolarisUserID | int | User account used to create the job
CreationDate | datetime | Date job was created
LastExecutionDate | datetime | Last execution date of the job
CompletionDate | datetime | Date job processing completed
Message | nvarchar(1000) | Message
Data | varbinary | Binary representation of the data provided by the third party
JobStatusID | int | Hangfire processing status of the job. References the Job_Statuses table
TaskResultID | int | Final result of the job. References the TaskResults table

See Also

Job_PurchaseOrderHistory, Job_PurchaseOrders_ErrorLog,


Job_PurchaseOrders_ErrorLog

Job_PurchaseOrders_ErrorLog Table

This table contains error messages received during Polaris.Jobs service processing

Columns

Column name | Data type | Description
JobID | int | Unique identifier for the jobs. References the Job_PurchaseOrders table
ExternalID | nvarchar(50) | Unique identifier provided by the third party
ErrorMessage | nvarchar(4000) | Error message


Job_Statuses

Job_Statuses Table

This table stores the processing statuses returned from the Polaris.Jobs service

Columns

Column name | Data type | Description
JobStatusID | int | Unique identifier for the status
Description | nvarchar(80) | Description of the status

See Also

Job_PurchaseOrders,


KeywordAlternatives

KeywordAlternatives Table

Contains one row for each term associated with 1 or more alternative terms 1623985209

Columns

Column name | Data type | Description
ReferenceID | int | Identifies the base term.
Term | nvarchar(128) | Normalized base term.
AlternativeTuple | varbinary | A tuple of alternative reference identifiers.


kwmssg

kwmssg Table

This table is used as a log of events that occurred on a database. Various scripts and stored procedures write to this table.

Columns

Column name | Data type | Description
dt | datetime | The date/time that the log message was posted.
mssg | nvarchar(1000) | The message being logged.


LabelConfigDefs

LabelConfigDefs Table

This table stores label page configuration data and ownership information per label type and owner. The page definition can be configured from SA Staff Client Profile or Label Manager. All sizes should be measured in 1/100 inches.

Columns

Column name | Data type | Description
CtxID | int | Context ID which is referenced by AttrID(1769) to indicate label configuration context per owner.
LabelTypeID | int | ID of label type. References to LabelTypes(LabelTypeID).
DomainID | int | ID of owner's domain.
OwnerID | int | Owner ID references to Organizations(OrganizationID) or Workstations(WorkstationID).
Enabled | bit | Bit value to indicate whether or not the label type is enabled by its owner.
PageWidth | smallint | Label page width.
PageHeight | smallint | Label page height.
PageTopMargin | smallint | Label page top margin.
PageLeftMargin | smallint | Label page left margin.
TextAlignment | nvarchar(20) | Text alignment of all labels on the page.


LabelConfigFontDefs

LabelConfigFontDefs Table

This table stores label size and font configuration data per label, label type and owner. For example, if label type is a 2-label set, there will be two entries per label type and owner, one for each label in the set. All sizes and gaps should be measured in 1/100 inches.

Columns

Column name | Data type | Description
CtxID | int | Context ID references to LabelConfigDefs(CtxID).
LabelTypeID | int | Label type ID references to LabelTypes(LabelTypeID).
LabelSequence | tinyint | Label appearance sequence in a set.
ContentTypeID | int | Label content type ID to indicate what content data is linked to the label. References to LabelContenTypes(ContentTypeID).
LabelWidth | smallint | Label width.
LabelHeight | smallint | Label height.
LabelIndent | smallint | Text left indent on a label.
FontName | nvarchar(255) | Label font name.
FontSize | float | Label font size.
FontColor | nvarchar(16) | Label font color constructed as a string to indicate a RGB color value.
IsBold | bit | Font is bold or not.
IsItalic | bit | Font is italic or not.
IsStrikeThrough | bit | Font has strike though effection or not.
IsUnderLine | bit | Font has under line effection or not.
VerticalGap | smallint | Gap between label and the label below it on the page.
HorizontalGap | smallint | Gap between label and the label next to it on the page.


LabelContentOptionDefs

LabelContentOptionDefs Table

This table stores label content type definitions and ownership info per label content type and owner.

Columns

Column name | Data type | Description
CtxID | int | Context ID which is referenced by AttrID(1302) to indicate label content context per owner.
OwnerID | int | Owner ID references to Organizations(OrganizationID) or Workstations(WorkstationID).
DomainID | int | ID of owner's domain.
ContentTypeID | int | ID of content type references to LabelContentTypes(ContentTypeID).
ContentID | int | ID of content option references to LabelContentOptions(ContentID).
ContentSection | tinyint | Indicates to which section the content option belongs. There are totally 3 sections.
ContentSequence | tinyint | Indicates content option's appearance sequences in a section.


LabelContentOptions

LabelContentOptions Table

This is a system defined table to store all options that are avialable to define a label content type.

Columns

Column name | Data type | Description
ContentID | int | Content ID, primary key.
ContentDescription | nvarchar(255) | Label content description.

See Also

LabelContentOptionDefs,


LabelContentTypes

LabelContentTypes Table

This table stores label content types. The entries with a positive ContentTypeID are system defined content types; the ones with a negative ContentTypeID are user created.

Columns

Column name | Data type | Description
ContentTypeID | int | Content type ID, primary key. 1 is spine, 2 is pocket and 3 is serial.
ContentTypeName | nvarchar(50) | Content type name.

See Also

LabelConfigFontDefs, LabelContentOptionDefs,


LabelDefaultOptions

LabelDefaultOptions Table

This is a system defined table to store Polaris TechClient subsystem options. These options are used to indicate which subsystem's label type is taken by Label Manager when it's fired from Utilities->Label Manager.

Columns

Column name | Data type | Description
OptionID | int | Option ID, primary key.
OptionDesc | nvarchar(50) | Description of option.


LabelPrimeMarkOptions

LabelPrimeMarkOptions Table

This table stores the numeric and literal definitions for label prime mark option parameters.

Columns

Column name | Data type | Description
PrimeMarkOptionID | int | numeric definition.
Description | nvarchar(80) | literal definition.


LabelPrinters

LabelPrinters Table

This table stores default printer info per workstation and label type. When label is printed, system will look up and use the default printer defined for the label type on the workstation first. If no default printer is found, the system default printer will be used to print.

Columns

Column name | Data type | Description
WorkstationID | int | Workstation ID references to Workstations(WorkstationID).
LabelTypeID | int | Label type ID refereneces to LabelTypes(LabelTypeID).
PrinterName | nvarchar(511) | Printer's display name.


LabelPrintOptions

LabelPrintOptions Table

This table stored the numeric and literal definitions of label printing method option parameters.

Columns

Column name | Data type | Description
PrintOptionID | int | numeric definition.
Description | nvarchar(80) | literal definition.


LabelTypes

LabelTypes Table

This table stores all label types defined by system or created by users. All label types with a positive LabelTypeID are system defined; the ones with a negative LabelTypeID are created by users.

Columns

Column name | Data type | Description
LabelTypeID | int | Label type ID, primary key.
DisplayName | nvarchar(80) | Label type's display name.
DomainID | int | Owner's domain ID references to Domains(DomainID).
OwnerID | int | ID of owner who creates the label type. references to Organizations(OrganizationID).

See Also

LabelConfigDefs, LabelConfigFontDefs, LabelPrinters,


Languages

Languages Table

This table contains a list of languages as coded values.

Columns

Column name | Data type | Description
LanguageID | smallint | Primary key
LanguageDesc | nvarchar(25) | Text description of language.
NcipValue | nvarchar(3) | 3 character code used for ncip messages
AdminLanguageID | int | The language ID stored in this column is the MS LanguageID which is 1033 for English, 3082 for Spanish, 3084 for French, etc..

See Also

PatronRegistration,


LexileGroups

LexileGroups Table

Contains one row for each lexile grouping

Columns

Column name | Data type | Description
GroupID | int | Unique identifier
Description | nvarchar(255) | Description for the Lexile Group

See Also

LexileLevels,


LexileLevels

LexileLevels Table

Contains one row for each level within a lexile group

Columns

Column name | Data type | Description
Level | int | Group level
GroupID | int | Foreign key to LexileGroups.GroupID


LibraryTypes

LibraryTypes Table

Static data that is used to define the type of library an organization is.

Columns

Column name | Data type | Description
LibraryTypeID | int | Primary key
Description | nvarchar(32) | 0 Public 1 Academic 2 Military 3 School 4 Corporate


LineItemPaymentStatusHistories

LineItemPaymentStatusHistories Table

This is a secondary table used by the purchase order line item and invoice line item objects. The line item payment status history is used mainly for reports. It tracks the payment status of PO and Invoice line items in the system.

Columns

Column name | Data type | Description
POLineItemID | int | Polaris assigned unique ID number for a purchase order line item record.
PaymentStatusID | int | Integer value used to link a Payment Status with a purchase order line item and/or invoice line item. Payment status descriptions are found on the PaymentStatus table.
InvLineItemID | int | Polaris assigned unique ID number for an invoice line item record.
PaymentStatusDate | datetime | System supplied date & time the PaymentStatusID was set.


LineItemSegmentPaymentStatusHistories

LineItemSegmentPaymentStatusHistories Table

This is a secondary table used by the purchase order line item segment and invoice line item segment objects. LineItemSegmentPaymentStatusHistories is used mainly for reports. It records the payment status of PO and Invoice line item segments in the system.

Columns

Column name | Data type | Description
POLineItemSegmentID | int | Polaris assigned unique ID number for a purchase order line item segment record.
PaymentStatusID | int | Integer value used to link a Payment Status with a purchase order segment and/or invoice segment. Payment status descriptions are found on the PaymentStatus table.
InvLineItemSegmentID | int | Polaris assigned unique ID number for an invoice line item segment record.
PaymentStatusDate | datetime | System supplied date & time the PaymentStatusID was set.


LineItemSegmentToItemRecord

LineItemSegmentToItemRecord Table

This table tracks the linkage of a PO line item segment with an item record. It also links an Invoice line item segment with an item record.

Columns

Column name | Data type | Description
POLineItemSegmentID | int | ID number of the PO line item segment linked to this record.
InvLineItemSegmentID | int | ID number of the Invoice line item segment linked to this record.
ItemRecordID | int | Polaris assigned unique ID number for an item record.


LineItemStatus

LineItemStatus Table

This is a secondary table used used by the Purchase Order Line Item Status History record.Line Item statuses are used to inform users of Polaris the current status of a purchase order line item record.

Columns

Column name | Data type | Description
StatusID | int | Integer value used to link a Line Item Status with an entry in the POLinesStatusHistories table. Must be unique to this table.
Status | nvarchar(21) | The status of a purchase order line item. Its pre-defined values are:backordered, canceled, claim pending, claimed, completed,confirmed, currently received, exceptional condition, never published, on order, out of print, pending,received, rejected, return requested, returned, under consideration.

See Also

POLineItemSegments, POLineItemSegmentStatusHistories, POLines, POLinesStatusHistories,


LinkedInvoices

LinkedInvoices Table

This table maintains the link to between one or more invoices.

Columns

Column name | Data type | Description
MainID | int | The InvoiceID of the record linked FROM to one or more invoices
LinkedID | int | The InvoiceID of the record linked TO from another invoice.


ListingDetails

ListingDetails Table

Dashboard detail content.

Columns

Column name | Data type | Description
ListingID | int | Foreign Key reference to ListingHeaders. (ListingID, ListingSubtypeID comprise the Primary Key for this table)
ListingSubTypeID | int | Foreign Key reference to ListingSubType. (ListingID, ListingSubTypeID comprise the Primary Key for this table)
Value | nvarchar(255) | Dashboard data content. Either the actual text to display on the dashboard or a link for use in dashboard display.


ListingHeaders

ListingHeaders Table

This table groups all the listingtypeIDs, and based on displayorder, they get rendered in that order.

Columns

Column name | Data type | Description
ListingID | int | Primary Key unique identifier.
ListingTypeID | int | Foreign Key reference to the ListingTypes table.
DisplayOrder | int | Sequential display order for the details on the dashboard.

See Also

ListingDetails,


ListingSubTypes

ListingSubTypes Table

Qualifies the data content in ListingDetails

Columns

Column name | Data type | Description
ListingSubTypeID | int | Primary Key unique identifier.
ListingSubTypeDescription | nvarchar(50) | Description of the subtype. i.e. Title, URL, Author.

See Also

ListingDetails,


ListingTypes

ListingTypes Table

This table defines the various Dashboards in the Polaris PowerPAC.

Columns

Column name | Data type | Description
ListingTypeID | int | Primary Key Unique Identifier.
ListingDescription | nvarchar(50) | This is the dashboard title.

See Also

ListingHeaders, WebParts,


LiteraryForms

LiteraryForms Table

Contains one row for each literary form.

Columns

Column name | Data type | Description
Code | char | Unique code .
Description | nvarchar(30) | Description of the literary form.


LJLookupValues

LJLookupValues Table

This table provides the lookup values that is displayed in SA for the valid values 0 through 2.

Columns

Column name | Data type | Description
LJID | int | Unique ID's of LJ Lookup Values in which the description is supplied in SA.
Description | nvarchar(50) | Description of the LJ Lookup ID. (LJID)


LJ_Fiction

LJ_Fiction Table

Library Journal "most popular" list for fiction.

Columns

Column name | Data type | Description
MARCLCCN | nvarchar(40) | The LCCN of this title.
Circs | int | Total circulations for this title in the past 60 days.
Holds | int | Total Holds placed on this title in the past 60 days.
Popularity | int | Popularity is defined as the sum of total circs and total holds in the past 60 days.
BrowseTitle | nvarchar(255) | Title.
BrowseAuthor | nvarchar(255) | Author.
LiteraryForm | char | The Literary Form of this title. This value must be "1" or "f" to be in this table for Fiction.


LJ_MostPopularTitles

LJ_MostPopularTitles Table

Table used to build the Library Journal Most Popular list. This is populated by the SQLServerAgent job "MostPopularList".

Columns

Column name | Data type | Description
BibliographicRecordID | int | Reference to the Bibliographic Record for this title.
Circs | int | Total circulations for this title in the past 60 days.
Holds | int | Total Holds placed on this title in the past 60 days.
MARCLCCN | nvarchar(40) | The LCCN of this title.
BrowseAuthor | nvarchar(255) | Author.
BrowseTitle | nvarchar(255) | Title.


LJ_NonFiction

LJ_NonFiction Table

Library Journal "most popular" list for non-fiction.

Columns

Column name | Data type | Description
MARCLCCN | nvarchar(40) | The LCCN of this title.
Circs | int | Total circulations for this title in the past 60 days.
Holds | int | Total Holds placed on this title in the past 60 days.
Popularity | int | Popularity is defined as the sum of total circs and total holds in the past 60 days.
BrowseTitle | nvarchar(255) | Title.
BrowseAuthor | nvarchar(255) | Author
LiteraryForm | char | The Literary Form of this title. This value must be "0" to be in this table for Non-Fiction.


LoanLimitMatrices

LoanLimitMatrices Table

FOR FUTURE USE

Columns

Column name | Data type | Description
LoanLimitMatrixID | int | Primary key
Description | nvarchar(80) | text description

See Also

LoanLimits,


LoanLimits

LoanLimits Table

FOR FUTURE USE

Columns

Column name | Data type | Description
LoanLimitID | int | Primary key
LoanLimitMatrixID | int | Link to Loan Limit Matrix table
MaterialTypeID | int | Link to Material types table
PatronCodeID | int | Link to Patron Code table
NumberOfItems | int | Number of items which can be loaned


LoanPeriodCodes

LoanPeriodCodes Table

This table stores loan period codes and descriptions for each organization.

Columns

Column name | Data type | Description
LoanPeriodCodeID | int | ID of the loan period code, combined primary key.
Description | nvarchar(80) | is the description of the loan period.

See Also

CircItemRecords, ItemTemplates, LoanPeriods, ReserveItemRecords,


LoanPeriods

LoanPeriods Table

This table stores the matrix of loan period for each organization based on different patron codes and loan period codes, for calculating due date or time at circulation.

Columns

Column name | Data type | Description
LPID | int | The sole purpose of this ID is to hold a unique identifier (Primary Key) for each entry in the table. This will be an IDENTITY property in the Replication Publishing Database.
OrganizationID | int | ID of organization. It references LoanPeriodCodes table(OrganizationID) and Organizations table (OrganizationID).
PatronCodeID | int | ID of patron code. It references PatronCodes table (PatronCodeID).
LoanPeriodCodeID | int | ID of loan period code. It references LoanPeriodCodes table (LoanPeriodCodeID).
TimeUnit | tinyint | ID of time unit that stands for days, hours or minutes. It references TimeUnits table (TimeUnitID).
Units | int | Number of basic loan unit. It makes meaningful only when combined with the time unit.


MailingLabelRecordSets

MailingLabelRecordSets Table

This table is used to store a Polaris user's mailing label record set for use with the Mailing Label manager workform. If data is stored here, it is persistent until the Polaris user decides to delete it.

Columns

Column name | Data type | Description
PolarisUserID | int | References PolarisUsers table. Represents the Polaris User for which the record set is saved for.
PatronID | int | References Patrons table. Represents the Patron for which the AddressID belongs to. This Patron's name will be printed on the mailing label.
AddressID | int | References Addresses table. Represents the Address of the Patron used to create the mailing label.
Count | int | Number of labels to print.


MainAuthorHeadings

MainAuthorHeadings Table

Contains one row for each unique normalized author heading.

Columns

Column name | Data type | Description
MainAuthorHeadingID | int | Unique identifier for the row.
Author | nvarchar(255) | Normalized author heading suitable for searching and sorting puporses. This column is unique for each row.
BrowseAuthor | nvarchar(255) | Unnormalized author heading suitable for display purposes.
StaffCount | int | Real-time count of distinct bibliographic records associated with the Author column that can be displayed in the staff client.
PACCount | int | Real-time count of distinct bibliographic records associated with the Author column that can be displayed in the PAC.

See Also

Author4XX, Author5XX, BibAuthorIndices,


MainCallNumberEntries

MainCallNumberEntries Table

Contains one row for each unique best bibliographic call number at the system level (AssignedBranchID = 1), and one row for each unique best item-level call number at the branch level (AssignedBranchID != 1).

Columns

Column name | Data type | Description
MainCallNumberEntryID | int | Unique identifier for the row.
AssignedBranchID | int | Identifier of the branch for which the NormalCallNumber column is associated with. When the AssignedBranchID = 1, the NormalCallNumber column contains a primary bibliographic call number. When the AssignedBranchID != 1, the NormalCallNumber column contains an item-level call number.
NormalCallNumber | nvarchar(255) | Normalized call number suitable for sorting puporses. The combination of AssignedBranchID and NormalCallNumber is unique for each row.
CanonicalCallNumber | nvarchar(255) | Canonicalized call number suitable for searching puporses. The combination of AssignedBranchID and CanonicalCallNumber is unique for each row.
BrowseCallNumber | nvarchar(255) | Unnormalized call number suitable for display purposes.
StaffCount | int | Real-time count of distinct bibliographic records associated with the AssignedBranchID and NormalCallNumber columns that can be displayed in the staff client.
PACCount | int | Real-time count of distinct bibliographic records associated with the AssignedBranchID and NormalCallNumber columns that can be displayed in the PAC.

See Also

BibCallNumberIndices,


MainSeriesEntries

MainSeriesEntries Table

Contains one row for each unique normalized series entry.

Columns

Column name | Data type | Description
MainSeriesEntryID | int | Unique identifier for the row.
Series | nvarchar(255) | Normalized series entry suitable for searching and sorting puporses. This column is unique for each row.
BrowseSeries | nvarchar(255) | Unnormalized series entry suitable for display purposes.
StaffCount | int | Real-time count of distinct bibliographic records associated with the Series column that can be displayed in the staff client.
PACCount | int | Real-time count of distinct bibliographic records associated with the Series column that can be displayed in the PAC.

See Also

BibSeriesIndices, Series4XX, Series5XX,


MainSubjectHeadingGroups

MainSubjectHeadingGroups Table

Contains one row for each distinct subject heading group/division.

Columns

Column name | Data type | Description
MainSubjectHeadingGroupID | int | Unique identifier of the subject heading group.
MainSubjectHeadingID | int | Unique identifier of the subject heading.


MainSubjectHeadings

MainSubjectHeadings Table

Contains one row for each unique normalized subject heading.

Columns

Column name | Data type | Description
MainSubjectHeadingID | int | Unique identifier for the row.
Subject | nvarchar(255) | Normalized subject heading suitable for searching and sorting puporses. This column is unique for each row.
BrowseSubject | nvarchar(255) | Unnormalized subject heading suitable for display purposes.
StaffCount | int | Real-time count of distinct bibliographic records associated with the Subject column that can be displayed in the staff client.
PACCount | int | Real-time count of distinct bibliographic records associated with the Subject column that can be displayed in the PAC.

See Also

BibSubjectIndices, Subject4XX, Subject5XX,


MainTitleEntries

MainTitleEntries Table

Contains one row for each unique normalized title entry.

Columns

Column name | Data type | Description
MainTitleEntryID | int | Unique identifier for the row.
NormalTitle | nvarchar(255) | Normalized title entry suitable for searching and sorting puporses. This column is unique for each row.
BrowseTitle | nvarchar(255) | Unnormalized title entry suitable for display purposes.
StaffCount | int | Real-time count of distinct bibliographic records associated with the NormalTitle column that can be displayed in the staff client.
PACCount | int | Real-time count of distinct bibliographic records associated with the NormalTitle column that can be displayed in the PAC.

See Also

BibTitleIndices,


Map_MediumType_TOM

Map_MediumType_TOM Table

For internal use only. This table is used to map MediumType in an ILL Request to a Primary TOM for format display. It has been embellished with additional TOMs in order to facilitate mapping from TOM to MediumType for future use.

Columns

Column name | Data type | Description
MediumType | int | ISO standard value which denotes the medium of the item.
MARCTypeOfMaterialID | int | MARC type of Material value. Foreign key reference to MARCTypeOfMaterial table.
DefaultTOM | bit | When mapping MediumType to TOM; the row with this value set to 1 contains the default Primary TOM for the MediumType.


MARC007TagLengths

MARC007TagLengths Table

Holds the lengths of the 007 tags

Columns

Column name | Data type | Description
MARCFixedFieldTagTypeID | int | What type of 007 tag this is
TagLength | int | Length of tag


MARC21ExportBranches

MARC21ExportBranches Table

This is a "temporary" table used during MARC data export. It contains information for filtering (by Branch and Record Status) of Holdings information that is included in the exported MARC record.

Columns

Column name | Data type | Description
BranchID | int | The OrganizationID of the branch to be exported.
RecordStatusID | int | The RecordStatusID to filter for export.


MARCAbbreviatedTitleCodes

MARCAbbreviatedTitleCodes Table

Code list according to MARC format web site. Contains values for Abbreviated Title Source Codes.

Columns

Column name | Data type | Description
AbbreviatedTitle | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCAccessRestrictionSourceCodes

MARCAccessRestrictionSourceCodes Table

Code list according to MARC format web site. Contains values for Access Restriction Term Source Codes.

Columns

Column name | Data type | Description
AccessRestrictionSource | nvarchar(255) | Access Restriction Source
Code | nchar | Code
BibCitationNote | nvarchar(255) | citation
ObsoleteFlag | bit | Obsolete?
LocallyDefinedFlag | bit | Is this local?
ModifiedFlag | bit | Modified?
UserNotes | nvarchar(255) | Any user notes


MARCActionsNoteCodes

MARCActionsNoteCodes Table

Code list according to MARC format web site. Contains values for Resource Action Term Source Codes.

Columns

Column name | Data type | Description
ActionsNote | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCAuthenticationCodes

MARCAuthenticationCodes Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
AuthenticationCode | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(800) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCAuthorityControlErrorCodes

MARCAuthorityControlErrorCodes Table

A table which states all of the possible errors that can be returned by the authority control process. Written in the scope of bib checking, but same list has relevance during see also processing as well.

Columns

Column name | Data type | Description
MARCAuthorityControlErrorCodeID | int | error code ID
MARCAuthorityControlErrorCodeDesc | nvarchar(255) | error description


MARCAvailabilityStatusCodes

MARCAvailabilityStatusCodes Table

MARC Code table for availability status codes. Contains values for Availability Status Code Source Codes.

Columns

Column name | Data type | Description
AvailabilityStatusSource | nvarchar(255) | The source description
Code | nchar | Code
BibCitationNote | nvarchar(255) | bib citation note
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | locally defined?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes


MARCCarrierCodesSources

MARCCarrierCodesSources Table

MARC Carrier Codes Sources

Columns

Column name | Data type | Description
CarrierCode | nvarchar(255) | The carrier code source description
Code | nchar | The code
BibCitationNote | nvarchar(255) | bib citation note
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | local?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes


MARCCartographicMathematicalSources

MARCCartographicMathematicalSources Table

Code list according to MARC format web site. Contains values for Cartographic Data source Codes.

Columns

Column name | Data type | Description
CartographicMathematicalSource | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCCatSourceDescConvCodes

MARCCatSourceDescConvCodes Table

Code list according to MARC format web site. Contains values for Description Convention Source Codes.

Columns

Column name | Data type | Description
CatSourceDescConv | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCCatSourceTermsCodes

MARCCatSourceTermsCodes Table

Code list according to MARC format web site. Contains values for Genre/Form Code and Term Source Codes, Subject Heading and Term Source Codes, and Musical Instrumentation and Voice Code Source Codes.

Columns

Column name | Data type | Description
CatSourceTerm | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCClassNumbersCanadaCodes

MARCClassNumbersCanadaCodes Table

Code list according to MARC format web site. Contains values for Classification Scheme Source Codes.

Columns

Column name | Data type | Description
ClassNumberCanada | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCCodeTableMap

MARCCodeTableMap Table

Listing of code tables used by validation

Columns

Column name | Data type | Description
MARCCodeTableID | int | primary key
MARCCodeTable | nvarchar(255) | The code table description
MARCCodeTableDisplay | nvarchar(255) | the string used for display in tech client
Obsolete | bit | Identifies mappings that are no longer used

See Also

MARCFixedFieldDefinitions,


MARCConcatenationPredicates

MARCConcatenationPredicates Table

Contains one row for each concatenation predicate within the scope of a concatenation rule.

Columns

Column name | Data type | Description
ConcatenationPredicateID | int | Unique identifier of the concatenation predicate.
ConcatenationRuleID | int | Unique identifier of the concatenation rule.
TagRangeSetID | int | Unique identifier of the tag range set that applies to the concatenation predicate.
SubfieldCodeRangeSetID | int | Unique identifier of the subfield code range set that applies to the concatenation predicate.


MARCConcatenationRules

MARCConcatenationRules Table

Contains one row for each concatenation rule within the scope a domain.

Columns

Column name | Data type | Description
ConcatenationRuleID | int | Unique identifier of the concatenation rule.
DomainID | smallint | Unique identifier of the domain.
Separator | nvarchar(128) | String used to separate two text fragments concatenated together.
Flags | int | Bitwise flags that control how the concatenation rule will be applied at runtime. This field can contain one or more of the following: COALESCESEPARATOR (0x01), PRESERVELEADINGWHITESPACE (0x02), PRESERVETRAILINGWHITESPACE (0x04), PRESERVEDANGLINGPUNCTUATION (0x08).

See Also

MARCConcatenationPredicates,


MARCConditionalProhibited

MARCConditionalProhibited Table

Holds rules for conditionally prohibited fields used by validation

Columns

Column name | Data type | Description
MARCTagDefinitionID | int | key to the MARC tag (format independent)
Subfield | char | the subfield limiting value (can be null)
IndicatorOne | char | value of indicator one (can be null as well)
IndicatorTwo | char | value of indicator two (can be null as well)
ProhibitedTagNumber | int | tag which is prohibited
ProhibitedSubfield | char | subfield which is prohibited


MARCConditionalRequired

MARCConditionalRequired Table

Holds rules for conditionally required fields used by validation

Columns

Column name | Data type | Description
MARCTagDefinitionID | int | key to the MARC tag (format independent)
Subfield | char | the subfield limiting value (can be null)
IndicatorOne | char | value of indicator one (can be null as well)
IndicatorTwo | char | value of indicator two (can be null as well)
RequiredTagNumber | int | tag which is required
RequiredSubfield | char | subfield which is required


MARCContentAdviceClassificationCodes

MARCContentAdviceClassificationCodes Table

MARC Content Advice Classification codes. Contains values for Content Advice Classification Source Codes.

Columns

Column name | Data type | Description
ContentAdviceSource | nvarchar(255) | The content advice source description
Code | nchar | The code
BibCitationNote | nvarchar(255) | bib citation note
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | local?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes


MARCContentCodesSources

MARCContentCodesSources Table

MARC Content codes sources

Columns

Column name | Data type | Description
ContentCode | nvarchar(255) | The content code source description
Code | nchar | The code
BibCitationNote | nvarchar(255) | bib citation note
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | local?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes


MARCControlFieldMaterializationPredicates

MARCControlFieldMaterializationPredicates Table

Contains one row for each materialization predicate within the scope of a materialization rule.

Columns

Column name | Data type | Description
ControlFieldMaterializationPredicateID | int | Unique identifier of the control field materialization predicate.
MaterializationRuleID | int | Unique identifier of the materialization rule.
Tag | smallint | Identifier of the tag of the control field predicate. The tag must be between 1 and 9.
StartPosition | smallint | Zero-based starting position of the text to be extracted. If this value is NULL then the starting position equals 0.
EndPosition | smallint | Zero-based ending character position of the text to be extracted. If this value is NULL then ending position is the length of the control field.


MARCCopyLegalDepositNumCodes

MARCCopyLegalDepositNumCodes Table

Code list according to MARC format web site. Contains values for Copyright and Legal Deposit Number Source Codes.

Columns

Column name | Data type | Description
CopyLegalDepositNumber | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCCountryCodes

MARCCountryCodes Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
MARCCountryCodeID | int | primary key
Country | nvarchar(255) | The description of the country
Code | nchar | The code of the country
ObsoleteFlag | bit | Is this country code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes

See Also

MARCCountryCodesUseFor,


MARCCountryCodesUseFor

MARCCountryCodesUseFor Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
MARCCountryCodeUseForID | int | primary key
CountryUseFor | nvarchar(255) | The description of the country
MARCCountryCodeID | int | FK to the main country codes table
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCCountryTermSourceCodes

MARCCountryTermSourceCodes Table

Code list according to MARC format web site. Contains values for Country Code and Term Source Codes.

Columns

Column name | Data type | Description
CountryTermSource | nvarchar(255) | Country Term Source
Code | nchar | Code
BibCitationNote | nvarchar(255) | citation
ObsoleteFlag | bit | Obsolete?
LocallyDefinedFlag | bit | Local?
ModifiedFlag | bit | Modified?
UserNotes | nvarchar(255) | User notes


MARCCustomerUpdateOmissions

MARCCustomerUpdateOmissions Table

This table lists any reason why a particular MARC update command that we script (based on format changes) would not be run at a particular customer site. Since the customer can change most of the table themselves, we want to be sure not to overwrite changes but at least log why we could not.

Columns

Column name | Data type | Description
Reason | nvarchar(2000) | Textual field
ScriptNumber | int | alter script number with the change that was not made


MARCDataFieldMaterializationPredicates

MARCDataFieldMaterializationPredicates Table

Contains one row for each data field materialization predicate within the scope of a materialization rule.

Columns

Column name | Data type | Description
IsDefault | bit | Flag indicating whether the materialization predicate is a system defined default.
MaterializationRuleID | int | Unique identifier of the materialization rule.
Precedence | int | Identifies the precedence of the materialization predicate. If multiple predicates have the same precedence, then the order will be based on the physical order of the data field within the record. If the materialization rule is not repeatable, then the first matching data field with the lowest precedence will be returned, otherwise all matching data fields will be returned ordered by precedence followed by the physical order of the data field.
TagRangeSetID | int | Unique identifier of the range set containing a set of tag numbers. Materialization will only include data fields that have a tag in the tag range set.
FirstIndicatorRangeSetID | int | Unique identifier of the code range set containing a set of indicator codes. If this value is NULL, then Ind1 is ignored. If this value is not NULL, then materialization will only include data fields that have Ind1 in the specified indicator code range set.
SecondIndicatorRangeSetID | int | Unique identifier of the code range set containing a set of indicator codes. If this value is NULL, then Ind2 is ignored. If this value is not NULL, then materialization will only include data fields that have Ind2 in the specified indicator code range set.
SubfieldCodeRangeSetID | int | Unique identifier of the range set containing a set of subfield identifiers. Materialization will only include subfields that have a subfield identifier in the subfield code range set.


MARCDateTimeSchemeCodes

MARCDateTimeSchemeCodes Table

MARC Date time scheme code sources. Contains values for Subject Heading and Term Source Codes.

Columns

Column name | Data type | Description
DateTimeSchemeSource | nvarchar(255) | Date time scheme source description
Code | nchar | The code
BibCitationNote | nvarchar(255) | bib citation note
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | local?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes


MARCElectronicLocationCodes

MARCElectronicLocationCodes Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
ElectronicLocation | nvarchar(255) | the description of the code
Code | nchar | the coded value
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCFingerprintIdentifierCodes

MARCFingerprintIdentifierCodes Table

Code list according to MARC format web site. Contains values for Fingerprint Scheme Source Codes.

Columns

Column name | Data type | Description
FingerprintIdentifier | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCFixedFieldData

MARCFixedFieldData Table

The table which stores all of the MARC data used in fixed fields

Columns

Column name | Data type | Description
FixedFieldDefinitionID | int | link to the definition (position or otherwise)
MARCLabel | nvarchar(100) | The MARC label (name)
MARCDescription | nvarchar(1000) | The description of the code associated with the MARC online format
UserDefinedLabel | nvarchar(100) | In case the user wants their own label.
DataValue | nvarchar(20) | the code
ObsoleteFlag | bit | Is this an obsolete value (Y/N)?
LocallyDefinedFlag | bit | user inserted this value local to their system
ModifiedFlag | bit | Has this been modified by Polaris SA?
UserNotes | nvarchar(255) | Any user notes


MARCFixedFieldDefinitions

MARCFixedFieldDefinitions Table

This table holds all of the entries associated with MARC tags/subfields which are either positionally defined or are part of a code list.

Columns

Column name | Data type | Description
FixedFieldDefinitionID | int | primary key
MARCLabel | nvarchar(255) | MARC label (name)
MARCDescription | nvarchar(1000) | Text associated with this entry as per MARC online format
UserDefinedLabel | nvarchar(255) | User defined label
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | Has this been modified via Polaris SA?
LengthOfField | int | length of the field
MaxLengthOfData | int | The data can be up to and including this value of characters long.
FixedLengthOfData | int | If the data is always a set length, this is that value.
MARCCodeTableID | int | if uses a specific code list, this has value of code table
IsDateField | bit | yes/no is this a date?
FormatOfDate | nvarchar(20) | String format of a date field

See Also

MARCFixedFieldData, MARCFixedFieldMap,


MARCFixedFieldMap

MARCFixedFieldMap Table

The mapping which binds all MARC tags/subfields to their positionally defined values/code list values

Columns

Column name | Data type | Description
MARCTagDefinitionID | int | FK to the MARCTagDefinitions table
Subfield | char | If this is a fixed field subfield, the subfield char is here
FixedFieldDefinitionID | int | Foreign Key to the definitions table
PositionNumber | int | The position number for this positionally defined element (if it is positional).
MARCFixedFieldTagTypeID | int | Foreign Key to the FixedFieldTagTypes table
ValidateFlag | bit | do we validate this fixed field position during MARC validation processing?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | Has this been modified via Polaris SA?


MARCFixedFieldTagTypes

MARCFixedFieldTagTypes Table

For MARC tags which have different implementations based on a type, this information is stored here. (ex. 008)

Columns

Column name | Data type | Description
MARCFixedFieldTagTypeID | int | primary key
TagNumber | int | tag number of the MARC tag
MARCRecordFormatID | int | record format ID (bib, authority, etc.)
FormatLabel | nvarchar(255) | The label for internal use
DisplayLabel | nvarchar(255) | the text to display.

See Also

MARC007TagLengths, MARCFixedFieldMap, MARCFixedFieldTypesCharMap,


MARCFixedFieldTypesCharMap

MARCFixedFieldTypesCharMap Table

The mapping between fixed field types and the determining characters which define which types are to be used.

Columns

Column name | Data type | Description
MARCFixedFieldTagTypeID | int | FK to the MARCFixedFieldTagTypes table
DeterminingCharacter | char | A one char field which is the determining character. For example, the 006/00 value is the determining character for the 006 tag.


MARCForeignInfoFieldCodes

MARCForeignInfoFieldCodes Table

Code list according to MARC format web site. Contains values for Format Source Codes.

Columns

Column name | Data type | Description
ForeignInfoField | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCGenderSourceCodes

MARCGenderSourceCodes Table

MARC code table for gender source codes. Contains values for Gender Code and Term Source Codes.

Columns

Column name | Data type | Description
GenderSource | nvarchar(255) | the source description
Code | nchar | code
BibCitationNote | nvarchar(255) | bib citation note
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | locally defined?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes


MARCGeographicAreaCodes

MARCGeographicAreaCodes Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
MARCGeographicAreaCodeID | int | Primary key
GeographicArea | nvarchar(255) | The description of the code
Code | nchar | The coded value
IsCollective | bit | Is this a parent to other GAC's (sharing the same code)?
MARCNotes | nvarchar(255) | The description as per the MARC description from the web site
ObsoleteFlag | bit | Is this an obsolete code?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes

See Also

MARCGeographicAreaCodesUseFor, MARCGeographicAreaCollectiveCodes,


MARCGeographicAreaCodeSources

MARCGeographicAreaCodeSources Table

Code list according to MARC format web site. Contains values for Geographic Area Code and Term Source Codes.

Columns

Column name | Data type | Description
GeographicAreaCodeSource | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCGeographicAreaCodesUseFor

MARCGeographicAreaCodesUseFor Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
MARCGeographicAreaCodeUseForID | int | The description of the GAC
GeographicAreaUseFor | nvarchar(255) | the use for description
MARCGeographicAreaCodeID | int | FK into the main codes table
MARCGeographicAreaCollectiveCodeID | int | FK into the collectives table
MARCNotes | nvarchar(255) | The MARC notes for the code via the online MARC web site
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCGeographicAreaCollectiveCodes

MARCGeographicAreaCollectiveCodes Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
MARCGeographicAreaCollectiveCodeID | int | Primary key
GeographicAreaCollective | nvarchar(255) | the collective code description
MARCGeographicAreaCodeID | int | FK into the main codes table
MARCNotes | nvarchar(255) | The description from the MARC online web site format
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes

See Also

MARCGeographicAreaCodesUseFor,


MARCGeographicClassCodes

MARCGeographicClassCodes Table

Code list according to MARC format web site. Contains values for Classification Scheme Source Codes.

Columns

Column name | Data type | Description
GeographicClass | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCGovDocClassNumberCodes

MARCGovDocClassNumberCodes Table

Code list according to MARC format web site. Contains values for Classification Scheme Source Codes.

Columns

Column name | Data type | Description
GovDocClassNumber | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCHeadingLinkingEntryCodes

MARCHeadingLinkingEntryCodes Table

Code list according to MARC format web site. Contains values for Genre/Form Code and Term Source Codes, Subject Heading and Term Source Codes, Musical Instrumentation and Voice Code Source Codes, and Name and Title Authority Source Codes.

Columns

Column name | Data type | Description
HeadingLinkingEntry | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCHoldingsSchemeSourceCodes

MARCHoldingsSchemeSourceCodes Table

Code list according to MARC format web site. Contains values for Holdings Scheme Source Codes.

Columns

Column name | Data type | Description
HoldingsSchemeSource | nvarchar(255) | Holdings scheme source
Code | nchar | Code
BibCitationNote | nvarchar(255) | citation
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | local?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes


MARCIndexTermCurriculumCodes

MARCIndexTermCurriculumCodes Table

Code list according to MARC format web site. Contains values for Curriculum Objective Code and Term Source Codes.

Columns

Column name | Data type | Description
IndexTermCurriculum | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCIndexTermFunctionCodes

MARCIndexTermFunctionCodes Table

Code list according to MARC format web site. Contains values for Genre/Form Code and Term Source Codes, and Function Term Source Codes.

Columns

Column name | Data type | Description
IndexTermFunction | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCIndexTermGenreFormCodes

MARCIndexTermGenreFormCodes Table

Code list according to MARC format web site. Contains values for Genre/Form Code and Term Source Codes.

Columns

Column name | Data type | Description
IndexTermGenreForm | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCIndexTermOccupationCodes

MARCIndexTermOccupationCodes Table

Code list according to MARC format web site. Contains values for Genre/Form Code and Term Source Codes, and Occupation Term Source Codes.

Columns

Column name | Data type | Description
IndexTermOccupation | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCIndicatorOne

MARCIndicatorOne Table

This table lists the definition used in tags which have a first indicator

Columns

Column name | Data type | Description
MARCTagDefinitionID | int | Foreign key into the MARC tags table
MARCLabel | nvarchar(255) | The MARC name for the indicator
MARCDescription | nvarchar(1000) | The description of the indicator from the MARC online web site
UserDefinedLabel | nvarchar(255) | The name the user has given to the indicator
ValidateFlag | bit | do we validate this particular indicator?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes
IsNonFilingCount | bit | Flag indicating whether the indicator represents a non-filing count.


MARCIndicatorOneValues

MARCIndicatorOneValues Table

This table lists all of the values used in tags which have a first indicator

Columns

Column name | Data type | Description
MARCTagDefinitionID | int | Foreign key into the MARC tags table
MARCLabel | nvarchar(255) | The MARC name for the indicator value
MARCDescription | nvarchar(1000) | The description from the MARC online web site
UserDefinedLabel | nvarchar(255) | The user's name for this indicator value
IndicatorValue | char | The actual indicator code
ObsoleteFlag | bit | Is this indicator an obsolete value?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCIndicatorTwo

MARCIndicatorTwo Table

This table lists the definition used in tags which have a second indicator

Columns

Column name | Data type | Description
MARCTagDefinitionID | int | Foreign key into the MARC tags table
MARCLabel | nvarchar(255) | The MARC name for the indicator
MARCDescription | nvarchar(1000) | The description of the indicator from the MARC online web site
UserDefinedLabel | nvarchar(255) | The name the user has given to the indicator
ValidateFlag | bit | do we validate this particular indicator?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes
IsNonFilingCount | bit | Flag indicating whether the indicator represents a non-filing count.


MARCIndicatorTwoValues

MARCIndicatorTwoValues Table

This table lists all of the values used in tags which have a second indicator

Columns

Column name | Data type | Description
MARCTagDefinitionID | int | Foreign key into the MARC tags table
MARCLabel | nvarchar(255) | The MARC name for the indicator value
MARCDescription | nvarchar(1000) | The description from the MARC online web site
UserDefinedLabel | nvarchar(255) | The user's name for this indicator value
IndicatorValue | char | The actual indicator code
ObsoleteFlag | bit | Is this indicator an obsolete value?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCInstrumentVoicesCodes

MARCInstrumentVoicesCodes Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
InstrumentOrVoice | nvarchar(255) | the description of the code
Code | nchar | the coded value
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCInstrumentVoicesSources

MARCInstrumentVoicesSources Table

Code list according to MARC format web site. Contains values for Musical Instrumentation and Voice Code and Term Source Codes.

Columns

Column name | Data type | Description
InstrumentVoicesSource | nvarchar(255) | Description of code
Code | nvarchar(12) | the coded value
BibCitationNote | nvarchar(255) | Bibliographic citation
ObsoleteFlag | bit | Is this obsolete?
LocallyDefinedFlag | bit | Is this local?
ModifiedFlag | bit | Has this been modified?
UserNotes | nvarchar(255) | Any user notes


MARCLanguageCodes

MARCLanguageCodes Table

The table of language codes used by the MARC format.

Columns

Column name | Data type | Description
MARCLanguageCodeID | int | primary key
Language | nvarchar(255) | The description of the language
Code | nchar | the coded value
IsCollective | bit | Is this a collective code (parent)
MARCNotes | nvarchar(255) | The description for this language taken from the MARC Online web site
ObsoleteFlag | bit | Is this an obsolete language code?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes

See Also

MARCLanguageCodesUseFor, MARCLanguageCollectiveCodes,


MARCLanguageCodeSources

MARCLanguageCodeSources Table

table for marc codes used primarily in subfields in the 041 tag

Columns

Column name | Data type | Description
LanguageCodeSource | nvarchar(255) | description
Code | nchar | language code
BibCitationNote | nvarchar(255) | from marc website
ObsoleteFlag | bit | is obsolete?
LocallyDefinedFlag | bit | is local?
ModifiedFlag | bit | is modified?
UserNotes | nvarchar(255) | user specific notes


MARCLanguageCodesUseFor

MARCLanguageCodesUseFor Table

The languages in the MARC format which link to the main codes and are described as the 'UF' languages. Writing to this table fires a trigger which will cause the entry to be porpogated to the MARCLanguageDisplay table, which is consumed by Polaris.

Columns

Column name | Data type | Description
MARCLanguageCodeUseForID | int | primary key
LanguageUseFor | nvarchar(255) | The description of the use for language
MARCLanguageCodeID | int | Foreign key into the main language codes table
MARCLanguageCollectiveCodeID | int | foreign key into the collective codes table
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCLanguageCollectiveCodes

MARCLanguageCollectiveCodes Table

The languages in the MARC format which link to the main codes and are described as the 'collective code for' languages. Writing to this table fires a trigger which will cause the entry to be porpogated to the MARCLanguageDisplay table, which is consumed by Polaris.

Columns

Column name | Data type | Description
MARCLanguageCollectiveCodeID | int | primary key
LanguageCollective | nvarchar(255) | the description of the language
MARCLanguageCodeID | int | foreign key into the main language codes table
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes

See Also

MARCLanguageCodesUseFor,


MARCLanguageDisplay

MARCLanguageDisplay Table

This table holds all of the MARC Languages in the database along with the flags set to determine if they will be available for scoping in the PAC and/or Tech Client.

Columns

Column name | Data type | Description
MARCLanguageCodeID | int | The psuedo primary key. This takes the ID from one of the three language tables.
MARCLanguageTypeID | int | A code to tell us if this is a main language (1), a collective language (2), or a use for language (3)
Code | nchar | The actual language code
Language | nvarchar(255) | The description of the language
PAC | bit | The PAC flag
ILS | bit | The tech client flag
sequence | int | where the language shows in the SA list (which is where flags are set)
ObsoleteFlag | bit | Is this language obsolete?
Display | nvarchar(4000) | Holds the language information displayed to the user.


MARCLevelizationPredicates

MARCLevelizationPredicates Table

Contains one row for each levelization predicate within the scope of a levelization rule.

Columns

Column name | Data type | Description
LevelizationRuleID | int | Unique identifier of the levelization rule.
LeaderPosition | tinyint | Zero based index of the leader value.
LeaderCodeRangeSetID | int | Unique identifier of the leader value range set to compare against.


MARCLevelizationRules

MARCLevelizationRules Table

Contains one row for each level within the scope of a domain.

Columns

Column name | Data type | Description
LevelizationRuleID | int | Unique identifier of the levelalization rule.
DomainID | smallint | Unique identifier of the domain.
LevelID | tinyint | Unique identifier of the level.

See Also

MARCLevelizationPredicates,


MARCLocationClassSourcesCodes

MARCLocationClassSourcesCodes Table

Code list according to MARC format web site. Contains values for Classification Scheme Source Codes.

Columns

Column name | Data type | Description
LocationClassSource | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCMacro

MARCMacro Table

Stores macro information such as name, description, etc

Columns

Column name | Data type | Description
MARCMacroID | int | int IDENTITY Primary Key
Type | char | char(1) B - Bib A - Auth H - Holdings
Name | nvarchar(50) | varchar(50) NOT NULL
Description | nvarchar(255) | varchar(255) NOT NULL
AssignedCTRL | bit | bit NOT NULL DEFAULT 0
AssignedATL | bit | bit NOT NULL DEFAULT 0
AssignedSHIFT | bit | bit NOT NULL DEFAULT 0
AssignedKey | smallint | smallint NOT NULL DEFAULT 0
CreatorID | int | int NOT NULL foreign key to PolarisUsers
CreationDate | datetime | datetime NOT NULL DEFAULT getdate()

See Also

MARCMacroItem,


MARCMacroItem

MARCMacroItem Table

Child table to MARCMacro. Stores the keystroke information

Columns

Column name | Data type | Description
MARCMacroItemID | int | int IDENTITY(1,1) Primary Key
MARCMacroID | int | int NOT NULL FOREIGN KEY to MARCMacro
KeyState | smallint | smallint NOT NULL 1 - key down 0 - key up
VirtualKey | smallint | smallint NOT NULL
ScanCode | smallint | smallint NOT NULL


MARCMaterializationRules

MARCMaterializationRules Table

Contains one row for each materialization rule within the scope of a domain.

Columns

Column name | Data type | Description
MaterializationRuleID | int | Unique identifier of the materialization rule.
DomainID | smallint | Unique identifier of the domain.
EntityPath | hierarchyid | Unique identifier of the entity path.
Type | char | Identifies the type of field which applies to the materialization rule. This can be one of the following: 'C' (Control Field), 'D' (Data Field) or 'V' (Virtual Field).
IsRepeatable | bit | Flag indicating whether the materialization rule should return all matching fields.
IsSystemGenerated | bit | Flag indicating whether the materialization rule predicates are system generated.
IsSystemSynchronized | bit | Flag indicating whether the materialization rule predicates are synchronized with rules defined separately in system administration (e.g. primary author display, primary title display, etc.).
NormalizationSchemeID | smallint | Specifies the normalization scheme to be applied to the output of the materialization rule.

See Also

MARCControlFieldMaterializationPredicates, MARCDataFieldMaterializationPredicates, MARCVirtualFieldMaterializationPredicates,


MARCMediaCodesSources

MARCMediaCodesSources Table

MARC Media Source codes

Columns

Column name | Data type | Description
MediaCode | nvarchar(255) | The media code source description
Code | nchar | The code
BibCitationNote | nvarchar(255) | bib citation note
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | local?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes


MARCMusicalCompositionSources

MARCMusicalCompositionSources Table

Code list according to MARC format web site. Contains values for Musical Composition Form Code Source Codes.

Columns

Column name | Data type | Description
MusicalCompositionSource | nvarchar(255) | The description of the code
Code | nvarchar(12) | the code per MARC
BibCitationNote | nvarchar(255) | Bibliographic citation
ObsoleteFlag | bit | Is this obsolete?
LocallyDefinedFlag | bit | Is this local?
ModifiedFlag | bit | Has this been modified?
UserNotes | nvarchar(255) | User notes


MARCMusicalIncipitSchemeSources

MARCMusicalIncipitSchemeSources Table

Code list according to MARC format web site. Contains values for Musical Incipit Scheme Source Codes.

Columns

Column name | Data type | Description
MusicalIncipitSchemeSource | nvarchar(255) | musical incipit scheme source
Code | nchar | code
BibCitationNote | nvarchar(255) | citation
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | local?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes


MARCNationalBibNumberCodes

MARCNationalBibNumberCodes Table

Code list according to MARC format web site. Contains values for National Bibliography Number Source Codes.

Columns

Column name | Data type | Description
NationalBibNumber | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCNonMarcInfoFieldCodes

MARCNonMarcInfoFieldCodes Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
NonMarcInfoField | nvarchar(255) | Description associated with the Code.
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCOtherClassNumberCodes

MARCOtherClassNumberCodes Table

Code list according to MARC format web site. Contains values for Classification Scheme Source Codes.

Columns

Column name | Data type | Description
OtherClassNumber | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCOtherStandardIdentifierCodes

MARCOtherStandardIdentifierCodes Table

Code list according to MARC format web site. Contains values for Standard Identifier Source Codes.

Columns

Column name | Data type | Description
OtherStandardIdentifier | nvarchar(255) | the description of the code
Code | nvarchar(25) | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCPreferredCitationCodes

MARCPreferredCitationCodes Table

Code list according to MARC format web site. Contains values for Citation Scheme Source Codes.

Columns

Column name | Data type | Description
PreferredCitation | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCPriceTypeCodes

MARCPriceTypeCodes Table

marc price type code list. Contains values for Price Type Code Source Codes.

Columns

Column name | Data type | Description
PriceTypeSource | nvarchar(255) | price type source description
Code | nchar | code
BibCitationNote | nvarchar(255) | bib citation note
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | locally defined?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes


MARCPublishingEntityCodes

MARCPublishingEntityCodes Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
PublishingEntityCode | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCRangeSetOrdinals

MARCRangeSetOrdinals Table

Contains one row for each distinct ordinal associated with a range set.

Columns

Column name | Data type | Description
RangeSetID | int | Unique identifier of the range set.
Ordinal | smallint | Ordinal value associated with the range set.


MARCRangeSets

MARCRangeSets Table

Contains one row for each distinct range set.

Columns

Column name | Data type | Description
RangeSetID | int | Unique identifier of the range set.
Descriptor | hierarchyid | A canonical binary key representing all of the ordinals within a range set.

See Also

MARCRangeSetOrdinals,


MARCRecordFormats

MARCRecordFormats Table

Code table for MARC record formats

Columns

Column name | Data type | Description
MARCRecordFormatID | int | format ID is the primary key
MARCRecordFormatDescription | nvarchar(50) | The description of the format (ex. Bib, Holdings)
DomainID | smallint | Unique identifier of the domain associated with the MARC record format

See Also

MARCFixedFieldTagTypes, MARCTagDefinitions,


MARCRelatorCodes

MARCRelatorCodes Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
MARCRelatorCodeID | int | primary key
Relator | nvarchar(255) | The text description of the relator
Code | nchar | The relator code
MARCNotes | nvarchar(400) | The MARC notes via the MARC online format
ObsoleteFlag | bit | is this an obsolete code?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes

See Also

MARCRelatorCodesUseFor,


MARCRelatorCodesUseFor

MARCRelatorCodesUseFor Table

Code list according to MARC format web site

Columns

Column name | Data type | Description
MARCRelatorCodeUseForID | int | Primary key
RelatorUseFor | nvarchar(255) | The relator code used for text
MARCRelatorCodeID | int | FK to relator codes table
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCSpecialCodedDates

MARCSpecialCodedDates Table

MARC special coded dates source codes. Contains values for Date and Time Scheme Source Codes.

Columns

Column name | Data type | Description
SpecialCodedDate | nvarchar(255) | Special coded date source description
Code | nchar | The code
BibCitationNote | nvarchar(255) | bib citation note
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | local?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes


MARCSubdivisionUsageCodes

MARCSubdivisionUsageCodes Table

Code list according to MARC format web site. Contains values for Subject Category Code Source Codes.

Columns

Column name | Data type | Description
SubdivisionUsage | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCSubfieldDefinitions

MARCSubfieldDefinitions Table

This table lists all of the MARC subfields which are associated with each tag

Columns

Column name | Data type | Description
MARCTagDefinitionID | int | FK to the MARC tag definitions table
MARCLabel | nvarchar(255) | MARC label (name)
MARCDescription | nvarchar(2000) | The description of the subfield as per the MARC online format web page.
UserDefinedLabel | nvarchar(255) | User has defined their own label
Subfield | char | The actual one-char subfield value
ValidateFlag | bit | do we validate this subfield during MARC validation processing?
ObsoleteFlag | bit | Is this subfield an obsolete subfield?
RepeatableFlag | bit | Is this subfield repeatable?
RequiredFlag | bit | Is this subfield required (determined by user, not by MARC format).
LocallyDefinedFlag | bit | Is this added via the Polaris SA?
ModifiedFlag | bit | Is this subfield modified via the Polaris SA?
UserNotes | nvarchar(255) | user added their own notes
IsFixedDataField | bit | Is this subfield a fixed data/coded field?
IsFormattedField | bit | this field is for future use.
IsURI | bit | Flag indicating whether the subfield represents a URI.
IsLinkText | bit | Flag indicating whether the subfield represents text that should be displayed in place of a URI.
IsMaterialsSpecified | bit | Flag indicating whether the subfield represents a description of the materials referenced by a URI.


MARCSubjectAddedEntryCodes

MARCSubjectAddedEntryCodes Table

Code list according to MARC format web site. Contains values for Genre/Form Code and Term Source Codes, Subject Heading and Term Source Codes, and Name and Title Authority Source Codes.

Columns

Column name | Data type | Description
SubjectAddedEntry | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCSubjectCategoryCodes

MARCSubjectCategoryCodes Table

Code list according to MARC format web site. Contains values for Subject Category Code Source Codes.

Columns

Column name | Data type | Description
SubjectCategory | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA?
ModifiedFlag | bit | modified via Polaris SA?
UserNotes | nvarchar(255) | user added their own notes


MARCSubjectFacetedTopicalCodes

MARCSubjectFacetedTopicalCodes Table

Code list according to MARC format web site. Contains values for Subject Heading and Term Source Codes.

Columns

Column name | Data type | Description
SubjectFacetedTopical | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA
ModifiedFlag | bit | modified via Polaris SA
UserNotes | nvarchar(255) | user added their own notes


MARCTagDefinitions

MARCTagDefinitions Table

The list of all MARC tags defined in all of the currently implemented MARC formats in Polaris

Columns

Column name | Data type | Description
MARCTagDefinitionID | int | primary key, also links to most other MARC tables.
TagNumber | int | The MARC tag number (technically doesn't have to be a 3-char number, but all of Polaris assumes this).
MARCRecordFormatID | int | link to record formats table
OrganizationID | int | The organization to which this particular tag is used by.
MARCLabel | nvarchar(255) | The MARC Label (name)
MARCDescription | nvarchar(1000) | The description associated with the tag corresponding to the MARC online web site.
UserDefinedLabel | nvarchar(255) | The user has defined their own label for this tag.
ValidateFlag | bit | Are we supposed to check this tag while performing validation?
ObsoleteFlag | bit | Is this value obsolete?
RepeatableFlag | bit | Is this tag repeatable?
RequiredFlag | bit | Is this tag required? (Polaris hardcodes in this table all LDR and 008 tags).
LocallyDefinedFlag | bit | Is this added via Polaris SA?
ModifiedFlag | bit | Changed via Polaris SA?
SortOrder | int | If the tags are sorted, what order? (type specific)
UserNotes | nvarchar(255) | user has added their own notes.

See Also

MARCConditionalProhibited, MARCConditionalRequired, MARCFixedFieldMap, MARCIndicatorOne, MARCIndicatorOneValues, MARCIndicatorTwo, MARCIndicatorTwoValues, MARCSubfieldDefinitions,


MARCTaxonomicIdentificationCodes

MARCTaxonomicIdentificationCodes Table

Code list according to MARC format web site. Contains values for Taxonomic Classification Source Codes.

Columns

Column name | Data type | Description
TaxonomicIdentificationCode | nvarchar(255) | the description of the code
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | Is this code obsolete?
LocallyDefinedFlag | bit | added via Polaris SA
ModifiedFlag | bit | modified via Polaris SA
UserNotes | nvarchar(255) | user added their own notes


MARCThematicIndexCodeSourceCodes

MARCThematicIndexCodeSourceCodes Table

Code list according to MARC format web site. Contains values for Thematic Index Code Source Codes.

Columns

Column name | Data type | Description
ThematicIndexCodeSource | nvarchar(255) | The thematic index code description
Code | nchar | the coded value
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | is this obsolete?
LocallyDefinedFlag | bit | added via Polaris SA
ModifiedFlag | bit | has this been modified?
UserNotes | nvarchar(255) | user added their own notes


MARCTradeAvailabilityInformation

MARCTradeAvailabilityInformation Table

MARC Trade Availablity Information source codes

Columns

Column name | Data type | Description
TradeAvailabilityInformation | nvarchar(255) | The trade availablity description
Code | nchar | The code
BibCitationNote | nvarchar(255) | the bibliography note for the code
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | local?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes?


MARCTradePriceSources

MARCTradePriceSources Table

MARC Trade Price source codes

Columns

Column name | Data type | Description
TradePriceSource | nvarchar(255) | The trade price source description
Code | nchar | The code
BibCitationNote | nvarchar(255) | Bib citation note
ObsoleteFlag | bit | obsolete?
LocallyDefinedFlag | bit | local?
ModifiedFlag | bit | modified?
UserNotes | nvarchar(255) | user notes?


MARCTypeOfMaterial

MARCTypeOfMaterial Table

Table defining the formats/types of material used in the MARC Bibliographic Format. This table is used in building the Type Of Material (TOM) index (BibliographicTOMIndex) that is used to limit Bibliographic searches by TOM. It represents the physical format in which an item appears. This table is static (GIS modifed only) as there is associated code that correlates to this table.

Columns

Column name | Data type | Description
MARCTypeOfMaterialID | tinyint | Pimary key unique ID.
Precedence | int | Precedence used when determinig the most significant TOM to use when a bibliographic record maps to multiple TOM entries.
Description | nvarchar(80) | The Type Of Material description.
SearchCode | nvarchar(25) | 3-character search code for the associated TOM.

See Also

BibliographicRecords, BibliographicTOMIndex, ILLRequests, InnReachCentralITypeToTOM, PatronReadingHistory, SA_SuppressAvailabilityAndRequests, SysHoldRequests,


MARCUniqueAuthorityLCCNs

MARCUniqueAuthorityLCCNs Table

This is a work table used by the MARC web service consumer when it connects to the MARC web service to obtain authority record updates. The local LCCNs are stored in this table for processing purposes.

Columns

Column name | Data type | Description
LCCNID | int | Primary key
MARCLCCN | nvarchar(40) | LCCN of the record
LastClientUpdate | datetime | Date the record was last updated in Polaris


MARCValidationDummyTable

MARCValidationDummyTable Table

Dummy table for SA use

Columns

Column name | Data type | Description
DummyData | varchar(1) | no meaning, ignore.


MARCValidationErrorCodes

MARCValidationErrorCodes Table

List of error codes used in MARC validation process

Columns

Column name | Data type | Description
MARCValidationErrorCodeID | int | primary key
MARCValidationErrorCodeDesc | nvarchar(255) | the description of the code


MARCVirtualFieldMaterializationPredicates

MARCVirtualFieldMaterializationPredicates Table

Contains one row for each materialization rule linked to a virtual tag (MARCMaterializationRules.Type='V')

Columns

Column name | Data type | Description
VirtualFieldMaterializationPredicateID | int | Unique identifier of the virtual field materialization predicate.
MaterializationRuleID | int | Unique identifier of the materialization rule.
Tag | smallint | Tag associated with a pre-defined virtual field. A virtual tag is always negative.


MARCVirtualTags

MARCVirtualTags Table

Contains one row for each system-defined virtual tag.

Columns

Column name | Data type | Description
Tag | smallint | Unique negative integer assigned to the virtual tag.
Name | sysname | Name of the virtual tag.

See Also

MARCVirtualFieldMaterializationPredicates,


MARC_cnv_DC_temp

MARC_cnv_DC_temp Table

A temp tabled used for the MARC to Dublin core crosswalk

Columns

Column name | Data type | Description
BibliographicRecordID | int | Bib ID
Description | nvarchar(255) | A description
Data | nvarchar(4000) | Data fron bibliograhic subfields
ord | int | The ordinal


MaterialLoanLimits

MaterialLoanLimits Table

This table defines the maximum number of loanable items of a certain material type for a particular organization and patron code.

Columns

Column name | Data type | Description
OrganizationID | int | Foreign key into Polaris..Organizations that defines the organization context.
PatronCodeID | int | Foreign key into Polars..PatronCodes that defines the Patron Code context.
MaterialTypeID | int | Foreing key into Polaris..MaterialTypes that defines the material type.
MaxItems | int | The actual loan limit for the given MaterialType/Organization/PatronCode combination.
MaxRequestItems | int | The actual request limit for the given MaterialType/Organization/PatronCode combination.


MaterialTypes

MaterialTypes Table

This will hold all of the values for the Bibliographic LDR/06 and will allow an item to have a material type, which can reflect the bib record type, or can serve as a different value (for an item tied to a bib but of different material type - CD tied to book record)

Columns

Column name | Data type | Description
MaterialTypeID | int | Primary key - code
Description | nvarchar(80) | Text description of the material type

See Also

BibliographicHoldableMaterialTypes, CircItemRecords, EphemeralItemRecords, InnReachFilterMaterialTypes, InvLines, ItemTemplates, LoanLimits, MaterialLoanLimits, NCIPMediumTypes, POLines, SA_BorrowByMail_MaterialTypesPermitted, SA_ChargeForCheckOut_MaterialTypes, SA_FloatingMatrixMaterialLimits, SA_FloatingMatrixMaterialTypes, SA_MaterialTypeGroups_Definitions, SA_MediaDispenser_MaterialTypes, SA_NCIPMediumTypes_Incoming, SA_NCIPMediumTypes_Outgoing, SA_ShelvingStatusDurations, SelfCheckMaterialTypes, SelListLines, SHRCopies,


MfhdCategories

MfhdCategories Table

This static table defines three categories of Holdings data according to MARC21 Format: -Basic Bibliographic Unit -Supplementary Material -Indexes

Columns

Column name | Data type | Description
CategoryID | tinyint | category integer value
MfhdCode | char | category USMARC code.
Description | nvarchar(30) | category name
Abbreviation | nvarchar(20) | Category's shortened description name.

See Also

MfhdPublicationPatterns, ShrClaimDefs,


MfhdChronCaptions

MfhdChronCaptions Table

This table stores publications' chronology caption data. These data maps to MARC21 Holdings Format 853/4/5 subfield $i-$m. Every record in this table should have a many-to-one relationship with a record in MfhdPublicationPatters table.

Columns

Column name | Data type | Description
PubPatternID | int | publication pattern record ID. FK, references MfhdPublicationPatterns.PubPatternID.
LevelNum | tinyint | indicates level of chronolgy. 1, 2, 3 or 4 indicates $i, $j, $k or $l accordingly.
IsAlter | bit | indicate whether it is a $m or not. if 1, then this is a subfield $m. $m - alternative numbering scheme, chronology.
ChronCap | tinyint | Chronology Caption ID defined in ChronCapCodes.
FormatID | tinyint | chronology caption format ID defined in MfhdChronFormats.
StartValue | nvarchar(20) | prediction start value of the subfield. usually is the value of the 1st linked 863/4/5's correspondent subsfield.


MfhdChronCodes

MfhdChronCodes Table

this static table stores all chronology captions supported by Polaris. These values are the values appear in Holdings 853/4/5 subfield $i-$m.

Columns

Column name | Data type | Description
CodeID | tinyint | chronology caption integer value.
MfhdCode | nvarchar(6) | chronology code defined by MARC21 Holdings Format.
Description | nvarchar(50) | chronology caption
Mnemonic | nvarchar(100) | Mnemonic used to lookup multilingual representations of the description

See Also

MfhdChronCaptions, MfhdRegularityPatterns,


MfhdChronFormats

MfhdChronFormats Table

this static table stores all chronology caption formats supported by Polaris.

Columns

Column name | Data type | Description
FormatID | tinyint | format integer value
Description | nvarchar(50) | format name

See Also

MfhdChronCaptions,


MfhdCompleteness

MfhdCompleteness Table

this static table stores all Holdings record's completeness statuses supported by Polaris.

Columns

Column name | Data type | Description
CodeID | tinyint | completeness integer value.
Description | nvarchar(20) | completeness status.

See Also

SHRCopies,


MfhdEnumCaptions

MfhdEnumCaptions Table

This table stores publications' enumeration caption data. These data maps to MARC21 Holdings Format 853/4/5 subfield $a-$h. Every record in this table should have a many-to-one relationship with a record in MfhdPublicationPatters table.

Columns

Column name | Data type | Description
PubPatternID | int | publication pattern ID. FK, references MfhdPubliationPatterns.PubPatternID.
LevelNum | tinyint | indicates level of enumeration. if IsAlter is 1 and LevelNum is 1, 2, 3 or 4, then indicates $a, $b, $c, $d, $e, $f; if IsAlter is 0 and LevelNum is 1 or 2 then indicates $g or $h accordingly.
IsAlter | bit | indicates if it's a subfield $g, $h, or not. if 1, then it's $g or $h.
EnumCap | nvarchar(50) | enumeration caption (subfield $a-$h).
FormatID | tinyint | enumration caption format ID. FK, references MfhdEnumFormats.FormatID.
StartValue | nvarchar(50) | prediction start value of the subfield. usually is the value of the 1st linked 863/4/5's correspondent subsfield.
BibUnits | int | Bibliographic units per next higher level (subfield $u). an integer value is expected.
NumSchemeID | tinyint | Numbering continuity (subfield $v). FK, references MfhdNumberingScheme.SchemeID.


MfhdEnumFormats

MfhdEnumFormats Table

this static table stores all enumeration caption formats supported by Polaris.

Columns

Column name | Data type | Description
FormatID | tinyint | format integer value.
MfhdCode | nvarchar(6) | Note: not currently supported.
Description | nvarchar(50) | format name.

See Also

MfhdEnumCaptions,


MfhdFrequencies

MfhdFrequencies Table

this static table stores all the frequencies (853/4/5 subfield $w) defined by MARC21 Holdings Format.

Columns

Column name | Data type | Description
FrequencyID | tinyint | Frequency integer value.
MfhdCode | char | one-character alphabetic code.
Description | nvarchar(100) | Frequency name.

See Also

MfhdPublicationPatterns,


MfhdIssues

MfhdIssues Table

This table stores all the Issue/Part records which are actually the 863/4/5 tags of the MARC21 Format Holdings record. Every record in this table should have a many-to-one relationship with a record in MfhdPublicationPatters table.

Columns

Column name | Data type | Description
IssueID | int | Issue/Part record control ID.
PubPatternID | int | linked publication pattern ID. FK, references to MfhdPubliationPatterns(PubPatternID).
BibliographicRecordID | int | Part record linked bibliographic record control ID. For an Issue record, this field should always be NULL.
Chron1 | nvarchar(20) | 1st level chronology value (863/4/5 $i).
Chron2 | nvarchar(20) | 2nd level chronology value (863/4/5 $j).
Chron3 | nvarchar(20) | 3rd level chronology value (863/4/5 $k).
Chron4 | nvarchar(20) | 4th level chronology value (863/4/5 $l).
ChronAlter | nvarchar(20) | alternative numbering scheme chronology value (863/4/5 $m).
ChronologyDate | datetime | chronology date of the Issue/Part record. this date is converted from the chronology values of the Issue/part record by Polaris.
CreationDate | datetime | record creation date.
CreatorID | int | record creator's Polaris user ID. FK, references PolarisUsers(PolarisUserID).
Designation | nvarchar(780) | Issue/Part's designation. This string is converted from chronology and enumeration values, formats and captions by Polaris. This is usually the string appears on the publication's face and displays in PAC.
Enum1 | nvarchar(50) | 1st level enumeration value (863/4/5 $a).
Enum2 | nvarchar(50) | 2nd level enumeration value (863/4/5 $b).
Enum3 | nvarchar(50) | 3rd level enumeration value (863/4/5 $c).
Enum4 | nvarchar(50) | 4th level enumeration value (863/4/5 $d).
Enum5 | nvarchar(50) | 5th level enumeration value (863/4/5 $e).
Enum6 | nvarchar(50) | 6th level enumeration value (863/4/5 $f).
EnumAlter1 | nvarchar(50) | 1st level alternative numbering scheme enumeration value (863/4/5 $g).
EnumAlter2 | nvarchar(50) | 2nd level alternative numbering scheme enumeration value (863/4/5 $h).
ExpectArrivalDate | datetime | date Issue/Part is expected to be received by library. this date is calculated based on record's ChronologyDate and it's linked publication pattern's arrival pattern.
InvLineItemSegmentID | int | Part record's linked invoice line item segment ID. FK, references InvLineItemSegments(InvLineItemSegmentID). For an Issue record, this field should always be NULL.
IssueStatusDate | datetime | Issue/Part status date. if it's status is 'Received', then this the date it was received. otherwise, this is the date it was created or unchecked in.
ItemRecordID | int | Issue/Part linked Iterm record's control ID. FK, references ItemRecordDetails(ItemRecordID).
LastTransaction | datetime | latest date when record was modified.
ModifierID | int | record modifier's user ID. FK, references PolarisUsers(PolarisUserID).
NoteNonPub | nvarchar(200) | non-public notes.
NotePub | nvarchar(200) | public notes.
NoteStaff | nvarchar(200) | staff notes or warnings.
RoutedCount | int | LTD count of Issue record being routed. For Part record, as Polaris v.3.1 or earlier does not support standing order routing, this field should always be NULL or zero.
RteStatus | smallint | Issue record routing status. FK, references to RouteStatus(StatusID).
TitleOfSupIndex | nvarchar(200) | Title of supplementary material/index (864/5 $o).
UnitPrice | money | Unit price of an individual issue/part.
IssueStatusId | smallint | ID of issue's current status. Foreign key references MfhdIssueStatuses(IssueID).
PreIssueStatusId | smallint | ID of issue's previous status. Foreign key references MfhdIssueStatuses(IssueID).
Retained | bit | Indicates whether or not issue/part is retained by the library.
SICICode | nvarchar(255) | System generated SICICode enumeration and chronology data element which is formatted according to SICI standard. This string doesn't include ISSN or other SICICode data elements.


MfhdIssueStatuses

MfhdIssueStatuses Table

This table stores all the available status for an serial issue or part record. all the values here are system defined values.

Columns

Column name | Data type | Description
StatusId | smallint | Numeric ID of a status.
StatusDesc | nvarchar(30) | Descripition of a status.

See Also

MfhdIssues, SA_NotReceived_IssueStatus_Assignment,


MfhdNumberingScheme

MfhdNumberingScheme Table

this static table stores the numbering continuities defined by MARC21 Format for 853/4/5 subfield $v to indicate whether the enumberation has continuously incrementing numbers or restarts at the completion of a specific unit.

Columns

Column name | Data type | Description
SchemeID | tinyint | scheme integer value.
MfhdCode | char | one-chararctor code of schecme. the value can be either 'c' or 'r'.
Description | nvarchar(20) | description of the numbering scheme.

See Also

MfhdEnumCaptions,


MfhdPublicationPatterns

MfhdPublicationPatterns Table

this table stores the primary data (some are 853/4/5 data) of all Holdings records' publication patterns and all publication pattern templates. Every record in this table should have a many-to-one relationship with a record in SHRCopies table.

Columns

Column name | Data type | Description
PubPatternID | int | record control ID. PK.
ArrivalDuration | smallint | number of days the linked Issue/Part record should be arrived in the library before or after its publication date (ie. chronology date). For a template, this field should always be NULL.
ArrivalTime | varchar(1) | the linked Issue/Part record should be arrived in the library before or after its publication date (ie. chronology date). For a template, this field should always be NULL.
CalendarChange | nvarchar(50) | 853/4/5 subfield $x. contain one or more two- or four-char numeric codes separated by comma that indicate the chronological point at which pattern's highest level enumeration increments or changes.
CategoryID | tinyint | category ID indicates pattern's category. FK, references to MfhdCategories(CategoryID).
CopyID | int | pattern's linked Serial Holdings record control ID. FK, references to SHRCopies(CopyID).
CreatorID | int | pattern's creator user ID. FK, references to PolarisUsers(PolarisUserID).
CreationDate | datetime | pattern's creation date.
Designation | nvarchar(780) | a string converted from pattern's chronology and enumeration captions, formats and start values by Polaris. this is usually the 1st linked Issue/Part record's designation value.
EndDate | datetime | date by when prediction for pattern or template stops, or, for a patern only, gets closed.
Frequency | tinyint | 853/4/5 subfield $x. pattern's frequency. FK, references to MfhdFrequencies(FrequencyID).
ItemRecordCreateCode | tinyint | indicates the following methodology of how creating item record during pattern's linked Issue/Part record check-in: 0 or NULL- no item record gets automatically created by Polaris; 1- one linked item record gets automatically created by Polaris without prompting user to input item record barcode; 2- one linked item record gets automatically created by Polaris with prompting user to input item record barcode; For a template, this field should always be NULL.
IsTemplate | bit | indicates whether record is a pattern or a template.
LastTransation | datetime | latest modification date.
ModifierID | int | modifier's user ID. FK, references to PolarisUsers(PolarisUserID).
StartDate | datetime | date when prediction for a pattern or template starts.
TemplateName | nvarchar(200) | template name. For a pattern, this field should always be NULL.
TypeOfSupIndex | nvarchar(200) | 854/5 subfield $o. Type of supplementary material/Index. For a template, this field should always be NULL.
IsClosed | bit | indicates whether pattern is closed or not. For a template this field should always be NULL.
NumberToPredict | tinyint | maxmium number of Issue/Part records can be automatically predicted for a pattern at a time. For a template, this field should always be NULL.
SeqNumber | tinyint | 853/4/5 subfield $8. Field link and sequence number.
UnitPrice | money | Unit price of an individual issue/part.
TemplateNote | nvarchar(512) | A free text note field for a pattern template.

See Also

MfhdChronCaptions, MfhdEnumCaptions, MfhdIssues, MfhdRegularityPatterns, TextualHoldings,


MfhdRegularityPatterns

MfhdRegularityPatterns Table

this table stores all the regularities of a publication pattern (853/4/5 subfield $y). Every record in this table should have a many-to-one relationship with a record in MfhdPublicationPatters table.

Columns

Column name | Data type | Description
RegPatternID | int | record control ID.
PubPatternID | int | linked publication pattern ID. FK, references to MfhdPublicationPatterns(PubPatternID).
PubCode | char | publication code. can be one of the following values defined by MARC21 Format but can not be NULL: p - Published c - Combined o - omitted.
ChronCode | tinyint | chronology type code defined by MARC21 Format for 853/4/5 $y. FK, references to MfhdChronCodes(CodeID).
CodePattern | nvarchar(30) | regularity chronology code pattern. this pattern is used to tell which portion of the value patterns stands for what chronology code. For example, if CodePatter is MMDD, and Patterns is 1224, that means month = 12 and day of month = 24 which is Dec 24.
Patterns | nvarchar(30) | regularity pattern values.


MRMS_AccessRequestDenialReasons

MRMS_AccessRequestDenialReasons Table

The reason that the Polaris Fusion PAC access request has been accepted or denied by the library. This table is used to build the Access request response e-mail sent to the patron.

Columns

Column name | Data type | Description
DenialReasonID | int | A unique denial reason ID
Description | nvarchar(80) | The description (subject line) of the denial or acceptance reason.
DescriptiveText | nvarchar(-1) | The body of the e-mail to be sent to the patron

See Also

MRMS_ACLPermissionRequests,


MRMS_AccessRequestReasons

MRMS_AccessRequestReasons Table

A table contaning the library defined access request reasons for Polaris Fusion. This table is used to populate a drop down list of request reasons for the patron.

Columns

Column name | Data type | Description
AccessRequestReasonID | int | A unique ID for the reason.
Description | nvarchar(80) | A description for the access request.
IsDefault | bit | Indicates if the reason is set as the default choice.

See Also

MRMS_ACLPermissionRequests,


MRMS_ACLPermissionRequests

MRMS_ACLPermissionRequests Table

A table that contains requests to use digital content that is under ACL control.

Columns

Column name | Data type | Description
ACLRequestID | int | A unique ID for the request.
PatronID | int | The ID of the patron requesting access
ResourceFileID | int | The resource for which access is requested.
Disposition | bit | What outcome did this request have.
CreationDate | datetime | The Date of the request
AccessRequestReasonID | int | The reason the patron requested access.
DenialReasonID | int | The acceptance or denial reason for the access request.
AccessRequestPatronGeneratedNote | nvarchar(4000) | A patron generated comment associated with the access request.


MRMS_ACL_UserList

MRMS_ACL_UserList Table

A table used in Polaris Fusion to maintain access control list entries for particular resource file entries.

Columns

Column name | Data type | Description
ResourceFileID | int | The resource file (digital asset) to which the patron has rights
PatronID | int | The PatronID of the person who has access to this file
AccessToken | nvarchar(255) | A unique token that is exchanged during the download process. This token expires after the download has completed.
UseCount | int | The number of times the file has been downloaded.
AccessRequestReasonID | int | The original reason for the access request (populated only if the entry originated as a PAC access request)
OrderDate | datetime | The date of the e-commerce purchase, or the date the patron was added to the access control list for this file.
LastDownloadDate | datetime | The last time the file was downloaded by the patron.
ResetCounter | int | The number of times the download counter has been reset by library staff.


MRMS_ApplicationDefaults

MRMS_ApplicationDefaults Table

A table holding the base defaults for the Polaris Fusion application.

Columns

Column name | Data type | Description
EnrichedDataLinksWebServiceURL | nvarchar(4000) | The URL of the Polaris Fusion web service
MaxResults | int | The maximum number of results returned in hit lists by the Polaris Fusion application
SearchTimeout | int | The search timeout in the Polaris Fusion application.
UseEcommerce | bit | Allow e-commerce requests in PowerPAC
EcommerceMediated | bit | Are access control list permission requests alloed in the PAC.
UseHST | bit | use the Harmonized sales tax.
HST | float | Harmonized sales tax percentage.
UsePST | bit | Use the PST
PST | float | Prov. Sales tax percentage.
UseGST | bit | Use the GST
GST | float | Goods and services tax percentage
UseCityTax | bit | Use the city tax
CityTax | float | The city tax percentage.
UseCountyTax | bit | Use the county tax
CountyTax | float | The county tax percentage.
UseStateTax | bit | Use the state tax
StateTax | float | The state tax percentage
PSTGST | bit | Accumulate PST on GST
AddShoppingCartTermsOfUse | bit | Display terms of use information on the shopping cart form
AddShoppingCartCopyright | bit | Display copyright information on the shopping cart form
AddShoppingCartContactInfomation | bit | Display contact information on the shopping cart form
AddShoppingCartPrivacyPolicy | bit | Display the privacy policy link information on the shopping cart form
RequestForAccessTermsOfUse | bit | Display terms of use information on the access request form
RequestForAccessCopyright | bit | Display copyright information on the access request form
RequestForAccessContactInfomation | bit | Display contact information on the access request form
RequestForAccessPrivacyPolicy | bit | Display privacy policy link information on the access request form
DownloadTermsOfUse | bit | Display terms of use information on the download form
DownloadCopyright | bit | Display copyright information on the download form
DownloadContactInfomation | bit | Display contact information on the download form
DownloadPrivacyPolicy | bit | Display privacy policy link information on the download form
RequireEmailAddress | bit | Email address information required for Access requests.
RequirePhoneVoice1 | bit | Patron phone information required for access requests.
RequireAddressType2 | bit | Mailing address required for access requests.
EmailFrom | nvarchar(4000) | The e-mail from address on an access request e-mail. Defaults to the value defined on the system level.
ReplyTo | nvarchar(4000) | The e-mail address reply to for PAC access request e-mail messages.
EmailFooter | nvarchar(4000) | The footer for the access request e-mail. Customizable. This defaults to the entry defined on the system. level.


MRMS_CopyRightClearanceProviders

MRMS_CopyRightClearanceProviders Table

For Future Use: Copyright clearance provider information for the Polaris Fusion Application

Columns

Column name | Data type | Description
CopyRightClearanceProviderID | int | A unique ID for this provider
CopyRightClearanceProviderDescription | nvarchar(80) | A description
CopyRightClearanceProviderCustomerID | nvarchar(255) | The customer ID
CopyRightClearanceProviderURL | nvarchar(255) | The URL of the provider
CopyRightClearanceProviderTerm | bit | The term
CopyRightClearanceProviderPassKey | nvarchar(255) | The Clearance provider password
CopyRightClearanceProviderNote | nvarchar(4000) | A general note describing the provider

See Also

MRMS_CopyrightTypes,


MRMS_CopyrightTypes

MRMS_CopyrightTypes Table

Copyright type for the Polaris Fusion Application

Columns

Column name | Data type | Description
CopyrightTypeID | int | The uniquie ID of the Copyright type.
SupplierID | int | The supplier ID holding the copyright for this resource.
CopyrightTypeDescription | nvarchar(80) | A Description of the copyright type
Expiration | datetime | The expiration date of the copyright
OpenURLResouce | bit | For Future use: Determines if the resource uses OpenURL
RightsConnectResouce | int | For Future use: Determines if the resource uses the Rights connect web service.
CopyRightClearanceProviderID | int | For Future Use: The Clearance Provider ID

See Also

MRMS_ResourceFileEntries,


MRMS_Default_ThumbnailTypes

MRMS_Default_ThumbnailTypes Table

A table describing the 'default' thumbnail types for the PolarisFusion Application. These thumbnails are assigned when a user does not generate a thumbnail in the Polaris Fusion application.

Columns

Column name | Data type | Description
ThumbNailID | int | The unique ID for the thumbnail type.
ThumbNailDescription | nvarchar(80) | A description of the thumbnail type
ThumbNailFileName | nvarchar(80) | The filename of the thumbnail.

See Also

MRMS_ResourceMIMETypes,


MRMS_EnrichedDataLinkDescriptions

MRMS_EnrichedDataLinkDescriptions Table

A table that stores the user defined enriched datalink language. Used by the Polaris Fusion application.

Columns

Column name | Data type | Description
DataLinkDescriptionID | int | A unique ID for the description.
DataLinkDescription | nvarchar(80) | The description that appears in PAC.

See Also

MRMS_ResourceFileEntries,


MRMS_GlobalSearchTypes

MRMS_GlobalSearchTypes Table

The ERMS global search types leveraged by the Polaris Fusion application.

Columns

Column name | Data type | Description
SearchType | int | The type of search
SearchTypeDescription | nvarchar(80) | A description for the search.
ERMSType | nvarchar(80) | The ERMS type.

See Also

MRMS_Searches,


MRMS_ImportSource_AllowedIndexes

MRMS_ImportSource_AllowedIndexes Table

The allowed indexes for ERMS import searches. Leveraged by the Polaris Fusion application.

Columns

Column name | Data type | Description
TargetID | int | The ERMS target.
IndexType | int | What type of index


MRMS_MarcToDCTagMap

MRMS_MarcToDCTagMap Table

MARC tag to Dublic core mapping table leveraged by the Polaris Fusion OAI/PMH provider application.

Columns

Column name | Data type | Description
MarcToDCID | int | The Unique ID
MarcToDCTypeID | int | The Type ID
TagNumber | int | The tag number
BibliographicSubfieldRestriction | char | Any subfield restriction
BibliographicSubfieldFFStart | int | the subfield start determination
BibliographicSubfieldFFEnd | int | The subfield determination
BibliographicFFFlag | bit | The Bib flag.
BibliographicRestrictedTag | bit | If the tag is restricted.


MRMS_MarcToDCTypes

MRMS_MarcToDCTypes Table

The Marc to DC types table. This table helps to crosswalk records from MARC21 to unqualified Dublin Core XML

Columns

Column name | Data type | Description
MarcToDCTypeID | int | The unique ID
Description | nvarchar(255) | A description of the type

See Also

MRMS_MarcToDCTagMap,


MRMS_OAIPMHProviderDefaults

MRMS_OAIPMHProviderDefaults Table

The Polaris Fusion OAI/PMH Provider default table. Used to supply vales exposed by the OAI-PMH identify verb, and set up various defaults.

Columns

Column name | Data type | Description
PowerPACURL | nvarchar(4000) | The PowerPAC URL
MaxRecordResponse | int | The maximum number of records per responce
StartHour | int | for future use
EndHour | int | for future use
StartMinute | int | for future use
EndMinute | int | for future use
BrandingURL | nvarchar(4000) | The URL that provides branding information for the OAI/PMH provider
BrandingIcon | nvarchar(4000) | The Branding ICON defined by the site
GatewayAdminEmail | nvarchar(4000) | The responsible party e-mail
GatewayURL | nvarchar(4000) | The URL of the provider
GatewayDescriptionURL | nvarchar(4000) | A description of the provider
ResumptionTokenExpirationInterval | int | How long until resumption tokens expire
AboutUS | nvarchar(4000) | A breif description of the repository.
RepositoryName | nvarchar(4000) | The Name of the repository
AllowListrRecords | bit | Allows the listrecords verb action.
AllowListIdentifiers | bit | Allows the listidentifiers verb action.
AllowListSets | bit | Allows the listsets verb action.
AllowGetRecord | bit | Allows the getrecord verb action
AllowListMetaDataFormats | bit | Allows the listmetadataformats verb action.
TimeRestriction | bit | for future use
IsActive | bit | Indicates of the provider is active


MRMS_OAIPMHResumptionTokens

MRMS_OAIPMHResumptionTokens Table

Polaris Fusion resumption tokens - Applies to the Fusion OAI-PMH provider

Columns

Column name | Data type | Description
ResumptionToken | nvarchar(450) | The Token
ExpirationDate | datetime | The expiration date/time of the resumption token
BID | int | The bibliographic record ID
MetadataFormat | nvarchar(4000) | The Metadata format for which the resumption token was granted.


MRMS_PowerPacInlineBehavior

MRMS_PowerPacInlineBehavior Table

Polaris Fusion table that determines the inline behavior of digital assets in PowerPAC

Columns

Column name | Data type | Description
InlineBehavior | int | A unique ID
InlineBehaviorDescription | nvarchar(80) | A description of the behavior

See Also

MRMS_ResourceMIMETypes,


MRMS_Repositories

MRMS_Repositories Table

A table that defines the Polaris Fusion repositories at the site. for Phase I only a single private/public repository is allowed.

Columns

Column name | Data type | Description
RepositoryID | int | The ID of the repository
BaseURL | nvarchar(1000) | The base URL of the repository
RepositoryDescription | nvarchar(80) | A description of the repository
RepositoryGUID | nvarchar(36) | The unique GUID of the repository
PhysicalPath | nvarchar(1000) | The Physical path to the public repository
ACLPhysicalPath | nvarchar(1000) | The physical path to private repository
RepWebServiceURL | nvarchar(1000) | The web service URL for the repository
ServerName | nvarchar(1000) | The server name on which the repository resides.

See Also

MRMS_RepositoryCollections,


MRMS_RepositoryCollections

MRMS_RepositoryCollections Table

Polaris Fusion collections.

Columns

Column name | Data type | Description
RepositoryCollectionID | int | The unique ID of the collection.
RepositoryID | int | The repository to which the collection belongs.
RepositoryCollectionDescr | nvarchar(80) | The description of the collection
OAICrawlable | bit | Indicates of the collection is an OAI/PMH set
PubliclyAvailable | bit | For future use
AuthenticationMethodID | int | The authentication method used by the collection.
DisplayInPAC | bit | For Future use
DefaultPrice | money | The default price assigned to ACL items.
MaximumDownloads | int | The maximum number of times a file under access list control may be downloaded by the patron.

See Also

MRMS_ResourceRecords,


MRMS_ResourceAuthenticationMethods

MRMS_ResourceAuthenticationMethods Table

The Authentication methods used by Polaris Fusion collections.

Columns

Column name | Data type | Description
AuthenticationMethodID | int | The unique ID of the authentication method.
AuthenticationMethodDescription | nvarchar(80) | A description of the authentication method.
FailureMethodID | int | For future use.
IsPublic | bit | Indicates of the authentication method is 'publicly availible no authentication required.
OpenIDAccessable | bit | For future use

See Also

MRMS_RepositoryCollections, MRMS_ResourceAuthenticationPatronOrganizations, MRMS_ResourceAuthenticationPowerPACOrganizations,


MRMS_ResourceAuthenticationPatronCode

MRMS_ResourceAuthenticationPatronCode Table

The patron code aspect of the authentication method matrix.

Columns

Column name | Data type | Description
AuthenticationMethodID | int | The authentication method ID
PatronCodeID | int | The patron code ID


MRMS_ResourceAuthenticationPatronOrganizations

MRMS_ResourceAuthenticationPatronOrganizations Table

The patron code aspect of the authentication method matrix.

Columns

Column name | Data type | Description
AuthenticationMethodID | int | The Authentication method ID
OrganizationID | int | The Patrons branch.


MRMS_ResourceAuthenticationPowerPACOrganizations

MRMS_ResourceAuthenticationPowerPACOrganizations Table

The PowerPac element used in the Polaris Fusion Resource authentication matrix

Columns

Column name | Data type | Description
AuthenticationMethodID | int | The authentication method ID
OrganizationID | int | The PowerPAC organization ID


MRMS_ResourceFailureMethods

MRMS_ResourceFailureMethods Table

For future use

Columns

Column name | Data type | Description
FailureMethodID | int | A unique ID of the failure method
FailureMethodDescription | nvarchar(80) | The description
RedirectURL | nvarchar(1000) | The URL of redirection.
FailureMessage | nvarchar(1000) | The failure message.

See Also

MRMS_ResourceAuthenticationMethods,


MRMS_ResourceFileEntries

MRMS_ResourceFileEntries Table

The digital files associated with Polaris Fusion content.

Columns

Column name | Data type | Description
ResourceFileID | int | The unique ID of the file.
ResourceRecordID | int | The resource record to which the file is attached.
MimeTypeID | int | The MIME type of the file
DataLinkDescriptionID | int | The datalink description ID
CopyrightTypeID | int | The copyright type ID
ExtendedDataLinkDescr | nvarchar(80) | An extended description created by the user
RRFileName | nvarchar(500) | The file name
RRURL | nvarchar(500) | A URL instead of the file name
IsPrimary | int | Indicates if this is the primary resource.
UsesACL | int | Indicates of the file is under access control. In which case the file lives in the provate repository.
Price | money | The price of the item.
IsPurchasable | bit | Allow this item to be purchased in the PAC (Only if the item is under ACL control)
AllowPACRequests | bit | Allow requests for this item in the PAC (Only if the item is under ACL control)

See Also

MRMS_ACL_UserList,


MRMS_ResourceLinks

MRMS_ResourceLinks Table

This table links a Polaris Fusion resource record to a Bib

Columns

Column name | Data type | Description
BibliographicRecordID | int | The bib ID to which the resource record id linked.
ResouceRecordID | int | The ID of the resource record.


MRMS_ResourceMIMETypes

MRMS_ResourceMIMETypes Table

A polaris Fusion MIME type definition table.

Columns

Column name | Data type | Description
MimeTypeID | int | The unique ID of the MIME type.
Extension | nvarchar(12) | The file extension
ContentType | nvarchar(80) | The MIME content type
SubType | nvarchar(100) | The MIME sub-type
InlineBehavior | int | How this kind of file behaves in-line in PowerPAC.
ThumbNailID | int | The default ThumbNail ID associated with the MIME type.

See Also

MRMS_ResourceFileEntries,


MRMS_ResourceRecords

MRMS_ResourceRecords Table

A table containing the Polaris Fusion Resource records.

Columns

Column name | Data type | Description
ResourceRecordID | int | The unique ID of the resource record.
RepositoryCollectionID | int | The collection to which the resource record belongs.
OrganizationID | int | The organization that owns the record.
BibliographicRecordID | int | The BIB to which the resource record is attached.
MRMSDesciption | nvarchar(80) | A description of the resource record.
PublicNote | nvarchar(1000) | The Public Note
RightsNote | nvarchar(1000) | The rights note
ProvenanceNote | nvarchar(1000) | The provenance Note.
NonPublicNote | nvarchar(1000) | The non-Public Note.

See Also

MRMS_ResourceFileEntries, MRMS_ResourceLinks,


MRMS_Searches

MRMS_Searches Table

The ERMS searches used by Polaris Fusion.

Columns

Column name | Data type | Description
SearchID | int | The unique ID of the ERMS search
Indextype | int | The Index type.
SearchType | int | The type of the ERMS search.
SearchDescription | nvarchar(80) | A description of the search
ERMSpredicate | nvarchar(80) | The ERMS predictate
AutoTruncation | bit | Indicates if the ERMS search should automatically truncate the search terms.


MRMS_SearchIndexTypes

MRMS_SearchIndexTypes Table

The ERMS index types used by Polaris Fusion.

Columns

Column name | Data type | Description
IndexType | int | They type associated with the index
IndexDescription | nvarchar(80) | A description of the index
ERMSMnemonic | nvarchar(20) | The ERMS Mnemonic
MarcType | int | The MARC type associated with the Index (BIB,Auth)

See Also

MRMS_ImportSource_AllowedIndexes, MRMS_Searches,


MRMS_SearchMARCTypes

MRMS_SearchMARCTypes Table

Polaris Fusion ERMS MARC types

Columns

Column name | Data type | Description
MARCType | int | The MARC type for ERMS searching.
MARCTypeDescription | nvarchar(80) | The Description of the MARC type.
Menomic | nvarchar(80) | The ERMS mnemonic

See Also

MRMS_SearchIndexTypes,


MRMS_ShoppingCart

MRMS_ShoppingCart Table

The Polaris Fusion shopping cart table.

Columns

Column name | Data type | Description
ShoppingCartID | int | A unique ID for the shopping cart.
PatronID | int | The ID of the patron who owns the shopping cart.
PatronFullName | nvarchar(100) | The Patrons full name
CartDescription | nvarchar(80) | A verbose description of the cart, system assigned.
CreationDate | datetime | The creation date of the cart
PurchaseDate | datetime | The date of checkout.
ShoppingCartTotal | money | The total amount purchased on checkout.
HasBeenPurchased | bit | Indicates if the items in the cart hve been purchased.
ShoppingCartPreTaxTotal | money | The pre-tax total of all items that the shopping cart contains.
ShoppingCartTaxTotal | money | The total tax calculated on the shopping cart.

See Also

MRMS_ShoppingCartItems, MRMS_ShoppingCartTaxDetail,


MRMS_ShoppingCartItems

MRMS_ShoppingCartItems Table

The table that contains the individual items in the shopping cart.

Columns

Column name | Data type | Description
ShoppingCartID | int | The shopping cart in thich this item resides.
ResourceFileID | int | The item purchased.
RRFileName | nvarchar(500) | The file name.
RRDescription | nvarchar(80) | The verbose description of the item.
Price | money | The proce of the item.


MRMS_ShoppingCartTaxDetail

MRMS_ShoppingCartTaxDetail Table

Tax detail lines for Polaris Fusion shopping carts

Columns

Column name | Data type | Description
TaxDetailID | int | Primary Key. A unique ID for the detail line
ShoppingCartID | int | The ID of the shopping cart for which the tax was calculated
TaxTypeID | int | The tax type.
CreationDate | datetime | Date the tax detail was created
TaxAmount | money | The amount of the tax
TaxableAmount | money | The taxable amount on which the tax was calculated


MRMS_StaffTermsOfUseAcceptance

MRMS_StaffTermsOfUseAcceptance Table

A table for Polaris Fusion that holds a record of staff accepting the terms of use for the Fusion application

Columns

Column name | Data type | Description
PolarisUserID | int | The User ID of the staff member
AcceptanceDate | datetime | The date that the staff member acceped the terms of use
Version | nvarchar(20) | The Polarisdbversion for which the acceptance applies
AcceptanceStatus | bit | Indicates if the staff member accepted or declined: 0 = declined 1 = accepted


MRMS_Targets

MRMS_Targets Table

Polaris fusion ERMS targets.

Columns

Column name | Data type | Description
TargetID | int | The ID of the ERMS target
TargetTypeID | int | They Type id of the ERMS target
TargetServer | nvarchar(255) | Ther server ID of the ERMS target.
TargetURL | nvarchar(255) | The URL of the ERMS target.
TargetDescription | nvarchar(80) | The description of the ERMS Target
TargetOrd | int | An Ordinal
IsImportSource | bit | Indicates if this ERMS target is for the import of records into Polaris.

See Also

MRMS_ImportSource_AllowedIndexes,


MRMS_TargetTypes

MRMS_TargetTypes Table

Polaris fusion ERMS target types.

Columns

Column name | Data type | Description
TargetTypeID | int | They Type of the target.
TargetBaseURL | nvarchar(255) | The Base URL of the target
TargetDescription | nvarchar(255) | A description of the target.

See Also

MRMS_Targets,


MRMS_TaxTypes

MRMS_TaxTypes Table

A table to transalate tax types for Polaris Fusion, primarily used for reporting purposes.

Columns

Column name | Data type | Description
TaxTypeID | int | Primary Key. The ID of the tax type.
Description | nvarchar(80) | A description of the tax type.

See Also

MRMS_ShoppingCartTaxDetail,


MRMS_TermsOfUseLanguage

MRMS_TermsOfUseLanguage Table

A Table defining the terms of use that appears for a patron when retreiving items under access list control.

Columns

Column name | Data type | Description
LanguageID | int | The ISO Language ID
TermsOfUse | nvarchar(-1) | The terms of use language


MRMS_UserRecordSetAssignments

MRMS_UserRecordSetAssignments Table

A table to track polarisusers and their assigned record set for bibliographic record creation in Polaris Fusion

Columns

Column name | Data type | Description
PolarisUserID | int | The users Polaris UserID
RecordSetID | int | The record set ID assigned
RecordSetName | nvarchar(50) | The name of the record set


MRMS_WebLinks

MRMS_WebLinks Table

The Polaris Fusion thumbnail entries.

Columns

Column name | Data type | Description
BibliographicRecordID | int | The bib ID
WebLink | nvarchar(4000) | The Thumbnail URL


MRMS_WorkFormFields

MRMS_WorkFormFields Table

A table holding The fields for Polaris Fusion templates.

Columns

Column name | Data type | Description
MRMSWorkFormFieldID | int | The unique field ID
MRMSWorkformID | int | The template that uses this MARC field
WorkFormFieldOrd | int | The field ordinal
WorkFormFieldTypeID | int | The kind of field (MARC)
WorkFormFieldLabel | nvarchar(80) | The label used on the template.
WorkFormFieldDefault | nvarchar(4000) | The default text for that tempate field.


MRMS_WorkFormFieldTypes

MRMS_WorkFormFieldTypes Table

The various field types for use with Polaris Fusion templates.

Columns

Column name | Data type | Description
WorkFormFieldTypeID | int | The unique ID of the field
DCElement | nvarchar(160) | The Dublin core element.
DCQualifier | nvarchar(160) | The MARC qualifier.
TagNumber | int | The MARC tag number
Subfield | char | The MARC subfield
FieldRepeatable | bit | For future use
FieldRequired | bit | Idicates if the field is required on all templates.
FieldAuthority | bit | Indicates if the field is under authority control.
IndicatorOne | char | The first Indicator Value
IndicatorTwo | char | The second indicator value

See Also

MRMS_WorkFormFields,


MRMS_Workforms

MRMS_Workforms Table

Polaris Fusion Templates.

Columns

Column name | Data type | Description
MRMSWorkformID | int | The unique ID of the template
MRMSWorkFormDescription | nvarchar(120) | The desciption of the template
MRMSWorkFormNote | nvarchar(4000) | A note regarding the template
MRMSWorkFormMaxAuthHits | int | The max number of authority hits
DisplayInPAC | bit | Indicates if, by default, bibs created from the template will display in PAC.

See Also

MRMS_WorkFormFields,


MultiLingualStrings

MultiLingualStrings Table

This table holds the 'Language String' values of all mutli-lingual database entries. This is different from the AdminLanguageStrings table because that one links to an SA value, while this will just be a text entry in a database table. An example of this would be the ChildPAC_Categories table, which contains a StringID for each string needing translation.

Columns

Column name | Data type | Description
StringID | int | ID of the string used in other database tables to reference a multi-lingual string.
LanguageID | int | Links to AdminLanguages
Value | nvarchar(500) | Actual multi-lingual string value.


NameTitles

NameTitles Table

Contains one row for each patron name title

Columns

Column name | Data type | Description
NameTitleID | int | Unique identifier
Description | nvarchar(8) | Text description of the patron name title
Display | bit | Boolean indicating if value should show for all patrons

See Also

PatronRegistration,


NCIPAcademicPrivs

NCIPAcademicPrivs Table

This is a static table of NCIP Academic User Privilege Types. It is used in conjunction with the table PatronCodes_NcipPrivs to map Polaris Patron Codes to its NCIP "equivalent". The values are defined in the NCIP standard document under: "NCIP Agency User Privilge Type Academic Scheme".

Columns

Column name | Data type | Description
NCIPAcademicPrivID | int | Unique Identifier. Every user privilege will have its own ID value. This value is to be used in the NCIPAcademicPrivID column of the PatronCode_NcipPrivs table.
NCIPAcademicDesc | nvarchar(-1) | This column holds the NCIP static values that are to be mapped to a Polaris patron codes. The values are: Faculty, Graduate, Post Doctoral, Staff, Undergraduate.

See Also

PatronCodes_NCIPPrivs,


NCIPFiscalActionTypes

NCIPFiscalActionTypes Table

The NCIPFiscalActionTypes table allows us to logically map the NCIP Fiscal Action Types (See NISO Z3983 Part 2 pp. 14, 30) to Polaris Transaction codes from the PatronAccTxnCodes table.

Columns

Column name | Data type | Description
FiscalActionTypeID | int | This is just an identity column that enumerates the descriptions.
Description | nvarchar(80) | The NCIP Standard gives us several fiscal actions such as: Assess, Cancel, Forgive, ... etc. The textual values are located in this field.
TxnCodeID | int | This column maps the NCIP Fiscal Action Type in the description field to the equivelant Polaris PatronAccTxnCodes value.


NCIPMediumTypes

NCIPMediumTypes Table

this table defines the standard NCIP Medium Types per the values defined in the standard. NCIP defines a set of Medium Types (like 'Book') which we have to map to our Polaris MaterialTypes.

Columns

Column name | Data type | Description
NCIPMediumTypeID | int | The first column is an identity value Primary Key
Description | nvarchar(80) | The second column is the NCIP Value which is defined in the standard. It is unique and should have in index since I’ll be looking up a Polaris MaterialType from this description. Here are the standard Medium Types: Audio Tape Blu-ray Book Book With Audio Tape Book With Compact Disc Book With Diskette Bound Journal CD-ROM Compact Disc (CD) Diskette DVD Magazine Microform Video Tape The NCIP client application will send us a 'Book' to circulate to one of our patrons. I’ll be doing a SELECT MaterialTypeID FROM Polaris.NCIPMediumTypes WITH (NOLOCK) WHERE Description = 'Book'
StandardMediumType | bit | StandardMediumType, is a Boolean or bit value to indicate that the corresponding description (column) is a standard value. I know that Prospector uses non-standard MediumTypes which will be added to the table. Non-standard values will be false or 0.
MaterialTypeID | int | The fourth column, MaterialTypeID, is used to map the MediumType to a Polaris MaterialTypeID from the Polaris.MaterialTypesTable. There is a foreign key constraint on this value to ensure that the value is in the Polaris.MaterialTypes table. Perhaps the default value should not be NULL and default to 1-Book if it can be guaranteed.

See Also

SA_NCIPMediumTypes_Incoming, SA_NCIPMediumTypes_Outgoing,


NCIPPaymentTypes

NCIPPaymentTypes Table

The NCIPPaymentTypes table allows us to logically map the NCIP Payment Method Types(See NISO Z3983 Part 2 pp. 16, 32, 33) to Polaris Payment Methods from the PatronPaymentMethods table.

Columns

Column name | Data type | Description
PaymentTypeID | int | This is just an identity column that enumerates all the descriptions.
Description | nvarchar(80) | The NCIP Standard gives us several Payment Method Types such as: Cash, Check, Credit Card, Debit Card, ... etc. The textual values are located in this field.
PaymentMethodID | int | This column maps the NCIP Payment Method Types in the description field to the equivelant Polaris PatronPaymentMethods value.


NCIPPublicPrivs

NCIPPublicPrivs Table

This is a static table of NCIP Public User Privilege Types. It is used in conjunction with the table PatronCodes_NcipPrivs to map Polaris Patron Codes to its NCIP "equivalent". The values are defined in the NCIP standard document under: "NCIP Agency User Privilege Type Public Scheme".

Columns

Column name | Data type | Description
NCIPPublicPrivID | int | Unique Identifier. Every user privilege will have its own ID value. This value is to be used in the NCIPPublicPrivID column of the PatronCode_NcipPrivs table.
NCIPPublicDesc | nvarchar(-1) | This column holds the NCIP static values that are to be mapped to a Polaris patron codes. The values are: Adult, Child, Senior, Staff, Young Adult.

See Also

PatronCodes_NCIPPrivs,


NetworkDomains

NetworkDomains Table

Contains one row for each network domain that will be associated with a Polaris user and/or workstation.

Columns

Column name | Data type | Description
NetworkDomainID | int | Unique identifier for the network domain.
NetBIOSName | nvarchar(255) | Identifies the NetBIOS name.
DNSName | nvarchar(255) | Identifies the DNS name.

See Also

PolarisUsers, Workstations,


NormalizationParameters

NormalizationParameters Table

Table which lists which MARC subfields are normalized according to which normalization rules

Columns

Column name | Data type | Description
TagNumber | smallint | Tag number which contains subfield to be normalized
SubfieldCode | char | Subfield to be normalized
NormalizationSchemeID | smallint | Link to schemes table
IndicatorOne | char | The indicator one value for this tag (for normalization purposes)
IndicatorTwo | char | The indicator two value for this tag (for normalization purposes)


NormalizationSchemes

NormalizationSchemes Table

The normalization schemes are coded and listed in this table.

Columns

Column name | Data type | Description
NormalizationSchemeID | smallint | Primary key - code
Description | nvarchar(50) | The free text normalization type

See Also

MARCMaterializationRules, NormalizationParameters,


NotificationStatuses

NotificationStatuses Table

Overdue notice status type

Columns

Column name | Data type | Description
NotificationStatusID | int | Primary key
Description | nvarchar(255) | notification status brief description


NotificationTypes

NotificationTypes Table

Overdue notification type

Columns

Column name | Data type | Description
NotificationTypeID | int | Primary key
Description | nvarchar(80) | notification type brief description


NSDatesNotToCall

NSDatesNotToCall Table

Used by the Phone Notification Subsystem as a filter for Dates not to notify.

Columns

Column name | Data type | Description
OrganizationID | int | Organization that the date specified will not call on.
DateNotToCall | datetime | Date not to call


NSLocalAreaCodes

NSLocalAreaCodes Table

Used by the Phone Notification Subsystem to specify area codes that do not charge long distance fees and are considered local calls still.

Columns

Column name | Data type | Description
OrganizationID | int | Organization that the area code specified is considered local.
LocalAreaCode | int | The area code that is considered a local call.


NSLocalPrefixes

NSLocalPrefixes Table

Used by the Phone Notification Subsystem to specify phone number prefixes (first 3 numbers in a 7 digit phone number) that do not charge long distance fees and are considered local calls.

Columns

Column name | Data type | Description
OrganizationID | int | Organization that the phone number prefix specified is considered local.
LocalPrefix | int | The 3 digit phone number prefix (out of the total 7 digits) that is considered a local call.


NSMDomains

NSMDomains Table

Contains one row for each domain.

Columns

Column name | Data type | Description
DomainID | smallint | Unique identifier of the domain.
Name | sysname | Name of the domain.

See Also

MARCConcatenationRules, MARCMaterializationRules, MARCRecordFormats, NSMPresentationSchemes,


NSMEntities

NSMEntities Table

Contains one row for each distinct entity.

Columns

Column name | Data type | Description
EntityID | smallint | Unique identifier of the entity.
Name | sysname | Name of the entity.


NSMLevels

NSMLevels Table

Contains one row for each level within a domain. The combination of DomainID and LevelID is unique for each row.

Columns

Column name | Data type | Description
DomainID | smallint | Unique identifier of the domain.
LevelID | tinyint | Unique identifier of the level within the scope of the domain.
EntityID | smallint | Unique identifier of the entity used to represent the hierarchical root.
Description | nvarchar(255) | Descriptive name of the level.

See Also

MARCLevelizationRules,


NSMPresentationAspects

NSMPresentationAspects Table

Contains one row for each presentation aspect.

Columns

Column name | Data type | Description
PresentationAspectID | smallint | Unique identifier of the presentation aspect.
Name | sysname | Unique name of the presentation aspect.

See Also

NSMPresentationTemplates,


NSMPresentationLayouts

NSMPresentationLayouts Table

Contains one row for each presentation layout.

Columns

Column name | Data type | Description
PresentationLayoutID | smallint | Unique identifier of the presentation layout.
Name | sysname | Unique name of the presentation layout.

See Also

NSMPresentationTemplates,


NSMPresentationPredicates

NSMPresentationPredicates Table

Contains one row for each presentation predicate in the scope of a presentation scheme, organization and entity path.

Columns

Column name | Data type | Description
IsDefault | bit | Flag indicating whether the presentation predicate is the system default.
OrganizationID | int | Unique identifier of the organization associated with the presentation predicate.
PresentationSchemeID | int | Unique identifier of the presentation scheme.
PresentationRuleID | int | Unique identifier of the presentation rule.
LevelID | tinyint | Unique identifier of the level.
ZoneIndex | smallint | Unique number representing the primary/secondary zone in which the entity should display.
DisplayOrder | smallint | Order in which the entity will display.
IsFixedDisplayOrder | bit | Flag indicating whether the display order is fixed.
IsLabelVisible | bit | Flag indicating whether the entity's label should be visible.
IsSuppressed | bit | Flag indicating whether the entity should be suppressed in the configuration dialog.
IsHidden | bit | Flag indicating whether to hide the entity label and value from the view. This column only applies to sub-entities.
IsHiddenOnSmallScreen | bit | Flag to indicate if the presentation predict is hidden on small screens.


NSMPresentationRules

NSMPresentationRules Table

Contains one row for each presentation rule in the scope of a presentation scheme and organization.

Columns

Column name | Data type | Description
PresentationRuleID | int | Unique identifier of the presentation rule.
PresentationSchemeID | int | Unique identifier of the presentation scheme.
EntityPath | hierarchyid | Identifies an entity path.
IsContainer | bit | Flag indicating whether the entity-path contains other entities.
CanShowLabel | bit | Flag indicating whether an entity can be displayed with a label.
MustShowLabel | bit | Flag indicating that the entity-path must be displayed with a label.
RelativePosition | smallint | Relative position of the entity-path relative to it's siblings. This column is ignored when the parent of the entity path is the root of the hierarchy tree.
GroupTemplateNameWithLabel | sysname | Group template name to use when an entity is to be displayed with a label.
GroupTemplateNameWithoutLabel | sysname | Group template name to use when an entity is to be displayed without a label.
SubzoneTemplateName | sysname | Subzone template name to use when the entity-path contains other entities.
SubitemTemplateName | sysname | Subitem template name to use when the entity-path contains other entities.
IsFixedRelativePosition | bit | Flag indicating whether the relative position is fixed. This column only applies to sub-entities.

See Also

NSMPresentationPredicates,


NSMPresentationSchemes

NSMPresentationSchemes Table

Contains one row for each presentation scheme.

Columns

Column name | Data type | Description
PresentationSchemeID | int | Unique identifier of the presentation scheme.
ProductID | int | Unique identifier of the product.
DomainID | smallint | Unique identifier of the domain.
PresentationViewID | smallint | Unique identifier of the presentation view.
RecordTemplateName | sysname | Record template name to use for the record.
PrimaryZoneTemplateName | sysname | The zone template name to use when rendering the first zone within a record.
SecondaryZoneTemplateName | sysname | The zone template name to use for all but the first zone within a record.
ItemDelimiter | nvarchar(16) | Specifies a string that will be used to delimit multiple entity values when rendering text for the brief or summary (NSM) view.

See Also

NSMPresentationPredicates, NSMPresentationRules,


NSMPresentationTemplates

NSMPresentationTemplates Table

Contains one row for each template defined within the scope of a product.

Columns

Column name | Data type | Description
ProductID | int | Unique identifier of the product associated with the presentation template.
PresentationLayoutID | smallint | Unique identifier of the presentation layout associated with this presentation template.
PresentationAspectID | smallint | Unique identifier of the presentation aspect associated with this presentation template.
TemplateName | sysname | Unique name of the presentation template.
InnerLayout |  | XML fragment containing HTML markup, stencil macros, and/or recursive pre-processing instructions.
HasApplyTemplates | bit | Flag indicating whether the InnerLayout contains any recursive pre-processing instructions (i.e. ).


NSMPresentationViews

NSMPresentationViews Table

Contains one row for each presentation view.

Columns

Column name | Data type | Description
PresentationViewID | smallint | Unique identifier of the presentation view.
Name | sysname | Name of the presentation view.

See Also

NSMPresentationSchemes,


NSMRegistry

NSMRegistry Table

Contains one row for each distinct entity path available within the scope of a domain.

Columns

Column name | Data type | Description
DomainID | smallint | Unique identifier of the domain.
EntityPath | hierarchyid | Unique identifier of the entity path.
LevelFlags | int | Restricts the entity path to a domain specific set of levels (e.g. the Bibliographic domain has two levels: Bibliographic and Serial).
IndexKey | char | Browse index key name to be cross-referenced with the underlying materialization rules at runtime.
IsCustom | bit | Flag indicating whether the entity path can be customized by the end user.
Description | nvarchar(255) | Descriptive name of the last entity in the entity path.
LabelMnemonic | nvarchar(100) | Multilingual string representing the label for the entity path.
BaseEntityPath | hierarchyid | Unique identifier of the base entity path. The base entity path equals the first entity in the EntityPath column.
CanConditionallySuppress | bit | Flag to indicate NSM entity can be suppressed.
AttributeValue | int | Specifies the Bib-1 use attribute associated with the entity path.


ObjectLocks

ObjectLocks Table

This table is used to indicate ownership of an active object within Polaris.

Columns

Column name | Data type | Description
ObjectTypeID | int | References ObjectTypes
ObjectID | int | ID of the object that is locked
PolarisUserID | int | Owner of the lock. References PolarisUsers table
LockDate | datetime | Date of lock
WorkstationID | int | The workstation who locked the object


ObjectTypes

ObjectTypes Table

This holds the enumerated values for each type of record. They should be set up as follows for constant data items:

Columns

Column name | Data type | Description
ObjectTypeID | int | Primary key - code
Description | nvarchar(80) | Free text description of the objects

See Also

Claims, FindTool_SaveDefaultSearchDatabases, FindToolSavedSearches, FindToolSearchObjects, FindToolSortBys, ImportJobsNoRecordCreated, ObjectLocks, PersonalSearchSettings, RecordSets, RouteListPieces, VegaDataSyncQueue, WebObjectLocks,


OfflinePolItem_ItemRecords

OfflinePolItem_ItemRecords Table

A table that has the list of item records in the system that can eventually be used by offline processing.

Columns

Column name | Data type | Description
ItemRecordID | int | item record ID
Barcode | nvarchar(20) | Item barcode
RecordStatusID | int | record status of item
CallNumber | nvarchar(255) | item call number
BrowseTitle | nvarchar(255) | Item's bib title
AssignedBranchID | int | Assigned Branch ID
MaterialTypeID | int | material type of item
ItemStatusID | int | item circ status ID


OfflinePolPatron_AddressLabels

OfflinePolPatron_AddressLabels Table

Contains one row for each address label for offline use

Columns

Column name | Data type | Description
AddressLabelID | int | Unique identifier
Description | nvarchar(255) | Text description of the address label
Display | bit | Boolean indicating if the label is always visible
DisplayOrder | int | Display order for Address Labels


OfflinePolPatron_NameTitles

OfflinePolPatron_NameTitles Table

Contains one row for each patron name title for offline purposes

Columns

Column name | Data type | Description
NameTitleID | int | Unique identifier
Description | nvarchar(255) | Text description of the patron name title
Display | bit | Boolean indicating if value should show for all patrons


OfflinePolPatron_PatronBlocks

OfflinePolPatron_PatronBlocks Table

This table stores the lookup values for the patronfreetextblocks entries. The combined values of the BlockID and PatronID make a unique entry in this table.

Columns

Column name | Data type | Description
BlockID | int | This is a non-identity valued column containing the BlockID that is used in the PatronFreeTextBlocks table.
PatronID | int | ID of patron.


OfflinePolPatron_PatronFreeTextBlocks

OfflinePolPatron_PatronFreeTextBlocks Table

This table stores the free text blocks a patron has.

Columns

Column name | Data type | Description
FreeTextBlock | nvarchar(255) | User entered text of the block.
PatronID | int | ID of patron who has the block. It references OfflinePolPatron_Patrons table (PatronID).


OfflinePolPatron_Patrons

OfflinePolPatron_Patrons Table

This table stores the basic information of patron records

Columns

Column name | Data type | Description
AmountOwed | money | Total charges on patron's account.
Barcode | nvarchar(20) | ID of patrons for circulation or patron service.
Claims | int | Overall number of claims the patron has made.
ItemsLongOverdue | int | The number of items that are long overdue.
ItemsOut | int | The number of items that are currently checked out.
ItemsOverdue | int | The number of items that are overdue.
Name | nvarchar(120) | The Patron's full name, last name first.
OrganizationID | int | ID of branch the patron registered at, references Polaris.Organizations (OrganizationID).
PatronID | int | ID of patron, internally used, is the primary key.
SystemBlocks | int | Will contain encoded data which will be retrieved on the bitwise level. 64 - block is set when patron self-registers via PAC 128 - block is set when patron clicks address update from PAC 256 - block is set when express registration is done from CheckOut WF 512 - block is set when patron is registered offline 1024 - block is set when patron account submitted to collection agency
UserName | nvarchar(50) | The patron's personally defined username established via the PAC.
Password | nvarchar(16) | This is the patron's password to get in PAC etc.
RecordStatusID | int | Record status identifier. Final or Secured


OfflinePolPatron_PatronStopDescriptions

OfflinePolPatron_PatronStopDescriptions Table

This table stores library defined patron blocks.

Columns

Column name | Data type | Description
Description | nvarchar(80) | Is the block description.
PatronStopID | int | Is the block ID, primary key.


OfflinePolSystem_AdminLanguages

OfflinePolSystem_AdminLanguages Table

This table holds all of the languages that the customer subscribes to with respect to multi-language capabilities in the PowerPAC. This table will contain at least one row to represent the 'English' language.

Columns

Column name | Data type | Description
AdminLanguageID | int | Unique identifier. Maps to the language code id in the syslanguages table on the master database. (1033 is the code for 'English')
Description | nvarchar(255) | Language label (eg. 'English', 'Spanish', ..., etc)
EnabledCPAC | bit | States whether this language will be enabled for the CPAC
EnabledExpressCheck | bit | States whether this language will be enabled for the Polaris ExpressCheck system
EnabledPowerPAC | bit | States whether this language will be enabled for the PowerPAC
Filename | nvarchar(255) | Associated translation file name.


OfflinePolSystem_Countries

OfflinePolSystem_Countries Table

Contains zipcode information for different countries.

Columns

Column name | Data type | Description
Country | nvarchar(32) | The country field
CountryID | int | Primary key
MinZipCodeLength | int | The minimum number of characters in any zip code for the particular country.
PostalCodeFormat | nvarchar(12) | Format of postal code
PostalCodeLength | int | The number of characters that can be present for a valid zip code.
StateRequired | bit | Whether the country requires the state for addresses.


OfflinePolSystem_CustomMultiLingualStrings

OfflinePolSystem_CustomMultiLingualStrings Table

This table contains customized representations of multi-lingual string values defined in the SA_DefaultMultiLingualStrings table, overriding the default values with the value defined in this table. An organizational context is also indicated so specific sites can tailor their own variation of a particular multi-lingual string for a given product and language if desired.

Columns

Column name | Data type | Description
StringID | int | Unique identifier - Primary key.
ProductID | int | Foreign key for the Products table - the Product this string is defined for.
LanguageID | int | Language identifier that indicates what language the string is in (1033 = English).
OrganizationID | int | Foreign key for the Organizations table - the Organizational context for this string is definition
Mnemonic | nvarchar(100) | A string mnemonic used to define the role the defined string represents
Value | nvarchar(4000) | The actual Unicode string value.


OfflinePolSystem_DefaultMultiLingualStrings

OfflinePolSystem_DefaultMultiLingualStrings Table

This table contains the default representation of all multi-lingual string values defined for the various Polaris products (from the Products table).

Columns

Column name | Data type | Description
StringID | int | Unique identifier - Primary key.
ProductID | int | Foreign key for the Products table - the Product this string is defined for.
LanguageID | int | Language identifier that indicates what language the string is in (1033 = English).
Mnemonic | nvarchar(100) | A string mnemonic used to define the role the defined string represents.
Value | nvarchar(4000) | The actual Unicode string value.
RequiresTranslation | bit | A bit field used to flag new strings that have been added since the last update (done periodically).


OfflinePolSystem_DeliveryOptions

OfflinePolSystem_DeliveryOptions Table

Defines the types of deliveries for correspondences to patrons. Entries in this table describe the data fields and processing to use in making the correspondence.

Columns

Column name | Data type | Description
DeliveryOption | nvarchar(50) | Is the description of the delivery method.
DeliveryOptionID | int | ID of the delivery method, primary key.


OfflinePolSystem_Genders

OfflinePolSystem_Genders Table

Contains one row for each gender for offline purposes

Columns

Column name | Data type | Description
OrganizationID | int | Unique identifier from the Organizations table
GenderID | int | Unique identifier from the Genders table
Description | nvarchar(255) | Text description of the gender
Display | bit | Bit indicating if the row is visible
DisplayOrder | int | Display sequence


OfflinePolSystem_ItemStatuses

OfflinePolSystem_ItemStatuses Table

The Polaris item statuses for offline file generation

Columns

Column name | Data type | Description
Description | nvarchar(80) | Description
ItemStatusName | nvarchar(25) | Used in circ processing
ItemStatusID | int | Item status ID


OfflinePolSystem_Languages

OfflinePolSystem_Languages Table

This table contains a list of languages as coded values.

Columns

Column name | Data type | Description
LanguageDesc | nvarchar(50) | Text description of language.
LanguageID | int | Primary key


OfflinePolSystem_MaterialTypes

OfflinePolSystem_MaterialTypes Table

Polaris material types table used in offline file generation.

Columns

Column name | Data type | Description
Description | nvarchar(80) | Description
MaterialTypeID | int | Material type ID


OfflinePolSystem_MobilePhoneCarriers

OfflinePolSystem_MobilePhoneCarriers Table

This table is populated from SA_MobilePhoneCarriers for offline database population purpose.

Columns

Column name | Data type | Description
CarrierID | int | Unique numeric identifier
CarrierName | nvarchar(255) | The display name for the phone carrier (eg. AT&T)
Email2SMSEmailAddress | nvarchar(255) | SMS (Short Message Service) address of the carrier (eg. @txt.att.net)
NumberOfDigits | smallint | Number of digits required in the phone number (not currently exposed - for future use)
Display | bit | A bit flag to indicate whether this carrier is allowable as an option (1 = Yes, 0 = No)


OfflinePolSystem_NetworkDomains

OfflinePolSystem_NetworkDomains Table

Contains one row for each network domain that will be associated with a Polaris user and/or workstation.

Columns

Column name | Data type | Description
NetworkDomainID | int | Unique identifier for the network domain.
NetBIOSName | nvarchar(255) | Identifies the NetBIOS name.
DNSName | nvarchar(255) | Identifies the DNS name.


OfflinePolSystem_OrganizationCodes

OfflinePolSystem_OrganizationCodes Table

Coded values of organization types (system, library, branch)

Columns

Column name | Data type | Description
Description | nvarchar(80) | The text description.
OrganizationCodeID | int | Primary key - code


OfflinePolSystem_Organizations

OfflinePolSystem_Organizations Table

A complete list of all Organizations in a Polaris system

Columns

Column name | Data type | Description
Abbreviation | nvarchar(15) | Used for many display purposes.
Name | nvarchar(50) | Name of the organization
OrganizationCodeID | int | Link to OrganizationCodes table.
OrganizationID | int | Primary key
ParentOrganizationID | int | Organizations form hierarchies in the form of system, library, branch. This element keeps track of which branches belong to which library, etc.
Special | int | Link to contact person (PolarisUserID) for this Organization.


OfflinePolSystem_PatronCodes

OfflinePolSystem_PatronCodes Table

This table stores patron codes and descriptions.

Columns

Column name | Data type | Description
Description | nvarchar(80) | Description of patron codes.
PatronCodeID | int | ID of patron code, primary key.


OfflinePolSystem_PatronCodesByOrg

OfflinePolSystem_PatronCodesByOrg Table

The patron codes that can display by organization used by offline processing.

Columns

Column name | Data type | Description
Description | nvarchar(80) | patron code description
PatronCodeID | int | Patron Code ID
OrganizationID | int | Branch the patron code can be displayed for


OfflinePolSystem_PatronStatClassCodes

OfflinePolSystem_PatronStatClassCodes Table

This table defines patron statistical class codes for each organization.

Columns

Column name | Data type | Description
Description | nvarchar(80) | String description of the statistical class code
OrganizationID | int | Foreign key column to Polaris..Organizations
StatisticalClassID | int | Unique identifier - Identity column


OfflinePolSystem_PolarisUsers

OfflinePolSystem_PolarisUsers Table

This table contains all of the users who are enabled to log onto the Polaris tech client.

Columns

Column name | Data type | Description
BranchID | int | Link to organizations table but is branch specific
Name | nvarchar(50) | Name of Polaris user
OrganizationID | int | Link to which organization user belongs to
PolarisUserID | int | Primary key
NetworkDomainID | int | Unique identifier of the network domain associated with the Polaris user.


OfflinePolSystem_PrinterControlCodeDefs

OfflinePolSystem_PrinterControlCodeDefs Table

This table stores all control code definition for the receipt printer drivers defined by user from Polaris TechClient SA Staff Client Profile "Receipt printer control codes".

Columns

Column name | Data type | Description
CodeID | int | Control code ID. This is a foreign key references PrinterControlCodes(CodeID).
Enabled | bit | Whether or not the control code is enabled for the printer.
EndCode | nvarchar(255) | Control code to cancel a property previously defined. All the characters in this field are ANSI characters.
PrinterID | int | Printer Driver ID. This is a foreign key references PrinterDrivers(PrinterID).
StartCode | nvarchar(255) | Control code to set a property. All the characters in this field are ANSI characters.


OfflinePolSystem_PrinterDrivers

OfflinePolSystem_PrinterDrivers Table

This table stores all the receipt printer drivers defined by user from Polaris TechClient SA Staff Client Profile "Receipt printer control codes".

Columns

Column name | Data type | Description
DriverName | nvarchar(255) | Printer driver's name. For example, Star TSP700.
PrinterID | int | Numeric ID of the driver.
Visible | bit | Boolean value to indicate whether or not Printer Driver name will be available for staff client to select in Circulation droplist.


OfflinePolSystem_RecordStatuses

OfflinePolSystem_RecordStatuses Table

List of Polaris record statuses used by offline processing.

Columns

Column name | Data type | Description
RecordStatusName | nvarchar(20) | name of status
RecordStatusID | int | Record status ID


OfflinePolSystem_SA_CircValuesByOrg

OfflinePolSystem_SA_CircValuesByOrg Table

This table contains the values stored in SA by their respective organizations (by organization id).

Columns

Column name | Data type | Description
AddressCheckTermCode | int | Default address check term code.
AddressCheckTermValue | nvarchar(255) | Default address check term type/code value.
City | nvarchar(32) | This is the name of the city where the Organization resides.
Country | nvarchar(32) | This is the name of the country where the Organization resides.
County | nvarchar(32) | This is the name of the county where the Organization resides.
DeliveryOptionID | int | Default delivery option id. This is a foreign key of the DeliveryOptions table.
ExpirationTermCode | int | Default expiration term code for this organization.
ExpirationTermValue | nvarchar(255) | Default value for the default expiration term.
HomePageUrl | nvarchar(255) | Default home page URL for this organization.
LanguageID | int | The default langauge of the organization - foreign key of the Langauges table.
OrganizationID | int | The assigned Organization ID of this organization. This is a foreign key to the Organizations Table.
PatronBarcodePrefix | nvarchar(255) | Prefix of Patron Barcode for this organization.
PatronBarcodeSigdigits | int | Sigificant digits of Patron Barcode
PatronCodeID | int | Default Patron Code for this organization.
PhoneOneAreaCode | nvarchar(7) | Organization area code.
PostalCode | nvarchar(12) | Zip Code
PrimaryPhoneNo | nvarchar(255) | Phone number of organization.
ReceiptTextMsg | nvarchar(255) | Default receipt note for this organization.
RegisteredBranchID | int | Default registered branch ID (Organization ID) for this Organization when registering patrons.
RequiredUDF1 | smallint | Determines if udf field one is required.
RequiredUDF2 | smallint | Determines if udf field two is required.
RequiredUDF3 | smallint | Determines if udf field three is required.
RequiredUDF4 | smallint | Determines if udf field four is required.
RequiredUDF5 | smallint | Determines if udf field five is required.
StandardLoanPeriod | int | Default standard loan period (specified in days).
StatClassCodeID | int | Default statistical class code ID for this organization when registering a new patron.
State | nvarchar(32) | State where Organization is in.
UDF1 | nvarchar(64) | User defined field one.
UDF2 | nvarchar(64) | User defined field two.
UDF3 | nvarchar(64) | User defined field three.
UDF4 | nvarchar(64) | User defined field four.
UDF5 | nvarchar(64) | User defined field five.
UDFLabel1 | nvarchar(255) | User defined label for udf field one.
UDFLabel2 | nvarchar(255) | User defined label for udf field two.
UDFLabel3 | nvarchar(255) | User defined label for udf field three.
UDFLabel4 | nvarchar(255) | User defined label for udf field four.
UDFLabel5 | nvarchar(255) | User defined label for udf field five.
EnableEmailReceipt | smallint | Whether e-mail receipt option is enabled for this organization. This value is populated from online SA value of ERECEIPTS_ENABLE_BY_EMAIL.
EnableTxtReceipt | smallint | Whether TXT/SMS receipt option is enabled for this organization. This value is populated from online SA value of ERECEIPTS_ENABLE_BY_TXT_MSG.
GenderSuppress | smallint | Whether gender suppress option is enabled for this organization. This value is populated from online SA value of PSPARMNORMREG_GENDERSUPPRESS.
ExportTxt | smallint | Whether the Export Txt option is enabled. This value is populated from the SA value for NSPARM_EXPORT_TXTMSG.
DisplayState | smallint | Whether display state for patron option is enabled for this organization. This value is populated from online SA value of DISPLAY_STATE_FOR_PATRON.


OfflinePolSystem_UDFOptionDefs

OfflinePolSystem_UDFOptionDefs Table

This table is populated from UDFOptionDefs for offline database population purpose. All the entries in this table are branch and UDF specific. If options are only selected for a library and saved in UDFOptionDefs, the selections for the library are duplicated for each branch belongs to this library in OfflinePolSystem_UDFOptionDefs. This is for offline data resource access purpose only. This way, offline data access doesn't have to deal with organization hierarchy.

Columns

Column name | Data type | Description
OrgID | int | Populated from UDFOptionDefs(OrgID)
UDFOptionID | int | Populated from UDFOptionDefs(UDFOptionID)
AttrID | int | Populated from UDFOptionDefs(AttrID)
DisplayOrder | int | Populated from UDFOptionDefs(DisplayOrder)


OfflinePolSystem_UDFOptions

OfflinePolSystem_UDFOptions Table

This table is populated from UDFOptions for offline database population purpose.

Columns

Column name | Data type | Description
UDFOptionID | int | populated from UDFOptions(UDFOptionID)
AttrID | int | populated from UDFOptions(AttrID)
OptionDesc | nvarchar(64) | populated from UDFOptions(OptionDesc)


OfflinePolSystem_Workstations

OfflinePolSystem_Workstations Table

Workstations are associated with a Branch organization only. The related record in Organizations must have an OrganizationCodeID = 4 (Branch).

Columns

Column name | Data type | Description
ComputerName | nvarchar(32) | Name of the computer.
OrganizationID | int | Organization where workstation exists.
WorkstationID | int | Primary key
NetworkDomainID | int | Unique identifier of the network domain associated with the workstation.


OrderStatus

OrderStatus Table

This is a secondary table used by the Purchase Order Status History record. Purchase order statuses are used to inform users of Polaris the current status of a purchase order record.

Columns

Column name | Data type | Description
OrderStatusID | int | Integer value used to link a Purchase Order Status with an entry in the OrderStatusHistories table. Must be unique to this table.
OrderStatus | nvarchar(10) | The status of a purchase order.its pre-defined values are: canceled, closed, continuing (subscriptions and standing orders only), pending,released (not used for subscriptions or standing orders), received.

See Also

OrderStatusHistories, PurchaseOrders,


OrderStatusHistories

OrderStatusHistories Table

This is a secondary table used by the purchase order object. The order status history is used, mainly for reporting purposes, to track the status of a purchase order while it exists in the system. The most recent entry is the one that displays in the purchase order workform.

Columns

Column name | Data type | Description
PurchaseOrderID | int | Polaris assigned unique ID number for a purchase order record.
OrderStatusID | int | Integer value used to link a Purchase Ordere Status with a purchase order.
StatusDate | datetime | System supplied date & time the OrderStatusID was set.


OrdersToInvoices

OrdersToInvoices Table

This is a secondary table used by both Purchase Order and Invoice records.This table is used to track which purchase orders and invoices are linked to each other.

Columns

Column name | Data type | Description
PurchaseOrderID | int | Polaris assigned unique ID number for a purchase order record.
InvoiceID | int | Polaris assigned unique ID number for an invoice record.


OrderTypes

OrderTypes Table

This a secondary table used by the Purchase Order record.Order types tell the user whether the purchase order is a regular one or one of the special types used by libraries.

Columns

Column name | Data type | Description
OrderTypeID | int | Integer value used to link an Order Type with a Purchase Order. Must be unique to this table.
OrderType | nvarchar(50) | The type of purchase order. Its pre-defined values: approval plan, blanket order, firm order, gift, membership, rental plan, standing order, subscription.

See Also

PurchaseOrders, SHRCopies,


OrganizationAddresses

OrganizationAddresses Table

This is a list of addresses that are associated with various organizations

Columns

Column name | Data type | Description
OrganizationID | int | Link to organization which uses an address.
SA_AddressID | int | Link to Address table (tells us the actual address)
AddressTypeID | int | Link to address types table


OrganizationCodes

OrganizationCodes Table

Coded values of organization types (system, library, branch)

Columns

Column name | Data type | Description
OrganizationCodeID | int | Primary key - code
Description | nvarchar(80) | The text description.

See Also

Organizations,


Organizations

Organizations Table

A complete list of all Organizations in a Polaris system

Columns

Column name | Data type | Description
OrganizationID | int | Primary key
ParentOrganizationID | int | Organizations form hierarchies in the form of system, library, branch. This element keeps track of which branches belong to which library, etc.
OrganizationCodeID | int | Link to OrganizationCodes table.
Name | nvarchar(50) | Name of the organization
Abbreviation | nvarchar(15) | Used for many display purposes.
SA_ContactPersonID | int | Link to contact person
CreatorID | int | ID of user who created this object
ModifierID | int | ID of user who last modified this object
CreationDate | datetime | Date/time of creation
ModificationDate | datetime | Date/time of the last modification
DisplayName | nvarchar(50) | The name of the organization used in other areas of Polaris (for display purposes).

See Also

AcqPurgeRecordDetails, AdminLanguageStrings, AuthorityOverlayRetentionTags, AuthorityTemplates, AuthPrefCatSource, BibliographicRecords, BibliographicTemplates, BibOverlayRetentionTags, CallNumberHierarchies, CatPurgeCriterias, ChildPAC_CollectionLimits, CircItemRecords, CollectionAgencyExcludePatronCodes, CollectionAgencyFees, CollectionAgencyIncludePatrons, CollectionAgencyRunDates, CommunityImportJobs, CommunityImportProfiles, CommunityInformationEventsPrograms, CommunityInformationRecords, ControlRecords, CourseReserves, Courses, CourseTemplates, CourseTerms, CrossReferenceDisplayConstants, DatesClosed, Departments, Donations, EOTDueDateExclude, EOTDueDateSchedule, EphemeralItemRecords, ExchangeRates, ExpressCheckLibAssignedIBlocks, ExpressCheckLibAssignedPBlocks, ExpressCheckPatCodePBlocks, FeeReasonCodesByBranch, Fines, FiscalYears, Funds, GendersByOrg, GroupOrganizations, HoldsPickupBranchesExclude, HoldsPreferredLendersInclude, ILLRequests, ILSStoreCreditCards, ILSStoreTransactions, ImportJobs, ImportProfiles, InboundPhoneVoices, InnReachCentrals_Locations, InnReachLocations, InvLineItemSegments, Invoices, ItemAvailabilityDisplay, ItemBlockDescriptions, ItemCheckouts, ItemPriceHierarchies, ItemRecordBranchCircCounts, ItemRecordDetails, ItemRecordHistory, ItemTemplates, LoanPeriods, MainCallNumberEntries, MARC21ExportBranches, MARCTagDefinitions, MaterialLoanLimits, MRMS_ResourceAuthenticationPatronOrganizations, MRMS_ResourceAuthenticationPowerPACOrganizations, MRMS_ResourceRecords, NSDatesNotToCall, NSLocalAreaCodes, NSLocalPrefixes, NSMPresentationPredicates, OrganizationAddresses, Organizations, OrganizationsCollections, OrganizationsFloatingCollections, OrganizationsPPPP, PAC_PatronFreeTextMessages, PAC_PatronMessages, PACAvailability, PACSearchTypes, PACSuppressionRules, PatRenewalLibAssignedIBlocks, PatRenewalLibAssignedPBlocks, PatRenewalPatCodePBlocks, PatronAccount, PatronCodeLists, PatronCollectionHistory, PatronCollectionTxn, PatronCustomDataDefinitionsToOrganizations, PatronCustomDataExpressRegistrationRules, PatronCustomDataPACManagementRules, PatronCustomDataPatronRegistrationRules, PatronCustomValidationRulesToOrganizations, PatronFineNotices, PatronFreeTextBlocks, PatronLoanLimits, PatronNotes, PatronReadingHistory, PatronRegistration, Patrons, PatronsInCollection, PatronStatClassCodes, PatronStops, PatronStopsByBranch, PolarisUserLists, PolarisUsers, POLineItemSegments, PrevYearItemsCircPerBranch, PromotionCampaigns, PromotionLocationIndex, Promotions, PurchaseOrders, ReceiveShipmentLogs, RecordSets, ReserveItemRecords, RouteLists, Rpt_RouteSlips, Rpt_SubsCancelNotices, RWRITER_BranchUserSecurity, SA_AutoChangePatronCodeControl, SA_Barcode_Formats, SA_BorrowByMail_MaterialTypesPermitted, SA_BorrowByMail_PatronCodesPermitted, SA_BorrowByMail_ProcessingCenters, SA_CATPROF_SubfieldNineProcessTags, SA_ChargeForCheckOut_MaterialTypes, SA_ChargeForCheckOut_PatronCodes, SA_CheckOutDisplayOrder, SA_CheckOutReceiptSettings, SA_COMMUNITY_PAC_SearchSettings, SA_COMMUNITY_PACLimitBy, SA_COMMUNITY_SearchDashboardDisplay, SA_CustomAnalyticsJavaScriptCodeSnippets, SA_CustomMultiLingualStrings, SA_FloatingMatrix, SA_FloatingMatrixCollectionLimits, SA_FloatingMatrixMaterialLimits, SA_FloatingMatrixMaterialTypes, SA_GeographicCoordinates, SA_Holds_Pickup_Branches, SA_ItemsOutReceiptSettings, SA_MaterialTypeGroups, SA_MediaDispenser_MaterialTypes, SA_NotReceived_IssueStatus_Assignment, SA_OLP_Gateway_Attributes, SA_ORS_DeliveryMode, SA_ORS_DeliveryRoute, SA_ORS_Disability, SA_ORS_Equipment, SA_ORS_ExcludedItemStatuses, SA_ORS_IncludedBranches, SA_ORS_PackingListText, SA_ORS_SLHeaderSelections, SA_PAC_ContentCarousels, SA_PAC_SearchDashboardDisplay, SA_PAC_SearchSettings, SA_PAC_SuppressedBranches, SA_PAC_SuppressedCircStatuses, SA_PACLimitBy, SA_PatronCodesFilterByRegisteredBranch, SA_PatronDisplayOrder, SA_PatronRegistrationCharges, SA_PatronSpecialMessages, SA_PaymentMethods, SA_PreferredVendorAccounts, SA_ResourceGroups_Organizations, SA_ShelvingStatusDurations, SA_SIPCheckOutItemAllowances, SA_SL_BranchFundFilter_BranchSettings, SA_SuppressAvailabilityAndRequests, SA_TitlesToGo_Configurations, SA_TrappingPreferenceGroups, SA_VR_Provider_Attributes, SchoolDivisions, SearchDatabases, SelectionLists, SelListLineSegments, ShelfLocations, SHRCopies, SHRSharedPublicNotes, StatisticalCodes, Subscriptions, Suppliers, SysHoldHistory, SysHoldRequests, SysHoldRoutingSequences, Telephony_ServerBranchMapping, ThemesAssigned, UDFOptionDefs, VegaDataSyncQueue, WebPageParts, Workstations,


OrganizationsCollections

OrganizationsCollections Table

Associative entity table resolving the many-to-many link between the Organizations table and the Collections table. This table lists all valid collections for all Branches.

Columns

Column name | Data type | Description
OrganizationID | int | Foreign key link to the Organizations table. This is restricted in the Polaris application to only Branch entries.
CollectionID | int | Foreign key link to the Collections table.

See Also

CircItemRecords, EphemeralItemRecords, InvLineItemSegments, ItemTemplates, POLineItemSegments, ReserveItemRecords, SelListLineSegments, SHRCopies, TextualHoldingsNotes,


OrganizationsFloatingCollections

OrganizationsFloatingCollections Table

This table will tell us which collections can float for a given home branch (for an item).

Columns

Column name | Data type | Description
HomeBranchID | int | The item record's home branch
CollectionID | int | Collection ID


OrganizationsPPPP

OrganizationsPPPP Table

Holds AdminAttribute data values that have been set for a particular organization.

Columns

Column name | Data type | Description
OrganizationID | int | ID of the Organization the data pertains to.
AttrID | int | AdminAttribute ID
Value | nvarchar(255) | The data value for this attribute


ORSDeliveryScheduleTypes

ORSDeliveryScheduleTypes Table

This table contains the delivery schedule types used by ORS for a patron's delivery options. These values are predefined and should not be changed.

Columns

Column name | Data type | Description
ORSDeliveryScheduleTypeID | int | ID of ORS delivery schedule type, internally used, is the primary key.
Description | nvarchar(50) | Description used in UI display.

See Also

ORSPatrons,


ORSPatronDisabilities

ORSPatronDisabilities Table

This table provides a list of disabilities for a specific ORS patron.

Columns

Column name | Data type | Description
PatronID | int | ID that references the Patrons table.
DisabilityID | int | ID that references SA_ORS_Disability table.


ORSPatronEquipment

ORSPatronEquipment Table

This table provides a list of equipment for a specific ORS patron.

Columns

Column name | Data type | Description
PatronID | int | ID that references the Patrons table.
EquipmentID | int | ID that references SA_ORS_Equipment table.


ORSPatrons

ORSPatrons Table

This table contains the ORS specific data for patrons.

Columns

Column name | Data type | Description
PatronID | int | ID that references the Patrons table.
ORSStatusID | int | Specifies if patron is active or inactive for ORS. References ORSStatuses table.
Enabled | bit | Determines if this patron account is using ORS.
ActivationDate | datetime | Date the account is considered active for ORS.
Note | nvarchar(255) | Freetext field for notes.
SearchFilter | nvarchar(-1) | XML document that contains the search preferences used with automated system searches.
LastServiceDate | datetime | The date of last delivery. This and delivery schedule type are used to help determine next service date.
NextServiceDate | datetime | The calculated date of next service or delivery.
DeliveryModeID | int | Type of ORS delivery used for this patron. References the SA_ORS_DeliveryMode table.
DeliveryRouteID | int | The delivery route this patron is on. References the SA_ORS_DeliveryRoute table.
DeliveryStopID | int | The delivery stop this patron is on. References the SA_ORS_DeliveryRouteStops table.
DeliveryScheduleTypeID | int | Type of delivery schedule for this patron. References the ORSDeliveryScheduleTypes table.
DeliveryScheduleDate | datetime | Specific delivery date option. Used when ORS Delivery schedule type is set to 'Exact Date'.
ResponsiblePickupPerson | nvarchar(255) | Freetext field to store the person resposible for pickups for the ORS Patron.
DeliveryNote | nvarchar(255) | Freetext field used to store special delivery notes.
NumItemsToSend | int | The number of items to send this patron.
ResendItems | bit | Used to determine if items the patron has already read (reading history list) should be resent to the patron.
ResendMonthsToWait | int | Used with resend items flag. If resend items is set to yes, resend months to wait filters out items the patron has already read from the automated searches until this timeframe has been reached.
PatronSelectionsOnly | bit | Acts a flag for the operator to determine if the system should search for items or only use the patron's selections.
DeliveryScheduleEvery | int | When the ORS schedule type is set to 'Daily', this store the number of days.


ORSPatronSelectionLists

ORSPatronSelectionLists Table

This table stores the item records for an ORS patron's selection list.

Columns

Column name | Data type | Description
PatronID | int | References the patrons table.
ItemRecordID | int | References the CircItemRecords table.


ORSPickListReports

ORSPickListReports Table

This table temporarily stores data for use is building the pick list report created by Microsoft Reporting Services.

Columns

Column name | Data type | Description
WorkstationID | int | References the Workstations table. Represents the workstation logged into the staff client that would like to print the pick list.
PolarisUserID | int | References the PolarisUsers table. Represents the operator logged into the staff client that would like to print the pick list.
PatronID | int | References the Patrons table. Represents the patron for which the pick list is printed.
ItemRecordID | int | References the CircItemRecords table. Represents an item in the patron's pick list.


ORSStatuses

ORSStatuses Table

This table stores the ORS account status values. These should not be changed.

Columns

Column name | Data type | Description
ORSStatusID | int | ID of ORS status, internally used, is the primary key.
Description | nvarchar(50) | Field used for display in UI.

See Also

ORSPatrons,


OverDriveMARCLanguageMapping

OverDriveMARCLanguageMapping Table

Contains one row for each OverDrive to MARC mapping

Columns

Column name | Data type | Description
OverDriveLanguageCode | nvarchar(2) | 2 character ISO-639-1 langauge code from OverDrive
MARCLanguageCode | nvarchar(3) | 3 character ISO-639-2B language code for MARC


PACAvailability

PACAvailability Table

Contains one row for each distinct bibliographic record, branch and resource group that is linked to at least one item record or serial holdings record that is displayable in PAC

Columns

Column name | Data type | Description
BibliographicRecordID | int | Identities the bibliographic record associated with this row.
BranchID | int | Identities the branch associated with this row.
ResourceGroupID | int | Identifies the resource group associated with this row. If the value is 0, then the row is not associated with a resource group.
AvailablePieceCount | int | The number of pieces currently available and displayable in PAC.
TotalPieceCount | int | The total number of pieces displayable in PAC.
MasterPieceID | int | Identifies the master piece associated with this row. This value is used to determine the best available local call number. The binary layout of a piece identifier is documented in the PAC_PopulateAvailability stored procedure.


PACAvailabilityFacetIndex

PACAvailabilityFacetIndex Table

Contains one row for each bibliographic record with one or more available pieces.

Columns

Column name | Data type | Description
BibliographicRecordID | int | Identifies the bibliographic record.
FacetKeyChain | varbinary | Compressed binary chain of (availability) facet keys associated with the bibliographic record.


PACSearchTypes

PACSearchTypes Table

This table specifies the Search Types that are enabled/disabled in the PAC, which organization or workstation they are used in, and the order in which they appear.

Columns

Column name | Data type | Description
PACSearchTypeID | int | ID that represents the mapping of the Search Type to Organization/Workstation relationship.
SearchTypeID | int | ID of the Search Type.
OrganizationID | int | ID of the organization that this search type is for. This value is mutually exclusive of the WorkstationID value.
WorkstationID | int | ID of the workstation that this search type is for. This value is mutually exclusive of the OrganizationID value.
Enabled | bit | States whether or not the Search Type is enabled in the PAC.
TypeOrder | smallint | The order in which the Search Types appear in the PAC (in the drop down box on the data entry bar of the particular search screen represented by the search method).


PACSuppressionRules

PACSuppressionRules Table

Contains one row per for each item status that should be suppressed per branch.

Columns

Column name | Data type | Description
BranchID | int | Is the branch identifier.
SuppressedItemStatusID | int | Is the item status to suppress.


PAC_PatronFreeTextMessages

PAC_PatronFreeTextMessages Table

Patron free text messages

Columns

Column name | Data type | Description
FreeTextMessageID | int | primary key
PatronID | int | patron ID
OrganizationID | int | organization ID
CreatorID | int | creator
WorkstationID | int | workstation ID
FreeTextMessage | nvarchar(255) | message text
CreationDate | datetime | creation date
IsRead | bit | has patron read message
ModifierID | int | modifier
ModificationDate | datetime | modification date


PAC_PatronMessages

PAC_PatronMessages Table

Organization messages associated with the patron

Columns

Column name | Data type | Description
MessageID | int | messageID
PatronID | int | patron ID
OrganizationID | int | organization
CreatorID | int | creator
WorkstationID | int | workstation
CreationDate | datetime | creation date
IsRead | bit | has patron read?
ModifierID | int | modifier
ModificationDate | datetime | modification date


PAC_PatronPasswordResetRequests

PAC_PatronPasswordResetRequests Table

Contains one row for each patron that has requested a password reset

Columns

Column name | Data type | Description
ResetRequestGUID | uniqueidentifier | Unique identifier
PatronID | int | Patron identifier from Patrons table
ExpirationDate | datetime | Date and time that the reset request will expire
EnteredLogin | nvarchar(50) | String indicating the text entered by the patron


PAPIPatronAuthentication

PAPIPatronAuthentication Table

This table stores authentication details for Patron's connected to the Polaris API (PAPI)

Columns

Column name | Data type | Description
PatronID | int | ID of the patron record
AccessSecret | nvarchar(64) | The authenticated secret
AuthenticationExpDate | datetime | Date the authentication expires


PAPIPatronAuthenticationFailures

PAPIPatronAuthenticationFailures Table

This table stores details for failed patron authentications to the Polaris API (PAPI)

Columns

Column name | Data type | Description
PatronID | int | ID of the patron record
AuthAttemptDate | datetime | Date of the authentication attempt
NumAuthAttempts | int | Number of authentication attempts


PAPIStaffAuthentication

PAPIStaffAuthentication Table

This table is used to support PAPI's "protected methods". The staff member must authenticate with the PAPI service using the "AuthenticateStaffUser" method over a secure connection. Domain account information will be exchanged and verified only once. If successful, the user will be provided an AccessToken and AccessSecret which will be used for the remainder of their operations.

Columns

Column name | Data type | Description
PolarisUserID | int | Polaris User ID associated with access secret and token.
AccessToken | nvarchar(64) | Access token generated with successful domain authentication.
AccessSecret | nvarchar(64) | Access secret generated with successful domain authentication.
AuthenticationExpDate | datetime | Date and time the access secret and token will expire.


PAPIStaffAuthenticationFailures

PAPIStaffAuthenticationFailures Table

This table is used to support PAPI's "protected methods". It keeps track of failed authentication attempts and may be used to temporarily block a Polaris User from using the Polaris API.

Columns

Column name | Data type | Description
PolarisUserID | int | Polaris user ID associated with the failed authentication attempt.
AuthAttemptDate | datetime | Date and time authentication attempt failed.
NumAuthAttempts | int | Number of failed authentication attempts.


PAPIUsers

PAPIUsers Table

This table stores the basic information of PAPI user accounts.

Columns

Column name | Data type | Description
PAPIUserID | int | ID of PAPI User, internally used, is the primary key.
AccessID | nvarchar(50) | PAPI User access ID. Used for authentication purposes.
AccessKey | nvarchar(64) | PAPI User access key. Private key used for authentication purposes.
ExpirationDate | datetime | Date the PAPI User account expires. If NULL, the account never expires.


PAPI_RequestsPicklistFilter

PAPI_RequestsPicklistFilter Table

A table used by the Polaris API to filter pick list data.

Columns

Column name | Data type | Description
SysHoldRequestID | int | The sysholdrequest affected by the filter
RequestingOrgID | int | The organization requesting the pick list
nByID | int | The type of organization impacted by the filter
SysHoldStatusID | int | The syshold status impacted by the filter
ExpirationDateTime | datetime | The expiration date and time of the filter


PAPI_SynchTasksCheckinLog

PAPI_SynchTasksCheckinLog Table

A table to collect check-in's transactions made by a third party. These check-in's are genreally associated with e-content.

Columns

Column name | Data type | Description
SynchTasksCheckinLogID | int | A unique ID for this transaction
ThirdPartyVendorID | int | The thrid party vendor performing the checkin transaction
PatronID | int | The Polaris Patron that checked the item in.
UniqueRecordID | nvarchar(255) | The record Being checked in
CheckinTransactionDate | datetime | The date and time that the transaction was posted in the third-party system
PolarisBranchID | int | The Branch ID where the transaction was processed.
PolarisUserID | int | The User making the checkin
PolarisWorkstationID | int | The workstation performing the checkin
MessageReceivedDate | datetime | The date and time that the transaction was received by Polaris.
MessageProcessed | bit | A boolean indicating if the message was processed by Polaris.
MessageProcessedDate | datetime | The date and time that the transaction was processed by Polaris.
ThirdPartyVendorContractID | nvarchar(255) | The ContractID associated with the vendor account from which the transaction originated.
ImportJobID | int | The import job associated with this entry (if any)
PatronVendorContractID | nvarchar(255) | The ContractID associated with the vendor account for the patron.
PatronBarcode | nvarchar(255) | The barcode of the patron checking the item in


PAPI_SynchTasksCheckoutLog

PAPI_SynchTasksCheckoutLog Table

A table to collect check-out's transactions made by a third party. These check-out's are genreally associated with e-content.

Columns

Column name | Data type | Description
SynchTasksCheckoutLogID | int | Primary key
ThirdPartyVendorID | int | Third party vendor key
PatronID | int | Patron ID from Patrons table
UniqueRecordID | nvarchar(255) | The record ID that links back to a Polaris record (could be different rules per vendor)
RecordExpireOrDueDate | datetime | Date that the record will expire (or be due)
CheckoutTransactionDate | datetime | The date and time that the transaction was posted in the third-party system
PolarisBranchID | int | Logon Branch ID
PolarisUserID | int | User ID
PolarisWorkstationID | int | Workstation ID
MessageReceivedDate | datetime | The date and time that the transaction was received by Polaris.
MessageProcessed | bit | A boolean indicating if the message was processed by Polaris.
MessageProcessedDate | datetime | The date and time that the transaction was processed by Polaris.
ThirdPartyVendorContractID | nvarchar(255) | The contract ID associated with the vendor account from which the transaction originated.
ImportJobID | int | The import job associated with this entry (if any)
PatronVendorContractID | nvarchar(255) | The ContractID associated with the vendor account from which the transaction originated.
PatronBarcode | nvarchar(255) | The barcode of the patron checking the item out.


PAPI_SynchTasksNotifyPatronItemLog

PAPI_SynchTasksNotifyPatronItemLog Table

This table is used to gather information needed that an ebook hold has become "held"

Columns

Column name | Data type | Description
SynchTasksNotifyPatronLogID | int | A unique ID for the row (identity)
ThirdPartyVendorID | int | The Vendor ID associated with the message.
ThirdPartyVendorContractID | nvarchar(255) | The Vendors contract ID associated with the message
PatronID | int | The patron to notify
UniqueRecordID | nvarchar(255) | The vendors unquie identifier for the item
PatronMessage | nvarchar(4000) | The message from the provider
PolarisBranchID | int | The Patrons branch ID
PolarisUserID | int | The polaris user that received the data
PolarisWorkstationID | int | The workstation that received the data
MessageReceivedDate | datetime | The date / time on which the message was received
MessageProcessed | bit | Indicates that the message has been processed
MessageProcessedDate | datetime | The date on which the message was proessed
ImportJobID | int | The import job associated with this entry (if any)


PAPI_SynchTasksNotifyPatronLog

PAPI_SynchTasksNotifyPatronLog Table

A queue used to propogate messages from a 3rd party system that need to be delivered to the patron record in Polaris.

Columns

Column name | Data type | Description
SynchTasksNotifyPatronLogID | int | Primary key
ThirdPartyVendorID | int | Third party vendor key
PatronID | int | Patron ID
PatronMessage | nvarchar(4000) | The message text for the patron
PolarisBranchID | int | Polaris branch ID
PolarisUserID | int | User ID
PolarisWorkstationID | int | Workstation ID
MessageReceivedDate | datetime | Date the message was received in the queue
MessageProcessed | bit | A flag to say if the message has been processed or not
MessageProcessedDate | datetime | Date the message was processed by Polaris.
ThirdPartyVendorContractID | nvarchar(255) | The ContractID associated with the vendor account from which the transaction originated.


PAPI_ThirdPartyCopyExpiredEvents

PAPI_ThirdPartyCopyExpiredEvents Table

A table used to track expired copy events sent to Polaris by eContent providers

Columns

Column name | Data type | Description
ThirdPartyRemoveCopyEventID | int | A Unique Identifier
ThirdPartyVendorID | int | The vendor sending the transaction
UniqueRecordID | nvarchar(255) | The vendor object identitifer associated with the transaction
PolarisBranchID | int | The Polaris branch ID
PolarisUserID | int | The Polaris User ID
PolarisWorkstationID | int | The Polaris workstation ID
MessageReceivedDate | datetime | The date and time that the message was received
ThirdPartyVendorContractID | nvarchar(255) | The Vendor account that is related to the transaction.
MessageTargeted | bit | Indicates if the message is targeted to a specific item, patron, or checkout transaction.
MessageTargetedDate | datetime | The date and time that the message was set to targeted
MessageProcessed | bit | Indicates if the message has been processed by the APIConsumer service
MessageProcessedDate | datetime | The date and time on which the message was processed
TargetPatronID | int | The PatronID targeted by the transaction (if any)
TargetItemRecordID | int | The ItemRecord targeted by the transaction (if any)
TargetSynchTasksCheckoutLogID | int | The checkout transaction targeted by the transaction (if any)


PAPI_ThirdPartyItemCheckouts

PAPI_ThirdPartyItemCheckouts Table

This table stores information on the check-out items that belong to this database. The patrons are not from this database.

Columns

Column name | Data type | Description
ThirdPartyVendorID | int | Identifier for the items vendor.
ThirdPartyVendorContractID | nvarchar(255) | Identifier for the items vendor contract.
UniqueRecordID | nvarchar(255) | Identifier for the title from the vendor.
ItemExpireDateTime | datetime | DueDate of the checked-out item
PatronBarcode | nvarchar(255) | Barcode of the patron the item is checked-out to.
PatronVendorContractID | nvarchar(255) | Identifier for the patrons vendor contract.
ItemRecordID | int | ID of the item. It references CircItemRecords table(ItemRecordID).


PAPI_ThirdPartyMARCRecordUpdates

PAPI_ThirdPartyMARCRecordUpdates Table

A table that tells the Polaris ILS that a MARC record has been created on a 3rd party system and is available to download.

Columns

Column name | Data type | Description
ThirdPartyMARCRecordUpdateID | int | Primary key
ThirdPartyVendorID | int | Third party vendor key
UniqueRecordID | nvarchar(255) | The record ID that links back to a Polaris record (could be different rules per vendor)
PolarisBranchID | int | Branch ID
PolarisUserID | int | User ID
PolarisWorkstationID | int | Workstation ID
MessageReceivedDate | datetime | Date the message was received in the queue
MessageProcessed | bit | A flag to say if the message has been processed or not
MessageProcessedDate | datetime | Date the message was processed by queue processing
MessageQueued | bit | Boolean, indicates if the message has been queued for processing.
MessageQueuedDate | datetime | The date/time that the message was put in the processing queue (internal use).
QueueThreadID | nvarchar(255) | The thread being used to process the record (internal use).
ThirdPartyVendorContractID | nvarchar(255) | The ContractID associated with the vendor account from which the transaction originated.
ImportJobID | int | The import job associated with this entry (if any)


PasswordTypes

PasswordTypes Table

Is a coded values table which lists different types of passwords used in Polaris

Columns

Column name | Data type | Description
PasswordTypeID | int | Primary key
Description | nvarchar(25) | The password type description


PatRenewalLibAssignedIBlocks

PatRenewalLibAssignedIBlocks Table

This table contains sets of item-specific Library Assigned blocking conditions grouped by Organization that will prevent a Patron-Initiated renewal (from the PAC or Inbound Telephony)

Columns

Column name | Data type | Description
OrganizationID | int | Organizations foreign key - The organization associated with the item block
ItemBlockID | int | ItemBlockDescriptions foreign key - The actual item-specific library assigned block


PatRenewalLibAssignedPBlocks

PatRenewalLibAssignedPBlocks Table

This table contains sets of patron-specific Library Assigned blocking conditions grouped by Organization that will prevent a Patron-Initiated renewal (from the PAC or Inbound Telephony)

Columns

Column name | Data type | Description
OrganizationID | int | Organizations table foreign key - The organization associated with the block
PatronStopID | int | PatronStopDescriptions foreign key - The actual Patron-specific block


PatRenewalPatCodePBlocks

PatRenewalPatCodePBlocks Table

This table contains sets of patron codes grouped by Organization that will prevented from performin a Patron-Initiated renewal (from the PAC or Inbound Telephony)

Columns

Column name | Data type | Description
OrganizationID | int | Organizations foreign key - The organization associated with the patron code ID being blocked
PatronCodeID | int | PatronCodes foreign key - The actual Patron Code being blocked


PatronAccount

PatronAccount Table

Main table of patron accounting that stores every money based transaction for patrons.

Columns

Column name | Data type | Description
TxnID | int | ID of the transaction, primary key, unique identifier (IDENTITY).
PatronID | int | ID of the patron associated with this transaction. It references Patrons table (PatronID).
TxnCodeID | int | ID of the transaction code that distinguishes the nature of different transactions such as Charge, Pay etc. It references PatronAccTxnCodes table (TxnCodeID).
FeeReasonCodeID | int | ID of the reason for this transaction, will be null if no reason. It references FeeReasonCodes table (FeeReasonCodeID).
TxnAmount | money | Amount of this transaction.
OutstandingAmount | money | Outstanding amount that this transaction is having.
ItemRecordID | int | ID of the item associated with this transaction, will be null if no such association.
TxnDate | datetime | Date of the transaction created.
PaymentMethodID | int | ID of the payment method associated with this transaction if any, otherwise will be null. It references PatronPaymentMethods table (PaymentMethodID).
OrganizationID | int | OrganizationID of the governing branch for fine calculations as defined in Systems Administration. Could be Item's Assigned Branch, Patron's Branch or the transacting library's branch.
WorkStationID | int | ID of the computer that the user uses to create this transation. It references Workstations table (WorkstationID).
CreatorID | int | ID of the user who loggs on to Polaris and creates this transaction. It references PolarisUsers table (PolarisUserID)
CheckOutDate | datetime | Check out date of the item associated with this transaction, will be null if no such association.
DueDate | datetime | Due date of the item circulated and associated with this transaction, will be null if no such association.
FreeTextNote | nvarchar(255) | Note of this transaction if any, otherwise will be null.
ILSStoreTransactionID | int | Links to ILSStoreTransactions table. ID of associated credit card transaction. Null if credit card was not used to pay for the fine/fee.
LoaningOrgID | int | Organization ID of item's lending branch. This is usually valid for overdue item related charges.
ItemAssignedBranchID | int | The associated item record's Assigned Branch at the time of the transaction.
PatronBranchID | int | The Patron's registration branch ID at the time of the transaction.
LoanUnit | int | Loan unit of the item when fine is calculated.
FineFreeUnits | int | Number of units that is deducted when fine is calculated.
FineDeducted | money | Amount of the fine that is deducted due to not finable units.
FineIsCapped | bit | Indicates whether or not the fine amount is capped due to maximum fine limit.
BillingStatusID | int | ID of the billing status. It references PatronAcctBillingStatus table (BillingStatusID).

See Also

ItemRecordNotifications, PatronAccountAssoc,


PatronAccountAssoc

PatronAccountAssoc Table

Table of patron accounting used to link the related transactions from PatronAccount table such as a pay associated with a charge etc.

Columns

Column name | Data type | Description
MainTxnID | int | ID of a transaction which is the base to other associated transactions. It references PatronAccount table (TxnID).
AssocTxnID | int | ID of a transaction based on another transaction. It references PatronAccount table (TxnID).


PatronAccountOverrideDetail

PatronAccountOverrideDetail Table

Table stores all override transactions and the waive transaction they are associated with.

Columns

Column name | Data type | Description
TransactionID | int | ID of the transaction from the PolarisTransactions database.
TransactionDate | datetime | Date of the transaction.
UserAction | nvarchar(-1) | Type of override committed.
DollarAmount | money | Amount of this transaction.
OrganizationID | int | OrganizationID of the transacting branch.
WorkstationID | int | ID of the computer that the user uses to create this transaction. It references Workstations table (WorkstationID).
OverrideSuspected | bit | Displays if the transaction was suspected of being overridden. 1 = Yes, 0 = No.
OverrideTransactionID | int | ID of the overriding transaction from the PolarisTransactions database.
StaffUserID | int | ID of the user who logs on to Polaris and creates this transaction. It references PolarisUsers table (PolarisUserID).
OverrideUserID | int | ID of the user who overrides the transactions. It references PolarisUsers table (PolarisUserID).
PatronAccountTxnID | int | ID of the transaction from the Polaris database. It references PatronAccount table (TxnID).


PatronAcctBillingStatus

PatronAcctBillingStatus Table

Contains the different billing statuses used for charges on a patron's account.

Columns

Column name | Data type | Description
StatusID | int | Unique identifier for the billing status.
StatusDesc | nvarchar(20) | Description of the billing status.

See Also

PatronAccount,


PatronAcctDeletedItemRecords

PatronAcctDeletedItemRecords Table

This table stores Item record info for all deleted item records which are still referenced by PatronAccount transactions. The data gets populated into this table via DELETE trigger on CircItemRecords table.

Columns

Column name | Data type | Description
ItemRecordID | int | Item record ID.
Barcode | nvarchar(20) | Item record barcode.
BrowseTitle | nvarchar(255) | Item record's browse title which is copied from its associated bibliographic record.
BrowseAuthor | nvarchar(255) | Item record's browse author which is copied from its associated bibliographic record.
MaterialType | nvarchar(80) | Item record's material type.


PatronAccTxnCodes

PatronAccTxnCodes Table

Table of patron accounting used to distinguish different kind of transactions from PatronAccount table. It's used internally only. User should not modify it.

Columns

Column name | Data type | Description
TxnCodeID | int | ID of transaction code, primary key, unique identifier (IDENTITY).
Description | nvarchar(20) | General description of the transction code.
AlternateName | nvarchar(40) | Detailed description of the transaction code.

See Also

NCIPFiscalActionTypes, PatronAccount,


PatronAddresses

PatronAddresses Table

Lists addresses which correspond to patrons, because patrons can have numerous addresses.

Columns

Column name | Data type | Description
PatronID | int | Link to Patrons table
AddressID | int | Link to addresses table (contains actual address)
AddressTypeID | int | Link to address types
Verified | bit | indicates whether the address is verified by a third-party web service.
VerificationDate | datetime | the date when patron address is verified by a third-party web service.
PolarisUserID | int | The polaris user ID who sends the address to a third-party web service for verification.
AddressLabelID | int | Foreign key into Polaris..AddressLabels, representing a patron's address label


PatronAssociations

PatronAssociations Table

This table contains information on the various patron records associated with a patron.

Columns

Column name | Data type | Description
PatronID | int | PatronID of the patron.
LinkedPatronID | int | PatronID of the associated patron.
Note | nvarchar(255) | Librarian entered text.
CreationDate | datetime | The date the association was created.
ModificationDate | datetime | Date the association was modified to change either the designation or the note.
BlockMe | bit | When this flag is set, the current patron is blocked by it's linked patron. Patron blocking can be one-way, two-way, or not at all (and yet still be associated).
CreatorID | int | Who created the association
ModifierID | int | Who modified the association
AllowMe | bit | When this flag is set, the current patron is allowed to pick up holds for it's linked patron. It can be one-way, two-way, or not at all (and yet still be associated).


PatronClaims

PatronClaims Table

Table to store basic information of the items claimed by patrons

Columns

Column name | Data type | Description
ClaimID | int | Identity of the table.
PatronID | int | ID of the patron who claimed for the item. It references Patrons table (PatronID).
ItemRecordID | int | ID of the claimed item.
DueDate | datetime | Due date assigned to the item when it was checked out.
ClaimDate | datetime | The date a claim is made.
ClaimTypeID | int | Claim type: either 8, 9, or 21. Refer to item status ID 8, 9, or 21: Claim Returned, Claim Never Had, or Claim Missing Parts
LoaningOrgID | int | Claimed Item Record's checked-out branch OrganizationID.
CheckOutDate | datetime | Claimed Item Record's check out date.
LoanUnits | int | Claimed Item Record's loan units when time it's checked out.
ClaimNoticeSent | bit | Flag indicates whether a notice has been sent for this claim.


PatronCodeLists

PatronCodeLists Table

Holds lists of patron codes used for different purposes. See KindOfList column description.

Columns

Column name | Data type | Description
OrganizationID | int | System, Library, or Branch where this list belongs.
PatronCodeID | int | Patron code in the list.
KindOfList | int | List ID: 0 - Password change from PAC 1 - Renewals from PAC 2 - Update info from PAC 3 - Disable ILL requests


PatronCodes

PatronCodes Table

This table stores patron codes and descriptions.

Columns

Column name | Data type | Description
PatronCodeID | int | ID of patron code, primary key.
Description | nvarchar(80) | Description of patron codes.

See Also

CollectionAgencyExcludePatronCodes, EOTDueDateExclude, ExpressCheckPatCodePBlocks, Fines, InnReachMapPatronCodeToPTypes, InnReachMapPTypeToPatronCodes, LoanLimits, LoanPeriods, MaterialLoanLimits, MRMS_ResourceAuthenticationPatronCode, PatRenewalPatCodePBlocks, PatronCodeLists, PatronCodes_NCIPPrivs, PatronLoanLimits, Patrons, SA_AutoChangePatronCodeControl, SA_BorrowByMail_PatronCodesPermitted, SA_ChargeForCheckOut_PatronCodes, SA_MaterialTypeGroups_Limits, SA_PatronCodesFilterByRegisteredBranch, SA_PatronRegistrationCharges,


PatronCodes_NCIPPrivs

PatronCodes_NCIPPrivs Table

This table is used to map the Polaris patron codes to their NCIP equivalent descriptions for systems outside of Polaris. We map the patron code id from the PatronCodes table to the identity value that is in either of the following tables: NCIPPublicPrivs or NCIPAcademicPrivs. If we have a patron with a patron code of 3 - "Juvenile with restrictions", then it gets mapped in this table to "Child" in the NCIPPublicPrivs table. Outside vendors using NCIP will only look for the term such as "Child" from Polaris. "Juvenile..." is not used outside of the Polaris library.

Columns

Column name | Data type | Description
PatronCodeID | int | This is a column that is a foreign key to the Polaris PatronCodes table.
NCIPPublicPrivID | int | This is a column that is a foreign key to the idenity value in the Polaris NCIPPublicPrivs table.
NCIPAcademicPrivID | int | This is a column that is a foreign key to the idenity value in the Polaris NCIPAcademicPrivs table.


PatronCollectionHistory

PatronCollectionHistory Table

This table has information on all the patrons that have been included in the past submission and update reports.

Columns

Column name | Data type | Description
OrgID | int | The organization that reported the patron in its report.
PatronID | int | The patron who was included in the report.
CollectionStatus | tinyint | Whether the patron was included in an update or submission report.
Amount | money | Amount that was due to the system.
CollectionDate | datetime | Date when the patron was included in the report.
HistoryID | int | Unique identifier - Identity column


PatronCollectionTxn

PatronCollectionTxn Table

This table has information on all the transactions that were used in calculating the amount due for the update or submission reports.

Columns

Column name | Data type | Description
OrgID | int | Organization which submitted the report.
PatronID | int | Patron who was included in the report.
TxnID | int | Charge transaction that the patron had when the last report which included the patron was sent.


PatronConcordance

PatronConcordance Table

Contains one row for each distinct collocation composed of 1 to 8 keywords within a patron record.

Columns

Column name | Data type | Description
CollocationID | int | Unique identifier for the row.
LexicalContextTuple | varbinary | Compressed tuple of keyword/delimiter pairs.


PatronConcordanceRadix

PatronConcordanceRadix Table

Contains one row for each distinct code point at a given prefix-position within the concordance.

Columns

Column name | Data type | Description
NexusID | int | Unique identifier for the row.
ParentNexusID | int | Unique identifier for the parent row.
EdgeTransition | nchar | Distinct code point at a given prefix-position within the concordance.
SemanticHintTuple | varbinary | Compressed tuple of collocation hints.


PatronCustomDataBoolean

PatronCustomDataBoolean Table

A table to hold Boolean values related to patron custom data entities

Columns

Column name | Data type | Description
PatronID | int | The patron possessing the custom data entity
PatronCustomDataDefinitionID | int | The data definition ID related to the custom data entity.
CustomDataEntry | bit | The custom data value


PatronCustomDataDates

PatronCustomDataDates Table

A table to hold date/time values related to patron custom data entities

Columns

Column name | Data type | Description
PatronID | int | The patron possessing the custom data entity.
PatronCustomDataDefinitionID | int | The data definition ID related to the custom data entity.
CustomDataEntry | datetime | The custom data value


PatronCustomDataDefinition

PatronCustomDataDefinition Table

A table to hold patron custom data definitions.

Columns

Column name | Data type | Description
PatronCustomDataDefinitionID | int | The unique identifier of the custom data definition.
PatronDataLabelValue | nvarchar(64) | The label text for the data definition.
PolarisCustomDataTypeID | int | What type of data does this data definition describe: string, integer, Boolean, or date/time
CreatorID | int | The PolarisUserID of the staff member who created the custom data definition.
CreationDate | datetime | The date that the custom data definition was created.
ModifierID | int | The PolarisUserID of the staff member who modified the data definition.
ModificationDate | datetime | The date on which the data definition was modified.
IsKeywordIndexed | bit | Indicates if the data for the custom data definition is keyword indexed. This is valid only for string data types.
Ordinal | int | The order in which the data definition appears in the patron record.

See Also

PatronCustomDataBoolean, PatronCustomDataDates, PatronCustomDataDefinitionsToOrganizations, PatronCustomDataDefinitionsToPatronCustomValidationRules, PatronCustomDataExpressRegistrationRules, PatronCustomDataIntegers, PatronCustomDataPACManagementRules, PatronCustomDataPatronRegistrationRules, PatronCustomDataStrings,


PatronCustomDataDefinitionsToOrganizations

PatronCustomDataDefinitionsToOrganizations Table

A table that relates patron custom data definitions to Polaris organizations.

Columns

Column name | Data type | Description
PatronCustomDataDefinitionID | int | The patron custom data definition
OrganizationID | int | The organization.
DisplayOrder | int | The order to display the custom data entry.
Enabled | bit | Indicates if the custom data field is displayed for the organization.


PatronCustomDataDefinitionsToPatronCustomValidationRules

PatronCustomDataDefinitionsToPatronCustomValidationRules Table

A table to relate a custom data definition to a custom validation rule.

Columns

Column name | Data type | Description
ValidationID | int | The validation id of the custom validation rule.
PatronCustomDataDefinitionID | int | The patron custom data definition id.
ParameterName | nvarchar(255) | The name of the parameter bring used in the stored procedure.


PatronCustomDataExpressRegistrationRules

PatronCustomDataExpressRegistrationRules Table

The rules governing the use of the patron custom data in patron express registration.

Columns

Column name | Data type | Description
PatronCustomDataDefinitionID | int | The custom data definition ID
OrganizationID | int | The patron branch id.
IsRequiredInExpressRegistration | bit | Indicates if the custom data field is required in express registration.
ExpressRegistrationDefaultValue | sql_variant | The default value to be used in express registration.


PatronCustomDataIntegers

PatronCustomDataIntegers Table

A table to hold integer values related to patron custom data entities

Columns

Column name | Data type | Description
PatronID | int | The patron possessing the custom data entity.
PatronCustomDataDefinitionID | int | The data definition ID related to the custom data entity.
CustomDataEntry | int | The custom data value


PatronCustomDataPACManagementRules

PatronCustomDataPACManagementRules Table

A table to define the use of patron custom data fields in Polaris PAC products.

Columns

Column name | Data type | Description
PatronCustomDataDefinitionID | int | The patron custom data definition ID.
OrganizationID | int | The patrons organization ID.
IsDisplayedInPatronAccount | bit | Indicates if the field displays on the patron update page in PAC.
IsRequiredInPatronAccount | bit | Indicates if the field is required on the patron update page in Polaris PAC products.
IsDisplayedInSelfReg | bit | Indicates if the field displays on the patron self registration page in Polaris PAC products.
IsRequiredInSelfReg | bit | Indicates if the field is required on the patron self registration page in Polaris PAC products.
PACDefaultValue | sql_variant | The default value on the self-registration page in Polaris PAV products.


PatronCustomDataPatronRegistrationRules

PatronCustomDataPatronRegistrationRules Table

A table to define the use of patron custom data fields during patron registration.

Columns

Column name | Data type | Description
PatronCustomDataDefinitionID | int | The patron custom data definition ID.
OrganizationID | int | The patrons organization ID.
IsRequiredInPatronRegistration | bit | Indicates if the field is required during patron registration.
PatronRegistrationDefaultValue | sql_variant | The default value of the custom data field for patron registration.


PatronCustomDataStrings

PatronCustomDataStrings Table

A table to hold Unicode string values related to patron custom data entities

Columns

Column name | Data type | Description
PatronID | int | The patron possessing the custom data entity.
PatronCustomDataDefinitionID | int | The data definition ID related to the custom data entity.
CustomDataEntry | nvarchar(255) | The custom data value


PatronCustomValidationFailureMessages

PatronCustomValidationFailureMessages Table

List of failure messages that can be returned by a custom validation rule.

Columns

Column name | Data type | Description
FailureMessageID | int | Unique identifier for the failure message.
FailureMessageString | nvarchar(4000) | The message returned when custom validation fails.
PACMultiLingualStringMnemonic | nvarchar(100) | Mnemonic used to associate custom multilingual strings with the validation failure in PAC.
MobilePACMultiLingualStringMnemonic | nvarchar(100) | Mnemonic used to associate custom multilingual strings with the validation failure in MobilePAC.


PatronCustomValidationParameters

PatronCustomValidationParameters Table

List of available fields that custom validation rules can be written for.

Columns

Column name | Data type | Description
ValidationParameterID | int | Unique identifier for each validation parameter.
ValidationParameterName | nvarchar(255) | Name of the validation parameter used to create custom validation procedures.
ValidationParameterDescription | nvarchar(255) | Parameter name as it exists on the patron workform.


PatronCustomValidationRules

PatronCustomValidationRules Table

List of custom validation rules that can be used when saving a patron record..

Columns

Column name | Data type | Description
ValidationID | int | Unique identifier for the validation rule.
ValidationProcedure | nvarchar(400) | Name of the stored procedure used for validation.
ValidationRuleName | nvarchar(400) | Name of the validation rule.
ValidationRuleDescription | nvarchar(4000) | Brief description of what the validation rule does.

See Also

PatronCustomDataDefinitionsToPatronCustomValidationRules, PatronCustomValidationRulesToOrganizations,


PatronCustomValidationRulesToOrganizations

PatronCustomValidationRulesToOrganizations Table

Indicates which organizations are using each validation rule.

Columns

Column name | Data type | Description
ValidationID | int | Foreign key to the PatronCustomValidationRules table.
OrganizationID | int | The patrons organization ID.
IsEnabled | bit | Indicates whether or not the validation rule is being used.
ValidateInPAC | bit | Indicates whether or not the validation rule is being used in the PAC.


PatronDisplayOptions

PatronDisplayOptions Table

This tables stores all the avaible patron related data fields that can be selected to display in the check-out w/f.

Columns

Column name | Data type | Description
OptionID | tinyint | Identical ID of the data field.
OptionName | nvarchar(255) | Description of the data field.

See Also

SA_PatronDisplayOrder,


PatronFineNotices

PatronFineNotices Table

This table has entries for patrons who will be receiving fine notices.

Columns

Column name | Data type | Description
PatronID | int | ID of the patron who received the fine notice.
ReportingOrgID | int | The orgID of the organization on whose behalf the patron was reported.
FineNoticeDate | datetime | Date when the fine notice was sent.
Amount | money | Amount owed by the patron at the time the fine notice was sent.
DeliveryOptionID | int | Notification method ID indicates how fine notice is sent.


PatronFreeTextBlocks

PatronFreeTextBlocks Table

This table stores the free text blocks a patron has.

Columns

Column name | Data type | Description
PatronID | int | ID of patron who has the block. It references Patrons table (PatronID).
FreeTextBlock | nvarchar(255) | User entered text of the block.
FreeTextBlockID | int | ID of the free text block, a primary key.
CreationDate | datetime | Date of block
CreatorID | int | creator
ModifierID | int | modifier
ModificationDate | datetime | modification date
OrganizationID | int | Organization who created block
WorkstationID | int | Workstation who created block


PatronKeywordIndex

PatronKeywordIndex Table

Contains one row for each keyword indexed in a patron record.

Columns

Column name | Data type | Description
KeywordID | int | Is the patron identifier.
RecordID | int | Identifies the patron record from which a keyword has been indexed.
TypeFlags | smallint | Identifies one or more keyword types; based on the (MARC) data element from which the keyword was indexed.
TokenizedData | varbinary | Contains compressed binary data which includes the Significance, TypeFlags, ContractionCount, DelimiterClass, ChunkID and WordPosition for each occurrence of a keyword within a given record.


PatronKeywordRules

PatronKeywordRules Table

Contains one row for each patron keyword indexing rule. Each patron keyword indexing rule identifies a MARC data element to be indexed and is identified by a unique tag/subfield pair.

Columns

Column name | Data type | Description
TagNumber | smallint | Identifies the tag of a MARC data field to be indexed. This column combined with the Subfield column is unique for each row.
Subfield | char | Identifies the subfield of a MARC data element to be indexed. This column combined with the TagNumber column is unqiue for each row.
TypeFlags | smallint | Associates this rule with one or more patron keyword types. A keyword type is enabled if bit position POWER(2, TypeID - 1) is set to one, where TypeID must reference a row in the PatronKeywordTypes table.
MinimumSignificance | real | Contains the minimum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
MaximumSignificance | real | Contains the maximum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
AverageTermCount | real | Contains the average term count for a given data element associated with a specific TagNumber and Subfield.
AverageTermCountStandardDeviation | real | Contains the standard deviation of the AverageTermCount for a given data element associated with a specific TagNumber and Subfield.


PatronKeywords

PatronKeywords Table

Contains one row for each distinct keyword found in a patron record.

Columns

Column name | Data type | Description
KeywordID | int | Unique identifier for the row.
Term | nvarchar(128) | Normalized term suitable for keyword and phrase searching. This column is unique for each row.
Weight | real | The IDF (inverse document frequency) weight associated with the term. The weight equals log((N + 1) / n), where N = total number of records and n = number of records containing one or more occurrences of the keyword.

See Also

PatronKeywordIndex,


PatronKeywordTypes

PatronKeywordTypes Table

Contains one row for each patron keyword type. Each keyword type corresponds to a search access point and is associated with a subset of MARC data elments.

Columns

Column name | Data type | Description
TypeID | tinyint | Unique identifier for the row.
Name | nvarchar(100) | Unique name for the row.
Mnemonic | nvarchar(32) | Search qualifier name.
MinimumDegradation | float | Contains the minimum degradation applied to the relevance of a collocation composed of multiple keywords.
MaximumDegradation | float | Contains the maximum degradation applied to the relevance of a collocation composed of multiple keywords.


PatronLoanLimits

PatronLoanLimits Table

This table defines various loan limits for a particular Organization/PatronCode combination.

Columns

Column name | Data type | Description
OrganizationID | int | Foreign key into Polaris..Organizations that defines the organization context
PatronCodeID | int | Foreign key into Polaris..PatronCodes that defines the Patron Code context
MaxFine | money | Second level fine limit
MinFine | money | First level fine limit
TotalItems | int | Item limit
TotalOverDue | int | Overdue items limit
TotalHolds | int | Hold limit
TotalILL | int | Inter-library loan limit
TotalReserveItems | int | Reserve items limit


PatronLostItems

PatronLostItems Table

Table to store basic information of the items declared lost by patrons.

Columns

Column name | Data type | Description
LostID | int | Identity of the table.
PatronID | int | ID of the patron who declared the lost of the item.
ItemRecordID | int | ID of the lost item.
LostDate | datetime | Date the item was declared lost.
LoaningOrgID | int | Lost Item Record's checked-out branch's OrganizationID.
CheckOutDate | datetime | Lost Item Record's check-out date.
DueDate | datetime | Lost Item Record's due date.
LoanUnits | int | Lost Item Record's loan units when it's checked out.


PatronNotes

PatronNotes Table

Table holds the patron note fields, which used to be part of the PatronRegistration table.

Columns

Column name | Data type | Description
PatronID | int | Patron record ID
NonBlockingStatusNotes | nvarchar(4000) | Notes which do not cause a block for the patron
BlockingStatusNotes | nvarchar(4000) | Notes that cause a block when trying to do a checkout
NonBlockingStatusNoteDate | datetime | Date of non-blocking note
BlockingStatusNoteDate | datetime | Date of blocking note
NonBlockingBranchID | int | Organization who last modified note
NonBlockingUserID | int | User who last modified note
NonBlockingWorkstationID | int | Workstation who last modified note
BlockingBranchID | int | Organization who last modified note
BlockingUserID | int | User who last modified note
BlockingWorkstationID | int | Workstation who last modified note


PatronPaymentMethods

PatronPaymentMethods Table

Table of patron accounting used to specify payment methods. IDs of 1-5 are defined by system, 6-10 are reserved for system defination. IDs of 1-10 are used by system transactions only. The other payment methods are available to StaffClient and/or ExpressCheck where they are applicable. The non-system-defined payment methods can be selected or de-selected by organizations from SA Policy Table.

Columns

Column name | Data type | Description
PaymentMethodID | int | ID of payment method, primary key, unique identifier (IDENTITY).
Description | nvarchar(20) | Description of payment method.

See Also

NCIPPaymentTypes, PatronAccount, SA_PaymentMethods, SIPPaymentTypes,


PatronQualificationIndex

PatronQualificationIndex Table

Contains one row for each partial or complete search term matching one or more qualification types.

Columns

Column name | Data type | Description
PrefixKey | varbinary | A canonical binary prefix key associated with a partial or complete search term.
QualificationContextTuple | varbinary | Contains compressed binary data which includes the QualificationTypeID and HitCount.


PatronQualificationTypes

PatronQualificationTypes Table

Contains one row for each patron qualification type. Each qualification type corresponds to a search access point.

Columns

Column name | Data type | Description
QualificationTypeID | int | Unique identifier for the qualification type.
Name | nvarchar(100) | Unique name for the qualification type.
Mnemonic | nvarchar(32) | Search qualifier name.


PatronReadingHistory

PatronReadingHistory Table

This table has entries for the items that a patron has checked out. Entry into this table is dependant on 1. SA parameter - enable reading history being set for the patron's organization. 2. Patron Registration - Maintain Reading History being set for the patron. 3. The organization should record Polaris checkout transactions.

Columns

Column name | Data type | Description
PatronID | int | Patron who checked out the book.
ItemRecordID | int | ItemRecordID of the item which was checked out.
CheckOutDate | datetime | Date the item was checked out.
LoaningOrgID | int | Organization where the checkout took place.
BrowseAuthor | nvarchar(255) | Author of the item which was checked out.
BrowseTitle | nvarchar(255) | Title of the item which was checked out.
PrimaryMARCTOMID | tinyint | MARC Type of Material associated with history entry
Notes | nvarchar(255) | Notes regarding this reading history entry.
TitleRatingID | int | Link to the Title ratings table
PatronReadingHistoryID | int | Primary key


PatronRecordSets

PatronRecordSets Table

Contains a list of which patron records belong to which record sets.

Columns

Column name | Data type | Description
RecordSetID | int | Link to corresponding record set.
PatronID | int | Links to patron record


PatronRegistration

PatronRegistration Table

This table stores personal information of patron records, and library specified information for the patron records.

Columns

Column name | Data type | Description
PatronID | int | ID of patron record, internally used, primary key, relationship referencing Polaris.Patrons (PatronID)
LanguageID | smallint | ID of patron's language, references Polaris.Languages (LanguageID)
NameFirst | nvarchar(32) | Patron's first name.
NameLast | nvarchar(32) | Patron's last name.
NameMiddle | nvarchar(32) | Patron's middle name.
NameTitle | nvarchar(8) | Patron's title.
NameSuffix | nvarchar(4) | Patron's name suffix.
PhoneVoice1 | nvarchar(20) | Patron's first phone number.
PhoneVoice2 | nvarchar(20) | Patron's second phone number.
PhoneVoice3 | nvarchar(20) | Patron's third phone number
EmailAddress | nvarchar(64) | is the patron's email address
EntryDate | datetime | is the date when the record is inserted.
ExpirationDate | datetime | is the date when the patron's registration expires.
AddrCheckDate | datetime | Date to check patron address
UpdateDate | datetime | Date when the patron registration is modified.
User1 | nvarchar(64) | User defined field one.
User2 | nvarchar(64) | User defined field two.
User3 | nvarchar(64) | User defined field three.
User4 | nvarchar(64) | User defined field four.
User5 | nvarchar(64) | User defined field five.
Birthdate | datetime | is patron's birth date
RegistrationDate | datetime | Date when the patron gets registered.
FormerID | nvarchar(20) | is the patron's former barcode if any.
ReadingList | tinyint | Denotes whether Polaris will track the items that the patron checks out.
PhoneFAX | nvarchar(20) | Patron's fax number.
DeliveryOptionID | int | ID of notification option, references, Polaris.DeliveryOptions (DeliveryOptionID)
StatisticalClassID | int | Foreign key into Polaris..PatronStatClassCodes, representing a patron's statistical class
CollectionExempt | bit | Denotes if the patron is to be excluded from collection reports.
AltEmailAddress | nvarchar(64) | Secondary patron email address
ExcludeFromOverdues | bit | Denotes if the patron is to be excluded from overdue notices.
SDIEmailAddress | nvarchar(150) | Default Email address to be used for SDI notification
SDIEmailFormatID | int | Default Email format to be used for SDI notification.
SDIPositiveAssent | bit | Indicates that the patron has given permission for the SDI system to record information about their searches.
SDIPositiveAssentDate | datetime | Date that assent was changed.
DeletionExempt | bit | Denotes if the patron is to be excluded from deletion - if this is set, then the patron cannot be deleted.
PatronFullName | nvarchar(100) | The Patron's full name, last name first. This field is maintained via table triggers as the Concatenation of NameLast + ", " + NameFirst + " " + NameMiddle.
ExcludeFromHolds | bit | Indicates whether the patron is to be excluded from hold request notices.
ExcludeFromBills | bit | Indicates whether the patron is to be excluded from billing notices.
EmailFormatID | int | Is a code which has the patron's default email type, either plain text or html.
PatronFirstLastName | nvarchar(100) | The Patron's full name, first name first. This field is maintained via table triggers as the Concatenation of NameFirst + " " + NameLast + ", " + NameMiddle.
Username | nvarchar(50) | The patron's personally defined username established via the PAC.
MergeDate | datetime | Date this patron was merged with another
MergeUserID | int | Polaris user who did the merge
MergeBarcode | nvarchar(20) | The barcode of the secondary patron which was merged.
EnableSMS | bit | Indicates whether or not an additional TXT message notice will be sent along with a primary notice.
RequestPickupBranchID | int | Patron's default pickup branch for PAC requests
Phone1CarrierID | int | ID of PhoneVoice1 carrier. References to Polaris.SA_MobilePhoneCarriers(CarrierID).
Phone2CarrierID | int | ID of PhoneVoice2 carrier. References to Polaris.SA_MobilePhoneCarriers(CarrierID).
Phone3CarrierID | int | ID of PhoneVoice3 carrier. References to Polaris.SA_MobilePhoneCarriers(CarrierID).
eReceiptOptionID | int | ID of eReceipt option. References to Polaris.DeliveryOptions(DeliveryOptionID).
TxtPhoneNumber | tinyint | Indicates which phone number is used for TXT/SMS notification and/or eReceipt. The valid value of this column is 1, 2 or 3 which represents PhoneVoice1, PhoneVoice2 or PhoneVoice3 accordingly.
ExcludeFromAlmostOverdueAutoRenew | bit | Indicates whether the patron is to be excluded from receiving reminder notices for Almost Overdue/Auto Renew.
ExcludeFromPatronRecExpiration | bit | Indicates whether the patron is to be excluded from receiving reminder notices for Patron record expiration.
ExcludeFromInactivePatron | bit | Indicates whether the patron is to be excluded from receiving reminder notices for Inactive Patron.
DoNotShowEReceiptPrompt | bit | Bit field to determine if we display the prompt for EReceipts.
PasswordHash | nvarchar(256) | BCrypt password hash.
ObfuscatedPassword | nvarchar(256) | Obfuscated password.
NameTitleID | int | Unique identifier from the NameTitles table
RBdigitalPatronID | int | RBdigital Patron ID
GenderID | int | Unique identifier from the Genders table
LegalNameFirst | nvarchar(32) | First name on legal identification
LegalNameLast | nvarchar(32) | Last name on legal identification
LegalNameMiddle | nvarchar(32) | Middle name on legal identification
LegalFullName | nvarchar(100) | Calculated field concatenating LegalNameFirst, LegalNameMiddle, and LegalNameLast
UseLegalNameOnNotices | bit | Flag to signify that the legal name data should be used on print and phone notices


Patrons

Patrons Table

This table stores the basic information of patron records

Columns

Column name | Data type | Description
PatronID | int | ID of patron, internally used, is the primary key.
PatronCodeID | int | ID of patron category, references Polaris.PatronCodes (PatronCodeID).
OrganizationID | int | ID of branch the patron registered at, references Polaris.Organizations (OrganizationID).
CreatorID | int | ID of Polaris user who created the patron, references Polaris..PolarisUsers (PolarisUserID).
ModifierID | int | ID of Polaris user who modified the patron registration, references Polaris..PolarisUsers (PolarisUserID).
Barcode | nvarchar(20) | ID of patrons for circulation or patron service.
SystemBlocks | int | Will contain encoded data which will be retrieved on the bitwise level. 64 - block is set when patron self-registers via PAC 128 - block is set when patron clicks address update from PAC 256 - block is set when express registration is done from CheckOut WF 512 - block is set when patron is registered offline 1024 - block is set when patron account submitted to collection agency 2048 - block is set for Registration Renewal 4096 - block is set for Patron Registration Fee
YTDCircCount | int | The circulation count for the current year
LifetimeCircCount | int | The lifetime circulation total
LastActivityDate | datetime | Date of last circulation activity.
ClaimCount | int | Overall number of claims the patron has made.
LostItemCount | int | Number of lost item the patron has declared, reduced if the lost item found.
ChargesAmount | money | Total charges on patron's account.
CreditsAmount | money | Total credits on patron's account. gets updated via a trigger on PatronAccounts table.
RecordStatusID | int | For future use.
RecordStatusDate | datetime | For future use.
YTDYouSavedAmount | money | The amount saved for the current year
LifetimeYouSavedAmount | money | The lifetime amount saved.

See Also

ChangeAddress, ChangeBasicInfo, CircItemRecords, CollectionAgencyIncludePatrons, CourseInstructorLinks, DML_Patron, ILLRequests, ILSStoreOrders, InnReachRequests, ItemCheckouts, ItemRecordHistory, MailingLabelRecordSets, ORSPatronDisabilities, ORSPatronEquipment, ORSPatrons, ORSPatronSelectionLists, PAC_PatronFreeTextMessages, PAC_PatronMessages, PAC_PatronPasswordResetRequests, PAPIPatronAuthentication, PAPIPatronAuthenticationFailures, PatronAccount, PatronAddresses, PatronAssociations, PatronClaims, PatronCustomDataBoolean, PatronCustomDataDates, PatronCustomDataIntegers, PatronCustomDataStrings, PatronFineNotices, PatronFreeTextBlocks, PatronLostItems, PatronNotes, PatronReadingHistory, PatronRecordSets, PatronRegistration, PatronsPPPP, PatronStops, PrevYearPatronsCirc, RouteListMembers, SDIHeader, SysHoldRequests, TitleRatings,


PatronsInCollection

PatronsInCollection Table

This table has information on all the patrons that have been included in the current submission and update reports.

Columns

Column name | Data type | Description
OrgID | int | The organization that reported the patron in its report.
PatronID | int | The patron who was included in the report.
CollectionStatus | tinyint | Whether the patron was included in an update or submission report. 1 = submission, 2 = update, 3 = synch report
Amount | money | Amount that was due to the system.
CollectionDate | datetime | Date when the patron was included in the report.


PatronsPPPP

PatronsPPPP Table

Holds AdminAttribute data values that have been set for a particular Patron. (FOR FUTURE USE)

Columns

Column name | Data type | Description
PatronID | int | ID of the Patron the data pertains to.
AttrID | int | AdminAtrribute ID
Value | nvarchar(255) | The data value for this attribute


PatronStatClassCodes

PatronStatClassCodes Table

This table defines patron statistical class codes for each organization.

Columns

Column name | Data type | Description
StatisticalClassID | int | Unique identifier - Identity column
OrganizationID | int | Foreign key column to Polaris..Organizations
Description | nvarchar(80) | String description of the statistical class code

See Also

PatronRegistration, SA_AutoChangePatronCodeControl,


PatronsToDelete

PatronsToDelete Table

This table contains PatronID's that are flagged for physical deletion. Deleted patrons from the tech services client are flagged for deletion and are physicially deleted, based on the content of this table, in the overnight processing window.

Columns

Column name | Data type | Description
PatronID | int | Foreign key reference to the Patrons table indicating the patron record marked for deletion.
DeleteDate | datetime | Date the Patron was marked for deletion.
PatronBarcode | nvarchar(20) | The barcode of the deleted patron.


PatronStopDescriptions

PatronStopDescriptions Table

This table stores library defined patron blocks.

Columns

Column name | Data type | Description
PatronStopID | int | Is the block ID, primary key.
Description | nvarchar(80) | Is the block description.

See Also

ExpressCheckLibAssignedPBlocks, PatRenewalLibAssignedPBlocks, PatronStops, PatronStopsByBranch,


PatronStops

PatronStops Table

This table stores patrons who have the library defined blocks.

Columns

Column name | Data type | Description
PatronID | int | ID of patron who has block(s), combined primary key, references Patrons table (PatronID).
PatronStopID | int | ID of patron block defined by library, combined primary key, references PatronStopDescriptions table (PatronStopID).
CreationDate | datetime | Date of stop
CreatorID | int | Creator of block
ModifierID | int | modifier of block
ModificationDate | datetime | modification date
OrganizationID | int | organization who created block
WorkstationID | int | workstation who created block


PatronStopsByBranch

PatronStopsByBranch Table

This table lists the patron stops by branch, as well as the order of display.

Columns

Column name | Data type | Description
OrganizationID | int | OrganizationID
PatronStopID | int | The patron stop ID
SequenceID | int | Order of stop for display.
DisplayInPAC | bit | Can this stop display in PAC?
Selected | bit | Bit column flag that determines whether the given patron block is an available option for the given branch (1 = Yes, 0 = No). If 'No' then the DisplayInPAC column value will effectively be 'No' (enforced by the Staff Client's SA UI).


PaymentHistories

PaymentHistories Table

This is a secondary table used by Invoices.The payment status history is used, mainly for reporting purposes, to track the payment status of an invoice while it exists in the system. View 4 of the Invoice workform list entries in this table for the particular invoice.

Columns

Column name | Data type | Description
PaymentHistID | int | Polaris assigned unique ID number for a history record entry.
InvoiceID | int | Polaris assigned unique ID number for an invoice record.
InvoiceStatusID | int | Integer value used to link an Invoice Status with an entry in the Payment History record.
PaymentStatusID | int | Integer value used to link an Payment Status with an entry in the Payment History record.
CheckDate | datetime | User entered date that appears on a check.
CheckNumber | nvarchar(30) | Number that appears on a printed check.
CrdtCrdName | nvarchar(50) | Name of a credit card used to make a payment.
CrdtCrdNumber | nvarchar(16) | Credit card number used to make a payment.
DepAmtBase | money | For a DEPOSIT account, the amount that was deposited, either initially or in subsequent deposits, with the supplier.
DepAmtForeign | money | for a deposit account, the amount that was used on this invoice in the foreign base currency of the supplier/vendor.
ExchangeRate | numeric | The exchange rate that was used to convert a particular price from one currency to another.
ForeignCurrencyID | int | ID number of foreign currency used by supplier/vendor.
PaymentAmtBase | money | Amount of a payment entry in the libraries base currency.
PaymentAmtForeign | money | Amount of a payment entry in the foreign currency of the supplier/vendor.
PaymentDate | datetime | System generated date & time of payment entry.
PaymentStatusDate | datetime | System generated date & time the paymetn status changed.
PaymentType | int | Type of payment made, ie. payment, credit.
UserID | int | Polaris User ID of person entering the payment.
Note | nvarchar(200) | Free text typed in note field during the invoice adjustment process from invoice workform.
VchrNumber | nvarchar(30) | Number that appears on a printed voucher.
VchrDate | datetime | User entered date that appears on a voucher.

See Also

PaymentHistoryLinks,


PaymentHistoryLinks

PaymentHistoryLinks Table

this table links entries in the PaymentHistories table with one or more INLI Segments. It is used for printed vouchers functionality.

Columns

Column name | Data type | Description
PaymentHistID | int | ID of record in PaymentHistories table that is linked to the InvLineItemSegments entry (InvLineItemSegmentID)in the same row.
InvLineItemSegmentID | int | ID of record in InvLineItemSegments table that is linked to the Payment history entry (PaymentHistID)in the same row.
Amount | money | Monetary value of the payment


PaymentMethods

PaymentMethods Table

This is a secondary table used by Purchase Orders and Invoices.Payment methods are the method by which the purchase order or invoice is being paid.

Columns

Column name | Data type | Description
PaymentMethodID | int | Integer value used to link a Payment Method with a Purchase Order or an Invoice. Must be unique to this table.
PaymentMethod | nvarchar(50) | The method by which the purchase order or invoice is being paid for. Its pre-defined options are: deposit account, depository agreement, exchange, free, gift, membership, prepaid, purchase.

See Also

Invoices, PurchaseOrders, Subscriptions,


PaymentStatus

PaymentStatus Table

This is a secondary table used by the LineItemPaymentStatusHistories and PaymentStatusHistories records.Payment statuses are used to inform users of Polaris the payment status of an invoice or a line item record.

Columns

Column name | Data type | Description
PaymentStatusID | int | Integer value used to link a Payment Status with an entry in one of the payment history records. Must be unique to this table.
PaymentStatus | nvarchar(15) | Payment status. It is pre-defined, such as: credited, exchange, free, gift, held, open, paid, partially paid, payment pending.

See Also

InvLineItemSegments, InvLines, LineItemPaymentStatusHistories, LineItemSegmentPaymentStatusHistories, PaymentHistories, POLineItemSegments,


PaymentTypes

PaymentTypes Table

Used by Acquisitions for paying/crediting

Columns

Column name | Data type | Description
PaymentTypeID | int | INT, Primary Key, for retrieving PaymentType string data
PaymentType | nvarchar(25) | VARCHAR(25), NOT NULL


PeriodTerms

PeriodTerms Table

This table is used to store the terms of date time periods. This table is referenced by Polaris.RouteLists table.

Columns

Column name | Data type | Description
TermID | int | PK of the table to identify the entry. not an auto generated field.
Description | nvarchar(10) | literal description of the date time term. not NULL field.

See Also

RouteLists,


PermissionDefs

PermissionDefs Table

Permission Definitions. They're NOT the Permissions themselves. Each permission is defined by 2 IDs - Conrol Record ID and Permission Definition ID.

Columns

Column name | Data type | Description
PermissionID | int | Unique ID.
ControlRecordDefID | int | ID of corresponding Control Record Definition.
PermissionNameID | int | ID of Permission Name.

See Also

FindToolSearchObjects, PermissionGroups, PermissionUsers, PermissionWorkstations,


PermissionGroups

PermissionGroups Table

Groups, associated with the Permission.

Columns

Column name | Data type | Description
ControlRecordID | int | ID of Permission's Control Record.
PermissionID | int | ID of Permission's Definition.
GroupID | int | ID of Group.


PermissionNames

PermissionNames Table

Names of Permissions. All of them are supposed to be different - that's the idea of creating this special table.

Columns

Column name | Data type | Description
PermissionNameID | int | Unique ID.
PermissionName | nvarchar(80) | Name.

See Also

PermissionDefs,


PermissionUsers

PermissionUsers Table

Users, associated with the Permission.

Columns

Column name | Data type | Description
ControlRecordID | int | ID of Permission's Control Record.
PermissionID | int | ID of Permission's Definition.
PolarisUserID | int | ID of User.


PermissionWorkstations

PermissionWorkstations Table

Worfstations, associated with the Permission.

Columns

Column name | Data type | Description
ControlRecordID | int | ID of Permission's Control Record.
PermissionID | int | ID of Permission's Definition.
WorkstationID | int | ID of Workstation.


PersonalDatabases

PersonalDatabases Table

List of databases associated with a user

Columns

Column name | Data type | Description
PersonalDBID | int | Primary key
DisplayName | nvarchar(100) | Display name for the associated database for presentation to the user for DB selection.


PersonalSearchSettings

PersonalSearchSettings Table

This table contains the user defined search settings for each FT Search Context. If states the user's preferred search for and search by choices as well as whether or not the results should be sorted and whether a Power Search is preferred. The default for all contexts is the system default.

Columns

Column name | Data type | Description
UserID | int | Polaris User ID for which the Personal Search settings apply.
FTContextID | int | The Tech Client Find Tool context for which the search settings apply.
ObjectTypeID | int | Polaris Object ID that is be used as the default for specified FT Context ID.
SearchType | int | Specifies the default "search type" for the object and context ID.
UseSystemDefault | bit | when = 1, the system search defaults for the specified Find Tool Context ID are to be used.
Z3950SearchByValue | int | This column represents the actual Z3950 attribute value of the default 'search-by' choice that the Find Tool will be set to upon instantiation
Z3950LimitByValue | int | This column represents the specific 'Limit-By' setting (a Z3950 attribute value) that the Find Tool will default to when it is instantiated
SearchMode | int | This column represents the default Find Tool search mode (0 = Normal, 1 = Power, 2 = SQL) that the Find Tool will initially be brought up in
CountOnly | bit | A bit column representing the default setting of the 'Count Only' checkbox control on the Find Tool (1 = checked, 0 = unchecked)
SortCookie | bigint | Contains the persisted sort cookie for a given find tool context and object type. See the FindToolSortBys table for a more complete description of what is contained in a sort cookie.
DescriptorID | int | A unique ID that will be referenced by the PersonalSearchSettings_LBVs table (instead of the composite primary key of User/Find Tool Context/Object Type ID combination)


PersonalSearchSettings_LBVs

PersonalSearchSettings_LBVs Table

This table saves a set of 1 or more Find Tool limit-by values for a given entry in the PersonalSearchSettings table where the saved limit-by search access point is represented by a value list (i.e. not free text)

Columns

Column name | Data type | Description
DescriptorID | int | Foreign key reference to the PersonalSearchSettings table
LimitByValueID | int | Numerical limit-by value list entry


PhoneFormatsByCountry

PhoneFormatsByCountry Table

Contains one row for each unique phone number format/country pair

Columns

Column name | Data type | Description
FormatID | int | Unique identifier
CountryID | int | Unique country identifier
PhoneFormat | nvarchar(40) | Phone number format
PhoneTypeID | tinyint | Indicates Phone Call (1) or TXT Messaging (2)


PIM_CallNumberIndex

PIM_CallNumberIndex Table

Call Number Index used by Polaris Inventory Manager for presenting a shelf list for inventory. This table is maintained by the nightly database job ClassificationIndexMaintenance.

Columns

Column name | Data type | Description
AssignedBranchID | int | AssignedBranchID from the associated CircItemRecords table.
ItemRecordID | int | Item record unique identifier (Primary Key)
NormalCallNumber | nvarchar(255) | Normalized Call Number for this item.
NormalVolume | nvarchar(255) | Normalized Volume Number.


PIM_ClassificationIndex

PIM_ClassificationIndex Table

Classification Index used by Polaris Inventory Manager for presenting a shelf list for inventory. Essentially this is the Call Number without the prefix. This table is maintained by the nightly database job ClassificationIndexMaintenance.

Columns

Column name | Data type | Description
AssignedBranchID | int | AssignedBranchID from the associated CircItemRecords table.
ItemRecordID | int | Item record unique identifier (Primary Key)
NormalClassification | nvarchar(255) | Normalized Call Number without the prefix. Sorting by this field will result in a sort by Classification Number.
NormalVolume | nvarchar(255) | Normalized Volume Number.
CallNumberPrefix | nvarchar(60) | The Call Number prefix for the item.


POAmounts

POAmounts Table

This is a secondary table used by Purchase Orders. Becuase one purchase order can be asscoiated with more than one Fund, this table was developed to maintain which Fund(s) were being used for a given purchase order.

Columns

Column name | Data type | Description
PurchaseOrderID | int | ID number of purchase order linked to this record.
FiscalYearID | int | ID number of fiscal year linked to this record.
FundID | int | ID number of fund linked to this record.
Amount | money | Amount of money assigned to linked fund by linked purchase order.
Percentage | int | Percentage of line item total this amount represents.
ChargeType | int | Integer type that links the dollar amount to a specific charge type in the PO header WF.


PolarisCustomDataTypes

PolarisCustomDataTypes Table

List of available data types used to create custom data fields.

Columns

Column name | Data type | Description
PolarisCustomDataTypeID | int | Unique identifier for each data type.
PolarisCustomDataTypeDescription | nvarchar(80) | Description of the type of data stored in the field.

See Also

PatronCustomDataDefinition,


PolarisDBVersion

PolarisDBVersion Table

This table contains a single row of information as to the current version of the database.

Columns

Column name | Data type | Description
Version | nvarchar(50) | The Polaris build version of the database.
VersionDate | datetime | Date the database was upgraded to the current version.
AppServer | nvarchar(100) | The name of the AppServer associated with this server at installation.
SystemGUID | nvarchar(36) | Unique identifier for this local system. All Polaris customers will have a mutually exclusive unique value for this field.
CustomerDBID | nvarchar(36) | A unique identifier for a customer database. Used now by the authority update service, but could be used for other processes in the future.
DataPath | nvarchar(255) | This is the location of the DataPath on the server where the Polaris programdata resides.
x32BinPath | nvarchar(255) | This is the location of where the 32-bit ROOT path is. For example - on a 64 bit machine: c:\program files (x86)\polaris\3.4\ If the machine is 32 bit, then the path will be identical to the x64BinPath.
x64BinPath | nvarchar(255) | This is the location of where the 64-bit ROOT path is. For example: c:\program files\polaris\3.4If the server is 32 bit - then this path is identical to the x32BinPath column as well.
AltGUID | nvarchar(36) | An Alternate GUID used by SimplyReports for Licencing purposes


PolarisUserLists

PolarisUserLists Table

Holds lists of users used for different purposes. See KindOfList column description.

Columns

Column name | Data type | Description
OrganizationID | int | System, Library, or Branch where this list belongs.
PolarisUserID | int | User in the list.
KindOfList | int | List ID: 0 - users to be informed about patron self-registration 1 - users to be informed about info changes from PAC 2 - users in 'Ask Us' list


PolarisUsers

PolarisUsers Table

This table contains all of the users who are enabled to log onto the Polaris tech client.

Columns

Column name | Data type | Description
PolarisUserID | int | Primary key
OrganizationID | int | Link to which organization user belongs to
Name | nvarchar(50) | Name of Polaris user
BranchID | int | Link to organizations table but is branch specific
Enabled | bit | This column flags that a user has been deleted and no longer has privileges to perform operations.
CreatorID | int | ID of user who created this object
ModifierID | int | ID of user who last modified this object
CreationDate | datetime | Date/time of creation
ModificationDate | datetime | Date/time of the last modification
NetworkDomainID | int | Unique identifier of the network domain associated with the Polaris user.

See Also

AcqPurgeRecordDetails, AuthorityRecords, AuthorityTemplates, BibliographicRecords, BibliographicTemplates, CatPurgeCriterias, CircItemRecords, ClaimHistories, Claims, Collections, CommunityAuthorityRecords, CommunityImportJobs, CommunityImportProfiles, CommunityInformationRecords, ControlRecords, Copy_INLISegs, Copy_POLISegs, CourseReserves, CourseTemplates, EphemeralItemRecords, ExchangeRates, FindTool_SaveDefaultSearchDatabases, FindToolDefaultSearchDatabases, FindToolSavedSearches, FindToolSearchSettings, FiscalYears, Funds, FundTransactionHistories, Groups, GroupUsers, ILSStoreTransactions, Import_ScheduledImportFiles, ImportJobs, ImportProfiles, InvLineItemSegments, InvLines, Invoices, ItemBulkChangeTemplates, ItemCheckouts, ItemRecordDetails, ItemRecordHistory, ItemTemplates, Job_PurchaseOrders, MailingLabelRecordSets, MARCMacro, MfhdIssues, MfhdPublicationPatterns, MRMS_StaffTermsOfUseAcceptance, ObjectLocks, Organizations, PAC_PatronFreeTextMessages, PAC_PatronMessages, PatronAccount, PatronAddresses, PatronAssociations, PatronFreeTextBlocks, PatronNotes, PatronRegistration, Patrons, PatronStops, PermissionUsers, PersonalSearchSettings, PolarisUserLists, PolarisUsers, POLineItemSegments, POLines, PromotionCampaigns, Promotions, PSE_InvoicesLog, PurchaseOrders, ReceiveShipmentLogs, RecordSets, ResourceEntities, RouteLists, Rpt_RouteSlips, Rpt_SubsCancelNotices, RWRITER_BranchUserSecurity, RWRITER_UserSecurity, RWRITERSavedReports, RWRITERScheduledJobs, SA_ResourceGroups, SelectionLists, SelListLines, SelListLineSegments, Servers, SHRCopies, SubscriptionRenewalHistories, Subscriptions, Suppliers, SysHoldHistory, UsersPPPP, VendorAccounts, Vendors, Workstations,


POLIDuplicateSegmentLinks

POLIDuplicateSegmentLinks Table

table contains the ID's of the source POLI Segment, it's POLI and Purchase Order as well as those of any segments found to be duplicates.

Columns

Column name | Data type | Description
SourcePOID | int | Purchase Order ID of the Source PO from which duplicate detectio was started.
SourcePOLineID | int | Purchase Order Line Item ID of the POLI that has segments in the system which duplicate detection was started.
SourcePOLISegmentID | int | Purchase Order Line Item Segment ID of the POLI Segment for which duplicates exist.
UserOrgID | int | Organization for which the Polaris User performing duplciate detection is logged into.
UserID | int | PolarisUserID of the user that initiated the duplicate detection.
WorkstationID | int | Workstation from which duplcaite detection was initiated. This, coupled with the UserID and OrgID allow multiple user to perform independent duplicate detectio processes using the same table.
DupePOID | int | Purchase Order ID of the PO that contains the duplciate segment(s)
DupeLineID | int | Purchase Order Line Item ID of the line containing the duplicate segment(s).
DupeSegID | int | POLI Segment ID of the a duplicate segment.
DupeOrderedDate | datetime | DateTime data type. Stores the 'Release date' from the PO on which the duplicate segment exists.


POLIDuplicateSegments

POLIDuplicateSegments Table

table contains the details of the duplicate segments that is displayed on the duplicates report.

Columns

Column name | Data type | Description
SegmentID | int | POLI SegmentID of the source POLI segment.
Title | nvarchar(255) | Title contained on the source POLI.
ISBN | nvarchar(50) | ISBN number of the Source POLI.
BibID | int | Bibliographic Record ID on POLI for which there are duplicate segments.
LineNumber | int | POLI's line number on the Source PO that has duplicate segments in the system
SegNumber | int | segment number on the POLI of the source segment.
Destination | nvarchar(50) | Source POLI Segments destined branch/library
Collection | nvarchar(50) | Source POLI Segment's Destination Collection
Total | int | Total number of segments for which the source segments has duplicates
PurOrderID | int | Purchase OrderID of the Source PO.
PolarisUser | int | PolarisUserID of the user that performed the duplicate detection.
Workstation | int | Workstation from which duplcaite detection was initiated. This, coupled with the UserID and OrgID allow multiple user to perform independent duplicate detectio processes using the same table.
UserOrg | int | OrganizationID for which the user performing duplcaite detection is logged into.
OrderedDate | datetime | DateTime data type. Stores the 'Release Date' from the PO on which the order duplicate segment exists.


POLineItemSegmentAmts

POLineItemSegmentAmts Table

This table tracks which Fund(s) is being used for a given Line Item Segment. Each PO segment can have one or more funds for payment.

Columns

Column name | Data type | Description
POLineItemSegmentID | int | ID number of the PO line item segment llinked to this record.
FiscalYearID | int | ID of the fiscal year linked to this record.
FundID | int | ID of the fund linked to this record.
Amount | money | Amount of money assigned from a linked fund to a linked PO line item segment.
Percentage | int | Percentage of the segment total that is allocated to the associated fund.


POLineItemSegments

POLineItemSegments Table

This is the main table used by the Purchase Order Line Item Segment object.

Columns

Column name | Data type | Description
POLineItemSegmentID | int | Polaris assigned unique ID number for a purchase order line item segment record. Each PO segment must belong to a specific PO line.
PurchaseOrderID | int | Polaris assigned unique ID number for linked the purchase order record.
POLineItemID | int | Polaris assigned unique ID number for a purchase order line item record.
AmountEncumbered | money | The currency amount that is currently encumbered by the purchase order line item segment. It insures that monies in the linked funds are unencumbered properly.
BindFormatChargeBase | money | Added cost associated with that segment that has special bindings requested.
CatServChargeBase | money | Cataloging service charge for this segment in the base currency of the library.
CreationDate | datetime | System generated date & time that this record was created.
CreatorID | int | Polaris User ID of the person that created the record.
DestinationCollectionID | int | The ID number of the collection for which an item is being purchased (for example, children's collection, reference collection, etc.)
DestinationOrgID | int | Organization ID of the destination organization for an item.
Encumbered | bit | A flag specifying whether funds have been encumbered for this segment. (0=NO (default), 1=YES)
Expended | bit | A flag specifying whether funds have been expended for this segment. (0=NO (default), 1=YES)
GrandTotalSegmentBase | money | The grand total of the segment in the library's base currency.
Invoiced | int | A flag indication if there is an invoice segment linked to it or not.
ModificationDate | datetime | System generated date & time that this record was modified.
ModifierID | int | Polaris User ID of the person who last modified the record.
POLISegmentNumber | int | The PO line item segment number as it appears on the purchase order.
PaymentStatusID | int | Integer value used to link a Payment Status with an entry in one of the payment history records.
PaymentStatusDate | datetime | The date on which the current payment status was entered.
OtherChargeBase | money | Other charges associated with the segment in the base currency of the library.
QuantOrd | smallint | Number of items ordered.
QuantRec | smallint | Number of items received.
QuantSent | smallint | Number of items sent by the supplier.
SalesTax1Base | money | Main sales tax associated with this segment in the base currency of the library.
SalesTax2Base | money | Secondary sales tax associated with this segment in the base currency of the library.
ServChargeBase | money | Service charge associated with this segment in the base currency of the library.
ShipChargeBase | money | Shipping charge associated with this segment in the base currency of the library.
SpecialHandChargeBase | money | Speical handling charge associated with this segment in the base currency of the library.
StatusID | int | An integer which identifies the status of the item on the segment. IDs and descriptions of all valid statuses for lines and segments are found on the LineItemStatus table.
StatusDate | datetime | The date on which the current acquisitions status was entered.
TotDiscPriceBase | money | The discount Price Per Unit multiplied by the Quantity Ordered (for a PO) or Quantity Sent (for an Invoice).
RequesterName | nvarchar(50) | The person who requested this item
ItemTemplateCode | nvarchar(10) | VARCHAR(10) - holds a template matching code populated from a Bib's 970 data.
RecByASN | bit | BIT - when set reflects the POLI Seg has been through EDI ASN receipt processing.
SplitPOLISegmentID | int | When a POLI Segment is split due to a partial invoice being received, this is a reference from the orginal POLineItemSegmentID to the newly split POLineItemSegmentID.

See Also

Copy_POLISegs, InvLineItemSegments, LineItemSegmentPaymentStatusHistories, LineItemSegmentToItemRecord, POLineItemSegmentAmts, POLineItemSegmentStatusHistories, ReceiveShipmentLogs,


POLineItemSegmentStatusHistories

POLineItemSegmentStatusHistories Table

This is a secondary table used by the PO line item object. The line item segment status history is used mainly for reporting purposes. It tracks the status of a PO line item segment while it exists in the system. The most recent entry is the one that displays in the PO line item segment workform.

Columns

Column name | Data type | Description
POLineItemSegmentID | int | Polaris assigned unique ID number for a PO line item segment record.
StatusID | int | Integer value linked to the Line Item Status table. It indicates the status of a Purchase Order segment.
StatusDate | datetime | System supplied date & time the StatusID was set.


POLines

POLines Table

This is the main table used by the Purchase Order Line Item object.

Columns

Column name | Data type | Description
POLineItemID | int | Polaris assigned unique ID number for a purchase order line item record.
PurchaseOrderID | int | Polaris assigned unique ID number for linked the purchase order record.
BibliographicRecordID | int | Polaris assigned unique ID number for linked bibliographic record.
BackorderInstrID | int | Desc for BackOrder
BindingFormatID | int | ID number for linked binding format instructions to supplier.
BindingSubInstrID | int | ID number for linked binding substitution instructions to supplier.
CatServInstrID | int | ID number for linked cataloging services instructions to supplier.
CatServQnty | smallint | Number of cataloging items requested.
ClmAlertDate | datetime | The date on which the item should first appear on the Claim Alert List.
ClmWtPer1 | smallint | The number of days to wait after a purchase order is released before the first clam.
ClmWtPer2 | smallint | Number of days to wait after first claim before sending a second.
ClmWtPer3 | smallint | Number of days to wait after second claim before sending a third.
ClmWtPer4 | smallint | Number of days to wait after third claim before sending a fourth.
ClmWtPer5 | smallint | Number of days to wait after fourth claim before sending a fifth.
CopyNumber | int | a number identifying the specific copy of a particular item.
CreationDate | datetime | System generated date & time that this record was created.
CreatorID | int | Polaris User ID of the that created the record.
DiscPriceUnitBase | money | Discount price paid for each item in the base currency of the library.
DiscRate | numeric | Discount rate applied to the line item.
ISBN_ISSN | nvarchar(50) | International Standard Book Number/International Standard Serial Number of the item.
ModificationDate | datetime | System generated date & time of the last modification to this record.
LineNumber | int | Line item number as it appears on the purchase order.
ListPriceUnitBase | money | List price/unit for the item in the libraries base currency. This is the price before the discount rate, if any, is applied.
MaxClaims | smallint | The number of claims that will be made against an item before it is canceled, or other action taken.
ModifierID | int | Polaris User ID of the person who last modified this record.
NotePub | nvarchar(255) | Free text note field for public notes.
NoteStaff | nvarchar(255) | Free text note field for staff notes.
NoteSupplier | nvarchar(255) | Free text note field for supplier notes.
POConfirmDate | datetime | The date upon which the library received confirmation from a supplier/vendor that the order had been received.
RentalReturnDate | datetime | The date upon which a rented item must be returned.
ReqName | nvarchar(50) | The name of the person that requested the item(s) be purchased. Comes from the selection list line item.
ReserveHold | smallint | An indication that an item or copy should be held for pickup by a library patron after it has been processed.
StartDate | datetime | The date on which a subscription, standing order, approval plan or other continuing plan should start.
StartNumber | nvarchar(25) | The issue number with which a subscription, standing order, approval plan or other continuing plan should start ....
SubscrPeriod | nvarchar(30) | The length of time or other unit covered by a subscription
TitleOrderedAs | nvarchar(255) | In cases where the title of an item changes between the time it is ordered and the time it arrives at the library, this feild allows the user to permanently record teh title under which the item was ordered.
SubscrExpDate | datetime | The date on which a subscription is due to expire.
MaterialTypeID | int | ID number for linked material type of the item(s) being ordered.
SLLineItemID | int | ID number for the linked selection list line item record.
StatusID | int | An integer which identifies the status of the PO line. IDs and descriptions of all valid statuses for lines and segments are found on the LineItemStatus table.
StatusDate | datetime | The date on which the current acquisitions status was entered.
NormalIsbnIssn | nvarchar(50) | This contains the normailzed version of the ISBN/ISSN number stored with a partiular line item. It is normalized based on Polaris' Normalization routine at the time the line item is saved to the database.
ClmNoticeInd | bit | flag determining whether a claim notice will be generated during overnight claim processing
CanNoticeInd | bit | flag to determine if cancellation notice should be generated duing overnight cancellation processing.
AutoCancelInd | bit | flag to determine if line should be included in overnight cancellation processing.
CanWtPer | int | number of days after last claim is generated that the line will be automatically cancelled during overnight processing.
CatalogNumber | nvarchar(50) | Bibliographic Catalog Number for the item being ordered. May be different from that of the linked Bibliographic Record. NOTE: This is known as Other Number in SLLI table as well as the SLLI, POLI and INLI UI.
Title | nvarchar(255) | title used for display purposes
Author | nvarchar(255) | author field used for display
MARCLCCN | nvarchar(40) | the LCCN found in associated bib record (if link exists) or entered by user.
Alert | bit | flag telling the user that they need to manually look at the line item
NormalLCCN | nvarchar(40) | normalized LCCN for searching
NormalTitle | nvarchar(255) | normalized title for searching
NormalAuthor | nvarchar(255) | normalized author for searching
TitleNonFilingCount | tinyint | Is the number of non-filing characters in the Title column that should be ignored for collating purposes.

See Also

InvLines, LineItemPaymentStatusHistories, POLineItemSegments, POLinesStatusHistories,


POLinesStatusHistories

POLinesStatusHistories Table

This is a secondary table used by the purchase order line item object.The line item status history is used, mainly for reporting purposes, to track the status of a purchase order line item while it exists in the system. The most recent entry is the one that displays in the purchase order line item workform.

Columns

Column name | Data type | Description
POLineItemID | int | Polaris assigned unique ID number for a purchase order line item record.
LineItemStatusID | int | Integer value used to link a Purchase Ordere Status with a purchase order.
StatusDate | datetime | System supplied date & time the LineItemStatusID was set.


PORelItemCreateErrors

PORelItemCreateErrors Table

table used to return errors encountered when createing item records during PO release

Columns

Column name | Data type | Description
poid | int | PurchaseOrderID of PO being released.
errorString | nvarchar(255) | varchar data type used to hold error messages


PostalCodes

PostalCodes Table

This table keeps a list of USPS Postal codes

Columns

Column name | Data type | Description
PostalCodeID | int | Primary key
PostalCode | nvarchar(12) | The actual zip code
City | nvarchar(32) | City used with the postal code
State | nvarchar(32) | State associated with postal code
CountryID | int | Link to countries table
County | nvarchar(32) | County where postal code is valid

See Also

Addresses,


PrevYearEphemeralItemsCirc

PrevYearEphemeralItemsCirc Table

The previous year circ counts for ephemeral items, populated when ytd circ count rollover process is run.

Columns

Column name | Data type | Description
EphemeralItemID | int | Item id
YTDCircCount | int | Circ count


PrevYearItemsCirc

PrevYearItemsCirc Table

The previous year circ counts for items, populated when ytd circ count rollover process is run.

Columns

Column name | Data type | Description
ItemRecordID | int | Item ID
YTDCircCount | int | Circ count
YTDInHouseUseCount | int | In house use count


PrevYearItemsCircPerBranch

PrevYearItemsCircPerBranch Table

The previous year circ counts for quick circ items per branch, populated when ytd circ count rollover process is run.

Columns

Column name | Data type | Description
ItemRecordID | int | Item ID
OrganizationID | int | Organization ID
YTDCircCount | int | Circ count
YTDInHouseUseCount | int | In house use count


PrevYearPatronsCirc

PrevYearPatronsCirc Table

The previous year circ counts for patrons, populated when ytd circ count rollover process is run.

Columns

Column name | Data type | Description
PatronID | int | Patron ID
YTDCircCount | int | Circ count


PrevYearReserveItemCourseCirc

PrevYearReserveItemCourseCirc Table

The previous year circ counts for reserve items by course, populated when ytd circ count rollover process is run.

Columns

Column name | Data type | Description
ItemRecordID | int | Item ID
CourseReserveID | int | Course reserve ID
YTDCircCount | int | Circ count


PrevYearReserveItemsCirc

PrevYearReserveItemsCirc Table

The previous year circ counts for reserve items, populated when ytd circ count rollover process is run.

Columns

Column name | Data type | Description
ItemRecordID | int | Item ID
YTDCircCount | int | Circ count


PrevYearYouSavedAmount

PrevYearYouSavedAmount Table

The previous year you saved amounts for patrons, populated when ytd rollover process is run.

Columns

Column name | Data type | Description
PatronID | int | Patron ID
YTDYouSavedAmount | money | Amount saved year to date


PrinterControlCodeDefs

PrinterControlCodeDefs Table

This table stores all control code definition for the receipt printer drivers defined by user from Polaris TechClient SA Staff Client Profile "Receipt printer control codes".

Columns

Column name | Data type | Description
PrinterID | int | Printer Driver ID. This is a foreign key references PrinterDrivers(PrinterID).
CodeID | tinyint | Control code ID. This is a foreign key references PrinterControlCodes(CodeID).
Enabled | bit | Whether or not the control code is enabled for the printer.
StartCode | nvarchar(255) | Control code to set a property. All the characters in this field are ANSI characters.
EndCode | nvarchar(255) | Control code to cancel a property previously defined. All the characters in this field are ANSI characters.


PrinterControlCodes

PrinterControlCodes Table

This table stores all the control code definitions for a printer. all the values here are system defined values.

Columns

Column name | Data type | Description
CodeID | tinyint | Numeric ID of a control code.
CodeDesc | nvarchar(100) | Desciption of a control code.


PrinterDrivers

PrinterDrivers Table

This table stores all the receipt printer drivers defined by user from Polaris TechClient SA Staff Client Profile "Receipt printer control codes".

Columns

Column name | Data type | Description
PrinterID | int | Numeric ID of the driver.
DriverName | nvarchar(255) | Printer driver's name. For example, Star TSP700.
Visible | bit | Boolean value to indicate whether or not Printer Driver name will be available for staff client to select in Circulation droplist.


Products

Products Table

This table contains descriptions of the various Polaris products that are available for multi-lingual expression.

Columns

Column name | Data type | Description
ProductID | int | Unique identifier - Primary Key
Description | nvarchar(80) | String description of the product.

See Also

NSMPresentationSchemes, NSMPresentationTemplates, SA_CustomMultiLingualStrings, SA_DefaultMultiLingualStrings, ThirdPartyAPIFailures,


PromotionBibliographicLinks

PromotionBibliographicLinks Table

Contains zero or more rows for each promotion with a LinkageTypeID equal to 1 (Bibliographic).

Columns

Column name | Data type | Description
PromotionID | int | Unique identifier of the promotion.
RecordID | int | Unique identifier of the bibliographic record.


PromotionCampaigns

PromotionCampaigns Table

A table to define campaigns. Campaigns are automatic promotions based on a user defined set of criteria that is used to select records to be promoted.

Columns

Column name | Data type | Description
PromotionCampaignID | int | A unique identifier for the campaign record
CampaignLinkageTypeID | tinyint | The type of campaign.FK to the CampaignLinkageTypes table.
OwnerOrganizationID | int | The organization owner of the campaign. FK reference to the Organization table
Name | nvarchar(255) | The name of the campaign
NormalizedName | nvarchar(255) | The NACO normalized name of the campaign
CreationDate | datetime | That date and time that the campaign record was created.
ModificationDate | datetime | The date that the campaign was modified
ActivationDate | datetime | The date and time the campaign was activated
ExpirationDate | datetime | The date and time the campaign will expire
CreatorID | int | The creator of the campaign record. FK to the PolarisUsers table
ModifierID | int | The user that modified the record. FK to the PolarisUsers table
LanguageGroupID | int | The language group associated with the campaign. Used in demographic targeting of the campaign. FK to the PromotionLanguageGroups table.
LocationGroupID | int | The location group associated with the campaign. Used in demographic targeting of the campaign. FK to the PromotionLocationGroups table.
Enabled | bit | Indicates if the campaign is enabled.
Weight | real | For internal use.
TargetOwnerGroupID | int | The organization owner of the objects targeted by the campaign. FK reference to the PromotionLocationGroups table

See Also

Promotions,


PromotionCommunityLinks

PromotionCommunityLinks Table

Contains zero or more rows for each promotion with a LinkageTypeID equal to 2 (Community).

Columns

Column name | Data type | Description
PromotionID | int | Unique identifier of the promotion.
RecordID | int | Unique identifier of the community information record.


PromotionConcordance

PromotionConcordance Table

Contains one row for each distinct collocation composed of 1 to 8 keywords within a promotion.

Columns

Column name | Data type | Description
CollocationID | int | Identifier of the collocation. This column is unique to each row.
LexicalContextTuple | varbinary | Compressed tuple of keyword/delimiter pairs.


PromotionConcordanceRadix

PromotionConcordanceRadix Table

Contains one row for each distinct code point at a given prefix-position within the concordance.

Columns

Column name | Data type | Description
NexusID | int | Identifier of the nexus. This column is unique to each row.
ParentNexusID | int | Identifier of the parent nexus.
EdgeTransition | nchar | Distinct code point at a given prefix-position within the concordance.
SemanticHintTuple | varbinary | Compressed tuple of collocation hints.


PromotionKeywordIndex

PromotionKeywordIndex Table

Contains one row for each keyword indexed in a promotion.

Columns

Column name | Data type | Description
KeywordID | int | Unique identifier of the keyword.
RecordID | int | Unique identifier of the promotion.
TypeFlags | smallint | Identifies one or more keyword types; based on the (MARC) data element from which the keyword was indexed.
TokenizedData | varbinary | Contains compressed binary data which includes the Significance, TypeFlags, ContractionCount, DelimiterClass, ChunkID and WordPosition for each occurrence of a keyword within a given record.


PromotionKeywordRules

PromotionKeywordRules Table

Contains one row for each promotion keyword indexing rule. Each promotion keyword indexing rule identifies a MARC data element to be indexed and is identified by a unique tag/subfield pair.

Columns

Column name | Data type | Description
TagNumber | smallint | Identifies the tag of a MARC data field to be indexed. This column combined with the Subfield column is unique for each row.
Subfield | char | Identifies the subfield of a MARC data element to be indexed. This column combined with the TagNumber column is unique for each row.
TypeFlags | smallint | Identifies one or more keyword types; based on the (MARC) data element from which the keyword was indexed.
MinimumSignificance | real | Contains the minimum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
MaximumSignificance | real | Contains the maximum significance assigned to keyword within a data element associated with a specific TagNumber and Subfield.
AverageTermCount | real | Contains the average term count for a given data element associated with a specific TagNumber and Subfield.
AverageTermCountStandardDeviation | real | Contains the standard deviation of the AverageTermCount for a given data element associated with a specific TagNumber and Subfield.


PromotionKeywords

PromotionKeywords Table

Contains one row for each distinct keyword found in any promotion.

Columns

Column name | Data type | Description
KeywordID | int | Unique identifier of the keyword.
Term | nvarchar(128) | Normalized term suitable for keyword and phrase searching. This column is unique for each row.
Weight | real | The IDF (inverse document frequency) weight associated with the term. The weight equals log((N + 1) / n), where N = total number of records and n = number of records containing one or more occurrences of the keyword.

See Also

PromotionKeywordIndex,


PromotionKeywordTypes

PromotionKeywordTypes Table

Contains one row for each promotion keyword type.

Columns

Column name | Data type | Description
TypeID | tinyint | Unique identifier of the keyword type.
Name | nvarchar(100) | Unique name of the keyword type.
Mnemonic | nvarchar(32) | Search qualifier name.
MinimumDegradation | float | Contains the minimum degradation applied to the relevance of a collocation composed of multiple keywords.
MaximumDegradation | float | Contains the maximum degradation applied to the relevance of a collocation composed of multiple keywords.


PromotionLanguageGroups

PromotionLanguageGroups Table

Contains one row for a distinct group of languages.

Columns

Column name | Data type | Description
LanguageGroupID | int | Unique identifer assigned to the language group.
PrefixKey | varbinary | A canonical binary prefix key associated with the language group. The combination of the PrefixKey column and the SuffixKey column is unqiue for each distinct group of languages.
SuffixKey | varbinary | A canonical binary suffix key associated with the language group. The combination of the PrefixKey column and the SuffixKey column is unqiue for each distinct group of languages.

See Also

PromotionCampaigns, PromotionLanguageIndex, Promotions,


PromotionLanguageIndex

PromotionLanguageIndex Table

Contains one row for each language associated with a language group.

Columns

Column name | Data type | Description
LanguageGroupID | int | Unique identifier assigned to a language group.
LanguageID | int | Unique identifier assigned to language.


PromotionLinkageTypes

PromotionLinkageTypes Table

Contains one row for each linkage type.

Columns

Column name | Data type | Description
LinkageTypeID | tinyint | Unique identifier of the linkage type.
Name | nvarchar(255) | Unique name of the linkage type.

See Also

Promotions,


PromotionLocationGroups

PromotionLocationGroups Table

Contains one row for a distinct group of locations.

Columns

Column name | Data type | Description
LocationGroupID | int | Unique identifer assigned to the location group.
PrefixKey | varbinary | A canonical binary prefix key associated with the location group. The combination of the PrefixKey column and the SuffixKey column is unqiue for each distinct group of locations.
SuffixKey | varbinary | A canonical binary suffix key associated with the location group. The combination of the PrefixKey column and the SuffixKey column is unqiue for each distinct group of locations.

See Also

PromotionCampaigns, PromotionLocationIndex, Promotions,


PromotionLocationIndex

PromotionLocationIndex Table

Contains one row for each location associated with a location group.

Columns

Column name | Data type | Description
LocationGroupID | int | Unique identifier assigned to a location group.
LocationID | int | Unique identifier assigned to a location (i.e. OrganizationID).


Promotions

Promotions Table

Contains one row for each promotion.

Columns

Column name | Data type | Description
PromotionID | int | Unique identifier of the promotion.
LinkageTypeID | tinyint | Identifier of the linkage type of the promotion.
OwnerOrganizationID | int | Unique identifier of the organization that owns the promotion.
Name | nvarchar(255) | User specified name of the promotion.
NormalizedName | nvarchar(255) | Normalized text used for searching and sorting by the promotion's name.
Headline | nvarchar(255) | Text displayed in the headline of the promotion.
NormalizedHeadline | nvarchar(255) | Normalized text used for searching and sorting by the promotion's headline.
Midline | nvarchar(255) | Text displayed in the midline of the promotion.
NormalizedMidline | nvarchar(255) | Normalized text used for searching and sorting by the promotion's midline.
Footline | nvarchar(255) | Text displayed in the footline of the promotion.
NormalizedFootline | nvarchar(255) | Normalized text used for searching and sorting by the promotion's footline.
CreationDate | datetime | Date and time on which the promotion was created.
ModificationDate | datetime | The date and time on which the promotion was last modified.
ActivationDate | datetime | Date and time on which the promotion becomes active.
ExpirationDate | datetime | Date and time on which the promotion expires.
CreatorID | int | Identifier of the user that created the promotion.
ModifierID | int | Identifier of the user that last modified the promotion.
LanguageGroupID | int | Specifies the language group identifier associated with this promotion. If the LanguageGroupID is NULL, then this promotion is targeted for all languages, otherwise this promotion is only targeted for those languages associated with the specified language group.
LocationGroupID | int | Specifies the location group identifier associated with this promotion. If the LocationGroupID is NULL, then this promotion is targeted for all locations, otherwise this promotion is only targeted for those locations associated with the specified location group.
PromotionCampaignID | int | The campaign ID to which the promotion is linked. FK reference to the PromotionCampaigns table.

See Also

PromotionBibliographicLinks, PromotionCommunityLinks, PromotionSiteLinks, PromotionTriggers,


PromotionSiteLinks

PromotionSiteLinks Table

Contains zero or one row for each promotion linked directly to a remote web site (LinkageTypeID = 3).

Columns

Column name | Data type | Description
PromotionID | int | Unique identifier of the promotion.
SiteURL | nvarchar(4000) | Destination URL associated with a promotion.


PromotionTriggers

PromotionTriggers Table

Contains one row for each trigger associated with a promotion.

Columns

Column name | Data type | Description
PromotionID | int | Unique identifier of the related promotion.
TriggerID | smallint | Unique identifier of the trigger.
IsNegative | bit | Flag specifying whether the trigger is negative or positive. A promotion will only display when zero negative triggers and one or more positive triggers match the search terms in a user's query.
TypeFlags | smallint | Restricts the trigger to a set of keyword types.
FreetextString | nvarchar(255) | Keywords and phrases to compare against the search terms in a user's query.


PSE_Funds

PSE_Funds Table

A table that maintains list of funds that are targeted by an export process

Columns

Column name | Data type | Description
FiscalYearID | int | The Fiscal year associated with the fund
FundID | int | The Fund ID


PSE_InvoicesLog

PSE_InvoicesLog Table

A table that maintains a log of invoice data that has been exported by certian export utilities

Columns

Column name | Data type | Description
InvID | int | The Invoice ID that was exported
AccountingDate | datetime | The date and time that the invoice data was exported
ExcelFilename | nvarchar(-1) | The name of the file to which the invoice data was exported
PolarisUserID | int | The Polaris User that initiated the export


PurchaseOrders

PurchaseOrders Table

This table holds information and links to information that pertains to Purchase Orders.

Columns

Column name | Data type | Description
PurchaseOrderID | int | Polaris assigned unique ID number for the purchase order record.
InvSequencingID | int | ID number for linked invoice sequencing instructions to supplier.
PaymentMethodID | int | ID number for linked payment method.
ShippingMethodID | int | ID number for linked shipping method instructions to supplier.
BackorderInstrID | int | Polaris assigned unique ID number for the purchase order record.
BindingSubInstrID | int | ID number for linked binding substitution instructions to supplier.
CatServInstrID | int | ID number for linked cataloging services instructions to supplier.
InvDeliveryMethID | int | ID number for linked invoice delivery method instructions to supplier.
OrderTypeID | int | ID number for linked purchase order type.
OrganizationID | int | ID number of organization that created/placed the order.
SupplierID | int | ID number of supplier to which the order was sent.
OrderStatusID | int | ID number for linked backorder instructions to supplier.
EDIFileCreateDateTime | datetime | System generated date & time that a BISAC file for this order was created.
EDIFileName | nvarchar(50) | Name of the BISAC file created for this order.
CatServChargeBase | money | Cataloging service charge for this line in the base currency of the library.
CatServChargeForeign | money | Cataloging service charge for this line in the foreign currency of the supplier/vendor.
ClmWtPer1 | smallint | The number of days to wait after a purchase order is released before the first clam.
ClmWtPer2 | smallint | Number of days to wait after first claim before sending a second.
ClmWtPer3 | smallint | Number of days to wait after second claim before sending a third.
ClmWtPer4 | smallint | Number of days to wait after third claim before sending a fourth.
ClmWtPer5 | smallint | Number of days to wait after fourth claim before sending a fifth.
CreationDate | datetime | System generated date & time when the record was created.
CreatorID | int | PolarisUserID for person that created the record.
DelBillInstr | smallint | reflects a delayed billing arrangement between the library or branch and the supplier, or other special billing terms(represents the month which billing for an item(s) should begin).
DiscRate | numeric | Discount rate applied to the line item.
ExchangePartner | bit | indicates that if the supplier is an exchange partner
ExchangeRate | numeric | The exchange rate that was used to convert a particular price from one currency to another.
ForeignCurrencyID | int | ID number of foreign currency used by supplier/vendor.
InstrSupp | nvarchar(60) | Free text field for instructions to supplier/vendor.
InvCopies | int | Number of copies of invoice the supplier should send.
IsTemplate | bit | This element determines whether or not the PO is a template or an actual PO.
ModificationDate | datetime | System generated date & time the record was last modified.
MaxClaims | smallint | The number of claims that will be made against an item before it is canceled, or other action taken.
MembershipRenewalDate | datetime | The date on which a membership is due for renewal.
ModifierID | int | Polaris User ID of user that last modified this record.
OrderCancelInstr | datetime | instructions to the supplier about the date that an order should be canceled, if the item is not currently available.Its format is date or period of time
OtherChargeBase | money | Other charges associated with the order in the base currency of the library.
OtherChargeForeign | money | Other charges associated with the order in the foreign currency of of the supplier/vendor.
PlanName | nvarchar(50) | Name of the plan associated with the purchase order.
POAddChrgsSubtotBase | money | Sutotal of additional charges associated with the order in the base currency of the library.
POAddChrgsSubtotForeign | money | Subtotal of additional charges associated with the order in the foreign currency of of the supplier/vendor.
POAuthorization | nvarchar(50) | Name of person authorized to allow purchase orders to be released.
POConfirmDate | datetime | The date upon which the library received confirmation from a supplier/vendor that the order had been received.
POGrndTotBase | money | Purchase Order grand total in library's base currency.
POGrndTotForeign | money | Purchase Order grand total in the foreign currency of supplier/vendor
POMaterSubtotBase | money | Accumulated "Total Discount Price" for all lines on the purchase order in the library's base currency.
POMaterSubtotForeign | money | Accumulated "Total Discount Price" for all lines on the purchase order in the foreign currency of the supplier/vendor.
PONumber | nvarchar(30) | Library or system assigned purchase order number.
PONumberSuf | nvarchar(8) | Suffix to a purchase order number.
ReleaseDate | datetime | Date that purchase order was released on.
RentalReturnDate | datetime | Return date for any rented materials.
Resale | bit | Flag stating whether or not items on the purchase order are for resale.(0=NO(default)/1=YES).
SalesTax1Base | money | Main sales tax associated with this order in the base currency of the library.
SalesTax2Base | money | Secondary sales tax associated with this order in the base currency of the library.
SalesTax1Foreign | money | Main sales tax associated with this order in the foreign currency of the supplier/vendor.
SalesTax2Foreign | money | Secondary sales tax associated with this order in the foreign currency of the supplier/vendor.
SalesTaxRate1 | numeric | the standard sales tax rate associated with purchasing items from a particular supplier.
ServChargeBase | money | Service charge associated with the order in the base currency of the library.
ServChargeForeign | money | Service charge associated with the order in the foreign currency of the supplier/vendor.
ShipChargeBase | money | Shipping charge associated with the order in the base currency of the library.
ShipChargeForeign | money | Shipping charge associated with the order in the foreign currency of the supplier/vendor.
ShipDate | datetime | Instructions to the supplier about the earliest date an order is to be shipped.
SpecialHandChargeBase | money | Special handling charge associated with the order in the base currency of the library.
SpecialHandChargeForeign | money | Special handling charge associated with the order in the foreign currency of the supplier/vendor.
TemplateName | nvarchar(50) | A user-assigned name that uniquely identifies a purchase order template
PONote | nvarchar(200) | Free text feild for notes related to the purchase order.
SelectionListID | int | Polaris assigned unique ID number for linked the selection list record.
Prepaid | int | indicating if the payment method is prepaid or not.
StatusDate | datetime | The date on which the purchase order status was entered
encumbered | int | this column will be set to 1 if the purchase order has funds encumbered against it and 0 if there are no funds currently encumbered against it.
ClmNoticeInd | bit | default flag to determine if lines should have claim notices generated in overnight claim processing.
CanNoticeInd | bit | default flag to determine if lines should have cancellation notices generated in overnight cancellation processing.
AutoCancelInd | bit | default flag to determine if lines should be included in overnight cancellation processing.
CanWtPer | int | default number of days after last claim is generated that the lines should be automatically cancelled during overnight processing.
ExternalID | nvarchar(30) | Nullable, VARCHAR(30). Used to hold the PO# from an external accounting system.
OriginalPONumber | nvarchar(30) | The original purchase order number
OriginalPONumberSuf | nvarchar(8) | The original purchase order number suffix

See Also

ExternalAcctSystemExchangePurchaseOrders, OrderStatusHistories, OrdersToInvoices, POAmounts, POLineItemSegments, POLines,


PurchaseRecommendations

PurchaseRecommendations Table

This is a secondary table used by Selection List Line Items.Items placed on selection lists can have recomendations for, or against, their purchases. This table holds the name of the person making the recommendation regarding the linked selection list line item.

Columns

Column name | Data type | Description
SLLineItemID | int | ID number of linked selection list line item.
RecomName | nvarchar(25) | Name of the person that recommended the item linked to by the selection list line item id in the same row.
PurchRecom | nvarchar(200) | contains the purchase recommendation made by a staff member or other authorized user (such as a library patron).
PurchRecomDate | datetime | The date on which the purchase recommendation is made.


PurgeErrorDetails

PurgeErrorDetails Table

contains detailed error information about records that were not purged when the scheduled job ran. This data will be used in the Purge Criteria Report when it is finalized.

Columns

Column name | Data type | Description
PurgeID | int | ID of the CatPurgeCriterias record that was caused the record to be attempted to be purged.
PurgeDate | datetime | Date and time that the purge job was executed.
Organization | nvarchar(50) | name of the organizaton for which the record that failed to be purged was owned.
RecordType | int | Type of record that failed to purge. 1 = Authority 2 = Bibliographic 3 = Item
ControlNumber | int | the record id of the authority, bibliographic or item record that failed to be purged.
Reason | nvarchar(255) | reason that the record was not purged. possible entries include the record being locked, a lack of permission on the user that created or last modified the purge cirteria beign executed or otehr issue such as unbreakable links that would prevent the record from being purged.
OrgID | int | OrganizationID of this record.


PurgeReportDetails

PurgeReportDetails Table

contains information about records and record sets that were succecssfully purged from the database. This data will be used in the Purge Criteria Report when it is finalized.

Columns

Column name | Data type | Description
PurgeID | int | ID of the CatPurgeCriterias record that was executed.
PurgeDate | datetime | date and time that the purge job was executed.
RecordType | int | Type of record that was purged. 1 = Authority 2 = Bibliographic 3 = Item
Organization | nvarchar(50) | name for the organization that owned the purged record.
ControlNumber | int | the record id of the authority, bibliographic or item record that failed to be purged.
Heading | nvarchar(255) | Heading from the Authority record that was purged.
Title | nvarchar(255) | Title of either the Bibliograhic record that was purged or the linked Bibliographic record in the case of an Item record being purged.
Author | nvarchar(255) | Author name of the Bibliographic record that was purged.
Barcode | nvarchar(50) | Barcode from the Item record that was purged.
OrgID | int | OrganizationID of this record.


PurgeReportHeaders

PurgeReportHeaders Table

Contains header details about the purge cirteria that was executed. This data will be used in the Purge Criteria Report when it is finalized.

Columns

Column name | Data type | Description
PurgeID | int | ID of the CatPurgeCriterias record that was executed.
PurgeDate | datetime | date & time that the purge criteria was executed.
Organization | nvarchar(50) | Organization name that owns the purge criteria record.
RecordTypes | nvarchar(50) | Record types that were purged, or attempted to be purged. Could be one or more of the following: Authority, Bibliographic, Item. Does not apply to Record Set purges.
RecordSetName | nvarchar(50) | Name of the record set that was scehduled to be purged.
DateRange | nvarchar(100) | Begin Date & End Date range that was set in the purge criteria. This corresponds to the record status date for deleted records to be purged. It does not apply to Record Set purges.
ScheduledDate | datetime | date from the CatPurgeCriteria record that the purge criteria was to be run.
Requester | nvarchar(50) | Name of the User that created or last modified the purge criteria record that was executed.


PurgeReportResults

PurgeReportResults Table

When a purge report is run, the details of the report are placed in this table

Columns

Column name | Data type | Description
PurgeID | int | Link to the purge criteria record
Details | nvarchar(1000) | Report details
DetailsDate | datetime | Date purge last generated a report


ReceiptOptionDefs

ReceiptOptionDefs Table

This table stores all the receipt/slip print options defined by user on the workforms where the options are available.

Columns

Column name | Data type | Description
WorkstationID | int | Polaris user ID of the user who defines the options.
OptionID | tinyint | Receipt option ID. Foreign key references ReceiptOptions(OptionID). This option ID indicates to which Polaris TechClient work form this receipt option definition belongs.
PrinterID | int | Printer driver ID. Foreign key references PrinterDrivers(PrinterID). This driver ID indicates to which driver the printer (specified by PrinterName) should be attached.
PrinterName | nvarchar(255) | Printer name indicates the printer where the receipt/slip will be printed.
RowPrint | bit | Whether or not to print in row.
EnableCheckOutReceipt | bit | Whether or not to print a check out receipt.
EnableHoldSlip | bit | Whether or not to print a hold slip.
EnableHoldCallSlip | bit | Whether or not to print a hold call slip.
EnableFineReceipt | bit | Whether or not to print a fine receipt.
EnableILLSlip | bit | Whether or not to print a ILL slip.
EnableInTransitSlip | bit | Whether or not to print an intransit slip.
EnableHoldPickupSlip | bit | Whether or not to print a hold pickup receipt.
EnableInTransitSlipHoldsOnly | bit | Whether or not to print the in-transit slip for holds only. This value cannot be true if EnableInTransitSlip is set to false. If this value is set to 'true', in-transit slip prints only if item is transferred for holds.
EnableFineReceiptNoEReceipt | bit | Print a fine receipt only if eReceipt is not enabled.
EnableCkoReceiptNoEReceipt | bit | Print a checkout receipt only if eReceipt is not enabled.
EnableINNReachPickupSlip | bit | Whether or not to print an INN-Reach pickup receipt.


ReceiptOptions

ReceiptOptions Table

This table stores all the available workforms that have receipt/slip printing options. All the values here are system defined values.

Columns

Column name | Data type | Description
OptionID | tinyint | Numeric ID of an option.
Mnemonic | nvarchar(50) | Mnemonic for a workform where the receipt/slip print options are available.


ReceiveShipmentLogs

ReceiveShipmentLogs Table

Used by the Acquisition's Receive Shipment functionality to store information about the received items.

Columns

Column name | Data type | Description
ItemRecordID | int | Data type = INT Polaris' ItemRecordID of checked-in item.
CheckedInDate | datetime | Data type = DATETIME Check-in date for the item recorded that was barcoded into the system for receipt.
CheckedInOrgID | int | Data type = INT OrganizationID where the item was checked-in.
CheckedInWkstID | int | Data type = INT WorkstationID of where the Check-in took place.
CheckedInUserID | int | Data type = INT PolarisUserID of staff member that Checked-in the item.
POLineItemSegmentID | int | Data type = INT Polaris' POLineItemSegmentID of received POLI segment.
Comment | nvarchar(4000) | Data type = VARCHAR(255) Relevant comments about the check in processing or receipt of item.
DateTimeStamp | timestamp | Data type = DATETIMESTAMP DatetimeStamp of when the row was written to the table.


RecordSets

RecordSets Table

The user is allowed to create sets of records (lists of records kept by id number for easy retrieval)

Columns

Column name | Data type | Description
RecordSetID | int | Primary key
Name | nvarchar(80) | Name of record set
ObjectTypeID | int | What type of objects are in record set?
CreatorID | int | Polaris user who created record set
ModifierID | int | Polaris user who last modified record set
OrganizationOwnerID | int | Organization which owns record set, if null owned by creator.
CreationDate | datetime | Date the record set was created
ModificationDate | datetime | The date when the record set was updated
Note | nvarchar(255) | Note is a free text field associated with record set
RecordStatusID | int | Status of the record

See Also

AuthorityRecordSets, BibRecordSets, CatPurgeCriterias, CommunityImportProfiles, ImportProfiles, ItemRecordSets, PatronRecordSets,


RecordStatuses

RecordStatuses Table

This structure holds the system specific codes that are associated with the record. These will consist of the following :

Columns

Column name | Data type | Description
RecordStatusID | int | This structure holds the system specific codes that are associated with the record. These will consist of the following : Final, Provisional, No Record Status
RecordStatusName | nchar | The text name

See Also

AuthorityRecords, BibliographicRecords, CircItemRecords, CommunityAuthorityRecords, CommunityInformationEventsPrograms, CommunityInformationRecords, MARC21ExportBranches, OfflinePolPatron_Patrons, Patrons, RecordSets,


ReplicatedFiscalYearsFunds

ReplicatedFiscalYearsFunds Table

Used by FY Rollover "Replicate Fiscal Year" process. This is a working table and contains no data when not in use.

Columns

Column name | Data type | Description
OrigFYID | int | INT - ID of fiscal year being replicated
NewFYID | int | INT - ID of newly created Fiscal Year
OrigFundID | int | INT - ID of fund being replicated
NewFundID | int | INT - ID of newly created fund


ReserveItemRecords

ReserveItemRecords Table

this table is the data associated with an item record when it is placed on reserve (linked to a course reserve record).

Columns

Column name | Data type | Description
ItemRecordID | int | link to CircItemRecords table
ReserveAssignedBranchID | int | assigned branch ID for reserve item
ReserveAssignedCollectionID | int | assigned collection ID for reserve item
ReserveShelfLocationID | int | shelf location ID for reserve item
ReserveLoanPeriodCodeID | int | loan period code ID for reserve item
ReserveFineCodeID | int | fine code ID for reserve item
ReserveRenewalLimit | int | renewal limit for reserve item
ReserveHoldable | int | holdable flag for reserve item
CopyrightFeeRequired | bit | Y/N flag
CopyrightCompliance | tinyint | is the CCG or CCL (or none) value
CopyrightFee | money | monetary value
CopyrightFeePaid | bit | Y/N flag
LimitedToLibUse | bit | prompts user at checkout, Y/N
LibraryCopy | bit | is owner by library or instructor?
DeleteWhenDone | bit | is the auto-delete flag
ActionWhenDone | tinyint | tells the user what to do with the RIR when it goes off active reserve
RequiresFullCataloging | bit | Y/N flag for reserve item
Purchase | bit | Y/N flag for reserve item
YTDCircCount | int | the number of circulations for this item for a particular course reserve
Note | nvarchar(255) | free text note
IsReserved | bit | field generated to tell us if an active reserve exists (for performance for circulation)
PrimaryAssignedBranchID | int | Item main assigned branch ID
PrimaryFineCodeID | int | Item main fine code ID
PrimaryLoanPeriodCodeID | int | Item main loan period code
PrimaryAssignedCollectionID | int | Item main assigned collection ID
PrimaryShelfLocationID | int | Item main shelf location ID
PrimaryRenewalLimit | int | Item main renewal limit
PrimaryHoldable | int | Item main holdable flag

See Also

CourseReserveLinks,


ReserveStatuses

ReserveStatuses Table

list of valid statuses that an Reserve item record linked to a course reserve can have

Columns

Column name | Data type | Description
ReserveStatusID | tinyint | primary key
Description | nvarchar(50) | The status description

See Also

CourseReserveLinks, ItemTemplates,


ResourceEntities

ResourceEntities Table

This table is a list of resource entites (web links etc.) that have been parsed from MARC data and have special processing.

Columns

Column name | Data type | Description
ResourceEntityID | int | primary key
VendorAccountID | int | The vendor account associated with the resource
BibliographicRecordID | int | Bib record ID
VendorObjectIdentifier | nvarchar(255) | the unique identifier for the object on the vendor site/database
URL | nvarchar(2000) | URL from the bib tag (resource)
LinkText | nvarchar(4000) | The link text of the resource
TagNumber | smallint | Tag number from the bib tag (resource)
IndicatorOne | char | Indicator one from the bib tag (resource)
IndicatorTwo | char | Indicator two from the bib tag (resource)
PublicNote | nvarchar(4000) | A public note
NonPublicNote | nvarchar(4000) | A non public note
CoverImageURL | nvarchar(2000) | The URL of the cover image asscoiated with this entity
CreationDate | datetime | The date that the resource entity was created
ModificationDate | datetime | That date and time that the entity was modified
CreatorID | int | The user that created the reource entity
ModifierID | int | The user that modified the entity

See Also

CircItemRecords, ResourceEntitiesSubfields,


ResourceEntitiesSubfields

ResourceEntitiesSubfields Table

The subfields as they existed in the MARC data (before the tag was converted into a resource entity)

Columns

Column name | Data type | Description
ResourceEntitesSubfieldID | int | primary key
ResourceEntityID | int | link to resource entity table
SubfieldSequence | smallint | The subfield sequence (so tag can be reconstructed if necessary)
Subfield | char | The MARC subfield
Data | nvarchar(4000) | MARC data
IsURL | bit | Was this subfield the URL?
IsLinkText | bit | Was this subfield the link text?
IsPublicNote | bit | Indicates if the subfield was used to derive the public note
IsNonPublicNote | bit | Indicates if the subfield was used to derive the non-public note


RFIDTagItemMapping

RFIDTagItemMapping Table

This table holds the information which maps an RFID tag to an item record in the database.

Columns

Column name | Data type | Description
ItemBarcode | nvarchar(15) | The barcode of the item
RFIDUID | nvarchar(24) | The unique identifier which is hardcoded into an RFID tag.
ItemRecordID | int | ItemRecordID - for informational purposes only, no referential integrity.
CurrentDate | datetime | The date the RFID tag had this item record written to it.


RFIDTagPatronMapping

RFIDTagPatronMapping Table

This table holds the information which maps an RFID tag to an patron record in the database.

Columns

Column name | Data type | Description
PatronBarcode | nvarchar(15) | patron's barcode which was written to RFID
RFIDUID | nvarchar(24) | the distinct RFID tag identifier (follows standard for RFID).
PatronID | int | Patron record ID
CurrentDate | datetime | date the tag was initialized


RouteListMembers

RouteListMembers Table

Route List Member belongs to a Route List object. The member may and may not be a Polaris Patron object. This table is used to store the data information of the Route List Members. There is a many->one relationship between RouteListMembers entries and RouteLists entry. This table is not referenced by any Polaris tables.

Columns

Column name | Data type | Description
MemberID | int | PK of the table to identify the entry.
RouteListID | int | Route List ID of the route list to whom the member links. FK references Polaris.RouteLists (RouteListID). not NULL field.
MemberName | nvarchar(96) | name of Route List Member. if the member is linked to a Patron, then the name comes from the Patron record. not NULL field.
PatronID | int | Polaris User ID of patron who links to the Route List Member. FK references Polaris.PatronRegistrations (PatronID).
Note | nvarchar(255) | note of Route List Member.
PriorityID | int | priority to determine the member's priority in a Route List. not NULL field.


RouteListPieceDisplayOptions

RouteListPieceDisplayOptions Table

This table defines the individual components of a route list piece that can be displayed on the Route List workform.

Columns

Column name | Data type | Description
OptionID | int | Primary Key - Unique Identifier
OptionName | nvarchar(30) | Option display label

See Also

SA_RLPieceDisplayOrder,


RouteListPieces

RouteListPieces Table

Route List Piece belongs to a Route List object. The Piece must be a Serial Issue, MFHD or Purchase Order Line record. This table is used to store the data information of Route List Pieces. There is a many->one relationship between RouteListPieces entries and RouteLists entry. This table is not referenced by any Polaris tables.

Columns

Column name | Data type | Description
PieceID | int | PK of the table to identify the entry.
RouteListID | int | ID of the Route List to whom the pieces links. FK references Polaris.RouteLists (RouteListID). not NULL field.
ObjectID | int | record ID of the object links to the piece. FK references Polaris.MfhdIssues (IssueID). not NULL field.
ObjectTypeID | int | type ID of the object indicated by the ObjectID in the table. not NULL field.
RouteStatusID | int | ID of the piece's route status. FK references Polaris.RouteStatus (StatusID).
RouteStatusDate | datetime | time when piece's status get changes.
ParentPieceID | int | Piece ID of the current piece's parent. This is always it's linked SHR's pieceID.

See Also

RouteListPieces, Rpt_RouteSlips,


RouteLists

RouteLists Table

Route List is a Serial subsystem object. RouteLists table is used to stored the majority data information of this object. This table is referenced by FKs of Polaris.RouteListMembers and Polaris.RouteListPieces.

Columns

Column name | Data type | Description
RouteListID | int | PK of the table to identify the entry.
ListName | nvarchar(50) | Route List's name. Not NULL field.
OwnerID | int | Organization ID of Route List's owner. Not NULL field. PK references Polaris.Organizations (OrganizationID).
RoutePeriod | int | numeric value of route period.
PeriodTermID | int | term ID of route period. FK references Polaris.PeriodTerms (TermID).
HomeLocationID | int | Organization ID of Route List's home location. PK references Polaris.Organization (OrganizationID). not NULL field.
ReturnInstruction | nvarchar(100) | Route List's return instruction.
Header | nvarchar(100) | Route List's header.
Footer | nvarchar(100) | Route List's footer.
CreatorID | int | Polaris User ID of the user who inserts/creates the entry. PK references Polaris.PolariUsers (PoarisUserID). not NULL field.
CreationDate | datetime | time when entry gets inserted/created. not NULL field.
ModifierID | int | Polaris User ID of the latest user who updates the entry. FK references Polaris.PolarisUsers (PoarisUserID).
LastTransaction | datetime | lastest time when entry gets updated.

See Also

RouteListMembers, RouteListPieces,


RouteStatus

RouteStatus Table

This table is used to store the description of route statuses. This table is referenced by Polaris.RouteListPieces table.

Columns

Column name | Data type | Description
StatusID | int | PK of the table to identify the entry. not an auto generated field.
Description | nvarchar(10) | literal description of route status. not NULL field.

See Also

RouteListPieces,


Rpt_RouteSlips

Rpt_RouteSlips Table

This table stores the route slips information that will be read by RoutingSlip.rpt during slip print. entries get inserted each time when slip print requested by routing pieces, issues, or items. entries get deleted each time when the print is done. application uses the clustered identifier of OrgID, WrkStaID and UserID to distinguish the entries created by different staffs.

Columns

Column name | Data type | Description
OrgID | int | Polaris organization ID of the record creator's branch.
WrkStaID | int | Polaris worksation ID of the record creator's workstation.
UserID | int | Polaris user ID of the record's creator.
PieceID | int | routing piece control ID.
Title | nvarchar(255) | title of the routing piece.
Header | nvarchar(100) | route slip header info.
Designation | nvarchar(255) | Routing piece designation data info.
ReturnBy | datetime | routing piece's due date.
ReturnInstruction | nvarchar(100) | route slip's return instruction info.
Footer | nvarchar(100) | Route slip footer info.


Rpt_SubsCancelNotices

Rpt_SubsCancelNotices Table

Contains the Subscription Cancellation Notices that will be read by SubsCancelNotice.rpt during cancellation notice print. entries get inserted each time when a Subscription is cancelled and notification is required, and get deleted after the print is done. application uses the clustered identifier of OrgID, WrkStaID and UserID to distinguish the entries created by different Polaris users.

Columns

Column name | Data type | Description
UserID | int | Polaris user ID who performs the cancellation.
OrgID | int | organization ID of the user who performs the cancellation.
WrkStaID | int | workstation ID of the user who performs the cancellation.
SubsID | int | Subscription record ID gets cancelled.
QtyCanceled | int | quantity of copy records get cancelled by the Subscription.
CreationDate | datetime | datetime when entry is inserted.


RSSContentChangeDates

RSSContentChangeDates Table

This table is used for RSS feeds. It's columns represent the last time a feed's content has changed.

Columns

Column name | Data type | Description
NewReleases | datetime | This column is used to store the last time the new releases RSS feed content has changed.


RSSNewReleases

RSSNewReleases Table

This table is used to store the results of the RSS_PopulateNewReleases stored procedure.

Columns

Column name | Data type | Description
NewReleaseTypeID | int | Type of new release. Book, video, sound recording or large print.
BibID | int | Bibliographic record ID of new release.
TransactionDate | datetime | Used to store firstavailabledate of new release.
ISBN | nvarchar(20) | ISBN of new release. Used to connect content of RSS feed back to the Polaris database.
BrowseTitle | nvarchar(255) | Title of new release. Used in RSS feed.
BrowseAuthor | nvarchar(255) | Author of new release. Used in RSS feed.
Description | nvarchar(500) | Description of new release. Used in RSS feed.


RWRITERAllowedSchedHrs

RWRITERAllowedSchedHrs Table

A table that defines the hours on which a report may be scheduled to run

Columns

Column name | Data type | Description
SchedHour | int | The hour
Description | nvarchar(80) | A description of the Hour
Allowed | bit | Is the Hour Allowed?


RWRITERCodeTranslations

RWRITERCodeTranslations Table

A special table for SimplyReports containing code translations of codes that do not have normal Polaris code definition tables.

Columns

Column name | Data type | Description
TableName | sysname | The table name in which the coded field resides
ColumnName | sysname | The column containing the code
ColValue | int | The value of the code
ColTxtValue | nvarchar(5) | The code
Description | nvarchar(80) | A description/translation of the code as it will appear on the report


RWRITERColumns

RWRITERColumns Table

A table that defines which columns display in the 'Report output columns' list box for SimplyReports list and count reports.

Columns

Column name | Data type | Description
ReportColumnID | int | The unique ID of the column
ReportTypeID | int | Which report type dores this column display for
ReportTableID | int | The ID of the polris table
ReportColumnValue | nvarchar(255) | The name of the column
ReportColumnAlias | nvarchar(255) | The Alias of the column
ReportListValue | nvarchar(255) | The value of the column in the Report output columns list box
ReportListText | nvarchar(255) | The name of the column in the Report output columns list box
IsDisplayed | int | Is the colum display or surpressed. 0 = surpressed 1 = Displayed
PolarisColumn | int | Is this a column deployed with SimplyReports? 1 = Predefined 0 = Added by the library in SimplyReports content administration
DefSortType | nvarchar(7) | The default sort type of the column.
IsDisplayedNormal | int | Display the column to normal users


RWRITERexecOptions

RWRITERexecOptions Table

The table that contains default settings for SimplyReports

Columns

Column name | Data type | Description
maxusers | int | The maximum number of users for SimplyReports
allowtranoverides | int | Allow user to overide the default for statistical reports (e.g. use the 'run report now' checkbox)
allowsharedreports | int | Not being used
SchedSavedReportsDirectory | nvarchar(255) | Not being used
OutputDirectory | nvarchar(255) | The directory to use when writing reports files
maxlistreports | int | The maximum number of rows to write to a list reports file
MaxRecordSet | int | The maximum number of items to add to a record set
HTMLPreviewCount | int | How many rows are rendered in the HTML preview of the report
maxtimeout | int | The maximum cmd timeout
RootFolderRDL | nvarchar(255) | The root folder to use
ReportingServicesUsername | nvarchar(255) | The username to use when publishing reports
ReportingServicesDomain | nvarchar(255) | The domain in which the SQL reporting services server resides
ReportingServicesServerName | nvarchar(255) | The URL of the Reporting services API
SRSessionTimeout | int | The session timeout
ExpandFilterDefault | int | Filter expansion areas are open by default
PurgeAdHocFiles | int | Not being used
PurgeRunFiles | int | not being used
PurgeScheduleFiles | int | not being used
ERMSTarget | nvarchar(4000) | The ERMS Target URL
ERMSServer | nvarchar(4000) | The ERMSServer URL
SRWebServiceURL | nvarchar(4000) | The SimplyReports web service URL
ExpFilNamePrefixbib | nvarchar(4000) | The file name prefix to use when exporting BIB MARC files.
ExpFilNamePrefixauth | nvarchar(4000) | The file name prefix to use when exporting authority MARC files
ExpMARCFilNameSuffix | nvarchar(4000) | The file name suffix to use when exporting MARC files
ExpFilMaxRecsPerByteArray | int | The Maximum number of MARC records (with no holdings) to store in the MARC Byte array before having the MARC web service write those records to disc. This setting is overidden after the byte array exceeds megabyte.
ExpFilMaxRecsPerHoldingsByteArray | int | The Maximum number of MARC records (with holdings) to store in the MARC Byte array before having the MARC web service write those records to disc. This setting is overidden after the byte array exceeds megabyte.
SRMARCWebServiceURL | nvarchar(4000) | The SimplyReports MARC web service URL
HistoryNumberofPages | int | The max number of pages to render in Patron and Item detail history reports.
ReportBuilderAppReference | nvarchar(255) | The Report Builder Application Reference
ObfuscatedPassword | nvarchar(256) | Obfuscated password


RWRITERLicTable1

RWRITERLicTable1 Table

For Internal Use

Columns

Column name | Data type | Description
NumberOfNamedUsers | nvarchar(255) | For Internal use
ToolBarPublishingKey | nvarchar(255) | For Internal Use
ExpirationPeriod | nvarchar(255) | For Internal Use
Value | int | For Internal Use
ExportExpress | bit | For internal use


RWRITEROutputTypes

RWRITEROutputTypes Table

The Types of report output availible for witing reports

Columns

Column name | Data type | Description
OutputTypeID | int | The unique ID if the output type
OutputTypeDescription | nvarchar(80) | A description of the output type

See Also

RWRITERSavedReports,


RWRITERPatStatDetailLevels

RWRITERPatStatDetailLevels Table

The detail levels availible for all statistical reports

Columns

Column name | Data type | Description
DetailLevelID | int | The unique ID of the detail level
DetailDescription | nvarchar(4000) | A desription of the detail level
ReportType | int | The report types for which the detail level is availible


RWRITERReportTables

RWRITERReportTables Table

The Polaris Tables used in SimplyReports

Columns

Column name | Data type | Description
ReportTableID | int | A unique ID of the table
ReportTypeID | int | Which report types use this table
ReportTableValue | nvarchar(255) | The name of the table
ReportTableAlias | nvarchar(255) | The Alias of the table
PolarisTable | int | Indicates if Polaris added this table

See Also

RWRITERColumns,


RWRITERReportTypes

RWRITERReportTypes Table

The report types availible in SimplyReports

Columns

Column name | Data type | Description
ReportTypeID | int | A unique ID of the report type
ReportTypeDescription | nvarchar(80) | A desription of the report type

See Also

RWRITERColumns, RWRITERReportTables, RWRITERSavedReports,


RWRITERRunStatus

RWRITERRunStatus Table

A table to define run statuses of reports

Columns

Column name | Data type | Description
LastRunStatus | int | The ID of the run status
LastRunStatusDescription | nvarchar(80) | A verbose description of the run status

See Also

RWRITERScheduledJobs,


RWRITERSavedReports

RWRITERSavedReports Table

A table to save the SQL and various metadata associated with a SimplyReports saved report

Columns

Column name | Data type | Description
ReportNumber | int | The unique ID of the report
ReportName | nvarchar(80) | The user defined name of the report
ReportDescription | nvarchar(1000) | a user defined description of the report
ReportTypeID | int | The kind of report
OutputTypeID | int | The kind of file the report will produce when run
PolarisUserID | int | The user that created the report
ReportSQL | nvarchar(-1) | The SQL used to produce the report
ReportMetaColumns | nvarchar(-1) | The metadata names used to descibe the colums in the report. This is used by reporting services when publishing the report
SharedFlag | int | not being used
CreationDate | datetime | The date on which the report was created
LastRunDate | datetime | The last time the report was run
Enabled | int | is the report availible. 1 = active 0 = deleted
ProfileID | int | If The report links to a custom holdings profile, this column references the Profile ID in the EXP_HoldingsProfile table
CharacterEncoding | tinyint | Identifies the character encoding used in the record. 0 - Use LDR/09 value, 1 - MARC-8, 2 - UTF-8.

See Also

RWRITERSavedReportsRDL, RWRITERScheduledReports,


RWRITERSavedReportsRDL

RWRITERSavedReportsRDL Table

The XML used by reporting services. This table is reserved for use by the new Reporting services. It will allow the report to be sent the SQL server 2008 reporting services editor to add advanced editing capabilities to SimplyReports for Polaris 3.5/SQL server 2008.

Columns

Column name | Data type | Description
ReportNumber | int | The number of the report
ReportXML | nvarchar(-1) | The reports RDL XML


RWRITERScheduledJobs

RWRITERScheduledJobs Table

A table containing the metadata that desribes SimplyReports scheduled jobs.

Columns

Column name | Data type | Description
ScheduleNumber | int | A system assigned schedule ID
ScheduleName | nvarchar(80) | The name of the schedule
ScheduleDescription | nvarchar(255) | A description of the schedule
PolarisUserID | int | The user who created the schedule
CreationDate | datetime | The date on which the schedule was created
BeginDate | datetime | When to start using the schedule
ExpirationDate | datetime | The expiration date of the report
LastRunDate | datetime | The last time the schedule was run
LastRunStatus | int | The run status of the schedule
Enabled | int | Indicates if the schedule is enabled
DW | nvarchar(255) | The day-of-week flag
HR | int | The hour on which to run the report
MN | int | The minute on which to run the report
YR | int | The yearly flag
DY | int | The Day-of-yeay flag
MO | int | The Monthly flag
DailyFlag | int | Is the report a daily report
OneTimeFlag | int | The one time flag
MonthlyFlag | int | A monthly run flag
WeeklyFlag | int | The weekly flag

See Also

RWRITERScheduledReports,


RWRITERScheduledReports

RWRITERScheduledReports Table

A table assocated reports with schedules. This table is used by SimplyReports

Columns

Column name | Data type | Description
ScheduleNumber | int | The schedule that will run the report
ReportNumber | int | The saved report number


RWRITERSessionControl

RWRITERSessionControl Table

For internal use

Columns

Column name | Data type | Description
ParseUser | nvarchar(255) | for internal use
SRWorkstationID | nvarchar(255) | for internal use
LoginTime | datetime | for internal use


RWRITERTableAliasTranslations

RWRITERTableAliasTranslations Table

The table to table alias translation table used by simplyreports content administration

Columns

Column name | Data type | Description
ReportTableAlias | nvarchar(50) | The table alias prefix
AliasTranslation | nvarchar(255) | A verbose description of the table rendered for the user


RWRITER_BranchUserSecurity

RWRITER_BranchUserSecurity Table

A SimplyReports table that defines which organizations that a SimplyReports user may report on.

Columns

Column name | Data type | Description
PolarisUserID | int | The PolarisUserID of the SimplyReports user
OrganizationID | int | The Polaris OrganizationID


RWRITER_RDLTEMPLATES

RWRITER_RDLTEMPLATES Table

A table that defines the default Portrait and Landscape formats for a Reporting Services RDL file.

Columns

Column name | Data type | Description
TemplateType | int | What kind of template is it
XMLPreamble | nvarchar(-1) | The XML preamble settings
XMLPostscript | nvarchar(-1) | The XML poscript settings
XMLMargins | nvarchar(-1) | The Margin control for the template
XMLGridControl | nvarchar(-1) | The Grid Control associated with the template
XMLPageControl | nvarchar(-1) | Page control for the template
XMLPageHeader | nvarchar(-1) | The Template page header
XMLPageFooter | nvarchar(-1) | The template footer


RWRITER_UserSecurity

RWRITER_UserSecurity Table

The Security setting for SimplyReports users

Columns

Column name | Data type | Description
PolarisUserID | int | The PolarisUserID of the SimplyReports user
PatListAccess | bit | Allow a user to use patron list reports
PatCountAccess | bit | Allow a user to use patron count reports
PatStatAccess | bit | Allow a user to use patron statistical reports
PatAcctListAccess | bit | Allow a user to use patron account list reports
PatAcctCountAccess | bit | Allow a user to use patron account count reports
PatAcctStatAccess | bit | Allow a user to use patron account statistical reports
HoldsListAccess | bit | Allow a user to use hold list reports
HoldsCountAccess | bit | Allow a user to use hold count reports
HoldsStatAccess | bit | Allow a user to use hold statistical reports
ItemListAccess | bit | Allow a user to use item list reports
ItemCountAccess | bit | Allow the user to use item count reports
ItemStatAccess | bit | Allow a user to use item statistical reports
BibListAccess | bit | Access to bib list reports
BibCountAccess | bit | Access to bib count reports
BibStatAccess | bit | Allow a user to run bib statistical reports
SerialsListAccess | bit | Allow a user to access serials list reports
SerialsCountAccess | bit | Allow a user to access serial count reports
SerialsStatAccess | bit | Allow a user to access serials statistical reports
FileMaintAccess | bit | Allow a user to access the FimeMaintenance sub-tab
SavedReportAccess | bit | Allow a user to access saved reports
ScheduleAccess | bit | Allow a user to schedule reports
AdminUsersAccess | bit | SimplyReports Administration access
AdminDefaultsAccess | bit | Allows a user to set up defaults in SimplyReports administration
AdminMasterSchedAccess | bit | Access to master schedule maintenance
CreateRDLAccess | bit | Allow a user to publish to the Polaris toolbar
PublishRDLAccess | bit | Allow a use to Publish to the Polaris toolbar
EditMetadaAccess | bit | Allow a user to edit metadata in SimplyReports content administration.
AddMetadaAccess | bit | Allows a user to add metadata in SimplyReports content administration
PatListRSAccess | bit | Allow a user to create record sets from patron list reports
PatAcctListRSAccess | bit | Allow a user to create patron record sets in patron account list reports
HoldsListRSAccess | bit | Allow a user to create record sets in hold list reports
ItemListRSAccess | bit | Allow a user to create item record sets in item list reports
BibListRSAccess | bit | Allow a user to create Bib record sets via SimplyReports
IsTechUser | int | Is the user a technical user 0 = NO 1 = Yes
AuthListAccess | bit | Allows a user to use Authority list reports
AuthCountAccess | bit | Allows a user to use authority count reports
AuthStatAccess | bit | Allows a user to use Authority statistical reports
AuthRSAccess | bit | Allows a user to create Authority record sets from authority list reports.
FundListAccess | bit | Allows a user to use fund list reports
FundCountAccess | bit | Allows a user to use fund count reports
ItemMARCExport | bit | Allow a user to use MARC / XML based export from the item list tab (applies only to sites where ExportExress is installed)
BibMARCExport | bit | Allows a user to export in MARC / XML fromat from the bib list tab (only if ExportExpress is installed)
AuthorityMARCExport | bit | Allows a user to export in MARC format from authority list reports (applies only when export express is installed)
AdvancedRDL | bit | Allows a user to use advanced publishing
ProfileView | bit | Allows a user to view holdings profiles
ProfileAdd | bit | Allows a user to add new Holdings profiles
ProfileEdit | bit | Allows a user to edit holdings profiles
ProfileDelete | bit | Allows a user to delete holdings profiles
PatronHistoryReports | bit | Allows a user to use Patron history reports, the default is false
ItemHistoryReports | bit | Allows as user to use Item History Reports. The default is false.
InvoiceListAccess | bit | Allow a user to create Invoice list reports
InvoiceCountAccess | bit | Allow a user to create Invoice count reports
InvoiceRSAccess | bit | Allow a user to create record sets Invoice list reports
POListAccess | bit | Allow a user to create PO list reports
POCountAccess | bit | Allow a user to create record sets PO count reports
PORSAccess | bit | Allow a user to create record sets PO list reports


SA_Addresses

SA_Addresses Table

This table holds all addresses referenced in the Systems Administration subsystem. This table is necessary in lieu of using Addresses/PostalCodes because the table needs to be replicated system-wide.

Columns

Column name | Data type | Description
SA_AddressID | int | Primary key
StreetOne | nvarchar(32) | Street One field
StreetTwo | nvarchar(32) | Place for user to enter more address info
City | nvarchar(32) | City field
State | nvarchar(32) | State field
County | nvarchar(32) | County field
Country | nvarchar(32) | Country field
PostalCode | nvarchar(32) | Postal code stored here
StreetThree | nvarchar(32) | Addition column to hold further street details

See Also

OrganizationAddresses,


SA_AttrCache

SA_AttrCache Table

This table contains a run-time cache of OrganizationsPPPP SA values that were obtained via DB stored procedure calls. The attribute cache is cleared whenever an SA change is saved and written to the database.

Columns

Column name | Data type | Description
mnemonic | nvarchar(30) | The mnemonic for the SA attribute.
OrganizationID | int | The organization at which this attribute is defined.
attrValue | nvarchar(255) | The current operational SA value for the associated attribute mnemonic at the associated OrganizationID.


SA_AutoChangePatronCodeControl

SA_AutoChangePatronCodeControl Table

A table to hold the SA Options to autochange the patron code of patrons who have reached a given age. Optional settings are availible to change the patrons statistical class, and UDF's. These tables control Optional Step 9 of the Patrons processing Job (patron age update). To activate this processing re-order the job steps (Making this step step 8) and make the on-success action of step 7 "go to the next step".

Columns

Column name | Data type | Description
ChangeID | int | A unique ID for the autochange rule
OrganizationID | int | The Candidate Organization ID. May be set on the System, Library, or branch level. Required.
ExistingPatronCodeID | int | The candidate patron code ID. Required.
ChangeToPatronCdeID | int | The Patron code to give the patron. Required.
PatronAge | int | The Candidate Patron Age. Required.
ExcludeBeforeDate | datetime | Exclude patrons from the process whose birth date is prior to this date. Required.
ExistingStatisticalClassID | int | The Candidate Statistical class ID. NULL means ANY statistical class.
ChangeToStatisticalClassID | int | The Statistical class to give the patron. Optional. If this column is NULL it indicates no change to statistical class.

See Also

SA_AutoChangeUDFControl,


SA_AutoChangeUDFControl

SA_AutoChangeUDFControl Table

A table to hold UDF entries for the patron autochange process. Entries are NOT required in this table unless a UDF Change is requested. Any number of UDF's may be changed. (UDF 1 - 5)

Columns

Column name | Data type | Description
ChangeID | int | A foreign key to the SA_AutoChangePatronCodeControl Table. Required.
UDFType | int | The type of UDF. 1 = User1 2 = User2 3 = User3 4 = User4 5 = User5
ExistingText | nvarchar(64) | The text of the existing UDF. NULL indicates ANY text.
ChangeToText | nvarchar(64) | The Text to change the UDF to. Required.


SA_Barcode_Formats

SA_Barcode_Formats Table

This table holds item and patron barcode format definitions and are managed from the Tech Client from a System Administration dialog. The barcode formats are organization-specific. Patron barcodes at the system level have the added feature of possibly being marked as the one 'default' patron barcode for the system.

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context for the given barcode format (Foreign Key relationship with the Organizations table)
Type | bit | This column flags whether or not the barcode format is an item barcode (1) or a patron barcode (0). (Bit column)
Length | int | Length component of the barcode format (total number of characters - integer)
Prefix | nvarchar(20) | String prefix component of the barcode format (varchar - 20)
DisplayOrder | int | Relative order to display the barcode formats in the System Administration dialog UI when the controls are initially populated


SA_BibRecordOpenOptions

SA_BibRecordOpenOptions Table

This table is used by the SA control to determine when a bib record is opened, which is the default view.

Columns

Column name | Data type | Description
BibRecordOpenOptionID | int | Primary key
Description | nvarchar(80) | Description of view


SA_BorrowByMail_MaterialTypesPermitted

SA_BorrowByMail_MaterialTypesPermitted Table

This table defines what material types are permitted to participate in Borrow-By-Mail for a given organizational context.

Columns

Column name | Data type | Description
OrgID | int | Organizational context (FK reference to the Organizations table)
MaterialTypeID | int | Material type that is allowed to participate in Borrow-By-Mail (FK reference to the MaterialTypes table).


SA_BorrowByMail_PatronCodesPermitted

SA_BorrowByMail_PatronCodesPermitted Table

This table defines what patron codes can and can not participate in Borrow-By-Mail for a given organizational context as well as the monetary charge that will be applied when a patron code make use of this service when the associated organizational context is used as the processing branch.

Columns

Column name | Data type | Description
OrgID | int | Organizational context (FK to the Organizations table)
PatronCodeID | int | Patron code in question (FK reference to the PatronCodes table)
Charge | money | Monetary value. The charge that will applied if the associated patron code uses the Borrow-By-Mail functionality with the associated organization context as its processing center.
Selected | bit | A bit flag that determines whether the associated patron code is allowed (1) or is not allowed (0) to participate in Borrow-By-Mail at the associated organizational context.


SA_BorrowByMail_ProcessingCenters

SA_BorrowByMail_ProcessingCenters Table

This table defines the set of branch organizations that are processing centers with respect to Borrow-By-Mail processing.

Columns

Column name | Data type | Description
BranchID | int | A branch that is defined to be a processing center. (FK to the Organizations table)


SA_BranchShelvingStatusDurations

SA_BranchShelvingStatusDurations Table

Table which has the mapping of shelving status time per branch (the amount of time an item that is IN displays as Shelving)

Columns

Column name | Data type | Description
BranchID | int | Organization ID
MaterialTypeID | int | Material type
Duration | int | The number of minutes expected to take to shelve the item from check in to being shelved. (i.e. staff time, in minutes, to shelve the item. Do not include time the library is not open.)


SA_CATPROF_SubfieldNineProcessTags

SA_CATPROF_SubfieldNineProcessTags Table

The tags to process for the subfiled nine utility

Columns

Column name | Data type | Description
Tagnumber | int | The tagnumber to be processed.
OrganizationID | int | The ORG ID current only the value "1" is valid
IsEnabled | bit | Indicates if the tag will be processed.


SA_ChargeForCheckOut_MaterialTypes

SA_ChargeForCheckOut_MaterialTypes Table

Defines the charges to applied when checking out a particular material type for a given organizational context.

Columns

Column name | Data type | Description
OrgID | int | Organizational context (foreign key constraint on Organizations table)
MaterialTypeID | int | The material type in question (foreign key reference to MaterialTypes table)
Charge | money | The dollar amount to be charged
Selected | bit | Indicates whether the material type is to be charged for. (1 = charge will be applied, 0 = no charge)


SA_ChargeForCheckOut_PatronCodes

SA_ChargeForCheckOut_PatronCodes Table

Defines the set of Patron Codes that are to participate in charging for check-outs for a given organizational context.

Columns

Column name | Data type | Description
OrgID | int | Organizational context (foreign key constrain on Organizations table)
PatronCodeID | int | Patron code that will be participating in charging (foreign key constraint on PatronCodes table)


SA_CheckOutDisplayOrder

SA_CheckOutDisplayOrder Table

This table defines all the values of SA parameters defined from "Check-out: List view options" in Patron Services tab.

Columns

Column name | Data type | Description
OrganizationID | int | ID of organization for which the SA parameters are defined.
OptionID | tinyint | ID of the options user choose to display on the check-out w/f. FK refers to CheckoutDisplayOptions.OptionID.
DisplayOrder | tinyint | display sequence of the data field.


SA_CheckOutReceiptSettings

SA_CheckOutReceiptSettings Table

Defines the configuration of various check-out receipts (Printed, Email, Text message) for a given organizational context.

Columns

Column name | Data type | Description
OrgID | int | Organizational context (foreign key constraint on Organizations table)
OptionID | tinyint | The option to include on a receipt (eg. Call number, Patron name, etc.) for the given organizational context (foreign key constraint on CircReceiptOptions table).
IsSelectedForPrint | bit | Indicates whether the given option is to be include on a Printed check-out receipt (1) or not (0) for the given organizational context.
IsSelectedForEmail | bit | Indicates whether the given option is to be include on an Email check-out receipt (1) or not (0) for the given organizational context.
IsSelectedForTXT | bit | Indicates whether the given option is to be include on a text message check-out receipt (1) or not (0) for the given organizational context.


SA_CircReceiptOptionSelections

SA_CircReceiptOptionSelections Table

This table defines all the values of SA parameters defined from "Check-out: Receipt options", "Fine receipt options" and "Hold slip options" in Patron Services tab.

Columns

Column name | Data type | Description
ContextID | int | ID of organization for which the SA parameters are defined.
OptionID | tinyint | ID of the options user choose to display on the check-out w/f. FK refers to CircReceiptOptions.OptionID.
DisplayOrder | tinyint | display sequence of the data field.


SA_COMMMUNITY_SearchDashboardElements

SA_COMMMUNITY_SearchDashboardElements Table

This table defines the set of 'Search by' facet choices used to populate the Profiles-->Community->Search settings defaults SA dialog as well as for configuration in the Profiles-->Community-->Dashboards: Narrow your search & related searches SA dialog.

Columns

Column name | Data type | Description
ElementID | int | Unique numeric identifier of the facet/element
Description | nvarchar(80) | Element description that appears in the dialog drop list.
FacetTypeID | tinyint | Underlying numeric identifier used by the internals of the PowerPAC Community search manager processing.

See Also

SA_COMMUNITY_SearchDashboardDisplay,


SA_CommunityEventViewOptions

SA_CommunityEventViewOptions Table

A list of default options for how events are rendered in the PowerPAC. 1 = List. 2 = Calendar

Columns

Column name | Data type | Description
OptionID | int | The unique identifier of the option
Description | nvarchar(32) | A description of the option


SA_COMMUNITY_PACLimitBy

SA_COMMUNITY_PACLimitBy Table

A table defining the limit bys used in PAC

Columns

Column name | Data type | Description
OrganizationID | int | The organization that owns the filter
LimitDescription | nvarchar(255) | A user-frendly description of the filter
CCLFilter | nvarchar(255) | The CCL filter for the limit by
Enabled | bit | Indicates if the filter displays in PAC
DisplayOrder | int | The display order of the filter used in PAC
Protected | bit | Indicates if the filter may be editied


SA_COMMUNITY_PAC_SearchByChoices

SA_COMMUNITY_PAC_SearchByChoices Table

The PAC search by choices available in the PAC. Used in system administration.

Columns

Column name | Data type | Description
SearchTypeID | int | The search by type ID
SearchByID | int | The unique identifier of the search by
DisplayOrder | int | Indicates the order of display in the SA dialogue


SA_COMMUNITY_PAC_SearchBys

SA_COMMUNITY_PAC_SearchBys Table

The table that identifiers search access points in used PAC. Used in system administration.

Columns

Column name | Data type | Description
SearchByID | int | Unique identifier
Mnemonic | nvarchar(10) | A mnemonic used by SA
Description | nvarchar(80) | The description of the access point

See Also

SA_COMMUNITY_PAC_SearchByChoices, SA_COMMUNITY_PAC_SearchSettings,


SA_COMMUNITY_PAC_SearchSettings

SA_COMMUNITY_PAC_SearchSettings Table

A table that defines the search by settings used by an organization

Columns

Column name | Data type | Description
OrganizationID | int | The organization ID
SearchTypeID | int | The type of access point
SearchByID | int | The type of search by
LimitByDescription | nvarchar(255) | A description of the default limit by
SortByID | int | The default sortby ID


SA_COMMUNITY_PAC_SortBys

SA_COMMUNITY_PAC_SortBys Table

A table that defines the sortbys available in PAC. Used by system administration.

Columns

Column name | Data type | Description
SortByID | int | Unique identifier
Mnemonic | nvarchar(10) | A mnemonic of the sort used in system administration
Description | nvarchar(80) | A description of the sort
DisplayOrder | int | The display order of the sort in system administration

See Also

SA_COMMUNITY_PAC_SearchSettings,


SA_COMMUNITY_SearchDashboardDisplay

SA_COMMUNITY_SearchDashboardDisplay Table

Organization-specific configuration settings for Community Info search dashboard display in the PowerPAC.

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context (Foreign key reference to Organizations)
DashboardType | int | Type of dashboard (1 = Narrow, 2 = Related)
ElementID | int | The element/facet in question (Foreign key reference to SA_COMMUNITY_SearchDashboardElements)
DisplayFlag | bit | Bit flag to indicate whether or not an element is to display (1 = display, 0 = do not display)
DisplayOrder | int | Sequence in which to display elements
AdminAttrID | int | Underlying SA attribute ID used to provide a basis for multi-lingual translation (Foreign key reference to AdminAttributes)
Expanded | bit | Bit flag to indicate whether an element is to appear initially expanded (1) or not (0)
MinimumToShow | int | Minimum number of a particular element to show
MaximumToShow | int | Maximum number of a particular element to show


SA_ContactPersons

SA_ContactPersons Table

Contains a list of contact persons (used by organizations).

Columns

Column name | Data type | Description
SA_ContactPersonID | int | Primary key
Name | nvarchar(50) | Name of contact person
EmailAddress | nvarchar(64) | Email of contact
PhoneNumberOne | nvarchar(20) | Primary phone number
PhoneNumberTwo | nvarchar(20) | Secondary phone number
FaxNumber | nvarchar(15) | Fax number of contact

See Also

Organizations,


SA_CustomAnalyticsJavaScriptCodeSnippets

SA_CustomAnalyticsJavaScriptCodeSnippets Table

This table contains the customized JavaScript code defined for a given organizational level to be inserted at the bottom of each PowerPAC or Mobile PAC page when 'Custom' Analytics is enabled from SA.

Columns

Column name | Data type | Description
OrganizationID | int | The organizational context of the customized JavaScript code (foreign key on the Polaris.Organizations table).
CustomJavaScript | nvarchar(4000) | The actual string of JavaScript to be inserted (4000 character limit).
PACContextID | int | Integer identifier to indicate which PAC product is intended. 1 = PowerPAC, 11 = Mobile PAC (reflects the ProductID value in the Products table, no FK constraint however)


SA_CustomMultiLingualStrings

SA_CustomMultiLingualStrings Table

This table contains customized representations of multi-lingual string values defined in the SA_DefaultMultiLingualStrings table, overriding the default values with the value defined in this table. An organizational context is also indicated so specific sites can tailor their own variation of a particular multi-lingual string for a given product and language if desired.

Columns

Column name | Data type | Description
StringID | int | Unique identifier - Primary key
ProductID | int | Foreign key for the Products table - the Product this string is defined for
LanguageID | int | Language identifier that indicates what language the string is in (1033 = English)
OrganizationID | int | Foreign key for the Organizations table - the Organizational context for this string is definition
Mnemonic | nvarchar(100) | A string mnemonic used to define the role the defined string represents
Value | nvarchar(4000) | The actual Unicode string value


SA_DatabaseTableTriggerAftermath

SA_DatabaseTableTriggerAftermath Table

This table is populated by Insert and Update triggers fired as a result of operations on several SA tables. Post-processing occurs using the data stored in this table to determine whether or not duplicates were encountered.

Columns

Column name | Data type | Description
AdminTableID | int | Foreign field reference to AdminTables (identifies the SA table that was the target of the update/insert).
NumColumns | int | The number of columns involved in the duplicate detection process. This determines how many of the ColumnValue columns are involved. For the duplicate MODIFY case the column values to replace the corresponding table grid row, reverting it to its previous state.
OperationResult | int | Numerical code to indicate if it was a duplicate or not. Also whether the operation was an insert or update. (1 = Good INSERT, 2 = Bad INSERT - duplicate, 3 = Good MODIFY, 4 = Bad MODIFY - duplicate)
PrimaryKeyID | int | This column represents a new Primary Key ID for the SA table when a successful INSERT happens. The post-processing code uses this ID to populate the 1st column of the table grid, to be used for any future operations.
Column1Value | nvarchar(255) | First column value (e.g. Shelf Location description)
Column2Value | nvarchar(255) | Second column value.
Column3Value | nvarchar(255) | Third column value.
Column4Value | nvarchar(255) | Fourth column value
Column5Value | nvarchar(255) | Fifth column value (Postal Codes uses all 5 ColumnValue columns)


SA_DefaultMultiLingualStrings

SA_DefaultMultiLingualStrings Table

This table contains the default representation of all multi-lingual string values defined for the various Polaris products (from the Products table).

Columns

Column name | Data type | Description
StringID | int | Unique identifier - Primary key
ProductID | int | Foreign key for the Products table - the Product this string is defined for
LanguageID | int | Language identifier that indicates what language the string is in (1033 = English)
Mnemonic | nvarchar(100) | A string mnemonic used to define the role the defined string represents
Value | nvarchar(4000) | The actual Unicode string value
RequiresTranslation | bit | A bit field used to flag new strings that have been added since the last update (done periodically)


SA_DWI_AccessPointIDs

SA_DWI_AccessPointIDs Table

This table is used to configure the set of search access points available for configuring a remote database with respect to federated searching from the PowerPAC. A unique identifier is assigned to each search-type/search-by combination and this identifier is assigned as a repeatable DWI attriubte for each entry that is 'checked' on the Usage Settings configuration SA dialog.

Columns

Column name | Data type | Description
AccessPointID | int | A unique integer identifier assigned to a particular search-type (Keyword, Exact, etc.) and search-by (Author, ISBN, etc.) combination. Stored directly in the DWI database tables as the repeatable AccessPointID attribute for ConfigurationTarget objects.
SearchTypeID | int | Foreign key reference to the SA_PAC_SearchTypes table to define a type of search (Keyword, Exact, etc.)
SearchByID | int | Foreign key reference to the SA_PAC_SearchBys table to define an attribute to search by (Author, ISBN, etc.)


SA_DWI_UserName_Password_Usage

SA_DWI_UserName_Password_Usage Table

This table was created to store off non-empty UserName and Password DWI attributes in preparation for the removal of these attributes from PolarisTarget objects. They are defunct and can not be assigned through the UI anymore. This is simply a record of those settings in case the values can still serve some purpose. The table can be removed once it is determined the values are not needed. The table only contains rows for instances where at least one of the 2 attributes has a value.

Columns

Column name | Data type | Description
EntryID | int | THe DWI Entry ID of the PolarisTarget object associated with the UserName/Password values.
OrgID | int | THe OrganizationID attribute value of the PolarisTarget object associated with the UserName/Password values.
DBID | int | The DatabaseID attribute values of the base Target object that is referenced by the PolarisTarget object assigned the associated UserName and Password values.
UserName | nvarchar(890) | THe actual UserName attribute value (string)
Password | nvarchar(890) | The actual Password attribute value (string)


SA_FloatingMatrix

SA_FloatingMatrix Table

This table is a matrix between the particular check-in branch of an item record and it's home branch and is an indication of if the item's home branch will allow it's items to float to the check in branch.

Columns

Column name | Data type | Description
ItemHomeBranchID | int | The item's home branch
ItemCheckInBranchID | int | The branch the item is being checked in at
CanFloat | bit | Can float flag


SA_FloatingMatrixCollectionLimits

SA_FloatingMatrixCollectionLimits Table

Contains the limits set by branch for floating collections.

Columns

Column name | Data type | Description
ItemCheckInBranchID | int | Foreign key link to the Organizations table. This is restricted in the Polaris application to only Branch entries.
CollectionID | int | Foreign key link to the Collections table.
Limit | int | Maximum number of items that can float to the associated collection for that organization.
ItemCount | int | Count of items currently on the shelves of the associated branch


SA_FloatingMatrixMaterialLimits

SA_FloatingMatrixMaterialLimits Table

For a specific check in branch, this table lists the number of allowed items (by material type) for a specific bib record that will be allowed to float to the check in branch.

Columns

Column name | Data type | Description
ItemCheckInBranchID | int | check in branch for the item
MaterialTypeID | int | Material type ID
MaterialTypeBibLimitInItems | int | The limit of 'In' items per bib for this material type.
MaterialTypeBibLimit | int | The limit of all items per bib for this material type.


SA_FloatingMatrixMaterialTypes

SA_FloatingMatrixMaterialTypes Table

This table is a matrix of item home branch's and corresponding material types. There is a flag saying if an item from a home branch and of a certain material type is allowed to float to another branch or not.

Columns

Column name | Data type | Description
ItemHomeBranchID | int | Item's home branch
MaterialTypeID | int | Material Type ID
CanFloat | bit | Can float flag


SA_GeographicCoordinates

SA_GeographicCoordinates Table

This table stores latitude and longitude coordinates for a given organization (System, Library, or Branch). The 'Geographic Coordinates' SA table interface is used to manage the content.

Columns

Column name | Data type | Description
OrganizationID | int | The organization whose coordinates are being defined (foreign key on the Polars.Organizations table).
Latitude | nvarchar(20) | Latitude coordinate. Stored as a string. Valid values are between -90 and 90 inclusively. Precision out to 14 decimal places.
Longitude | nvarchar(20) | Longitude coordinate. Stored as a string. Valid values are between -180 and 180 inclusively. Precision out to 14 decimal places.


SA_Holds_Pickup_Branches

SA_Holds_Pickup_Branches Table

This table contains the set of branch organizations where holds can be picked-up (no choice originally). The set of branches can be tailored to each branch organization.

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context of the a configured set of branches. This value is itself a branch organization and represents the Assigned Branch of the held item to be picked up.
PickupBranchID | int | A branch organization ID that is available as the set of pickup branches given the assigned branch as represented by the corresponding Organization ID column value.


SA_ItemAvailability_DisplayNotesOptions

SA_ItemAvailability_DisplayNotesOptions Table

Set of choices for the display of item availability note information.

Columns

Column name | Data type | Description
OptionID | int | Unique integer identifier for the option.
Description | nvarchar(32) | String description that displays on the SA user interface in a drop-list (static list: 'Do not display' (1), 'Icon' (2), 'Text' (3))


SA_ItemRecordOpenOptions

SA_ItemRecordOpenOptions Table

This is a table of choices available in SA which determine which is the first view that is enabled when a record workform is opened.

Columns

Column name | Data type | Description
ItemRecordOpenOptionID | int | Primary key
Description | nvarchar(80) | view description


SA_ItemsOutReceiptSettings

SA_ItemsOutReceiptSettings Table

Defines the configuration of an 'Items out' receiptfor a given organizational context.

Columns

Column name | Data type | Description
OrgID | int | Organizational context (foreign key constrain on Organizations table)
OptionID | tinyint | The option to include on a receipt (eg. Call number, Patron name, etc.) for the given organizational context (foreign key constraint on CircReceiptOptions table).
IsSelected | bit | Indicates whether the given options is to be included on the receipt (1) or not (0).


SA_JobLog

SA_JobLog Table

Table added late in 4.0 to contain one entry per job that needs it to record info the job needs to reference previous activity by the job.

Columns

Column name | Data type | Description
JobID | int | Primary key unique identifier.
JobName | sysname | Name of the SQL Agent job
LastRun | smalldatetime | Last time the job was run in which in performed actions. This can be different than the Last Run Date in the msdb job history, that date records the last time the agent executed the job.


SA_LostItemRecoveryOptionDetails

SA_LostItemRecoveryOptionDetails Table

This table stores the lost item recovery more detailed default actions defined from SA for Patron Service parameter 'Lost Item Recovery Options'.

Columns

Column name | Data type | Description
ContextID | int | ContextID defines in SA_LostItemRecoveryOptions.
RecoveryType | int | RecoveryType defines in SA_LostItemRecoveryOptions.
RecoveryProcess | int | Circulation transactions where the lost item gets recovered. 1 - Check-in normal mode, 2 - check-in bulk mode, and 6 - check-out/renew.
UsingDefaultAction | bit | Whether or not the default actions needs to be used.
OverdueFine | int | Default action to deal with overdue fines. It references to PatronAccTxnCodes.TxnCodeID, but -2 means not action.
ProcessingFee | int | Default action to deal with processing fee. It references to PatronAccTxnCodes.TxnCodeID, but -2 means not action.
ReplacementCharge | int | Default action to deal with replacement cost. It references to PatronAccTxnCodes.TxnCodeID, but -2 means not action.


SA_LostItemRecoveryOptions

SA_LostItemRecoveryOptions Table

This table stores the lost item recovery default actions defined from SA for Patron Service parameter 'Lost Item Recovery Options'.

Columns

Column name | Data type | Description
OrganizationID | int | ID of the organization that the options are defined for.
ContextID | int | ID value stored for the organization to identify the options that belong to the organization. This value will be stored in the OrganizationsPPPP where AttrID is 2327.
RecoveryType | int | indicates what type of lost item gets recovered. 1 indicates Lost Item, and 2 indicates Lost-and-paid Item.
RecoveredPeriod | int | indicates within what time period the lost item gets recovered the options should be applied.
RecoveredTerm | nvarchar(10) | term of the time period the lost item gets recovered. it can be either 'year' or 'month'.


SA_LostItemReplacementCosts

SA_LostItemReplacementCosts Table

This table stores item replacement cost and processing fee by material types per location. All the values are defined by user from SA Patron Service Parameters "Replacement fee options".

Columns

Column name | Data type | Description
ContextID | int | Each location will have a unique context ID if the user defined options get saved to the location level. This ContextID will be also saved to OrganiationsPPPP Value column where the AttrID is 1016.
OrganizationID | int | Organization ID of the system, library or branch to where the options are belong.
MaterialTypeID | int | ID of the Material Type for which options are defined.
ReplacementCost | money | Amount of replacement cost.
ProcessingFee | money | Amount of processing fee.


SA_MaterialTypeGroups

SA_MaterialTypeGroups Table

Defines a grouping of material types that can have a collective constraint applied, for a given organizational context.

Columns

Column name | Data type | Description
GroupID | int | Unique integer identifier for a group.
OrganizationID | int | Organizational context (foreign key constraint on Organizations table)
GroupName | nvarchar(80) | String description of the group.

See Also

SA_MaterialTypeGroups_Definitions, SA_MaterialTypeGroups_Limits,


SA_MaterialTypeGroups_Definitions

SA_MaterialTypeGroups_Definitions Table

Defines the set of material types encompassed the indicates material type group.

Columns

Column name | Data type | Description
GroupID | int | Material type group link (foreign key constraint on SA_MaterialTypeGroups table)
MaterialTypeID | int | Material type included in the associated group (foreign key constraint on MaterialTypes table)


SA_MaterialTypeGroups_Limits

SA_MaterialTypeGroups_Limits Table

Defines the overall limit to be applied to the associated material type group for the indicated patron code.

Columns

Column name | Data type | Description
GroupID | int | Material type group ID (foreign key constrain on SA_MaterialTypeGroups table)
PatronCodeID | int | Associated patron code that the limit will apply to (foreign key constraint on PatronCodes table)
Limit | int | Numerical limit to be applied to the group for the associated patron code.


SA_MediaDispenser_MaterialTypes

SA_MediaDispenser_MaterialTypes Table

This table defines all material types that are designated as valid materials for containment in a media dispenser unit for a given organizational context.

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context (foreign key on the Polaris.Organizations table).
MaterialTypeID | int | Designated material type (foreign key on the Polaris.MaterialTypes table).


SA_MediaDispenser_Vendors

SA_MediaDispenser_Vendors Table

This table defines all media dispenser vendors that can be configured in Polaris. (eg. ITG DiscXpress)

Columns

Column name | Data type | Description
VendorID | int | A unique numeric identifier assigned to a specific vendor.
Description | nvarchar(80) | Text description of the vendor for display on the SA UI.


SA_MobilePhoneCarriers

SA_MobilePhoneCarriers Table

This table defines the set of mobile phone carriers that, if enabled for display, are available to be associated with a patron.

Columns

Column name | Data type | Description
CarrierID | int | Unique numeric identifier
CarrierName | nvarchar(255) | The display name for the phone carrier (eg. AT&T)
Email2SMSEmailAddress | nvarchar(255) | SMS (Short Message Service) address of the carrier (eg. @txt.att.net)
NumberOfDigits | smallint | Number of digits required in the phone number (not currently exposed - for future use)
Display | bit | A bit flag to indicate whether this carrier is allowable as an option (1 = Yes, 0 = No)


SA_NCIPMediumTypes_Incoming

SA_NCIPMediumTypes_Incoming Table

This table provides a mapping of an NCIP Medium Type to a Polaris Material Type

Columns

Column name | Data type | Description
NCIPMediumTypeID | int | Foreign key reference to the NCIPMediumTypes table
MaterialTypeID | int | Foreign key reference to the MaterialTypes table


SA_NCIPMediumTypes_Outgoing

SA_NCIPMediumTypes_Outgoing Table

This table provides a mapping of a Polaris Material Type to an NCIP Medium Type.

Columns

Column name | Data type | Description
MaterialTypeID | int | Foreign key reference to the MaterialTypes table
NCIPMediumTypeID | int | Foreign key reference to the NCIPMediumTypes table


SA_NCIP_UserPrivilegeTypes

SA_NCIP_UserPrivilegeTypes Table

This table contains the set of user privilege types that are popped-up when the Parameters-->NCIP-->NCIP user privilege type SA attribute is selected. Currently there are 2 choices to assign: Public and Academic

Columns

Column name | Data type | Description
TypeID | int | Unique integer ID for the type (1 = Academic, 2 = Public)
Description | nvarchar(20) | The string description of the privilege type ('Public', 'Academic')


SA_NotReceived_IssueStatus_Assignment

SA_NotReceived_IssueStatus_Assignment Table

This table defines the set of statuses that make up the virtual 'Not Received' status grouping for Serial Issue records for a given organizational context.

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context for the 'Not Received' status (foreign key to the Polaris.Organizations table).
IssueStatusID | smallint | An issue status that is included as a 'Not Received' status (foreign key to the Polaris.MfhdIssueStatuses table).


SA_OLP_Attributes

SA_OLP_Attributes Table

This table is static and contains a list of all Online Payment attributes for the set of providers (currently VeriSign and CLASS) available. The corresponding attribute IDs will be used to record configuration information as managed via the System Administration UI.

Columns

Column name | Data type | Description
AttributeID | int | Primary key - unique integer ID
Description | nvarchar(80) | Character description of he attribute (varchar - 80)

See Also

SA_OLP_Gateway_Attributes,


SA_OLP_Gateways

SA_OLP_Gateways Table

This table contains the list of available online payment gateways available, including an entry for no gateway (None) so that a site can explicitly choose not to use the feature. The corresponding gateway IDs will be used to record configuration information as managed via the System Administration UI.

Columns

Column name | Data type | Description
GatewayID | int | Unique identifier (ID)
Description | nvarchar(80) | A string description of the gateway (eg. VeriSign's Payflow Pro)

See Also

ILSStoreTransactions, SA_OLP_Gateway_Attributes,


SA_OLP_Gateway_Attributes

SA_OLP_Gateway_Attributes Table

This table represents a particular Online Payment gateway's attribute settings for a given organizational context as set by the Online Payment Settings dialog in System Administration.

Columns

Column name | Data type | Description
GatewayID | int | The online payment gateway ID (Foreigh Key relationship to SA_OLP_Gateways)
AttributeID | int | The online payment gateway attribute ID (Foreign Key relationship to SA_OLP_Attributes)
OrganizationID | int | Organizational context ID (Foreign Key relationship to Organizations)
Value | nvarchar(255) | String value of the gateway attribute (varchar - 255)


SA_ORS_DeliveryMode

SA_ORS_DeliveryMode Table

This table holds the list of all Outreach Services delivery modes

Columns

Column name | Data type | Description
DeliveryModeID | int | Identity column that uniquely identifies the delivery mode
OrganizationID | int | Organizational context (foreign key reference on Organizations.OrganizationID)
Term | nvarchar(80) | The string description value of the delivery mode

See Also

ORSPatrons,


SA_ORS_DeliveryRoute

SA_ORS_DeliveryRoute Table

This table holds all Outreach Services delivery route information

Columns

Column name | Data type | Description
DeliveryRouteID | int | Identity column that uniquely identifies a particular route
OrganizationID | int | Organizational context (foreign key reference on Organizations.OrganizationID)
Term | nvarchar(80) | The string name of the route
Description | nvarchar(255) | An optional description of the route

See Also

ORSPatrons, SA_ORS_DeliveryRouteStops,


SA_ORS_DeliveryRouteStops

SA_ORS_DeliveryRouteStops Table

This table holds all route stops associated with a given Outreach Services route

Columns

Column name | Data type | Description
DeliveryRouteID | int | The delivery route associated with this route stop (foreign key reference on SA_ORS_DeliveryRoute.DeliveryRouteID)
RouteStopID | int | A number that uniquely identifies a particular stop within the given route
StopName | nvarchar(80) | The string name of the route stop
StopDescription | nvarchar(255) | An optional description of the route stop
StopSequence | int | The relative order of this stop within the route

See Also

ORSPatrons,


SA_ORS_Disability

SA_ORS_Disability Table

This table holds the list of all Outreach Services disabilities

Columns

Column name | Data type | Description
DisabilityID | int | Identity column that uniquely identifies the disability
OrganizationID | int | Organizational context (foreign key reference on Organizations.OrganizationID)
Term | nvarchar(80) | The name of the disability

See Also

ORSPatronDisabilities,


SA_ORS_Equipment

SA_ORS_Equipment Table

This table holds all Outreach Services equipment values

Columns

Column name | Data type | Description
EquipmentID | int | Identity column that uniquely identifies the piece of equipment
OrganizationID | int | Organizational context (foreign key reference on Organizations.OrganizationID)
Term | nvarchar(80) | Name of the piece of equipment

See Also

ORSPatronEquipment,


SA_ORS_ExcludedItemStatuses

SA_ORS_ExcludedItemStatuses Table

This table indicates the inclusion/exclusion of each item statuses with respect to Outreach Services processing

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context (foreign key reference on Organizations.OrganizationID)
ItemStatusID | int | The item status in question (foreign key reference on ItemStatuses.ItemStatusID)
Excluded | bit | This column indicates whether the given item status is excluded or not


SA_ORS_IncludedBranches

SA_ORS_IncludedBranches Table

This table indicates the inclusion/exclusion of each organization (branch) with respect to Outreach Services processing

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context (foreign key reference on Organizations.OrganizationID)
BranchID | int | The particular branch organization involved (foreign key reference on Organizations.OrganizationID)
Included | bit | Indicates whether the branch (BranchID) is to be included or not


SA_ORS_PackingListText

SA_ORS_PackingListText Table

This table defines the heading text and rating text with respect to packing list content for Outreach Services Title Ratings, for a given organizational context.

Columns

Column name | Data type | Description
OrgID | int | Organizational context (FK to the Organizations table)
HeaderText | nvarchar(500) | Header text (up to 500 characters)
RatingText | nvarchar(500) | Rating text (up to 500 characters)


SA_ORS_SLHeaders

SA_ORS_SLHeaders Table

This table holds the list of column headers to be used to display Outreach Services selection lists

Columns

Column name | Data type | Description
HeaderID | int | Identity column that uniquely identifies each column header
Term | nvarchar(80) | The text of the column header

See Also

SA_ORS_SLHeaderSelections,


SA_ORS_SLHeaderSelections

SA_ORS_SLHeaderSelections Table

This table holds the particular inclusion and display order of Outreach Service selection list column headers

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context (foreign key on Organizations.OrganizationID)
HeaderID | int | The column header involved (foreign key reference on SA_ORS_SLHeaders.HeaderID)
DisplayOrder | int | Relative left-to-right display order of all included column headers for the particular organizational context
Included | bit | Indicates whether or not the column header is to be included in the display


SA_PACLimitBy

SA_PACLimitBy Table

This table holds the various CCL filters to limit PAC searches by for the 'Type of Material' functionality. A set of defaults are supplied and these can not be programmatically removed. The table is managed as an SA policy table.

Columns

Column name | Data type | Description
OrganizationID | int | The specific organizational identifier associated with this limit.
LimitDescription | nvarchar(255) | This is a string description of the limit and it is what displays on the PAC UI list of filter choices.
CCLFilter | nvarchar(255) | The CCL that represents the filter to be applied to a PAC search. eg) TOM=art
Enabled | bit | This flag indicates whether or not this limit should be available on the PAC UI as a search filter.
DisplayOrder | int | The relative list display order of this particular limit for a given organization.
Protected | bit | This flag indicates whether or not the limit is a supplied default (Protected=Yes) or whether it represents a limit created by the site (Protected=No). Protected items can not be deleted and can only have their limit description and display order changed.


SA_PAC_ContentCarousels

SA_PAC_ContentCarousels Table

Defines the set of content carousels to be displayed in the PowerPAC for a given organizational context.

Columns

Column name | Data type | Description
OrgID | int | Organizational context (foreign key constraint on Organizations table)
IsRecordSet | bit | Indicates whether the defined carousel is a bibliographic record set (1) or a system-defined list (0).
ObjectID | int | Identifier of a bibliographic record set (if the IsRecordSet value = 1, links to RecordSets table) or a system-defined listing (if the IsRecordSet value = 0, links to ListingTypes table)
Name | nvarchar(128) | Configurable sting description of the carousel.
DisplayOrder | int | The relative top-down order to display a carousel in relation to the other carousels defined for the given organizational context.


SA_PAC_MARCDataElements

SA_PAC_MARCDataElements Table

This table holds all the PowerPAC display elements available for Title Display Configuration in both the Brief and Full displays. The configuration tables SA_PAC_BriefTitleDisplay and SA_PAC_FullTitleDisplay reference these elements.

Columns

Column name | Data type | Description
ElementID | int | Unique integer ID (Primary Key)
Description | nvarchar(80) | Data element description that will display in the Title Configuration Display SA dialog (Read-only; varchar-80)
BriefEntityID | smallint | Identifier of the brief NSM entity associated with this row. This column is only used for conversion purposes; the SA_PAC_MARCDataElements table has been deprecated and will be dropped in a future release.
FullEntityID | smallint | Identifier of the full NSM entity associated with this row. This column is only used for conversion purposes; the SA_PAC_MARCDataElements table has been deprecated and will be dropped in a future release.


SA_PAC_SearchByChoices

SA_PAC_SearchByChoices Table

This table contains the list of available 'search-by' choices for a given PowerPAC search type and is used to populate the Default Search Settings SA dialog.

Columns

Column name | Data type | Description
SearchTypeID | int | PowerPAC search type ID (FK on SA_PAC_SearchTypes)
SearchByID | int | Search-By ID (FK on SA_PAC_SearchBys)
DisplayOrder | int | Relative order to display the search-by choices for a given search-type in the Default Search Settings drop list


SA_PAC_SearchBys

SA_PAC_SearchBys Table

This table holds the list of all available search-by choices and will be used to populate the Default Search Settings SA dialog

Columns

Column name | Data type | Description
SearchByID | int | Unique identifier
Mnemonic | nvarchar(10) | CCL mnemonic for the search-by (varchar-10)
Description | nvarchar(80) | String description of the search-by choice (varchar-80)

See Also

SA_DWI_AccessPointIDs, SA_PAC_SearchByChoices, SA_PAC_SearchSettings,


SA_PAC_SearchDashboardDisplay

SA_PAC_SearchDashboardDisplay Table

This table holds configuration information for the customization of the 'Narrow your search' and 'Related searches' digital dashboard display in the PowerPAC as managed by the 'Narrow your search & Related searches' SA property sheet dialog.

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context ID (Foreign Key relationship with Organizations table)
DashboardType | int | Digital dashboard indicator (1 = Narrow your search, 2 = Related searches)
ElementID | int | Digital dashboard element ID (Foreign Key relationship with SA_PAC_SearchDashboardElements table)
DisplayFlag | bit | Bit column indicating whether or not to even display the corresponding dashboard element (1 = Yes, 0 = No)
DisplayOrder | int | Numeric value indicating the relative display order (from top to bottom) that a digital dashboard element will appear among other elements of the same dashboard (same DashboardType value)
AdminAttrID | int | The corresponding PowerPAC profile SA language string attribute, used as a look-up in the AdminLanguageStrings table to retrieve the actual string label for a dashboard element. (Foreign Key relationship with the AdminAttributes table)
Expanded | bit | Bit column indicating whether a given dashboard element is to appear initially expanded or collapsed (1 = Expanded, 0 = Collapsed)
MinimumToShow | int | A numeric value indicating the minimum number of entries to display when the corresponding dashboard element is expanded
MaximumToShow | int | A numeric value indicating the maximum number of entries to display when the corresponding dashboard element is expanded


SA_PAC_SearchDashboardElements

SA_PAC_SearchDashboardElements Table

This table holds all the PowerPAC digital dashboard display elements available for the 'Narrow your search' and 'Related searches' digital dashboard. The configuration table SA_PAC_SearchDashboardDisplay references these elements.

Columns

Column name | Data type | Description
ElementID | int | Unique integer ID (Primary Key)
Description | nvarchar(80) | Digital dashboard element description that will display in the 'Narrow your search & Related searches' SA property sheet dialog (Read-only; varchar-80)
FacetTypeID | tinyint | The facet type associated with this dashboard element.

See Also

SA_PAC_SearchDashboardDisplay,


SA_PAC_SearchSettings

SA_PAC_SearchSettings Table

This table holds configuration information for the default search settings in the PowerPAC as managed by the Search Settings Defaults dialog in System Administration. For each available PowerPAC search type, a default 'search-by', 'sort-by', and 'limit-by' choice can be specified.

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context ID (Foreign Key relationship with Organizations)
SearchTypeID | int | PowerPAC search type ID (Foreign Key relationship with SA_PAC_SearchTypes)
SearchByID | int | Default 'search-by' ID (Foreign Key relationship with SA_PAC_SearchBys)
LimitByDescription | nvarchar(255) | Default 'limit-by' choice description (varchar-255)
SortByID | int | Default 'sort-by' ID for local database searching (Foreign Key relationship with SA_PAC_SortBys)
RemoteSortByID | int | Defines the default sorting option to use when at least 1 remote database is selected (Foreign Key relationship with SA_PAC_SortBys)


SA_PAC_SearchTypes

SA_PAC_SearchTypes Table

This table holds the list of all available PowerPAC search types to be used in constructing the Default Search Settings SA dialog

Columns

Column name | Data type | Description
SearchTypeID | int | Unique identifier
Description | nvarchar(20) | String description of the search type (varchar-20)

See Also

SA_COMMUNITY_PAC_SearchByChoices, SA_COMMUNITY_PAC_SearchSettings, SA_DWI_AccessPointIDs, SA_PAC_SearchByChoices, SA_PAC_SearchSettings,


SA_PAC_SortBys

SA_PAC_SortBys Table

This table holds the list of all available sort-by choices and will be used to populate the Default Search Settings SA dialog

Columns

Column name | Data type | Description
SortByID | int | Unique identifier
Mnemonic | nvarchar(10) | CCL mnemonic representation of the sort-by attribute (varchar-10)
Description | nvarchar(80) | String description of the sort-by choice (varchar-80)
DisplayOrder | int | Relative display order for the Default Search Settings drop list

See Also

SA_PAC_SearchSettings,


SA_PAC_SuppressedBranches

SA_PAC_SuppressedBranches Table

This table holds those branch organizations that are to be suppressed from the Active PAC and PowerPAC interfaces. This is managed via the SA dialog Suppress Branches (Profiles-->PAC; System level context only).

Columns

Column name | Data type | Description
OrganizationID | int | The organizational context, currently only the System level (Organization ID = 1), for a particular suppressed branch organization.
SuppressedOrgID | int | The organization ID of a branch that will be suppressed.


SA_PAC_SuppressedCircStatuses

SA_PAC_SuppressedCircStatuses Table

This table holds those circulation statuses that are to be suppressed from the PowerPAC with respect to items having one of those statuses. This is managed via the SA dialog Suppress Item Display.

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context ID (FK on Organizations)
ItemStatusID | int | Circulation Status to suppress (FK on ItemStatuses)


SA_PatronCodesFilterByRegisteredBranch

SA_PatronCodesFilterByRegisteredBranch Table

This table stores a set of patron codes for a given organization that are to be available on the staff client UI at patron registration, among other places. An SA dialog is used to configure what subset of patron codes are applicable for a given organization (registered branch).

Columns

Column name | Data type | Description
OrganizationID | int | Foreign key reference to the Organizations table - Organizational context for the patron code being made available (every organization is required to have at least 1 defined)
PatronCodeID | int | Foreign key reference to the PatronCodes table - The patron code that is available for an organization


SA_PatronDisplayOrder

SA_PatronDisplayOrder Table

This table defines all the values of SA parameters defined from "Check-out: Optional patron data" in Patron Services tab.

Columns

Column name | Data type | Description
OrganizationID | int | ID of organization for which the SA parameters are defined.
OptionID | tinyint | ID of the options user choose to display on the check-out w/f. FK refers to PatronDisplayOptions.OptionID.
DisplayOrder | tinyint | display sequence of the data field.


SA_PatronInitCirc_XactingBranch

SA_PatronInitCirc_XactingBranch Table

This table provides the choices that appear in the 'Patron Services-->Profiles-->Patron initiated circulation: Transaction branch' SA combo-box attribute (currently only 2 choices: Patron's branch (1) and Item's branch (2) )

Columns

Column name | Data type | Description
OptionID | int | The unique numeric identifier for the corresponding transaction branch option, the actual value that is stored in the OrganizationsPPPP table when set at the system level
Description | nvarchar(64) | The string that represents the transaction branch option and appears in the SA combo box


SA_PatronMessageLanguageStrings

SA_PatronMessageLanguageStrings Table

The table where patron organizational messages are defined (allows for multi-lingual)

Columns

Column name | Data type | Description
MessageID | int | Message ID (key)
LanguageID | int | Language ID
MessageValue | nvarchar(255) | message text


SA_PatronRegistrationCharges

SA_PatronRegistrationCharges Table

This table stores the charges ($$) for patron registration for a given patron code at a given branch organization.

Columns

Column name | Data type | Description
OrganizationID | int | The organization ID (branch) for which a charge is defined for some patron code. Foreign key on the Organizations table.
PatronCodeID | int | The patron code for which a charge is defined. Foreign key on the PatronCodes table.
Charge | money | The monetary value that represents the charge. The default value is $0.00 and will also be the value returned if a row for a given patron code and branch organization does not explicitly exist in the table.


SA_PatronSpecialMessages

SA_PatronSpecialMessages Table

The organization defined patron messages

Columns

Column name | Data type | Description
MessageID | int | message ID
OrganizationID | int | Organization ID

See Also

PAC_PatronMessages, SA_PatronMessageLanguageStrings,


SA_PatronStatusOpenOptions

SA_PatronStatusOpenOptions Table

This is a table of choices available in SA which determine which is the first view that is enabled when a record workform is opened.

Columns

Column name | Data type | Description
PatronStatusOpenOptionID | int | primary key
Description | nvarchar(80) | view description


SA_PaymentMethods

SA_PaymentMethods Table

This table represents the available payment methods and their relative display order as presented to the user for selection in the staff client (Pay dialog launched from the Account view of the Patron Status work form. The SA policy table Payment Methods manages these settings.

Columns

Column name | Data type | Description
OrganizationID | int | Foreign key to the Organizations table. Organizational context for a particular payment method.
PaymentMethodID | int | Foreign key to the PatronPaymentMethods table. The actual payment method (eg. Check, Credit card, Cash, etc.) involved.
DisplayOrder | int | Relative display order that the payment method option will appear (if the Selected column is Yes) in the UI control where a payment method selection is required.
Selected | bit | A Yes/No value to indicate whether or not the specific payment method is available for selection.


SA_PermissionSubsystems

SA_PermissionSubsystems Table

This static table contains the string descriptions of all subsystems that are assigned some subset of Permissions in SA, eventually replacing the hard-coded string arrays that appear in mutliple places in the code.

Columns

Column name | Data type | Description
SubsystemID | int | Numeric identifier for the subsystem for which a foreign key constraint now exists on the Polaris.ControlRecordDefs table.
Description | nvarchar(40) | String description of the subsystem.

See Also

ControlRecordDefs,


SA_PowerPAC_Themes

SA_PowerPAC_Themes Table

This table defines a set of themes available for use by the PowerPAC. Five system-defined themes are supplied at installation.

Columns

Column name | Data type | Description
ThemeID | int | Unique theme identifier (IDENTITY)
DisplayName | nvarchar(255) | The displayable name of the theme
Path | nvarchar(255) | Relative directory path for resources associated with the theme
UserDefined | bit | A flag to indicate whether or not the Theme is user-defined (0 = System-defined, 1 = User-defined)


SA_PreferredVendorAccounts

SA_PreferredVendorAccounts Table

Contains one row for each preferred vendor account mapping

Columns

Column name | Data type | Description
PreferredVendorAccountID | int | Unique identifier
OrganizationID | int | Organization identifier from Organizations table
VendorID | int | Vendor identifier from Vendors table
VendorAccountID | int | Vendor account identifier from VendorAccounts table


SA_PrimaryDisplayAuthor

SA_PrimaryDisplayAuthor Table

This table holds the tags/subfields that can be used to build a display and sort version of a bibliographic author field. This is tied into find tool and PAC display, and NOT into author browsing.

Columns

Column name | Data type | Description
BibAuthorPrecedence | int | Precedence to use a specific tag as the primary author
BibTagNumber | int | Bib Tag Number
BibSubfield | char | Bib Subfield


SA_PrimaryDisplayTitle

SA_PrimaryDisplayTitle Table

This table holds the tags/subfields that can be used to build a display and sort version of a bibliographic title field. This is tied into find tool and PAC display, and NOT into title browsing.

Columns

Column name | Data type | Description
BibTitlePrecedence | int | Precedence to use a specific tag as the primary title
BibTagNumber | int | Bibliographic Tag number
BibSubfield | char | Bibliographic subfield


SA_ProductPage_Categories

SA_ProductPage_Categories Table

Defines a static list of possible features that can be configured to appear on the product page of the PowerPAC and Mobile PAC. (Enriched data features, Map It, Availability, etc.)

Columns

Column name | Data type | Description
CategoryID | int | Unique integer identifier for a given category
Category | nvarchar(80) | String description of the category

See Also

SA_ProductPage_Mnemonics,


SA_ProductPage_Configuration

SA_ProductPage_Configuration Table

Defines the set of features to appear on the product page for both the PowerPAC and Mobile PAC, for a given organizational context

Columns

Column name | Data type | Description
OrgID | int | Organizational context (foreign key constraint on Organizations table)
CategoryID | int | Product page category link (foreign key constraint on SA_ProductPage Categories table)
InitialState | int | Indicates whether a category is to appear initially collapsed (0) or expanded (1). For features for which expanding/collapsing doesn't apply the value will be 2.
Sequence | int | Relative order in which the feature is to be displayed on the product page for a given organizational context.
ContextID | int | Product link (1 = PowerPAC, 11 = Mobile PAC)


SA_ProductPage_Mnemonics

SA_ProductPage_Mnemonics Table

Defines the WebAdmin mnemonic associated with a given product page category for multilingual translation (for both the PowerPAC and Mobile PAC)

Columns

Column name | Data type | Description
CategoryID | int | Product page feature link (foreign key constraint on SA_ProductPage_Categories)
ContextID | int | Indicates PowerPAC (1) or Mobile PAC (11)
Mnemonic | nvarchar(100) | WebAdmin mnemonic string that allows for multilingual configuration of a category name

See Also

SA_ProductPage_Configuration,


SA_RemotePrimaryDisplayAuthor

SA_RemotePrimaryDisplayAuthor Table

Contains one row for each (remote) author-based tag/subfield pair.

Columns

Column name | Data type | Description
BibAuthorPrecedence | int | Identifies the precedence of the tag/subfield pair.
BibTagNumber | int | Identifies the (MARC) tag number.
BibSubfield | char | Identifies the (MARC) subfield identifier.


SA_RemotePrimaryDisplayTitle

SA_RemotePrimaryDisplayTitle Table

Contains one row for each (remote) title-based tag/subfield pair.

Columns

Column name | Data type | Description
BibTitlePrecedence | int | Identifies the precedence of the tag/subfield pair.
BibTagNumber | int | Identifies the (MARC) tag number.
BibSubfield | char | Identifies the (MARC) subfield identifier.


SA_ResourceGroups

SA_ResourceGroups Table

Resource Group object definition

Columns

Column name | Data type | Description
GroupID | int | Unique identifier (IDENTITY column)
Name | nvarchar(110) | Text name of the group (required)
Description | nvarchar(255) | Text description of the group (required)
CreatorID | int | User who created the group (Foreign key reference to PolarisUsers)
ModifierID | int | User who made the last modification (Foreign key reference to PolarisUsers)
CreationDate | datetime | Timestamp of the group's creation
ModificationDate | datetime | Timestamp showing when the last modification was made to the group

See Also

BibliographicRecordResourceGroups, SA_ResourceGroups_Organizations, Servers, VendorAccounts,


SA_ResourceGroups_Organizations

SA_ResourceGroups_Organizations Table

The set of branches (can include the system organization) that makes up a resource group

Columns

Column name | Data type | Description
GroupID | int | The resource group (Foreign key reference to SA_ResourceGroups)
OrganizationID | int | Branch (or System org) that is a member of the resource group (Foreign key reference to Organizations)


SA_RLPieceDisplayOrder

SA_RLPieceDisplayOrder Table

This table defines sets of Route List Piece Display options along with a Left-To-Right ordering scheme. Each set of options is marked by a context ID.

Columns

Column name | Data type | Description
ContextID | int | An integer identifier that marks a specific set of piece display options. This value is the System Administration link between a particular domain context (user, workstation, org) and a defined set of piece display options.
DisplayOptionID | int | A foreign key link to the RouteListPieceDisplayOptions table. Defines the inclusion of a particular piece display option.
DisplayOrder | int | The relative left-to-right display order of the piece display options set for the given context ID.


SA_SecurityHistory_Group_Denied_Permission

SA_SecurityHistory_Group_Denied_Permission Table

History record of a permission being removed from a permission group.

Columns

Column name | Data type | Description
CRID | int | ControlRecords table component of the permission that was removed
PermissionID | int | PermissionDefs table component of the permission that was removed.
GroupID | int | Groups table ID of the permission group being changed (may not be present anymore)
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the permission group)
Date | datetime | Time of the permission removal


SA_SecurityHistory_Group_Granted_Permission

SA_SecurityHistory_Group_Granted_Permission Table

History record of a permission being added to a permission group.

Columns

Column name | Data type | Description
CRID | int | ControlRecords table component of the permission that was added
PermissionID | int | PermissionDefs table component of the permission that was added.
GroupID | int | Groups table ID of the permission group being changed (may not be present anymore)
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the permission group)
Date | datetime | Time of the permission addition


SA_SecurityHistory_HistoryMakers

SA_SecurityHistory_HistoryMakers Table

This table represents all user and workstation combinations that have made any kind of permission operations for security history recording.

Columns

Column name | Data type | Description
HistoryMakerID | int | Unique identifier referenced by the various Security History tables
UserID | int | Staff Member reference (may no longer be present in the PolarisUsers table)
WorkstationID | int | Workstation reference (may no longer be present in the Workstations table)

See Also

SA_SecurityHistory_Group_Denied_Permission, SA_SecurityHistory_Group_Granted_Permission, SA_SecurityHistory_Organization_AddedTo_Group, SA_SecurityHistory_Organization_RemovedFrom_Group, SA_SecurityHistory_User_AddedTo_Group, SA_SecurityHistory_User_Denied_Permission, SA_SecurityHistory_User_Granted_Permission, SA_SecurityHistory_User_RemovedFrom_Group, SA_SecurityHistory_Workstation_AddedTo_Group, SA_SecurityHistory_Workstation_Denied_Permission, SA_SecurityHistory_Workstation_Granted_Permission, SA_SecurityHistory_Workstation_RemovedFrom_Group,


SA_SecurityHistory_MemberNames

SA_SecurityHistory_MemberNames Table

This table holds the name of the user, workstation, permission group or organization involved in a permission change (for security history recording)

Columns

Column name | Data type | Description
MemberNameID | int | Unique identifier (referenced by the various Security History tables)
MemberName | nvarchar(255) | The name of a user, workstation, permission group or organization

See Also

SA_SecurityHistory_Group_Denied_Permission, SA_SecurityHistory_Group_Granted_Permission, SA_SecurityHistory_Organization_AddedTo_Group, SA_SecurityHistory_Organization_RemovedFrom_Group, SA_SecurityHistory_User_AddedTo_Group, SA_SecurityHistory_User_Denied_Permission, SA_SecurityHistory_User_Granted_Permission, SA_SecurityHistory_User_RemovedFrom_Group, SA_SecurityHistory_Workstation_AddedTo_Group, SA_SecurityHistory_Workstation_Denied_Permission, SA_SecurityHistory_Workstation_Granted_Permission, SA_SecurityHistory_Workstation_RemovedFrom_Group,


SA_SecurityHistory_Organization_AddedTo_Group

SA_SecurityHistory_Organization_AddedTo_Group Table

History record of a permission group being added to an organization.

Columns

Column name | Data type | Description
GroupID | int | Groups table ID of the permission group being added (may not be present anymore)
OrganizationID | int | Organizations table ID of the organization being added to
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the organization)
Date | datetime | Time of the group addition


SA_SecurityHistory_Organization_RemovedFrom_Group

SA_SecurityHistory_Organization_RemovedFrom_Group Table

History record of a permission group being removed from an organization.

Columns

Column name | Data type | Description
GroupID | int | Groups table ID of the permission group being removed(may not be present anymore)
OrganizationID | int | Organizations table ID of the organization being removed from
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the organization)
Date | datetime | Time of the group removal


SA_SecurityHistory_User_AddedTo_Group

SA_SecurityHistory_User_AddedTo_Group Table

History record of a User being added to a permission group.

Columns

Column name | Data type | Description
GroupID | int | Groups table ID of the permission group being changed (may not be present anymore)
UserID | int | PolarisUsers table ID of the user that was added.
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the User)
Date | datetime | Time of the User addition


SA_SecurityHistory_User_Denied_Permission

SA_SecurityHistory_User_Denied_Permission Table

History record of a Permission being removed from a User.

Columns

Column name | Data type | Description
CRID | int | ControlRecords table component of the permission that was removed
PermissionID | int | PermissionDefs table component of the permission that was removed.
UserID | int | PolarisUsers table ID of the User being changed (may not be present anymore)
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the User)
Date | datetime | Time of the permission removal


SA_SecurityHistory_User_Granted_Permission

SA_SecurityHistory_User_Granted_Permission Table

History record of a Permission being added to a User.

Columns

Column name | Data type | Description
CRID | int | ControlRecords table component of the permission that was removed
PermissionID | int | PermissionDefs table component of the permission that was removed.
UserID | int | PolarisUsers table ID of the User being changed (may not be present anymore)
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the User)
Date | datetime | Time of the permission addition


SA_SecurityHistory_User_RemovedFrom_Group

SA_SecurityHistory_User_RemovedFrom_Group Table

History record of a User being removed from a permission group.

Columns

Column name | Data type | Description
GroupID | int | Groups table ID of the permission group being changed (may not be present anymore)
UserID | int | PolarisUsers table ID of the user that was removed.
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the User)
Date | datetime | Time of the User removal


SA_SecurityHistory_Workstation_AddedTo_Group

SA_SecurityHistory_Workstation_AddedTo_Group Table

History record of a Workstation being added to a permission group.

Columns

Column name | Data type | Description
GroupID | int | Groups table ID of the permission group being changed (may not be present anymore)
WorkstationID | int | Workstations table ID of the workstation that was added.
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the Workstation)
Date | datetime | Time of the Workstation addition


SA_SecurityHistory_Workstation_Denied_Permission

SA_SecurityHistory_Workstation_Denied_Permission Table

History record of a Permission being removed from a Workstation.

Columns

Column name | Data type | Description
CRID | int | ControlRecords table component of the permission that was removed
PermissionID | int | PermissionDefs table component of the permission that was removed.
WorkstationID | int | Workstations table ID of the Workstation being changed (may not be present anymore)
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the Workstation)
Date | datetime | Time of the permission removal


SA_SecurityHistory_Workstation_Granted_Permission

SA_SecurityHistory_Workstation_Granted_Permission Table

History record of a Permission being added to a Workstation.

Columns

Column name | Data type | Description
CRID | int | ControlRecords table component of the permission that was added
PermissionID | int | PermissionDefs table component of the permission that was added.
WorkstationID | int | Workstations table ID of the Workstation being changed (may not be present anymore)
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the Workstation)
Date | datetime | Time of the permission addition


SA_SecurityHistory_Workstation_RemovedFrom_Group

SA_SecurityHistory_Workstation_RemovedFrom_Group Table

History record of a Workstation being removed from a permission group.

Columns

Column name | Data type | Description
GroupID | int | Groups table ID of the permission group being changed (may not be present anymore)
WorkstationID | int | Workstations table ID of the workstation that was removed.
HistoryMakerID | int | Foreign key reference to the SA_SecurityHistory_HistoryMakers table (identifies user and workstation that made the change)
MemberNameID | int | Foreign key reference to the SA_SecurityHistory_MemberNames table (stores the name of the Workstation)
Date | datetime | Time of the Workstation removal


SA_ShelvingStatusDurations

SA_ShelvingStatusDurations Table

The table defines the duration (in minutes) to be applied when determining is a recently checked in item is in "shelving" status.

Columns

Column name | Data type | Description
OrganizationID | int | Organization the associated MaterialTypeID/Duration is to be associated with.
MaterialTypeID | int | The item's MaterialTypeID.
Duration | int | The number of minutes required for an item of this material type to be shelved. (zero indicates do not apply shelving status to this material type)


SA_SIPCheckOutItemAllowances

SA_SIPCheckOutItemAllowances Table

List of item statuses for each branch that are available for check-out through the SIP service.

Columns

Column name | Data type | Description
OrganizationID | int | ID of the Organization. Foreign Key reference to the Organizations table.
ItemStatusID | int | ID of the Item Status. Foreign Key reference to the ItemStatuses table.
IsSelected | bit | Flag indicating if the item status is available for check-out through the SIP service.


SA_SL_BranchFundFilter_BranchSettings

SA_SL_BranchFundFilter_BranchSettings Table

This table associates a domain settings with one or more branch organizations for a Selection List branch/fund filter definition.

Columns

Column name | Data type | Description
BranchSettingID | int | Unique numer identifier.
DomainSettingID | int | FK reference to the SA_SL_BranchFundFilterDomainSettings table
BranchID | int | The branch organization ID that will be associated with the given domain definition.

See Also

SA_SL_BranchFundFilter_FundSettings,


SA_SL_BranchFundFilter_DomainSettings

SA_SL_BranchFundFilter_DomainSettings Table

This table associates an organization or a specific user with a set of branch/fund filter settings for Selection List processing.

Columns

Column name | Data type | Description
DomainSettingID | int | Unique numeric identifier
DomainID | int | Identifies whether this is an organizational context or a user-specific context (FK to the Domains table)
DomainValue | int | The organization ID (if the Domain ID indicates an organizational context - Organizations table reference) or user ID (if a user context is indicated - PolarisUsers table reference)

See Also

SA_SL_BranchFundFilter_BranchSettings,


SA_SL_BranchFundFilter_FundSettings

SA_SL_BranchFundFilter_FundSettings Table

This table associates a given branch setting (which is associated with a given organizational or user context) with a set of Funds that defines a Branch/Fund filter for Selection List processing (multiple funds across multiple branches)

Columns

Column name | Data type | Description
BranchSettingID | int | FK reference to the SA_SL_BranchFundFilter_BranchSettings table
FundID | int | A Fund that is 'selected' as part of the Branch/Fund Filter (FK to the Funds table)


SA_SubfieldNineUtility_ReportDetail

SA_SubfieldNineUtility_ReportDetail Table

The report detail for the subfield nine utility report

Columns

Column name | Data type | Description
UtilityRunID | int | The unique ID of the utility run.
BibliographicRecordID | int | The affected bib record ID
BibliographicTagID | int | The affected bib tag ID
TagNumber | int | The tagnumber processed
SubFieldNineData | nvarchar(4000) | The subfield nine data in the affected tag
Content | nvarchar(4000) | The content (subfield data) of the affected tag excluding the data in the subfield nine.
Ind1 | char | The indicator one value of the subfield nine
Ind2 | char | The indicator two value of the subfield nine


SA_SubfieldNineUtility_ReportHeader

SA_SubfieldNineUtility_ReportHeader Table

The header data for the subfield nine utility report.

Columns

Column name | Data type | Description
UtilityRunID | int | The unique ID of the utility run
UtilityRunDate | date | The date that the utility ran
UtilityOptions | nvarchar(255) | The options selected for the run
UtilityStartTime | time | The time that processing began
UtilityEndTime | time | The time the utility completed
NumberOfBibs | int | The number of bibs processed in the run
NumberofTags | int | The number of tags processed in the run


SA_SubfieldNineUtility_ReportSummary

SA_SubfieldNineUtility_ReportSummary Table

The summary data for the subfield nine utility report

Columns

Column name | Data type | Description
UtilityRunID | int | The unique ID of the subfield nine utility run
TagNumber | int | The tag number
NumberofType | int | The number of tags of type


SA_Supplier_WebServices

SA_Supplier_WebServices Table

This table lists the available web services for the Titles-To-Go functionality in the Acquisitions subsystem. This information is used to populate the Titles To Go SA dialog.

Columns

Column name | Data type | Description
WebServiceID | int | Unique identifier
SupplierName | nvarchar(50) | Name of the supplier associated with the web service (varchar-50)
SupplierSAN | nvarchar(7) | The associated SAN of the web service supplier (varchar-7)
URL | nvarchar(255) | The web site associated with the supplier that will provide Titles-To-Go functionality (varchar-255)

See Also

SA_TitlesToGo_Configurations,


SA_SuppressAvailabilityAndRequests

SA_SuppressAvailabilityAndRequests Table

This table contains a row for every primary TOM currently defined in the MARCTypeOfMaterial table for a given organizational context. Associated with each row is a flag indicating whether or not records having that TOM are to be suppressed with respect to availability and request functionality in the PowerPAC and Mobile PAC, as well as a flag indicating whether the suppression should only apply to records containing and 856 tag.

Columns

Column name | Data type | Description
OrgID | int | Organizational context (Foreign Key on the Organizations table)
TypeOfMaterialID | tinyint | Primary TOM (Foreign key on the MARCTypeOfMaterial table)
IsSuppressed | bit | A bit flag that indicates whether the associated TOM is to be suppressed (1) or not (0) at the associated organizational context.
OnlyWith856 | bit | A bit flag that indicates whether the associated TOM, if the IsSuppressed column is set to 1, is to be suppressed only records containing at 856 tag (1) or all records (0) at the associated organizational context.


SA_Telephony_Outbound_SAPI_Settings

SA_Telephony_Outbound_SAPI_Settings Table

This table holds Index, Rate, and Volume settings for a given Telephony Server and a given Language (licensed for that server) with respect to the Speech API employed during Outbound calling.

Columns

Column name | Data type | Description
ServerID | int | Foreign key to the Servers table - The Telephony Server context
LanguageID | int | Foreign key to the AdminLanguages table - The licensed language context with respect to the server
IndexSetting | int | Numeric voice index setting (server-specific), a number between 0 and 100 inclusively
RateSetting | int | Numeric rate setting, a number between -10 and 10 inclusively
VolumeSetting | int | Numeric volume setting, a number between 0 and 100 inclusively


SA_ThemeDashboardPositions

SA_ThemeDashboardPositions Table

This table defines the set of choices for the position of a theme dashboard (Profiles-->PowerPAC-->Theme dashboard position)

Columns

Column name | Data type | Description
PositionID | int | Unique identifier for a position (1 = Left, 2 = Right)
Description | nvarchar(16) | Text description of a position (Left, Right)


SA_TitlesToGo_Configurations

SA_TitlesToGo_Configurations Table

This table holds web service configuration settings for the Titles To Go functionality and is managed from the Title To Go SA dialog.

Columns

Column name | Data type | Description
OrganizationID | int | Organizational context ID (FK on Organizations)
WebServiceID | int | Web service identifier (FK on SA_Supplier_WebServices)
Enabled | bit | Flag to indicate whether the Titles To Go functionality is enabled or not for the given Organization for the given Web Service supplier. (Bit column: 1 = Enabled, 0 = Disabled)
Username | nvarchar(40) | User name of the subscriber account (varchar-40)
Password | nvarchar(20) | Optional password for the subscriber account (varchar-20)
Account | nvarchar(20) | Account number of subscriber account (varchar-20)
Note | nvarchar(255) | Miscellaneous note field for the configuration (varchar-255)


SA_TrappingPreferenceGroups

SA_TrappingPreferenceGroups Table

This table contains set of branch organization clusters that compose each trapping preference group that has been defined.

Columns

Column name | Data type | Description
GroupID | int | The numeric identifier of the trapping preference group to which the branch is associated.
BranchID | int | Branch organization belonging to a trapping preference group (foreign key on the Polaris.Organizations table).


SA_VR_Attributes

SA_VR_Attributes Table

This table holds all the virtual reference configuration attributes available across all providers

Columns

Column name | Data type | Description
AttributeID | int | Unique identifier for an attribute
Description | nvarchar(80) | The name of the attribute

See Also

SA_VR_Provider_Attributes,


SA_VR_Providers

SA_VR_Providers Table

This table holds the list of all virtual reference 3rd-party providers

Columns

Column name | Data type | Description
ProviderID | int | Unique identifier for each provider (0 = (None))
Description | nvarchar(80) | The name of the provider

See Also

SA_VR_Provider_Attributes,


SA_VR_Provider_Attributes

SA_VR_Provider_Attributes Table

This table holds the list attribute values for each provider in a given organizational context

Columns

Column name | Data type | Description
ProviderID | int | The VR provider involved (foreign key reference on SA_VR_Providers.ProviderID)
AttributeID | int | The VR attribute involved (foreign key reference on SA_VR_Attributes.AttributeID)
OrganizationID | int | Organizational context (foreign key reference on Organizations.OrganizationID)
Value | nvarchar(255) | The string value of the attribute for the given provider for the given organizational context


SchoolDivisions

SchoolDivisions Table

list of schools/divisions which can be associated with a course reserve

Columns

Column name | Data type | Description
SchoolDivisionID | int | primary key
OrganizationID | int | the organization where the school/division is
SchoolDivisionName | nvarchar(255) | free text field which is the name

See Also

CourseReserves, CourseTemplates,


SDIHeader

SDIHeader Table

This table is used to define a saved search

Columns

Column name | Data type | Description
SDISearchID | int | Key for table
PatronID | int | Identifies patron who owns saved search
SDIName | nvarchar(100) | Name of search for identification
SDIDescription | nvarchar(255) | Textual description of search
SearchCriteria | nvarchar(255) | The search string
CreateDate | datetime | Date of saved search creation
LastRunDate | datetime | Date the saved search was last run by PolSDIServer
MaxSearchCount | int | The number of times to run this search
NumberSearchsRun | int | How many times the saved search has alread been run
EmailResultsTo | nvarchar(150) | The email address to send search resuts to
EmailFormatID | int | The format of the results email
NotifyOnNoResults | bit | Indicates that the patron wants to be notifed when a search has been run and no new results where found, contrary is that no email is sent.
SearchPeriodID | int | Indicates the basis for running this saved search
CriteriaPlainText | nvarchar(255) | The display criteria with our ccl
SearchOrder | nvarchar(255) | The order to be applied to serch when run in PowerPAC and ActivePAC
DaysToBacktrack | smallint | Identifies the number of days to backtrack when executing a saved search.
NextRunDate | datetime | The next date the saved search will run. This is a computed column based on the last run date and search period.

See Also

SDIRuns, SDISearchFilter, SDISearchOption,


SDIResults

SDIResults Table

Contains one row for each distinct bibliographic record associated a saved search run.

Columns

Column name | Data type | Description
SDIRunID | int | Identifies a saved search run.
BibliographicRecordID | int | Identifies the bibliographic record.


SDIRuns

SDIRuns Table

Contains one row for each run of a saved search

Columns

Column name | Data type | Description
SDIRunID | int | Uniquely identies a saved search run.
SDISearchID | int | Identities a saved search.
SearchDate | datetime | Identies the date and time a saved search was run.
EmailSent | bit | Flag indicating whether an e-mail was successfully sent.


SDISearchFilter

SDISearchFilter Table

Stores search option filter string. Must bestored in table by itself because of it's possible max size

Columns

Column name | Data type | Description
SDISearchID | int | Key field, one to one realationship to SDIHeader's key.
SearchFilter | nvarchar(4000) | Text filter


SDISearchOption

SDISearchOption Table

This table stores search options associated with a saved search. These options are used to limit the scope of the search

Columns

Column name | Data type | Description
SDISearchID | int | Key field
SearchOption | nvarchar(4000) | String contains search options to be applied to search


SDISearchPeriod

SDISearchPeriod Table

Look up table that has allowed search periods.

Columns

Column name | Data type | Description
SearchPeriodID | int | Key to table
SearchPeriod | nvarchar(7) | The search period

See Also

SDIHeader,


SearchDatabases

SearchDatabases Table

Defines what databases are to be searchable based on workstation or organization where request is originated. Up to four queries are run to ascquire that data: first for the current workstation id, than for the current branch id, than library id and finally system id. If any of that queries returns data process is stopped and returned rows define searchable database set.

Columns

Column name | Data type | Description
SearchDBID | int | Just this table unique id.
OrganizationID | int | Branch, Library, or System id. Either this or WorkstationID field must be null.
WorkstationID | int | Workstation id. Either this or OrganizationID field must be null.
DBID | int | Database id in the Databases table.


SearchMethods

SearchMethods Table

A table giving the descriptions that can be mapped to of the different methods of searching. For each method of searching, there can be many types of searching (see the SearchTypes table).

Columns

Column name | Data type | Description
SearchMethodID | int | ID of the search method that can be mapped to (specifically from the SearchTypes table).
Description | nvarchar(100) | The description of the search method.

See Also

SearchTypes,


SearchSuggestionOverrides

SearchSuggestionOverrides Table

This table is used to map search suggestion phrases to override search suggestion phrases with respect to PowerPAC's 'Did You Mean' functionality. It is managed via the 'Did You Mean Overrides' database table interface in System Administration.

Columns

Column name | Data type | Description
Phrase | nvarchar(100) | String of text representing the original search suggestion phrase in the PowerPAC (varchar 100 - is not repeatable, only one 'Did You Mean' override phrase for any particular Phrase)
OverridePhrase | nvarchar(100) | The corresponding 'Did You Mean' term that is presented for the term in the Phrase column. (varchar 100 - can be repeated for different Phrase values)


SearchSuggestions

SearchSuggestions Table

Contains one row for each unique profile/column-ordinal pair that should be mapped to an image.

Columns

Column name | Data type | Description
SearchSuggestionID | int | Unique identifier for the row.
Phrase | nvarchar(100) | Bibliographic heading (ASCII-only).
SoundValue | nvarchar(200) | Metaphone sound-value associated with the Phrase column.
Count | int | Total number of bibliographic records associated with the Phrase column.


SearchTypes

SearchTypes Table

This table maps Z3950 Attribute Values to a Search Method. Each one of these is called a Search Type, and a Search Method can have many of them. Each Z3950 Attribute Value can also be assigned to more than one Search Method.

Columns

Column name | Data type | Description
SearchTypeID | int | ID of the Search Type that represents the Z3950 Attribute Value to Seach Method mapping.
Z3950AttributeValueID | int | ID of the Z3950 Attribute Value that maps to the Search Method.
SearchMethodID | int | ID of the Search Method that maps to the Z3950 Attribute Value.

See Also

PACSearchTypes,


SeeAlsoControl

SeeAlsoControl Table

The table which tells the code with authority 5xx tags need to be checked for 1xx links

Columns

Column name | Data type | Description
SeeAlsoTagNumber | smallint | The 5xx tag which is being "authorized"
AuthorityTagNumber | smallint | The authority 1xx the see also tag uses
AuthorizeOption | bit | whether or not to use this tag

See Also

SeeAlsoControlIndicatorOne, SeeAlsoControlIndicatorTwo, SeeAlsoControlSubfields,


SeeAlsoControlIndicatorOne

SeeAlsoControlIndicatorOne Table

indicator 1 values to consider for see also control

Columns

Column name | Data type | Description
SeeAlsoTagNumber | smallint | see also (5xx) tag number
IndOneCharValue | char | indicator one value


SeeAlsoControlIndicatorTwo

SeeAlsoControlIndicatorTwo Table

Indicator 2 values to consider for see also control

Columns

Column name | Data type | Description
SeeAlsoTagNumber | smallint | see also (5xx) tag number
IndTwoCharValue | char | indicator two value


SeeAlsoControlSubfields

SeeAlsoControlSubfields Table

The subfields which can be used for "see also" control (linking 5xx to 1xx)

Columns

Column name | Data type | Description
SeeAlsoTagNumber | smallint | the 5xx tag number
SubfieldCharValue | char | the subfield designator


SelectionListCheckDuplicates

SelectionListCheckDuplicates Table

table used during Selection List Line Item duplicate detection.

Columns

Column name | Data type | Description
DupOrigination | int | specifies from where the duplicate detection process where originated. for example, during Copy To from SL to PO or Tools|Detect Duplicates from SL WF.
DuplicateLevel | int | based on system admin duplicate setup for selection list.
DuplicatedField | nvarchar(100) | field that generated duplicate entry.
SourceLineNo | int | line number of item being duped.
SourceSegmentNo | int | segment number of item being duped.
DestSelectionList | nvarchar(50) | name of selection list that contains potential duplicate.
DestLibrary | int | SLLI destination library of duplicate lines
DestLineNo | int | selection list line item line number of duplciate line item
DestLineID | int | selection list line item id of duplciate line item
DestSegmentNo | int | selection list line item segment number of duplciate line item
DestSegmentID | int | Selection list line item segment ID of duplicate record.
PONumber | nvarchar(39) | if duplicate item exists on a PO, this is the PO Number.
DestOrderedLib | int | OrganizationID of ordering library found on duplicate selection list line item
BibID | int | bibliographic record control number for bib record of duplicate SLLI.
WorkstationID | int | workstation ID from whcih duplicate record is being generated. Will prevent multiple users from getting each others dupes as well as preventing one user from deleting another users duplicates when done.
SelectionListID | int | primary key of current selection list.
LibraryID | int | Parent Library ID of Selection List from which duplicate detection was initiated.


SelectionLists

SelectionLists Table

This is the main table for the Selection List object. Selection lists are used as a means to gather/record ideas and input about items that a library is considering purchasing.

Columns

Column name | Data type | Description
SelectionListID | int | Polaris assigned unique ID number for a selection list record.
CreationDate | datetime | System generated date & time that this record was created.
CreatorID | int | Polaris User ID of the person that created the record.
Description | nvarchar(255) | Free text field for description of selection list.
ModificationDate | datetime | System generated date & time that the record was modified.
ModifierID | int | Polaris User ID of the person who last modified the record.
OrganizationID | int | An integer that represents the Organization (library) which is tracking and reviewing the selection list.
SelListName | nvarchar(50) | Name of the selection list.
StatusID | int | A flag that indicates whether the SelectionList is open and active (+1) OR closed (0).
StatusDate | datetime | Date of the most recent status for a selection list. The current date is used when the SelectionList record is created.
LineCount | int | Number of Selection List line items contained on the selection list.
TotalCost | money | Total cost of all line item segments on the selection list.

See Also

PurchaseOrders, SelListLines, SelListLineSegments,


SelfCheckExtendedBooleans

SelfCheckExtendedBooleans Table

A table describing a three-state boolean value (no, yes, & unknown) used in the self check tables.

Columns

Column name | Data type | Description
SelfCheckExtendedBooleanID | int | ID of the three-state boolean value.
Description | nvarchar(255) | Either 'No', 'Yes', or 'Unknown'.

See Also

SelfCheckMaterialTypes,


SelfCheckMaterialTypes

SelfCheckMaterialTypes Table

A table that directly maps to the MaterialTypes table with a one-to-one relationship and extends the Material Type with more information specific to the Self Check unit.

Columns

Column name | Data type | Description
MaterialTypeID | int | ID of an item found in the MaterialTypes table. This value creates the one-to-one relationship.
SelfCheckMediaTypeID | int | ID of the static Self Check Media Type that this material type represents. This maps to the SelfCheckMediaTypes table.
IsMagnetic | int | States whether or not this material type is magnetic.
CanDesensitize | int | States whether or not this material type can be desensitized.
IsBlocked | tinyint | States whether or not this material type is blocked by the 3M system.
DoubleSided | bit | Used with EM devices to determine is both the spine and cover of the item need to be desensitized.
Unlocker | bit | Used with security that support Audio/Visual Locker devices. When set to 1, it tells the self check unit that the material is in an AV security case.
DDM_MediaFormatID | int | A foreign key reference to the DDM_MediaFormats table that associates a SelfCheck Material type with a Danish Data Model media format


SelfCheckMediaTypes

SelfCheckMediaTypes Table

This table represents the static list of 3M Self Check Media Types that each Material Type can map to.

Columns

Column name | Data type | Description
SelfCheckMediaTypeID | int | ID of the Self Check Media Type.
Description | nvarchar(255) | The description that 3M has given for the Media Type in the SIP protocol.

See Also

SelfCheckMaterialTypes,


SelfCheckSecurityMarkers

SelfCheckSecurityMarkers Table

Static description table that allows selection of the type of security type implemented by selfcheck unit.

Columns

Column name | Data type | Description
SelfCheckSecurityMarkerID | int | Description ID
Description | nvarchar(255) | static decription data


SelListDecisions

SelListDecisions Table

This table contains information on Selection Decision Descriptions and Identifiers.

Columns

Column name | Data type | Description
DecisionID | int | An integer that represents the current decision a library has made regarding the purchase of a bibliographic item on a selection list line item record.
DecisionDescription | nvarchar(50) | A text description of the DecisionID (eg. Consider, Desiderata, Approved, Rejected, Processed).

See Also

SelListLines,


SelListLines

SelListLines Table

This table contains line level information regarding a selection list. Line level information includes Bibliographic data WITHOUT specifying a library destination. Line data includes: Author, Title, Editions, ISBN, LCCN, Publisher, Material Type, List Price, and more.

Columns

Column name | Data type | Description
SLLineItemID | int | Polaris assigned unique ID number for the selection list line item record.
SelectionListID | int | Polaris assigned unique ID number for a selection list record.
Author | nvarchar(255) | The originator or creator of the item.
BibliographicRecordID | int | The unique identifier for a Bibliographic record. (primary key, identity)
CreationDate | datetime | System generated date & time that the record was created.
CreatorID | int | Polaris User ID of the user that created the record.
DecisionDate | datetime | The date when a library administrative decision occurs regarding the potential purchase of a requested item on a selection list.
DecisionID | int | An integer that represents the current decision a library has made regarding the purchase of a bibliographic item on a selection list line item record. The DecisionID is linked to the SelListDecisions table for its decision description.
Edition | nvarchar(255) | The form or version inwhich a text is published.
ISBN_ISSN | nvarchar(50) | International Standard Book Number/International Standard Serial Number of the item.
LCCN | nvarchar(40) | Library of Congress Catalog Number.
ListPriceUnitBase | money | List price/unit for the item in the libraries base currency. This is the price before the discount rate, if any, is applied.
MaterialTypeID | int | ID number for linked material type of the item(s) being requested.
ModificationDate | datetime | System generated date & time of the last modification to the record.
ModifierID | int | Polaris User ID of the person who last modified the record.
Notes | nvarchar(255) | Free text notes about the line item.
NormalISBNISSN | nvarchar(50) | This contains the normalized version of the ISBN/ISSN number stored with a partiular line item. It is normalized based on Polaris' Normalization routine at the time the line item is saved to the database.
PublicationDate | nchar | Year the item was published.
Publisher | nvarchar(255) | The company that published (eg. printed, recorded, marketed, distributed) the item.
ReviewSource | nvarchar(255) | Journal or person who reviewed the item.
SeriesTitle | nvarchar(500) | Name of the Series within which the item has been assigned.
SeriesNumber | nvarchar(255) | Number of the item within a specific series.
SLLineNumber | int | The Selection List line number as it appears on the Selection List.
Summary | nvarchar(2500) | Condensed description of the contents of the item.
Title | nvarchar(255) | The name of the item.
NormalLCCN | nvarchar(40) | Normalized form of the LCCN - for searching.
NormalAuthor | nvarchar(255) | Normalized form of the author - for searching.
NormalTitle | nvarchar(255) | Normalized form of the title - for searching.
MiscIdentifier | nvarchar(25) | VARCHAR(25). Can be NULL. free text field.
OtherNumber | nvarchar(50) | VARCHAR(50). Used for OtherStandardIdentifer in linked Bib record (ie UPC). Can be NULL.
SupplierID | int | Integer. Foreign Key to linked Supplier record. Can be NULL.
Alert | bit | BIT data type. Default = 0. During Bulk Add is set when there are multiple ISBNs in the linked bib record. Also can be set in the SLLI WF by the user. Copies to POLI.
TitleNonFilingCount | tinyint | Is the number of non-filing characters in the Title column that should be ignored for collating purposes.

See Also

POLines, SelListLineSegments,


SelListLineSegments

SelListLineSegments Table

This table contains all of the selection list line item segments

Columns

Column name | Data type | Description
SLLineItemSegmentID | int | primary key for this table
SLLineItemID | int | Link to selection list line item table
SelectionListID | int | Link to selection list table
CreationDate | datetime | Date of segment creation
CreatorID | int | Link to PolarisUsers table
DestinationCollectionID | int | Link to collections table
DestinationOrgID | int | Link to Organizations table
FiscalYearID | int | Link to FiscalYears table
FundID | int | Link to Funds table
ModificationDate | datetime | Date that this segment was last changed
ModifierID | int | Link to PolarisUsers table
Quantity | int | The quantity associated with this segment
RequesterName | nvarchar(50) | The person who requested this item
SLSegmentNumber | int | segment number


SelListStatuses

SelListStatuses Table

This table contains a list of selection list statuses which can be assigned.

Columns

Column name | Data type | Description
StatusID | int | Primary key.
StatusDescription | nvarchar(50) | Description of the status

See Also

SelectionLists,


Series4XX

Series4XX Table

Provides a link between the Series Bib entries for See References.

Columns

Column name | Data type | Description
ID4xx | int | The MainSeriesHeadingID value for the heading represented in a 4XX authority tag.
ID1xx | int | The MainSeriesHeadingID for the Series associated with 1XX authority tag entry. (The See heading)
AuthorityTagID | int | Link to Authority tags table
DisplayCode | char | Cross Reference Display Code referencing the field CrossReferenceDisplayConstants.CrossReferenceCode


Series5XX

Series5XX Table

Provides a link between the Series Bib entries for See Also References.

Columns

Column name | Data type | Description
ID5xx | int | The MainSeriesHeadingID for the Series associated with 5XX authority tag entry. (The See Also heading)
ID1xx | int | The MainSeriesHeadingID for the Series associated with 1XX authority tag entry.
AuthorityTagID | int | Link to authority tags table
DisplayCode | char | Cross Reference Display Code referencing the field CrossReferenceDisplayConstants.CrossReferenceCode


ServerHistory

ServerHistory Table

Used with a "stub" application to check and verify the client on the local machine (see the documentation for the Auto Install Application Stub)

Columns

Column name | Data type | Description
HistorySequence | int | UniqueID for entry
ServerVersion | nvarchar(50) | Current Version of the Server eg) 1.7.1290
Comments | nvarchar(255) | A comment about the entry in the table
ClientUpdateNeeded | char | For this version of the server do the clients need to be upgraded (Y/N)
LastUpdateUser | nvarchar(50) | Who added the entry
LastUpdateDate | datetime | When did they add it!


Servers

Servers Table

Contains definitions of servers available to Polaris.

Columns

Column name | Data type | Description
ServerID | int | Primary key
ComputerName | nvarchar(32) | internally generated machine name if a SQL connection is defined for this server.
DisplayName | nvarchar(80) | Name for display purposes
CreatorID | int | ID of user who created this object
ModifierID | int | ID of user who last modified this object
CreationDate | datetime | Date/time of creation
ModificationDate | datetime | Date/time of the last modification
ResourceGroupID | int | The Resource Group associated with this Server.
Note | nvarchar(255) | General purpose free text field for a server (Note edit control on a Server work form)

See Also

Connections, Databases, SA_Telephony_Outbound_SAPI_Settings, ServersPPPP, Telephony_ServerBranchMapping,


ServersPPPP

ServersPPPP Table

Holds AdminAttribute data values that have been set for a particular server.

Columns

Column name | Data type | Description
ServerID | int | Server the data pertains to.
AttrID | int | AdminAttribute ID
Value | nvarchar(255) | The data value for this attribute


ShelfLocations

ShelfLocations Table

This table lists the shelf location terms used by specific organizations

Columns

Column name | Data type | Description
ShelfLocationID | int | Part of primary key (with organizationID)
OrganizationID | int | Organization which uses the shelf location
Description | nvarchar(80) | The text shelf location description

See Also

CircItemRecords, ItemTemplates, ReserveItemRecords,


ShelvingSchemes

ShelvingSchemes Table

This table is a coded value list of all shelving schemes (defined by system, not org specific)

Columns

Column name | Data type | Description
ShelvingSchemeID | int | Primary key - code
Description | nvarchar(80) | The text description

See Also

CallNumberHierarchies, ItemRecordDetails, ItemTemplates, SHRCopies,


ShippingMethods

ShippingMethods Table

This is a secondary table used by purchase order record.Shipping methods are instructions to the supplier about how to ship an order.

Columns

Column name | Data type | Description
ShippingMethodID | int | Integer value used to link a Shipping Method with a Purchase Order. Must be unique to this table.
ShippingMethod | nvarchar(50) | Instructions to the supplier about how to ship the order.Pre-defined values are: UPS, Book rate, Freight, Hold for pickup, Air Express.

See Also

PurchaseOrders,


ShrClaimDefs

ShrClaimDefs Table

This table stores all the claim criteria defined by user in a serial holdings record.

Columns

Column name | Data type | Description
CopyId | int | ID of serial holdings record that the criteria are defined for.
CategoryId | tinyint | ID of category that the criteria are defined for.
OrderNumber | smallint | Execution order number of a criterion.
DaysToWait | smallint | Numbers of days to wait to execute the criterion.


SHRCopies

SHRCopies Table

this table stores all the Serial Holdings records.

Columns

Column name | Data type | Description
CopyID | int | record control ID. PK.
BibRecordID | int | record linked bibliographic record control ID. this field should not be NULL. variable control field 004. FK, references to BibliogarphicRecords(BibliographicRecordID).
CompletenessCodeH | tinyint | record's completenes status code. FK, references to MfhdCompleteness(CodeID).
CompressExpandBibH | tinyint | Note: not being used.
CompressExpandSupH | tinyint | Note: not being used.
CopyNumber | int | copy number. 852 subfield $t.
CreationDate | datetime | date of record gets created.
CreatorID | int | ID of the Polaris user who creates the record. PK, references to Polaris(PolarisUserID).
CallNoPrefix | nvarchar(60) | call number prefix. 852 $k.
ClassificationNo | nvarchar(60) | call number classification part. 852 $h
CutterNo | nvarchar(60) | call number cutter part.
DateOfReport | datetime | Note: not being used.
DestinationCollectionID | int | 852 $b. destination collection control ID. FK, references to Collections(CollectionID).
DestinationOrgID | int | 852 $a. destination organization control ID. FK, references to Organizaitons(OrganizationID).
ImportedBibCN | nvarchar(20) | imported bibliographic record control ID.
ImportedHoldingsCN | nvarchar(20) | imported Holdings record control ID.
ImportedRecordSource | nvarchar(20) | imported record source
IntentToCancel | datetime | subscription intent to cancel date.
LastTransaction | datetime | lates modification date.
ListServerAddr | nvarchar(255) | electronic access server address. usually is an URL.
MaterialTypeID | int | 852 $3. Material type. FK, references to MaterialTypes(MaterialTypeID).
MaxClaims | tinyint | maximum number of times can be claimed.
MembershipDesignation | bit | indicates whether it belongs to a membership.
MemberOrgName | nvarchar(255) | oraganization name of a membership.
MemberName | nvarchar(255) | member name of a membership.
ModifierID | int | modifier's user ID. FK, references to PolarisUsers(PolarisUserID).
NoteNonPub | nvarchar(600) | non public notes.
NoteStaff | nvarchar(600) | staff notes or warnings.
OrganizationID | int | organization ID where Holdings record gets ordered. FK, references to Organizations(OrganizationID).
OrderType | int | order type of Serial Holdings records. can be either 7 (standing order) or 8 (subcription), but can not be NULL. FK, references to OrderTypes(OrderTypeID).
PatHoldReqID | int | Note: not being used.
PlanDescr | nvarchar(200) | Holdings record's purchase order plan description.
PlanName | nvarchar(50) | Holdings record's purchase order plan name.
ShelvingSchemeID | int | 852 1st indicator. shelving scheme ID. FK, references to ShelvingSchemes(ShelvingSchemeID).
StartDate | datetime | subscription start date.
StartNumber | nvarchar(25) | subscription start number.
SubsID | int | linked subscription record control ID. FK, references to Subscriptions(SubsID).
SubscrDuration | smallint | Note: not be used.
SubscrExpDate | datetime | subscription expire date.
SubscrStatusH | smallint | Holdings record subscription status. FK, references to CopySubsStatuses(StatusID).
SupplierID | int | for a Standing Order SHR, this is its linked Supplier control ID. for a Subscription SHR, this is its linked Subscription's Supplier control ID. FK, references to Suppliers(SupplierID).
VendorTitleNumber | nvarchar(30) | vendor title number.
DisplayInPAC | bit | Indicates whether or not the linked issues/parts will be displayed in PAC.

See Also

Copy_INLISegs, Copy_POLISegs, MfhdPublicationPatterns, ShrClaimDefs,


SHRSharedPublicNotes

SHRSharedPublicNotes Table

Public note on the serial holdings record. If multiple SHR exist per location/bibliographic record, this note field is shared by all the SHRs. Each note line is stored in a separate row per Bib/Shr.

Columns

Column name | Data type | Description
OrganizationID | int | ID of SHR's destination organization ID.
BibliographicRecordID | int | ID of SHR's associated bibliographic record.
RowNumber | tinyint | Seqencial row number of per Bib/Shr.
Value | nvarchar(4000) | Each note line data content.


SIPPaymentTypes

SIPPaymentTypes Table

The SIPPaymentTypes table allows us to logically map the SIP Payment Type(See Standard Interchange Protocol Rev. 2.00, pp. 23) to Polaris Payment Methods from the PatronPaymentMethods table.

Columns

Column name | Data type | Description
PaymentTypeID | int | This is an identity column that enumerates the standard SIP payment types.
PaymentType | int | The PaymentType value is the value the SIP client will send to us to indicate how the money was received. The standard defines payment types of 0 - 4. Envisionware gave us 20 - 22 and 99.
Description | nvarchar(80) | The description column is a texual representation of the SIP standard payment types. Its more for the SIP user to describe the SIP payment type. If we get a payment with a payment type of 0 (zero) then we know it was a Cash payment.
PaymentMethodID | int | This column maps the SIP Payment types to the equivalent Polaris PatronPaymentMethods value.


SIPServicePorts

SIPServicePorts Table

This table is used to hold the TCPIP port numbers that are assigned for each organization. The table is initialized by the SIPService_Add_Ports stored procedure. The table was implemented in support of Polaris ASP.

Columns

Column name | Data type | Description
OrganizationID | int | Organizationid from the organizations table. A port number will be assigned for each organizationid. If an organization does not have a SIP client, then you do not need to specify it in this table.
TCPIPPortNumber | int | This will be the tcpip port number that SIP clients will connect to and is related to an organization id. There is one port number for every organization id that needs a SIP responder. Note that for implementations that do not have self check clients, a port and organizationid is not needed.


SiteScan_CheckDataMsgs

SiteScan_CheckDataMsgs Table

This table contains the nightly output of the Polaris Data Validation process which is a SQL Server Agent scheduled job (Data Validation) that check the database for application level inconsistencies.

Columns

Column name | Data type | Description
Message | nvarchar(254) | The text message of the error or information reported.


StatesAndProvinces

StatesAndProvinces Table

Table used to contain states and provinces used for credit card processing.

Columns

Column name | Data type | Description
StateProvinceID | int | Primary key.
Abbreviation | varchar(2) | State or province abbreviation used in dropdowns.
Description | nvarchar(50) | Full text description of state or province.
CountryID | int | Link to countries table

See Also

Donations, ILSStoreOrders,


StatisticalCodes

StatisticalCodes Table

This table contains a list of statistical codes used by organization

Columns

Column name | Data type | Description
StatisticalCodeID | int | Part of primary key (with organizationID)
OrganizationID | int | Organization which uses particular stat code
Description | nvarchar(80) | The text description of the stat code

See Also

CircItemRecords, ItemTemplates,


Subject4XX

Subject4XX Table

Provides a link between the Subject Bib headings for See References.

Columns

Column name | Data type | Description
ID4xx | int | The MainSubjectHeadingID for the Subject associated with 4XX authority tag entry.
ID1xx | int | The MainSubjectHeadingID for the Subject associated with 1XX authority tag entry. (The See heading)
AuthorityTagID | int | Link to authority tags table
DisplayCode | char | Cross Reference Display Code referencing the field CrossReferenceDisplayConstants.CrossReferenceCode


Subject5XX

Subject5XX Table

Provides a link between the Subject Bib headings for See Also References.

Columns

Column name | Data type | Description
ID5xx | int | The MainSubjectHeadingID for the Subject associated with 5XX authority tag entry. (The See Also heading)
ID1xx | int | The MainSubjectHeadingID for the Subject associated with 1XX authority tag entry.
AuthorityTagID | int | Link to authority tags table
DisplayCode | char | Cross Reference Display Code referencing the field CrossReferenceDisplayConstants.CrossReferenceCode


SubscriptionRenewalHistories

SubscriptionRenewalHistories Table

Constains the histories of subscription renewal processes.

Columns

Column name | Data type | Description
SubsID | int | Subscripiton record ID.
StaffID | int | Polaris user ID who renews the subscription.
TransactionDate | datetime | datetime when the subscription gets renewed.
NumOfCopiesRenewed | int | number of copy records get renewed.
StartDate | datetime | new start date of the subscription record after it gets renewed.
ExpireDate | datetime | new expire date of the subscription record after it gets renewed.
Price | money | unit price when subscription gets renewed.
SupplierID | int | Subscription linked Supplier record ID when it gets renewed.
SupplierName | nvarchar(50) | Subscription linked Supplier's name when it gets renewed.
Identifier | nvarchar(30) | Subscription identifier when it gets renewed.


Subscriptions

Subscriptions Table

Contains the basic data information of subscription records.

Columns

Column name | Data type | Description
SubsID | int | Subscription record ID.
BibID | int | linked Bibliographic record ID.
OwnerID | int | organization ID of subscription's owner.
Status | bit | subscription status - Cancelled or Open. Bit value.
StatusDate | datetime | datetime when subscription gets cancelled or reopened.
SupplierID | int | linked Supplier record ID.
SubscriptionTerm | int | indicates number of months subscription gets expired from the start date.
StartDate | datetime | start date of the subscription record.
ExpireDate | datetime | expire date of the subscription.
CurrentPrice | money | current unit price of the subscription.
Identifier | nvarchar(30) | Subscription identifier.
OriginalDate | datetime | subscription original date.
AutoRenewal | bit | Indicate whether or not the subscription record can be renewed automatically. Bit value.
PaymentMethodID | int | payment method ID. refers to PaymentMethods.PaymentMethodID.
FundID | int | linked Fund ID.
RenewInstruction | nvarchar(255) | renew instruction note.
Note | nvarchar(255) | subscription note.
CreatorID | int | Polaris user ID who creates the subscription record.
CreationDate | datetime | datetime when subscription gets created.
ModifierID | int | This is the ID of the Polaris user who last modified the record.
LastTransaction | datetime | latest datetime when subscription gets modified.

See Also

Rpt_SubsCancelNotices, SHRCopies, SubscriptionRenewalHistories,


Suppliers

Suppliers Table

This table contains the ordering, payment, and claiming data associated with suppliers that the library deals with such as addresses and contact information.

Columns

Column name | Data type | Description
SupplierID | int | Polaris assigned unique id for each supplier.
ClaimCPID | int | Claiming contact person id, contains the unique id from the ContactPersons table where the claiming contact person data is stored.
ClaimAddrID | int | Claiming address id, contains the unique id from the Addresses table where the claiming address data is stored.
CreationDate | datetime | The date the supplier record was created.
CreatorID | int | The UserID for the user who created this Supplier.
DataFormatsAccepted | nvarchar(10) | Stores the electronic data formats that the Supplier will accept.
DefJobber | nvarchar(12) | Indicates whether the Supplier is the jobber from which all items purchases are automatically ordered.
ElecCommFlag | bit | Indicates whether the Supplier accepts BISAC/EDI ordering.
EncLimPerItem | money | Indicates the maximum amount that can be encumbered per line item for this Supplier.
EncLimPerOrder | money | Indicates the maximum amount that can be encumbered per order for this Supplier.
EncLimTotEnc | money | Indicates the maximum amount that can be encumbered for this Supplier.
ExchangePartner | bit | A flag which indicates whether the Supplier is actually a exchange partner for the Organization.
ExpLimPerItem | money | Indicates the maximum amount that can be expended per line item to this Supplier.
ExpLimPerOrder | money | Indicates the maximum amount that can be expended per order to this Supplier.
ExpLimTotExp | money | Indicates the maximum amount that can be expended to this Supplier.
LBAcctNumber | nvarchar(50) | The account number used by the Organization when dealing with the Supplier.
ModifierID | int | The UserID for the user who last modified this Supplier.
OrderingCPID | int | Ordering contact person id, contains the unique id from the ContactPersons table where the ordering contact person data is stored.
OrderingAddrID | int | Ordering address id, contains the unique id from the Addresses table where the ordering address data is stored.
PaymentCPID | int | Payment contact person id, contains the unique id from the ContactPersons table where the payment contact person data is stored.
PaymentAddrID | int | Payment address id, contains the unique id from the Addresses table where the payment address data is stored.
RecordName | nvarchar(50) | A secondary name used to reference the Supplier.
Rounding | smallint | A flag which indicates whether the Supplier rounds up or down to the nearest penny.
SupplierName | nvarchar(50) | The main name used to reference the current Supplier.
SupplierSAN | nvarchar(7) | Stores the main part of the Supplier SAN.
SupplierSANSuf | nvarchar(5) | Stores the suffix part of the Supplier SAN.
SupplierSANPre | varchar(2) | Stores the prefix part of the Supplier SAN.
TotCurrEnc | money | The total money currently encumbered for this Supplier.
TotExp | money | The total money expended to this Supplier.
OrganizationID | int | Contains the unique id from the Organizations table for the organization that owns this Supplier record.
Note | nvarchar(400) | Stores a Supplier specific note.
LastTransaction | datetime | Date this supplier record was last modified.
MaxClaims | int | maximum number of claims specified for a particular supplier. System maimum is 5.
ClmWtPer1 | int | default data for claim waiting period one that is copied to linked PO's. null unless max number of claims is used.
ClmWtPer2 | int | default data for claim waiting period two that is copied to linked PO's. should be null unless waiting periods is used.
ClmWtPer3 | int | default data for claim waiting period three that is copied to linked PO's. should be null unless waiting periods 1 and 2 are used.
ClmWtPer4 | int | default data for claim waiting period four that is copied to linked PO's. should be null unless waiting periods 1-3 are used.
ClmWtPer5 | int | default data for claim waiting period five that is copied to linked PO's. should be null unless waiting periods 1-4 are used.
ClmNoticeInd | bit | bit flag copied to linked POs/POLIs that tells user and system that a claim notice should be generated when the item is claimed.
CanNoticeInd | bit | default flag to determine if linked purchase order lines should have cancellation notices generated during overnight cancellation processing. Copy to PO's when linked to supplier record.
AutoCancelInd | bit | default flag to determine if linked purchase orders and purchase order lines should be included in overnight cancellation processing. Copy to PO's when linked to supplier record.
CanWtPer | int | default number of days after last claim that linked POLI's should be cancelled during overnight cancellation processing. Copy to PO's when linked to supplier record.
DiscRate | money | default discount rate for supplier. copied to linked PO's
PlanNote | nvarchar(400) | free text note for supplier records that are used for specific 'plans'.
DeliveryOptionId | int | Indicates the notification method will be used to send the claiming notice. Foreign key references DeliveryOptions(DeliveryOptionID).
CurrencyID | int | Foreign key linked to the Currencies table.
ExternalID | nvarchar(30) | External ID to map a supplier represented in a 3rd-party financial system to a Polaris supplier. This field was added to facilitate integration between Polaris Acquisitions and 3rd-party financial systems.

See Also

Claims, ElectronicCommunications, Invoices, MRMS_CopyrightTypes, PurchaseOrders, SelListLines, SHRCopies, SubscriptionRenewalHistories, Subscriptions,


SupplierStaticData

SupplierStaticData Table

Supplier data that is constant for a given Supplier SAN. It should not be changed by Polaris customers.

Columns

Column name | Data type | Description
SAN | nchar | CHAR(7) - PK. Supplier SAN
Name | nvarchar(50) | VARCHAR(50) - Name of supplier linked to the SAN
MaxPONumSize | int | INT - The maximum PO Number sized allowed by the specific vendor.
VendorName | nvarchar(50) | Display name of the EDI vendor that appears on the report or log file.
LogFileNameSuffix | nvarchar(50) | EDI vendor exported log file suffix.


SuspectedDuplicateCharges

SuspectedDuplicateCharges Table

Table of patron account charges that are suspected duplicates by the system SQL job (will not appear in regular patron account).

Columns

Column name | Data type | Description
TxnID | int | Same as PatronAccount field
DuplicateTxnID | int | The patron account transaction this is a suspected duplicate of
PatronID | int | Same as PatronAccount field
TxnCodeID | int | Same as PatronAccount field
FeeReasonCodeID | int | Same as PatronAccount field
TxnAmount | money | Same as PatronAccount field
OutstandingAmount | money | Same as PatronAccount field
ItemRecordID | int | Same as PatronAccount field
TxnDate | datetime | Same as PatronAccount field
PaymentMethodID | int | Same as PatronAccount field
OrganizationID | int | Same as PatronAccount field
WorkstationID | int | Same as PatronAccount field
CreatorID | int | Same as PatronAccount field
CheckoutDate | datetime | Same as PatronAccount field
DueDate | datetime | Same as PatronAccount field
FreeTextNote | nvarchar(255) | Same as PatronAccount field
InsertionDate | datetime | Date the SQL job found the suspected duplicate
Processed | bit | Has the SQL jbo processed this entry?


Synonyms

Synonyms Table

Contains one row for each term/related-term pair.

Columns

Column name | Data type | Description
Term | nvarchar(128) | Identifies the base term.
RelatedTerm | nvarchar(128) | Identifies the related term.
Likelihood | float | A floating point number between 0 and 1 that represents the likelihood the Term is related to the RelatedTerm.


SysHoldHistory

SysHoldHistory Table

This table has information about certain status changes for hold requests.

Columns

Column name | Data type | Description
SysHoldRequestID | int | Hold request ID.
SysHoldStatusID | int | Status of the hold request.
StatusTransitionDate | datetime | Date when the status transition occured.
CreatorID | int | User who caused the status change to happen.
ItemRecordID | int | Item record ID associated with entry in history table (for statuses when a specific item is applicable).
ActionTakenID | int | The action taken on the request
OrganizationID | int | organization
WorkstationID | int | workstation
SysHoldHistoryID | int | primary key


SysHoldHistoryActions

SysHoldHistoryActions Table

This table holds a coded list of actions taken on a hold request throughout it's life cycle.

Columns

Column name | Data type | Description
ActionTakenID | int | Primary key field
ActionTakenDesc | nvarchar(255) | The description of the action

See Also

SysHoldHistory, SysHoldHistoryDaily,


SysHoldHistoryDaily

SysHoldHistoryDaily Table

This table has information about certain status changes for hold requests (written to in real time and moved to a permanent table overnight).

Columns

Column name | Data type | Description
SysHoldHistoryID | int | Primary key
SysHoldRequestID | int | request ID
SysHoldStatusID | int | hold status
StatusTransitionDate | datetime | Date of action
CreatorID | int | Polaris user ID
ItemRecordID | int | Associated item
ActionTakenID | int | Hold action taken
OrganizationID | int | Organization
WorkstationID | int | workstation


SysHoldItemRecordRTFPrimaryCycles

SysHoldItemRecordRTFPrimaryCycles Table

Represents the item records currently in the current primary cycle for a given hold request.

Columns

Column name | Data type | Description
SysHoldRequestID | int | SysHoldRequestID
ItemRecordID | int | ItemRecordID
RTFCycleCreationDate | datetime | Date this item was added to the cycle (not the same as the begin date)
RTFCycleBeginDate | datetime | Date this item began this cycle
RTFCycleEndDate | datetime | Date this item ended this cycle
RTFCycleOpenDaysCount | int | Number of days the branch has been open during the cycle
RTFCycleExtendedForSingleItem | bit | A flag to say if this is the only item in the cycle
RTFRouteEndedByAskMeLater | bit | A flag to say that the user moved the item out of the cycle manually
RTFCycleCompleted | bit | Indicates that the cycle is complete


SysHoldItemRecordRTFPrimaryCyclesHistory

SysHoldItemRecordRTFPrimaryCyclesHistory Table

Represents the item records in previous primary cycles for a given hold request.

Columns

Column name | Data type | Description
SysHoldRequestID | int | SysHoldRequestID
ItemRecordID | int | ItemRecordID
RTFCycleCreationDate | datetime | Date this item was added to the cycle (not the same as the begin date)
RTFCycleBeginDate | datetime | Date this item began this cycle
RTFCycleEndDate | datetime | Date this item ended this cycle
RTFCycleOpenDaysCount | int | Number of days the branch has been open during the cycle
RTFCycleExtendedForSingleItem | bit | A flag to say if this is the only item in the cycle
RTFRouteEndedByAskMeLater | bit | A flag to say that the user moved the item out of the cycle manually
RTFCycleCompleted | bit | Indicates that the cycle is complete


SysHoldItemRecordRTFSecondaryCycles

SysHoldItemRecordRTFSecondaryCycles Table

Represents the item records currently in the current secondary cycle for a given hold request.

Columns

Column name | Data type | Description
SysHoldRequestID | int | SysHoldRequestID
ItemRecordID | int | ItemRecordID
RTFCycleCreationDate | datetime | Date this item was added to the cycle (not the same as the begin date)
RTFCycleBeginDate | datetime | Date this item began this cycle
RTFCycleEndDate | datetime | Date this item ended this cycle
RTFCycleOpenDaysCount | int | Number of days the branch has been open during the cycle
RTFCycleExtendedForSingleItem | bit | A flag to say if this is the only item in the cycle
RTFRouteEndedByAskMeLater | bit | A flag to say that the user moved the item out of the cycle manually
RTFCycleCompleted | bit | Indicates that the cycle is complete


SysHoldItemRecordRTFSecondaryCyclesHistory

SysHoldItemRecordRTFSecondaryCyclesHistory Table

Represents the item records in previous secondary cycles for a given hold request.

Columns

Column name | Data type | Description
SysHoldRequestID | int | SysHoldRequestID
ItemRecordID | int | ItemRecordID
RTFCycleCreationDate | datetime | Date this item was added to the cycle (not the same as the begin date)
RTFCycleBeginDate | datetime | Date this item began this cycle
RTFCycleEndDate | datetime | Date this item ended this cycle
RTFCycleOpenDaysCount | int | Number of days the branch has been open during the cycle
RTFCycleExtendedForSingleItem | bit | A flag to say if this is the only item in the cycle
RTFRouteEndedByAskMeLater | bit | A flag to say that the user moved the item out of the cycle manually
RTFCycleCompleted | bit | Indicates that the cycle is complete


SysHoldItemRecordsRTFAvailable

SysHoldItemRecordsRTFAvailable Table

This table says for a given request, which items are available for RTF (and which items have been denied)

Columns

Column name | Data type | Description
SysHoldRequestID | int | SysHoldRequestID
ItemRecordID | int | ItemRecordID
DeniedByPolarisUser | bit | This item was denied by the user
DeniedBySystem | bit | This item was denied by the system (material type limits)
DeniedReasonID | int | Reason for denial
DeniedDate | datetime | Date the item was denied for the request
DeniedBySystemOverrideDate | datetime | FUTURE - a date to say when a system denial was overturned


SysHoldReasonCodes

SysHoldReasonCodes Table

This table contains a record for each reason a hold request may not be filled.

Columns

Column name | Data type | Description
SysHoldReasonCodeID | int | Primary Key unique identifier for this table.
Description | nvarchar(100) | Describes the reason why a hold request is not filled

See Also

SysHoldRequests,


SysHoldRequestGroups

SysHoldRequestGroups Table

This table will have information about requests which have been grouped.

Columns

Column name | Data type | Description
GroupID | int | ID of the group.
SysHoldRequestID | int | Hold request ID for each request in a particular group.


SysHoldRequests

SysHoldRequests Table

This table contains one row for each hold request placed within the system.

Columns

Column name | Data type | Description
SysHoldRequestID | int | Identifies the hold request. The SysHoldRequestID is the primary key and has the identity property.
Sequence | int | Position of the hold request in the hold queue. The Sequence column is handled automatically and should never be set directly. Upon placing a new request, the sequence value is set by the SysHoldRequests_INS trigger. The sequence value can be modified by calling the Circ_UpdateHoldQueue stored procedure.
PatronID | int | Patron for which the hold request was placed. Required.
PickupBranchID | int | Branch at which the item is to be picked up. Required.
SysHoldStatusID | int | Status of the hold request. The SysHoldStatusID column is handled automatically and should never be set directly.
RTFCyclesPrimary | int | Number of times this hold request has cycled through requests to fill primary cycle. The RTFCycles column is handled automatically and should never be set directly.
CreationDate | datetime | Date the hold request was placed. This value is handled automatically and should never be set directly.
ActivationDate | datetime | Date the hold request is activated (system does not attempt to satisfy request until after specified date has been reached). Optional. If not specified, default is the ActivationDate.
ExpirationDate | datetime | Date the hold request expires
LastStatusTransitionDate | datetime | Date of last status transition. This value is handled automatically and should never be set directly.
LCCN | nvarchar(40) | LC call number of requested item. See also BibliographicRecords table. Optional, can be NULL.
PublicationYear | smallint | Publication year of requested item. See also BibliographicRecords table. Optional, can be NULL.
ISBN | nvarchar(50) | ISBN of requested item. See also BibliographicTag020Index table. Optional, can be NULL.
ISSN | nvarchar(50) | ISSN of requested item. See also BibliographicTag022Index table. Optional, can be NULL.
ItemBarcode | nvarchar(20) | Barcode of requested item. See also CircItemRecords table. Optional, can be NULL.
BibliographicRecordID | int | Bibliographic record for which the hold request was orignally placed. Optional. If specified, the bibliographic information included in the hold request (such as Author, Title, PublicationYear) should match the columns associated with the bibliographic record. See also Circ_CreateHoldRequest stored procedure. Specifying a bibliographic record identifier causes the hold request to bind to the specified bibliographic record immediately.
TrappingItemRecordID | int | Item currently associated with hold request. The ItemRecordID column is handled automatically and should never be set directly.
StaffDisplayNotes | nvarchar(255) | Contains notes entered by staff
NonPublicNotes | nvarchar(255) | Contains notes entered by staff
PatronNotes | nvarchar(255) | Contains notes entered by patron
MessageID | uniqueidentifier | When a hold request is created via PAC, this value denotes the unique identifier of the request.
HoldTillDate | datetime | Number of days an item would be held for a patron.
Origin | smallint | Denotes who placed the hold request. 0 - System - future : Outreach services 1 - Patron - from PAC. 2 - Library - TechClient. 3 - System - initiated from SIP/NCIP/INN-Reach
Series | nvarchar(255) | The series requested.
Pages | nvarchar(255) | Number of pages from the article requested.
CreatorID | int | The UserID of the person who created the hold request.
ModifierID | int | The UserID of the person who modified the hold request.
ModificationDate | datetime | Date when the hold request was last modified.
Publisher | nvarchar(40) | Publisher of the item requested.
Edition | nvarchar(10) | Edition of the item requested.
VolumeNumber | nvarchar(60) | Denotes which volume is required - taken from the VolumeNumber field in the item record. Used in duplicate detection.
HoldNotificationDate | datetime | Denotes the date when a notice for this request was sent.
DeliveryOptionID | int | Denotes how the hold notice was delivered
Suspended | bit | Flag to indicate if the hold request has been suspended
UnlockedRequest | bit | a flag that says the user entered the "bib" data by hand, without linking directly.
RTFCyclesSecondary | int | Number of times this hold request has cycled through requests to fill secondary cycle. The RTFCycles column is handled automatically and should never be set directly.
PrimarySecondaryFlag | tinyint | Is a flag stating which RTF cycle a request is currently in.
PrimaryRandomStartSequence | int | Is the branch sequence number we start with when RTF is randomized for the primary cycle.
SecondaryRandomStartSequence | int | Is the branch sequence number we start with when RTF is randomized for the secondary cycle.
PrimaryMARCTOMID | tinyint | Marc type of Material ID
ISBNNormalized | nvarchar(50) | Normalized version of the ISBN data
ISSNNormalized | nvarchar(50) | Normalized version of the ISSN
Designation | nvarchar(780) | Issue designation for hold request
ItemLevelHold | bit | Flag for item level hold
ItemLevelHoldItemRecordID | int | Item record ID associated with item level hold
BorrowByMailRequest | bit | Flag to tell user is this to be mailed
PACDisplayNotes | nvarchar(255) | display notes for PAC for request
TrackingInfo | nvarchar(100) | free text tracking info field (for mailing)
HoldNotification2ndDate | datetime | Denotes the date when a second notice for this request was sent.
ConstituentBibRecordID | int | If the hold is related to a bound with constituent record, that constituent record ID is here
PrimaryRTFBeginDate | datetime | Date primary RTF cycles begin
PrimaryRTFEndDate | datetime | Date primary RTF cycles end
SecondaryRTFBeginDate | datetime | Date secondary RTF cycles begin
SecondaryRTFEndDate | datetime | Date secondary RTF cycles end
NotSuppliedReasonCodeID | int | If the hold is not supplied, this links to the reason why
NewPickupBranchID | int | ID of the branch the pickup location has been changed to. This field is only populated if the hold status was held at the time of the change.

See Also

InnReachRequests, SysHoldHistory, SysHoldHistoryDaily, SysHoldItemRecordRTFPrimaryCycles, SysHoldItemRecordRTFSecondaryCycles, SysHoldItemRecordsRTFAvailable, SysHoldRequestGroups, SysHoldRequestSearchTerms,


SysHoldRequestSearchTerms

SysHoldRequestSearchTerms Table

Bib author/title associated with a hold request.

Columns

Column name | Data type | Description
SysHoldRequestID | int | SysHoldRequestID
IsConstituent | bit | Does this value represent the bib record or the constituent bib record?
BrowseTitle | nvarchar(255) | Display title
BrowseTitleNonFilingCount | tinyint | Non filing indicator value
SortTitle | nvarchar(255) | normalized title
BrowseAuthor | nvarchar(255) | Display author
SortAuthor | nvarchar(255) | normalized author


SysHoldRoutingSequences

SysHoldRoutingSequences Table

This table contains the routing sequence by which a hold request is forwarded to various branches.

Columns

Column name | Data type | Description
RequesterBranchID | int | Branch requesting an item (the pickup branch)
ResponderBranchID | int | Branch requested to fill a hold request (the branch assigned to an item that can fill a hold request)
Sequence | int | Order in which a requester branch asks responders to fill a hold request (the Sequence is associated with the ResponderBranchID and is relative to the RequesterBranchID)
MaxDaysInRTF | int | Number of days to wait before the requester branch asks for an item from the responder branch (the responder will not fill a hold request until the current date minus the activation date is greater than or equal to the number of days to wait). A NULL value indicates that the responder branch does not fill hold requests from the requester branch.
PrimarySecondaryFlag | tinyint | Flag to say if this is the primary or secondary sequence


SysHoldStatuses

SysHoldStatuses Table

This table contains a record for each valid hold status.

Columns

Column name | Data type | Description
SysHoldStatusID | int | Identifies the hold status. Primary Key unique identifier.
Description | nvarchar(80) | Describes the hold status.
Name | nvarchar(25) | Name of the hold status

See Also

SysHoldHistory, SysHoldRequests,


SysHoldTaskHistory

SysHoldTaskHistory Table

This table contains a record for each holds-related task.

Columns

Column name | Data type | Description
TaskName | nvarchar(31) | Name of a holds-related task.
LastRunDate | datetime | Last completion date of a task.
PercentDone | real | Progress of a currently running task.


TargetAudiences

TargetAudiences Table

Defines diffent target audiences that could be assigned to library materials.

Columns

Column name | Data type | Description
Code | char | One-letter code.
Description | nvarchar(30) | Full description.


TaskResults

TaskResults Table

This table stores the final results of jobs processed by the Polaris.Jobs service

Columns

Column name | Data type | Description
TaskResultID | int | Unique identifier for the result
Description | nvarchar(80) | Description of the result

See Also

Job_PurchaseOrders,


TaskRunDates

TaskRunDates Table

This table can be used to record the last run date of SQL jobs.

Columns

Column name | Data type | Description
TaskID | int | ID of the task.
TaskName | nvarchar(50) | Name of the task.
LastRunDate | datetime | The last date when the SQL job was run.


Telephony_HangUpTypes

Telephony_HangUpTypes Table

This table stores the list of valid hangup detection types used in inbound and outbound telephony to configure the Dialogic API.

Columns

Column name | Data type | Description
HangUpTypeID | int | Primary key.
Description | nvarchar(30) | Brief description of hangup detection type.


Telephony_HelloEdges

Telephony_HelloEdges Table

Used by inbound and outbound phone services. Contains data used to configure Dialogic API. The "hello" edge is the point at which a connect will be returned to the application, either the rising edge (immediately when a connect is detected) or the falling edge (after the end of the salutation).

Columns

Column name | Data type | Description
HelloEdgeID | int | Primary key.
Description | nvarchar(20) | Brief description of the hello edge type.


Telephony_ServerBranchMapping

Telephony_ServerBranchMapping Table

This table represents the sets of branch organizations that are served by a given telephony server. For single-telephony-server sites there is only a single mapping (all branches mapped to the one server) but for sites with multiple telephony servers the table can now be configured from the SA UI to assign branches to the appropriate telephony server.

Columns

Column name | Data type | Description
ServerID | int | Foreign key on the Severs table. This represents the telephony server that the OrganizationID maps to.
OrganizationID | int | Foreign key on the Organizations table. This represents the branch portion of the mapping.


TextualHoldings

TextualHoldings Table

this table stores the textual holdings information of all publication pattern records (866/7/8).

Columns

Column name | Data type | Description
TextualHoldingsID | int | Polaris assigned unique ID number for the textual holding record (PK).
EncodLevelH | nvarchar(10) | Indicates the holdings level of textual holdings Indicator Level blank, 3, 4 or 5 (which is 4 + part designation). Refer to holdings record leader 86X 1st indicator.
TypeNotationH | smallint | Indicates whether the textual holdings conforms to any of the ANSI standards for holdings display. z39.44 or z39.57 -->z39.71. Indicator 1 z39.42 -->Indicator 2 Essentially, we don't think this is useful for Polaris created records, however, as with many of these fields, they may be critical upon implementation of holdings record import functionality.
TextualHoldings | nvarchar(1500) | 866/7/8 $a. Textual description which MAY include the captions and enumeration and chronology for the holdings of the bibiographic item in the collections of the reporting organization. Refers to 866-868 fields (basic bib, supplement and index)of the holdings record. E.g. 1937-1968, plus 1969-1978 cumulative vol.
NoteNonPub | nvarchar(200) | Subfield 866/7/8 subfield $x (where user can enter non public note relating to the textual holding. E.g. Incomplete volumes unbound).
NotePub | nvarchar(200) | Subfield 86/7/8 subfield $z (where user can enter public note which should display in the PAc relating to the textual holding. E.g. Some issues missing).
PubPatternID | int | linked publication pattern ID. FK, references to MfhdPublicationPatterns(PubPatternID).


TextualHoldingsNotes

TextualHoldingsNotes Table

This table contains the summarized textual holdings and SHR level public notes for each Bib title, location and collection combination. All the entries in this table are maintained by the delete, update and insert triggers on TextualHoldings and SHRCopies tables.

Columns

Column name | Data type | Description
BibliographicRecordID | int | Serial holdings record's Bibliographic record control ID. FK, references to BibliographicRecords(BibliographicRecordID).
OrganizationID | int | Serial holdings record's destination organization control ID. FK, references to OrganizationsCollections(OrganizationID).
CollectionID | int | Serial holdings record's destination collection control ID. FK, references to OrganizationsCollections(CollectionID).
Notes | nvarchar(-1) | Summary of all textual holdings data and all SHR public notes belong to this Bib title, location and collection combination.


Themes

Themes Table

This table holds all Themes for the Children's PAC that are defined through System Administration.

Columns

Column name | Data type | Description
ThemeID | int | Unique identifier (primary key)
DisplayName | nvarchar(255) | The name of the theme, used to identify it in System Administration.
CursorTypeID | int | The type of mouse cursor associated with a theme (foreign key of CursorTypes)
DefaultImagePath | nvarchar(255) | A file directory in which to look for graphical images/icons that will be displayed on the Children's PAC next to a Category Name
Core | bit | Whether this theme is a "core" theme or not. Core themes are read-only, and must be copied to a new theme in order to edit them.

See Also

ThemesAssigned, ThemeWebFilesAssignment,


ThemesAssigned

ThemesAssigned Table

Defines a subset of themes for a particular organization eligible for displaying on the Children's PAC interface

Columns

Column name | Data type | Description
OrganizationID | int | Organization designation (foreign key on Organizations table)
ThemeID | int | Theme designation (foreign key on Themes table)


ThemeWebFiles

ThemeWebFiles Table

This table holds the various web files that can be associated with a Children's PAC theme.

Columns

Column name | Data type | Description
ThemeWebFileID | int | Unique identifier (primary key)
Description | nvarchar(255) | The description of the theme web file

See Also

ThemeWebFilesAssignment,


ThemeWebFilesAssignment

ThemeWebFilesAssignment Table

This file holds the values given to theme web files for a particular Children's PAC theme

Columns

Column name | Data type | Description
ThemeID | int | The theme the assignment represents (foreign key of Themes)
ThemeWebFileID | int | The particular web file being defined in the assignment (foreign key of ThemeWebFiles)
FileName | nvarchar(255) | The value that is assigned to the particular Theme and Web File combination


ThirdPartyAPIFailures

ThirdPartyAPIFailures Table

A table to track failed calls to third party API's. This table tracks calls associated with PowerPAC, the APIConsumer Service, MobilePAC, and the staff client. This table is "owned" by the polaris application. This table is to allow polaris support and research and development investigate API failures.

Columns

Column name | Data type | Description
ThirdPartyApiFaliureID | int | A unique ID (system assigned)
VendorID | int | A FK reference to the vendors table. The third party vendor throwing the failure.
VendorAccountID | int | A FK Refernce to the vendorAccounts table. The vendor account settings being used when the failure occured.
FalureDate | datetime | The date and time of the failed API call.
Exception | nvarchar(4000) | The exception that was thrown during the call (if any)
HTTPErrorCode | int | The HTTP error code thrown by the failed call (if any)
ThirdPartyAPIMethodID | int | A FK reference to the ThirPartyAPIMethods table. The API method that threw the error.
ProductID | int | A FK reference to the products table. The polaris product that threw the call (PowerPAC, MobilePAc, etc...)
HttpRequest | nvarchar(4000) | The HTTP request that resulted in failure.


ThirdPartyApiMethods

ThirdPartyApiMethods Table

A list of third party API methods being called by various Polaris applications. This table is "owned" by the polaris application, users are now allowed to insert data into this table.

Columns

Column name | Data type | Description
ThirdPartyAPIMethodID | int | A unique ID for the method (system assigned)
ThirdPartyAPIMethodDescription | nvarchar(255) | A description of the method.
VendorID | int | The Vendor that supports the method.

See Also

ThirdPartyAPIFailures,


TimeUnits

TimeUnits Table

Coded list of time unit values

Columns

Column name | Data type | Description
TimeUnitID | tinyint | Primary key - code
Description | nvarchar(32) | Text description

See Also

LoanPeriods,


TitleRatings

TitleRatings Table

A table to hold Patron Title ratings.

Columns

Column name | Data type | Description
TitleRatingID | int | A unique ID for the title rating.
PatronID | int | The Patron who rated the title. Can be NULL if the patron has been deleted.
BibliographicRecordID | int | The bib record ID of the rating.
Rating | int | The rating assigned to the title. Valid values are from 0 - 5. 0 indicates tha patron has refused to rate the title.
DateRated | datetime | The date of the rating.
ORS | bit | Indicates if the rating originated from outreach services.
BrowseAuthor | nvarchar(255) | The browse author. Populated only if the bib has been deleted from the system.
BrowseTitle | nvarchar(255) | The browse title. Poluated only of the bib has been deleted.

See Also

PatronReadingHistory,


TitlesToGoTags

TitlesToGoTags Table

This table is used by the "Titles To Go" web services component. It contains the XML tags used by each vendor to provide Bib, availability and pricing data from their respective web services.

Columns

Column name | Data type | Description
SAN | nvarchar(7) | Contains the vendor SAN so we know what tags are associated with what vendor.
Author | nvarchar(50) | Contains the tag specifying 'Author' data.
Availability | nvarchar(50) | Contains the tag specifying 'Availability' data.
DiscPrice | nvarchar(50) | Contains the tag specifying 'Discount Price' data.
DiscRate | nvarchar(50) | Contains the tag specifying 'Discount Rate' data.
ListPrice | nvarchar(50) | Contains the tag specifying 'List Price' data.
Title | nvarchar(50) | Contains the tag specifying 'Title' data.
Publisher | nvarchar(50) | Contains the tag specifying the name of the publisher.
PubDate | nvarchar(50) | Contains the tag specifying 'Date of Publication' data.
Edition | nvarchar(50) | Contains the tag specifying 'Edition' data.
BookBinding | nvarchar(50) | Contains the tag specifying 'Binding' data.
Error | nvarchar(50) | Contains the tag specifying 'Error' data returned from the vendor web service.


TmpACQEXCHXMLData

TmpACQEXCHXMLData Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
XmlOrd | int | Reserved. For internal use only.
DataChr | nvarchar(-1) | Reserved. For internal use only.
Typ | int | Reserved. For internal use only.
PurchaseOrderID | int | Reserved. For internal use only.
POLineItemID | int | Reserved. For internal use only.


tmpCollectionSubmission

tmpCollectionSubmission Table

This table is used for intermediate calculation for creating submission reports for collection agency reporting.

Columns

Column name | Data type | Description
OrgID | int | ID of the organization.
PatronID | int | ID of patron under consideration.
ItemRelatedCharges | money | The charges that are related to items belonging to the organization submitting the report.
NonItemRelatedCharges | money | The charges that are not related to items but were created by the organization submitting the report.
Credit | money | The credit that the patron has.
TotalOutstandingCharges | money | Total amount that the patron owes to the organization.
ItemRelatedReplCharges | money | The replacement charges that are related to items belonging to the organization submitting the report.
NonItemRelatedReplCharges | money | The replacement charges that are currently not related to items but were created by the organization submitting the report.
ItemRelatedOVDCharges | money | The overdue charges that are related to items belonging to the organization submitting the report.
NonItemRelatedOVDCharges | money | The overdue charges that are currently not related to items but were created by the organization submitting the report.
ItemRelatedOtherCharges | money | The charges that are related to items belonging to the organization submitting the report. The charges included are those other than replacement and overdue charges.
NonItemRelatedOtherCharges | money | Charges other than the replacement and overdue charges that are not related to items but were created by the organization submitting the report.
CollectionAgencyCharge | money | Collection agency charge added to the patron's account.
TotalReplCharges | money | Sum of NonItem and ItemRelated replacement charges.
TotalOVDCharges | money | Sum of NonItem and ItemRelated overdue charges.
TotalOtherCharges | money | Sum of NonItem and ItemRelated other charges.
TotalReportingOrgCharges | money | Total money that the patron owes the reporting organization.
ItemRelatedProcFee | money | The processing fee charges that are related to items belonging to the organization submitting the report.
NonItemRelatedProcFee | money | The processing fee charges that are currently not related to items but were created by the organization submitting the report.
TotalProcFee | money | Sum of item and non-item related processing fee charges.


tmpCollectionUpdate

tmpCollectionUpdate Table

This table is used for intermediate calculation for creating update reports for collection agency reporting.

Columns

Column name | Data type | Description
OrgID | int | ID of the organization.
PatronID | int | ID of patron under consideration.
ItemRelatedCharges | money | The charges that are related to items belonging to the organization submitting the report.
NonItemRelatedCharges | money | The charges that are not related to items but were created by the organization submitting the report.
TotalReportingOrgCharges | money | Total amount that the patron owes to the organization.
ReportingOrgItemRelatedNewCharges | money | The total charges that were added to the patron's account since the last report that included this patron. This is the sum which the patron owes the organization for item related charges.
ReportingOrgNonItemRelatedNewCharges | money | The total charges that were added to the patron's account since the last report that included this patron. This is the sum which the patron owes the organization for non-item related charges.
TotalReportingOrgNewCharges | money | The total charges that were added to the patron's account since the last report that included this patron.
ItemRelatedWaivedCharges | money | The charges which were waived that are related to items belonging to the organization submitting the report.
NonItemRelatedWaivedCharges | money | The charges which were waived that are currently not related to items but were created at the organization submitting the report.
ItemRelatedPaidReplCharges | money | The replacement cost charges which were paid that are related to items belonging to the organization submitting the report.
NonItemRelatedPaidReplCharges | money | The replacement cost charges which were paid that are currently not related to items but were created at the organization submitting the report.
ItemRelatedPaidOtherCharges | money | The charges which were paid that are related to items belonging to the organization submitting the report. This only includes payments which were not for replacement cost.
NonItemRelatedPaidOtherCharges | money | The charges that are not related to items but were created by the organization submitting the report. This only includes payments other than those for replacement cost charges.
TotalWaivedCharges | money | Sum of ItemRelated and NonItemRelated waived and waivedExisting charges.
TotalPaidReplCharges | money | Sum of ItemRelated and NonItemRelated Paid Replacement charges.
TotalPaidOtherCharges | money | Sum of ItemRelated and NonItemRelated PaidOther charges.
NonItemRelatedWaivedExCharges | money | The charges which were waived that are currently not related to items but were created at the organization submitting the report.
ItemRelatedWaivedReplCharges | money | The replacement charges which were waived that are related to items belonging to the organization submitting the report.
NonItemRelatedWaivedReplCharges | money | The replacement charges which were waived that are currently not related to items but were created at the organization submitting the report.
TotalWaivedReplCharges | money | Sum of ItemRelated and NonItemRelated waived replacement charges.
ItemRelatedWaivedOtherCharges | money | The non-replacement charges which were waived that are related to items belonging to the organization submitting the report.
NonItemRelatedWaivedOtherCharges | money | The non-replacement charges which were waived that are currently not related to items but were created at the organization submitting the report.
TotalWaivedOtherCharges | money | Sum of ItemRelated and NonItemRelated waived other charges.


TypeOfPAC

TypeOfPAC Table

This table enumerates the different type of PAC applications (ActivePAC, PowerPAC, Children's PAC)

Columns

Column name | Data type | Description
TypeID | int | Unique identifier (Primary Key)
Description | nvarchar(30) | String description of the particular PAC application

See Also

WebPages,


UDFOptionDefs

UDFOptionDefs Table

This stable stores all UDF options picked and ordered by different organizations for each drop-menu UDF. The contents in this table are maintained via Patron Services SA Profile 'Patron registration user defined fields' at system, library and branch level. The option selections are organization and UDF specific.

Columns

Column name | Data type | Description
OrgID | int | ID of Organization to which the selection is belong.
UDFOptionID | int | OptionID defined in UDFOptions table. This column has FK constraint references to UDFOptions(UDFOptionID).
AttrID | int | AttrID of User defined field for which the option is selected. The AttrID is defined in AdminAttributes table and its value is between 57 and 61.
DisplayOrder | int | Display order of each selected options.


UDFOptions

UDFOptions Table

This table stores options defined for all UDF fields that are defined as drop-menu type. All the contents in this table are maintained via Patron Service SA Profile 'Patron registration user defined fields' at system level. The options are UDF specific.

Columns

Column name | Data type | Description
UDFOptionID | int | ID of each option.
AttrID | int | AttrID of User defined field for which the option is defined. The AttrID is defined in AdminAttributes table and its value is between 57 and 61.
OptionDesc | nvarchar(64) | Description of each option.

See Also

UDFOptionDefs,


UnauthorizedBibHeadings

UnauthorizedBibHeadings Table

A table which lists all of the bib authority control tags which do not have a 1xx link (by tag numbers that can be authorized).

Columns

Column name | Data type | Description
BibliographicRecordID | int | Bib record ID where tag exists
BibliographicTagID | int | Bib tag ID
Heading | nvarchar(255) | the normalized heading


UnauthorizedSeeAlsoHeadings

UnauthorizedSeeAlsoHeadings Table

A table which lists all of the authority 5xx tags which do not have a 1xx link

Columns

Column name | Data type | Description
AuthorityRecordID | int | authority record ID of the 5xx tag
AuthorityTagID | int | authority tag ID of the 5xx tag
Heading | nvarchar(255) | the normalized text


UsersPPPP

UsersPPPP Table

Holds AdminAttribute data values that have been set for a particular PolarisUser.

Columns

Column name | Data type | Description
PolarisUserID | int | Corresponding Polaris User
AttrID | int | AdminAttribute ID
Value | nvarchar(255) | The data value for this attribute


VegaDataSyncQueue

VegaDataSyncQueue Table

Contains one row for each object waiting to be synced with Vega.

Columns

Column name | Data type | Description
ObjectTypeID | int | Identifier for the type of object
ObjectID | int | Unique identifier for the object
OrganizationID | int | Identifier for the organization
ActionTypeID | int | Action to be taken on the item. 1 = Add, 2 = Update, 3 = Suppress, 4 = Delete
TransactionDate | datetime | Date of transaction


VegaNotificationMatrix

VegaNotificationMatrix Table

This table is a matrix to allow configuration of enabled notifications for Vega

Columns

Column name | Data type | Description
OrganizationID | int | Unique identifier for the organization
NotificationTypeID | int | Unique identifier for the notification type
DeliveryOptionID | int | Unique identifier for the delivery option
Enabled | bit | Is this row enabled for use with Vega? 1 = Yes, 0 = No


VendorAccountGroups

VendorAccountGroups Table

A table that associates admin attributes with various types of vendor accounts. This table is "owned" by the polaris application. Users may not change the entries in this table.

Columns

Column name | Data type | Description
VendorID | int | FK reference to the vendors table. This column allows attributes to be assigned to vendor accounts owned by a particular vendor.
AttrID | int | The Admin Attribute ID
VendorAccountParameterTypeID | int | The type of parameter.


VendorAccountParameterTypes

VendorAccountParameterTypes Table

A table used to assign a type to a vendor account admin attribute.

Columns

Column name | Data type | Description
VendorAccountParameterTypeID | int | A unique ID, system assigned.
VendorAccountParameterTypeDescription | nvarchar(255) | The description of the parameter type.

See Also

VendorAccountGroups, VendorAccountsPPPP,


VendorAccounts

VendorAccounts Table

A table used to contain vendor accounts. Vendor accounts are used to associate bibliographic data with particular vendors, resource groups, and connection settings. Vendor accounts are not used in acquisitions they are used to introduce special functionality in the Polaris PowerPAC and MobilePAC.

Columns

Column name | Data type | Description
VendorAccountID | int | A unique ID for the vendor account.
VendorID | int | A FK reference to the vendors table.
ResourceGroupID | int | The resource group (if any) associated with this vendor account.
VendorAccountDescription | nvarchar(255) | A wordy description of the vendor account.
CreatorID | int | The PolarisUserID of the creator.
ModifierID | int | The PolarisUserID who modified the vendor account entry.
CreationDate | datetime | The date that the account was created.
ModificationDate | datetime | The date that the vendor account entry was modified.
VendorContractID | nvarchar(255) | The vendor contract identifier associated with the libraries contract with the vendor (optional). In other words the libraries account number with the vendor.
ValidateVendorContractID | bit | Indicates if import processing validates the vendor contract ID.
ValidateVendorObjectIdentifier | bit | Indicates if import processing validates the vendor object identifier.
VendorEnabled | bit | Indicates if the vendor account is currently being used to supply special functionality in the PAC.
VendorAccountName | nvarchar(80) | The name of the vendor account.
VendorIconURL | nvarchar(4000) | A library defined Icon associated with this vendor account
AccountHasBeenSynchronized | bit | A flag indicating if the account has been synchronized.
LastSyncDate | datetime | Date vendor account was last sync'd. Only used for integrated OverDrive.
StepsCompleted | int | Identifies the number of steps completed for the Overnight integrated OverDrive processing.

See Also

ImportJobs, ImportProfiles, ResourceEntities, SA_PreferredVendorAccounts, ThirdPartyAPIFailures, VendorAccountsPPPP,


VendorAccountsPPPP

VendorAccountsPPPP Table

A table to used asscociate The profiles, parameters, and other attributes to a vendor account.

Columns

Column name | Data type | Description
VendorAccountID | int | The vendor account to which this parameter, profile, or attribute value is assigned.
AttrID | int | The admin attribute ID
VendorAccountParameterTypeID | int | The type of parameter.
ParamName | nvarchar(4000) | For future use.
ParamPrompt | nvarchar(4000) | For Future use.
Value | nvarchar(4000) | The value of the profile, parameter, or attribute.


VendorAccount_eContentProviderDataManagement

VendorAccount_eContentProviderDataManagement Table

A table that tracks vendor account synchronization activity for integrated vendor accounts that use pull synchronization

Columns

Column name | Data type | Description
VendorAccountID | int | The vendor account being tracked
LastTransactionDatePatronSynch | datetime | The last date and time the patron synchronization process took place for the vendor account
LastTransactionDateBibSynch | datetime | The last date and time the bib synchronization process took place for the vendor account
LastTransactionDateAdddedCopies | datetime | The last date and time the added copy process took place for the vendor account


VendorAccount_MarcRecordCandidates

VendorAccount_MarcRecordCandidates Table

A table used to resolve bib synchronization candidates

Columns

Column name | Data type | Description
VendorAccountID | int | The vendor account being synchronized
VendorObjectIdentifier | nvarchar(255) | The object identifier being synchronized


VendorAccount_PatronRecordSynch

VendorAccount_PatronRecordSynch Table

A table used to resolve patron synchronization candidates

Columns

Column name | Data type | Description
PatronID | int | The patrons ID
VendorAccountID | int | The vendor account associated with the patron
ResourceGroupID | int | The resource group to which the patron belongs. if any.
Barcode | nvarchar(20) | The patrons barcode
EmailAddress | nvarchar(64) | The patrons e-mail address
LastActivityDate | datetime | The patrons last activity date


VendorAccount_ResourceEntityRecordSynch

VendorAccount_ResourceEntityRecordSynch Table

A table used to synchronize the resource entities associated with a title.

Columns

Column name | Data type | Description
BibliographicRecordID | int | The bibliographic record id of the title
ResourceEntityID | int | The resource entity associated with the title
VendorAccountID | int | The vendor account ID
nTotalItems | int | The total number of final items.
nCKOItems | int | The number of items that are checked out
nAvailableItems | int | The number of items that are available (checked in)


VendorAccount_SynchCopyCount

VendorAccount_SynchCopyCount Table

A table used by Polaris PAC products which is allows those products to report eContent items that are out of synchronization with the Polaris ILS

Columns

Column name | Data type | Description
SynchCopyCountID | int | A uniquie identifier
VendorObjectIdentifier | nvarchar(255) | The vendor object identifier
VendorAccountID | int | The vendor account associated with the out of synchronization condition
VendorTotalCopies | int | The total number of copies the library has access to in the vendors repository
VendorAvailableCopies | int | The number of copies that the vendor claims to be available for checkout
PolarisTotalCopies | int | The total number of copies on hand reported by the Polaris ILS
PolarisAvailableCopies | int | The number of copies that the Polaris ILS reports as available for checkout
CopySynchronized | bit | Idicates if copy synchronization has been completed
SynchronizationStep | int | Indicates the current sychronization step (there are 4 steps)
CopyProcessed | bit | Indicates if the transaction was processed by the API consumer service
InsertDate | datetime | The date and time that the PAC product reported a potential out-of-synchronization condition


VendorAccount_SynchronizationEntities

VendorAccount_SynchronizationEntities Table

A table used to request that the API consumer service to resynchronized all data related to a particular integrated resource entity

Columns

Column name | Data type | Description
SynchronizationEntityID | int | A unique identifier for the row in the table
VendorObjectIdentifier | nvarchar(4000) | The Unique ID of the title in the vendor’s repository
VendorAccountID | int | The vendor account associated with the resource entity
DateAddedToQueue | datetime | The date and time the entry was added to the resynchronization queue
SynchronizationEntityProcessed | bit | A flag indicating if the item was processed
SynchronizationQueued | bit | A flag indicating that the item is queued from processing
SynchronizationDate | datetime | The date and time that the resource entity was resynchronized


Vendors

Vendors Table

A table to hold entries for supported third party API partners (vendors). These vendors are associated with API functionality. This table is not used in acquisitions (did you mean "suppliers?"). This table is "owned" by the Polaris application, and may not be altered by a customer.

Columns

Column name | Data type | Description
VendorID | int | A unique ID for the API Partner.
VendorName | nvarchar(255) | The name of the API Partner.
CreatorID | int | The ID for the creator.
ModifierID | int | The Polaris User ID of the modifier.
CreationDate | datetime | The date the vendor was created.
ModificationDate | datetime | The date that the vendor was modified.
IsAPIPartner | bit | Indicates if the vendor has integrated API functionality.
VendorDescription | nvarchar(255) | A human readable description of the vendor
OverdriveOrganizationContext | int | The vendor account to use at the system level when multiple vendor accounts exist for the vendor. This is used for overdrive advantage accounts.

See Also

DRMAuthenticationData, SA_PreferredVendorAccounts, ThirdPartyApiMethods, VendorAccountGroups, VendorAccounts,


WAM_Settings

WAM_Settings Table

Wireless access manager settings

Columns

Column name | Data type | Description
SettingsId | int | Reserved. For internal use only.
Gateways |  | Reserved. For internal use only.
Admins |  | Reserved. For internal use only.
Guests |  | Reserved. For internal use only.


WAM_UsageActive

WAM_UsageActive Table

Currently active wireless access manager users.

Columns

Column name | Data type | Description
UsageId | int | This is the unique identifier for the record. (primary key, identity)
UserId | int | The ID of the user in the WAM_Users table.
Login | datetime | The date and time the user logged in.
GatewayIP | nvarchar(15) | The IP address of the gateway that the user is logged into.


WAM_UsageInactive

WAM_UsageInactive Table

Users who are no longer logged into the wireless access manager.

Columns

Column name | Data type | Description
UsageId | int | This is the unique identifier for the record. (primary key, identity)
StatMarker | varbinary | An encrypted form of the data used for reporting through the wireless access manager software.
Login | datetime | The date and time the user logged in.
Logout | datetime | The date and time the user logged out.
GatewayIP | nvarchar(15) | The IP address of the gateway that was used.


WAM_Users

WAM_Users Table

Users who have logged into the wireless access manager.

Columns

Column name | Data type | Description
UserId | int | This is the unique identifier for the record. (primary key, identity)
Barcode | nvarchar(20) | The barcode of the user if applicable.
NameFirst | nvarchar(32) | The first name of the user if applicable.
NameLast | nvarchar(32) | The last name of the user if applicable.
Username | nvarchar(50) | The user's username if applicable.
PatronId | int | The user's PatronID if applicable.
StatMarker | varbinary | An encrypted form of the user data.


WebObjectLocks

WebObjectLocks Table

A table to track object locks created by web users

Columns

Column name | Data type | Description
ObjectTypeID | int | What kind of object got locked (Community record, event, etc...)
ObjectID | int | The ID of the object that was locked
LockingEntityID | int | The ID of the user who issued the object lock
LockingEntityTypeID | int | What kind of user issued the lock (Patron, Staff member, etc...)
LockDateTime | datetime | Date and time the lock was created
LockExpirationDateTime | datetime | The date and time the lock will expire
Token | nvarchar(64) | The Lock Token


WebPageParts

WebPageParts Table

This table represents the Web Page / Web Part assignments, grouped by an organization context.

Columns

Column name | Data type | Description
OrganizationID | int | Foreign key link (Organizations) that represents an organizational context for the particual web page assignemnts
WebPageID | int | Foreign key link (WebPages) that identifies a web page
WebPartID | int | Foreign key link (WebParts) that identifies a particular web part
DisplayOrder | int | Numerical order that determines the order a particular web part appears on a particular web page to make up the dashboard


WebPages

WebPages Table

This table defines the list of web pages that can have digital dashboard assignments

Columns

Column name | Data type | Description
WebPageID | int | Unique identifier
Description | nvarchar(255) | Relative URL description of the .asp page
PACTypeID | int | Designation of the type of PAC application the web page is associated with (foreign key on TypeOfPAC table)

See Also

WebPageParts,


WebParts

WebParts Table

This table defines all Polaris, 3rd party, and user-defined web parts that can be applied to a web page as a digital dashboard component.

Columns

Column name | Data type | Description
WebPartID | int | Unique identifier
WebPartTypeID | int | Foreign key reference to WebPartTypes. This column indicates the type of web part (Polaris, 3rd party, or user-defined).
ListingTypeID | int | Foreign Key reference to ListingTypes. Provides a link to the header and detail information for Polaris and 3rd party web parts only.
Title | nvarchar(30) | String description of this web part.
TotalListingRows | int | Number of entries to show on the dashboard. Zero indicates show an unlimited amount of entries from the data provided.
Mnemonic | nvarchar(100) | String indicating the mnemonic used for multi-lingual strings in WebAdmin

See Also

WebPageParts, WebPartUDElements,


WebPartTypes

WebPartTypes Table

This table defines the various types of web parts.

Columns

Column name | Data type | Description
WebPartTypeID | int | Unique identifier
Description | nvarchar(255) | String description of the web part type. (eg. "3rd Party")

See Also

WebParts,


WebPartUDDetails

WebPartUDDetails Table

This table defines a particular component value of a single web part element.

Columns

Column name | Data type | Description
WebPartUDElementID | int | Foreign key link (WebPartUDElements) to the web part element that this detail is part of.
WebPartUDSubTypeID | int | Foreign key link (WebPartUDSubTypes) indicating the sub type of this particular detail.
Value | nvarchar(255) | String value for this detail.


WebPartUDElements

WebPartUDElements Table

This table represents a particular web part element for a particular user-defined web part. It is composed of one or more details.

Columns

Column name | Data type | Description
WebPartUDElementID | int | Unique identifier
WebPartID | int | Foreign key link (WebParts) to the particular web part that this element is part of
WebPartUDTypeID | int | Foreign key link (WebPartUDTypes) to identify the type of element this is.
DisplayOrder | int | Numerical ranking for sorting; Determines the element order display for a web part


WebPartUDSubTypes

WebPartUDSubTypes Table

This table defines the set of web part details subtypes for user-defined web parts.

Columns

Column name | Data type | Description
WebPartUDSubTypeID | int | Unique identifier
Description | nvarchar(255) | String description of the subtype (eg. "Author")

See Also

WebPartUDDetails,


WebPartUDTypes

WebPartUDTypes Table

This table defines the set of user-defined web part element types.

Columns

Column name | Data type | Description
WebPartUDTypeID | int | Unique identifier
Description | nvarchar(255) | String description of type (eg. "URL")

See Also

WebPartUDElements,


WorkflowAnswers

WorkflowAnswers Table

This table contains the Polaris.ApplicationServices responses to an API workflow request.

Columns

Column name | Data type | Description
WorkflowAnswerID | int | Primary key
WorkflowRequestID | int | ID of workflow request that this answer is attached to.
CreationDate | datetime | Date answer was added to the database.
WorkflowStatusID | int | ID of workflow status.
WorkflowPromptID | int | ID of prompt
Prompt | varbinary | Serialized prompt object.
InformationMessages | varbinary | Additional messages that the consumer may want to show the user.
AnswerExtension | varbinary | Additional information that may be used to build the prompt.
ReceiptType | int | Type of receipt
ReceiptURL | nvarchar(2048) | URL of the receipt.


WorkflowPromptOptionTypes

WorkflowPromptOptionTypes Table

This table contains the Polaris.ApplicationServices prompt option types for API workflow prompts. Examples would be YesNo, OKCancel.

Columns

Column name | Data type | Description
WorkflowPromptOptionTypeID | int | Primary key.
Name | nvarchar(50) | Mnemonic
Description | nvarchar(200) | Description

See Also

WorkflowPrompts,


WorkflowPromptResults

WorkflowPromptResults Table

This table contains the valid Polaris.ApplicationServices prompt option results for API workflow replies. Examples would be OK, Yes, No.

Columns

Column name | Data type | Description
WorkflowPromptResultID | int | Primary key.
Name | nvarchar(50) | Mnemonic
Description | nvarchar(200) | Description.

See Also

WorkflowPrompts, WorkflowReplies,


WorkflowPrompts

WorkflowPrompts Table

This table contains the valid Polaris.ApplicationServices prompts for use in API workflow answers. An example would be a resolve lost item prompt.

Columns

Column name | Data type | Description
WorkflowPromptID | int | Primary Key.
Name | nvarchar(50) | Mnemonic
Description | nvarchar(200) | General description of the prompt contents.
WorkflowPromptTypeID | int | ID of workflow prompt type. Example, this prompt contains simple text.
WorkflowPromptOptionTypeID | int | ID of the workflow prompt option type. Example, this prompt should display options for OK and Cancel.
DefaultPromptOption | int | The ID of the default prompt result. For example, this prompt has a default option of Cancel.

See Also

WorkflowAnswers, WorkflowReplies,


WorkflowPromptTypes

WorkflowPromptTypes Table

This table contains the valid Polaris.ApplicationServices prompt types for use in API workflow prompts. An example, would be a text prompt type or a charge for checkout prompt type.

Columns

Column name | Data type | Description
WorkflowPromptTypeID | int | Primary key
Name | nvarchar(50) | Mnemonic
Description | nvarchar(200) | Description.

See Also

WorkflowPrompts,


WorkflowReplies

WorkflowReplies Table

This table contains the Polaris.ApplicationServices replies used when the consumer of the workflow API sends a message back to reply to a prompt.

Columns

Column name | Data type | Description
WorkflowReplyID | int | Primary key
WorkflowRequestID | int | ID of the workflow request this reply is associated with.
CreationDate | datetime | Date workflow reply was added to the database.
WorkflowPromptID | int | The ID of the workflow prompt that this reply is associated with.
WorkflowPromptResultID | int | The ID of the workflow prompt result. Example, did the consumer return a OK or Cancel prompt result.
ReplyValue | decimal | This field may be used to store a numeric value. May be used instead of the reply extension for simple replies requiring a count, etc.
ReplyExtension | varbinary | Field is used to serialize and store dynamic data returned by the workflow API consumer. This data is specific to the prompt that is being replied to.


WorkflowRequests

WorkflowRequests Table

This table contains the Polaris.ApplicationServices requests used when the consumer of the workflow API sends a message to initiate a workflow process such as check-out or check-in.

Columns

Column name | Data type | Description
WorkflowRequestID | int | Primary key.
WorkflowRequestGuid | uniqueidentifier | Unique identifier used by the consumer when replying to workflow answers.
WorkflowRequestTypeID | int | ID of workflow request type.
WorkflowStatusID | int | ID of workflow status.
CreationDate | datetime | Date workflow request was added to the database.
LastActivityDate | datetime | Last activity date of workflow request.
TxnBranchID | int | Transacting branch ID.
TxnUserID | int | Transacting user ID.
TxnWorkstationID | int | Transacting workstation ID.
RequestExtension | varbinary | Additional data, specific to the request type, that is attached to the workflow request.
StateObject | varbinary | Serialized state object used to restore state between network round-trips.
CircTranType | int | The circulation transaction type to identify the transaction.

See Also

WorkflowAnswers, WorkflowReplies,


WorkflowRequestTypes

WorkflowRequestTypes Table

This table contains the valid Polaris.ApplicationServices workflow request types. Examples are Check-in and Check-out.

Columns

Column name | Data type | Description
WorkflowRequestTypeID | int | Primary Key
Name | nvarchar(50) | Mnemonic of workflow request type.
Description | nvarchar(200) | Description of workflow request type.

See Also

WorkflowRequests,


WorkflowStatuses

WorkflowStatuses Table

This table contains the valid Polaris.ApplicationServices workflow statuses. Examples are input required, completed successfully.

Columns

Column name | Data type | Description
WorkflowStatusID | int | Primary Key
Name | nvarchar(50) | Mnemonic of status
Description | nvarchar(200) | Description of workflow status.

See Also

WorkflowAnswers, WorkflowRequests,


Workstations

Workstations Table

Workstations are associated with a Branch organization only. The related record in Organizations must have an OrganizationCodeID = 4 (Branch).

Columns

Column name | Data type | Description
WorkstationID | int | Primary key
OrganizationID | int | Organization where workstation exists
DisplayName | nvarchar(80) | name of the computer which is displayed
ComputerName | nvarchar(32) | Name of the computer.
CreatorID | int | ID of user who created this object
ModifierID | int | ID of user who last modified this object
CreationDate | datetime | Date/time of creation
ModificationDate | datetime | Date/time of the last modification
Enabled | bit | This flags the workstation as being enabled (licensed) for use with Polaris.
Status | bit | Whether the workstation is logged on or off the StaffClient. 1 means the client is currently logged on, 0 means the workstation is not logged on.
StatusDate | datetime | The last time the workstation is logged on the StaffClient
NetworkDomainID | int | Unique identifier of the network domain associated with the workstation.
LeapAllowed | bit | Bit value to allow the use of this workstation with Polaris Leap.
TerminalServer | bit | 1-bit flag that indicates whether the workstation is a terminal server.

See Also

AdminLog, CircItemRecords, CommunityImportJobs, EphemeralItemRecords, GroupWorkstations, ILSStoreTransactions, Import_ScheduledImportFiles, ImportJobs, ItemRecordHistory, LabelPrinters, ObjectLocks, PAC_PatronFreeTextMessages, PAC_PatronMessages, PACSearchTypes, PatronAccount, PatronFreeTextBlocks, PatronNotes, PatronStops, PermissionWorkstations, ReceiveShipmentLogs, Rpt_RouteSlips, Rpt_SubsCancelNotices, SearchDatabases, SysHoldHistory, WorkstationsPPPP,


WorkstationsPPPP

WorkstationsPPPP Table

Holds AdminAttribute data values that have been set for a particular Workstation.

Columns

Column name | Data type | Description
WorkstationID | int | Corresponding Workstation ID
AttrID | int | AdminAttribute ID
Value | nvarchar(255) | DATA


wrs_BibList

wrs_BibList Table

Table used by Conversion Services for bulk BibliographicRecords processing.

Columns

Column name | Data type | Description
BibliographicRecordID | int | Link to Bib Records table


Z3950$AccessPointDensities

Z3950$AccessPointDensities Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ObjectID | int | Reserved. For internal use only.
Density | float | Reserved. For internal use only.


Z3950$AttributeSetInfo

Z3950$AttributeSetInfo Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
AttributeSetID | int | Reserved. For internal use only.
AttributeSetOID | varchar(50) | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.

See Also

Z3950$AttributeTypeInfo,


Z3950$AttributeTypeInfo

Z3950$AttributeTypeInfo Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
AttributeTypeID | int | Reserved. For internal use only.
AttributeSetID | int | Reserved. For internal use only.
AttributeType | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.

See Also

Z3950$AttributeValueInfo,


Z3950$AttributeValueDetails

Z3950$AttributeValueDetails Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
DatabaseID | int | Reserved. For internal use only.
AttributeValueID | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.
DescriptorID | int | Reserved. For internal use only.


Z3950$AttributeValueInfo

Z3950$AttributeValueInfo Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
AttributeValueID | int | Reserved. For internal use only.
AttributeTypeID | int | Reserved. For internal use only.
AttributeValue | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.
DescriptorID | int | Reserved. For internal use only.

See Also

Z3950$AttributeValueDetails, Z3950$SortDetails, Z3950$TermListDetails,


Z3950$Columns

Z3950$Columns Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ObjectID | int | Reserved. For internal use only.
Name | sysname | Reserved. For internal use only.
OrdinalPosition | int | Reserved. For internal use only.
DataType | int | Reserved. For internal use only.
ColumnSize | int | Reserved. For internal use only.
CollationName | sysname | Reserved. For internal use only.


Z3950$DatabaseInfo

Z3950$DatabaseInfo Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
DatabaseID | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.
DescriptorID | int | Reserved. For internal use only.
DomainID | int | Reserved. For internal use only.
ControlMask | int | Reserved. For internal use only.

See Also

Z3950$AttributeValueDetails, Z3950$SortDetails, Z3950$TermListDetails,


Z3950$Descriptors

Z3950$Descriptors Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
DescriptorID | int | Reserved. For internal use only.
DescriptorTypeID | int | Reserved. For internal use only.
Value | int | Reserved. For internal use only.
ParentDescriptorID | int | Reserved. For internal use only.
Sequence | int | Reserved. For internal use only.

See Also

Z3950$AttributeValueDetails, Z3950$AttributeValueInfo, Z3950$DatabaseInfo, Z3950$SortDetails, Z3950$TermListDetails,


Z3950$DescriptorTypes

Z3950$DescriptorTypes Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
DescriptorTypeID | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.

See Also

Z3950$Descriptors,


Z3950$ElementDetails

Z3950$ElementDetails Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ElementSetID | int | Reserved. For internal use only.
ElementID | int | Reserved. For internal use only.
Sequence | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.
MaxSize | int | Reserved. For internal use only.
MinSize | int | Reserved. For internal use only.
AvgSize | int | Reserved. For internal use only.
FixedSize | int | Reserved. For internal use only.


Z3950$ElementInfo

Z3950$ElementInfo Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ElementID | int | Reserved. For internal use only.
TagSetID | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.
TagValue | int | Reserved. For internal use only.
SortDataTypeID | int | Reserved. For internal use only.


Z3950$ElementSetDetails

Z3950$ElementSetDetails Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ElementSetID | int | Reserved. For internal use only.
DatabaseID | int | Reserved. For internal use only.
RecordSyntaxID | int | Reserved. For internal use only.
SchemaID | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.
DescriptorID | int | Reserved. For internal use only.


Z3950$KeywordSchemes

Z3950$KeywordSchemes Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
KeywordSchemeID | int | Reserved. For internal use only.
KeywordTableID | int | Reserved. For internal use only.
KeywordIndexID | int | Reserved. For internal use only.
TypeFlags | smallint | Reserved. For internal use only.
KeywordFilterID | int | Reserved. For internal use only.
KeywordRelationsID | int | Reserved. For internal use only.


Z3950$NormalizationDetails

Z3950$NormalizationDetails Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ObjectID | int | Reserved. For internal use only.
OrdinalPosition | int | Reserved. For internal use only.
NormalizationTypeID | int | Reserved. For internal use only.
CanonicalFormat | bit | Reserved. For internal use only.


Z3950$NormalizationTypes

Z3950$NormalizationTypes Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
NormalizationTypeID | int | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.

See Also

Z3950$NormalizationDetails,


Z3950$ObjectFlags

Z3950$ObjectFlags Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ObjectFlag | int | Reserved. For internal use only.
Name | nvarchar(255) | Reserved. For internal use only.


Z3950$Objects

Z3950$Objects Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ObjectID | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
ObjectTypeID | int | Reserved. For internal use only.
ForeignDatabaseID | int | Reserved. For internal use only.
Flags | int | Reserved. For internal use only.

See Also

Z3950$Columns, Z3950$KeywordSchemes,


Z3950$ObjectTypes

Z3950$ObjectTypes Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ObjectTypeID | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.

See Also

Z3950$Objects,


Z3950$RecordSyntaxInfo

Z3950$RecordSyntaxInfo Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
RecordSyntaxID | int | Reserved. For internal use only.
RecordSyntaxOID | varchar(50) | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.


Z3950$SchemaInfo

Z3950$SchemaInfo Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
SchemaID | int | Reserved. For internal use only.
SchemaOID | varchar(50) | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.


Z3950$SortDataTypes

Z3950$SortDataTypes Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
SortDataTypeID | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.

See Also

Z3950$ElementInfo,


Z3950$SortDetails

Z3950$SortDetails Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
DatabaseID | int | Reserved. For internal use only.
AttributeValueID | int | Reserved. For internal use only.
DescriptorID | int | Reserved. For internal use only.


Z3950$TagSetInfo

Z3950$TagSetInfo Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
TagSetID | int | Reserved. For internal use only.
TagSetOID | varchar(50) | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.

See Also

Z3950$ElementInfo,


Z3950$TermListDetails

Z3950$TermListDetails Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
DatabaseID | int | Reserved. For internal use only.
AttributeValueID | int | Reserved. For internal use only.
Name | varchar(50) | Reserved. For internal use only.
Description | varchar(255) | Reserved. For internal use only.
DescriptorID | int | Reserved. For internal use only.


__AuthorityDiacriticCleanup

__AuthorityDiacriticCleanup Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
AuthoritySubfieldID | int | Reserved. For internal use only.
AuthorityTagID | int | Reserved. For internal use only.
SubfieldSequence | smallint | Reserved. For internal use only.
Subfield | char | Reserved. For internal use only.
Data | nvarchar(4000) | Reserved. For internal use only.
NumberOfNonFilingCharacters | tinyint | Reserved. For internal use only.


__BibliographicDiacriticCleanup

__BibliographicDiacriticCleanup Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
BibliographicSubfieldID | int | Reserved. For internal use only.
BibliographicTagID | int | Reserved. For internal use only.
SubfieldSequence | smallint | Reserved. For internal use only.
Subfield | char | Reserved. For internal use only.
Data | nvarchar(4000) | Reserved. For internal use only.
NumberOfNonFilingCharacters | tinyint | Reserved. For internal use only.


__IRRecordStores__

__IRRecordStores__ Table

Contains one row for each named record store owned by a given account. Currently, all accounts are patron accounts but other account types may be used in the future.

Columns

Column name | Data type | Description
RecordStoreID | int | Is the record store identifier.
AccountID | int | Is the account identifier (e.g. Patron Identifier).
Name | nvarchar(255) | Is the name of the record store (e.g. "My Favorites").
Sorted | bit | Indicates whether record store is sorted by record name.
CreationDate | datetime | Date the record store was created.

See Also

__IRRecords__,


__IRRecords__

__IRRecords__ Table

Contains one row for each persistent record saved in a record store.

Columns

Column name | Data type | Description
RecordID | int | Identifies the record within the record store.
RecordStoreID | int | Identifies the record store in which the record is associated with.
Position | int | Identifies the position of the record within a record store.
Name | nvarchar(255) | Identifies the name of the record (e.g. primary title).
Data | image | Contains cached record data (e.g. MARC).
LocalControlNumber | int | Identifies the local control number from which this record originated from.


__PatronAddresses__

__PatronAddresses__ Table

Backup table: Lists addresses which correspond to patrons, because patrons can have numerous addresses.

Columns

Column name | Data type | Description
PatronID | int | Backup table: Unique identifier from Patrons table
AddressID | int | Backup table: Unique identifier from Address table (contains the actual address)
AddressTypeID | int | Backup table: Unique identifier from AddressTypes table
FreeTextLabel | nvarchar(30) | Backup table: Free text description of the address
Verified | bit | Backup table: Indicates whether the address is verified by a third-party web service
VerificationDate | datetime | Backup table: The date when patron address is verified by a third-party web service
PolarisUserID | int | Backup table: The polaris user ID who sends the address to a third-party web service for verification
AddressLabelID | int | Backup table: Foreign key into Polaris..AddressLabels, representing a patron's address label


AggregateGroupings

PolarisTransactions Database

AggregateGroupings Table

Computed aggregates for an Aggregates table entry broken down by a secondary Transaction field (indicated by TransactionSubTypeID in the associated AggregateSpecifcations record).

Columns

Column name | Data type | Description
AggregateID | int | Foreign Key reference to the Aggregates table.
GroupByTransactionSubTypeID | int | The TransactionSubTypeID value for this grouping. (i.e. As specified by the associated AggregateSpecifications.TransactionSubTypeID)
SubTypeValue | int | The TransactionSubTypeID's value for this grouping. (i.e. If GroupByTransactionSubTypeID indicates the PatronCode field, this is the value of the PatronCode for which this grouping is computed)
SubTypeTotal | int | AggregateGrouping total for the GroupByTransactionSubTypeID value.


Aggregates

PolarisTransactions Database

Aggregates Table

This table contains aggregated totals for transactions defined in the AggregateTypes and AggregateSpecifications tables.

Columns

Column name | Data type | Description
AggregateID | int | Unique identifier for each row.
AggregateTypeID | int | Foreign Key reference to AggreateTypes table.
OrganizationID | int | OrganizationID (Branch) associated with this aggregate total. Typically the OrganizationID from the TransactionHeaders table, unless overridden by a TransactionDetails Organization field as specified by AggregateSpecifications.OrganizationSubTypeID.
StartDateTime | datetime | Start time for the period of the aggregate total entry
EndDateTime | datetime | End time for the period of the aggregate total entry
Total | int | Aggregate total for the time period. This could be a record count of transactions or a summed value if so specified by AggregateSpecifications.SumationSubTypeID.

See Also

AggregateGroupings,


AggregateSpecifications

PolarisTransactions Database

AggregateSpecifications Table

Specification details for the generation of Aggregates.

Columns

Column name | Data type | Description
AggregateTypeID | int | Foreign Key reference to AggregateTypes table
TransactionTypeID | int | TransactionTypeID used for this Aggregate.
TransactionSubtypeID | int | TransactionSubTypeID to use for an AggregateGrouping. NULL indicates this is an Aggregates level specification and not an AggregateGrouping level aggregate.
OrganizationSubTypeID | int | TransactionSubTypeID to use for the aggregate OrganizationID. NULL indicates use OrganizationID from TransactionHeaders table.


AggregateTypes

PolarisTransactions Database

AggregateTypes Table

Defines Aggregates

Columns

Column name | Data type | Description
AggregateTypeID | int | Unique identifier (Primary Key)
AggregateDescription | nvarchar(100) | Description of this Aggregate type
AggregatePeriod | smallint | Time period, in minutes, to break down aggregate totals.
LastRunDate | datetime | Last Date/Time aggregate totals have been computed for this AggregateTypeID. (Note: an entry of "1/4/2001 12:00 AM" indicates Aggregates are computed for the library's processing though 1/3/2001)
AggregateFunctionCode | tinyint | Indicates type of Aggregate: 1 -- Transaction Count 2 -- Sumation of TransactionDetails field. (as indicated by SummationSubTypeID)
SumationSubTypeID | int | The TransactionSubTypeID field the sums are calculated for. (Valid only if AggregateFunctionCode = 2)
ConditionalSubTypeID | int | Make compilation of this aggregate dependant on the transaction containing this conditional TransactionSubTypeID in the TransactionDetails record.
ConditionalSubTypeValue | int | See ConditionalSubTypeID. This is an optional value to use in filtering aggregate counting for the conditional subtype.
LastTranID | int | This is the Last transaction ID that was processed for this aggregate. Used to mark the start point for the next day's processing.

See Also

Aggregates, AggregateSpecifications,


EmailLog

PolarisTransactions Database

EmailLog Table

This table stores all eReceipt emails and SMS messages. All the entries stored in this table will be used to generate eReceipt failure report.

Columns

Column name | Data type | Description
PatronID | int | ID of patron to whom email or SMS is sent.
OrganizationID | int | ID of Polaris user logon organization from where email or SMS is sent.
FromAddr | nvarchar(255) | Email address from where Email or SMS is sent.
ToAddr | nvarchar(255) | Email address to where Email or SMS is sent.
EmailSubject | nvarchar(4000) | Subject context appeared on email or SMS receipt.
SendDate | datetime | Datetime when email or SMS is sent.
EmailType | smallint | Email or SMS type ID. Currently, only Type=1 is implemented which stands for Circ eReceipt.
Succeeded | bit | Whether Email or SMS is sent successfully.


NotificationLog

PolarisTransactions Database

NotificationLog Table

This table gives an overview of every notice that is sent to a patron.

Columns

Column name | Data type | Description
PatronID | int | ID of the patron that this notice pertains to.
NotificationDateTime | datetime | Date/Time when the notification was performed.
NotificationTypeID | int | Type of notification (can be Overdues, Holds, Cancels, Recalls, or All). Maps to the Polaris..NotificationTypes table. Since Phone Notification is the only system that is using this table right now, this column will most likey always be set to All.
DeliveryOptionID | int | Maps to the Polaris..DeliveryOptions table. This tells how the notice was delivered (Phone, Printed, Email, etc).
DeliveryString | nvarchar(255) | Where this notice was delivered. For phone notification, this tells the phone number used for the call.
OverduesCount | int | # of 1st time notified overdue items included in the notice.
HoldsCount | int | # of held items included in the notice.
CancelsCount | int | # of cancelled hold requests included in the notice.
RecallsCount | int | Number of Recalls in the notice (not used).
NotificationStatusID | int | Status of the notice (whether or not it was successful).
Details | nvarchar(255) | Details about the notification. For phone notification, this tells more information about the call and the results of it.
RoutingsCount | int | Number of Routings in the notice.
ReportingOrgID | int | ID of the organization from where notice is sent.
PatronBarcode | nvarchar(20) | Barcode of the patron to whom the notice is sent.
Reported | bit | Boolean value to indicate whether or not the summary report has been sent to the responsible e-mail address which is defined in SA Notification Options.
Overdues2ndCount | int | # of 2nd time notified overdue items included in the notice.
Overdues3rdCount | int | # of 3rd time notified overdue items included in the notice.
BillsCount | int | # of billed items included in the notice.
LanguageID | int | ID of the language in which a notice is sent. It references Languages.AdminLanguageID.
CarrierName | nvarchar(255) | the name of cell phone carrier from whom TXT notice is sent.
ManualBillCount | int | # of manual bills included in the notice.
NotificationLogID | int | Unique identifier


PolSupportMaintTable

PolarisTransactions Database

PolSupportMaintTable Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ColIDIntValue | int | Reserved. For internal use only.
ColOrgIDValue | int | Reserved. For internal use only.
ColDateValue | datetime | Reserved. For internal use only.
ColTypeIDValue | int | Reserved. For internal use only.
ColNumValue | int | Reserved. For internal use only.
RunDate | datetime | Reserved. For internal use only.
IsRollBack | bit | Reserved. For internal use only.


PolSupportMaintTableTwo

PolarisTransactions Database

PolSupportMaintTableTwo Table

Reserved. For internal use only.

Columns

Column name | Data type | Description
ColIDIntValue | int | Reserved. For internal use only.
ColOrgIDValue | int | Reserved. For internal use only.
ColTypeIDValue | int | Reserved. For internal use only.
ColNumValue | int | Reserved. For internal use only.
ColDateValue | datetime | Reserved. For internal use only.
RunDate | datetime | Reserved. For internal use only.
IsRollBack | bit | Reserved. For internal use only.


SA_PurgePatronIDRunCounts

PolarisTransactions Database

SA_PurgePatronIDRunCounts Table

Table storing statistics related to removing patron information from transactions.

Columns

Column name | Data type | Description
OrganizationID | int | ID of the related organization
RunDate | datetime | Date run
FirstTranDate | datetime | Date of first run.
LastTranDate | datetime | Date last run
TranCount | int | Count of affected transactions
HistoriesCount | int | Total count historically


TransactionDetails

PolarisTransactions Database

TransactionDetails Table

This table holds all the subtypes/details represented by the transaction in the header table

Columns

Column name | Data type | Description
TransactionID | int | transactionid that is being defined from the transactionheaders table
TransactionSubTypeID | int | Transactionsubtypeid is the detail/subtype that goes with the transaction
numValue | int | to store numbers and string values. The amounts are stored multiplied by a 1000
dateValue | datetime | column to store date subtypes


TransactionDetailStrings

PolarisTransactions Database

TransactionDetailStrings Table

This table holds all the strings for the transactions

Columns

Column name | Data type | Description
TransactionStringID | int | id - represnting the string and this is used in the transactiondetails table to represent the strings
TransactionString | nvarchar(256) | text value of the string id


TransactionHeaders

PolarisTransactions Database

TransactionHeaders Table

This table holds the transactions and header information

Columns

Column name | Data type | Description
TransactionID | int | sequence number for the transaction
OrganizationID | int | organization id where the transaction originated
WorkstationID | int | woprkstationid where the transaction originated
PolarisUserID | int | userid responsible for the transaction
TransactionDate | datetime | the date when the transaction is inserted into the database
TransactionTypeID | int | type of transaction -- from the transaction types table
TranClientDate | datetime | client date of the transaction

See Also

TransactionDetails,


TransactionRules

PolarisTransactions Database

TransactionRules Table

This table defines all the sub types that go with a transaction

Columns

Column name | Data type | Description
TransactionTypeID | int | transaction type id that is being defined.
TransactionSubTypeID | int | transaction sub type id that goes with the transaction


TransactionSubTypeCodes

PolarisTransactions Database

TransactionSubTypeCodes Table

Table that holds all the possible values for a sub type

Columns

Column name | Data type | Description
TransactionSubTypeID | int | subtypeid is the foreign key column to the transaction subtype table
TransactionSubTypeCode | int | code value of the subtype that is defined in the transaction detail table
TransactionSubTypeCodeDesc | nvarchar(50) | code description for the subtype value code that is defined in the detail table


TransactionSubTypes

PolarisTransactions Database

TransactionSubTypes Table

The table that defines the details possible for all the transaction

Columns

Column name | Data type | Description
TransactionSubTypeID | int | primary key that holds the subtype id
TransactionSubTypeDescription | nvarchar(100) | brief description for the sub type
DataType | char | data type of the detail - 'N' - Number 'D' - Date 'T' - Text 'K' - key 'B' - Boolean
Mnemonic | nvarchar(100) | mnemonic used in the client implementation
IsImplemented | bit | Flag that defines if this subtype is currently implemented. An unimplemented subtype indicates the subtype was formerly used and is now obsolete.

See Also

AggregateSpecifications, AggregateTypes, TransactionDetails, TransactionRules, TransactionSubTypeCodes,


TransactionTypes

PolarisTransactions Database

TransactionTypes Table

This base table defines all the transactions types that can be logged to the system

Columns

Column name | Data type | Description
TransactionTypeID | int | transaction type id is the primary key
TransactionTypeDescription | nvarchar(100) | describes the transaction
Mnemonic | nvarchar(50) | mnemonic that is used in the client implementation code
SysAdminuseTransaction | bit | configurable bit flag which defines whether a transaction needs to be logged or not 1 - log the transaction 0 - do not log the transaction
IsImplemented | bit | bit flag which defines whether a transaction is implemented or not

See Also

AggregateSpecifications, TransactionHeaders, TransactionRules,


CallStatuses

Results Database

CallStatuses Table

Data in this table represents the status of unsuccessful calls from the phone notification unit. The unit will query this table to determine the next time it will be able to make the call.

Columns

Column name | Data type | Description
PatronID | int | ID of the patron that had the unsuccessful call.
NumberOfTries | int | Number of unsuccessful calls. After a predetermined number of unsuccessful calls, the unit will transfer the notice to be printed instead.
LastTry | datetime | Date/Time of last call attempt.


CircReminders

Results Database

CircReminders Table

This is a table which holds reminder notices that can be generated. There are three types of reminder notices contained in this table: expired patron reminder, inactive patron reminder, and overdue item reminders

Columns

Column name | Data type | Description
NotificationTypeID | int | What kind of notification is this?
ReportingOrgID | int | Organization ID
ReportingOrgName | nvarchar(50) | Name of the reporting organization
ReportingOrgAddress | nvarchar(400) | Organization address
PatronID | int | PatronID
PatronName | nvarchar(160) | Name of the patron
EmailAddress | nvarchar(130) | Patron's email address
PatronAddress | nvarchar(400) | Address for the patron for the notice
PhoneVoice | nvarchar(20) | Patron phone number
EmailFormatID | int | Format of the email (html or text)
ItemRecordID | int | Item Record ID
DueDate | datetime | Item's due date
BrowseTitle | nvarchar(255) | Title of the bib record
ItemFormat | nvarchar(80) | Description of the item's primary type of material
ItemAssignedBranch | nvarchar(50) | Assigned branch of the item
Renewals | int | Renewals remaining for the item
ReportingOrgPhone | nvarchar(255) | Telephone info of the reporting organization.
AdminLanguageID | int | ID of the Language that reminder notice is translated to and displayed in. The language ID stored in this column is the MS LanguageID which is 1033 for English, 3082 for Spanish, 3084 for French, etc..
DeliveryOptionID | int | Indicates delivery method the notice needs to be sent by. It maps to values in Polaris.DeliveryOptions table.
IsAdditionalTxt | bit | Flag indicating if this is an additional txt message.
AutoRenewal | bit | Flag indicating if this is an auto-renewal reminder.


ClaimNotices

Results Database

ClaimNotices Table

Extended information for each claim item that is displayed in the Report. Also, see ViewClaimNoticesData for more information on where these values are coming from.

Columns

Column name | Data type | Description
ItemRecordID | int | ID of the item.
PatronID | int | ID of the patron this item notice belongs to.
ItemBarcode | nvarchar(20) | Barcode of the item.
DueDate | datetime | Date the item was due.
BrowseTitle | nvarchar(255) | Title information gathered from the BibliographicRecord.
BrowseAuthor | nvarchar(255) | Author information gathered from the BibliographicRecord.
Abbreviation | nvarchar(15) | Organization abbreviation of the item's assigned branch.
Name | nvarchar(50) | Organization name of the item's assigned branch.
PhoneNumberOne | nvarchar(20) | Phone number of the contact person for the reporting organization.
LoaningOrganizationID | int | ID of the organization that loaned the item to this patron.
ReportingOrgID | int | ID of the organization from where this notice gets notified.
DeliveryOptionID | int | The type of delivery that this notice will take. The values map to the DeliveryOptions table in the Polaris database.
ReturnAddressOrgID | int | Address ID of the organization which is designated as the Return Address from SA at organization levels.
NotificationTypeID | int | ID of the type of notification that this item needs (ie. 1st Overdues/2nd overdues/3rd overdues/Billing). The values map to the NotificationTypes table in the Polaris database and will only be 19.
AdminLanguageID | int | ID of the Language that claim notice is translated to and displayed in. The language ID stored in this column is the MS LanguageID which is 1033 for English, 3082 for Spanish, 3084 for French, etc..
ClaimDate | datetime | The date a claim is made.
MaterialTypeID | int | The ID of the items Material Type. The values map to the MaterialTypes table in the Polaris database.


FineNotices

Results Database

FineNotices Table

Extended information for charges displayed on Patron's Fine Notice. The data in this table is populated by Process Fine Notices step in the Notice Processing job.

Columns

Column name | Data type | Description
PatronID | int | ID of patron who is fined.
ItemRelatedCharges | money | Patron's total outstanding charges related to item records.
NonItemRelatedCharges | money | Patron's total outstanding charges not related to item rcords.
Credit | money | Not being used.
TotalOutstandingCharges | money | Patron's total outstanding charges which is the total of item related and non-item related charges.
PrimaryPatronID | int | If fined patron is minor, this is the ID of fined patron's guardian.
DeliveryOptionID | int | Fine notice's delivery option ID. 1 - Mail; 2 - E-mail. Note, fine notices cannot be done by phone.
ReportingOrgID | int | ID of the organization (usually, a branch) from where the fine notice is generated and sent.
TxnID | int | Transaction ID of the charge.
IsAdditionalTxt | bit | Flag indicating if this is an additional txt message.


FineNoticesReport

Results Database

FineNoticesReport Table

Extended information for detailed patron, transaction, and item (if charge is item related) info displayed in Patron's Fine Notice. The data in this table is populated by Populate Fine Notices for Reporting step in the Notice Processing job. Maintaining this table is for reporting performance sake.

Columns

Column name | Data type | Description
PatronID | int | Fined patron ID.
PatronName | nvarchar(165) | Fined patron's name.
ReportingOrgID | int | ID of the organization from where fine notices is generated and sent.
ReturnAddrOrgID | int | ID of the organization whose address is used as the fine notice's returning address.
ReportingOrgName | nvarchar(80) | Full name of the organization from where fine notices is generated and sent.
ReportingOrgAbbreviation | nvarchar(15) | Abbreviation of the organization from where fine notices is generated and sent.
ReportingOrgPhoneVoice | nvarchar(32) | Telephone info of the organization from where fine notices is generated and sent.
TotalAmountOwed | money | Patron's total outstanding charges which is the total amount owed to the reporting organization appeared on the fine notice.
MinorPatronID | int | If fine notice is generated for the guardain, this is its minor patron's ID.
MinorPatronBarcode | nvarchar(20) | If fine notice is generated for the guardain, this is its minor patron's barcode.
MinorPatronName | nvarchar(165) | If fine notice is generated for the guardain, this is its minor patron's name.
ItemRecordID | int | If charge is item related, this is item record's ID.
ItemBarcode | nvarchar(20) | If charge is item related, this is the item's barcode.
CallNumber | nvarchar(370) | If charge is item related, this is call number info of the item record.
Author | nvarchar(400) | If charge is item related, this is author info of the item record.
Title | nvarchar(600) | If charge is item related, this is title info of the item record.
TxnDate | datetime | Transaction date when fine was charged.
Amount | money | Outstanding charges of each transaction.
OwedOrganizationID | int | ID of the organization which patron owed money.
OwedOrganizationAbbr | nvarchar(15) | Abbreviation of the organization which patron owed money.
DeliveryOptionID | int | Fine notice's delivery option ID. 1 - Mail; 2 - E-mail. Note, fine notices cannot be done by phone.
PatronAddressID | int | Fined patron's address ID which should reference to Addresses(AddressID).
PatronAddress | nvarchar(400) | Fined patron's address.
ReportingOrgAddress | nvarchar(400) | Address of the organization from where fine notices is generated and sent.
PatronCity | nvarchar(32) | Fined patron's addrees City info. this is used for sorting purpose only.
PatronZip | nvarchar(17) | Fined patron's addrees Zipcode info. this is used for sorting purpose only.
AdminLanguageID | int | ID of the Language that fine notice is translated to and displayed in. The language ID stored in this column is the MS LanguageID which is 1033 for English, 3082 for Spanish, 3084 for French, etc..
TxnID | int | Patron account transaction ID. References PatronAccount.TxnID.


GenericEmailQueue

Results Database

GenericEmailQueue Table

A generic email queue that gets populated for AD-HOC notice types, For example Polaris Fusion

Columns

Column name | Data type | Description
EmailID | int | A unique ID for the email
OrganizationID | int | The organization responsibile fro the email
NotificationTypeID | int | The notification type
PatronID | int | The patron to whom the email is sent
ItemRecordID | int | The item record id
BibliographicRecordID | int | The bibliographic record id
EmailFrom | nvarchar(4000) | Who is email is sent from (set in SA) for the organization.
ReplyTo | nvarchar(4000) | The reply to email address (set in SA) for the organization.
EmailTo | nvarchar(4000) | The emailaddress(es) to send to
EmailSubject | nvarchar(4000) | The subject of the email
EmailBody | ntext | The body of the email
EmailFooter | nvarchar(4000) | The footer of the email
PolarisUserID | int | The Polaris user who placed this request.
AttachmentPath | nvarchar(4000) | The attachment path, if any.
ReportingOrgID | int | The organization reporting.
NoticeDate | datetime | The date this was placed in the queue.
AltEmailAddress | nvarchar(64) | The alternate e-mail address for the patron.


GetNQItems

Results Database

GetNQItems Table

Used by Polaris..GenerateOverdueNoticesSub stored procedure as a temporary storage space for data while processing.

Columns

Column name | Data type | Description
ItemRecordID | int | ID of the item that an overdue notice is being generated for.
PatronID | int | ID of the patron that a notice is being generated for.
TempFix | int | Not used. (fixes problem with remote stored procedure)


HoldCancellationNotices

Results Database

HoldCancellationNotices Table

Extended information for each cancelled held item that is reported by Hold Cancellation Notice. The entry in this table is populated each time a hold request is cancelled. This table is needed because once a request is cancelled it can be deleted from database. So the previous held information will get lost. This table contains all the held info a request has when it's cancelled so that it still can be reported even after the request is deleted but before the cancellation is notified.

Columns

Column name | Data type | Description
RequestID | int | Request ID copied from SysHoldRequests(RequestID) or ILLRequests(RequestID) when a hold request or ILL request is cancelled.
PatronID | int | Patron info copied from SysHoldRequests(PatronID) or ILLRequests(PatronID) when a hold request or ILL request is cancelled.
PickupOrganizationID | int | Pickup organization info copied from SysHoldRequests(PickupOrganizationID) or ILLRequests(PickupOrganizationID) when a hold request or ILL request is cancelled.
Title | nvarchar(255) | Title info copied from SysHoldRequests(Title) or ILLRequests(Title) when a hold request or ILL request is cancelled.
RequestDate | datetime | Request date copied from SysHoldRequests(RequestDate) or ILLRequests(RequestDate) when a hold request or ILL request is cancelled.
Reason | nvarchar(4000) | Cancellation reason copied from SysHoldRequests(Reason) or ILLRequests(Reason) when a hold request or ILL request is cancelled.
ISSN | nvarchar(50) | ISSN info copied from ILLRequests(ISSN) when a ILL request is cancelled.
ISBN | nvarchar(50) | ISBN info copied from ILLRequests(ISBN) when a ILL request is cancelled.
BibliographicRecordID | int | Bib info copied from SysHoldRequests(BibliographicRecordID) when a hold request is cancelled.
AdminLanguageID | int | ID of the Language that cancellation notice is translated to and displayed in. The language ID stored in this column is the MS LanguageID which is 1033 for English, 3082 for Spanish, 3084 for French, etc..
DeliveryOptionID | int | Delivery option that cancellation notice will be using. 1 - mail; 2 - e-mail; 3, 4, or 5 - phone.
StatusID | int | Hold status of the hold request which is cancelled. The status could be 9 - Expired or 16 - Cancelled. This StatusID should reference to SysHoldStatuses(SysHoldStatusID) or ILLStatuses(ILLStatusID). This StatusID is used by Cancellation Notice to determine some of the displayed text.
IsAdditionalTxt | bit | Flag indicating if this is an additional txt message.


HoldNotices

Results Database

HoldNotices Table

Extended information for each held item that is displayed in the Crystal Report. This table is needed because items can be located on different servers. Also, see ViewHoldNoticesData for more information on where these values are coming from.

Columns

Column name | Data type | Description
ItemRecordID | int | ID of the item.
AssignedBranchID | int | ID of the item's organization.
PickupOrganizationID | int | ID of the organization where this held item can be picked up by the patron.
PatronID | int | ID of the patron this item is being held for.
ItemBarcode | nvarchar(20) | Barcode of the item.
BrowseTitle | nvarchar(255) | Title information gathered from the BibliographicRecord.
BrowseAuthor | nvarchar(255) | Author information gathered from the BibliographicRecord.
ItemCallNumber | nvarchar(370) | Call number of the item.
Price | money | Price of the item.
Abbreviation | nvarchar(15) | Organization abbreviation of the item's assigned branch.
Name | nvarchar(50) | Organization name of the item's assigned branch.
PhoneNumberOne | nvarchar(20) | Patron's phone number.
DeliveryOptionID | int | Delivery Option ID of the hold request. FK refers to DeliveryOptions.DeliveryOptionID.
HoldTillDate | datetime | The Date till when Item gets held for the patron. This date is copied from SysHoldRequests.HoldTillDate or ILLRequests.HoldTillDate.
ItemFormatID | int | Held item's material type ID. FK refers to MaterialTypes.MaterialTypeID.
AdminLanguageID | int | ID of the Language that hold notice is translated to and displayed in. The language ID stored in this column is the MS LanguageID which is 1033 for English, 3082 for Spanish, 3084 for French, etc..
NotificationTypeID | int | ID of the type of notification that this notice needs (ie. Overdues/Holds/Cancels/Recalls/etc). The values map to the NotificationTypes table in the Polaris database.


LeapOfflineTransactionData

Results Database

LeapOfflineTransactionData Table

Contains one row for each transaction line

Columns

Column name | Data type | Description
LeapOfflineTransactionDataID | int | Unique identifier
LeapOfflineTransactionSetID | int | Unique identifier from the LeapOfflineTransactionSets table
Sequence | int | Order transaction was stored in the transaction set
Data | nvarchar(4000) | Raw transaction data


LeapOfflineTransactionSets

Results Database

LeapOfflineTransactionSets Table

Contains one row for each uploaded transaction set

Columns

Column name | Data type | Description
LeapOfflineTransactionSetID | int | Unique identifier
Name | nvarchar(255) | Text description of the transaction set
UploadedDate | datetime | Date and time the transaction set was received by ther server
Processed | bit | Indicates if this transaction set has been added to the offline tables
ProcessedDate | datetime | Date and time the transaction set was added to the offline tables

See Also

LeapOfflineTransactionData,


ManualBillNotices

Results Database

ManualBillNotices Table

Extended information for each manual bill that is displayed in the Report.

Columns

Column name | Data type | Description
TxnID | int | ID of the charge.
ItemRecordID | int | If applicable, the ID of the charged item.
PatronID | int | ID of the charged patron.
ItemBarcode | nvarchar(20) | If applicable, the barcode of the charged item.
BrowseTitle | nvarchar(255) | If applicable, the title of the charged item.
BrowseAuthor | nvarchar(255) | If applicable, the author of the charged item.
ItemCallNumber | nvarchar(370) | If applicable, the call number of the charged item.
Abbreviation | nvarchar(15) | Abbreviation of the organization where the charge originated.
Name | nvarchar(50) | Name of the organization where the charge originated.
PhoneNumber | nvarchar(20) | Phone number for the organization where the charge originated.
ReportingOrgID | int | ID of the organization sending the notice.
DeliveryOptionID | int | Type of notice being sent (i.e. Mail, Email, Phone, etc.)
ReturnAddressOrgID | int | ID of the organization listed as the return address on the notice.
NotificationTypeID | int | ID of the notice type.
AdminLanguageID | int | Language the notice will be sent in.
MaterialTypeID | int | If applicable, the material type of the charged item.
FeeReasonCodeID | int | Fee reason tied to the charge.
AddedMessage | nvarchar(255) | Additional message to include with the manual bill.
ChargingLibraryID | int | ID of the organization where the charge originated.
TxnDate | datetime | Date the charge was created.
Amount | money | Amount of the bill.


NotificationHistory

Results Database

NotificationHistory Table

History of patron's hold, fine, overdue, billing and almost overdue notifications. Entry gets populated into this table each time patron is being notified by overdue, billing or almost overdue notices. See Reviewing Notice Histories for details on retention.

Columns

Column name | Data type | Description
PatronId | int | Patron ID.
ItemRecordId | int | Item record info that patron was being notified.
TxnId | int | This column has been depreciated
NotificationTypeId | int | Notification type which references NotificationTypes(NotificationTypeID). In this table, this value could only be 1, 2, 3, 7, 8, 11, 12, 13 and 18.
ReportingOrgId | int | Organization from where notice was sent.
DeliveryOptionId | int | Notification method that being used to notify patron which is phone, mail or email.
NoticeDate | datetime | Date when patron was notificed.
Amount | money | Money amount patron is billed for an item.
NotificationStatusId | int | Status of the notification which references NotificationStatuses(NotificationStatusID).
Title | nvarchar(255) | Title of the item associated with the patrons notice.


NotificationQueue

Results Database

NotificationQueue Table

This table stores every item (and its associated patron) that needs a notices (of any sort) generated.

Columns

Column name | Data type | Description
ItemRecordID | int | Overdue, Billing, Fine or Hold notices: ID of the item record that a notice to be generated which is CircItemRecords.ItemRecordID; Route notices: ID of the Route List Piece that a notice to be generated which is RouteListPieces.PieceID; Hold Cancellation notices: SysHoldRequests.RequestID for a cancelled system request, or negative ILLRequests.RequestID for a cancelled ILS request; Claim notices: ID of the Issue/Part record that a notice to be generated which is MfhdIssues.IssueID.
NotificationTypeID | int | ID of the type of notification that this item needs (ie. Overdues/Holds/Cancels/Recalls/etc). The values map to the NotificationTypes table in the Polaris database.
PatronID | int | ID of the patron that this item's notification belongs to.
DeliveryOptionID | int | The type of delivery that this notice will take. The values map to the DeliveryOptions table in the Polaris database.
Processed | bit | Indicates whether or not this notice has been attempted. This is usually used by Telephony. If the phone process failed, then DeliveryOption will change from Phone to Mail, this flag is turned on.
MinorPatronID | int | ID of a patron who is younger than 18-years-old.
ReportingOrgID | int | Polaris Organization ID from where notice gets notified.
Amount | money | Money amount related to the notice.
CreationDate | datetime | Date the notice was created.
IsAdditionalTxt | bit | Flag indicating if this is an additional txt message.
NotificationQueueID | int | Unique identifier


OverdueItemInfo

Results Database

OverdueItemInfo Table

Used by Polaris..GenerateOverdueNoticesSub stored procedure as a temporary storage space for data while processing. Also, see ViewOverdueNoticesData for more information on where these values are coming from.

Columns

Column name | Data type | Description
ItemRecordID | int | ID of the item.
PatronID | int | ID of the patron this item notice belongs to.
ItemBarcode | nvarchar(20) | Barcode of the item.
DueDate | nvarchar(50) | Date the item was due.
BrowseTitle | nvarchar(255) | Title information gathered from the BibliographicRecord.
BrowseAuthor | nvarchar(255) | Author information gathered from the BibliographicRecord.
ItemCallNumber | nvarchar(255) | Call number of the item.
Price | nvarchar(20) | Price of the item.
Abbreviation | nvarchar(15) | Organization abbreviation of the item's assigned branch.
Name | nvarchar(50) | Organization name of the item's assigned branch.
PhoneNumberOne | nvarchar(20) | Patron's phone number.
LoaningOrganizationID | int | ID of the organization that loaded the item to this patron.
FineCodeID | int | ID of the item's fine code.
LoanUnits | int | Loaning units.


OverdueNotices

Results Database

OverdueNotices Table

Extended information for each overdue item that is displayed in the Crystal Report. This table is needed because items can be located on different servers. Also, see ViewOverdueNoticesData for more information on where these values are coming from.

Columns

Column name | Data type | Description
ItemRecordID | int | ID of the item.
PatronID | int | ID of the patron this item notice belongs to.
ItemBarcode | nvarchar(20) | Barcode of the item.
DueDate | datetime | Date the item was due.
BrowseTitle | nvarchar(255) | Title information gathered from the BibliographicRecord.
BrowseAuthor | nvarchar(255) | Author information gathered from the BibliographicRecord.
ItemCallNumber | nvarchar(370) | Call number of the item.
Price | money | Price of the item.
Abbreviation | nvarchar(15) | Organization abbreviation of the item's assigned branch.
Name | nvarchar(50) | Organization name of the item's assigned branch.
PhoneNumberOne | nvarchar(20) | Patron's phone number.
LoaningOrganizationID | int | ID of the organization that loaded the item to this patron.
FineCodeID | int | ID of the item's fine code.
LoanUnits | int | Loaning units.
BillingNotice | tinyint | States whether or not this item's notice is a billing notice.
ReplacementCost | money | Cost to replace the overdue item.
OverdueCharge | money | Current overdue charge that this item is creating for the patron.
ReportingOrgID | int | ID of the organization from where this notice gets notified.
DeliveryOptionID | int | The type of delivery that this notice will take. The values map to the DeliveryOptions table in the Polaris database.
ReturnAddressOrgID | int | Address ID of the organization which is designated as the Return Address from SA at organization levels.
NotificationTypeID | int | ID of the type of notification that this item needs (ie. 1st Overdues/2nd overdues/3rd overdues/Billing). The values map to the NotificationTypes table in the Polaris database and will be only among 1, 11, 12 and 13.
IncludeClaimedItems | bit | Indicates whether or not this overdue notice includes a list of claimed item records.
ProcessingCharge | money | Processing charge associated with the item for which the notice is being generated
AdminLanguageID | int | ID of the Language that overdue or billing notice is translated to and displayed in. The language ID stored in this column is the MS LanguageID which is 1033 for English, 3082 for Spanish, 3084 for French, etc..
OverdueNoticeID | int | Unique identifier


RouteNotices

Results Database

RouteNotices Table

Extended information for each routed piece that is displayed in the Crystal Report. entries get inserted whenever a routing notification is needed by a patron whose delivery option is set to "mailing". entries get deleted after route notice is printed. application uses the cluster identifier of OrgID, WrkStaID, and UserID to distinguish entries created by different staffs.

Columns

Column name | Data type | Description
OrgID | int | Polaris organization ID of the record creator's branch.
PatronID | int | Polaris patron ID of the staff to whom the piece is routed to.
PieceID | int | routed piece ID.
NotificationText | nvarchar(1024) | SA defined notification text for the branch of the record creator.
DeliveryOption | int | The type of delivery that this notice will take. The values map to the DeliveryOptions table in the Polaris database.
NotificationHeader | nvarchar(255) | A text note appears in the Subject field of an Email notice or the Header field of a Printed notice. This is a SA value defined at all organization levels by the reporting organizations.


SysHoldBindings

Results Database

SysHoldBindings Table

Contains one row for each active/pending hold request. This table is used exclusively by the Circ_ProcessHoldRequestsToFill stored procedure and represents a snapshot of hold requests to fill.

Columns

Column name | Data type | Description
SysHoldRequestID | int | Identifies the hold request to fill (i.e. hold status is either active or pending).
ItemRecordID | int | Identifies the item record that could satisfy the hold request (i.e. item status must be 'In').
AssignedBranchID | int | Identifies the assigned branch of the specified item record.


tempClaimItems

Results Database

tempClaimItems Table

Used by Polaris..ProcessClaimNotices stored procedure as a temporary storage space for data while processing (for performance reasons). Also, see other tables and views related to claims for more information regarding the columns (ie. ClaimNotices, ViewClaimNoticesData, etc).

Columns

Column name | Data type | Description
ItemRecordID | int | ID of the item.
PatronID | int | ID of the patron.
DeliveryOptionID | int | The type of delivery that this notice will take. The values map to the DeliveryOptions table in the Polaris database.
ReportingOrgID | int | ID of the organization sending the notice.
IsAdditionalTxt | bit | Flag indicating if this is an additional txt message.


tempOverDueItems

Results Database

tempOverDueItems Table

This table stores the intermediate results populated by stored procedure ProcessOverdueNotices. The entries in this table will be used by the 2nd step of overdue notice processing.

Columns

Column name | Data type | Description
ItemRecordID | int | Notified item record ID.
PatronID | int | Notified patron ID.
OVDNoticeCount | int | Number of overdue the current notice entry belongs to.
DeliveryOptionID | int | Indicates delivery method the notice needs to be sent by. It maps to values in Polaris.DeliveryOptions table.
Billed | bit | Indicates if the entry is a billing notice entry.
ReportingOrgID | int | Organization ID of the branch from where the notice is sent.
IsAdditionalTxt | bit | Flag indicating if this is an additional txt message.
tempOverDueItemID | int | Unique identifier


tmpCircOfflineUpload

Results Database

tmpCircOfflineUpload Table

Table storing circulation transactions to upload via the automated offline upload processing.

Columns

Column name | Data type | Description
TransactionFileName | nvarchar(255) | Name of the uploaded file.
TransactionTime | datetime | Date of the transaction.
TransactionLogonBranch | int | Logon branch for the transaction.
TransactionLogonPolarisUserID | int | Logon user for the transaction.
TransactionLogonWorkstationID | int | Logon workstation for the transaction.
TransactionVersion | nvarchar(50) | Version of the software when the transaction was created.
RecordCode | int | Code to identify the different types of transactions. 2 = Checkout, 3 = Checkin, 5 = PatronRegistrationCreate, 6 = Inventory, 7 = PatronRegistrationUpdate
PatronBarcode | nvarchar(20) | Barcode of the patron.
LoanUnits | int | Loan units of the item.
LoanPeriod | int | Loan period of the item.
ItemBarcode | nvarchar(20) | Barcode of the item.
Processed | bit | Flag indicating if this record has been processed.


tmpDonations

Results Database

tmpDonations Table

This is a interim table used by hosted credit card payment for donations. This table holds the donation information submitted by the patron when they donate a monetary gift to the library via the PowerPAC. The content in this table is supposed to be transferred to Polaris.Polaris.Donations table when hosted CCP transaction is finished.

Columns

Column name | Data type | Description
ILSStoreOrderID | int | ILS Store Order record ID.
DonationCategoryID | int | Donation category ID.
ReceivingOrgID | int | ID of organization that should receive the donation.
Amount | decimal | Monetary amount of donation.
SendAcknowledgement | bit | Bit signifying an acknowledgement should be sent.
AckName | nvarchar(50) | Acknowledgement name field.
AckAddress | nvarchar(100) | Acknowledgement address field.
AckCity | nvarchar(50) | Acknowledgement city field.
AckStateProvinceID | int | Acknowledgement state field.
AckZip | nvarchar(20) | Acknowledgement zip code field.
AckEmail | nvarchar(50) | Acknowledgement email field.
PurchaseTitle | bit | Text field to store a title name the donation should be used to purchase.
SubjectArea | nvarchar(100) | Text field to store a subject area item the donation should be used to purchase.
Processed | bit | Bit signifying if the library is done "handling" this donation. Used to verify an acknowledgement was sent if required.
ProcessedDate | datetime | Date this donation was processed.
DonationDate | datetime | Date donation was submitted.
DonatingPatronBarcode | nvarchar(20) | Barcode of patron who submitted the donation.


tmpLabels

Results Database

tmpLabels Table

This table stores all the labels user generated from Polaris TechClient or Label Manager. The label data stored is user and label type specific.

Columns

Column name | Data type | Description
UserID | int | ID of Polaris user who creates the label sets.
LabelTypeID | int | ID of label type the data is stored for.
SequenceNumber | int | Label set's sequence number to indicate the sequence of its generation and display order in Label Manager.
Content1 | nvarchar(510) | The content of the first label in a label set.
Content2 | nvarchar(510) | The content of the second label in a label set.
Content3 | nvarchar(510) | The content of the third label in a label set.
tmpLabelID | int | Unique identifier


tmpOfflineUploadLog

Results Database

tmpOfflineUploadLog Table

Log of the files uploaded for processing.

Columns

Column name | Data type | Description
TransactionFileName | nvarchar(255) | Name of the file the transaction came from.
TransactionTime | datetime | Date the transaction was committed.
TransactionBranch | int | Transacting branch.
TransactionPolarisUserID | int | User that committed the transaction.
TransactionWorkstationID | int | Workstation where the transaction was committed.
RecordCode | smallint | Code to identify the different types of transactions. 2 = Checkout, 3 = Checkin, 5 = PatronRegistrationCreate, 6 = Inventory, 7 = PatronRegistrationUpdate
PatronBarcode | nvarchar(20) | Barcode of the patron.
PatronName | nvarchar(100) | Name of the patron.
ItemBarcode | nvarchar(20) | Barcode of the item.
ItemTitle | nvarchar(255) | Title of the item.
ItemCallNumber | nvarchar(255) | Call number of the item.
IsError | bit | Flag indicating if there was an error.
MessageInfo | nvarchar(-1) | Error information.


tmpOverdue

Results Database

tmpOverdue Table

Used by Polaris..GetOverdueNotices stored procedure as a temporary storage space for data while processing (for performance reasons). Also, see other tables and views related to overdues for more information regarding the columns (ie. OverdueItemInfo, OverdueNotices, ViewOverdueNoticesData, etc).

Columns

Column name | Data type | Description
MaterialTypeID | int | ID of the item's material type.
AssignedBranchID | int | ID of the item's organization.
ItemRecordID | int | ID of the item.
ItemBarcode | nvarchar(20) | Barcode of the item.
DueDate | datetime | Date the item was due.
BrowseTitle | nvarchar(255) | Title information gathered from the BibliographicRecord.
BrowseAuthor | nvarchar(255) | Author information gathered from the BibliographicRecord.
ItemCallNumber | nvarchar(255) | Call number of the item.
Price | money | Price of the item.
Name | nvarchar(50) | Organization name of the item's assigned branch.
Abbreviation | nvarchar(15) | Organization abbreviation of the item's assigned branch.
PhoneNumberOne | nvarchar(20) | Patron's phone number.
OVDNoticeCount | int | Total number of notices sent (including this one) for this item.
LoaningOrganizationID | int | ID of the organization that loaded the item to this patron.
PatronID | int | ID of the patron this item notice belongs to.
Barcode | nvarchar(20) | Barcode of the patron.
OrganizationID | int | ID of the patron's organization.
OrgName | nvarchar(50) | Organization name of the patron's branch.
OrgAbbreviation | nvarchar(15) | Organization abbreviation of the patron's branch.
OrgPhoneVoice | nvarchar(20) | Patron organization's voice phone number.
OrgPhoneFAX | nvarchar(15) | Patron organization's fax number.
OrgEmailAddress | nvarchar(64) | Patron organization's email address.
FineCodeID | int | ID of the item's fine code.
LoanUnits | int | Loaning units.
PatronCodeID | int | ID of the patron's code.


tmpPatronOfflineAddresses

Results Database

tmpPatronOfflineAddresses Table

Stores address information for patron create and update transactions

Columns

Column name | Data type | Description
TransactionTime | datetime | Date of the transaction.
PatronBarcode | nvarchar(20) | Barcode of the patron.
FreeTextAddressLabel | nvarchar(30) | Type of address.
AddressType | int | Type of address.
PatronStreetOne | nvarchar(64) | The optional first street address for the patron
PatronStreetTwo | nvarchar(64) | The optional second street address for the patron
PatronCity | nvarchar(32) | City for the address.
PatronState | nvarchar(32) | State for the address.
PostalCode | nvarchar(12) | Postal code.
ZipPlusFour | nvarchar(4) | Extension on the postal code information.
County | nvarchar(32) | Name of the county.
CountryID | int | ID of the country.
PatronStreetThree | nvarchar(64) | The optional third street address for the patron


tmpPatronOfflineUpload

Results Database

tmpPatronOfflineUpload Table

Contains patron information uploaded via offline files.

Columns

Column name | Data type | Description
TransactionFileName | nvarchar(255) | Name of file the patron record was uploaded from.
TransactionTime | datetime | Date of the transaction.
TransactionLogonBranch | int | Logon branch that committed the transaction.
TransactionLogonPolarisUserID | int | User that committed the transaction.
TransactionLogonWorkstationID | int | Workstation where the transaction was committed.
TransactionVersion | nvarchar(50) | Version the transaction was committed in.
RecordCode | int | Code to identify the different types of transactions. 2 = Checkout, 3 = Checkin, 5 = PatronRegistrationCreate, 6 = Inventory, 7 = PatronRegistrationUpdate
CreationDate | datetime | Transaction date.
PatronLastName | nvarchar(32) | Patron's last name.
PatronFirstName | nvarchar(32) | Patron first name.
PatronMiddleName | nvarchar(32) | Patron's middle name.
PatronNameTitle | nvarchar(8) | Patron's title.
PatronNameSuffix | nvarchar(4) | Patron's name suffix.
PatronCodeID | int | Type of patron.
PatronBranchID | int | Organization the patron is registered to.
PatronBarcode | nvarchar(20) | Barcode of the patron.
ExpirationDate | datetime | Date patron record expires.
PatronStatCodeID | int | Patron's statistical class.
PatronPassword | nvarchar(16) | Patrons password
LanguageID | int | ID of patron's language.
RegistrationDate | datetime | Date of registration.
BirthDate | datetime | Date of birth.
Permission | int | Deprecated.
MaintainReadingList | bit | Denotes whether Polaris will track the items that the patron checks out.
FormerID | nvarchar(20) | Patrons previous barcode.
UserDefined1 | nvarchar(64) | User defined field one.
UserDefined2 | nvarchar(64) | User defined field two.
UserDefined3 | nvarchar(64) | User defined field three.
UserDefined4 | nvarchar(64) | User defined field four.
UserDefined5 | nvarchar(64) | User defined field five.
DoNotDelete | bit | Flag to reflect if the patron record should be protected from deletion.
ExcludeFromBills | bit | Flag to exclude patron from billing notices.
ExcludeFromColleciton | bit | Flag to exclude patron from collections.
ExcludeFromHolds | bit | Flag to exclude patron from hold notices.
ExcludefromOverdue | bit | Flag to exclude patron from overdue notices.
PlainTextNotification | bit | Flag to receive notifications in plain text or html.
AddressCheckDate | datetime | Date to validate address information.
EmailAddress | nvarchar(64) | Primary email address.
AlternateEmailAddress | nvarchar(64) | Secondary email address.
Phone1 | nvarchar(20) | Patron's first phone number.
Phone1CarrierID | int | Carrier for patron's first phone number.
Phone2 | nvarchar(20) | Patron's second phone number.
Phone2CarrierID | int | Carrier for patron's second phone number.
Phone3 | nvarchar(20) | Patron's third phone number.
Phone3CarrierID | int | Carrier for patron's third phone number.
FaxNumber | nvarchar(20) | Fax number.
DeliveryOptionID | int | Preferred method to receive notices.
PatronRecordID | int | ID of patron record.
SMSEnabled | bit | Indicates whether or not an additional TXT message notice will be sent along with a primary notice.
eReceiptOptionID | int | Preferred method to receive eReceipts.
txtPhoneNumber | int | Phone number to send SMS notifications to.
ExcludeFromAlmostOverdueAutoRenew | bit | Flag to exclude patron from almost overdue/auto renewal notices.
ExcludeFromPatronRecExpir | bit | Exclude patron from patron expired notices.
ExcludeFromInactivePatron | bit | Flag to exclude patron from inactive patron notices.
Processed | bit | Flag representing if this record has been processed already.
PasswordHash | nvarchar(256) | Hashed value for password.
ObfuscatedPassword | nvarchar(256) | Encrypted password
GenderID | int | Unique identifier from the Genders table
LegalNameLast | nvarchar(32) | The optional last name on legal identification
LegalNameFirst | nvarchar(32) | The optional first name on legal identification
LegalNameMiddle | nvarchar(32) | The optional middle name on legal identification
UseLegalNameOnNotices | bit | The flag to signify that the legal name data should be used on print and phone notices